No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Typical Configuration Examples

CloudEngine 12800, 12800E, 8800, 7800, 6800, and 5800 Series Switches

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Using MSTP to Replace or Interoperate with Cisco PVST+

Using MSTP to Replace or Interoperate with Cisco PVST+

Introduction to Cisco Spanning Tree Protocols

Cisco switches support the following spanning tree protocols: Per-VLAN Spanning Tree (PVST), Per-VLAN Spanning Tree Plus (PVST+), Rapid PVST+, Multiple Instance Spanning Tree Protocol (MISTP), and Multiple Spanning Tree (MST). Cisco Catalyst series switches running IOS 12.2 or a later version support PVST+, Rapid PVST+, and MST. Some bridge protocol data units (BPDUs) of these spanning tree protocols use Cisco proprietary BPDU formats, which differ from that defined by IEEE.

  • PVST can be considered a common STP running in each VLAN. The status and calculation of STP are independent in each VLAN. Although PVST does not define instances like the Multiple Spanning Tree Protocol (MSTP), PVST can load balance traffic from different VLANs. This is because PVST BPDUs carry VLAN information. The destination MAC address of PVST BPDUs is 01-00-0C-CC-CC-CD; therefore, PVST cannot interoperate with standard IEEE spanning tree protocols.

  • PVST+ is an improvement on PVST. Just like PVST, PVST+ alone does not support fast convergence, but it can work with the PortFast, UplinkFast, or BackboneFast feature to implement fast convergence. PVST+ is an improvement on PVST in that it achieves interoperability with standard spanning tree protocols. It achieves such interoperability by sending standard STP BPDUs with the destination MAC address of 01-80-C2-00-00-00 on access interfaces. On a trunk interface, it also sends these standard STP BPDUs, but only in VLAN 1. In other VLANs allowed by the trunk interface, it sends Cisco proprietary BPDUs with the destination MAC address of 01-00-0C-CC-CC-CD.

  • Rapid PVST+ is an improvement on PVST+. In contrast to PVST+, Rapid PVST+ uses the Rapid Spanning Tree Protocol (RSTP) mechanism to implement rapid convergence.

  • Cisco MST supports VLAN-instance mapping and defines the concept of region; therefore, it can be considered as a standard MSTP protocol. MST BPDUs use the standard format defined by IEEE. Huawei and Cisco switches use different keys to generate MSTP digests in BPDUs. By default, MSTP and Cisco MST can implement only inter-region interoperation because Huawei and Cisco switches generate different digests. To enable MSTP and Cisco MST to interoperate within an MSTP region, enable the digest snooping function on the Huawei switch and the Huawei switch's interface connected to a Cisco switch.

Using MSTP to Replace or Interoperate with Cisco PVST+

PVST+ is a Cisco proprietary protocol and cannot directly work with protocols on Huawei switches. You can use MSTP or RSTP to implement interoperability with PVST+. The following provides three solutions for using MSTP to replace or interoperate with PVST+.

  • Solution 1: Huawei MSTP device acts as the root bridge to interoperate with Cisco PVST+ device

    Set an appropriate bridge priority for VLAN 1 to ensure that the root bridge of VLAN 1 is located on the Huawei MSTP device and the blocked port is located on the Cisco PVST+ switch. As shown in Figure 4-4, trunk ports of Cisco PVST+ switches send standard RSTP BPDUs only in VLAN 1, so the common spanning tree (CST) mapping VLAN 1 of MSTP or RSTP can communicate with the spanning tree that corresponds to VLAN 1 of Cisco PVST+ (blue line). After a port on a Huawei switch receives PVST+ BPDUs from a VLAN other than VLAN 1, the switch broadcasts the PVST+ BPDUs to all the other ports. Upon receiving the PVST+ BPDUs, Cisco PVST+ switches block the receiving ports (orange line). Because blocked ports for the VLANs are different, traffic can still be load balanced in the VLANs.

    Figure 4-4 Huawei MSTP device used as the root bridge
  • Solution 2: Huawei MSTP device interoperates with Cisco PVST+ device acting as the root bridge

    Set spanning tree priorities for all Cisco PVST+ VLANs to ensure that the root bridge is located on a Cisco PVST+ switch and the blocked ports are located on the Huawei MSTP device. The Huawei MSTP device maintains the same forwarding state as all the instances; therefore, Huawei switches block service packets and Cisco PVST+ BPDUs from VLANs other than VLAN 1. This means that Cisco PVST+ switches do not receive broadcast Cisco PVST+ BPDUs and can forward service packets as normal from these VLANs. Figure 4-5 shows the root bridge on a Cisco PVST+ switch and blocked ports on Huawei switches.

    Figure 4-5 Cisco PVST+ device used as the root bridge
  • Solution 3: Huawei switch is dual-homed to Cisco PVST switches through Smart Link

    Cisco switches running PVST function as aggregation switches, and a Huawei switch functions as the access switch and is dual-homed to the Cisco switches. This is a common interoperation scenario where Smart Link can be used, as shown in Figure 4-6.

    Figure 4-6 Huawei switch is dual-homed to Cisco PVST switches through Smart Link
What are the differences between these solutions and how can an appropriate solution be selected?
Table 4-2 Using MSTP to replace or interoperate with Cisco PVST+

Solution

Convergence Time

Load Balancing

Solution 1: Huawei MSTP device acts as the root bridge to interoperate with Cisco PVST+ device

About 30 seconds

Yes

Solution 2: Huawei MSTP device interoperates with Cisco PVST+ device acting as the root bridge

Several seconds

No

Solution 3: Huawei switch is dual-homed to Cisco PVST switches through Smart Link

Under 1 second

Yes

Follow these suggestions to select a solution:
  • If Smart Link is used in dual-homing networking, select solution 3.
  • If Smart Link cannot be implemented in dual-homing networking:
    • If load balancing is required, select solution 1.
    • If fast convergence is required or the Cisco device used as the root bridge cannot be changed, select solution 2.

Typical Networking

The following provides typical cases.

NOTE:

The following interface names on Cisco devices are just used as examples and may be different from the actual interface names.

Case 1: Huawei MSTP device used as the root bridge interoperates with Cisco PVST+ device

  1. Networking
    Figure 4-7 Huawei MSTP device used as the root bridge interoperates with Cisco PVST+ device
  2. Configuration requirements

    A Huawei device runs MSTP or RSTP and load balancing is required. The Huawei device must be configured as the root bridge. When the Huawei device runs MSTP, the interface on the Huawei device automatically switches to the RSTP mode to interoperate with the Cisco PVST+ device. As shown in Figure 4-7, a Huawei device runs MSTP and connects to ports G1/0/1 and G1/0/2 on a Cisco device. These ports automatically switch to the RSTP mode. The blocked port of VLAN 1 is G1/0/2 on the Cisco device, and the blocked port of VLAN 30 is G1/0/1 on the Cisco device.

  3. Configuration precautions
    • Cisco device: Configure the same path cost algorithm on all Cisco switches. Set an appropriate spanning tree priority for VLAN 1 to ensure that it is lower than the spanning tree priority of Huawei CST, and set spanning tree priorities for other VLANs based on the site requirements.
    • Huawei device: Configure the same path cost algorithm on all Huawei switches. Ensure that the bridge priority of Huawei CST is higher than that of Cisco VLAN 1.
    NOTE:
    • Ensure that spanning trees in all VLANs use a Huawei switch as the root bridge.
    • Configure Huawei switches to work in MSTP or RSTP mode, and do not use the STP mode.
    • Cisco native VLAN traffic is untagged, so the PVID on Huawei switches must be the same as the native VLAN ID on Cisco switches.
  4. Configuration file summary
    • Cisco device:
      spanning-tree mode rapid-pvst                                                      
      spanning-tree logging                                                           
      spanning-tree extend system-id 
      spanning-tree vlan 1 priority 4096
      spanning-tree pathcost method long
      !                                                                               
      interface GigabitEthernet1/0/1                                                  
       switchport trunk encapsulation dot1q                                           
       switchport trunk allowed vlan 1,30                                               
       switchport mode trunk                                                             
      end  
      !                                                                               
      interface GigabitEthernet1/0/2                                                  
       switchport trunk encapsulation dot1q                                           
       switchport trunk allowed vlan 1,30                                               
       switchport mode trunk                                        
       spanning-tree vlan 30 port-priority 48                                      
      end
    • Huawei device:
      #
      stp root primary
      #
      interface  GE1/0/1
       port link-type trunk
       port trunk allow-pass vlan 30
      #
      interface  GE1/0/2
       port link-type trunk
       port trunk allow-pass vlan 30
      #

Case 2: The Huawei MSTP device interoperates with the Cisco PVST+ device used as the root bridge

  1. Networking
    Figure 4-8 Huawei MSTP device interoperates with the Cisco PVST+ device used as the root bridge
  2. Configuration requirements

    The Huawei device runs MSTP or RSTP and load balancing is not required. The Cisco PVST+ device can be configured as the root bridge. When the Huawei device runs MSTP, the interface on the Huawei device automatically switches to the RSTP mode to interoperate with the Cisco PVST+ device. As shown in Figure 4-8, the Huawei device runs MSTP and connects to the Cisco device through G1/0/1 and G1/0/2, which automatically switch to the RSTP mode. The blocked port of VLAN 1 is G1/0/1 on the Huawei device. Service packets of VLAN 30 are also blocked, and therefore the Cisco PVST+ BPDUs cannot be broadcast in VLAN 30. As a result, both the two Cisco PVST+ ports (G1/0/1 and G1/0/2) connected to the Huawei device in VLAN 30 become designated ports. Fast convergence cannot be implemented in VLAN 30 because G1/0/2 on the Huawei device cannot receive packets from VLAN 30.

  3. Configuration precautions
    • Cisco device: Configure the same path cost algorithm on all Cisco switches, and ensure that the bridge priority of Cisco VLAN 1 is higher than that of Huawei CST.
    • Huawei device: Configure the same path cost algorithm on all Huawei switches, and ensure that the bridge priority of Huawei CST is lower than that of Cisco VLAN 1.
  4. Configuration file summary
    • Cisco device:
      spanning-tree mode rapid-pvst
      spanning-tree logging                                                           
      spanning-tree extend system-id 
      spanning-tree vlan 1 priority 0
      spanning-tree pathcost method long
      !                                                                               
      interface GigabitEthernet1/0/1                                                  
       switchport trunk encapsulation dot1q                                           
       switchport trunk allowed vlan 1,30                                               
       switchport mode trunk                                         
      end  
      !                                                                               
      interface GigabitEthernet1/0/2                                                  
       switchport trunk encapsulation dot1q                                           
       switchport trunk allowed vlan 1,30                                               
       switchport mode trunk                                        
      end
    • Huawei device:
      #
      interface  GE1/0/1
       port link-type trunk
       port trunk allow-pass vlan 30
       stp instance 0 cost 30000
      #
      interface  GE1/0/2
       port link-type trunk
       port trunk allow-pass vlan 30
      #

Case 3: The Huawei switch is dual-homed to Cisco PVST switches through Smart Link

  1. Networking
    Figure 4-9 Huawei switch is dual-homed to Cisco PVST switches through Smart Link
  2. Configuration requirements

    The Huawei switch is configured with Smart Link and is dual-homed to two Cisco aggregation switches through 10GE1/0/1 and 10GE1/0/2. Load balancing needs to be implemented. Normally, traffic in VLAN 100 is forwarded through 10GE1/0/1, and traffic in VLAN 200 is forwarded through 10GE1/0/2.

  3. Configuration precautions
    • Cisco device: No special configuration is required on the Cisco switch interfaces connected to the Huawei switch. You only need to add interfaces to VLAN 100 and VLAN 200, regardless of whether PVST is enabled on Cisco switch interfaces.
    • Huawei device: Add interfaces connected to Cisco switches to the corresponding Cisco PVST VLANs. The interfaces do not participate in STP calculation.
  4. Configuration file summary
    • Cisco device:

      The configuration file is not provided here.

    • Huawei device:
      #
      stp region-configuration
       instance 1 vlan 100
       instance 2 vlan 200
      #
      interface 10GE1/0/1
       port link-type trunk
       undo port trunk allow-pass vlan 1
       port trunk allow-pass vlan 100 200
       stp disable
      #
      interface 10GE1/0/2
       port link-type trunk
       undo port trunk allow-pass vlan 1
       port trunk allow-pass vlan 100 200
       stp disable
      #
      smart-link group 1
       load-balance instance 2 slave
       restore enable
       smart-link enable
       port 10GE1/0/1 master
       port 10GE1/0/2 slave
       timer wtr 30
      #
Download
Updated: 2019-04-03

Document ID: EDOC1000039339

Views: 114657

Downloads: 7519

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next