No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Typical Configuration Examples

CloudEngine 12800, 12800E, 8800, 7800, 6800, and 5800 Series Switches

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuring Multi-level M-LAG Interconnection

Configuring Multi-level M-LAG Interconnection

Networking Requirements

The customer wants to build a stable large Layer 2 network so that a large number of servers can be deployed. The requirements are as follows:
  • The dual-homing mode is used to ensure reliability.
  • The load balancing mode is used to improve the link use efficiency.

As shown in Figure 2-29, multi-level M-LAG interconnection ensures reliability, improves the link use efficiency, and expands the network scale in dual-homing mode, meeting customer requirements. Aggregation devices function as active-active gateways, and core and aggregation devices are connected in a crossover manner to ensure device-level reliability.

In this example, SwitchA, SwitchB, SwitchC, and SwitchD are CE8800&7800&6800&5800 series switches, and SwitchE, SwitchF, SwitchG, and SwitchH are CE12800 series switches. The CE12804 (modular switch) and CE6850EI (fixed switch) are used as examples.

Figure 2-29 Networking for configuring multi-level M-LAG interconnection
Table 2-5 Data preparation

Device Name

Interface

IP Address

Virtual IP Address

SwitchC

Management interface

10.1.1.1/24

-

SwitchD

Management interface

10.1.1.2/24

-

SwitchE

Management interface

10.2.1.1/24

-

VLANIF11

10.3.1.1/24

10.3.1.111

10GE1/0/5

10.4.1.1/24

-

10GE1/0/6

10.5.1.1/24

-

SwitchF

Management interface

10.2.1.2/24

-

VLANIF11

10.3.1.2/24

10.3.1.111

10GE1/0/5

10.6.1.1/24

-

10GE1/0/6

10.7.1.1/24

-

SwitchG

10GE1/0/1

10.4.1.2/24

-

10GE1/0/2

10.7.1.2/24

-

SwitchH

10GE1/0/1

10.6.1.2/24

-

10GE1/0/2

10.5.1.2/24

-

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchA and SwitchB to form a stack to ensure high reliability of server access.

  2. Add the link connecting Server 1 and the stack to the inter-chassis Eth-Trunk to improve the link bandwidth and reliability.

  3. Configure the V-STP, DFS group, peer-link, and M-LAG on SwitchC, SwitchD, SwitchE, and SwitchF.

  4. Create VLANIF interfaces on SwitchG and SwitchH and configure IP addresses for the VLANIF interfaces, and create VRRP groups on the VLANIF interfaces to implement gateway backup.

  5. Enable OSPF on SwitchE, SwitchF, SwitchG, and SwitchH to implement Layer 3 connectivity.

NOTE:

Perform the configuration in sequence strictly; configure the devices that constitute the M-LAG one by one; and ensure that the LACP mode is used.

Procedure

  1. Configure SwitchA and SwitchB to form a stack. For details, see Stack Configuration in Configuration Guide - Virtualization Configuration.
  2. Create an Eth-Trunk in the stack, add the Eth-Trunk to VLAN 11, and configure the Eth-Trunk to preferentially forward local traffic in the stack.

    The uplink interface of the server connected to the stack needs to be bound to an aggregation link, and the link aggregation modes on the server and stack must be consistent.

    <HUAWEI> system-view
    [~HUAWEI] sysname iStack
    [*HUAWEI] commit
    [~iStack] vlan batch 11
    [*iStack] interface eth-trunk 10
    [*iStack-Eth-Trunk10] mode lacp-dynamic
    [*iStack-Eth-Trunk10] port link-type access
    [*iStack-Eth-Trunk10] port default vlan 11
    [*iStack-Eth-Trunk10] trunkport 10ge 1/0/3
    [*iStack-Eth-Trunk10] trunkport 10ge 2/0/3
    [*iStack-Eth-Trunk10] undo local-preference disable
    [*iStack-Eth-Trunk10] quit
    [*iStack] interface eth-trunk 20
    [*iStack-Eth-Trunk20] mode lacp-static
    [*iStack-Eth-Trunk20] port link-type trunk
    [*iStack-Eth-Trunk20] port trunk allow-pass vlan 11
    [*iStack-Eth-Trunk20] trunkport 10ge 1/0/1
    [*iStack-Eth-Trunk20] trunkport 10ge 1/0/2
    [*iStack-Eth-Trunk20] trunkport 10ge 2/0/1
    [*iStack-Eth-Trunk20] trunkport 10ge 2/0/2
    [*iStack-Eth-Trunk20] quit
    [*iStack] commit

  3. Configure the V-STP, DFS group, peer-link, and M-LAG on SwitchC, SwitchD, SwitchE, and SwitchF.

    # Configure SwitchC.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchC
    [*HUAWEI] commit
    [~SwitchC] stp mode rstp
    [*SwitchC] stp v-stp enable
    [*SwitchC] interface meth 0/0/0
    [*SwitchC-MEth0/0/0] ip address 10.1.1.1 24
    [*SwitchC-MEth0/0/0] quit
    [*SwitchC] dfs-group 1
    [*SwitchC-dfs-group-1] source ip 10.1.1.1
    [*SwitchC-dfs-group-1] priority 150
    [*SwitchC-dfs-group-1] quit
    [*SwitchC] interface eth-trunk 0
    [*SwitchC-Eth-Trunk0] trunkport 10ge 1/0/3
    [*SwitchC-Eth-Trunk0] trunkport 10ge 1/0/4
    [*SwitchC-Eth-Trunk0] mode lacp-static
    [*SwitchC-Eth-Trunk0] peer-link 1
    [*SwitchC-Eth-Trunk0] quit
    [*SwitchC] vlan batch 11
    [*SwitchC] interface eth-trunk 20
    [*SwitchC-Eth-Trunk20] mode lacp-static
    [*SwitchC-Eth-Trunk20] port link-type trunk
    [*SwitchC-Eth-Trunk20] port trunk allow-pass vlan 11
    [*SwitchC-Eth-Trunk20] trunkport 10ge 1/0/1 to 1/0/2
    [*SwitchC-Eth-Trunk20] dfs-group 1 m-lag 1
    [*SwitchC-Eth-Trunk20] quit
    [*SwitchC] interface eth-trunk 30
    [*SwitchC-Eth-Trunk30] mode lacp-static
    [*SwitchC-Eth-Trunk30] port link-type trunk
    [*SwitchC-Eth-Trunk30] port trunk allow-pass vlan 11
    [*SwitchC-Eth-Trunk30] trunkport 10ge 1/0/5 to 1/0/6
    [*SwitchC-Eth-Trunk30] dfs-group 1 m-lag 2
    [*SwitchC-Eth-Trunk30] quit
    [*SwitchC] commit

    # Configure SwitchD.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchD
    [*HUAWEI] commit
    [~SwitchD] stp mode rstp
    [*SwitchD] stp v-stp enable
    [*SwitchD] interface meth 0/0/0
    [*SwitchD-MEth0/0/0] ip address 10.1.1.2 24
    [*SwitchD-MEth0/0/0] quit
    [*SwitchD] dfs-group 1
    [*SwitchD-dfs-group-1] source ip 10.1.1.2
    [*SwitchD-dfs-group-1] priority 120
    [*SwitchD-dfs-group-1] quit
    [*SwitchD] interface eth-trunk 0
    [*SwitchD-Eth-Trunk0] trunkport 10ge 1/0/3
    [*SwitchD-Eth-Trunk0] trunkport 10ge 1/0/4
    [*SwitchD-Eth-Trunk0] mode lacp-static
    [*SwitchD-Eth-Trunk0] peer-link 1
    [*SwitchD-Eth-Trunk0] quit
    [*SwitchD] vlan batch 11
    [*SwitchD] interface eth-trunk 20
    [*SwitchD-Eth-Trunk20] mode lacp-static
    [*SwitchD-Eth-Trunk20] port link-type trunk
    [*SwitchD-Eth-Trunk20] port trunk allow-pass vlan 11
    [*SwitchD-Eth-Trunk20] trunkport 10ge 1/0/1 to 1/0/2
    [*SwitchD-Eth-Trunk20] dfs-group 1 m-lag 1
    [*SwitchD-Eth-Trunk20] quit
    [*SwitchD] interface eth-trunk 30
    [*SwitchD-Eth-Trunk30] mode lacp-static
    [*SwitchD-Eth-Trunk30] port link-type trunk
    [*SwitchD-Eth-Trunk30] port trunk allow-pass vlan 11
    [*SwitchD-Eth-Trunk30] trunkport 10ge 1/0/5 to 1/0/6
    [*SwitchD-Eth-Trunk30] dfs-group 1 m-lag 2
    [*SwitchD-Eth-Trunk30] quit
    [*SwitchD] commit

    # Configure SwitchE.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchE
    [*HUAWEI] commit
    [~SwitchE] stp mode rstp
    [*SwitchE] stp v-stp enable
    [*SwitchE] interface meth 0/0/0
    [*SwitchE-MEth0/0/0] ip address 10.2.1.1 24
    [*SwitchE-MEth0/0/0] quit
    [*SwitchE] dfs-group 1
    [*SwitchE-dfs-group-1] source ip 10.2.1.1
    [*SwitchE-dfs-group-1] priority 150
    [*SwitchE-dfs-group-1] quit
    [*SwitchE] interface eth-trunk 0
    [*SwitchE-Eth-Trunk0] trunkport 10ge 1/0/3
    [*SwitchE-Eth-Trunk0] trunkport 10ge 1/0/4
    [*SwitchE-Eth-Trunk0] mode lacp-static
    [*SwitchE-Eth-Trunk0] peer-link 1
    [*SwitchE-Eth-Trunk0] quit
    [*SwitchE] vlan batch 11
    [*SwitchE] interface eth-trunk 40
    [*SwitchE-Eth-Trunk40] mode lacp-static
    [*SwitchE-Eth-Trunk40] port link-type trunk
    [*SwitchE-Eth-Trunk40] port trunk allow-pass vlan 11
    [*SwitchE-Eth-Trunk40] trunkport 10ge 1/0/1 to 1/0/2
    [*SwitchE-Eth-Trunk40] dfs-group 1 m-lag 1
    [*SwitchE-Eth-Trunk40] quit
    [*SwitchE] commit
    
    
    
    

    # Configure SwitchF.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchF
    [*HUAWEI] commit
    [~SwitchF] stp mode rstp
    [*SwitchF] stp v-stp enable
    [*SwitchF] interface meth 0/0/0
    [*SwitchF-MEth0/0/0] ip address 10.2.1.2 24
    [*SwitchF-MEth0/0/0] quit
    [*SwitchF] dfs-group 1
    [*SwitchF-dfs-group-1] source ip 10.2.1.2
    [*SwitchF-dfs-group-1] priority 120
    [*SwitchF-dfs-group-1] quit
    [*SwitchF] interface eth-trunk 0
    [*SwitchF-Eth-Trunk0] trunkport 10ge 1/0/3
    [*SwitchF-Eth-Trunk0] trunkport 10ge 1/0/4
    [*SwitchF-Eth-Trunk0] mode lacp-static
    [*SwitchF-Eth-Trunk0] peer-link 1
    [*SwitchF-Eth-Trunk0] quit
    [*SwitchF] vlan batch 11
    [*SwitchF] interface eth-trunk 40
    [*SwitchF-Eth-Trunk40] mode lacp-static
    [*SwitchF-Eth-Trunk40] port link-type trunk
    [*SwitchF-Eth-Trunk40] port trunk allow-pass vlan 11
    [*SwitchF-Eth-Trunk40] trunkport 10ge 1/0/1 to 1/0/2
    [*SwitchF-Eth-Trunk40] dfs-group 1 m-lag 1
    [*SwitchF-Eth-Trunk40] quit
    [*SwitchF] commit

  4. Create VLANIF interfaces on SwitchE and SwitchF and configure IP addresses for the VLANIF interfaces, and create VRRP groups on the VLANIF interfaces.

    # Configure SwitchE.

    [~SwitchE] interface vlanif 11
    [*SwitchE-Vlanif11] ip address 10.3.1.1 24
    [*SwitchE-Vlanif11] vrrp vrid 1 virtual-ip 10.3.1.111
    [*SwitchE-Vlanif11] quit
    [*SwitchE] commit

    # Configure SwitchF.

    [~SwitchF] interface vlanif 11
    [*SwitchF-Vlanif11] ip address 10.3.1.2 24
    [*SwitchF-Vlanif11] vrrp vrid 1 virtual-ip 10.3.1.111
    [*SwitchF-Vlanif11] quit
    [*SwitchF] commit

  5. Enable OSPF on SwitchE, SwitchF, SwitchG, and SwitchH.

    # Configure SwitchE.
    [~SwitchE] interface 10ge 1/0/5
    [*SwitchE-10GE1/0/5] undo portswitch
    [*SwitchE-10GE1/0/5] ip address 10.4.1.1 24
    [*SwitchE-10GE1/0/5] quit
    [*SwitchE] interface 10ge 1/0/6
    [*SwitchE-10GE1/0/6] undo portswitch
    [*SwitchE-10GE1/0/6] ip address 10.5.1.1 24
    [*SwitchE-10GE1/0/6] quit
    [*SwitchE] ospf 1
    [*SwitchE-ospf-1] area 0
    [*SwitchE-ospf-1-area-0.0.0.0] network 10.3.1.0 0.0.0.255
    [*SwitchE-ospf-1-area-0.0.0.0] network 10.4.1.0 0.0.0.255
    [*SwitchE-ospf-1-area-0.0.0.0] network 10.5.1.0 0.0.0.255
    [*SwitchE-ospf-1-area-0.0.0.0] quit
    [*SwitchE-ospf-1] quit
    [*SwitchE] commit
    # Configure SwitchF.
    [~SwitchF] interface 10ge 1/0/5
    [*SwitchF-10GE1/0/5] undo portswitch
    [*SwitchF-10GE1/0/5] ip address 10.6.1.1 24
    [*SwitchF-10GE1/0/5] quit
    [*SwitchF] interface 10ge 1/0/6
    [*SwitchF-10GE1/0/6] undo portswitch
    [*SwitchF-10GE1/0/6] ip address 10.7.1.1 24
    [*SwitchF-10GE1/0/6] quit
    [*SwitchF] ospf 1
    [*SwitchF-ospf-1] area 0
    [*SwitchF-ospf-1-area-0.0.0.0] network 10.3.1.0 0.0.0.255
    [*SwitchF-ospf-1-area-0.0.0.0] network 10.6.1.0 0.0.0.255
    [*SwitchF-ospf-1-area-0.0.0.0] network 10.7.1.0 0.0.0.255
    [*SwitchF-ospf-1-area-0.0.0.0] quit
    [*SwitchF-ospf-1] quit
    [*SwitchF] commit

    # Configure SwitchG.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchG
    [*HUAWEI] commit
    [~SwitchG] interface 10ge 1/0/1
    [*SwitchG-10GE1/0/1] undo portswitch
    [*SwitchG-10GE1/0/1] ip address 10.4.1.2 24
    [*SwitchG-10GE1/0/1] quit
    [*SwitchG] interface 10ge 1/0/2
    [*SwitchG-10GE1/0/2] undo portswitch
    [*SwitchG-10GE1/0/2] ip address 10.7.1.2 24
    [*SwitchG-10GE1/0/2] quit
    [*SwitchG] ospf 1
    [*SwitchG-ospf-1] area 0
    [*SwitchG-ospf-1-area-0.0.0.0] network 10.4.1.0 0.0.0.255
    [*SwitchG-ospf-1-area-0.0.0.0] network 10.7.1.0 0.0.0.255
    [*SwitchG-ospf-1-area-0.0.0.0] quit
    [*SwitchG-ospf-1] quit
    [*SwitchG] commit

    # Configure SwitchH.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchH
    [*HUAWEI] commit
    [~SwitchH] interface 10ge 1/0/1
    [*SwitchH-10GE1/0/1] undo portswitch
    [*SwitchH-10GE1/0/1] ip address 10.6.1.2 24
    [*SwitchH-10GE1/0/1] quit
    [*SwitchH] interface 10ge 1/0/2
    [*SwitchH-10GE1/0/2] undo portswitch
    [*SwitchH-10GE1/0/2] ip address 10.5.1.2 24
    [*SwitchH-10GE1/0/2] quit
    [*SwitchH] ospf 1
    [*SwitchH-ospf-1] area 0
    [*SwitchH-ospf-1-area-0.0.0.0] network 10.5.1.0 0.0.0.255
    [*SwitchH-ospf-1-area-0.0.0.0] network 10.6.1.0 0.0.0.255
    [*SwitchH-ospf-1-area-0.0.0.0] quit
    [*SwitchH-ospf-1] quit
    [*SwitchH] commit

  6. Verify the configuration.

    • Run the display dfs-group command to check M-LAG information.

      # Check DFS group information.

      [~SwitchC] display dfs-group 1 m-lag
      *                : Local node
      Heart beat state : OK
      Node 1 *
        Dfs-Group ID   : 1
        Priority       : 150
        Address        : ip address 10.1.1.1
        State          : Master
        Causation      : -
        System ID      : 0025-9e95-7c31
        SysName        : SwitchC
        Version        : V100R006C00
        Device Type    : CE6850EI
      Node 2
        Dfs-Group ID   : 1
        Priority       : 120
        Address        : ip address 10.1.1.2
        State          : Backup
        Causation      : -
        System ID      : 0025-9e95-7c11
        SysName        : SwitchD
        Version        : V100R006C00
        Device Type    : CE6850EI
      [~SwitchE] display dfs-group 1 m-lag
      *                : Local node
      Heart beat state : OK
      Node 1 *
        Dfs-Group ID   : 1
        Priority       : 150
        Address        : ip address 10.2.1.1
        State          : Master
        Causation      : -
        System ID      : 0025-9e95-7c41
        SysName        : SwitchE
        Version        : V100R006C00
        Device Type    : CE12800
      Node 2
        Dfs-Group ID   : 1
        Priority       : 120
        Address        : ip address 10.2.1.2
        State          : Backup
        Causation      : -
        System ID      : 0025-9e95-7c21
        SysName        : SwitchF
        Version        : V100R006C00
        Device Type    : CE12800

      # Check M-LAG information on SwitchC.

      [~SwitchC] display dfs-group 1 node 1 m-lag brief
      * - Local node
      
      M-Lag ID     Interface      Port State    Status
             1     Eth-Trunk 20   Up            active(*)-active
             2     Eth-Trunk 30   Up            active(*)-active

      # Check M-LAG information on SwitchE.

      [~SwitchE] display dfs-group 1 node 2 m-lag brief
      * - Local node
      
      M-Lag ID     Interface      Port State    Status
             1     Eth-Trunk 40   Up            active-active(*)

      In the preceding information, the value of Heart beat state is OK, indicating that the heartbeat is normal. SwitchC and SwitchE are used as Node 1, its priority is 150, and the value of State is Master. SwitchD and SwitchF are used as Node 2, the priority is 120, and the value of State is Backup. The value of Causation is -, the values of Port State of Node 1 and Node 2 are both Up, and the M-LAG status of both Node 1 and Node 2 is active, indicating that the M-LAG configuration is correct.

    • Run the display vrrp command on SwitchG and SwitchH. You can see that SwitchG and SwitchH are in Master state.

      [~SwitchG] display vrrp verbose
      Vlanif11 | Virtual Router 1
      State        : Master
      Virtual IP     : 10.3.1.111
      Master IP      : 10.3.1.1
      PriorityRun    : 100
      PriorityConfig : 100
      MasterPriority : 100
      Preempt        : YES   Delay Time : 0s   Remain : --
      TimerRun       : 1s
      TimerConfig    : 1s
      Auth Type      : NONE
      Virtual MAC    : 0000-5e00-0101
      Check TTL      : YES
      Config Type    : Normal
      Create Time       : 2015-03-20 11:39:18
      Last Change Time  : 2015-03-25 11:38:58 
      [~SwitchH] display vrrp verbose
      Vlanif11 | Virtual Router 1
      State        : Master
      Virtual IP     : 10.3.1.111
      Master IP      : 10.3.1.1
      PriorityRun    : 100
      PriorityConfig : 100
      MasterPriority : 120
      Preempt        : YES   Delay Time : 0s   Remain : --
      TimerRun       : 1s
      TimerConfig    : 1s
      Auth Type      : NONE
      Virtual MAC    : 0000-5e00-0101
      Check TTL      : YES
      Config Type    : Normal
      Create Time      : 2015-03-20 11:39:18
      Last Change Time : 2015-03-25 11:38:58 

Configuration Files

  • Stack configuration file

    #
    sysname iStack
    #
    vlan batch 11
    #
    stack
     #
     stack member 1 domain 10
     stack member 1 priority 150
     #
     stack member 2 domain 10
    #
    interface Stack-Port1/1
    #
    interface Stack-Port2/1
    #
    interface Eth-Trunk10
     port default vlan 11
     mode lacp-dynamic
    #
    interface Eth-Trunk20
     port link-type trunk
     port trunk allow-pass vlan 11
     mode lacp-static
    #
    interface 10GE1/0/1
     eth-trunk 20
    #
    interface 10GE1/0/2
     eth-trunk 20
    #
    interface 10GE1/0/3
     eth-trunk 10
    #
    interface 40GE1/0/1
     port mode stack
     stack-port 1/1
    #
    interface 40GE1/0/2
     port mode stack
     stack-port 1/1
    #
    interface 10GE2/0/1
     eth-trunk 20
    #
    interface 10GE2/0/2
     eth-trunk 20
    #
    interface 10GE2/0/3
     eth-trunk 10
    #
    interface 40GE2/0/1
     port mode stack
     stack-port 2/1
    #
    interface 40GE2/0/2
     port mode stack
     stack-port 2/1
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    dfs-group 1
     priority 150
     source ip 10.1.1.1
    #
    vlan batch 11
    #
    stp v-stp enable
    stp mode rstp
    #
    interface MEth0/0/0
     ip address 10.1.1.1 255.255.255.0
    #
    interface Eth-Trunk0
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk20
     port link-type trunk
     port trunk allow-pass vlan 11
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk30
     port link-type trunk
     port trunk allow-pass vlan 11
     mode lacp-static
     dfs-group 1 m-lag 2
    #
    interface 10GE1/0/1
     eth-trunk 20
    #
    interface 10GE1/0/2
     eth-trunk 20
    #
    interface 10GE1/0/3
     eth-trunk 0
    #
    interface 10GE1/0/4
     eth-trunk 0
    #
    interface 10GE1/0/5
     eth-trunk 30
    #
    interface 10GE1/0/6
     eth-trunk 30
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    dfs-group 1
     priority 120
     source ip 10.1.1.2
    #
    vlan batch 11
    #
    stp v-stp enable
    stp mode rstp
    #
    interface MEth0/0/0
     ip address 10.1.1.2 255.255.255.0
    #
    interface Eth-Trunk0
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk20
     port link-type trunk
     port trunk allow-pass vlan 11
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk30
     port link-type trunk
     port trunk allow-pass vlan 11
     mode lacp-static
     dfs-group 1 m-lag 2
    #
    interface 10GE1/0/1
     eth-trunk 20
    #
    interface 10GE1/0/2
     eth-trunk 20
    #
    interface 10GE1/0/3
     eth-trunk 0
    #
    interface 10GE1/0/4
     eth-trunk 0
    #
    interface 10GE1/0/5
     eth-trunk 30
    #
    interface 10GE1/0/6
     eth-trunk 30
    #
    return
  • SwitchE configuration file

    #
    sysname SwitchE
    #
    dfs-group 1
     priority 150
     source ip 10.2.1.1
    #
    vlan batch 11
    #
    stp mode rstp
    stp v-stp enable
    #
    interface Vlanif11
     ip address 10.3.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.3.1.111
    #
    interface MEth0/0/0
     ip address 10.2.1.1 255.255.255.0
    #
    interface Eth-Trunk0
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk40
     port link-type trunk
     port trunk allow-pass vlan 11
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface 10GE1/0/1
     eth-trunk 40
    #
    interface 10GE1/0/2
     eth-trunk 40
    #
    interface 10GE1/0/3
     eth-trunk 0
    #
    interface 10GE1/0/4
     eth-trunk 0
    #
    interface 10GE1/0/5
     undo portswitch
     ip address 10.4.1.1 255.255.255.0
    #
    interface 10GE1/0/6
     undo portswitch
     ip address 10.5.1.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 10.3.1.0 0.0.0.255
      network 10.4.1.0 0.0.0.255
      network 10.5.1.0 0.0.0.255
    #
    return
  • SwitchF configuration file

    #
    sysname SwitchF
    #
    dfs-group 1
     priority 120
     source ip 10.2.1.2
    #
    vlan batch 11
    #
    stp mode rstp
    stp v-stp enable
    #
    interface Vlanif11
     ip address 10.3.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.3.1.111
    #
    interface MEth0/0/0
     ip address 10.2.1.2 255.255.255.0
    #
    interface Eth-Trunk0
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk40
     port link-type trunk
     port trunk allow-pass vlan 11
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface 10GE1/0/1
     eth-trunk 40
    #
    interface 10GE1/0/2
     eth-trunk 40
    #
    interface 10GE1/0/3
     eth-trunk 0
    #
    interface 10GE1/0/4
     eth-trunk 0
    #
    interface 10GE1/0/5
     undo portswitch
     ip address 10.6.1.1 255.255.255.0
    #
    interface 10GE1/0/6
     undo portswitch
     ip address 10.7.1.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 10.3.1.0 0.0.0.255
      network 10.6.1.0 0.0.0.255
      network 10.7.1.0 0.0.0.255
    #
    return
  • SwitchG configuration file

    #
    sysname SwitchG
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.4.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 10.7.1.2 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 10.4.1.0 0.0.0.255
      network 10.7.1.0 0.0.0.255
    #
    return
  • SwitchH configuration file

    #
    sysname SwitchH
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.6.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 10.5.1.2 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 10.5.1.0 0.0.0.255
      network 10.6.1.0 0.0.0.255
    #
    return
Download
Updated: 2019-04-03

Document ID: EDOC1000039339

Views: 105539

Downloads: 7472

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next