No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides IGMP snooping configuration examples to help you configure basic IGMP snooping functions, static interfaces, an IGMP snooping querier, an IGMP snooping proxy, and Layer 2 multicast SSM mapping.

Example for Configuring IGMP Snooping

Networking Requirements

As shown in Figure 8-111, Router connects to user hosts through a Layer 2 Switch Module and Router runs IGMPv2. The multicast source (Source) sends data to multicast groups 225.1.1.1 to 225.1.1.5. There are three receivers HostA, HostB, and HostC on the network. The receivers are only allowed to receive data of groups 225.1.1.1 to 225.1.1.3.

Figure 8-111 Networking diagram for IGMP snooping configuration

Configuration Roadmap

To meet the preceding requirements, configure basic IGMP snooping functions and a multicast group policy on the Layer 2 Switch Module. The configuration roadmap is as follows:

  1. On the Switch Module, create a VLAN and add interfaces to the VLAN.
  2. Enable IGMP snooping globally and in the VLAN.
  3. Configure a multicast group policy and apply this policy to the VLAN.

Procedure

  1. Create a VLAN and add interfaces to the VLAN.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch Module
    [*HUAWEI] commit
    [~Switch Module] vlan 10
    [*Switch Module-vlan10] quit
    [*Switch Module] interface 10ge 1/17/1
    [*Switch Module-10GE1/17/1] port default vlan 10
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] interface 10ge 1/17/2
    [*Switch Module-10GE1/17/2] port default vlan 10
    [*Switch Module-10GE1/17/2] quit
    [*Switch Module] interface 10ge 1/17/3
    [*Switch Module-10GE1/17/3] port link-type trunk
    [*Switch Module-10GE1/17/3] port trunk allow-pass vlan 10
    [*Switch Module-10GE1/17/3] commit
    [~Switch Module-10GE1/17/3] quit

  2. Enable IGMP snooping.

    # Enable IGMP snooping globally.

    [*Switch Module] igmp snooping enable

    # Enable IGMP snooping in VLAN 10.

    [~Switch Module] vlan 10
    [*Switch Module-vlan10] igmp snooping enable
    [*Switch Module-vlan10] commit
    [~Switch Module-vlan10] quit

  3. Configure a multicast group policy and apply this policy.

    # Configure a multicast group policy.

    [~Switch Module] acl 2000
    [*Switch Module-acl4-basic-2000] rule deny source 225.1.1.4 0
    [*Switch Module-acl4-basic-2000] rule deny source 225.1.1.5 0
    [*Switch Module-acl4-basic-2000] commit
    [~Switch Module-acl4-basic-2000] quit

    # Apply the multicast group policy in VLAN 10.

    [~Switch Module] vlan 10
    [*Switch Module-vlan10] igmp snooping group-policy 2000
    [*Switch Module-vlan10] commit
    [~Switch Module-vlan10] quit

  4. Verify the configuration.

    # Check the member port information on the Switch Module.

    [~Switch Module] display igmp snooping port-info vlan 10 
     -------------------------------------------------------------------------------
      Flag: S:Static     D:Dynamic     M:Ssm-mapping                                
            A:Active     P:Protocol    T:Trill                               
                         (Source, Group)  Port                                  Flag
     -------------------------------------------------------------------------------
     VLAN 10, 5 Entry(s)                                                            
                          (*, 225.1.1.1)                                        PA- 
                                          10GE1/17/1                             -D- 
                                          10GE1/17/2                             -D- 
                                                            2 port(s) include       
                          (*, 225.1.1.2)                                        PA- 
                                          10GE1/17/1                             -D- 
                                          10GE1/17/2                             -D- 
                                                            2 port(s) include       
                          (*, 225.1.1.3)                                        PA- 
                                          10GE1/17/1                             -D- 
                                          10GE1/17/2                             -D- 
                                                            2 port(s) include       
                          (*, 225.1.1.4)                                        -A- 
                          (*, 225.1.1.5)                                        -A- 
     -------------------------------------------------------------------------------

    The command output shows that multicast groups 225.1.1.1 to 225.1.1.3 have dynamically generated member ports 10GE1/17/1 and 10GE1/17/2 on the Switch Module, whereas groups 225.1.1.4 and 225.1.1.5 have no member ports.

    # Check the router port information on the Switch Module.

    [~Switch Module] display igmp snooping router-port vlan 10 
     Port Name                            UpTime        Expires       Flags
     -------------------------------------------------------------------------- 
     VLAN 10, 1 router-port(s)
     10GE1/17/3                            12h03m12s     00h02m31s     DYNAMIC

    The command output shows that the router port is 10GE1/17/3.

    # Check the Layer 2 multicast forwarding table on the Switch Module.

    [~Switch Module] display multicast layer-2 ip fib vlan 10
    -------------------------------------------------------------------------------- 
    Forwarding Mode: IP 
    VLAN  Total                      (Source,Group)  Interface
    -------------------------------------------------------------------------------- 
    10     5
                                     (*, 225.1.1.1)  10GE1/17/1
                                                     10GE1/17/2
                                                     10GE1/17/3
                                     (*, 225.1.1.2)  10GE1/17/1 
                                                     10GE1/17/2
                                                     10GE1/17/3
                                     (*, 225.1.1.3)  10GE1/17/1 
                                                     10GE1/17/2
                                                     10GE1/17/3
                                     (*, 225.1.1.4)  10GE1/17/3
                                     (*, 225.1.1.5)  10GE1/17/3
    -------------------------------------------------------------------------------- 
    

    According to the preceding command output, only groups 225.1.1.1 to 225.1.1.3 have member ports in the multicast forwarding table, and multicast data of these groups can be forwarded to the hosts. Groups 225.1.1.4 and 225.1.1.5 have no member ports, and multicast data of the two groups is not forwarded to the host.

Configuration Files
  • Configuration file of the Switch Module

    #
    sysname Switch Module
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     igmp snooping group-policy 2000
    #
    acl number 2000
     rule 5 deny source 225.1.1.4 0
     rule 10 deny source 225.1.1.5 0
    #
    interface 10GE1/17/1
     port default vlan 10
    #
    interface 10GE1/17/2
     port default vlan 10
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return

Example for Configuring Layer 2 Multicast Through Static Interfaces

Networking Requirements

As shown in Figure 8-112, Router connects to user hosts through a Layer 2 switch. The user-side VLANIF interface of Router has static groups 225.1.1.1 to 225.1.1.5 configured and does not run IGMP. There are four receivers on the network: HostA, HostB, HostC, and HostD. HostA and HostB expect to receive data of multicast groups 225.1.1.1 to 225.1.1.3 for long time. HostC and HostD expect to receive data of multicast groups 225.1.1.4 to 225.1.1.5.

Figure 8-112 Networking diagram for Layer 2 multicast configuration through static interfaces

Configuration Roadmap

To meet the preceding requirements, configure a static router port and static member ports of IGMP snooping on the Layer 2 Switch Module. The configuration roadmap is as follows:

  1. On the Switch Module, create a VLAN and add interfaces to the VLAN.
  2. Enable IGMP snooping globally and in the VLAN.
  3. Configure a static router port.
  4. Configure static member ports.

Procedure

  1. Create a VLAN and add interfaces to the VLAN.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch Module
    [*HUAWEI] commit
    [~Switch Module] vlan 10
    [*Switch Module-vlan10] quit
    [*Switch Module] interface 10ge 1/17/1
    [*Switch Module-10GE1/17/1] port default vlan 10
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] interface 10ge 1/17/2
    [*Switch Module-10GE1/17/2] port default vlan 10
    [*Switch Module-10GE1/17/2] quit
    [*Switch Module] interface 10ge 1/17/3
    [*Switch Module-10GE1/17/3] port link-type trunk
    [*Switch Module-10GE1/17/3] port trunk allow-pass vlan 10
    [*Switch Module-10GE1/17/3] commit
    [~Switch Module-10GE1/17/3] quit

  2. Enable IGMP snooping.

    # Enable IGMP snooping globally.

    [~Switch Module] igmp snooping enable

    # Enable IGMP snooping in VLAN 10.

    [*Switch Module] vlan 10
    [*Switch Module-vlan10] igmp snooping enable
    [*Switch Module-vlan10] commit
    [~Switch Module-vlan10] quit

  3. Configure a static router port.

    [~Switch Module] interface 10GE 1/17/3
    [~Switch Module-10GE1/17/3] igmp snooping static-router-port vlan 10
    [*Switch Module-10GE1/17/3] commit
    [*~-10GE1/17/3] quit
    

  4. Configure static member ports.

    [~Switch Module] interface 10ge 1/17/1
    [~Switch Module-10GE1/17/1] igmp snooping static-group group-address 225.1.1.1 to 225.1.1.3 vlan 10
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] interface 10ge 1/17/2
    [*Switch Module-10GE1/17/2] igmp snooping static-group group-address 225.1.1.4 to 225.1.1.5 vlan 10
    [*Switch Module-10GE1/17/2] commit
    [~Switch Module-10GE1/17/2] quit
    

  5. Verify the configuration.

    # Check the router port information on the Switch Module.

    [~Switch Module] display igmp snooping router-port vlan 10 
     Port Name                       UpTime        Expires       Flags              
     ---------------------------------------------------------------------          
     VLAN 10, 1 router-port(s)                                                     
     10GE1/17/3                        00h20m09s     --            STATIC

    The command output shows that 10GE1/17/3 has been configured as static router port.

    # Check the member port information on the Switch Module.

    [~Switch Module] display igmp snooping port-info vlan 10 
     -------------------------------------------------------------------------------
      Flag: S:Static     D:Dynamic     M:Ssm-mapping                                
            A:Active     P:Protocol    T:Trill                               
                         (Source, Group)  Port                                  Flag
     -------------------------------------------------------------------------------
     VLAN 10, 5 Entry(s)                                                            
                          (*, 225.1.1.1)                                        P-- 
                                          10GE1/17/1                             S-- 
                                                            1 port(s) include       
                          (*, 225.1.1.2)                                        P-- 
                                          10GE1/17/1                             S-- 
                                                            1 port(s) include       
                          (*, 225.1.1.3)                                        P-- 
                                          10GE1/17/1                             S-- 
                                                            1 port(s) include       
                          (*, 225.1.1.4)                                        P-- 
                                          10GE1/17/2                             S-- 
                                                            1 port(s) include       
                          (*, 225.1.1.5)                                        P-- 
                                          10GE1/17/2                             S-- 
                                                            1 port(s) include       
     --------------------------------------------------------------------------------

    The command output shows that multicast groups 225.1.1.1 to 225.1.1.3 have a static member port 10GE1/17/1 on the Switch Module and multicast groups 225.1.1.4 to 225.1.1.5 have a static member port 10GE1/17/2 on the Switch Module.

    # Check the Layer 2 multicast forwarding table on the Switch Module.

    [~Switch Module] display multicast layer-2 ip fib vlan 10
    -------------------------------------------------------------------------------- 
    Forwarding Mode: IP 
    VLAN  Total                      (Source,Group)  Interface 
    -------------------------------------------------------------------------------- 
    10     5 
                                     (*, 225.1.1.1)  10GE1/17/1 
                                                     10GE1/17/3
                                     (*, 225.1.1.2)  10GE1/17/1 
                                                     10GE1/17/3
                                     (*, 225.1.1.3)  10GE1/17/1
                                                     10GE1/17/3
                                     (*, 225.1.1.4)  10GE1/17/2
                                                     10GE1/17/3
                                     (*, 225.1.1.5)  10GE1/17/2
                                                     10GE1/17/3 
    -------------------------------------------------------------------------------- 
    

    The command output shows that multicast groups 225.1.1.1 to 225.1.1.5 have a forwarding table on the Switch Module.

Configuration Files
  • Configuration file of the Switch Module

    #
    sysname Switch Module
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
    #
    interface 10GE1/17/1
     port default vlan 10
     igmp snooping static-group group-address 225.1.1.1 to 225.1.1.3 vlan 10 
    #
    interface 10GE1/17/2
     port default vlan 10
     igmp snooping static-group group-address 225.1.1.4 to 225.1.1.5 vlan 10 
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 10
     igmp snooping static-router-port vlan 10 
    #
    return

Example for Configuring an IGMP Snooping Querier

Networking Requirements

As shown in Figure 8-113, on a pure Layer 2 network, multicast sources Source1 and Source2 send multicast data to multicast groups 224.1.1.1 and 225.1.1.1. HostA and HostC join multicast group 224.1.1.1, while HostB and HostD join multicast group 225.1.1.1. All the hosts run IGMPv2. Multicast data is expected to be transmitted on the Layer 2 network through IGMP snooping.

Figure 8-113 Networking diagram for IGMP snooping querier configuration

Configuration Roadmap

To meet the preceding requirements, enable IGMP snooping on the four Switch Modulees and configure an IGMP snooping querier. Enable all the Switch Modulees to discard unknown multicast packets to prevent the Switch Modulees from broadcasting multicast data in the VLAN when there are no Layer 2 multicast forwarding entries on the Switch Modulees. The configuration roadmap is as follows:

  1. On all the Switch Modulees, create a VLAN and add interfaces to the VLAN according to Figure 8-113.
  2. Enable IGMP snooping globally and in the VLAN on all the Switch Modulees.
  3. Configure Switch ModuleA as an IGMP snooping querier.
  4. Enable all the Switch Modulees to discard unknown multicast packets.

Procedure

  1. On all the Switch Modulees, create a VLAN and add interfaces to the VLAN.

    # Configure Switch ModuleA.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan 10
    [*Switch ModuleA-vlan10] quit
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port default vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] port link-type trunk
    [*Switch ModuleA-10GE1/17/2] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] interface 10ge 1/17/3
    [*Switch ModuleA-10GE1/17/3] port default vlan 10
    [*Switch ModuleA-10GE1/17/3] commit
    [~Switch ModuleA-10GE1/17/3] quit

    # The configurations of Switch ModuleB, Switch ModuleC and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here.

  2. Enable IGMP snooping globally and in the VLAN on all the Switch Modulees.

    # Configure Switch ModuleA.

    [~Switch ModuleA] igmp snooping enable
    [*Switch ModuleA] vlan 10
    [*Switch ModuleA-vlan10] igmp snooping enable
    [*Switch ModuleA-vlan10] commit
    [~Switch ModuleA-vlan10] quit

    # The configurations of Switch ModuleB, Switch ModuleC and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here.

  3. Configure Switch ModuleA as an IGMP snooping querier.

    [~Switch ModuleA] vlan 10
    [~Switch ModuleA-vlan10] igmp snooping querier enable
    [*Switch ModuleA-vlan10] commit
    [~Switch ModuleA-vlan10] quit

  4. Enable all the Switch Modulees to discard unknown multicast packets.

    # Configure Switch ModuleA.

    [~Switch ModuleA] vlan 10
    [~Switch ModuleA-vlan10] multicast drop-unknown
    [*Switch ModuleA-vlan10] commit
    [~Switch ModuleA-vlan10] quit
    

    # The configurations of Switch ModuleB, Switch ModuleC and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here.

  5. Verify the configuration.

    # When the IGMP snooping querier begins to work, all the Switch Modulees except the IGMP snooping querier receive IGMP General Query messages. Run the display igmp snooping statistics vlan 10 command on Switch ModuleB to view IGMP message statistics. The command output is as follows:

    [~Switch ModuleB] display igmp snooping statistics vlan 10
     IGMP Snooping Packets Counter:                                                  
       Statistics for VLAN 10                                                       
         Receive V1 Report:          0                                                  
         Receive V2 Report:          32                                                 
         Receive V3 Report:          0                                                  
         Receive V1 Query:           0                                                  
         Receive V2 Query:         30                              
         Receive V3 Query:           0                                                  
         Receive Leave:              0                                                  
         Receive Pim Hello:          0                                                  
         Send Query (S=0):           0                                                  
         Send Query (S!=0):          -                                                  
         Proxy Send General Query:                0                                   
         Proxy Send Group-Specific Query:         0                                   
         Proxy Send Group-Source-Specific Query:  0                                   
    

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     igmp snooping querier enable
     multicast drop-unknown
    #
    interface 10GE1/17/1
     port default vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/3
     port default vlan 10
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     multicast drop-unknown
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/3
     port default vlan 10
    #
    interface 10GE1/17/4
     port default vlan 10
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     multicast drop-unknown
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/3
     port default vlan 10
    #
    return
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     multicast drop-unknown
    #
    interface 10GE1/17/1
     port default vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return

Example for Configuring IGMP Snooping Proxy

Networking Requirements

As shown in Figure 8-114, Router connects to user hosts through a Layer 2 Switch Module and Router runs IGMPv2. There are multiple receiver hosts on the network, and the administrator expects that exchange of IGMP messages will not be a burden to Router.

Figure 8-114 Networking diagram for the IGMP snooping proxy configuration

Configuration Roadmap

To meet the preceding requirements, configure IGMP snooping proxy on the Switch Module. The configuration roadmap is as follows:

  1. Create a VLAN and add interfaces to the VLAN.

  2. Enable IGMP snooping globally and in the VLAN.

  3. Configure IGMP snooping proxy on the Switch Module to reduce packet exchange between the Switch Module and Router.

  4. Disable the Switch Module from sending IGMP Query messages to the upstream Router to prevent election of the IGMP querier.

Procedure

  1. Create a VLAN and add interfaces to the VLAN.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch Module
    [*HUAWEI] commit
    [~Switch Module] vlan 10
    [*Switch Module-vlan10] quit
    [*Switch Module] interface 10ge 1/17/1
    [*Switch Module-10GE1/17/1] port default vlan 10
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] interface 10ge 1/17/2
    [*Switch Module-10GE1/17/2] port default vlan 10
    [*Switch Module-10GE1/17/2] quit
    [*Switch Module] interface 10ge 1/17/3
    [*Switch Module-10GE1/17/3] port link-type trunk
    [*Switch Module-10GE1/17/3] port trunk allow-pass vlan 10
    [*Switch Module-10GE1/17/3] commit
    [~Switch Module-10GE1/17/3] quit

  2. Enable IGMP snooping.

    # Enable IGMP snooping globally.

    [*Switch Module] igmp snooping enable

    # Enable IGMP snooping in VLAN 10.

    [~Switch Module] vlan 10
    [~Switch Module-vlan10] igmp snooping enable
    [*Switch Module-vlan10] commit
    

    # Configure IGMPv3 snooping to enable the Switch Module to process IGMP messages of all versions.

    [~Switch Module-vlan10] igmp snooping version 3
    [*Switch Module-vlan10] commit
    

  3. Enable IGMP snooping proxy.

    [~Switch Module-vlan10] igmp snooping proxy
    [*Switch Module-vlan10] commit
    [~Switch Module-vlan10] quit

  4. Disable the Switch Module from sending IGMP Query messages to the upstream Router.

    [~Switch Module] interface 10ge 1/17/3
    [~Switch Module-10GE1/17/3] igmp snooping proxy-uplink-port vlan 10
    [*Switch Module-10GE1/17/3] commit
    [~Switch Module-10GE1/17/3] quit

  5. Verify the configuration.

    # Check IGMP message statistics on the Switch Module.

    [~Switch Module] display igmp snooping statistics vlan 10
     IGMP Snooping Packets Counter:                                                      
       Statistics for VLAN 10                                                            
         Receive V1 Report:          0                                                   
         Receive V2 Report:          1121                                                
         Receive V3 Report:          0                                                   
         Receive V1 Query:           0                                                   
         Receive V2 Query:           2                                                   
         Receive V3 Query:           0                                                   
         Receive Leave:              0                                                   
         Receive Pim Hello:          4                                                   
         Send Query (S=0):           0                                                   
         Send Query (S!=0):          -                                                   
         Proxy Send General Query:             13                                     
         Proxy Send Group-Specific Query:         0                                      
         Proxy Send Group-Source-Specific Query:  0                                      
    

    The command output shows that the IGMP snooping proxy takes effect as the Switch Module functions as a proxy to send IGMP General Query messages.

Configuration Files
  • Configuration file of the Switch Module

    #
    sysname Switch Module
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     igmp snooping version 3
     igmp snooping proxy
    #
    interface 10GE1/17/1
     port default vlan 10
    #
    interface 10GE1/17/2
     port default vlan 10
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 10
     igmp snooping proxy-uplink-port vlan 10 
    #
    return

Example for Configuring Multicast SSM Mapping

Networking Requirements

As shown in Figure 8-115, Router connects to user hosts through a Layer 2 Switch Module. Router runs IGMPv3 and uses the ASM mode and SSM mode to provide multicast services. User hosts HostA, HostB, and HostC on the network run IGMPv2 and do not support IGMPv3. The multicast sources Source1 and Source2 send multicast data to the multicast group 225.1.1.1, but the user hosts want to receive only the multicast data sent from Source1.

Figure 8-115 Networking diagram for the SSM mapping configuration

Configuration Roadmap

To meet the preceding requirements, configure SSM mapping on the Switch Module. The configuration roadmap is as follows:

  1. On the Switch Module, create a VLAN and add interfaces to the VLAN.

  2. Enable IGMP snooping globally and in the VLAN.

  3. Configure an IGMP snooping SSM policy to add the multicast address of the ASM mode to the SSM group address range.

  4. Configure SSM mapping to allow the users to receive only multicast data sent from the specified source.

Procedure

  1. Create a VLAN and add interfaces to the VLAN.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch Module
    [*HUAWEI] commit
    [~Switch Module] vlan 10
    [*Switch Module-vlan10] quit
    [*Switch Module] interface 10ge 1/17/1
    [*Switch Module-10GE1/17/1] port default vlan 10
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] interface 10ge 1/17/3
    [*Switch Module-10GE1/17/3] port link-type trunk
    [*Switch Module-10GE1/17/3] port trunk allow-pass vlan 10
    [*Switch Module-10GE1/17/3] commit
    [~Switch Module-10GE1/17/3] quit

  2. Enable IGMP snooping.

    # Enable IGMP snooping globally.

    [~Switch Module] igmp snooping enable

    # Enable IGMP snooping in VLAN 10.

    [*Switch Module] vlan 10
    [*Switch Module-vlan10] igmp snooping enable
    [*Switch Module-vlan10] commit
    [~Switch Module-vlan10] quit

  3. Configure an IGMP snooping SSM policy.

    # Create an ACL, and configure a rule that allows hosts to receive data of multicast group 225.1.1.1.

    [~Switch Module] acl number 2008
    [*Switch Module-acl4-basic-2008] rule 5 permit source 225.1.1.1 0
    [*Switch Module-acl4-basic-2008] commit
    [~Switch Module-acl4-basic-2008] quit
    

    # Apply the SSM mapping policy in the VLAN and treat the multicast group 225.1.1.1 as a member in the SSM groups.

    [~Switch Module] vlan 10 
    [*Switch Module-vlan10] igmp snooping ssm-policy 2008
    [*Switch Module-vlan10] commit
    

  4. Enable SSM mapping.

    # Configure the Switch Module to run IGMPv3, enable SSM mapping, and configure a mapping between the multicast group 225.1.1.1 and the source IP address 10.10.1.1.

    [~Switch ModuleA-vlan10] igmp snooping version 3
    [*Switch ModuleA-vlan10] igmp snooping ssm-mapping enable 
    [*Switch ModuleA-vlan10] igmp snooping ssm-mapping 225.1.1.1 32 10.10.1.1
    [*Switch ModuleA-vlan10] commit
    [~Switch ModuleA-vlan10] quit

  5. Verify the configuration.

    # Check the IGMP snooping configuration in the VLAN.

    [~Switch Module] display igmp snooping vlan configuration
     IGMP Snooping Configuration for VLAN 10
         igmp snooping enable
         igmp snooping version 3
         igmp snooping ssm-policy 2008
         igmp snooping ssm-mapping enable
         igmp snooping ssm-mapping 225.1.1.1 255.255.255.255 10.10.1.1

    An SSM mapping policy has been configured in VLAN 10.

    # Check the Layer 2 multicast forwarding table.

    [~Switch Module] display multicast layer-2 ip fib vlan 10
    -------------------------------------------------------------------------------- 
    Forwarding Mode: IP 
    VLAN  Total                      (Source,Group)  Interface
    -------------------------------------------------------------------------------- 
    10     1 
                             (10.10.1.1, 225.1.1.1)  10GE1/17/1
                                                     10GE1/17/3
    -------------------------------------------------------------------------------- 

    The command output shows that a mapping entry (10.10.1.1, 225.1 .1.1) has been generated on the Switch Module. The mapping entry indicates that the data is sent by Source1.

Configuration Files
  • Configuration file of the Switch Module

    #
    sysname Switch Module
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    acl number 2008
     rule 5 permit source 225.1.1.1 0
    #
    vlan 10
     igmp snooping enable
     igmp snooping version 3
     igmp snooping ssm-policy 2008
     igmp snooping ssm-mapping enable
     igmp snooping ssm-mapping 225.1.1.1 255.255.255.255 10.10.1.1
    #
    interface 10GE1/17/1
     port default vlan 10
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    return 
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 57533

Downloads: 3619

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next