No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This topic describes the examples for Configuring System Startup.

Example for Backing Up the Configuration File

Networking Requirements

As shown in Figure 1-34, a user logs in to the device and backs up the configuration file to the TFTP server. So the configuration file can be recovered in case that the device is damaged.

Figure 1-34 Networking diagram of backing up the configuration file

Configuration Roadmap

The configuration roadmap is as follows:

  1. Save the configuration file.

  2. Back up the configuration file through TFTP.

Procedure

  1. Save configurations to the config.cfg file.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch Module
    [Switch Module] quit
    <Switch Module> save config.cfg

  2. Back up the configuration file through TFTP.
    1. Start the TFTP server program.

      Start the TFTP server program on the PC. Set the path for transmitting the configuration file, and the IP address and port number of the TFTP server.

    2. Transfer the configuration file.

      # Run the tftp command in the user view to back up the specified configuration file.

      <Switch Module> tftp 10.110.24.254 put flash:/config.cfg backup.cfg

Example for Recovering the Configuration File

Networking Requirements

As shown in Figure 1-35, a user logs in to the device and finds that some incorrect configurations cause errors in the system. To recover the original configuration, the user downloads the configuration file saved in the TFTP server to the device and specifies the configuration file for the next startup.

Figure 1-35 Network diagram of recovering the configuration file

Configuration Roadmap

The configuration roadmap is as follows:

  1. Recover the configuration file that is backed up on the PC through TFTP.

  2. Specify the recovered configuration file for the next startup.

Procedure

  1. Recover the configuration file that is backed up on the PC through TFTP.
    1. Start the TFTP server program.

      Start the TFTP server program on the PC. Set the path for transmitting the configuration file, and the IP address and port number of the TFTP server.

    2. Transfer the configuration file.

      # Run the tftp command in the user view.

      <HUAWEI> system-view
      [HUAWEI] sysname Switch Module
      [Switch Module] quit
      <Switch Module> tftp 10.110.24.254 get backup.cfg config.cfg

  2. Specify the recovered configuration file for the next startup.

    <Switch Module> startup saved-configuration config.cfg

Example for Rolling Back Configurations

Networking Requirements

As shown in Figure 1-36, a user logs in to the switch and configures an IP address for each switch interface. Generally, after submitting the configuration, the user cannot check the latest configurations and can only check the current configuration file. When the configurations are incorrect or an unexpected configuration result occurs on the network, the user can only manually delete or modify the configurations one by one and cannot perform the batch recovery operation.

Figure 1-36 Network diagram of rolling back configurations

To solve the preceding problem, the user can check the difference between the historical and current configurations and roll back the system configuration to the appropriate configuration point without restarting the system or interrupting services.

In this example, the user finds that IP addresses are incorrectly configured for interfaces and wants to reconfigure them. By using the traditional method, the user must enter each interface view to delete the corresponding IP address and reconfigure the IP address. By using the configuration rollback function, the user can recover the configurations to the configuration state when the IP addresses have not been configured, which greatly simplifies configuration recovery.

Configuration Roadmap

The configuration roadmap is as follows:

  • Check the configuration rollback points and the latest configuration changes.

  • Determine the configuration rollback point or the number of configuration changes to roll back the configuration.

Procedure

  1. Configure IP addresses for 10GE1/17/1, 10GE1/17/2, 10GE1/17/3, and 10GE1/17/4 on the switch.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan batch 77 to 80
    [*Switch] interface vlanif 77
    [*Switch-Vlanif77] ip address 100.0.1.1 24
    [*Switch] quit
    [*Switch] interface vlanif 78
    [*Switch-Vlanif78] ip address 100.0.2.1 24
    [*Switch] quit
    [*Switch] interface vlanif 79
    [*Switch-Vlanif79] ip address 100.0.3.1 24
    [*Switch] quit
    [*Switch] interface vlanif 80
    [*Switch-Vlanif80] ip address 100.0.4.1 24
    [*Switch] quit
    [*Switch] interface 10ge 1/17/1
    [*Switch-10GE1/17/1] port link-type trunk
    [*Switch-10GE1/17/1] port trunk allow-pass vlan 77
    [*Switch-10GE1/17/1] quit
    [*Switch] interface 10ge 1/17/2
    [*Switch-10GE1/17/2] port link-type trunk
    [*Switch-10GE1/17/2] port trunk allow-pass vlan 78
    [*Switch-10GE1/17/2] quit
    [*Switch] interface 10ge 1/17/3
    [*Switch-10GE1/17/3] port link-type trunk
    [*Switch-10GE1/17/3] port trunk allow-pass vlan 79
    [*Switch-10GE1/17/3] quit
    [*Switch] interface 10ge 1/17/4
    [*Switch-10GE1/17/4] port link-type trunk
    [*Switch-10GE1/17/4] port trunk allow-pass vlan 80
    [*Switch-10GE1/17/4] quit
    [*Switch] commit
    [~Switch] quit

  2. Check the configuration rollback points and the difference between the historical and current configurations.

    # Check the configuration rollback points.

    <Switch> display configuration commit list verbose
    1) CommitId: 1000000006
            Label: -
            User: root
            User-Intf: VTY 1
            Type: CLI
            TimeStamp: 2012-06-29 15:55:20
            Description: 
    
    2) CommitId: 1000000005
            Label: -
            User: root
            User-Intf: VTY 1
            Type: CLI
            TimeStamp: 2012-06-29 15:50:05
            Description: 
    
    3) CommitId: 1000000004
            Label: -
            User: root
            User-Intf: VTY 0
            Type: CLI
            TimeStamp: 2012-06-29 09:57:34
            Description: 
    
    4) CommitId: 1000000003
            Label: -
            User: root
            User-Intf: VTY 0
            Type: CLI
            TimeStamp: 2012-06-29 09:57:21
            Description: 
    
    5) CommitId: 1000000002
            Label: -
            User: anonymous
            User-Intf: CON 1023
            Type: CLI
            TimeStamp: 2012-06-28 16:31:48
            Description: 
    
    6) CommitId: 1000000001
            Label: -
            User: anonymous
            User-Intf: CON 1023
            Type: CLI
            TimeStamp: 2012-06-28 16:31:48
            Description:

    # Check the latest configuration change.

    <Switch> display configuration commit changes last 1
    Building configuration                                                          
      #                                                                             
    + vlan batch 77 to 80                                                           
      #                                                                             
    + interface Vlanif77                                                            
    +  ip address 100.0.1.1 255.255.255.0                                           
      #                                                                             
    + interface Vlanif78                                                            
    +  ip address 100.0.2.1 255.255.255.0                                           
      #                                                                             
    + interface Vlanif79                                                            
    +  ip address 100.0.3.1 255.255.255.0                                           
      #                                                                             
    + interface Vlanif80                                                            
    +  ip address 100.0.4.1 255.255.255.0                                           
      #                                                                             
      interface 10GE1/17/1                                                           
    +  port link-type trunk                                                         
    +  port trunk allow-pass vlan 77                                                
      #                                                                             
      interface 10GE1/17/2                                                           
    +  port link-type trunk                                                         
    +  port trunk allow-pass vlan 78                                              
      #                                                                             
      interface 10GE1/17/3                                                           
    +  port link-type trunk                                                         
    +  port trunk allow-pass vlan 79                                                
      #                                                                             
      interface 10GE1/17/4                                                           
    +  port link-type trunk                                                         
    +  port trunk allow-pass vlan 80                                                
      #

  3. Roll back configurations.

    # Roll system configurations back to what they were before the most recent configuration rollback point was created.

    <Switch> rollback configuration last 1
    Warning: This operation will revert configuration changes to the previous status. Continue? [Y/N]:y
    Loading rollback changes
    Committing
    Check rollback result
    Configuration rollback succeeded.
    Please use 'display configuration commit changes last 1' to view the changes. 

    # Check whether a configuration rollback point is generated after the configuration rollback is completed.

    <Switch> display configuration commit list verbose
    1) CommitId: 1000000007
            Label: -
            User: root
            User-Intf: VTY 1
            Type: ROLLBACK
            TimeStamp: 2012-06-29 15:58:22
            Description: 
    
    2) CommitId: 1000000006
            Label: -
            User: root
            User-Intf: VTY 1
            Type: CLI
            TimeStamp: 2012-06-29 15:55:20
            Description: 
    
    3) CommitId: 1000000005
            Label: -
            User: root
            User-Intf: VTY 1
            Type: CLI
            TimeStamp: 2012-06-29 15:50:05
            Description: 
    
    4) CommitId: 1000000004
            Label: -
            User: root
            User-Intf: VTY 0
            Type: CLI
            TimeStamp: 2012-06-29 09:57:34
            Description: 
    
    5) CommitId: 1000000003
            Label: -
            User: root
            User-Intf: VTY 0
            Type: CLI
            TimeStamp: 2012-06-29 09:57:21
            Description: 
    
    6) CommitId: 1000000002
            Label: -
            User: anonymous
            User-Intf: CON 1023
            Type: CLI
            TimeStamp: 2012-06-28 16:31:48
            Description: 
    
    7) CommitId: 1000000001
            Label: -
            User: anonymous
            User-Intf: CON 1023
            Type: CLI
            TimeStamp: 2012-06-28 16:31:48
            Description: 

  4. Verify the configuration.

    # Check the configuration file to verify that the configuration rollback is successful.

    <Switch> display current-configuration interface
    #
    interface 10GE1/17/1
    #
    interface 10GE1/17/2
    #
    interface 10GE1/17/3
    #
    interface 10GE1/17/4
    return

Configuration Files

Switch configuration file

#
sysname Switch
#
interface 10GE1/17/1
#
interface 10GE1/17/2
#
interface 10GE1/17/3
#
interface 10GE1/17/4
#
return

Example of Configuring System Startup

Networking Requirements

As shown in Figure 1-37, the current system software cannot meet user needs. The device must load new software version with more features. Then the device software needs to be upgraded remotely.

Figure 1-37 Configuring System Startup Networking

Configuration Roadmap

The configuration roadmap is as follows:

  1. Upload the new system software to the root directory of the device.

  2. Save the current configuration so that it remains active after upgrade.

  3. Specify the system software for next startup.

  4. Specify the configuration file for next startup of the device.

  5. Restart the device to complete upgrade.

Procedure

  1. Upload the new system software to the root directory of the device.

    Before configuration, run the display startup command to view the files for next startup.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch Module
    [Switch Module] quit
    <Switch Module> display startup
    MainBoard:
      Configured startup system software:        flash:/basicsoft.cc
      Startup system software:                   flash:/basicsoft.cc
      Next startup system software:              flash:/basicsoft.cc
      Startup saved-configuration file:          flash:/vrpcfg.zip
      Next startup saved-configuration file:     flash:/vrpcfg.zip
      Startup paf file:                          default
      Next startup paf file:                     default
      Startup patch package:                     NULL
      Next startup patch package:                NULL

    # Upload the new system software to the device. This example uses FTP to transfer the system software. Configure the device as an FTP server and upload the system software to the device from the FTP client. Make sure there is enough space in the storage device before uploading files. If the space is insufficient, delete unnecessary files to free up space in the storage device.

    <Switch Module> system-view
    [Switch Module] ftp server enable
    [Switch Module] aaa
    [Switch Module-aaa] local-user huawei password irreversible-cipher Helloworld@6789
    [Switch Module-aaa] local-user huawei service-type ftp
    [Switch Module-aaa] local-user huawei ftp-directory flash:
    [Switch Module-aaa] local-user huawei level 15
    [Switch Module-aaa] commit
    [Switch Module-aaa] quit
    [Switch Module] quit
    

    # Run the ftp 10.1.1.1 command in the command line window of the PC to set up an FTP connection with the device. Run the put command to upload new system software newbasicsoft.cc. After the upload completes, run the dir command to check the system software.

    <Switch Module> dir
    Directory of flash:/
    
      Idx  Attr     Size(Byte)  Date        Time       FileName
        0  drw-              -  Apr 16 2012 13:19:58   logfile
        1  -rw-     85,925,409  Apr 16 2012 13:18:02   basicsoft.cc
        2  -rw-              4  Oct 27 2011 17:25:22   snmpnotilog.txt
        3  -rw-          6,033  Jul 16 2012 16:40:02   private-data.txt
        4  -rw-          3,275  Jul 14 2012 14:18:08   vrpcfg.zip
        5  drw-              -  Nov 14 2011 19:14:26   sysdrv 
        6  drw-     88,239,759  Jul 16 2012 19:14:26   newbasicsoft.cc
    ...
    
    670,092 KB total (569,904 KB free)

  2. Save the current configuration to the default storage device.

    <Switch Module> save
    The current configuration will be written to the device.                        
    Are you sure to continue? [Y/N]y                                                 
    Now saving the current configuration to the slot 0 .                            
    Info: Save the configuration successfully. 

  3. Specify the system software to be loaded for next startup.

    <Switch Module> startup system-software newbasicsoft.cc

  4. Specify the configuration file for next startup.

    <Switch Module> startup saved-configuration vrpcfg.zip
    NOTE:

    In step 1, you can run the display startup command to check the configuration file for next startup. The message "Next startup saved-configuration file: flash:/vrpcfg.zip" will be displayed. This means the vrpcfg.zip configuration file has been specified for next startup, so you do not need to perform this step. To specify another file for next startup, perform this step.

  5. Checking the configuration

    # Run the following command to view the system software and configuration file for next startup.

    <Switch Module> display startup
    MainBoard:
      Configured startup system software:        flash:/basicsoft.cc
      Startup system software:                   flash:/basicsoft.cc
      Next startup system software:              flash:/newbasicsoft.cc
      Startup saved-configuration file:          flash:/vrpcfg.zip
      Next startup saved-configuration file:     flash:/vrpcfg.zip
      Startup paf file:                          default
      Next startup paf file:                     default
      Startup patch package:                     NULL
      Next startup patch package:                NULL

  6. Restart the device.

    # Since the configuration file has been saved, run the reboot fast command to restart the device quickly.

    <Switch Module> reboot fast
    System will reboot! Continue? [Y/N]:y                                            
    Info: system is rebooting ,please wait...

  7. Verify the configuration.

    # Wait for several minutes until the device restart is complete. Run the display version command to check the current system version. If the current system software is new, the upgrading has succeeded.

    The display version command output is not provided here.

Configuration File
#
FTP server enable
#
vlan batch 10
#
aaa
 local-user huawei password irreversible-cipher $1a$v!=.5/:(q-$xL=\K+if"'S}>k7vGP5$_ox0B@ys7.'DBHL~3*aN$
 local-user huawei service-type ftp
 local-user huawei level 15
 local-user huawei ftp-directory flash:
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.0 
#
interface 10GE1/17/1
 port link-type trunk
 port trunk allow-pass vlan 10
#
return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 59787

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next