No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides configuration examples of multicast VLAN replication.

Example for Configuring Multicast VLAN Replication Based on User VLANs

Networking Requirements

As shown in Figure 8-121, service VLAN 10 is used to transmit multicast data between RouterA and SwitchA. HostA, HostB, and HostC belong to VLAN 100, VLAN 200, and VLAN 300 respectively. All of them want to receive multicast data from Source.

You can configure multicast VLAN replication based on user VLANs, so that RouterA only needs to copy multicast data for VLAN 10 to respond to the same multicast data request from different user hosts. This reduces bandwidth consumption between RouterA and SwitchA.

Figure 8-121 Configuring multicast VLAN replication based on user VLANs

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable IGMP snooping in the system view.
  2. Create user VLANs and enable IGMP snooping in the user VLANs.
  3. Create a multicast VLAN and enable IGMP snooping in the multicast VLAN.
  4. Bind the user VLANs to the multicast VLAN.
  5. Add the network-side interface and user-side interfaces to VLANs as hybrid interfaces.

Procedure

  1. Enable IGMP snooping in the system view.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] igmp snooping enable
    [*Switch ModuleA] commit
    

  2. Create user VLANs and enable IGMP snooping in the user VLANs.

    [~Switch ModuleA] vlan 100
    [*Switch ModuleA-vlan100] igmp snooping enable
    [*Switch ModuleA-vlan100] quit
    [*Switch ModuleA] vlan 200
    [*Switch ModuleA-vlan200] igmp snooping enable
    [*Switch ModuleA-vlan200] quit
    [*Switch ModuleA] vlan 300
    [*Switch ModuleA-vlan300] igmp snooping enable
    [*Switch ModuleA-vlan300] commit
    [~Switch ModuleA-vlan300] quit
    

  3. Create a multicast VLAN and enable IGMP snooping in the multicast VLAN.

    [~Switch ModuleA] vlan 10
    [*Switch ModuleA-vlan10] igmp snooping enable
    [*Switch ModuleA-vlan10] multicast vlan enable
    [*Switch ModuleA-vlan10] commit
    

  4. Bind user VLANs 100, 200, and 300 to multicast VLAN 10.

    [~Switch ModuleA-vlan10] multicast vlan user-vlan 100 200 300
    [*Switch ModuleA-vlan10] commit
    [~Switch ModuleA-vlan10] quit

  5. Add interfaces to VLANs.

    # Add 10GE1/17/1 to multicast VLAN 10, and configure 10GE1/17/1 to allow all the user VLANs.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk pvid vlan 10
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 10 100 200 300 
    [*Switch ModuleA-10GE1/17/1] commit 
    [~Switch ModuleA-10GE1/17/1] quit

    # Add 10GE1/17/2, 10GE1/17/3, and 10GE1/17/4 to user VLANs 100, 200, and 300 respectively.

    [~Switch ModuleA] interface 10ge 1/17/2
    [~Switch ModuleA-10GE1/17/2] port link-type hybrid 
    [*Switch ModuleA-10GE1/17/2] port hybrid pvid vlan 100
    [*Switch ModuleA-10GE1/17/2] port hybrid untagged vlan 100
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] interface 10ge 1/17/3
    [*Switch ModuleA-10GE1/17/3] port link-type hybrid
    [*Switch ModuleA-10GE1/17/3] port hybrid pvid vlan 200
    [*Switch ModuleA-10GE1/17/3] port hybrid untagged vlan 200
    [*Switch ModuleA-10GE1/17/3] quit
    [*Switch ModuleA] interface 10ge 1/17/4
    [*Switch ModuleA-10GE1/17/4] port link-type hybrid
    [*Switch ModuleA-10GE1/17/4] port hybrid pvid vlan 300
    [*Switch ModuleA-10GE1/17/4] port hybrid untagged vlan 300
    [*Switch ModuleA-10GE1/17/4] commit
    [~Switch ModuleA-10GE1/17/4] quit
    
    NOTE:

    On RouterA, to terminate VLAN packets on the interface connected to SwitchA, configure a sub-interface on this interface to terminate VLAN 10, VLAN 100, VLAN 200, and VLAN 300.

  6. Verify the configuration. View information about the multicast VLAN and user VLANs on Switch ModuleA.

    [~Switch ModuleA] display multicast vlan mvlan
     Total: 1                                                        
     multicast-vlan     user-vlan number     snooping-state          
     ----------------------------------------------------------------
                 10                   3      IGMP Enable      
    [~Switch ModuleA] display multicast vlan user-vlan 
     Total: 3                                                              
     user-vlan  snooping-state  multicast-vlan  snooping-state
     -----------------------------------------------------------------------------  
           100  IGMP Enable                10   IGMP Enable 
           200  IGMP Enable                10   IGMP Enable 
           300  IGMP Enable                10   IGMP Enable 

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 100 200 300
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     multicast vlan enable
     multicast vlan user-vlan 100 200 300 
    #
    vlan 100
     igmp snooping enable
    #
    vlan 200
     igmp snooping enable
    #
    vlan 300
     igmp snooping enable
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10 100 200 300
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface 10GE1/17/4
     port link-type hybrid
     port hybrid pvid vlan 300
     port hybrid untagged vlan 300
    #
    return
    

Example for Configuring Interface-based Multicast VLAN Replication

Networking Requirements

As shown in Figure 8-122, 10GE1/17/1 of the Switch ModuleA is connected to the Router. 10GE1/17/2 provides services for ISP1, and 10GE1/17/3 provides services for ISP2. ISP1 and ISP2 use multicast VLAN 2 and VLAN 3 respectively to provide multicast services for users. 10GE1/17/2 and 10GE1/17/3 have the same user VLAN (VLAN 10).

To protect interests of the ISPs and ensure that multicast packets of each ISP are sent only to users of the ISP, the interface-based multicast VLAN replication is required. After the configuration is complete, multicast data of an ISP will be sent only to the interface connected to the ISP.

Figure 8-122 Configuring interface-based multicast VLAN replication

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable IGMP snooping in the system view.
  2. Create user VLAN 10 and enable IGMP snooping in the user VLAN.
  3. Create multicast VLANs 2 and 3 and enable IGMP snooping in the multicast VLANs.
  4. Bind user VLAN 10 to multicast VLANs on 10GE1/17/2 and 10GE1/17/3 respectively.
  5. Add the network-side interface and user-side interfaces to VLANs.

Procedure

  1. Create user VLAN 10 and enable IGMP snooping in the user VLAN.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] igmp snooping enable
    [*Switch ModuleA] vlan 10
    [*Switch ModuleA-vlan10] igmp snooping enable
    [*Switch ModuleA-vlan10] commit
    [~Switch ModuleA-vlan10] quit

  2. Create multicast VLANs 2 and 3 and enable IGMP snooping in the multicast VLANs.

    [~Switch ModuleA] vlan 2
    [*Switch ModuleA-vlan2] igmp snooping enable
    [*Switch ModuleA-vlan2] quit
    [*Switch ModuleA] vlan 3
    [*Switch ModuleA-vlan3] igmp snooping enable
    [*Switch ModuleA-vlan3] commit
    [~Switch ModuleA-vlan3] quit

  3. Bind user VLAN 10 to multicast VLANs on 10GE1/17/2 and 10GE1/17/3 respectively.

    [~Switch ModuleA] interface 10ge 1/17/2
    [~Switch ModuleA-10GE1/17/2] multicast layer-2 bind vlan 10 mvlan 2
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] interface 10ge 1/17/3
    [*Switch ModuleA-10GE1/17/3] multicast layer-2 bind vlan 10 mvlan 3
    [*Switch ModuleA-10GE1/17/3] commit
    [~Switch ModuleA-10GE1/17/3] quit

  4. Add 10GE1/17/1 to the multicast VLANs. Add 10GE1/17/2 and 10GE1/17/3 to the user VLAN.

    # Add 10GE1/17/1 to multicast VLANs 2 and 3 as a trunk interface.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 2 3 
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit

    # Add 10GE1/17/2 and 10GE1/17/3 respectively to user VLAN 10 as hybrid interfaces.

    [~Switch ModuleA] interface 10ge 1/17/2
    [~Switch ModuleA-10GE1/17/2] port link-type hybrid 
    [*Switch ModuleA-10GE1/17/2] port hybrid pvid vlan 10
    [*Switch ModuleA-10GE1/17/2] port hybrid untagged vlan 10 
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] interface 10ge 1/17/3
    [*Switch ModuleA-10GE1/17/3] port link-type hybrid 
    [*Switch ModuleA-10GE1/17/3] port hybrid pvid vlan 10
    [*Switch ModuleA-10GE1/17/3] port hybrid untagged vlan 10 
    [*Switch ModuleA-10GE1/17/3] commit
    [~Switch ModuleA-10GE1/17/3] quit

  5. Verify the configuration.

    Run the display multicast layer-2 bind command on Switch ModuleA to view binding between the user VLAN and multicast VLANs.

    [~Switch ModuleA] display multicast layer-2 bind
     ------------------------------------------------------------------- 
     Port                          Startvlan        Endvlan        Mvlan
     ------------------------------------------------------------------- 
     10GE1/17/2                           10             --            2
     10GE1/17/3                           10             --            3
     ------------------------------------------------------------------- 
     Total Table(s) : 2

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 2 to 3 10
    #
    igmp snooping enable
    #
    vlan 2
     igmp snooping enable
    #
    vlan 3
     igmp snooping enable
    #
    vlan 10
     igmp snooping enable
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     multicast layer-2 bind vlan 10 mvlan 2
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     multicast layer-2 bind vlan 10 mvlan 3
    #
    return
    
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 58899

Downloads: 3621

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next