No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 13

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides examples to illustrate how to configure multicast static routes and multicast load splitting on a multicast network.

Example for Configuring a Multicast Static Route to Change the RPF Route

Networking Requirements

As shown in Figure 8-94, SwitchA, SwitchB, and SwitchC run OSPF to implement IP interworking, and switch interfaces use PIM-SM to provide multicast services. Data sent from the multicast source (Source) is forwarded to the receiver host (Receiver) through SwitchA and SwitchB. The link between SwitchA and SwitchB transmits unicast and multicast services simultaneously. To reduce the loads on this link, multicast data needs to be transmitted along the path SwitchA->SwitchC->SwitchB.

Figure 8-94 Configuring a static route to change the RPF route

Configuration Roadmap

The RPF interface used to receive multicast data can be changed by configuring a multicast static route. After the RPF route is changed, multicast and unicast services are transmitted through different links so that the load on a single link is reduced. The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces and configure a unicast routing protocol (OSPF in this example) on each switch. Multicast routing protocols depend on unicast routing protocols.

  2. Enable multicast routing on all switches and PIM-SM on all Layer 3 interfaces. Configure an interface as a C-BSR and C-RP. Enable IGMP on the interface connected to the network segment of the receiver host. After these basic multicast functions are configured, the switches can establish a multicast distribution tree using default parameter settings. Then multicast data can be forwarded to Receiver along the multicast distribution tree.

  3. Configure a multicast RPF static route on Switch ModuleB and specify Switch ModuleC as the RPF neighbor.

Procedure

  1. Configure IP addresses for interfaces and configure OSPF on each switch.

    # Create VLANs and add Layer 2 physical interfaces to VLANs on the switches. (The configurations of the other switches are similar to the configuration of Switch ModuleB.)

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 10 40 50
    [*SwitchB] interface 10ge 1/17/1
    [*SwitchB-10GE1/17/1] port link-type trunk
    [*SwitchB-10GE1/17/1] port trunk allow-pass vlan 10
    [*SwitchB-10GE1/17/1] quit
    [*SwitchB] interface 10ge 1/17/2
    [*SwitchB-10GE1/17/2] port link-type trunk
    [*SwitchB-10GE1/17/2] port trunk allow-pass vlan 40
    [*SwitchB-10GE1/17/2] quit
    [*SwitchB] interface 10ge 1/17/3
    [*SwitchB-10GE1/17/3] port default vlan 50
    [*SwitchB-10GE1/17/3] quit
    [*SwitchB] commit
    

    # Configure IP addresses and masks for Layer 3 VLANIF interfaces on the switches. (The configurations of the other switches are similar to the configuration of Switch ModuleB.)

    [~SwitchB] interface vlanif 10
    [*SwitchB-Vlanif10] ip address 9.1.1.2 24
    [*SwitchB-Vlanif10] quit
    [*SwitchB] interface vlanif 40
    [*SwitchB-Vlanif40] ip address 13.1.1.1 24
    [*SwitchB-Vlanif40] quit
    [*SwitchB] interface vlanif 50
    [*SwitchB-Vlanif50] ip address 7.1.1.1 24
    [*SwitchB-Vlanif50] quit
    [*SwitchB] commit
    

    # Configure OSPF on the switches. (The configurations of the other switches are similar to the configuration of Switch ModuleB.)

    [~SwitchB] ospf
    [*SwitchB-ospf-1] area 0
    [*SwitchB-ospf-1-area-0.0.0.0] network 7.1.1.0 0.0.0.255
    [*SwitchB-ospf-1-area-0.0.0.0] network 9.1.1.0 0.0.0.255
    [*SwitchB-ospf-1-area-0.0.0.0] network 13.1.1.0 0.0.0.255
    [*SwitchB-ospf-1-area-0.0.0.0] quit
    [*SwitchB-ospf-1] quit
    [*SwitchB] commit

  2. Enable multicast routing on all switches, PIM-SM on all Layer 3 interfaces, and IGMP on the interface connected to the network segment of the receiver host.

    # Enable multicast routing on all the switches and enable PIM-SM on all Layer 3 interfaces. Enable IGMP on the interface connected to the network segment of the receiver host. (The PIM-SM configurations on the other switches are similar to the PIM-SM configuration on Switch ModuleB.)

    [~SwitchB] multicast routing-enable
    [*SwitchB] interface vlanif 10
    [*SwitchB-Vlanif10] pim sm
    [*SwitchB-Vlanif10] quit
    [*SwitchB] interface vlanif 40
    [*SwitchB-Vlanif40] pim sm
    [*SwitchB-Vlanif40] quit
    [*SwitchB] interface vlanif 50
    [*SwitchB-Vlanif50] pim sm
    [*SwitchB-Vlanif50] igmp enable 
    [*SwitchB-Vlanif50] quit
    [*SwitchB] commit

    # Configure VLANIF30 of SwitchC as a C-BSR and C-RP.

    [~SwitchC] pim
    [*SwitchC-pim] c-bsr vlanif 30
    [*SwitchC-pim] c-rp vlanif 30
    [*SwitchC-pim] commit
    [~SwitchC-pim] quit

    # Run the display multicast rpf-info command on Switch ModuleB to check the RPF route to Source. The following command output shows that the RPF route is originated from a unicast routing protocol, and the RPF neighbor is SwitchA.

    [~SwitchB] display multicast rpf-info 8.1.1.2
    VPN-Instance: public net
    RPF information about source: 8.1.1.2
         RPF interface: Vlanif10, RPF neighbor: 9.1.1.1
         Referenced route/mask: 8.1.1.0/24
         Referenced route type: unicast
         Route selection rule: preference-preferred
         Load splitting rule: disable

  3. Configure a multicast static route.

    # Configure a multicast RPF static route to Source on Switch ModuleB, and configure Switch ModuleC as the RPF neighbor.

    [~SwitchB] ip rpf-route-static 8.1.1.0 255.255.255.0 13.1.1.2
    [*SwitchB] commit

  4. Verify the configuration.

    # Run the display multicast rpf-info command on Switch ModuleB to check the RPF route to Source. The following information is displayed, indicating that the unicast RPF route has been replaced by the multicast static route and the RPF neighbor has changed to Switch ModuleC.

    [~SwitchB] display multicast rpf-info 8.1.1.2
    VPN-Instance: public net
    RPF information about source: 8.1.1.2
         RPF interface: Vlanif40, RPF neighbor: 13.1.1.2
         Referenced route/mask: 8.1.1.0/24
         Referenced route type: mstatic
         Route selection rule: preference-preferred
         Load splitting rule: disable 

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20 30
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 9.1.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif20
     ip address 8.1.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif30
     ip address 12.1.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port default vlan 20
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 8.1.1.0 0.0.0.255
      network 9.1.1.0 0.0.0.255
      network 12.1.1.0 0.0.0.255
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10 40 50
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 9.1.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 13.1.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif50
     ip address 7.1.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/17/3
     port default vlan 50
    #
    ospf 1
     area 0.0.0.0
      network 7.1.1.0 0.0.0.255
      network 9.1.1.0 0.0.0.255
      network 13.1.1.0 0.0.0.255
    #
    ip rpf-route-static 8.1.1.0 24 13.1.1.2
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 30 40
    #
    multicast routing-enable
    #
    interface Vlanif30
     ip address 12.1.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 13.1.1.2 255.255.255.0
     pim sm
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 12.1.1.0 0.0.0.255
      network 13.1.1.0 0.0.0.255
    #
    pim
     c-bsr Vlanif30
     c-rp Vlanif30
    #
    return

Example for Configuring Multicast Static Routes to Connect RPF Routes

Networking Requirements

As shown in Figure 8-95, SwitchB and SwitchC run OSPF to implement IP interworking, but they have no unicast route to SwitchA. Switch interfaces need to run PIM-SM to provide multicast services. The receiver host (Receiver) can receive data from Source1. Now Receiver needs to receive data from Source2.

Figure 8-95 Configuring multicast static routes to connect RPF routes

Configuration Roadmap

An RPF route to Source2 can be established on the path SwitchC->SwitchB->SwitchA by configuring multicast static routes on SwitchB and SwitchC. The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces of the switch moduleses. Configure OSPF on Switch ModuleB and Switch ModuleC but not on Switch ModuleA, so that Switch ModuleB and Switch ModuleC have no unicast route to Switch ModuleA.

  2. Enable multicast routing on all switches and PIM-SM on all Layer 3 interfaces. Configure an interface as a C-BSR and C-RP. Enable IGMP on the interface connected to the network segment of the receiver host. After these basic multicast functions are configured, the switches can establish a multicast distribution tree using default parameter settings. Then multicast data can be forwarded to Receiver along the multicast distribution tree.

  3. Configure multicast static routes to Source2 on SwitchB and SwitchC.

Procedure

  1. Configure IP addresses for interfaces and configure OSPF on each switch.

    # Create VLANs and add Layer 2 physical interfaces to VLANs on the switches. (The configurations of the other switches are similar to the configuration of Switch ModuleB.)

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 13 20 40
    [*SwitchB] interface 10ge 1/17/1
    [*SwitchB-10GE1/17/1] port link-type trunk
    [*SwitchB-10GE1/17/1] port trunk allow-pass vlan 20
    [*SwitchB-10GE1/17/1] quit
    [*SwitchB] interface 10ge 1/17/2
    [*SwitchB-10GE1/17/2] port default vlan 13
    [*SwitchB-10GE1/17/2] quit
    [*SwitchB] interface 10ge 1/17/3
    [*SwitchB-10GE1/17/3] port link-type trunk
    [*SwitchB-10GE1/17/3] port trunk allow-pass vlan 40
    [*SwitchB-10GE1/17/3] quit
    [*SwitchB] commit
    

    # Configure IP addresses and masks for Layer 3 VLANIF interfaces on the switches. (The configurations of the other switches are similar to the configuration of Switch ModuleB.)

    [~SwitchB] interface vlanif 13
    [*SwitchB-Vlanif13] ip address 10.1.3.1 24
    [*SwitchB-Vlanif13] quit
    [*SwitchB] interface vlanif 20
    [*SwitchB-Vlanif20] ip address 10.1.2.2 24
    [*SwitchB-Vlanif20] quit
    [*SwitchB] interface vlanif 40
    [*SwitchB-Vlanif40] ip address 10.1.4.1 24
    [*SwitchB-Vlanif40] quit
    [*SwitchB] commit
    

    # Configure OSPF on Switch ModuleB and Switch ModuleC. (The configuration of Switch ModuleC is similar to the configuration of Switch ModuleB.)

    [~SwitchB] ospf
    [*SwitchB-ospf-1] area 0
    [*SwitchB-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [*SwitchB-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [*SwitchB-ospf-1-area-0.0.0.0] quit
    [*SwitchB-ospf-1] quit
    [*SwitchB] commit

  2. Enable multicast routing on all switches, PIM-SM on all Layer 3 interfaces, and IGMP on the interface connected to the network segment of the receiver host.

    # On SwitchA, enable multicast routing globally and enable PIM-SM on the Layer 3 interfaces. (The configuration of SwitchB is similar to the configuration of SwitchA.)

    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 11
    [*SwitchA-Vlanif11] pim sm
    [*SwitchA-Vlanif11] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] pim sm
    [*SwitchA-Vlanif40] quit
    [*SwitchA] commit
    

    # On SwitchC, enable multicast routing globally, enable PIM-SM on Layer 3 interfaces, and enable IGMP on the interface connected to the network segment of the receiver host.

    [~SwitchC] multicast routing-enable
    [*SwitchC] interface vlanif 20
    [*SwitchC-Vlanif20] pim sm
    [*SwitchC-Vlanif20] quit
    [*SwitchC] interface vlanif 12
    [*SwitchC-Vlanif12] pim sm
    [*SwitchC-Vlanif12] igmp enable
    [*SwitchC-Vlanif12] quit
    [*SwitchC] commit
    

    # Configure VLANIF20 as a C-BSR and C-RP on SwitchB.

    [~SwitchB] pim
    [*SwitchB-pim] c-bsr vlanif 20
    [*SwitchB-pim] c-rp vlanif 20
    [*SwitchB-pim] commit
    [~SwitchB-pim] quit
    

    # Source1 (10.1.3.2/24) and Source2 (10.1.5.2/24) send multicast data to group G (225.1.1.1). After Receiver joins group G, it receives the multicast data sent by Source1 but cannot receive the multicast data sent by Source2.

    # Run the display multicast rpf-info 10.1.5.2 command on SwitchB and SwitchC. No information is displayed, indicating that SwitchB and SwitchC have no RPF route to Source2.

  3. Configure multicast static routes.

    # Configure a multicast RPF static route to Source2 on SwitchB, and configure SwitchA as the RPF neighbor.

    [~SwitchB] ip rpf-route-static 10.1.5.0 255.255.255.0 10.1.4.2
    [*SwitchB] commit

    # Configure a multicast RPF static route to Source2 on SwitchC, and configure SwitchB as the RPF neighbor.

    [~SwitchC] ip rpf-route-static 10.1.5.0 255.255.255.0 10.1.2.2
    [*SwitchC] commit

  4. Verify the configuration.

    # Run the display multicast rpf-info 10.1.5.2 command on SwitchB and SwitchC to check the RPF route to Source2. The following information is displayed:

    [~SwitchB] display multicast rpf-info 10.1.5.2
    VPN-Instance: public net
    RPF information about source: 10.1.5.2
         RPF interface: Vlanif40, RPF neighbor: 10.1.4.2
         Referenced route/mask: 10.1.5.0/24
         Referenced route type: mstatic
         Route selecting rule: preference-preferred
         Load splitting rule: disable 
    
    
    [~SwitchC] display multicast rpf-info 10.1.5.2
    VPN-Instance: public net
    RPF information about source 10.1.5.2:
         RPF interface: Vlanif20, RPF neighbor: 10.1.2.2
         Referenced route/mask: 10.1.5.0/24
         Referenced route type: mstatic
         Route selection rule: preference-preferred
         Load splitting rule: disable 

    # Run the display pim routing-table command on SwitchC to check the PIM routing table. SwitchC has multicast entries of Source2, indicating that Receiver can receive multicast data from Source2.

    [~SwitchC] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 2 (S, G) entries
    
     (*, 225.1.1.1)
         RP: 10.1.2.2
         Protocol: pim-sm, Flag: WC
         UpTime: 03:54:19
         Upstream interface: Vlanif20
             Upstream neighbor: 10.1.2.2
             RPF prime neighbor: 10.1.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif12
                 Protocol: pim-sm, UpTime: 01:38:19, Expires: never
    
    (10.1.3.2, 225.1.1.1)     
         RP: 10.1.2.2
         Protocol: pim-sm, Flag: ACT
         UpTime: 00:00:44
         Upstream interface: Vlanif20
             Upstream neighbor: 10.1.2.2
             RPF prime neighbor: 10.1.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
              1: Vlanif12
                  Protocol: pim-sm, UpTime: 00:00:44, Expires: never
    
    (10.1.5.2, 225.1.1.1)     
         RP: 10.1.2.2
         Protocol: pim-sm, Flag: ACT
         UpTime: 00:00:44
         Upstream interface: Vlanif20
             Upstream neighbor: 10.1.2.2
             RPF prime neighbor: 10.1.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
              1: Vlanif12
                  Protocol: pim-sm, UpTime: 00:00:44, Expires: never
    

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    multicast routing-enable
    #
    vlan batch 11 40
    #
    interface Vlanif11
     ip address 10.1.5.1 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 10.1.4.2 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 11
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    return 
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 13 20 40
    #
    multicast routing-enable
    #
    interface Vlanif13
     ip address 10.1.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 10.1.4.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/17/2
     port default vlan 13
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
    #
    ip rpf-route-static 10.1.5.0 24 10.1.4.2
    #
    pim
     c-bsr Vlanif20
     c-rp Vlanif20
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 12 20
    #
    multicast routing-enable
    #
    interface Vlanif12
     ip address 10.1.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/17/2
     port default vlan 12
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
    #
    ip rpf-route-static 10.1.5.0 24 10.1.2.2
    #
    return 

Example for Configuring Multicast Load Splitting

Networking Requirements

As shown in Figure 8-96, Switch ModuleE connects to HostA and has three equal-cost routes to the multicast source (Source). According to the default RPF check policy, Switch ModuleE will select one of equal-cost routes to transmit multicast data. When the rate of multicast traffic is high, the network may be congested, degrading the quality of multicast services. To ensure the quality of multicast services, configure multicast load splitting so that multicast data can be transmitted through multiple equal-cost routes.

Figure 8-96 Networking diagram of multicast load splitting

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces on the switches.

  2. Configure a unicast routing protocol (IS-IS in this example) to implement interworking among all the switches and ensure that route costs are the same.

  3. Enable multicast routing on all the switches and enable PIM-SM on all the Layer 3 interfaces. Configure the loopback interface on SwitchA as a C-BSR and C-RP.

  4. On SwitchE, configure stable-preferred multicast load splitting to ensure stable transmission of multicast services.

  5. On SwitchE, configure static multicast groups on the interface connected to the network segment of HostA, because HostA needs to receive data of these groups for a long time.

Procedure

  1. Configure IP addresses for interfaces on the switches.

    # Create VLANs and add Layer 2 physical interfaces to VLANs on the switches. (Configurations of the other switches are similar to the configuration of SwitchA.)

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20 30 40
    [*SwitchA] interface 10ge 1/17/4
    [*SwitchA-10GE1/17/4] port default vlan 10
    [*SwitchA-10GE1/17/4] quit
    [*SwitchA] interface 10ge 1/17/1
    [*SwitchA-10GE1/17/1] port link-type trunk
    [*SwitchA-10GE1/17/1] port trunk allow-pass vlan 20
    [*SwitchA-10GE1/17/1] quit
    [*SwitchA] interface 10ge 1/17/2
    [*SwitchA-10GE1/17/2] port link-type trunk
    [*SwitchA-10GE1/17/2] port trunk allow-pass vlan 30
    [*SwitchA-10GE1/17/2] quit
    [*SwitchA] interface 10ge 1/17/3
    [*SwitchA-10GE1/17/3] port link-type trunk
    [*SwitchA-10GE1/17/3] port trunk allow-pass vlan 40
    [*SwitchA-10GE1/17/3] quit
    [*SwitchA] commit
    

    # Configure IP addresses and masks for Layer 3 interfaces on the switches. (Configurations of the other switches are similar to the configuration of SwitchA.)

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 10.110.1.2 24
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ip address 192.168.1.1 24
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ip address 192.168.2.1 24
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] ip address 192.168.3.1 24
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] ip address 1.1.1.1 32
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit
    

  2. Configure IS-IS to implement interworking among all the switches and ensure that route costs are the same.

    # Configure SwitchA. (Configurations of the other switches are similar to the configuration of SwitchA.)

    [~SwitchA] isis
    [*SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [*SwitchA-isis-1] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] isis enable
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] isis enable
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] isis enable
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] isis enable
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] isis enable
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit
    

  3. Enable multicast routing on all the switches and enable PIM-SM on all the Layer 3 interfaces.

    # Configure SwitchA. (Configurations of the other switches are similar to the configuration of SwitchA.)

    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] pim sm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] pim sm
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback 0
    [*SwitchA-LoopBack0] pim sm
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

  4. Configure a C-BSR and C-RP on SwitchA.

    # Configure Loopback0 on SwitchA as a C-BSR and C-RP.

    [~SwitchA] pim
    [*SwitchA-pim] c-bsr loopback 0
    [*SwitchA-pim] c-rp loopback 0
    [*SwitchA-pim] commit
    [~SwitchA-pim] quit

  5. Configure stable-preferred multicast load splitting on SwitchE.

    [~SwitchE] multicast load-splitting stable-preferred
    [*SwitchE] commit

  6. Configure static multicast groups on the interface of SwitchE connected to the network segment of HostA.

    # Configure static multicast groups 225.1.1.1 to 225.1.1.3 on VLANIF140.

    [~SwitchE] interface Vlanif140
    [~SwitchE-Vlanif140] igmp static-group 225.1.1.1 inc-step-mask 32 number 3
    [*SwitchE-Vlanif140] commit
    [~SwitchE-Vlanif140] quit

  7. Verify the configuration of stable-preferred multicast load splitting.

    # Source (10.110.1.1/24) sends multicast data to multicast groups 225.1.1.1 to 225.1.1.3. HostA can receive multicast data from Source. Check brief information about the PIM routing table on SwitchE.

    [~SwitchE] display pim routing-table brief
     VPN-Instance: public net
     Total 3 (*, G) entries, 3 (S, G) entries
     Entries                                Upstream interface       NDwnstrms
     (*, 225.1.1.1)                         Vlanif100                 1
     (10.110.1.1, 225.1.1.1)                Vlanif100                 1
     (*, 225.1.1.2)                         Vlanif80                  1
     (10.110.1.1, 225.1.1.2)                Vlanif80                  1
     (*, 225.1.1.3)                         Vlanif60                  1
     (10.110.1.1, 225.1.1.3)                Vlanif60                  1

    (*, G) and (S, G) entries are evenly distributed on the three equal-cost routes. The upstream interfaces of the routes are VLANIF100, VLANIF80, and VLANIF60 respectively.

    The load splitting algorithm processes (*, G) and (S, G) entries separately using the same rule.

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20 30 40
    #
    multicast routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 10.110.1.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif20
     ip address 192.168.1.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif30
     ip address 192.168.2.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif40
     ip address 192.168.3.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/17/4
     port default vlan 10
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
     isis enable 1
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 20 60
    #
    multicast routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif20
     ip address 192.168.1.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif60
     ip address 192.168.4.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 30 80
    #
    multicast routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif30
     ip address 192.168.2.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif80
     ip address 192.168.5.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    vlan batch 40 100
    #
    multicast routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0004.00
    #
    interface Vlanif40
     ip address 192.168.3.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif100
     ip address 192.168.6.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • Configuration file of SwitchE

    #
    sysname SwitchE
    #
    vlan batch 60 80 100 140
    #
    multicast routing-enable
    multicast load-splitting stable-preferred
    #
    isis 1
     network-entity 10.0000.0000.0005.00
    #
    interface Vlanif60
     ip address 192.168.4.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif80
     ip address 192.168.5.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif100
     ip address 192.168.6.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif140
     ip address 10.110.2.2 255.255.255.0
     pim sm
     igmp static-group 225.1.1.1 inc-step-mask 0.0.0.1 number 3
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/17/4
     port default vlan 140
    #
    return
Translation
Download
Updated: 2019-12-13

Document ID: EDOC1000041694

Views: 60746

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next