No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides configuration examples including networking requirements and configuration roadmap.

Example for Configuring ARP

Networking Requirements
As shown in Figure 6-19, 10GE1/17/1 of the switch connects to hosts through the LAN Switch (LSW). 10GE1/17/2 connects the Router and visit the server through the Internet. Requirements:
  • 10GE1/17/1 and 10GE1/17/2 should belong to VLAN2 and VLAN3 respectively.
  • Dynamic ARP parameters should be configured for VLANIF2 of the Switch so that packets are transmitted correctly regardless of network typology change.
  • A static ARP entry should be configured on 10GE1/17/2 of the switch to ensure secure communication with the server and prevent illegal ARP packets. The IP address of the router should be 10.2.2.3 and the corresponding MAC address is 00e0-fc01-0000.
Figure 6-19 Networking diagram for configuring ARP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create VLANs and add interfaces to the VLANs.
  2. Set dynamic ARP parameters for the user-side VLANIF interface.
  3. Configure a static ARP entry.

Procedure

  1. Create VLANs and add interfaces to the VLANs.

    # Create VLAN2 and VLAN3.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan batch 2 3
    [*Switch] commit
    

    # Add 10GE1/17/1 to VLAN2 and 10GE1/17/2 to VLAN3.

    [~Switch] interface 10ge 1/17/1
    [~Switch-10GE1/17/1] port link-type trunk
    [*Switch-10GE1/17/1] port trunk allow-pass vlan 2
    [*Switch-10GE1/17/1] quit
    [*Switch] interface 10ge 1/17/2
    [*Switch-10GE1/17/2] port link-type trunk
    [*Switch-10GE1/17/2] port trunk allow-pass vlan 3
    [*Switch-10GE1/17/2] quit
    [*Switch] commit
    

  2. Set dynamic ARP parameters for the VLANIF interface.

    # Create VLANIF2.

    [~Switch] interface vlanif 2

    # Configure an IP address for VLANIF2.

    [*Switch-Vlanif2] ip address 2.2.2.2 255.255.255.0

    # Set the aging time of ARP entries to 60s.

    [*Switch-Vlanif2] arp timeout 60

    # Set the number of probes to ARP entries to 2.

    [*Switch-Vlanif2] arp detect times 2
    [*Switch-Vlanif2] quit
    [*Switch] commit
    

  3. Configure a static ARP entry.

    # Create VLANIF3.

    [~Switch] interface vlanif 3

    # Configure an IP address for VLANIF3.

    [*Switch-Vlanif3] ip address 10.2.2.2 255.255.255.0
    [*Switch-Vlanif3] quit
    [*Switch] commit
    

    # Configure a static ARP entry with IP address 10.2.2.3, MAC address 00e0-fc01-0000, VLAN ID 3, and outbound interface 10GE1/17/2.

    [~Switch] arp static 10.2.2.3 00e0-fc01-0000 vlan 3 interface 10ge 1/17/2
    [*Switch] commit
    [~Switch] quit

  4. # Verify the configuration.

    # Run the display current-configuration command to check the aging time, number of probes, and ARP mapping entries.

    <Switch> display current-configuration | include arp
     arp detect times 2
     arp timeout 60
    arp static 10.2.2.3 00e0-fc01-0000 vlan 3 interface 10GE1/17/2

Configuration File

Configuration file of Switch.

#
sysname Switch
#
vlan batch 2 to 3
#
interface Vlanif2
 ip address 2.2.2.2 255.255.255.0
 arp detect times 2
 arp timeout 60
#
interface Vlanif3
 ip address 10.2.2.2 255.255.255.0
#
interface 10GE1/17/1
 port link-type trunk
 port trunk allow-pass vlan 2
#
interface 10GE1/17/2
 port link-type trunk
 port trunk allow-pass vlan 3
#
arp static 10.2.2.3 00e0-fc01-0000 vlan 3 interface 10GE1/17/2
#
return

Example for Configuring Routed Proxy ARP

Networking Requirements

In Figure 6-20, Ethernet interfaces 10GE1/17/1 and 10GE1/17/2 connect to two LANs respectively. The two LANs are at the same network segment 172.16.0.0/16. ServerA and ServerB have no default gateway. Routed proxy ARP is required to be configured on the switch so that servers on two LANs can communicate.

Figure 6-20 Networking diagram for configuring routed proxy ARP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces.

  2. Enable routed proxy ARP on interfaces.

Procedure

  1. Create VLAN2 and add 10GE1/17/2 to VLAN2.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan 2
    [*Switch-vlan2] quit
    [*Switch] interface 10ge 1/17/2
    [*Switch-10GE1/17/2] port default vlan 2
    [*Switch-10GE1/17/2] quit
    [*Switch] commit

  2. Create and configure VLANIF2.

    [~Switch] interface vlanif 2
    [*Switch-Vlanif2] ip address 172.16.1.1 255.255.255.0

  3. Enable routed proxy ARP on VLANIF2.

    [*Switch-Vlanif2] arp proxy enable
    [*Switch-Vlanif2] quit
    [*Switch] commit

  4. Create VLAN3 and add 10GE1/17/1 to VLAN3.

    [~Switch] vlan batch 3
    [*Switch] interface 10ge 1/17/1
    [*Switch-10GE1/17/1] port default vlan 3
    [*Switch-10GE1/17/1] quit
    [*Switch] commit

  5. Create and configure VLANIF3.

    [~Switch] interface vlanif 3
    [*Switch-Vlanif3] ip address 172.16.2.1 255.255.255.0

  6. Enable routed proxy ARP on VLANIF3.

    [*Switch-Vlanif3] arp proxy enable
    [*Switch-Vlanif3] quit
    [*Switch] commit

  7. Configure servers.

    # Configure IP address 172.16.1.2/16 for ServerA.

    # Configure IP address 172.16.2.2/16 for ServerB.

  8. Verify the configuration.

    # Ping ServerB from ServerA. ServerA can ping ServerB successfully.

Configuration File

Configuration file of the switch

#
sysname Switch
#
vlan batch 2 to 3
#
interface Vlanif2
 ip address 172.16.1.1 255.255.255.0
 arp proxy enable
#
interface Vlanif3
 ip address 172.16.2.1 255.255.255.0
 arp proxy enable
#
interface 10GE1/17/1
 port default vlan 3 
#
interface 10GE1/17/2
 port default vlan 2 
#
return

Example for Configuring Intra-VLAN Proxy ARP

Networking Requirements
In Figure 6-21, 10GE1/17/1 and 10GE1/17/2 belong to sub-VLAN2. VLAN2 is a sub-VLAN of super-VLAN3. Requirements:
  • ServerA and ServerB in VLAN2 are isolated at Layer 2.
  • ServerA and ServerB can communicate at Layer 3 using Intra-VLAN proxy ARP.

The IP address of the VLANIF interface corresponding to the super-VLAN is 10.10.10.1 and the mask is 255.255.255.0.

Figure 6-21 Networking diagram for configuring intra-VLAN proxy ARP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create and configure a super-VLAN and sub-VLAN.
  2. Add interfaces to the sub-VLAN.
  3. Create a VLANIF interface corresponding to the super-VLAN and configure an IP address for the VLANIF interface.
  4. Enable intra-VLAN proxy ARP on the VLANIF interface.

Procedure

  1. Configure a super-VLAN and sub-VLAN.

    # Configure sub-VLAN2.
    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan 2
    [*Switch-vlan2] commit
    [~Switch-vlan2] quit
    # Enable interface isolation on 10GE1/17/1 and 10GE1/17/2.
    [~Switch] interface 10ge 1/17/1
    [~Switch-10GE1/17/1] port-isolate enable group 1
    [*Switch-10GE1/17/1] quit
    [*Switch] interface 10ge 1/17/2
    [*Switch-10GE1/17/2] port-isolate enable group 1
    [*Switch-10GE1/17/2] quit
    [*Switch] commit
    # Add 10GE1/17/1 and 10GE1/17/2 to sub-VLAN2.
    [~Switch] interface 10ge 1/17/1
    [~Switch-10GE1/17/1] port default vlan 2
    [*Switch-10GE1/17/1] quit
    [*Switch] interface 10ge 1/17/2
    [*Switch-10GE1/17/2] port default vlan 2
    [*Switch-10GE1/17/2] quit
    [*Switch] commit
    # Configure super-VLAN3 and add sub-VLAN2 to super-VLAN3.
    [~Switch] vlan 3
    [*Switch-vlan3] aggregate-vlan
    [*Switch-vlan3] access-vlan 2
    [*Switch-vlan3] quit
    [*Switch] commit

  2. Create and configure VLANIF3.

    # Create VLANIF3.

    [~Switch] interface vlanif 3

    # Configure an IP address for VLANIF3.

    [*Switch-Vlanif3] ip address 10.10.10.1 24

  3. Enable intra-VLAN proxy ARP on VLANIF3.

    [*Switch-Vlanif3] arp proxy intra-vlan enable
    [*Switch-Vlanif3] commit
    [~Switch-Vlanif3] quit
    [~Switch] quit

  4. Configure servers.

    # Configure IP address 10.10.10.2/24 for ServerA.

    # Configure IP address 10.10.10.3/24 for ServerB.

  5. Verify the configuration.

    # Run the display arp command to check all ARP entries.

    <Switch> display arp
    ARP Entry Types: D - Dynamic, S - Static, I - Interface                                                                             
    EXP: Expire-time
                                                                                                                                        
    IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE                                                        
    ------------------------------------------------------------------------------                                                      
    10.10.10.1      0018-2000-0083        I         Vlanif3                                                                             
    10.10.10.3      00e0-fc00-0003   20   D/2       10GE1/17/1                                                                           
    10.10.10.2      00e0-fc00-0002   20   D/2       10GE1/17/2                                                                           
    ------------------------------------------------------------------------------                                                      
    Total:3          Dynamic:2       Static:0    Interface:1  

    # ServerA and ServerB can ping through each other.

Configuration File

Configuration file of the switch

#
sysname Switch
#
vlan batch 2 to 3 
#
vlan 3
 aggregate-vlan
 access-vlan 2
#
interface Vlanif3
 ip address 10.10.10.1 255.255.255.0
 arp proxy intra-vlan enable
#
interface 10GE1/17/1
 port default vlan 2
 port-isolate enable group 1
#
interface 10GE1/17/2
 port default vlan 2
 port-isolate enable group 1
#
return

Example for Configuring Inter-VLAN Proxy ARP

Networking Requirements
As shown in Figure 6-22, VLAN2 and VLAN3 compose super-VLAN4. Requirements:
  • Servers in VLAN2 and VLAN3 cannot ping each other.
  • Servers in VLAN2 and VLAN3 can communicate after inter-VLAN proxy ARP is configured.
Figure 6-22 Networking diagram for configuring inter-VLAN proxy ARP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a super-VLAN and sub-VLANs.
  2. Add interfaces to the sub-VLANs.
  3. Create a VLANIF interface corresponding to the super-VLAN and configure an IP address for the VLANIF interface.
  4. Enable inter-VLAN proxy ARP.

Procedure

  1. Configure a super-VLAN and sub-VLANs.

    # Configure sub-VLAN2.
    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan 2
    [*Switch-vlan2] commit
    [~Switch-vlan2] quit
    # Add 10GE1/17/1 and 10GE1/17/2 to sub-VLAN2.
    [~Switch] interface 10ge 1/17/2
    [~Switch-10GE1/17/2] port default vlan 2
    [*Switch-10GE1/17/2] quit
    [*Switch] interface 10ge 1/17/1
    [*Switch-10GE1/17/1] port default vlan 2
    [*Switch-10GE1/17/1] quit
    [*Switch] commit
    # Create sub-VLAN3.
    [~Switch] vlan 3
    [*Switch-vlan3] commit
    [~Switch-vlan3] quit
    # Add 10GE1/17/3 and 10GE1/17/4 to sub-VLAN3.
    [~Switch] interface 10ge 1/17/3
    [*Switch-10GE1/17/3] port default vlan 3
    [*Switch-10GE1/17/3] quit
    [*Switch] interface 10ge 1/17/4
    [*Switch-10GE1/17/4] port default vlan 3
    [*Switch-10GE1/17/4] quit
    [*Switch] commit
    # Create super-VLAN4 and add sub-VLAN2 and sub-VLAN3 to super-VLAN4.
    [~Switch] vlan 4
    [*Switch-vlan4] aggregate-vlan
    [*Switch-vlan4] access-vlan 2
    [*Switch-vlan4] access-vlan 3
    [*Switch-vlan4] quit
    [*Switch] commit

  2. Create and configure VLANIF4.

    # Create VLANIF4.

    [~Switch] interface vlanif 4

    # Configure an IP address for VLANIF4.

    [*Switch-Vlanif4] ip address 10.10.10.1 24

  3. Enable inter-VLAN proxy ARP on VLANIF4.

    [*Switch-Vlanif4] arp proxy inter-vlan enable
    [*Switch-Vlanif4] quit
    [*Switch] commit
    [~Switch] quit

  4. Configure servers.

    # Configure IP address 10.10.10.2/24 for ServerA.

    # Configure IP address 10.10.10.3/24 for ServerB.

    # Configure IP address 10.10.10.4/24 for ServerC.

    # Configure IP address 10.10.10.5/24 for ServerD.

  5. Verify the configuration.

    # Run the display arp command to check all ARP entries.

    <Switch> display arp
    ARP Entry Types: D - Dynamic, S - Static, I - Interface                                                                             
    EXP: Expire-time
                                                                                                                                        
    IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE                                                        
    ------------------------------------------------------------------------------                                                      
    10.10.10.1      0018-2000-0083        I         Vlanif4                                                                             
    10.10.10.2      00e0-fc00-0002   19   D/2       10GE1/17/1                                                                           
    10.10.10.3      00e0-fc00-0003   19   D/2       10GE1/17/2                                                                           
    10.10.10.4      00e0-fc00-0004   19   D/3       10GE1/17/3                                                                           
    10.10.10.5      00e0-fc00-0005   19   D/3       10GE1/17/4                                                                           
    ------------------------------------------------------------------------------                                                      
    Total:5          Dynamic:4       Static:0    Interface:1  

    # Servers in VLAN2 and VLAN3 can ping each other.

Configuration File

Configuration file of the switch

#
sysname Switch
#
vlan batch 2 to 4 
#
vlan 4
 aggregate-vlan
 access-vlan 2 to 3
#
interface Vlanif4
 ip address 10.10.10.1 255.255.255.0
 arp proxy inter-vlan enable
#
interface 10GE1/17/1
 port default vlan 2
#
interface 10GE1/17/2
 port default vlan 2
#
interface 10GE1/17/3
 port default vlan 3
#
interface 10GE1/17/4
 port default vlan 3
#
return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 57526

Downloads: 3619

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next