No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 13

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides examples for configuring IP routing, including networking requirements and configuration roadmap.

Example for Configuring IPv4 FRR on the Public Network

Networking Requirements

As shown in Figure 7-129, OSPF is configured on Switch ModuleT, Switch ModuleA, and Switch ModuleC, and IS-IS is configured on Switch ModuleT, Switch ModuleB, and Switch ModuleC. OSPF routes have a higher priority than IS-IS routes. Therefore, link B is the backup link of link A. Traffic must be rapidly switched from link A to link B when a fault occurs on link A.

Figure 7-129 Networking diagram of configuring IPv4 FRR on the public network



Configuration Roadmap

Enable IPv4 FRR on the public network on Switch ModuleT so that traffic can be rapidly switched to link B when a fault occurs on link A.

Procedure

  1. Create VLANs and add interfaces to the VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleT
    [*HUAWEI] commit
    [~Switch ModuleT] vlan batch 10 20 30
    [*Switch ModuleT] interface 10ge 1/17/1
    [*Switch ModuleT-10GE1/17/1] port link-type trunk 
    [*Switch ModuleT-10GE1/17/1] port trunk allow-pass vlan 10
    [*Switch ModuleT-10GE1/17/1] quit
    [*Switch ModuleT] interface 10ge 1/17/2
    [*Switch ModuleT-10GE1/17/2] port link-type trunk 
    [*Switch ModuleT-10GE1/17/2] port trunk allow-pass vlan 20
    [*Switch ModuleT-10GE1/17/2] quit
    [*Switch ModuleT] interface 10ge 1/17/3
    [*Switch ModuleT-10GE1/17/3] port link-type trunk 
    [*Switch ModuleT-10GE1/17/3] port trunk allow-pass vlan 30
    [*Switch ModuleT-10GE1/17/3] quit
    [*Switch ModuleT] commit

    The configurations of Switch ModuleA, Switch ModuleB, and Switch ModuleC are similar to the configuration of Switch ModuleT, and are not mentioned here.

  2. Assign IPv4 addresses to VLANIF interfaces.

    [~Switch ModuleT] interface vlanif 10
    [*Switch ModuleT-Vlanif10] ip address 172.16.1.1 24
    [*Switch ModuleT-Vlanif10] quit
    [*Switch ModuleT] interface vlanif 20
    [*Switch ModuleT-Vlanif20] ip address 192.168.10.1 24
    [*Switch ModuleT-Vlanif20] quit
    [*Switch ModuleT] interface vlanif 30
    [*Switch ModuleT-Vlanif30] ip address 192.168.20.1 24
    [*Switch ModuleT-Vlanif30] quit
    [*Switch ModuleT] commit

    The configurations of Switch ModuleA, Switch ModuleB, and Switch ModuleC are similar to the configuration of Switch ModuleT, and are not mentioned here.

  3. Configure OSPF on Switch ModuleT, Switch ModuleA, and Switch ModuleC.

    # Configure Switch ModuleT.

    [~Switch ModuleT] ospf
    [*Switch ModuleT-ospf-1] area 0
    [*Switch ModuleT-ospf-1-area-0.0.0.0] network 172.16.1.0 0.0.0.255
    [*Switch ModuleT-ospf-1-area-0.0.0.0] network 192.168.10.0 0.0.0.255
    [*Switch ModuleT-ospf-1-area-0.0.0.0] commit
    [~Switch ModuleT-ospf-1-area-0.0.0.0] quit
    [~Switch ModuleT-ospf-1] quit

    # Configure Switch ModuleA.

    [~Switch ModuleA] ospf
    [*Switch ModuleA-ospf-1] area 0
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 192.168.10.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 192.168.11.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] commit
    [~Switch ModuleA-ospf-1-area-0.0.0.0] quit
    [~Switch ModuleA-ospf-1] quit

    # Configure Switch ModuleC.

    [~Switch ModuleC] ospf
    [*Switch ModuleC-ospf-1] area 0
    [*Switch ModuleC-ospf-1-area-0.0.0.0] network 172.17.1.0 0.0.0.255
    [*Switch ModuleC-ospf-1-area-0.0.0.0] network 192.168.11.0 0.0.0.255
    [*Switch ModuleC-ospf-1-area-0.0.0.0] commit
    [~Switch ModuleC-ospf-1-area-0.0.0.0] quit
    [~Switch ModuleC-ospf-1] quit

  4. Configure IS-IS on Switch ModuleT, Switch ModuleB, and Switch ModuleC.

    # Configure Switch ModuleT.

    [~Switch ModuleT] isis
    [*Switch ModuleT-isis-1] network-entity 10.0000.0000.0001.00
    [*Switch ModuleT-isis-1] quit
    [*Switch ModuleT] interface vlanif 10
    [*Switch ModuleT-Vlanif10] isis enable 1
    [*Switch ModuleT-Vlanif10] quit
    [*Switch ModuleT] interface vlanif 30
    [*Switch ModuleT-Vlanif30] isis enable 1
    [*Switch ModuleT-Vlanif30] commit
    [~Switch ModuleT-Vlanif30] return
    

    # Configure Switch ModuleB.

    [~Switch ModuleB] isis
    [*Switch ModuleB-isis-1] network-entity 10.0000.0000.0002.00
    [*Switch ModuleB-isis-1] quit
    [*Switch ModuleB] interface vlanif 30
    [*Switch ModuleB-Vlanif30] isis enable 1
    [*Switch ModuleB-Vlanif30] quit
    [*Switch ModuleB] interface vlanif 50
    [*Switch ModuleB-Vlanif50] isis enable 1
    [*Switch ModuleB-Vlanif50] commit
    [~Switch ModuleB-Vlanif50] quit
    

    # Configure Switch ModuleC.

    [~Switch ModuleC] isis
    [*Switch ModuleC-isis-1] network-entity 10.0000.0000.0003.00
    [*Switch ModuleC-isis-1] quit
    [*Switch ModuleC] interface vlanif 50
    [*Switch ModuleC-Vlanif50] isis enable 1
    [*Switch ModuleC-Vlanif50] quit
    [*Switch ModuleC] interface vlanif 60
    [*Switch ModuleC-Vlanif60] isis enable 1
    [*Switch ModuleC-Vlanif60] commit
    [~Switch ModuleC-Vlanif60] quit
    

  5. Check routing information.

    # Check the routes to destination 172.17.1.0 on Switch ModuleT.

    <Switch ModuleT> display ip routing-table 172.17.1.0 verbose
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Table : _public_
    Summary Count : 2 
    
    Destination: 172.17.1.0/24
         Protocol: OSPF            Process ID: 1
       Preference: 10                    Cost: 3
          NextHop: 192.168.10.2     Neighbour: 0.0.0.0
            State: Active Adv             Age: 00h00m07s
              Tag: 0                 Priority: low
            Label: NULL               QoSInfo: 0xa98ac7
       IndirectID: 0x40000041
     RelayNextHop: 0.0.0.0          Interface: Vlanif20
         TunnelID: 0x0                  Flags: D
    
    Destination: 172.17.1.0/24
         Protocol: ISIS-L1         Process ID: 1
       Preference: 15                    Cost: 30
          NextHop: 192.168.20.2     Neighbour: 0.0.0.0
            State: Inactive Adv           Age: 00h01m26s
              Tag: 0                 Priority: high
            Label: NULL               QoSInfo: 0xa98ac7
       IndirectID: 0x80000081
     RelayNextHop: 0.0.0.0          Interface: Vlanif30
         TunnelID: 0x0                  Flags: 

    The routing table contains two routes to 172.17.1.0/24. OSPF routes have a higher priority than IS-IS routes. Therefore, the route with next hop 192.168.10.2 is the optimal route.

  6. Enable IPv4 FRR on the public network.

    # Enable IPv4 FRR on the public network on Switch ModuleT.

    <Switch ModuleT> system-view
    [~Switch ModuleT] ip frr
    [*Switch ModuleT] commit

    # Check information about the backup outbound interface and backup next hop on Switch ModuleT.

    [Switch ModuleT] display ip routing-table 172.17.1.0 verbose
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Table : _public_
    Summary Count : 2 
    
    Destination: 172.17.1.0/24
         Protocol: OSPF            Process ID: 1
       Preference: 10                    Cost: 3
          NextHop: 192.168.10.2     Neighbour: 0.0.0.0
            State: Active Adv             Age: 00h01m36s
              Tag: 0                 Priority: low
            Label: NULL               QoSInfo: 0xa98ac7
       IndirectID: 0x40000041
     RelayNextHop: 0.0.0.0          Interface: Vlanif20
         TunnelID: 0x0                  Flags: D
        BkNextHop: 192.168.20.2   BkInterface: Vlanif30
          BkLabel: NULL           SecTunnelID: 0x0
     BkPETunnelID: 0x0        BkPESecTunnelID: 0x0
     BkIndirectID: 0x80000081
    
    Destination: 172.17.1.0/24
         Protocol: ISIS-L1         Process ID: 1
       Preference: 15                    Cost: 30
          NextHop: 192.168.20.2     Neighbour: 0.0.0.0
            State: Inactive Adv           Age: 00h02m55s
              Tag: 0                 Priority: high
            Label: NULL               QoSInfo: 0xa98ac7
       IndirectID: 0x80000081
     RelayNextHop: 0.0.0.0          Interface: Vlanif30
         TunnelID: 0x0                  Flags: 

    The routing table contains the backup outbound interface and backup next hop of the route to 172.17.1.0/24. The IS-IS route becomes the backup route.

Configuration Files

  • Configuration file of Switch ModuleT

    #
    sysname Switch ModuleT
    #
    vlan batch 10 20 30
    #
    ip frr
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 172.16.1.1 255.255.255.0 
     isis enable 1
    #
    interface Vlanif20
     ip address 192.168.10.1 255.255.255.0
    #
    interface Vlanif30
     ip address 192.168.20.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1 
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/17/3 
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 172.16.1.0 0.0.0.255
      network 192.168.10.0 0.0.0.255
    #
    return
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 20 40
    #
    interface Vlanif20
     ip address 192.168.10.2 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.11.2 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 192.168.10.0 0.0.0.255
      network 192.168.11.0 0.0.0.255
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 30 50
    #
    isis 1
     network-entity 10.0000.0000.0002.00 
    #
    interface Vlanif30
     ip address 192.168.20.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif50
     ip address 192.168.21.2 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 40 50 60
    #
    isis 1
     network-entity 10.0000.0000.0003.00 
    #
    interface Vlanif40
     ip address 192.168.11.1 255.255.255.0
    #
    interface Vlanif50
     ip address 192.168.21.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif60
     ip address 172.17.1.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    ospf 1
     area 0.0.0.0
      network 172.17.1.0 0.0.0.255
      network 192.168.11.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-12-13

Document ID: EDOC1000041694

Views: 61014

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next