No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Example

Configuration Example

This section provides configuration examples for RMON.

Example for Configuring RMON

Networking Requirements

As shown in Figure 14-16, the subnet connected to 10GE1/17/1 on the switch modules needs to be monitored, including

  • Collecting real-time and history statistics on traffic and each type of packets

  • Recording logs when the traffic volume per minute exceeds the threshold

  • Monitoring broadcast and multicast traffic volume on the subnet and reporting alarm to the NMS when the traffic volume exceeds the threshold

Figure 14-16 Networking diagram of RMON configuration
Configuration Roadmap

To collect real-time and history statistics on traffic and each type of packets, configure the RMON statistics function. To report alarms to the NMS when traffic volume exceeds the threshold, configure the RMON alarm function.

The configuration roadmap is as follows:

  1. Assign IP addresses to interfaces of the switch modules.Configure a reachable route between the switch modules and NMS.
  2. Configure basic SNMP functions and enable the switch modules to send traps to the NMS.
  3. Enable RMON statistics function and configure the statistics table and history control table.

  4. Configure the event table, alarm table.

Procedure

  1. Configure IP addresses and reachable route for switch interfaces.

    <HUAWEI> system-view
    [~HUAWEI] vlan 100
    [*HUAWEI-vlan100] quit
    [*HUAWEI] interface vlanif 100
    [*HUAWEI-Vlanif100] ip address 2.2.2.1 24
    [*HUAWEI-Vlanif100] quit
    [*HUAWEI] quit
    [*HUAWEI] interface 10ge 1/17/2
    [*HUAWEI-10GE1/17/2] port link-type trunk
    [*HUAWEI-10GE1/17/2] port trunk pvid vlan 100
    [*HUAWEI-10GE1/17/2] port trunk allow-pass vlan 100
    [*HUAWEI-10GE1/17/2] quit
    [*HUAWEI] vlan 110
    [*HUAWEI-vlan110] quit
    [*HUAWEI] interface vlanif 110
    [*HUAWEI-Vlanif110] ip address 3.3.3.1 24
    [*HUAWEI-Vlanif110] quit
    [*HUAWEI] quit
    [*HUAWEI] interface 10ge 1/17/1
    [*HUAWEI-10GE1/17/1] port link-type trunk
    [*HUAWEI-10GE1/17/1] port trunk pvid vlan 110
    [*HUAWEI-10GE1/17/1] port trunk allow-pass vlan 110
    [*HUAWEI-10GE1/17/1] quit
    [*HUAWEI] ospf
    [*HUAWEI-ospf-1] area 0
    [*HUAWEI-ospf-1-area-0.0.0.0] network 2.2.2.0 0.0.0.255
    [*HUAWEI-ospf-1-area-0.0.0.0] network 3.3.3.0 0.0.0.255
    [*HUAWEI-ospf-1-area-0.0.0.0] quit
    [*HUAWEI-ospf-1] quit

  2. Configure basic SNMP functions and enable the switch to send traps to the NMS.

    # Configure SNMPv3 on the switch. Configure an SNMP user group admin and add a user nms-admin to the user group.

    [*HUAWEI] snmp-agent group v3 admin privacy
    [*HUAWEI] snmp-agent usm-user v3 nms-admin admin authentication-mode md5 abc123456 privacy-mode des56 123456abc

    # Enable SNMP to send traps.

    [*HUAWEI] snmp-agent trap enable

    # Specify the NMS that receives the traps.

    [*HUAWEI] snmp-agent target-host trap address udp-domain 1.1.1.1 params securityname nms-admin v3 privacy

  3. Configure statistics function.

    # Enable the RMON statistics function on the interface.

    [*HUAWEI] interface 10GE 1/17/1
    [*HUAWEI-10GE1/17/1] rmon-statistics enable
    

    # Configure the statistics table.

    [*HUAWEI-10GE1/17/1] rmon statistics 1 owner Test300
    

    # Configure the history control table. Sample traffic on the subnet every 30 seconds and save the latest 10 records

    [*HUAWEI-10GE1/17/1] rmon history 1 buckets 10 interval 30 owner Test300
    [*HUAWEI-10GE1/17/1] commit
    

  4. Configure the alarm function.

    # Configure the event table. Configure the switch to record logs for RMON event 1 and send traps to the NMS for RMON event 2.

    [*HUAWEI] rmon event 1 log owner Test300
    [*HUAWEI] rmon event 2 description forUseofPrialarm trap public owner Test300
    

    # Configure the alarm table. Set the sampling interval and the threshold for triggering event 1 (OID is 1.3.6.1.2.1.16.1.1.1.6.1).

    [*HUAWEI] rmon alarm 1 1.3.6.1.2.1.16.1.1.1.6.1 30 absolute rising-threshold 500 1 falling-threshold 100 1 owner Test300
    [*HUAWEI] commit
    [~HUAWEI] quit

  5. Verify the configuration.

    # View traffic volume on the subnet.

    <HUAWEI> display rmon statistics 10ge 1/17/1
    Statistics entry 1 owned by Test300 is valid.
      Interface : 10GE1/17/1<ifIndex.16>
      Received  :
      Octets              :142915224 , Packets          :1749151
      Broadcast packets   :11603     , Multicast packets:756252
      Undersize packets   :0         , Oversize packets :0
      Fragments packets   :0         , Jabbers packets  :0
      CRC alignment errors:0         , Collisions       :0
      Dropped packet (insufficient resources):1795
      Packets received according to length (octets):
      64     :150183    ,  65-127  :150183    ,  128-255  :1383
      256-511:3698      ,  512-1023:0         ,  1024-1518:0
    

    # View the sampling records.

    <HUAWEI> display rmon history
    History control entry 1 owned by Test300 is valid
      Samples interface     : 10GE1/17/1<ifIndex.16>
      Sampling interval     : 30(sec) with 10 buckets max
      Last Sampling time    : 0days 00h:19m:43s.49th
      Latest sampled values :
      Octets               :654       , Packets           :0
      Broadcast packets    :7         , Multicast packets :0
      Undersize packets    :6         , Oversize packets  :0
      Fragments packets    :0         , Jabbers packets   :0
      CRC alignment errors :0         , Collisions        :0
      Dropped packet       :0         , Utilization       :0

    # View the RMON event configurations.

    <HUAWEI> display rmon event
    Event table 1 owned by Test300 is valid.
      Description: null.                          
      Will cause log  when triggered, last triggered at 0days 00h:24m:10s.05th.
    Event table 2 owned by Test300 is valid.
      Description: forUseofPrialarm.            
      Will cause snmp-trap when triggered, last triggered at 0days 00h:26m:10s.05th.

    # View the RMON alarm configurations.

    <HUAWEI> display rmon alarm 1
    Alarm table 1 owned by Test300 is valid. 
    Samples  absolute value   : 1.3.6.1.2.1.16.1.1.1.6.1
    Sampling interval         : 30(sec)                                            
    Rising threshold          : 500(linked with event 1)                       
    Falling threshold         : 100(linked with event 1)                          
    When startup enables      : risingOrFallingAlarm                              
    Latest value              : 1975

    # View the event logs.

    <HUAWEI> display rmon eventlog
    Event table 1 owned by Test300 is valid.
      Generates eventLog 1.1 at 0days 00h:39m:30s.01th.
      Description: The 1.3.6.1.2.1.16.1.1.1.6.1 defined in alarm table 1 is less than or equal to 100 with alarm value 0. Alarm sample type is absolute.

Configuration Files
#
vlan batch 100 110
#
interface Vlanif100
 ip address 2.2.2.1 255.255.255.0
#
interface Vlanif110
 ip address 3.3.3.1 255.255.255.0
#
interface 10GE1/17/2
 port link-type trunk                                                           
 port trunk pvid vlan 100                                                       
 port trunk allow-pass vlan 100 
#
interface 10GE1/17/1
 port link-type trunk                                                           
 port trunk pvid vlan 110                                                       
 port trunk allow-pass vlan 110 
 rmon-statistics enable
 rmon statistics 1 owner Test300
 rmon history 1 buckets 10 interval 30 owner Test300
#
ospf 1                                                                          
 area 0.0.0.0                                                                   
  network 2.2.2.0 0.0.0.255                                                       
  network 3.3.3.0 0.0.0.255
#
snmp-agent
snmp-agent local-engineid 800007DB0300C020177602
#
snmp-agent group v3 admin privacy
snmp-agent target-host trap address udp-domain 1.1.1.1 params securityname nms-admin v3 privacy
#
snmp-agent usm-user v3 nms-admin
snmp-agent usm-user v3 nms-admin group admin
snmp-agent usm-user v3 nms-admin authentication-mode md5 cipher %@%@FYM32S4XeHL\}}WlSly9,ai_%@%@
snmp-agent usm-user v3 nms-admin privacy-mode des56 cipher %@%@Os}rA$F^G!FqnIU1#g4X,aie%@%@
#
rmon event 1 description null log owner Test300
rmon event 2 description forUseofPrialarm trap public owner Test300
rmon alarm 1 1.3.6.1.2.1.16.1.1.1.6.1 30 absolute rising-threshold 500 1 falling-threshold 100 1 owner Test300
#
snmp-agent trap enable  
#
return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 58434

Downloads: 3621

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next