No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides examples to illustrate how to configure multicast load splitting on an IPv6 multicast network.

Example for Configuring IPv6 Multicast Load Splitting

Networking Requirements

On an IPv6 multicast network as shown in Figure 8-104, Switch ModuleE connects to HostA and has three equal-cost routes to the multicast source (Source). According to the default RPF check policy, Switch ModuleE will select one of equal-cost routes to transmit multicast data. When the rate of multicast traffic is high, the network may be congested, degrading the quality of multicast services. To ensure the quality of multicast services, configure IPv6 multicast load splitting so that multicast data can be transmitted through multiple equal-cost routes.

Figure 8-104 Networking diagram of multicast load splitting

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IPv6 addresses for interfaces on the switches.

  2. Configure an IPv6 unicast routing protocol (IS-IS (IPv6) in this example) to implement interworking among all the switches and ensure that route costs are the same.

  3. Enable IPv6 multicast routing on all the switches and enable PIM-SM (IPv6) on all the Layer 3 interfaces. Configure the loopback interface on SwitchA as a C-BSR and C-RP.

  4. On SwitchE, configure stable-preferred IPv6 multicast load splitting to ensure stable transmission of multicast services.

  5. On SwitchE, configure static multicast groups on the interface connected to the network segment of HostA, because HostA needs to receive data of these groups for a long time.

Procedure

  1. Configure IPv6 addresses for interfaces on the switches.

    # Create VLANs and add Layer 2 physical interfaces to VLANs on the switches. (Configurations of the other switches are similar to the configuration of SwitchA.)

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20 30 40
    [*SwitchA] interface 10ge 0/17/4
    [*SwitchA-10GE0/17/4] port link-type hybrid
    [*SwitchA-10GE0/17/4] port hybrid pvid vlan 10
    [*SwitchA-10GE0/17/4] port hybrid untagged vlan 10
    [*SwitchA-10GE0/17/4] quit
    [*SwitchA] interface 10ge 1/17/1
    [*SwitchA-10GE1/17/1] port link-type hybrid
    [*SwitchA-10GE1/17/1] port hybrid pvid vlan 20
    [*SwitchA-10GE1/17/1] port hybrid untagged vlan 20
    [*SwitchA-10GE1/17/1] quit
    [*SwitchA] interface 10ge 1/17/2
    [*SwitchA-10GE1/17/2] port link-type hybrid
    [*SwitchA-10GE1/17/2] port hybrid pvid vlan 30
    [*SwitchA-10GE1/17/2] port hybrid untagged vlan 30
    [*SwitchA-10GE1/17/2] quit
    [*SwitchA] interface 10ge 1/17/3
    [*SwitchA-10GE1/17/3] port link-type hybrid
    [*SwitchA-10GE1/17/3] port hybrid pvid vlan 40
    [*SwitchA-10GE1/17/3] port hybrid untagged vlan 40
    [*SwitchA-10GE1/17/3] quit
    [*SwitchA] commit

    # Configure IPv6 addresses and masks for Layer 3 interfaces on the switches. (Configurations of the other switches are similar to the configuration of SwitchA.)

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address 2001::2 64
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address 2002::1 64
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ipv6 enable
    [*SwitchA-Vlanif30] ipv6 address 2003::1 64
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] ipv6 enable
    [*SwitchA-Vlanif40] ipv6 address 2004::1 64
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] ipv6 enable
    [*SwitchA-LoopBack0] ipv6 address 2000::1 64
    [*SwitchA-LoopBack0] quit
    [~SwitchA] commit

  2. Configure IS-IS (IPv6) to implement interworking among all the switches and ensure that route costs are the same.

    # Configure SwitchA. (Configurations of the other switches are similar to the configuration of SwitchA.)

    [~SwitchA] isis
    [*SwitchA-isis-1] ipv6 enable topology standard
    [*SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [*SwitchA-isis-1] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] isis ipv6 enable
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] isis ipv6 enable
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] isis ipv6 enable
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] isis ipv6 enable
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] isis ipv6 enable
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

  3. Enable IPv6 multicast routing on all the switches and enable PIM-SM (IPv6) on all the Layer 3 interfaces.

    # Configure SwitchA. (Configurations of the other switches are similar to the configuration of SwitchA.)

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim ipv6 sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] pim ipv6 sm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] pim ipv6 sm
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback 0
    [*SwitchA-LoopBack0] pim ipv6 sm
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

  4. Configure a C-BSR and C-RP on SwitchA.

    # Configure Loopback0 on SwitchA as a C-BSR and C-RP.

    [~SwitchA] pim ipv6
    [*SwitchA-pim6] c-bsr 2000::1
    [*SwitchA-pim6] c-rp 2000::1
    [*SwitchA-pim6] quit
    [*SwitchA] commit

  5. Configure stable-preferred multicast load splitting on SwitchE.

    [~SwitchE] multicast ipv6 load-splitting stable-preferred
    [*SwitchE] commit

  6. Configure static multicast groups on the interface of SwitchE connected to the network segment of HostA.

    # Configure static multicast groups FF13::1 to FF13::3 on VLANIF140.

    [~SwitchE] interface vlanif 140
    [~SwitchE-Vlanif140] mld static-group ff13::1 inc-step-mask 128 number 3
    [*SwitchE-Vlanif140] quit
    [*SwitchE] commit

  7. Verify the configuration of stable-preferred multicast load splitting.

    # Source (2001::1/64) sends multicast data to multicast groups FF13::1 to FF13::3. HostA can receive multicast data from Source. Check brief information about the PIM (IPv6) routing table on SwitchE.

    [~SwitchE] display pim ipv6 routing-table brief
     VPN-Instance: public net
     Total 3 (*, G) entries; 3 (S, G) entries
    
      00001.(*, FF13::1)
           Upstream interface:Vlanif60
           Number of downstream:1
      00002.(2001::1, FF13::1)
           Upstream interface:Vlanif60
           Number of downstream:1
      00003.(*, FF13::2)
           Upstream interface:Vlanif80
           Number of downstream:1
      00004.(2001::1, FF13::2)
           Upstream interface:Vlanif80
           Number of downstream:1
      00005.(*, FF13::3)
           Upstream interface:Vlanif100
           Number of downstream:1
      00006.(2001::1, FF13::3)
           Upstream interface:Vlanif100
           Number of downstream:1

    (*, G) and (S, G) entries are evenly distributed on the three equal-cost routes. The upstream interfaces of the routes are VLANIF100, VLANIF80, and VLANIF60 respectively.

    NOTE:

    The load splitting algorithm processes (*, G) and (S, G) entries separately using the same rule.

Configuration Files
  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20 30 40
    #
    multicast ipv6 routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0001.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 2001::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 2002::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address 2003::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address 2004::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    interface 10GE1/17/4
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface LoopBack0
     ipv6 enable
     ipv6 address 2000::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    pim ipv6
     c-bsr 2000::1
     c-rp 2000::1
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 20 60
    #
    multicast ipv6 routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0002.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 2002::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address 2005::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 60
     port hybrid untagged vlan 60
    #
    return 
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 30 80
    #
    multicast ipv6 routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0003.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address 2003::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address 2006::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 80
     port hybrid untagged vlan 80
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    vlan batch 40 100
    #
    multicast ipv6 routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0004.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address 2004::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address 2007::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    return
  • Configuration file of SwitchE

    #
    sysname SwitchE
    #
    vlan batch 60 80 100 140
    #
    multicast ipv6 routing-enable
    multicast ipv6 load-splitting stable-preferred
    #
    isis 1
     network-entity 10.0000.0000.0005.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address 2005::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address 2006::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address 2007::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif140
     ipv6 enable
     ipv6 address 3001::1/64
     pim ipv6 sm
     mld static-group FF13::1 inc-step-mask 128 number 3
     isis ipv6 enable 1
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 60
     port hybrid untagged vlan 60
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 80
     port hybrid untagged vlan 80
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface 10GE1/17/4
     port link-type hybrid
     port hybrid pvid vlan 140
     port hybrid untagged vlan 140
    #
    return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 59748

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next