No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides a priority mapping configuration example, including networking requirements, configuration notes, and configuration roadmap.

Example for Configuring Priority Mapping

Networking Requirements

As shown in Figure 13-9, uplink interfaces 40GE1/18/1 and 40GE1/18/2 of Switch connect to core switches SwitchA and SwitchB, downlink interfaces 10GE1/17/1 and 10GE1/17/2 of Switch connect to tenant servers, and Switch connects to the Internet through the egress router.

On the data center network, tenant 1 and tenant 2 lease different servers. The CoS of tenant 1 is higher than that of tenant 2, so a short delay is required for tenant 1' services. 802.1p priorities of packets from servers of tenant 1 and tenant 2 are 0. DiffServ domains are defined to map 802.1p priority of packets from tenant 1's server to AF4 and map 802.1p priority of packets from tenant 2's server to AF2. The DiffServ domains are applied to 10GE1/17/1 and 10GE1/17/2 to implement differentiated services and ensure user experience of tenant 1.

Figure 13-9 Networking diagram of priority mapping

Configuration Roadmap
The configuration roadmap is as follows:
  1. Create VLANs and configure interfaces so that the Switch Module connects to tenants' servers, SwitchA, and SwitchB.
  2. Configure interfaces to trust outer 802.1p priorities.
  3. Create DiffServ domains, and map 802.1p priorities to PHBs and colors.
  4. Bind DiffServ domains to 10GE1/17/1 and 10GE1/17/2 on the Switch Module respectively.

Procedure

  1. Create VLANs and configure interfaces.

    # Create VLAN 100 and VLAN 200.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch Module
    [*HUAWEI] commit
    [~Switch Module] vlan batch 100 200
    [*Switch Module] commit
    

    # Configure 40GE1/18/1 and 40GE1/18/2 on Switch Module as trunk interfaces. Add 10GE1/17/1 to VLAN 100, 10GE1/17/2 to VLAN 200, and 40GE1/18/1 and 40GE1/02/ to both VLAN 100 and VLAN 200.

    [~Switch Module] interface 10ge 1/18/1
    [~Switch Module-10GE1/17/1] port default vlan 100
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] interface 10ge 1/17/2
    [*Switch Module-10GE1/17/2] port default vlan 200
    [*Switch Module-10GE1/17/2] quit
    [*Switch Module] interface 40ge 1/18/1
    [*Switch Module-40GE1/18/1] port link-type trunk
    [*Switch Module-40GE1/18/1] port trunk allow-pass vlan 100 200
    [*Switch Module-40GE1/18/1] quit
    [*Switch Module] interface 40ge 1/18/2
    [*Switch Module-40GE1/18/2] port link-type trunk
    [*Switch Module-40GE1/18/2] port trunk allow-pass vlan 100 200
    [*Switch Module-40GE1/18/2] quit
    [*Switch Module] commit
    

  2. Configure interfaces to trust outer 802.1p priorities.

    By default, an interface trusts outer 802.1p priorities. The procedure is not mentioned here.

  3. Create and configure DiffServ domains.

    # Create DiffServ domains ds1 and ds2 on the Switch Module and map 802.1p priorities of packets from tenants' servers to different CoS.

    [~Switch Module] diffserv domain ds1
    [*Switch Module-dsdomain-ds1] 8021p-inbound 0 phb af4 green
    [*Switch Module-dsdomain-ds1] quit
    [*Switch Module] diffserv domain ds2
    [*Switch Module-dsdomain-ds2] 8021p-inbound 0 phb af2 green
    [*Switch Module-dsdomain-ds2] quit
    [*Switch Module] commit
    

  4. Bind DiffServ domains to interfaces.

    # Bind DiffServ domains ds1 and ds2 to 10GE1/17/1 and 10GE1/17/2 respectively.

    [~Switch Module] interface 10ge 1/17/1
    [~Switch Module-10GE1/17/1] trust upstream ds1
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] interface 10ge 1/17/2
    [*Switch Module-10GE1/17/2] trust upstream ds2
    [*Switch Module-10GE1/17/2] quit
    [*Switch Module] commit
    

  5. Verify the configuration.

    # View queue statistics on the outbound interface.

    [~Switch Module] display qos queue statistics interface 40ge 1/18/1
     Queue    CIR/PIR                  Passed     Pass Rate                 Dropped     Drop Rate                                       
               (kbps)           (Packet/Byte)     (pps/bps)           (Packet/Byte)     (pps/bps)                                       
     --------------------------------------------------------------------------------------------                                       
         0          0                       0             0                       0             0                                       
             10000000                       0             0                       0             0                                       
     --------------------------------------------------------------------------------------------                                       
         1          0                       0             0                       0             0                                       
             10000000                       0             0                       0             0                                       
     --------------------------------------------------------------------------------------------                                       
         2          0                11295086         17516                       0             0                                       
             10000000               114688668      14573986                       0             0                                       
     --------------------------------------------------------------------------------------------                                       
         3          0                       0             0                       0             0                                       
             10000000                       0             0                       0             0                                       
     --------------------------------------------------------------------------------------------                                       
         4          0                11511125         19563                       0             0                                       
             10000000               112653485      15352321                       0             0                                       
     --------------------------------------------------------------------------------------------                                       
         5          0                       0             0                       0             0                                       
             10000000                       0             0                       0             0                                       
     --------------------------------------------------------------------------------------------                                       
         6          0                       0             0                       0             0                                       
             10000000                       0             0                       0             0                                       
     --------------------------------------------------------------------------------------------                                       
         7          0                       0             0                       0             0                                       
             10000000                       0             0                       0             0                                       
     -------------------------------------------------------------------------------------------- 

Configuration Files
  • Configuration file of the Switch Module
    #
     sysname Switch Module
    #
     vlan batch 100 200
    #
    diffserv domain ds1
      8021p-inbound 0 phb af4 green
    #
    diffserv domain ds2
      8021p-inbound 0 phb af2 green
    # 
    interface 10GE1/17/1
     port default vlan 100
     trust upstream ds1
    #
    interface 10GE1/17/2
     port default vlan 200
     trust upstream ds2
    #
    interface 40GE1/18/1
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    interface 40GE1/18/2
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
    
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 58414

Downloads: 3621

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next