No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 13

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

Example for Configuring Interface-based Rate Limiting

Networking Requirements

As shown in Figure 13-19, a tenant server sends traffic through Switch ModuleA and Switch Module and accesses the network through the egress router.

The rate of packets sent from the tenant server cannot exceed 100 Mbit/s.

Figure 13-19 Networking diagram for configuring interface-based rate limiting

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure interfaces on Switch Module so that users can access the network.
  2. Create a CAR profile and set the CIR value.
  3. Apply the CAR profile to 10GE1/17/1 on Switch Module in the inbound direction and limit the interface bandwidth within the allowed range.

Procedure

  1. Create a VLAN and configure interfaces on Switch Module.

    # Create VLAN 100 on Switch Module.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch Module
    [*HUAWEI] commit
    [~Switch Module] vlan 100
    [*Switch Module-vlan100] quit
    [*Switch Module] commit

    # Configure 10GE1/17/1 and 10GE1/17/2 on Switch Module as trunk interfaces and add them to VLAN 100.

    [~Switch Module] interface 10ge 1/17/1
    [~Switch Module-10GE1/17/1] port link-type trunk
    [*Switch Module-10GE1/17/1] port trunk allow-pass vlan 100
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] interface 10ge 1/17/2
    [*Switch Module-10GE1/17/2] port link-type trunk
    [*Switch Module-10GE1/17/2] port trunk allow-pass vlan 100
    [*Switch Module-10GE1/17/2] quit
    [*Switch Module] commit

  2. Configure the CAR profile.

    # Create CAR profile car1 on Switch Module to limit traffic from the tenant server.

    [~Switch Module] qos car car1 cir 100000
    [*Switch Module] commit

  3. Apply the CAR profile.

    # Apply car1 in the inbound direction of 10GE1/17/1 on Switch Module to limit traffic from the tenant server.

    [~Switch Module] interface 10ge 1/17/1
    [~Switch Module-10GE1/17/1] qos car inbound car1
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] commit

  4. Verify the configuration.

    # View the CAR profile configuration.

    [~Switch Module] display qos car car1
      ----------------------------------------------------------------
       CAR Name  : car1
       CAR Index : 0
        car cir 100000 kbps cbs 18800000 bytes 
       Applied number on behavior  : 0
       Applied number on interface inbound  : 1
        10GE1/17/1
       Applied number on Eth-Trunk inbound  : 0
    # Send traffic to 10GE1/17/1 at the rates of 60000 kbit/s and 110000 kbit/s, and run the display qos car statistics command to check the QoS CAR statistics. If the configuration is successful, you can obtain the following results:
    • When packets are sent to 10GE1/17/1 at the rate of 60000 kbit/s, all the packets are forwarded.
    • When packets are sent to 10GE1/17/1 at the rate of 110000 kbit/s, some packets are discarded.

Configuration Files

  • Configuration file of Switch Module
    #
    sysname Switch Module
    #
    vlan 100
    #
    qos car car1 cir 100000 kbps 
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 100
     qos car inbound car1
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
    

Example for Configuring MQC to Implement Traffic Policing

Networking Requirements

As shown in Figure 13-20, Tenant 1, Tenant 2, and Tenant 3 are connected to Switch ModuleA and Switch Module and access the network through the egress router. The server of Tenant 1 belongs to VLAN 10, the server of Tenant 2 belongs to VLAN 20, and the server of Tenant 3 belongs to VLAN 30.

The rate of traffic from users needs to be limited within a proper range on Switch Module. Table 13-12 describes details about limited bandwidth of each tenant.

Table 13-12 CAR values for traffic from each tenant

User

CIR (kbit/s)

Tenant 1

2000

Tenant 2

4000

Tenant 3

8000

Figure 13-20 MQC to implement traffic policing

Configuration Roadmap

The configuration roadmap is as follows:
  1. Create VLANs and configure interfaces on Switch Module so that the servers can access the network.
  2. Configure traffic classifiers on Switch Module to classify packets based on the VLAN ID.
  3. Configure traffic behaviors on Switch Module to limit the rate of traffic from the servers.
  4. Configure a traffic policy on Switch Module, bind the configured traffic behaviors and traffic classifiers to the traffic policy, and apply the traffic policy to the inbound interface on Switch Module.

Procedure

  1. Create VLANs and configure interfaces.

    # Create VLAN 10, VLAN 20, and VLAN 30 on Switch ModuleA.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 10 20 30
    [*Switch ModuleA] commit
    

    # Configure 10GE1/17/4 on Switch ModuleA as a trunk interface. Add 10GE1/17/1 to VLAN 10, 10GE1/17/2 to VLAN 20, 10GE1/17/3 to VLAN 30, and 10GE1/17/4 to VLAN 10, VLAN 20, and VLAN 30.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] port default vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] port default vlan 20
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] interface 10ge 1/17/3
    [*Switch ModuleA-10GE1/17/3] port default vlan 30
    [*Switch ModuleA-10GE1/17/3] quit
    [*Switch ModuleA] interface 10ge 1/17/4
    [*Switch ModuleA-10GE1/17/4] port link-type trunk
    [*Switch ModuleA-10GE1/17/4] port trunk allow-pass vlan 10 20 30
    [*Switch ModuleA-10GE1/17/4] quit
    [*Switch ModuleA] commit
    

    # Create VLANs 10, 20, and 30 on Switch Module.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch Module
    [*HUAWEI] commit
    [*Switch Module] vlan batch 10 20 30
    [*Switch Module] commit
    

    # Configure 10GE1/17/1 and 40GE1/18/1 on Switch Module as trunk interfaces. Add both 10GE1/17/1 and 40GE1/18/1 to VLAN 10, VLAN 20, and VLAN 30.

    [~Switch Module] interface 10ge 1/17/1
    [~Switch Module-10GE1/17/1] port link-type trunk
    [*Switch Module-10GE1/17/1] port trunk allow-pass vlan 10 20 30
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] commit
    [~Switch Module] interface 40ge 1/18/1
    [~Switch Module-40GE1/18/1] port link-type trunk
    [*Switch Module-40GE1/18/1] port trunk allow-pass vlan 10 20 30
    [*Switch Module-40GE1/18/1] quit
    [*Switch Module] commit
    

  2. Configure traffic classifiers.

    # Configure traffic classifiers c1, c2, and c3 on Switch Module to classify different service flows from the servers based on the VLAN ID.

    [~Switch Module] traffic classifier c1
    [*Switch Module-classifier-c1] if-match vlan 10
    [*Switch Module-classifier-c1] quit
    [*Switch Module] traffic classifier c2
    [*Switch Module-classifier-c2] if-match vlan 20
    [*Switch Module-classifier-c2] quit
    [*Switch Module] traffic classifier c3
    [*Switch Module-classifier-c3] if-match vlan 30
    [*Switch Module-classifier-c3] quit
    [*Switch Module] commit
    

  3. Configure traffic behaviors.

    # Create traffic behaviors b1, b2, and b3 on Switch Module to limit the rates of service flows.

    [~Switch Module] traffic behavior b1
    [*Switch Module-behavior-b1] car cir 2000
    [*Switch Module-behavior-b1] statistics enable
    [*Switch Module-behavior-b1] quit
    [*Switch Module] traffic behavior b2
    [*Switch Module-behavior-b2] car cir 4000
    [*Switch Module-behavior-b2] statistics enable
    [*Switch Module-behavior-b2] quit
    [*Switch Module] traffic behavior b3
    [*Switch Module-behavior-b3] car cir 8000
    [*Switch Module-behavior-b3] statistics enable
    [*Switch Module-behavior-b3] quit
    [*Switch Module] commit
    

  4. Configure a traffic policy and apply it to interfaces.

    # Create a traffic policy p1 on Switch Module, bind the traffic behaviors and traffic classifiers to p1, and apply p1 to 10GE1/17/1 in the inbound direction.

    [~Switch Module] traffic policy p1
    [*Switch Module-trafficpolicy-p1] classifier c1 behavior b1
    [*Switch Module-trafficpolicy-p1] classifier c2 behavior b2
    [*Switch Module-trafficpolicy-p1] classifier c3 behavior b3
    [*Switch Module-trafficpolicy-p1] quit
    [*Switch Module] interface 10ge 1/17/1
    [*Switch Module-10GE1/17/1] traffic-policy p1 inbound
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] commit
    

  5. Verify the configuration.

    # View the traffic classifier configurations.

    [~Switch Module] display traffic classifier
      Traffic Classifier Information: 
        Classifier: c1
          Type: OR
          Rule(s):
            if-match vlan 10
    
        Classifier: c2
          Type: OR
          Rule(s):
            if-match vlan 20
    
        Classifier: c3
          Type: OR
          Rule(s):
            if-match vlan 30
    
    Total classifier number is 3

    # View the traffic policy configuration.

    [~Switch Module] display traffic policy p1
      Traffic Policy Information:
        Policy: p1
          Classifier: c1
            Type: OR
          Behavior: b1
            Committed Access Rate:
              CIR 2000 (Kbps), PIR 2000 (Kbps), CBS 250000 (Bytes), PBS 250000 (Bytes)
              Color Mode: color blind
              Conform Action: pass
              Yellow  Action: pass
              Exceed  Action: discard
            Statistics: enable
    
          Classifier: c2
            Type: OR
          Behavior: b2
            Committed Access Rate:
              CIR 4000 (Kbps), PIR 4000 (Kbps), CBS 500000 (Bytes), PBS 500000 (Bytes)
              Color Mode: color blind
              Conform Action: pass
              Yellow  Action: pass
              Exceed  Action: discard
            Statistics: enable
    
          Classifier: c3
            Type: OR
          Behavior: b3
            Committed Access Rate:
              CIR 8000 (Kbps), PIR 8000 (Kbps), CBS 1000000 (Bytes), PBS 1000000 (Bytes)
              Color Mode: color blind
              Conform Action: pass
              Yellow  Action: pass
              Exceed  Action: discard
            Statistics: enable

    # View the traffic policy configuration on 10GE1/17/1.

    [~Switch Module] display traffic-policy statistics interface 10ge 1/17/1 inbound
    Traffic policy: p1, inbound                                                                                                         
    -------------------------------------------------------------------------                                                           
      Slot: 1                                                                                                                           
        Item                              Packets                       Bytes                                                           
        ---------------------------------------------------------------------                                                           
        Matched                            204112                    21227648                                                           
          +--Passed                         96243                    10009272                                                           
          +--Dropped                       107869                    11218376                                                           
            +--Filter                           0                           0                                                           
            +--CAR                         107869                    11218376                                                           
        --------------------------------------------------------------------- 

Configuration Files

  • Configuration file of Switch Module
    #
    sysname Switch Module
    #
    vlan batch 10 20 30
    #
    traffic classifier c1 type or
     if-match vlan 10
    #
    traffic classifier c2 type or
     if-match vlan 20
    #
    traffic classifier c3 type or
     if-match vlan 30
    #
    traffic behavior b1
     statistics enable
     car cir 2000 kbps
    #
    traffic behavior b2
     statistics enable
     car cir 4000 kbps
    #
    traffic behavior b3
     statistics enable
     car cir 8000 kbps
    #
    traffic policy p1
     classifier c1 behavior b1 precedence 5 
     classifier c2 behavior b2 precedence 10 
     classifier c3 behavior b3 precedence 15
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 20 30
     traffic-policy p1 inbound
    #
    interface 40GE1/18/1
     port link-type trunk
     port trunk allow-pass vlan 10 20 30
    #
    return
    
  • Configuration file of Switch ModuleA
    #
    sysname Switch ModuleA
    #
    vlan batch 10 20 30
    #
    interface 10GE1/17/1
     port default vlan 10
    #
    interface 10GE1/17/2
     port default vlan 20
    #
    interface 10GE1/17/3
     port default vlan 30
    #
    interface 10GE1/17/4
     port link-type trunk
     port trunk allow-pass vlan 10 20 30
    #
    return
    

Example for Configuring Hierarchical Traffic Policing

Networking Requirements

Only CX111&CX915 switch module GE switching plane and CX110 switch module GE switching plane switches can be used in this example.

As shown in Figure 13-21, tenants are connected to Switch ModuleA and Switch Module and access the network through the egress router. Tenants send packets of voice, video, and data. This topic assumes that the DSCP priority of data flows is AF21, that of video flows is CS5, and that of voice flows is EF.

Users require that the traffic rate be limited within an allowed range to ensure bandwidth for traffic of the three types. Table 13-13 describes bandwidth requirements. The total CIR of tenants cannot exceed 500 Mbit/s.

Table 13-13 CAR values for traffic from each tenant

Tenant Traffic

DSCP Priority

CIR (kbit/s)

PIR (kbit/s)

Data

AF21

50000

100000

Network Video

CS5

200000

400000

IP Voice

EF

100000

200000

Figure 13-21 Networking diagram for hierarchical traffic policing

Configuration Roadmap

The configuration roadmap is as follows:
  1. Create a VLAN and configure interfaces on the Switch ModuleA and Switch Module so that users can access the network.
  2. Configure traffic classifiers based on the DSCP priority on Switch Module to limit the rate of service flows and the total rate of all service flows.
  3. Bind traffic classifiers to traffic behaviors on Switch Module and apply traffic policies to inbound interfaces on Switch Module so that the rate of inbound traffic on Switch Module is limited.

Procedure

  1. Create a VLAN and configure interfaces.

    # Create VLAN 10 on Switch ModuleA.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan 10
    [*Switch ModuleA-vlan10] quit
    [*Switch ModuleA] commit
    

    # Configure 10GE1/17/2 on Switch ModuleA as a trunk interface. Add 10GE1/17/1 and 10GE1/17/2 to VLAN 10.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] port default vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] port link-type trunk
    [*Switch ModuleA-10GE1/17/2] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] commit
    

    # Create VLAN 10 on Switch Module.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch Module
    [*HUAWEI] commit
    [~Switch Module] vlan 10
    [*Switch Module-vlan10] quit
    [*Switch Module] commit
    

    # Configure 10GE1/17/1 and 40GE1/18/1 on Switch Module as trunk interfaces. Add 10GE1/17/1 and 40GE1/18/1 to VLAN 10.

    [~Switch Module] interface 10ge 1/17/1
    [~Switch Module-10GE1/17/1] port link-type trunk
    [*Switch Module-10GE1/17/1] port trunk allow-pass vlan 10
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] commit
    [~Switch Module] interface 40ge 1/18/1
    [~Switch Module-40GE1/18/1] port link-type trunk
    [*Switch Module-40GE1/18/1] port trunk allow-pass vlan 10
    [*Switch Module-40GE1/18/1] quit
    [*Switch Module] commit
    

  2. Create a CAR profile and set the maximum bandwidth to 500 Mbit/s.

    [~Switch Module] qos car car_total cir 500000
    [*Switch Module] commit
    

  3. Configure traffic classifiers based on the DSCP priority for traffic of different services on Switch Module to limit the rate of service flows and the total rate of all service flows.

    # Create classifiers c1, c2, and c3 on Switch Module to classify traffic based on the DSCP priority.

    [~Switch Module] traffic classifier c1
    [*Switch Module-classifier-c1] if-match dscp af21
    [*Switch Module-classifier-c1] quit
    [*Switch Module] traffic classifier c2
    [*Switch Module-classifier-c2] if-match dscp cs5
    [*Switch Module-classifier-c2] quit
    [*Switch Module] traffic classifier c3
    [*Switch Module-classifier-c3] if-match dscp ef
    [*Switch Module-classifier-c3] quit
    [*Switch Module] commit
    

    # Create traffic behaviors b1, b2, and b3 on Switch Module to limit the rates of service flows.

    [~Switch Module] traffic behavior b1
    [*Switch Module-behavior-b1] car cir 50000 pir 100000
    [*Switch Module-behavior-b1] car car_total share
    [*Switch Module-behavior-b1] statistics enable
    [*Switch Module-behavior-b1] quit
    [*Switch Module] traffic behavior b2
    [*Switch Module-behavior-b2] car cir 200000 pir 400000 
    [*Switch Module-behavior-b2] car car_total share
    [*Switch Module-behavior-b2] statistics enable
    [*Switch Module-behavior-b2] quit
    [*Switch Module] traffic behavior b3
    [*Switch Module-behavior-b3] car cir 100000 pir 200000 
    [*Switch Module-behavior-b3] car car_total share
    [*Switch Module-behavior-b3] statistics enable
    [*Switch Module-behavior-b3] quit
    [*Switch Module] commit
    

  4. # Create a traffic policy p1 on Switch Module and bind the traffic policy to the traffic classifiers and traffic behaviors.

    [~Switch Module] traffic policy p1
    [*Switch Module-trafficpolicy-p1] classifier c1 behavior b1
    [*Switch Module-trafficpolicy-p1] classifier c2 behavior b2
    [*Switch Module-trafficpolicy-p1] classifier c3 behavior b3
    [*Switch Module-trafficpolicy-p1] quit
    [*Switch Module] commit
    

  5. Apply the traffic policy p1 to the inbound interface 10GE1/17/1 on Switch Module.

    [~Switch Module] interface 10ge 1/17/1
    [~Switch Module-10GE1/17/1] traffic-policy p1 inbound
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] commit
    

  6. Verify the configuration.

    # View the traffic classifier configuration.

    [~Switch Module] display traffic classifier
      Traffic Classifier Information:
        Classifier: c1
          Type: OR
          Rule(s):
            if-match dscp af21
    
        Classifier: c2
          Type: OR
          Rule(s):
            if-match dscp cs5
    
        Classifier: c3
          Type: OR
          Rule(s):
            if-match dscp ef
    
    Total classifier number is 3
    

    # View the traffic policy configuration.

    [~Switch Module] display traffic policy
      Traffic Policy Information:
        Policy: p1
          Classifier: c1
            Type: OR
          Behavior: b1
            Committed Access Rate:
              CIR 50000 (Kbps), PIR 100000 (Kbps), CBS 6250000 (Bytes), PBS 12500000 (Bytes)
              Color Mode: color blind
              Conform Action: pass
              Yellow  Action: pass
              Exceed  Action: discard
            Share car:
              Car car_total share
            Statistics: enable
    
          Classifier: c2
            Type: AND
          Behavior: b2
            Committed Access Rate:
              CIR 200000 (Kbps), PIR 400000 (Kbps), CBS 25000000 (Bytes), PBS 50000000 (Bytes) 
              Color Mode: color blind
              Conform Action: pass
              Yellow  Action: pass
              Exceed  Action: discard
            Share car:
              Car car_total share
            Statistics: enable
    
          Classifier: c3
            Type: AND
          Behavior: b3
            Committed Access Rate:
              CIR 100000 (Kbps), PIR 200000 (Kbps), CBS 12500000 (Bytes), PBS 25000000 (Bytes)
              Color Mode: color blind
              Conform Action: pass
              Yellow  Action: pass
              Exceed  Action: discard
            Share car:
              Car car_total share
            Statistics: enable
    
    Total policy number is 1
    

    # View the traffic policy statistics on 10GE1/17/1 of Switch Module.

    [~Switch Module] display traffic-policy statistics interface 10ge 1/17/1 inbound
    Traffic policy: p1, inbound
    -------------------------------------------------------------------------                                                           
      Slot: 2                                                                                                                           
        Item                              Packets                       Bytes                                                           
        ---------------------------------------------------------------------                                                           
        Matched                         231899573                 24118326440                                                           
          +--Passed                     136982327                 14246674104                                                           
          +--Dropped                     94917246                  9871652336                                                           
            +--Filter                           0                           0                                                           
            +--CAR                       94917246                  9871652336                                                           
        ---------------------------------------------------------------------

Configuration Files

  • Configuration file of Switch Module
    #
    sysname Switch Module
    #
    vlan batch 10
    #
    qos car car_total cir 500000 kbps 
    #
    traffic classifier c1 type or
     if-match dscp af21
    #
    traffic classifier c2 type or
     if-match dscp cs5
    #
    traffic classifier c3 type or
     if-match dscp ef
    #
    traffic behavior b1
     car cir 50000 kbps pir 100000 kbps
     car car_total share
     statistics enable
    #
    traffic behavior b2
     car cir 200000 kbps pir 400000 kbps
     car car_total share
     statistics enable
    #
    traffic behavior b3
     car cir 100000 kbps pir 200000 kbps
     car car_total share
     statistics enable
    #
    traffic policy p1
     classifier c1 behavior b1 precedence 5
     classifier c2 behavior b2 precedence 10
     classifier c3 behavior b3 precedence 15
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
     traffic-policy p1 inbound
    #
    interface 40GE1/18/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
  • Configuration file of Switch ModuleA
    #
    sysname Switch ModuleA
    #
    vlan batch 10
    #
    interface 10GE1/17/1
     port default vlan 10
    #
    interface 10GE1/17/2
     port link-type tunk
     port trunk allow-pass vlan 10
    #
    return
    

Example for Configuring Traffic Shaping

Networking Requirements

As shown in Figure 13-22, the Switch Module connects to RouterA through 40GE1/18/1; three servers locate in the data center to provide voice, video, and data services; packets of different services are identified by 802.1p priorities, for example, 802.1p priorities of the voice, video, and data services are 5, 3, and 2 respectively. When packets reach 40GE1/18/1, jitter may occur. The following conditions must be met to prevent jitter and ensure bandwidth for services:

  • The CIR on the interface is 12000 kbit/s.

  • The CIR and PIR for the voice service are 3000 kbit/s and 5000 kbit/s respectively.

  • The CIR and PIR for the video service are 5000 kbit/s and 8000 kbit/s respectively.

  • The CIR and PIR for the data service are 2000 kbit/s and 3000 kbit/s respectively.

Figure 13-22 Networking of traffic shaping

Configuration Roadmap

The configuration roadmap is as follows:
  1. Create VLANs and configure interfaces on the Switch Module so that users can access the network.
  2. Set priorities for interfaces connecting Switch ModuleA and servers to differentiate service packets.

  3. Configure interface-based rate limiting in the outbound direction to limit the bandwidth of the interface.

  4. Configure traffic shaping for queues on the interface to limit the bandwidth of voice, video, and data services.

Procedure

  1. Create VLANs and configure interfaces on Switch Module.

    # Create VLANs 10, 20 and 30.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch Module
    [*HUAWEI] commit
    [~Switch Module] vlan batch 10 20 30
    [*Switch Module] commit

    # Configure 10GE1/17/1 and 40GE1/18/1 as trunk interfaces, and add them to VLANs 10, 20, and 30.

    [~Switch Module] interface 10ge 1/17/1
    [*Switch Module-10GE1/17/1] port link-type trunk
    [*Switch Module-10GE1/17/1] port trunk allow-pass vlan 10 20 30
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] commit
    [~Switch Module] interface 40ge 1/18/1
    [~Switch Module-40GE1/18/1] port link-type trunk
    [*Switch Module-40GE1/18/1] port trunk allow-pass vlan 10 20 30
    [*Switch Module-40GE1/18/1] quit
    [*Switch Module] commit

  2. Set priorities for interfaces connecting Switch ModuleA and servers.

    # Set priorities of 10GE1/17/1, 10GE1/17/2, and 10GE1/17/3 to 5, 3, and 2 respectively.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port default vlan 10
    [*Switch ModuleA-10GE1/17/1] port priority 5
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] commit
    [~Switch ModuleA] interface 10ge 1/17/2
    [~Switch ModuleA-10GE1/17/2] port default vlan 20
    [*Switch ModuleA-10GE1/17/2] port priority 3
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] commit
    [~Switch ModuleA] interface 10ge 1/17/3
    [~Switch ModuleA-10GE1/17/3] port default vlan 30
    [*Switch ModuleA-10GE1/17/3] port priority 2
    [*Switch ModuleA-10GE1/17/3] quit
    [*Switch ModuleA] commit

  3. Configure traffic shaping on 40GE1/18/1 and set the rate limit to 12000 kbit/s.

    [~Switch Module] interface 40ge 1/18/1
    [~Switch Module-40GE1/18/1] qos lr cir 12000 outbound
    [*Switch Module-40GE1/18/1] quit
    [*Switch Module] commit

  4. Configure traffic shaping for queues on the interface.

    # Configure queue shaping on the Switch Module to set the CIR values of packets of the voice, video, and data services to 3000 kbit/s, 5000 kbit/s, and 2000 kbit/s respectively and their PIR values to 5000 kbit/s, 8000 kbit/s, and 3000 kbit/s respectively.

    [~Switch Module] interface 40ge 1/18/1
    [~Switch Module-40GE1/18/1] qos queue 5 shaping cir 3000 pir 5000
    [*Switch Module-40GE1/18/1] qos queue 3 shaping cir 5000 pir 8000
    [*Switch Module-40GE1/18/1] qos queue 2 shaping cir 2000 pir 3000
    [*Switch Module-40GE1/18/1] quit
    [*Switch Module] commit

  5. Verify the configuration.

    # View outbound queue statistics on 40GE1/18/1.

    [~Switch Module] display qos queue statistics interface 40ge 1/18/1
     Queue    CIR/PIR                  Passed     Pass Rate                 Dropped     Drop Rate                                       
               (kbps)           (Packets/Bytes)     (pps/bps)           (Packets/Bytes)     (pps/bps)                                       
     --------------------------------------------------------------------------------------------                                       
         0          0                       0             0                       0             0                                       
             40000000                       0             0                       0             0                                       
     --------------------------------------------------------------------------------------------                                       
         1          0                       0             0                       0             0                                       
             40000000                       0             0                       0             0                                       
     --------------------------------------------------------------------------------------------                                       
         2       2000                   54584             0                       0             0                                       
                 3000                 5676736             0                       0             0                                       
     --------------------------------------------------------------------------------------------                                       
         3       5000                   49648             0                       0             0                                       
                 8000                 5163392             0                       0             0                                       
     --------------------------------------------------------------------------------------------                                       
         4          0                       0             0                       0             0                                       
             40000000                       0             0                       0             0                                       
     --------------------------------------------------------------------------------------------                                       
         5       3000                   49998             0                       0             0                                       
                 5000                 5199792             0                       0             0                                       
     --------------------------------------------------------------------------------------------                                       
         6          0                       0             0                       0             0                                       
             40000000                       0             0                       0             0                                       
     --------------------------------------------------------------------------------------------                                       
         7          0                       0             0                       0             0                                       
             40000000                       0             0                       0             0                                       
     --------------------------------------------------------------------------------------------  

Configuration Files

  • Configuration file of the Switch Module
    #
    sysname Switch Module
    #
    vlan batch 10 20 30
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 20 30
    #
    interface 40GE1/18/1
     port link-type trunk
     port trunk allow-pass vlan 10 20 30
     qos lr cir 12000 kbps outbound
     qos queue 2 shaping cir 2000 kbps pir 3000 kbps
     qos queue 3 shaping cir 5000 kbps pir 8000 kbps
     qos queue 5 shaping cir 3000 kbps pir 5000 kbps
    #
    return
    
  • Configuration file of Switch ModuleA
    #
    sysname Switch ModuleA
    #
    interface 10GE1/17/1
     port default vlan 10
     port priority 5
    #
    interface 10GE1/17/2
     port default vlan 20
     port priority 3
    #
    interface 10GE1/17/3
     port default vlan 30
     port priority 2
    #
    return
Translation
Download
Updated: 2019-12-13

Document ID: EDOC1000041694

Views: 59872

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next