No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 13

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section describes several configuration examples of the Smart Link. You can comprehend the configuration procedures through the configuration roadmap. The configuration examples explain networking requirements, configuration notes, and configuration roadmap.

Example for Configuring Link Redundancy of Smart Link

Networking Requirements

As shown in Figure 11-84, the user-side network uses the dual-homing mode to ensure network reliability. It is required that loops be removed and link redundancy and fast convergence be implemented.

Figure 11-84 Networking of link redundancy of Smart Link

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create VLANs and configure allowed VLANs on interfaces.

  2. Create a Smart Link group on SwitchA and specify interface roles.

  3. Enable revertive switching on SwitchA so that traffic switches to the original active link after the fault on the active link is rectified.

  4. Enable SwitchA to send Flush packets.

  5. Enable SwitchB, SwitchC, and SwitchD to receive Flush packets on the interfaces.

  6. Enable the Smart Link group on SwitchA.

Procedure

  1. Create VLANs on Switch ModuleA and configure allowed VLANs on interfaces.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 10 to 30 
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 10 to 30
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit
    [~Switch ModuleA] interface 10ge 1/17/2
    [~Switch ModuleA-10GE1/17/2] port link-type trunk
    [*Switch ModuleA-10GE1/17/2] port trunk allow-pass vlan 10 to 30
    [*Switch ModuleA-10GE1/17/2] commit
    [~Switch ModuleA-10GE1/17/2] quit
    

    The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here.

  2. Create a Smart Link group on Switch ModuleA and specify interface roles.

    # Configure Switch ModuleA.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] stp disable
    [~Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit
    [~Switch ModuleA] interface 10ge 1/17/2
    [~Switch ModuleA-10GE1/17/2] stp disable
    [~Switch ModuleA-10GE1/17/2] commit
    [~Switch ModuleA-10GE1/17/2] quit
    [~Switch ModuleA] smart-link group 1
    [*Switch ModuleA-smlk-group1] port 10ge 1/17/1 master
    [*Switch ModuleA-smlk-group1] port 10ge 1/17/2 slave
    [*Switch ModuleA-smlk-group1] commit

  3. Enable revertive switching and set the WTR time.

    # Configure Switch ModuleA.

    [~Switch ModuleA-smlk-group1] restore enable
    [*Switch ModuleA-smlk-group1] timer wtr 30
    [*Switch ModuleA-smlk-group1] commit

  4. Enable Switch ModuleA to send Flush packets.

    # Configure Switch ModuleA. Indicates that the Flush packets sent from the Smart Link group contain an SHA-encrypted password.

    [~Switch ModuleA-smlk-group1] flush send control-vlan 10 password sha 123
    [*Switch ModuleA-smlk-group1] commit

  5. Enable Switch ModuleB, Switch ModuleC, and Switch ModuleD to receive Flush packets.

    # Configure Switch ModuleB and encrypt the password for receiving Flush packets using SHA.

    [~Switch ModuleB] interface 10ge 1/17/1
    [~Switch ModuleB-10GE1/17/1] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleB-10GE1/17/1] commit
    [~Switch ModuleB-10GE1/17/1] quit
    [~Switch ModuleB] interface 10ge 1/17/2
    [~Switch ModuleB-10GE1/17/2] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleB-10GE1/17/2] commit
    [~Switch ModuleB-10GE1/17/2] quit
    

    # Configure Switch ModuleC and encrypt the password for receiving Flush packets using SHA.

    [~Switch ModuleC] interface 10ge 1/17/1
    [~Switch ModuleC-10GE1/17/1] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleC-10GE1/17/1] commit
    [~Switch ModuleC-10GE1/17/1] quit
    [~Switch ModuleC] interface 10ge 1/17/2
    [~Switch ModuleC-10GE1/17/2] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleC-10GE1/17/2] commit
    [~Switch ModuleC-10GE1/17/2] quit
    

    # Configure Switch ModuleD and encrypt the password for receiving Flush packets using SHA.

    [~Switch ModuleD] interface 10ge 1/17/1
    [~Switch ModuleD-10GE1/17/1] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleD-10GE1/17/1] commit
    [~Switch ModuleD-10GE1/17/1] quit
    [~Switch ModuleD] interface 10ge 1/17/2
    [~Switch ModuleD-10GE1/17/2] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleD-10GE1/17/2] commit
    [~Switch ModuleD-10GE1/17/2] quit
    

  6. Enable the Smart Link group on Switch ModuleA.

    [~Switch ModuleA-smlk-group1] smart-link enable
    [*Switch ModuleA-smlk-group1] commit
    [~Switch ModuleA-smlk-group1] quit

  7. Verify the configuration.

    # Run the display smart-link group command to view information about the Smart Link group on Switch ModuleA. If the following information is displayed, the configuration is successful:

    • The Smart Link function is enabled.
    • The interval of revertive switching is 30s.
    • The control VLAN ID is 10.
    • 10GE1/17/1 is the master interface and is in Active state, and 10GE1/17/2 is the slave interface and is in Inactive state.
    [~Switch ModuleA] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group: enabled
      Wtr-time is: 30 sec.
      Load-Balance Instance: --                                                                                                         
      Protected-VLAN reference-instance: --
      DeviceID: 0018-2000-0083  Control-VLAN ID: 10
      Member       Role    InstanceID  State      Flush Count  Last-Flush-Time
      -----------------------------------------------------------------------------------
      10GE1/17/1    Master           0  Active               0  0000/00/00 00:00:00 UTC+00:00
      10GE1/17/2    Slave            0  Inactive             0  0000/00/00 00:00:00 UTC+00:00
    

    # Run the shutdown command to shut down 10GE1/17/1. You can see that 10GE1/17/1 is in Inactive state and 10GE1/17/2 is in Active state.

    [~Switch ModuleA] system-view
    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] shutdown
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group: enabled
      Wtr-time is: 30 sec.
      Load-Balance Instance: --                                                                                                         
      Protected-VLAN reference-instance: --
      DeviceID: 0018-2000-0083  Control-VLAN ID: 10
      Member       Role    InstanceID  State      Flush Count  Last-Flush-Time
      ------------------------------------------------------------------------------------
      10GE1/17/1    Master           0  Inactive             0  0000/00/00 00:00:00 UTC+00:00
      10GE1/17/2    Slave            0  Active               1  2013/05/05 10:34:46 UTC+00:00
    

    # Run the undo shutdown command to start 10GE1/17/1. After 30s, you can see that 10GE1/17/1 is in Active state and 10GE1/17/2 is in Inactive state.

    [~Switch ModuleA-10GE1/17/1] undo shutdown
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group: enabled
      Wtr-time is: 30 sec.
      Load-Balance Instance: --                                                                                                         
      Protected-VLAN reference-instance: --
      DeviceID: 0018-2000-0083  Control-VLAN ID: 10
      Member       Role    InstanceID  State      Flush Count  Last-Flush-Time
      -----------------------------------------------------------------------------------
      10GE1/17/1    Master           0  Active               1  2013/05/05 10:35:46 UTC+00:00
      10GE1/17/2    Slave            0  Inactive             1  2013/05/05 10:34:46 UTC+00:00
    

Configuration Files

  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 to 30
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
    #
    smart-link group 1
     restore enable
     smart-link enable
     port 10GE1/17/1 master
     port 10GE1/17/2 slave
     timer wtr 30
     flush send control-vlan 10 password sha @%@%;Ddy,`FNyIFb\o+3WMHE,E~d@%@%
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 10 to 30
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     smart-link flush receive control-vlan 10 password sha @%@%FzQY')e<hPA~oH$^C11U,HA;@%@%
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     smart-link flush receive control-vlan 10 password sha @%@%kJ'J*+falJfD\&/'V]iH,HXh@%@%
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 10 to 30
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     smart-link flush receive control-vlan 10 password sha @%@%h"xBTq7oD*sM/'Z!vBgB,HF\@%@%
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     smart-link flush receive control-vlan 10 password sha @%@%#!Y(Uo`H{;9"*n(u>qo+,HVu@%@%
    #
    return
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 10 to 30
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     smart-link flush receive control-vlan 10 password sha @%@%a\,kTUwbY1x3h/(wa0#I,H(i@%@%
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     smart-link flush receive control-vlan 10 password sha @%@%F9|"$A,M=6+\>7Gk9UN%,H:9@%@%
    #
    return

Example for Configuring Load Balancing on a Smart Link Instance

Networking Requirements

As shown in Figure 11-85, the user-side network uses the dual-homing mode to ensure network reliability. Multiple VLAN data flows exist on the network. To increase the link use efficiency, the two uplinks both forward the data flows. The service interruption duration is restricted to millisecond level.

Figure 11-85 Example for configuring load balancing between active and standby links of a Smart Link group

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a Smart Link group on Switch A and add the corresponding interface to the Smart Link group.
  2. Map VLAN 500 to load balancing instance 10.
  3. Create a Smart Link group on SwitchA and specify interface roles.
  4. Configure load balancing on Switch A and forward the data flows from VLANs mapped to instance 10 through the backup link.
  5. Enable revertive switching on Switch A to switch traffic to the original active link.
  6. Enable the function of sending Flush packets on Switch A.
  7. Enable SwitchB, SwitchC, and SwitchD to receive Flush packets on the interfaces.
  8. Enable Smart Link on Switch A.

Procedure

  1. Create VLANs on Switch ModuleA, and configure interfaces to allow these VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 10 100 500 
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 10 100 500
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit
    [~Switch ModuleA] interface 10ge 1/17/2
    [~Switch ModuleA-10GE1/17/2] port link-type trunk
    [*Switch ModuleA-10GE1/17/2] port trunk allow-pass vlan 10 100 500
    [*Switch ModuleA-10GE1/17/2] commit
    [~Switch ModuleA-10GE1/17/2] quit
    

    The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA and are not mentioned here. For details, see the configuration files.

  2. Configure VLAN mapping on Switch ModuleA.

    [~Switch ModuleA] stp region-configuration
    [~Switch ModuleA-mst-region] instance 10 vlan 500
    [*Switch ModuleA-mst-region] commit
    [~Switch ModuleA-mst-region] quit
    

  3. Disable STP on uplink interfaces, add the interfaces to the Smart Link group, and specify the master and slave interfaces.

    # Configure Switch ModuleA.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] stp disable
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit
    [~Switch ModuleA] interface 10ge 1/17/2
    [~Switch ModuleA-10GE1/17/2] stp disable
    [*Switch ModuleA-10GE1/17/2] commit
    [~Switch ModuleA-10GE1/17/2] quit
    [~Switch ModuleA] smart-link group 1
    [*Switch ModuleA-smlk-group1] port 10ge 1/17/1 master
    [*Switch ModuleA-smlk-group1] port 10ge 1/17/2 slave
    [*Switch ModuleA-smlk-group1] commit

  4. Configure load balancing on Switch ModuleA.

    [~Switch ModuleA-smlk-group1] load-balance instance 10 slave
    [*Switch ModuleA-smlk-group1] commit

  5. Enable revertive switching and set the WTR time.

    # Configure Switch ModuleA.

    [~Switch ModuleA-smlk-group1] restore enable
    [*Switch ModuleA-smlk-group1] timer wtr 30
    [*Switch ModuleA-smlk-group1] commit

  6. Enable the function of sending Flush packets.

    # Configure Switch ModuleA and encrypt the password for receiving Flush packets using SHA.

    [~Switch ModuleA-smlk-group1] flush send control-vlan 10 password sha 123
    [*Switch ModuleA-smlk-group1] commit

  7. Enable the function of receiving Flush packets.

    # Configure Switch ModuleB and encrypt the password for receiving Flush packets using SHA.

    [~Switch ModuleB] interface 10ge 1/17/1
    [~Switch ModuleB-10GE1/17/1] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleB-10GE1/17/1] commit
    [~Switch ModuleB-10GE1/17/1] quit
    [~Switch ModuleB] interface 10ge 1/17/2
    [~Switch ModuleB-10GE1/17/2] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleB-10GE1/17/2] commit
    [~Switch ModuleB-10GE1/17/2] quit
    

    # Configure Switch ModuleC and encrypt the password for receiving Flush packets using SHA.

    [~Switch ModuleC] interface 10ge 1/17/1
    [~Switch ModuleC-10GE1/17/1] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleC-10GE1/17/1] commit
    [~Switch ModuleC-10GE1/17/1] quit
    [~Switch ModuleC] interface 10ge 1/17/2
    [~Switch ModuleC-10GE1/17/2] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleC-10GE1/17/2] commit
    [~Switch ModuleC-10GE1/17/2] quit
    

    # Configure Switch ModuleD and encrypt the password for receiving Flush packets using SHA.

    [~Switch ModuleD] interface 10ge 1/17/1
    [~Switch ModuleD-10GE1/17/1] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleD-10GE1/17/1] commit
    [~Switch ModuleD-10GE1/17/1] quit
    [~Switch ModuleD] interface 10ge 1/17/2
    [~Switch ModuleD-10GE1/17/2] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleD-10GE1/17/2] commit
    [~Switch ModuleD-10GE1/17/2] quit
    

  8. Enable Smart Link on Switch ModuleA.

    [~Switch ModuleA-smlk-group1] smart-link enable
    [*Switch ModuleA-smlk-group1] commit
    [~Switch ModuleA-smlk-group1] quit

  9. Check the configuration.

    # Run the display smart-link group command to view information about the Smart Link group on Switch ModuleA. If the following information is displayed, it indicates that the configuration is successful.

    • The Smart Link function is enabled.
    • The WTR time is 30 seconds.
    • The control VLAN ID is 10.
    • 10GE 1/17/1 is the active interface and is in Active state, and 10GE 1/17/2 is the standby interface and is in Inactive state. The load balancing function is configured.
    [~Switch ModuleA] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group: enabled
      Wtr-time is: 30 sec.
      Load-Balance Instance: 10
      Protected-VLAN reference-instance: --
      DeviceID: 0018-2000-0083  Control-VLAN ID: 10
      Member       Role    InstanceID  State      Flush Count  Last-Flush-Time
      -----------------------------------------------------------------------------------
      10GE1/17/1    Master           0  Active               0  0000/00/00 00:00:00 UTC+00:00
      10GE1/17/1    Master          10  Inactive             0  0000/00/00 00:00:00 UTC+00:00
      10GE1/17/2    Slave            0  Inactive             0  0000/00/00 00:00:00 UTC+00:00
      10GE1/17/2    Slave           10  Active               0  0000/00/00 00:00:00 UTC+00:00
    

    # Run the shutdown command to shut down 10GE 1/17/1, and you can find that 10GE 1/17/1 is in Inactive state and 10GE 1/17/2 is in Active state.

    [~Switch ModuleA] system-view
    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] shutdown
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group: enabled
      Wtr-time is: 30 sec.
      Load-Balance Instance: 10
      Protected-VLAN reference-instance: --
      DeviceID: 0018-2000-0083  Control-VLAN ID: 10
      Member       Role    InstanceID  State      Flush Count  Last-Flush-Time
      -----------------------------------------------------------------------------------
      10GE1/17/1    Master           0  Inactive             0  0000/00/00 00:00:00 UTC+00:00
      10GE1/17/1    Master          10  Inactive             0  0000/00/00 00:00:00 UTC+00:00
      10GE1/17/2    Slave            0  Active               1  2013/01/05 10:34:46 UTC+08:00
      10GE1/17/2    Slave           10  Active               1  2013/01/05 10:34:46 UTC+08:00
    

    # Run the undo shutdown command to enable 10GE 1/17/1 and wait for 30 seconds, and you can find that 10GE 1/17/1 is in Active state and 10GE 1/17/2 is in Inactive state.

    [~Switch ModuleA-10GE1/17/1] undo shutdown
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group: enabled
      Wtr-time is: 30 sec.
      Load-Balance Instance: 10
      Protected-VLAN reference-instance: --
      DeviceID: 0018-2000-0083  Control-VLAN ID: 10
      Member       Role    InstanceID  State      Flush Count  Last-Flush-Time
      -----------------------------------------------------------------------------------
      10GE1/17/1    Master           0  Active               1  2013/01/05 10:35:46 UTC+08:00
      10GE1/17/1    Master          10  Inactive             1  2013/01/05 10:35:46 UTC+08:00
      10GE1/17/2    Slave            0  Inactive             1  2013/01/05 10:34:46 UTC+08:00
      10GE1/17/2    Slave           10  Active               1  2013/01/05 10:34:46 UTC+08:00
    

Configuration Files

  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 100 500
    #
    stp region-configuration
     instance 10 vlan 500
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 100 500
     stp disable
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10 100 500
     stp disable
    #
    smart-link group 1
     load-balance instance 10 slave
     restore enable
     smart-link enable
     port 10GE1/17/1 master
     port 10GE1/17/2 slave
     timer wtr 30
     flush send control-vlan 10 password sha @%@%;Ddy,`FNyIFb\o+3WMHE,E~d@%@%
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 10 100 500
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 100 500
     smart-link flush receive control-vlan 10 password sha @%@%FzQY')e<hPA~oH$^C11U,HA;@%@%
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10 100 500
     smart-link flush receive control-vlan 10 password sha @%@%kJ'J*+falJfD\&/'V]iH,HXh@%@%
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 10 100 500
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 100 500
     smart-link flush receive control-vlan 10 password sha @%@%h"xBTq7oD*sM/'Z!vBgB,HF\@%@%
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10 100 500
     smart-link flush receive control-vlan 10 password sha @%@%#!Y(Uo`H{;9"*n(u>qo+,HVu@%@%
    #
    return
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 10 100 500
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 100 500
     smart-link flush receive control-vlan 10 password sha @%@%a\,kTUwbY1x3h/(wa0#I,H(i@%@%
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10 100 500
     smart-link flush receive control-vlan 10 password sha @%@%F9|"$A,M=6+\>7Gk9UN%,H:9@%@%
    #
    return

Example for Configuring the Integrated Application of Monitor Link and Smart Link

Networking Requirements

As shown in Figure 11-86, Switch ModuleC on the MAN is connected to user networks. It accesses the backbone network through upstream devices Switch ModuleA and Switch ModuleB in dual-homing mode.

A monitoring mechanism is required to prevent service interruption caused by uplink faults. When the uplink fails, the downlink rapidly detects the fault. Therefore, link switching is performed in a timely manner, which shortens the interruption duration.

Figure 11-86 Example for configuring the integrated application of Smart Link and Monitor Link

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a Smart Link group on Switch ModuleA and Switch ModuleC and add corresponding interfaces to the Smart Link group.
  2. Configure a Monitor Link group on Switch ModuleA and set the Smart Link group as uplinks. Smart Link and Monitor Link are used together. The Smart Link group improves the uplink reliability in the Monitor Link group.
  3. Configure a Monitor Link group on Switch ModuleB to enable the Smart Link group on Switch ModuleC to rapidly detect uplink faults. The application scope of Smart Link functions is broadened.
  4. Enable the function of sending Flush packets on Switch ModuleA andSwitch ModuleC.
  5. Enable the function of receiving Flush packets on Switch ModuleA and Switch ModuleB.

Procedure

  1. Configure the same control VLAN on Switch ModuleA, Switch ModuleB and Switch ModuleC. Add the interfaces of the Smart Link group or Monitor Link group to this VLAN.

    The configuration procedure is not mentioned here. For details, see VLAN Configuration in CX11x&CX31x&CX91x Series Switch Modules Configuration Guide - Ethernet Configuration.

  2. Create a Smart Link group.

    # Configure Switch ModuleA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~Switch ModuleA] smart-link group 1
    [*Switch ModuleA-smlk-group1] commit
    [~Switch ModuleA-smlk-group1] quit

    # Configure Switch ModuleC.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchC
    [*HUAWEI] commit
    [~Switch ModuleC] smart-link group 2
    [*Switch ModuleC-smlk-group2] commit
    [~Switch ModuleC-smlk-group2] quit

  3. Add interfaces to the Smart Link group and specify the master and slave interfaces.

    # Configure Switch ModuleA.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] stp disable
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit
    [~Switch ModuleA] interface 10ge 1/17/2
    [~Switch ModuleA-10GE1/17/2] stp disable
    [*Switch ModuleA-10GE1/17/2] commit
    [~Switch ModuleA-10GE1/17/2] quit
    [~Switch ModuleA] smart-link group 1
    [*Switch ModuleA-smlk-group1] port 10ge 1/17/1 master
    [*Switch ModuleA-smlk-group1] port 10ge 1/17/2 slave
    [*Switch ModuleA-smlk-group1] commit

    # Configure Switch ModuleC.

    [~Switch ModuleC] interface 10ge 1/17/1
    [~Switch ModuleC-10GE1/17/1] stp disable
    [*Switch ModuleC-10GE1/17/1] commit
    [~Switch ModuleC-10GE1/17/1] quit
    [~Switch ModuleC] interface 10ge 1/17/2
    [~Switch ModuleC-10GE1/17/2] stp disable
    [*Switch ModuleC-10GE1/17/2] commit
    [~Switch ModuleC-10GE1/17/2] quit
    [~Switch ModuleC] smart-link group 2
    [*Switch ModuleC-smlk-group2] port 10ge 1/17/1 master
    [*Switch ModuleC-smlk-group2] port 10ge 1/17/2 slave
    [*Switch ModuleC-smlk-group2] commit

  4. Enable revertive switching and set the WTR time.

    # Configure Switch ModuleA.

    [*Switch ModuleA-smlk-group1] restore enable
    [*Switch ModuleA-smlk-group1] timer wtr 30
    [*Switch ModuleA-smlk-group1] commit

    # Configure Switch ModuleC.

    [*Switch ModuleC-smlk-group2] restore enable
    [*Switch ModuleC-smlk-group2] timer wtr 30
    [*Switch ModuleC-smlk-group2] commit

  5. Enable the function of sending or receiving Flush packets.

    # Configure Switch ModuleA and encrypt the password for receiving Flush packets using SHA.

    [~Switch ModuleA-smlk-group1] flush send control-vlan 10 password sha 123
    [*Switch ModuleA-smlk-group1] commit
    [~Switch ModuleA-smlk-group1] quit
    [~Switch ModuleA] interface 10ge 2/17/1
    [~Switch ModuleA-10GE2/17/1] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleA-10GE2/17/1] commit
    [~Switch ModuleA-10GE2/17/1] quit
    [~Switch ModuleA] interface 10ge 2/17/2
    [~Switch ModuleA-10GE2/17/2] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleA-10GE2/17/2] commit
    [~Switch ModuleA-10GE2/17/2] quit
    

    # Configure Switch ModuleB and encrypt the password for receiving Flush packets using SHA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~HUAWEIB] interface 10ge 2/17/1
    [~Switch ModuleB-10GE2/17/1] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleB-10GE2/17/1] commit
    [~Switch ModuleB-10GE2/17/1] quit
    [~Switch ModuleB] interface 10ge 2/17/2
    [~Switch ModuleB-10GE2/17/2] smart-link flush receive control-vlan 10 password sha 123
    [*Switch ModuleA-10GE2/17/2] commit
    [~Switch ModuleB-10GE2/17/2] quit
    

    # Configure Switch ModuleC and encrypt the password for receiving Flush packets using SHA.

    [~Switch ModuleC-smlk-group2] flush send control-vlan 10 password sha 123
    [*Switch ModuleC-smlk-group2] commit
    [~Switch ModuleC-smlk-group2] quit

  6. Enable the Smart Link function.

    # Configure Switch ModuleA.

    [~Switch ModuleA] smart-link group 1
    [*Switch ModuleA-smlk-group1] smart-link enable
    [*Switch ModuleA-smlk-group1] commit
    [~Switch ModuleA-smlk-group1] quit

    # Configure Switch ModuleC.

    [~Switch ModuleC] smart-link group 2
    [*Switch ModuleC-smlk-group2] smart-link enable
    [*Switch ModuleC-smlk-group2] commit
    [~Switch ModuleC-smlk-group2] quit

  7. Create a Monitor Link group and add the uplink and downlink interfaces to the Monitor Link group.

    # Configure Switch ModuleA.

    [*Switch ModuleA] monitor-link group 1
    [*Switch ModuleA-mtlk-group1] smart-link group 1 uplink
    [*Switch ModuleA-mtlk-group1] port 10ge 2/17/1 downlink 1
    [*Switch ModuleA-mtlk-group1] commit

    # Configure Switch ModuleB.

    [*Switch ModuleB] monitor-link group 2
    [*Switch ModuleB-mtlk-group2] port 10ge 1/17/1 uplink
    [*Switch ModuleB-mtlk-group2] port 10ge 2/17/1 downlink 1
    [*Switch ModuleB-mtlk-group2] commit

  8. Set the WTR time of a Monitor Link group.

    # Configure Switch ModuleA.

    [*Switch ModuleA-mtlk-group1] timer recover-time 10
    [*Switch ModuleA-mtlk-group1] commit
    [*Switch ModuleA-mtlk-group1] quit

    # Configure Switch ModuleB.

    [*Switch ModuleB-mtlk-group2] timer recover-time 10
    [*Switch ModuleB-mtlk-group2] commit
    [*Switch ModuleB-mtlk-group2] quit

  9. Check the configuration.

    [~Switch ModuleA] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group: enabled
      Wtr-time is: 30 sec.
      Load-Balance Instance: --                                                                                                         
      Protected-VLAN reference-instance: --
      DeviceID: 0018-2000-0083  Control-VLAN ID: 10
      Member       Role    InstanceID  State      Flush Count  Last-Flush-Time
      ------------------------------------------------------------------------
      10GE1/17/1    Master           0  Active               0  0000/00/00 00:00:00 UTC+05:00
      10GE1/17/2    Slave            0  Inactive             0  0000/00/00 00:00:00 UTC+05:00
    
    [~Switch ModuleA] display monitor-link group 1
    Monitor Link group 1 information : 
      Recover-timer is 10 sec.                                                       
        Member   Role     State Last-up-time                       Last-down-time 
     Smart-link1 UpLk     UP    0000/00/00 00:00:00 UTC+05:00      0000/00/00 00:00:00 UTC+05:00
     10GE2/17/1   DwLk[1]  UP    0000/00/00 00:00:00 UTC+05:00      0000/00/00 00:00:00 UTC+05:00
    

Configuration Files

  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface 10GE2/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
     smart-link flush receive control-vlan 10 password sha @%@%;Ddy,`FNyIFb\o+3WMHE,E~d@%@%
    #
    interface 10GE2/17/2
     port link-type trunk
     port trunk allow-pass vlan 10
     smart-link flush receive control-vlan 10 password sha @%@%FzQY')e<hPA~oH$^C11U,HA;@%@%
    #
    smart-link group 1
     restore enable
     smart-link enable 
     port 10GE1/17/1 master
     port 10GE1/17/2 slave 
     timer wtr 30
     flush send control-vlan 10 password sha @%@%kJ'J*+falJfD\&/'V]iH,HXh@%@%
    #
    monitor-link group 1
     smart-link group 1 uplink
     port 10GE2/17/1 downlink 1
     timer recover-time 10
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 10
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE2/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
     smart-link flush receive control-vlan 10 password sha @%@%h"xBTq7oD*sM/'Z!vBgB,HF\@%@%
    #
    interface 10GE2/17/2
     port link-type trunk
     port trunk allow-pass vlan 10
     smart-link flush receive control-vlan 10 password sha @%@%#!Y(Uo`H{;9"*n(u>qo+,HVu@%@%
    #
    monitor-link group 2
     port 10GE1/17/1 uplink
     port 10GE2/17/1 downlink 1
     timer recover-time 10
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 10
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    smart-link group 2
     restore enable
     smart-link enable 
     port 10GE1/17/1 master
     port 10GE1/17/2 slave 
     timer wtr 30
     flush send control-vlan 10 password sha @%@%a\,kTUwbY1x3h/(wa0#I,H(i@%@%
    #
    return
Translation
Download
Updated: 2019-12-13

Document ID: EDOC1000041694

Views: 60578

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next