No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides several configuration examples of OSPFv3 together with the configuration flowchart. The configuration examples explain networking requirements, and configuration roadmap.

Example for Configuring Basic OSPFv3 Functions

Networking Requirements

As shown in Figure 7-63, all switch moduless run OSPFv3. The entire autonomous system is divided into three areas. Switch Module B and Switch Module C serve as ABRs to forward the inter-area routes.

After the configuration, each router should learn the routes from the AS to all network segments.

Figure 7-63 Networking diagram of configuring OSPFv3 areas

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable basic OSPFv3 functions on each switch modules.

  2. Check the routing list and LSDB.

Procedure

  1. Assign an IPv6 address to each interface. The detailed configuration is not mentioned here.
  2. Configure basic OSPFv3 functions.

    # Configure Switch Module A.

    [~Switch ModuleA] ospfv3
    [*Switch ModuleA-ospfv3-1] router-id 1.1.1.1
    [*Switch ModuleA-ospfv3-1] quit
    [*Switch ModuleA] interface vlanif 20
    [*Switch ModuleA-Vlanif20] ospfv3 1 area 1
    [*Switch ModuleA-Vlanif20] quit
    [*Switch ModuleA] interface vlanif 40
    [*Switch ModuleA-Vlanif40] ospfv3 1 area 1
    [*Switch ModuleA-Vlanif40] quit
    [*Switch ModuleA] commit

    # Configure Switch Module B.

    [~Switch ModuleB] ospfv3
    [*Switch ModuleB-ospfv3-1] router-id 2.2.2.2
    [*Switch ModuleB-ospfv3-1] quit
    [*Switch ModuleB] interface vlanif 10
    [*Switch ModuleB-Vlanif10] ospfv3 1 area 0
    [*Switch ModuleB-Vlanif10] quit
    [*Switch ModuleB] interface vlanif 20
    [*Switch ModuleB-Vlanif20] ospfv3 1 area 1
    [*Switch ModuleB-Vlanif20] quit
    [*Switch ModuleB] commit

    # Configure Switch Module C.

    [~Switch ModuleC] ospfv3
    [*Switch ModuleC-ospfv3-1] router-id 3.3.3.3
    [*Switch ModuleC-ospfv3-1] quit
    [*Switch ModuleC] interface vlanif 10
    [*Switch ModuleC-Vlanif10] ospfv3 1 area 0
    [*Switch ModuleC-Vlanif10] quit
    [*Switch ModuleC] interface vlanif 30
    [*Switch ModuleC-Vlanif30] ospfv3 1 area 2
    [*Switch ModuleC-Vlanif30] quit
    [*Switch ModuleC] commit

    # Configure Switch Module D.

    [~Switch ModuleD] ospfv3
    [*Switch ModuleD-ospfv3-1] router-id 4.4.4.4
    [*Switch ModuleD-ospfv3-1] quit
    [*Switch ModuleD] interface vlanif 30
    [*Switch ModuleD-Vlanif30] ospfv3 1 area 2
    [*Switch ModuleD-Vlanif30] quit
    [*Switch ModuleD] commit

  3. Verify the configuration.

    #View the neighbors of Switch B, and you can see that the status of the neighbor relationship between Switch B and other devices is Full.

    [~Switch ModuleB] display ospfv3 peer
    
    
    OSPFv3 Process (1)
    OSPFv3 Area (0.0.0.0)
    Neighbor ID    Pri   State           Dead Time   Interface               Instance ID
    3.3.3.3        1     Full/Backup     00:00:32    Vlanif10                0
    OSPFv3 Area (0.0.0.1)
    Neighbor ID    Pri   State           Dead Time   Interface               Instance ID
    1.1.1.1        1     Full/DR         00:00:34    Vlanif20                0

    # Display the OSPFv3 neighbors of Switch ModuleC.

    [~Switch ModuleC] display ospfv3 peer
    
    
    OSPFv3 Process (1)
    OSPFv3 Area (0.0.0.0)
    Neighbor ID    Pri   State           Dead Time   Interface                Instance ID
    2.2.2.2        1     Full/DR         00:00:37    Vlanif10                 0
    OSPFv3 Area (0.0.0.2)
    Neighbor ID    Pri   State           Dead Time   Interface                Instance ID
    4.4.4.4        1     Full/Backup     00:00:33    Vlanif30                 0

    # Display the OSPFv3 routing table of Switch ModuleD.

    [~Switch ModuleD] display ospfv3 routing
                                                                                    
    Codes : E2 - Type 2 External, E1 - Type 1 External, IA - Inter-Area             
    Flags : A - Added to URT6                                                       
                                                                                    
    OSPFv3 Process (1)                                                              
         Destination                                                         Metric 
           Next-hop                                                                 
    IA   1000::/64                                                                2 
           via FE80::225:9EFF:FE01:211, Vlanif30, Flags : A                       
    IA   1001::/64                                                                3 
           via FE80::225:9EFF:FE01:211, Vlanif30, Flags : A                       
         1002::/64                                                                1 
           directly connected, Vlanif30, Flags : A                                
    IA   2000::/64                                                                4 
           via FE80::225:9EFF:FE01:211, Vlanif30, Flags : A                       

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 20 40
    #
    ospfv3 1
     router-id 1.1.1.1
     area 0.0.0.1
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 1001::2/64
     ospfv3 1 area 0.0.0.1
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address 2000::1/64
     ospfv3 1 area 0.0.0.1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 10 20
    #
    ospfv3 1
     router-id 2.2.2.2
     area 0.0.0.0
     area 0.0.0.1
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 1000::1/64
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 1001::1/64
     ospfv3 1 area 0.0.0.1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 10 30
    #
    ospfv3 1
     router-id 3.3.3.3
     area 0.0.0.0
     area 0.0.0.2
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 1000::2/64
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address 1002::1/64
     ospfv3 1 area 0.0.0.2
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 30
    #
    ospfv3 1
     router-id 4.4.4.4
     area 0.0.0.2
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address 1002::2/64
     ospfv3 1 area 0.0.0.2
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return

Example for Configuring DR Election Through OSPFv3

Networking Requirements

As shown in Figure 7-64, the priority of Switch ModuleA is 100, which is the highest priority on the network; therefore, Switch ModuleA is elected as the DR. Switch ModuleC, which has the second highest priority 2, is elected as the BDR. The priority of Switch ModuleB is 0, which means that it cannot become the DR. Switch ModuleD is not configured with a priority, that is, Switch ModuleD uses the default priority, namely, 1.

Figure 7-64 Networking diagram for configuring DR election through OSPFv3

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IPv6 addresses for interfaces.

  2. Configure the router ID of each Switch Module, enable OSPFv3, and specify the network segments.

  3. Check the DR/BDR status of each Switch Module when the default priority is used.

  4. Set the DR priority of the interface on each Switch Module and check whether the Switch Module becomes the DR or BDR.

Procedure

  1. Add interfaces to VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan 10
    [*Switch ModuleA-vlan10] quit
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk 
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] commit

    The configurations of Switch ModuleB, Switch ModuleC, Switch ModuleD are similar to the configuration of Switch ModuleA and are not mentioned here.

  2. Assign IPv6 addresses to the VLANIF interfaces.

    [~Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ipv6 enable
    [*Switch ModuleA-Vlanif10] ipv6 address 1001::1/64
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] commit

    The configurations of Switch ModuleB, Switch ModuleC, Switch ModuleD are similar to the configuration of Switch ModuleA and are not mentioned here.

  3. Configure the basic OSPFv3 functions.

    # On Switch ModuleA, enable OSPFv3 and set the router ID to 1.1.1.1.

    [~Switch ModuleA] ospfv3
    [*Switch ModuleA-ospfv3-1] router-id 1.1.1.1
    [*Switch ModuleA-ospfv3-1] quit
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ospfv3 1 area 0
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] commit

    # On Switch ModuleB, enable OSPFv3 and set the router ID to 2.2.2.2.

    [~Switch ModuleB] ospfv3
    [*Switch ModuleB-ospfv3-1] router-id 2.2.2.2
    [*Switch ModuleB-ospfv3-1] quit
    [*Switch ModuleB] interface vlanif 10
    [*Switch ModuleB-Vlanif10] ospfv3 1 area 0
    [*Switch ModuleB-Vlanif10] quit
    [*Switch ModuleB] commit

    # On Switch ModuleC, enable OSPFv3 and set the router ID to 3.3.3.3.

    [~Switch ModuleC] ospfv3
    [*Switch ModuleC-ospfv3-1] router-id 3.3.3.3
    [*Switch ModuleC-ospfv3-1] quit
    [*Switch ModuleC] interface vlanif 10
    [*Switch ModuleC-Vlanif10] ospfv3 1 area 0
    [*Switch ModuleC-Vlanif10] quit
    [*Switch ModuleC] commit

    # On Switch ModuleD, enable OSPFv3 and set the router ID to 4.4.4.4.

    [~Switch ModuleD] ospfv3
    [*Switch ModuleD-ospfv3-1] router-id 4.4.4.4
    [*Switch ModuleD-ospfv3-1] quit
    [*Switch ModuleD] interface vlanif 10
    [*Switch ModuleD-Vlanif10] ospfv3 1 area 0
    [*Switch ModuleD-Vlanif10] quit
    [*Switch ModuleD] commit

    Check the neighbors of Switch ModuleA. You can view the DR priority and the neighbor status. By default, the DR priority is 1. Now Switch ModuleD functions as the DR and Switch ModuleC functions as the BDR.

    NOTE:

    When the priorities of two Switch Modulees are the same, the Switch Module that has a greater router ID is elected as the DR. If the VLANIF interface of an Switch Module becomes the DR, the other broadcast interfaces of this Switch Module have a high priority in the future DR election. That is, the Switch Module still functions as the DR. The DR cannot be preempted.

    [~Switch ModuleA] display ospfv3 peer
    
    OSPFv3 Process (1)
    OSPFv3 Area (0.0.0.0)
    Neighbor ID     Pri   State            Dead Time   Interface  Instance ID
    2.2.2.2           1   2-Way/DROther    00:00:32    Vlanif10         0
    3.3.3.3           1   Full/Backup      00:00:36    Vlanif10         0
    4.4.4.4           1   Full/DR          00:00:38    Vlanif10         0

    # View the neighbors of Switch ModuleD, and you can see that the status of the neighbor relationship between Switch ModuleD and other devices is Full.

    [~Switch ModuleD] display ospfv3 peer
    
    OSPFv3 Process (1)
    OSPFv3 Area (0.0.0.0)
    Neighbor ID     Pri   State            Dead Time   Interface  Instance ID
    1.1.1.1           1   Full/DROther     00:00:32    Vlanif10         0
    2.2.2.2           1   Full/DROther     00:00:35    Vlanif10         0
    3.3.3.3           1   Full/Backup      00:00:30    Vlanif10         0

  4. Configure the DR priorities of interfaces.

    # Configure the DR priority of Switch ModuleA to 100.

    [~Switch ModuleA] interface vlanif 10
    [~Switch ModuleA-Vlanif10] ospfv3 dr-priority 100
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] commit

    # Configure the DR priority of Switch ModuleB to 0.

    [~Switch ModuleB] interface vlanif 10
    [~Switch ModuleB-Vlanif10] ospfv3 dr-priority 0
    [*Switch ModuleB-Vlanif10] quit
    [*Switch ModuleB] commit

    # Configure the DR priority of Switch ModuleC to 2.

    [~Switch ModuleC] interface vlanif 10
    [~Switch ModuleC-Vlanif10] ospfv3 dr-priority 2
    [*Switch ModuleC-Vlanif10] quit
    [*Switch ModuleC] commit

    # View the neighbors of Switch ModuleA, and you can see that the other DR priority is updated but the DR and BDR are unchanged.

    [~Switch ModuleA] display ospfv3 peer
    
    OSPFv3 Process (1)
    OSPFv3 Area (0.0.0.0)
    Neighbor ID     Pri   State            Dead Time   Interface  Instance ID
    2.2.2.2           0   2-Way/DROther    00:00:34    Vlanif10         0
    3.3.3.3           2   Full/Backup      00:00:38    Vlanif10         0
    4.4.4.4           1   Full/DR          00:00:31    Vlanif10         0

    # View the neighbors of Switch ModuleD, and you can see that the other DR priority is updated.

    [~Switch ModuleD] display ospfv3 peer
    
    OSPFv3 Process (1)
    OSPFv3 Area (0.0.0.0)
    Neighbor ID     Pri   State            Dead Time   Interface  Instance ID
    1.1.1.1         100   Full/DROther     00:00:36    Vlanif10         0
    2.2.2.2           0   Full/DROther     00:00:30    Vlanif10         0
    3.3.3.3           2   Full/Backup      00:00:36    Vlanif10         0

  5. Perform DR/BDR election again.

    # Restart OSPFv3 processes to re-elect the DR and BDR.

  6. Verify the configuration.

    # View the neighbors of Switch ModuleA, and you can see that Switch ModuleC is the BDR.

    [~Switch ModuleA] display ospfv3 peer
    
    OSPFv3 Process (1)
    OSPFv3 Area (0.0.0.0)
    Neighbor ID     Pri   State            Dead Time   Interface  Instance ID
    2.2.2.2           0   Full/DROther     00:00:31    Vlanif10         0
    3.3.3.3           2   Full/Backup      00:00:36    Vlanif10         0
    4.4.4.4           1   Full/DROther     00:00:39    Vlanif10         0

    # View the neighbors of Switch ModuleD, and you can see that Switch ModuleA is the DR.

    [~Switch ModuleD] display ospfv3 peer
    
    OSPFv3 Process (1)
    OSPFv3 Area (0.0.0.0)
    Neighbor ID     Pri   State            Dead Time   Interface  Instance ID
    1.1.1.1         100   Full/DR          00:00:39    Vlanif10         0
    2.2.2.2           0   2-Way/DROther    00:00:35    Vlanif10         0
    3.3.3.3           2   Full/Backup      00:00:39    Vlanif10         0

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10
    #
    ospfv3 1
     router-id 1.1.1.1
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 1001::1/64
     ospfv3 1 area 0.0.0.0
     ospfv3 dr-priority 100
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 10
    #
    ospfv3 1
     router-id 2.2.2.2
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 1001::2/64
     ospfv3 1 area 0.0.0.0
     ospfv3 dr-priority 0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 10
    #
    ospfv3 1
     router-id 3.3.3.3
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 1001::3/64
     ospfv3 1 area 0.0.0.0
     ospfv3 dr-priority 2
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 10
    #
    ospfv3 1
     router-id 4.4.4.4
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 1001::4/64
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return

Example for Configuring BFD for OSPFv3

Networking Requirements

As shown in Figure 7-65, OSPFv3 is run among SwitchA, SwitchB, and SwitchC. Service traffic is forwarded along the primary link SwitchA→SwitchB. The link SwitchA→SwitchC→SwitchB is used as a backup. Customers require that a fault on the primary link be detected in milliseconds so that service traffic can be fast switched to the backup link when the primary link fails.

Figure 7-65 Networking diagram for configuring BFD for OSPFv3
Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic OSPFv3 functions on each switch to make the primary link transmit service traffic properly.

  2. Configure OSPFv3 BFD so that traffic can be fast switched to the backup link when the primary link fails.

Procedure

  1. Configure IPv6 addresses for interfaces of all switches. The configuration details are not provided here.
  2. Configure basic OSPFv3 functions.

    # Configure SwitchA.

    [~SwitchA] ospfv3
    [*SwitchA-ospfv3-1] router-id 1.1.1.1
    [*SwitchA-ospfv3-1] quit
    [*SwitchA] interface 10ge 1/17/1
    [*SwitchA-10GE1/17/1] ospfv3 1 area 0.0.0.0
    [*SwitchA-10GE1/17/1] quit
    [*SwitchA] interface 10ge 1/17/3
    [*SwitchA-10GE1/17/3] ospfv3 1 area 0.0.0.0
    [*SwitchA-10GE1/17/3] quit
    [*SwitchA] commit

    # Configure SwitchB.

    [~SwitchB] ospfv3 1
    [*SwitchB-ospfv3-1] router-id 2.2.2.2
    [*SwitchB-ospfv3-1] quit
    [*SwitchB] interface 10ge 1/17/1
    [*SwitchB-10GE1/17/1] ospfv3 1 area 0.0.0.0
    [*SwitchB-10GE1/17/1] quit
    [*SwitchB] interface 10ge 1/17/2
    [*SwitchB-10GE1/17/2] ospfv3 1 area 0.0.0.0
    [*SwitchB] interface 10ge 1/17/3
    [*SwitchB-10GE1/17/3] ospfv3 1 area 0.0.0.0
    [*SwitchB-10GE1/17/3] quit
    [*SwitchB] commit

    # Configure SwitchC.

    [~SwitchC] ospfv3 1
    [*SwitchC-ospfv3-1] router-id 3.3.3.3
    [*SwitchC-ospfv3-1] quit
    [*SwitchC] interface 10ge 1/17/1
    [*SwitchC-10GE1/17/1] ospfv3 1 area 0.0.0.0
    [*SwitchC] interface 10ge 1/17/3
    [*SwitchC-10GE1/17/3] ospfv3 1 area 0.0.0.0
    [*SwitchC-10GE1/17/3] quit
    [*SwitchC] commit

    # After the preceding configurations are complete, run the display ospfv3 peer command, and you can view that neighbor relationships are established between SwitchA and SwitchB, and between SwitchB and SwitchC. Take the display on SwitchA as an example:

    [SwitchA] display ospfv3 peer verbose
     OSPFv3 Process (1)
     OSPFv3 Area (0.0.0.0)
    
     Neighbor 3.3.3.3 is Full, interface address FE80::219:7400:4959:3310
        In the area 0.0.0.0 via interface 10GE1/17/1       
        DR Priority is 1 DR is 3.3.3.3 BDR is 1.1.1.1 
        Options is 0x000013 (-|-|-|-|-|-|-|-|-|-|-)  
        Dead timer due in 00:00:39
        Neighbour is up for 00h28m50s  
        Link State Request List 0 
        Link State Retransmission List 0 
        Neighbour Event: 6 
        Neighbour If Id : 0x49 
     Neighbor 2.2.2.2 is Full, interface address FE80::3D43:0:8C14:1
        In the area 0.0.0.0 via interface 10GE1/17/3
        DR Priority is 1 DR is 1.1.1.1 BDR is 2.2.2.2 
        Options is 0x000013 (-|-|-|-|-|-|-|-|-|-|-)
        Dead timer due in 00:00:29
        Neighbour is up for 16h41m02s
        Link State Request List 0
        Link State Retransmission List 0
        Neighbour Event: 7
        Neighbour If Id : 0x04

    # Check information about the OSPFv3 routing table on SwitchA, and you can view the routing entries to SwitchB and SwitchC.

    [SwitchA] display ospfv3 routing
    
    
    Codes : E2 - Type 2 External, E1 - Type 1 External, IA - Inter-Area 
    Flags : A - Added to URT6  
    OSPFv3 Process (1)
         Destination                                                 Metric
          Next-hop
         1:1:1::/64                                                    1
          directly connected, 10GE1/17/3, Flags : A
         2:2:2::/64                                                    2
          via FE80::E0:9C69:8142:2, 10GE1/17/1, Flags : A
          via FE80::E0:CE19:8142:1, 10GE1/17/3, Flags : A
         3:3:3::/64                                                    1
          directly connected, 10GE1/17/1, Flags : A
         4:4:4::1/64                                                   2
          via FE80::E0:CE19:8142:1, 10GE1/17/3, Flags : A               

    In the OSPFv3 routing table, you can view that the next hop of the route to 4:4:4::1/64 is 10GE1/17/3, and traffic is transmitted on the primary link SwitchA→SwitchB.

  3. Configure OSPFv3 BFD.

    # Enable BFD globally on SwitchA.

    [~SwitchA] bfd
    [*SwitchA-bfd] quit
    [*SwitchA] ospfv3
    [*SwitchA-ospfv3-1] bfd all-interfaces enable
    [*SwitchA-ospfv3-1] bfd all-interfaces min-transmit-interval 100 min-receive-interval 100 detect-multiplier 4
    [*SwitchA-ospfv3-1] commit

    # Enable BFD globally on SwitchB.

    [~SwitchB] bfd
    [*SwitchB-bfd] quit
    [*SwitchB] ospfv3
    [*SwitchB-ospfv3-1] bfd all-interfaces enable
    [*SwitchB-ospfv3-1] bfd all-interfaces min-transmit-interval 100 min-receive-interval 100 detect-multiplier 4
    [*SwitchB-ospfv3-1] commit

    # Enable BFD globally on SwitchC.

    [~SwitchC] bfd
    [*SwitchC-bfd] quit
    [*SwitchC] ospfv3
    [*SwitchC-ospfv3-1] bfd all-interfaces enable
    [*SwitchC-ospfv3-1] bfd all-interfaces min-transmit-interval 100 min-receive-interval 100 detect-multiplier 4
    [*SwitchC-ospfv3-1] commit

    After the preceding configurations are complete, run the display ospfv3 bfd session command on SwitchA or SwitchB, and you can view that the status of the BFD session is Up.

    Take the display on SwitchB as an example:

    [SwitchB] display ospfv3 bfd session verbose
    * - STALE
     
              OSPFv3 Process 1 with Router ID 2.2.2.2
     
       Neighbor-Id: 1.1.1.1               BFD Status: Up
       Interface: 10GE1/17/3               Instance : 2
       IPv6-Local-Address: FE80::E0:CE19:8142:1
       IPv6-Remote-Address: FE80::E0:4C3A:143:1
     
          Total UP/DOWN/UNKNOWN BFD Session Number : 1 / 0 / 0

  4. Verify the configuration.

    # Run the shutdown command on 10GE1/17/3 of SwitchB to simulate a primary link fault.

    [~SwitchB] interface 10ge 1/17/3
    [~SwitchB-10GE1/17/3] shutdown
    [*SwitchB-10GE1/17/3] commit

    # Check the routing table on SwitchA. In the routing table, you can view that the backup link SwitchA-SwitchC-SwitchB transmits traffic after the primary link fails, and the next hop of the route to 4:4:4::1/64 becomes 10GE1/17/1.

    [SwitchA] display ospfv3 routing
    
    
    Codes : E2 - Type 2 External, E1 - Type 1 External, IA - Inter-Area  
    Flags : A - Added to URT6  
    OSPFv3 Process (1)
    
    
        Destination                                                 Metric
         Next-hop
        1:1:1::/64                                                    1
              directly connected, 10GE1/17/3, Flags : A
        2:2:2::/64                                                    2
              via FE80::E0:9C69:8142:2, 10GE1/17/1, Flags : A
        3:3:3::/64                                                    1
              directly connected, 10GE1/17/1, Flags : A
        4:4:4::1/64                                                   2
              via FE80::E0:9C69:8142:2, 10GE1/17/1, Flags : A          

Configuration Files
  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    bfd
    #
    ospfv3 1
     router-id 1.1.1.1
     bfd all-interfaces enable
     bfd all-interfaces min-transmit-interval 100 min-receive-interval 100 detect-multiplier 4
    #
    interface 10GE1/17/1
     undo portswitch
     ipv6 enable
     ipv6 address 3:3:3::1/64
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/17/3 
     undo portswitch
     ipv6 enable
     ipv6 address 1:1:1::3/64
     ospfv3 1 area 0.0.0.0
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    bfd
    #
    ospfv3 1
     router-id 2.2.2.2
     bfd all-interfaces enable
     bfd all-interfaces min-transmit-interval 100 min-receive-interval 100 detect-multiplier 4
    #
    interface 10GE1/17/1
     undo portswitch
     ipv6 enable
     ipv6 address 2:2:2::1/64
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/17/2
     undo portswitch
     ipv6 enable
     ipv6 address 4:4:4::1/64
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/17/3
     undo portswitch
     ipv6 enable
     ipv6 address 1:1:1::2/64
     ospfv3 1 area 0.0.0.0
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    bfd
    #
    ospfv3 1
     router-id 3.3.3.3
     bfd all-interfaces enable
     bfd all-interfaces min-transmit-interval 100 min-receive-interval 100 detect-multiplier 4
    #
    interface 10GE1/17/1
     undo portswitch
     ipv6 enable
     ipv6 address 3:3:3::3/64
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/17/3
     undo portswitch
     ipv6 enable
     ipv6 address 2:2:2::2/64
     ospfv3 1 area 0.0.0.0
    #
    return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 57980

Downloads: 3621

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next