No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 13

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides configuration examples to help you configure basic IGMP functions, static group membership, IGMP SSM Mapping on a multicast network.

Example for Configuring Basic IGMP Functions

Networking Requirements

As shown in Figure 8-26, users are located on network segments N1 and N2. On the PIM network, Switch ModuleA connects to network segment N1; Switch ModuleB and Switch ModuleC connect to network segment N2. The PIM network uses multicast addresses 225.1.1.1 to 225.1.1.5 to transmit video streams.

HostA on N1 and HostC on N2 want to receive video streams in multicast mode. HostA only subscribes to programs of multicast group 225.1.1.1, and HostC subscribes programs of all multicast groups. Appropriate configurations need to be performed on the switch moduleses to allow HostA to receive only video streams of multicast group 225.1.1.1 and allow HostC to receive video streams of all multicast groups.

Figure 8-26 Networking diagram for basic IGMP configuration

Configuration Roadmap

To meet the preceding requirements, configure basic IGMP functions on the switch moduleses, configure a group policy on Switch ModuleA to limit the multicast group range on the interface connected to network segment N1. The configuration roadmap is as follows:

  1. To ensure normal operating of the multicast routing protocol, configure a unicast routing protocol on the network to implement IP interworking. Multicast routing protocols work depending on unicast routing protocols.
  2. To enable the switch moduleses to forward video streams to the hosts in multicast mode, configure basic multicast functions on the switch moduleses.
  3. To allow HostA to receive only multicast data sent to multicast group 225.1.1.1, configure a group policy on Switch ModuleA's interface connected to N1 to filter multicast data sent to this network segment.

Procedure

  1. Configure IP addresses for interfaces and configure a unicast routing protocol on each switch modules.

    # Configure IP addresses and masks for switch modules interfaces according to Figure 8-26. Configure OSPF on the switch moduleses to implement IP interworking and dynamic route update. The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here. See Configuration Files.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 10 11
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type hybrid
    [*Switch ModuleA-10GE1/17/1] port hybrid untagged vlan 10
    [*Switch ModuleA-10GE1/17/1] port hybrid pvid vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] port link-type hybrid
    [*Switch ModuleA-10GE1/17/2] port hybrid untagged vlan 11
    [*Switch ModuleA-10GE1/17/2] port hybrid pvid vlan 11
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ip address 10.110.1.1 24
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] interface vlanif 11
    [*Switch ModuleA-Vlanif11] ip address 192.168.1.1 24
    [*Switch ModuleA-Vlanif11] quit
    [*Switch ModuleA] ospf
    [*Switch ModuleA-ospf-1] area 0
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 10.110.1.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] commit
    [~Switch ModuleA-ospf-1-area-0.0.0.0] quit
    [~Switch ModuleA-ospf-1] quit

  2. Enable IP multicast routing on all the switch moduleses and enable PIM-SM on all interfaces.

    # Enable IP multicast routing on Switch ModuleA and enable PIM-SM on all its interfaces. The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here. See Configuration Files.

    [~Switch ModuleA] multicast routing-enable
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] pim sm
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit
    [~Switch ModuleA] interface vlanif 11
    [~Switch ModuleA-Vlanif11] pim sm
    [*Switch ModuleA-Vlanif11] commit
    [~Switch ModuleA-Vlanif11] quit
    

  3. Configure a static RP.

    # Configure a static RP on Switch ModuleA. Specify VLANIF40 of Switch ModuleD as the static RP. The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here. See Configuration Files.

    [~Switch ModuleA] pim
    [*Switch ModuleA-pim] static-rp 192.168.4.2
    [*Switch ModuleA-pim] commit
    [~Switch ModuleA-pim] quit
    

  4. On Switch ModuleA, Switch ModuleB, and Switch ModuleC, enable IGMP on the interfaces connected to the receiver network segments.

    # Enable IGMP on VLANIF10 of Switch ModuleA. The configurations of Switch ModuleB and Switch ModuleC are similar to the configuration of Switch ModuleA, and are not mentioned here. See Configuration Files.

    [~Switch ModuleA] interface vlanif 10
    [~Switch ModuleA-Vlanif10] igmp enable
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit

  5. Allow VLANIF10 of Switch ModuleA to join only multicast group 225.1.1.1.

    # On Switch ModuleA, create an ACL, configure a rule that permits only packets of multicast group 225.1.1.1, and then apply the ACL to VLANIF10.

    [~Switch ModuleA] acl number 2001
    [*Switch ModuleA-acl4-basic-2001] rule permit source 225.1.1.1 0
    [*Switch ModuleA-acl4-basic-2001] commit
    [~Switch ModuleA-acl4-basic-2001] quit
    [~Switch ModuleA] interface vlanif 10
    [~Switch ModuleA-Vlanif10] igmp group-policy 2001
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit
    

  6. Verify the configuration.

    # Run the display igmp interface command on each switch to check the IGMP configuration and running status on each interface.

    The IGMP command output on VLANIF10 of Switch ModuleA is as follows:

    [~Switch ModuleA] display igmp interface vlanif 10
    Interface information of VPN instance: public net
     Vlanif10(10.110.1.1):
       IGMP is enabled
       Current IGMP version is 2
       IGMP state: up 
       IGMP group policy: 2001 
       IGMP limit: - 
       Query interval for IGMP (negotiated): -
       Query interval for IGMP (configured): 60 s 
       Other querier timeout for IGMP: 0 s 
       Maximum query response time for IGMP: 10 s
       Querier for IGMP: 10.110.1.1 (this router)
      Total 1 IGMP Group reported

    The command output shows that IGMP is enabled on VLANIF10 of Switch ModuleA, and a group policy referencing ACL 2001 has been applied to this interface. In addition, VLANIF10 has received a Report message of a multicast group.

    The IGMP command output on VLANIF20 of Switch ModuleB is as follows:

    [~Switch ModuleB] display igmp interface vlanif 20
    Interface information of VPN instance: public net
     Vlanif20(10.110.2.1):
       IGMP is enabled
       Current IGMP version is 2
       IGMP state: up 
       IGMP group policy: none 
       IGMP limit: - 
       Query interval for IGMP (negotiated): -
       Query interval for IGMP (configured): 60 s 
       Other querier timeout for IGMP: 0 s 
       Maximum query response time for IGMP: 10 s
       Querier for IGMP: 10.110.2.1 (this router)
      Total 2 IGMP Groups reported

    The command output shows that Switch ModuleB is a querier. This is because the IP address of VLANIF20 on Switch ModuleB is the smallest on the network segment. In addition, VLANIF20 has received Report messages of two multicast groups.

    # Run the display pim routing-table command to check the PIM-SM routing table on each switch.

    On the shared network segment where Switch ModuleB and Switch ModuleC are located, Switch ModuleB is elected as the multicast data forwarder. The PIM-SM routing table on Switch ModuleB is as follows:

    [~Switch ModuleB] display pim routing-table
     VPN-Instance: public net
     Total 2 (*, G) entries; 2 (S, G) entries
    
     (*, 225.1.1.1)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: WC
         UpTime: 00:21:35
         Upstream interface: Vlanif21
             Upstream neighbor: 192.168.2.2
             RPF prime neighbor: 192.168.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: igmp, UpTime: 00:21:35, Expires: - 
    
     (193.3.5.2, 225.1.1.1)
         RP: 192.168.4.2 
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:42:46
         Upstream interface: Vlanif21
             Upstream neighbor: 192.168.2.2
             RPF prime neighbor: 192.168.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: pim-sm, UpTime: 00:21:35, Expires: - 
    
     (*, 225.1.1.2)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: WC 
         UpTime: 00:06:02 
         Upstream interface: Vlanif21
             Upstream neighbor: 192.168.2.2
             RPF prime neighbor: 192.168.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20 
                 Protocol: igmp, UpTime: 00:06:02, Expires: - 
    
     (193.3.5.2, 225.1.1.2)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:15:12
         Upstream interface: Vlanif21 
             Upstream neighbor: 192.168.2.2
             RPF prime neighbor: 192.168.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20 
                 Protocol: pim-sm, UpTime: 00:06:04, Expires: - 
    
    

    The command output shows that (*, 225.1.1.1), (193.3.5.2, 225.1.1.1), (*, 225.1.1.2), and (193.3.5.2, 225.1.1.2) entries exist on SwitchB. This indicates that VLANIF20 has joined multicast groups 225.1.1.1 and 225.1.1.2 and can receive multicast data from multicast source 193.3.5.2.

    The PIM-SM routing table on SwitchA is as follows:

    [~Switch ModuleA] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: WC
         UpTime: 00:21:35 
         Upstream interface: Vlanif11
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10
                 Protocol: igmp, UpTime: 00:21:35, Expires: - 
    
     (193.3.5.2, 225.1.1.1)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:42:46
         Upstream interface: Vlanif11
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10
                 Protocol: pim-sm, UpTime: 00:21:35, Expires: - 
    
    

    The command output shows that only (*, 225.1.1.1) and (193.3.5.2, 225.1.1.1) entries exist on SwitchA. This is because that a group policy is configured on VLANIF10 of SwitchA.

Configuration Files

  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 to 11
    #
    multicast routing-enable
    #
    acl number 2001
     rule 5 permit source 225.1.1.1 0
    #
    interface Vlanif10
     ip address 10.110.1.1 255.255.255.0
     pim sm
     igmp enable
     igmp group-policy 2001
    #
    interface Vlanif11
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 11
     port hybrid untagged vlan 11
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.2 
    #
    return
    
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 20 to 21
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif21
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 21
     port hybrid untagged vlan 21
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.2 
    #
    return
    
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 20 31
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.110.2.2 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif31
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 31
     port hybrid untagged vlan 31
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.2 
    #
    return
    
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 11 21 31 40
    #
    multicast routing-enable
    #
    interface Vlanif11
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif21
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif31
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 192.168.4.2 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 11
     port hybrid untagged vlan 11
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 21
     port hybrid untagged vlan 21
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 31
     port hybrid untagged vlan 31
    #
    interface 10GE1/17/4
     port link-type hybrid
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.2 
    #
    return
    

Example for Configuring a Static Multicast Group on an Interface

Networking Requirements

As shown in Figure 8-27, users are located on network segments N1 and N2. On the PIM network, Switch ModuleA connects to network segment N1; Switch ModuleB and Switch ModuleC connect to network segment N2. The PIM network uses multicast addresses 225.1.1.1 to 225.1.1.5 to transmit video streams.

HostA on N1 and HostC and HostD on N2 want to receive video streams in multicast mode. HostA wants to receive data of multicast group 225.1.1.1 for a long time, while HostC and HostD do not have such requirements.

Figure 8-27 Networking diagram for static multicast group configuration

Configuration Roadmap

To meet the preceding requirements, configure static multicast group 225.1.1.1 on Switch ModuleA's interface connected to N1. The configuration roadmap is as follows:

  1. To ensure normal operating of the multicast routing protocol, configure a unicast routing protocol on the network to implement IP interworking. Multicast routing protocols work depending on unicast routing protocols.

  2. To enable the switch moduleses to forward video streams to the hosts in multicast mode, configure basic multicast functions on the switch moduleses.

  3. To enable HostA to receive data of group 225.1.1.1 in a long time, statically bind Switch ModuleA's interface connected to N1 to this group.

Procedure

  1. Configure IP addresses for interfaces and configure a unicast routing protocol on each switch modules.

    # Configure IP addresses and masks for switch modules interfaces according to Figure 8-27. Configure OSPF on the switch moduleses to implement IP interworking and dynamic route update. The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here. See Configuration Files.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 10 11
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type hybrid
    [*Switch ModuleA-10GE1/17/1] port hybrid untagged vlan 10
    [*Switch ModuleA-10GE1/17/1] port hybrid pvid vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] port link-type hybrid
    [*Switch ModuleA-10GE1/17/2] port hybrid untagged vlan 11
    [*Switch ModuleA-10GE1/17/2] port hybrid pvid vlan 11
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ip address 10.110.1.1 24
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] interface vlanif 11
    [*Switch ModuleA-Vlanif11] ip address 192.168.1.1 24
    [*Switch ModuleA-Vlanif11] quit
    [*Switch ModuleA] ospf
    [*Switch ModuleA-ospf-1] area 0
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 10.110.1.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] commit
    [~Switch ModuleA-ospf-1-area-0.0.0.0] quit
    [~Switch ModuleA-ospf-1] quit

  2. Enable IP multicast routing on each switch modules and enable PIM-SM on all interfaces.

    # Enable IP multicast routing on Switch ModuleA and enable PIM-SM on all its interfaces. The configurations of Switch ModuleB, Switch ModuleC and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here. See Configuration Files.

    [~Switch ModuleA] multicast routing-enable
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] pim sm
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit
    [~Switch ModuleA] interface vlanif 11
    [~Switch ModuleA-Vlanif11] pim sm
    [*Switch ModuleA-Vlanif11] commit
    [~Switch ModuleA-Vlanif11] quit
    

  3. Configure a static RP.

    # Configure a static RP on Switch ModuleA. Specify VLANIF40 of Switch ModuleD as the static RP. The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here. See Configuration Files.

    [~Switch ModuleA] pim
    [*Switch ModuleA-pim] static-rp 192.168.4.1
    [*Switch ModuleA-pim] commit
    [~Switch ModuleA-pim] quit
    

  4. On Switch ModuleA, Switch ModuleB, and Switch ModuleC, enable IGMP on the interfaces connected to the receiver network segments.

    # Enable IGMP on VLANIF10 of Switch ModuleA. The configurations of Switch ModuleB and Switch ModuleC are similar to the configuration of Switch ModuleA, and are not mentioned here. See Configuration Files.

    [~Switch ModuleA] interface vlanif 10
    [~Switch ModuleA-Vlanif10] igmp enable
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit
    

  5. Statically bind VLANIF10 of Switch ModuleA to multicast group 225.1.1.1 so that hosts connected to VLANIF10 can receive stable multicast data sent to this multicast group 225.1.1.1.

    [~Switch ModuleA] interface vlanif 10
    [~Switch ModuleA-Vlanif10] igmp static-group 225.1.1.1
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit
    

  6. Verify the configuration.

    # Run the display igmp interface command to check the IGMP configuration and running status on each interface. The IGMP command output on VLANIF20 of Switch ModuleB is as follows:

    [~Switch ModuleB] display igmp interface vlanif 20
    Interface information of VPN instance: public net
     Vlanif20(10.110.2.1):
       IGMP is enabled
       Current IGMP version is 2
       IGMP state: up 
       IGMP group policy: none 
       IGMP limit: - 
       Query interval for IGMP (negotiated): -
       Query interval for IGMP (configured): 60 s 
       Other querier timeout for IGMP: 0 s 
       Maximum query response time for IGMP: 10 s
       Querier for IGMP: 10.110.2.1 (this router)
      Total 2 IGMP Groups reported

    The command output shows that IGMP is enabled on VLANIF20 of Switch ModuleB.

    # Run the display pim routing-table command on Switch ModuleA. You can see that VLANIF10 has been statically bound to multicast group 225.1.1.1. The command output information is as follows:

    [~Switch ModuleA] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 192.168.4.1
         Protocol: pim-sm, Flag: WC
         UpTime: 00:12:17
         Upstream interface: Vlanif11
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10
                 Protocol: static igmp, UpTime: 00:12:17, Expires: -

    The command output shows that Switch ModuleA has a (*, 225.1.1.1) entry, with the downstream interface VLANIF10 and protocol type static igmp. This verifies that VLANIF10 has been statically bound to multicast group 225.1.1.1. If IGMP is disabled on VLANIF10 of Switch ModuleA, the protocol type is static.

Configuration Files

  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 to 11
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 10.110.1.1 255.255.255.0
     pim sm
     igmp enable
     igmp static-group 225.1.1.1
    #
    interface Vlanif11
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 11
     port hybrid untagged vlan 11
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.1 
    #
    return
    
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 20 to 21
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif21
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 21
     port hybrid untagged vlan 21
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.1 
    #
    return
    
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 20 31
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.110.2.2 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif31
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 31
     port hybrid untagged vlan 31
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.1 
    #
    return
    
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 11 21 31 40
    #
    multicast routing-enable
    #
    interface Vlanif11
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif21
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif31
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 11
     port hybrid untagged vlan 11
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 21
     port hybrid untagged vlan 21
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 31
     port hybrid untagged vlan 31
    #
    interface 10GE1/17/4
     port link-type hybrid
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.1 
    #
    return
    

Example for Configuring IGMP SSM Mapping

Networking Requirements

As shown in Figure 8-28, the network runs PIM-SM and uses the SSM model to provide multicast services to group members. SwitchD's interface VLANIF13 connected to the network segment of Receiver runs IGMPv3. Receiver runs IGMPv2 and does not support IGMPv3; therefore, Receiver cannot specify desired multicast sources when it joins a group. The SSM group address range on the network is 232.1.1.0/24. Source1, Source2, and Source3 all send multicast data to the multicast groups in this range.

Receiver needs to obtain the SSM service and wants to receive only multicast data sent from Source1 and Source3.

Figure 8-28 Networking diagram for the IGMP SSM mapping configuration

Configuration Roadmap

To meet the preceding requirements, configure IGMP SSM mapping on Switch ModuleD. The configuration roadmap is as follows:

  1. To ensure normal operating of the multicast routing protocol, configure a unicast routing protocol on the network to implement IP interworking. Multicast routing protocols work depending on unicast routing protocols.

  2. To enable the switch moduleses to forward multicast data to Receiver, configure basic multicast functions on switch moduleses.

  3. To allow Receiver to receive data from specified multicast sources, enable IGMP SSM mapping and configure mapping rules on Switch ModuleD.

Procedure

  1. Configure IP addresses for interfaces and configure a unicast routing protocol on each switch modules.

    # Configure IP addresses and masks for switch modules interfaces according to Figure 8-28. Configure OSPF on the switch moduleses to implement IP interworking and dynamic route update. The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here. See Configuration Files.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 10 20 30
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type hybrid
    [*Switch ModuleA-10GE1/17/1] port hybrid untagged vlan 10
    [*Switch ModuleA-10GE1/17/1] port hybrid pvid vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] port link-type hybrid
    [*Switch ModuleA-10GE1/17/2] port hybrid untagged vlan 20
    [*Switch ModuleA-10GE1/17/2] port hybrid pvid vlan 20
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] interface 10ge 1/17/3
    [*Switch ModuleA-10GE1/17/3] port link-type hybrid
    [*Switch ModuleA-10GE1/17/3] port hybrid untagged vlan 30
    [*Switch ModuleA-10GE1/17/3] port hybrid pvid vlan 30
    [*Switch ModuleA-10GE1/17/3] quit
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ip address 10.10.1.2 24
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] interface vlanif 20
    [*Switch ModuleA-Vlanif20] ip address 192.168.1.1 24
    [*Switch ModuleA-Vlanif20] quit
    [*Switch ModuleA] interface vlanif 30
    [*Switch ModuleA-Vlanif30] ip address 192.168.4.2 24
    [*Switch ModuleA-Vlanif30] quit
    [*Switch ModuleA] ospf
    [*Switch ModuleA-ospf-1] area 0
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 10.10.1.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 192.168.4.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] commit
    [~Switch ModuleA-ospf-1-area-0.0.0.0] quit
    [~Switch ModuleA-ospf-1] quit

  2. Enable IP multicast routing on all the switch moduleses and enable PIM-SM on all interfaces.

    # Enable IP multicast routing on Switch ModuleA and enable PIM-SM on all its interfaces. The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here. See Configuration Files.

    [~Switch ModuleA] multicast routing-enable
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] pim sm
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit
    [~Switch ModuleA] interface vlanif 20
    [~Switch ModuleA-Vlanif20] pim sm
    [*Switch ModuleA-Vlanif20] commit
    [~Switch ModuleA-Vlanif20] quit
    [~Switch ModuleA] interface vlanif 30
    [~Switch ModuleA-Vlanif30] pim sm
    [*Switch ModuleA-Vlanif30] commit
    [~Switch ModuleA-Vlanif30] quit
    

  3. Enable IGMP on the interface of Switch ModuleD connected to Receiver and set the IGMP version to IGMPv3.

    # Enable IGMP on VLANIF13 of Switch ModuleD and set the IGMP version to IGMPv3.

    [~Switch ModuleD] interface vlanif 13
    [~Switch ModuleD-Vlanif13] igmp enable
    [*Switch ModuleD-Vlanif13] igmp version 3
    [*Switch ModuleD-Vlanif13] commit
    [~Switch ModuleD-Vlanif13] quit
    

  4. Enable IGMP SSM mapping on the interface connected to the receiver network segment.

    # Enable IGMP SSM mapping on VLANIF13 of Switch ModuleD.

    [~Switch ModuleD] interface vlanif 13
    [~Switch ModuleD-Vlanif13] igmp ssm-mapping enable
    [*Switch ModuleD-Vlanif13] commit
    [~Switch ModuleD-Vlanif13] quit
    

  5. Configure the range of SSM group addresses on all switch moduleses.

    # Set the range of SSM group addresses to 232.1.1.0/24 on Switch ModuleA. The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here. See Configuration Files.

    [~Switch ModuleA] acl number 2000
    [*Switch ModuleA-acl4-basic-2000] rule permit source 232.1.1.0 0.0.0.255
    [*Switch ModuleA-acl4-basic-2000] commit
    [~Switch ModuleA-acl4-basic-2000] quit
    [~Switch ModuleA] pim
    [*Switch ModuleA-pim] ssm-policy 2000
    [*Switch ModuleA-pim] commit
    [~Switch ModuleA-pim] quit

  6. Configure IGMP SSM mapping rules on Switch ModuleD.

    # On Switch ModuleD, map the multicast groups in the range of 232.1.1.0/24 to Source1 and Source3.

    [~Switch ModuleD] igmp
    [*Switch ModuleD-igmp] ssm-mapping 232.1.1.0 24 10.10.1.1
    [*Switch ModuleD-igmp] ssm-mapping 232.1.1.0 24 10.10.3.1
    [*Switch ModuleD-igmp] commit
    [~Switch ModuleD-igmp] quit
    

  7. Verify the configuration.

    # Run the display igmp ssm-mapping group command on Switch ModuleD to view the mappings between multicast sources and multicast groups.

    [~Switch ModuleD] display igmp ssm-mapping group
    IGMP SSM-Mapping conversion table of VPN instance: public net
     Total entries: 2    (2 entries matched)
    
     00001. (10.10.1.1, 232.1.1.0)
     00002. (10.10.3.1, 232.1.1.0)
    
     Total 2 entries matched
    
    

    The preceding information shows that multicast groups in the range of 232.1.1.0/24 are mapped to Source1 and Source3.

    # Run the display igmp group ssm-mapping command on Switch ModuleD to view information about multicast group memberships established with SSM mapping. The command output is as follows:

    [~Switch ModuleD] display igmp group ssm-mapping
    IGMP SSM mapping interface group report information of VPN instance: public net
     Limited entry of this VPN instance: - 
     Vlanif13 (10.10.4.2):
      Total 1 IGMP SSM-Mapping Group reported
       Group Address   Last Reporter   Uptime      Expires
       232.1.1.1       10.10.4.1       00:01:44    00:00:26
    
    

    The preceding information shows that Receiver has joined group 232.1.1.1.

    # Run the display pim routing-table command on Switch ModuleD to view the PIM-SM multicast routing table. The command output is as follows:

    [~Switch ModuleD] display pim routing-table
    VPN-Instance: public net
     Total 2 (S, G) entries
    
     (10.10.1.1, 232.1.1.1)
         Protocol: pim-ssm, Flag: SG_RCVR                                           
         UpTime: 00:19:40                                                           
         Upstream interface: Vlanif30                                               
             Upstream neighbor: 192.168.4.2                                         
             RPF prime neighbor: 192.168.4.2                                        
         Downstream interface(s) information:                                       
         Total number of downstreams: 1                                             
             1: Vlanif13                                                            
                 Protocol: ssm-map, UpTime: 00:19:40, Expires: -                    
    
     (10.10.3.1, 232.1.1.1)
         Protocol: pim-ssm, Flag: SG_RCVR                                           
         UpTime: 00:19:40                                                           
         Upstream interface: Vlanif21                                               
             Upstream neighbor: 192.168.3.1                                         
             RPF prime neighbor: 192.168.3.1                                        
         Downstream interface(s) information:                                       
         Total number of downstreams: 1                                             
             1: Vlanif13                                                            
                 Protocol: ssm-map, UpTime: 00:19:40, Expires: -                    
    

    You can see that multicast sources 10.10.1.1 and 10.10.3.1 send data to group 232.1.1.1, and SwitchD receives the multicast data from the two multicast sources through interfaces VLANIF30 and VLANIF21 respectively.

Configuration Files

  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 20 30
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif10
     ip address 10.10.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif20
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif30
     ip address 192.168.4.2 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 10.10.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
    
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 11 20 31
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif11
     ip address 10.10.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif20
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif31
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 11
     port hybrid untagged vlan 11
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 31
     port hybrid untagged vlan 31
    #
    ospf 1
     area 0.0.0.0
      network 10.10.2.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
    
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 12 21 31
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif12
     ip address 10.10.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif21
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif31
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 12
     port hybrid untagged vlan 12
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 21
     port hybrid untagged vlan 21
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 31
     port hybrid untagged vlan 31
    #
    ospf 1
     area 0.0.0.0
      network 10.10.3.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
    
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 13 21 30
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif13
     ip address 10.10.4.2 255.255.255.0
     pim sm
     igmp enable
     igmp version 3
     igmp ssm-mapping enable
    #
    interface Vlanif21
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif30
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 13
     port hybrid untagged vlan 13
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 21
     port hybrid untagged vlan 21
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 10.10.4.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    igmp
     ssm-mapping 232.1.1.0 255.255.255.0 10.10.1.1
     ssm-mapping 232.1.1.0 255.255.255.0 10.10.3.1
    #
    pim
     ssm-policy 2000
    #
    return
    
Translation
Download
Updated: 2019-12-13

Document ID: EDOC1000041694

Views: 61508

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next