No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides an example for configuring an MCE IPv6 device.

Example for Configuring IPv6 MCE

Networking Requirements

An enterprise needs to implement connectivity between IPv6 isolated sites between the headquarters and branches through MPLS VPN and to isolate two types of different services. To save costs, the branch is required to connect to the PE through one MCE.

In Figure 9-20:

  • CE1 and CE2 connect to enterprise headquarters. CE1 belongs to vpna and CE2 belongs to vpnb.
  • The MCE connects to the enterprise branch, and vpna and vpnb through SwitchA and SwitchB respectively.
NOTE:

In Figure 9-20, the CX11x&CX31x&CX91x series switch modules functions as the MCE.

Figure 9-20 MCE networking

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure OSPF between PEs to implement interworking between PEs and configure MP-IBGP to exchange VPN routing information.
  2. Configure basic MPLS functions and LDP, and set up LDP LSPs.
  3. Create different VPN instances (vpna and vpnb) on PEs and MCE to isolate services in different VPNs.
  4. Establish an EBGP peer relationship between PE1 and its connected switch so that they can exchange VPN routes.
  5. Configure routes between the MCE and sites, and between MCE and PE2 so that they can exchange VPN routes.

Procedure

  1. Configure OSPF on PEs of the backbone network so that the PEs can communicate.

    # Configure PE1.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE1
    [*HUAWEI] commit
    [~PE1] interface loopback 1
    [*PE1-LoopBack1] ip address 1.1.1.9 32
    [*PE1-LoopBack1] quit
    [*PE1] vlan batch 30
    [*PE1] interface 10ge 1/17/3
    [*PE1-10GE1/17/3] port link-type trunk
    [*PE1-10GE1/17/3] port trunk allow-pass vlan 30
    [*PE1-10GE1/17/3] quit
    [*PE1] interface vlanif 30
    [*PE1-Vlanif30] ip address 172.1.1.1 24
    [*PE1-Vlanif30] quit
    [*PE1] ospf
    [*PE1-ospf-1] area 0
    [*PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [*PE1-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [*PE1-ospf-1-area-0.0.0.0] quit
    [*PE1-ospf-1] quit
    [*PE1] commit

    The configuration of PE2 is similar to the configuration of PE1, and is not mentioned here.

    After the configurations are complete, run the display ip routing-table command, and you can see that PE devices have learned the routes to Loopback1 of each other.

  2. Configure basic MPLS functions and MPLS LDP on PEs of the backbone network and set up an LDP LSP between PEs.

    # Configure PE1.
    [~PE1] mpls lsr-id 1.1.1.9
    [*PE1] mpls
    [*PE1-mpls] quit
    [*PE1] mpls ldp
    [*PE1-mpls-ldp] quit
    [*PE1] interface vlanif 30
    [*PE1-Vlanif30] mpls
    [*PE1-Vlanif30] mpls ldp
    [*PE1-Vlanif30] quit
    [*PE1] commit

    The configuration of PE2 is similar to the configuration of PE1, and is not mentioned here.

    After the configurations are complete, run the display mpls ldp session command on the PEs. You can see that the MPLS LDP session between PEs is in Operational state.

  3. Configure VPN instances on PEs. Connect CE1 and CE2 to PE1 and connect the MCE to PE2.

    # Configure PE1.

    [~PE1] vlan batch 10 20
    [*PE1] interface 10ge 1/17/1
    [*PE1-10GE1/17/1] port link-type trunk
    [*PE1-10GE1/17/1] port trunk allow-pass vlan 10
    [*PE1-10GE1/17/1] quit
    [*PE1] interface 10ge 1/17/2
    [*PE1-10GE1/17/2] port link-type trunk
    [*PE1-10GE1/17/2] port trunk allow-pass vlan 20
    [*PE1-10GE1/17/2] quit
    [*PE1] ip vpn-instance vpna
    [*PE1-vpn-instance-vpna] ipv6-family
    [*PE1-vpn-instance-vpna-af-ipv6] route-distinguisher 100:1
    [*PE1-vpn-instance-vpna-af-ipv6] vpn-target 111:1 both
    [*PE1-vpn-instance-vpna-af-ipv6] quit
    [*PE1-vpn-instance-vpna] quit
    [*PE1] ip vpn-instance vpnb
    [*PE1-vpn-instance-vpnb] ipv6-family
    [*PE1-vpn-instance-vpnb-af-ipv6] route-distinguisher 100:2
    [*PE1-vpn-instance-vpnb-af-ipv6] vpn-target 222:2 both
    [*PE1-vpn-instance-vpnb-af-ipv6] quit
    [*PE1-vpn-instance-vpnb] quit
    [*PE1] interface vlanif 10
    [*PE1-Vlanif10] ip binding vpn-instance vpna
    [*PE1-Vlanif10] ipv6 enable
    [*PE1-Vlanif10] ipv6 address 2001::1/64
    [*PE1-Vlanif10] quit
    [*PE1] interface vlanif 20
    [*PE1-Vlanif20] ip binding vpn-instance vpnb
    [*PE1-Vlanif20] ipv6 enable
    [*PE1-Vlanif20] ipv6 address 2002::1/64
    [*PE1-Vlanif20] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] vlan batch 100 200
    [*PE2] interface 10ge 1/17/2
    [*PE2-10GE1/17/2] port link-type trunk
    [*PE2-10GE1/17/2] port trunk allow-pass vlan 100 200
    [*PE2-10GE1/17/2] quit
    [*PE2] ip vpn-instance vpna
    [*PE2-vpn-instance-vpna] ipv6-family
    [*PE2-vpn-instance-vpna-af-ipv6] route-distinguisher 200:1
    [*PE2-vpn-instance-vpna-af-ipv6] vpn-target 111:1 both
    [*PE2-vpn-instance-vpna-af-ipv6] quit
    [*PE2-vpn-instance-vpna] quit
    [*PE2] ip vpn-instance vpnb
    [*PE2-vpn-instance-vpnb] ipv6-family
    [*PE2-vpn-instance-vpnb-af-ipv6] route-distinguisher 200:2
    [*PE2-vpn-instance-vpnb-af-ipv6] vpn-target 222:2 both
    [*PE2-vpn-instance-vpnb-af-ipv6] quit
    [*PE2-vpn-instance-vpnb] quit
    [*PE2] interface vlanif 100
    [*PE2-Vlanif100] ip binding vpn-instance vpna
    [*PE1-Vlanif100] ipv6 enable
    [*PE2-Vlanif100] ipv6 address 2007::1/64
    [*PE2-Vlanif100] quit
    [*PE2]interface vlanif 200
    [*PE2-Vlanif200] ip binding vpn-instance vpnb
    [*PE1-Vlanif200] ipv6 enable
    [*PE2-Vlanif200] ipv6 address 2008::1/64
    [*PE2-Vlanif200] quit
    [*PE2] commit

  4. Configure VPN instances on the MCE, and connect SwitchA and SwitchB to the MCE.

    <HUAWEI> system-view
    [~HUAWEI] sysname MCE
    [*HUAWEI] commit
    [~MCE] vlan batch 60 70 100 200
    [*MCE] interface 10ge 1/17/1
    [*MCE-10GE1/17/1] port link-type trunk
    [*MCE-10GE1/17/1] port trunk allow-pass vlan 100 200
    [*MCE-10GE1/17/1] quit
    [*MCE] interface 10ge 1/17/3
    [*MCE-10GE1/17/3] port link-type trunk
    [*MCE-10GE1/17/3] port trunk allow-pass vlan 60
    [*MCE-10GE1/17/3] quit
    [*MCE] interface 10ge 1/17/4
    [*MCE-10GE1/17/4] port link-type trunk
    [*MCE-10GE1/17/4] port trunk allow-pass vlan 70
    [*MCE-10GE1/17/4] quit
    [*MCE] ip vpn-instance vpna
    [*MCE-vpn-instance-vpna] ipv6-family
    [*MCE-vpn-instance-vpna-af-ipv6] route-distinguisher 100:1
    [*MCE-vpn-instance-vpna-af-ipv6] vpn-target 111:1 both
    [*MCE-vpn-instance-vpna-af-ipv6] quit
    [*MCE-vpn-instance-vpna] quit
    [*MCE] ip vpn-instance vpnb
    [*MCE-vpn-instance-vpnb] ipv6-family
    [*MCE-vpn-instance-vpnb-af-ipv6] route-distinguisher 100:2
    [*MCE-vpn-instance-vpnb-af-ipv6] vpn-target 222:2 both
    [*MCE-vpn-instance-vpnb-af-ipv6] quit
    [*MCE-vpn-instance-vpnb] quit
    [*MCE] interface vlanif 60
    [*MCE-Vlanif60] ip binding vpn-instance vpna
    [*MCE-Vlanif60] ipv6 enable
    [*MCE-Vlanif60] ipv6 address 2003::1/64
    [*MCE-Vlanif60] quit
    [*MCE] interface vlanif 70
    [*MCE-Vlanif70] ip binding vpn-instance vpnb
    [*MCE-Vlanif70] ipv6 enable
    [*MCE-Vlanif70] ipv6 address 2004::1/64
    [*MCE-Vlanif70] quit
    [*MCE] interface vlanif 100
    [*MCE-Vlanif100] ip binding vpn-instance vpna
    [*MCE-Vlanif100] ipv6 enable
    [*MCE-Vlanif100] ipv6 address 2007::2/64
    [*MCE-Vlanif100] quit
    [*MCE] interface vlanif 200
    [*MCE-Vlanif200] ip binding vpn-instance vpnb
    [*MCE-Vlanif200] ipv6 enable
    [*MCE-Vlanif200] ipv6 address 2008::2/64
    [*MCE-Vlanif200] quit
    [*MCE] commit

  5. Set up an MP-IBGP peer relationship between PEs, and EBGP peer relationships between PE1 and CE1, and between PE1 and CE2.

    The configuration details are not mentioned here.

    After the configurations are complete, run the display bgp vpnv6 all peer command on PE1. You can see that the IBGP peer relationship between PE1 and PE2 is in Established state. The EBGP peer relationships between PE1 and CE1 and between PE1 and CE2 are in Established state.

    [~PE1] display bgp vpnv6 all peer
    
     BGP local router ID : 1.1.1.9
     Local AS number : 100
     Total number of peers : 3                 Peers in established state : 3
    
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
    
      2.2.2.9         4   100      288      287     0 01:19:16 Established       6
    
      Peer of ipv6-family for vpn instance :
    
    
      VPN-Instance vpna, router ID 1.1.1.9:
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
      2001::2/64        4 65410        9       11       0 00:04:14 Established       2
      VPN-Instance vpnb, router ID 1.1.1.9:
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
      2002::2/64        4 65420        9       12       0 00:04:09 Established       2
    

  6. Configure routes between the MCE and sites.

    The MCE directly connects to vpna and no routing protocol is used in vpna, so static routes can be used.
    • # Configure SwitchA.

      Configure IPv6 address 2005::1/24 for the interface of SwitchA connected to vpna. The configuration details are not mentioned here.

      <HUAWEI> system-view
      [~HUAWEI] sysname SwitchA
      [*HUAWEI] commit
      [~SwitchA] vlan batch 60
      [*SwitchA] interface 10ge 1/17/1
      [*SwitchA-10GE1/17/1] port link-type trunk
      [*SwitchA-10GE1/17/1] port trunk allow-pass vlan 60
      [*SwitchA-10GE1/17/1] quit
      [*SwitchA] interface vlanif 60
      [*SwitchA-Vlanif60] ipv6 enable
      [*SwitchA-Vlanif60] ipv6 address 2003::2/64
      [*SwitchA-Vlanif60] quit
      [*SwitchA] ipv6 route-static :: 0 2003::1
      [*SwitchA] commit
    • # Configure the MCE.

      [~MCE] ipv6 route-static vpn-instance vpna 2005:: 64 2003::2 
      [*MCE] commit
    • # Check the routing table of the VPN instance vpna on the MCE.
      [~MCE] display ipv6 routing-table vpn-instance vpna
      Routing Table : vpna                                                            
              Destinations : 6        Routes : 6                                      
                                                                                      
       Destination  : 2003::                          PrefixLength : 64               
       NextHop      : 2003::1                         Preference   : 0                
       Cost         : 0                               Protocol     : Direct           
       RelayNextHop : ::                              TunnelID     : 0x0              
       Interface    : VLANIF60                        Flags        : D                
                                                                                      
       Destination  : 2003::2                         PrefixLength : 128              
       NextHop      : ::1                             Preference   : 0                
       Cost         : 0                               Protocol     : Direct           
       RelayNextHop : ::                              TunnelID     : 0x0              
       Interface    : VLANIF60                        Flags        : D                
                                                                                      
       Destination  : 2005::                          PrefixLength : 64               
       NextHop      : 2003::2                         Preference   : 60               
       Cost         : 0                               Protocol     : Static           
       RelayNextHop : ::                              TunnelID     : 0x0              
       Interface    : VLANIF60                        Flags        : RD               
                                                                                      
       Destination  : 2007::                          PrefixLength : 64               
       NextHop      : 2007::2                         Preference   : 0                
       Cost         : 0                               Protocol     : Direct           
       RelayNextHop : ::                              TunnelID     : 0x0              
       Interface    : VLANIF100                       Flags        : D                
                                                                                      
       Destination  : 2007::2                         PrefixLength : 128              
       NextHop      : ::1                             Preference   : 0                
       Cost         : 0                               Protocol     : Direct           
       RelayNextHop : ::                              TunnelID     : 0x0              
       Interface    : VLANIF100                       Flags        : D                
                                                                                      
       Destination  : FE80::                          PrefixLength : 10               
       NextHop      : ::                              Preference   : 0                
       Cost         : 0                               Protocol     : Direct           
       RelayNextHop : ::                              TunnelID     : 0x0              
       Interface    : NULL0                           Flags        : D                
                                                                                      
      You can see that a static route is specified for vpna on the MCE.

    Run RIPng in vpnb, configure RIPng process 200 on the MCE, and bind RIPng process 200 to vpnb so that routes in vpnb can be added to the routing table of vpnb.

    • # Configure the MCE.
      [~MCE] ripng 200 vpn-instance vpnb
      [*MCE-ripng-200] import-route ospfv3 200
      [*MCE-ripng-200] quit
      [*MCE] interface vlanif 70
      [*MCE-Vlanif70] ripng 200 enable
      [*MCE-Vlanif70] quit
      [*MCE] commit
    • # Configure SwitchB.

      Configure IPv6 address 2006::1/64 for the interface of SwitchB connected to vpnb. The configuration details are not mentioned here.

      <HUAWEI> system-view
      [~HUAWEI] sysname SwitchB
      [*HUAWEI] commit
      [~SwitchB] vlan batch 70
      [*SwitchB] interface 10ge 1/17/1
      [*SwitchB-10GE1/17/1] port link-type trunk
      [*SwitchB-10GE1/17/1] port trunk allow-pass vlan 70
      [*SwitchB-10GE1/17/1] quit
      [*SwitchB] ripng 200
      [*SwitchB-ripng-200] quit
      [*SwitchB] interface vlanif 70
      [*SwitchB-Vlanif70] ipv6 enable
      [*SwitchB-Vlanif70] ipv6 address 2004::2/64
      [*SwitchB-Vlanif70] ripng 200 enable
      [*SwitchB-Vlanif70] quit
      [*SwitchB] commit
    • # Check the routing table of the VPN instance vpnb on the MCE.
      [~MCE] display ipv6 routing-table vpn-instance vpnb                     
      Routing Table : vpnb                                                            
              Destinations : 6        Routes : 6                                      
                                                                                      
       Destination  : 2004::                          PrefixLength : 64               
       NextHop      : 2004::1                         Preference   : 0                
       Cost         : 0                               Protocol     : Direct           
       RelayNextHop : ::                              TunnelID     : 0x0              
       Interface    : VLANIF70                        Flags        : D                
                                                                                      
       Destination  : 2004::1                         PrefixLength : 128              
       NextHop      : ::1                             Preference   : 0                
       Cost         : 0                               Protocol     : Direct           
       RelayNextHop : ::                              TunnelID     : 0x0              
       Interface    : VLANIF70                        Flags        : D                
                                                                                      
       Destination  : 2006::                          PrefixLength : 64               
       NextHop      : FE80::5689:98FF:FE28:8442       Preference   : 100              
       Cost         : 0                               Protocol     : RIPng            
       RelayNextHop : ::                              TunnelID     : 0x0              
       Interface    : VLANIF70                        Flags        : D                
                                                                                      
       Destination  : 2008::                          PrefixLength : 64               
       NextHop      : 2008::2                         Preference   : 0                
       Cost         : 0                               Protocol     : Direct           
       RelayNextHop : ::                              TunnelID     : 0x0              
       Interface    : VLANIF200                       Flags        : D                
                                                                                      
       Destination  : 2008::2                         PrefixLength : 128              
       NextHop      : ::1                             Preference   : 0                
       Cost         : 0                               Protocol     : Direct           
       RelayNextHop : ::                              TunnelID     : 0x0              
       Interface    : VLANIF200                       Flags        : D                
                                                                                      
       Destination  : FE80::                          PrefixLength : 10               
       NextHop      : ::                              Preference   : 0                
       Cost         : 0                               Protocol     : Direct           
       RelayNextHop : ::                              TunnelID     : 0x0              
       Interface    : NULL0                           Flags        : D                
                                                                               

      You can see that the MCE has learned private routes in vpnb through RIPng. These private routes and route 2005::/64 in vpna exist in two routing tables.

  7. Configure OSPFv3 multi-instance between the MCE and PE2.

    # Configure PE2.
    NOTE:
    The following configurations need to be performed on PE2:
    • Configure PE2 to import BGP routs in the OSPFv3 view and advertise private routes of PE1 to the MCE.
    • Configure PE2 to import the OSPFv3 process in the BGP view and advertise private routes of the MCE to PE1.
    [~PE2] ospfv3 100 vpn-instance vpna
    [*PE2-ospfv3-100] router-id 3.3.3.3
    [*PE2-ospfv3-100] import-route bgp
    [*PE2-ospfv3-100] quit
    [*PE2] ospfv3 200 vpn-instance vpnb
    [*PE2-ospfv3-200] router-id 4.4.4.4
    [*PE2-ospfv3-200] import-route bgp
    [*PE2-ospfv3-200] quit
    [*PE2] interface vlanif 100
    [*PE2-Vlanif100] ospfv3 100 area 0
    [*PE2-Vlanif100] quit
    [*PE2] interface vlanif 200
    [*PE2-Vlanif200] ospfv3 200 area 0
    [*PE2-Vlanif200] quit
    [*PE2] bgp 100
    [*PE2-bgp] ipv6-family vpn-instance vpna
    [*PE2-bgp-6-vpna] import-route ospfv3 100
    [*PE2-bgp-6-vpna] quit
    [*PE2-bgp] ipv6-family vpn-instance vpnb
    [*PE2-bgp-6-vpnb] import-route ospfv3 200
    [*PE2-bgp-6-vpnb] quit
    [*PE2] commit
    # Configure the MCE.
    NOTE:

    The MCE needs to import private routes to the OSPFv3 process.

    [~MCE] ospfv3 100 vpn-instance vpna
    [*MCE-ospfv3-100] router-id 1.1.1.1
    [*MCE-ospfv3-100] import-route static
    [*MCE-ospfv3-100] vpn-instance-capability simple
    [*MCE-ospfv3-100] quit
    [*MCE] ospfv3 200 vpn-instance vpnb
    [*MCE-ospfv3-200] router-id 2.2.2.2
    [*MCE-ospfv3-200] import-route ripng 200
    [*MCE-ospfv3-200] vpn-instance-capability simple
    [*MCE-ospfv3-200] quit
    [*MCE]interface vlanif 60
    [*MCE-Vlanif60] ospfv3 100 area 0
    [*MCE-Vlanif60] quit
    [*MCE]interface vlanif 100
    [*MCE-Vlanif100] ospfv3 100 area 0
    [*MCE-Vlanif100] quit
    [*MCE] interface vlanif 200
    [*MCE-Vlanif200] ospfv3 200 area 0
    [*MCE-Vlanif200] quit
    [*MCE] commit

  8. Verify the configuration.

    After the configurations are complete, run the display ipv6 routing-table vpn-instance command on the MCE. You can see the route to the peer switch.

    vpna is used as an example.

    [~MCE] display ipv6 routing-table vpn-instance vpna
    Routing Table : vpna                                                            
            Destinations : 7        Routes : 7                                      
                                                                                    
     Destination  : 2001::                          PrefixLength : 64               
     NextHop      : FE80::5689:98FF:FE28:8472       Preference   : 150              
     Cost         : 0                               Protocol     : OSPFv3ASE        
     RelayNextHop : ::                              TunnelID     : 0x0              
     Interface    : VLANIF100                       Flags        : D                
                                                                                    
     Destination  : 2003::                          PrefixLength : 64               
     NextHop      : 2003::1                         Preference   : 0                
     Cost         : 0                               Protocol     : Direct           
     RelayNextHop : ::                              TunnelID     : 0x0              
     Interface    : VLANIF60                        Flags        : D                
                                                                                    
     Destination  : 2003::1                         PrefixLength : 128              
     NextHop      : ::1                             Preference   : 0                
     Cost         : 0                               Protocol     : Direct           
     RelayNextHop : ::                              TunnelID     : 0x0              
     Interface    : VLANIF60                        Flags        : D                
                                                                                    
     Destination  : 2005::                          PrefixLength : 64               
     NextHop      : 2003::2                         Preference   : 60               
     Cost         : 0                               Protocol     : Static           
     RelayNextHop : ::                              TunnelID     : 0x0              
     Interface    : VLANIF60                        Flags        : RD               
                                                                                    
     Destination  : 2007::                          PrefixLength : 64               
     NextHop      : 2007::2                         Preference   : 0                
     Cost         : 0                               Protocol     : Direct           
     RelayNextHop : ::                              TunnelID     : 0x0              
     Interface    : VLANIF100                        Flags        : D                
                                                                                    
     Destination  : 2007::2                         PrefixLength : 128              
     NextHop      : ::1                             Preference   : 0                
     Cost         : 0                               Protocol     : Direct           
     RelayNextHop : ::                              TunnelID     : 0x0              
     Interface    :  VLANIF100                        Flags        : D                
                                                                                    
     Destination  : FE80::                          PrefixLength : 10               
     NextHop      : ::                              Preference   : 0                
     Cost         : 0                               Protocol     : Direct           
     RelayNextHop : ::                              TunnelID     : 0x0              
     Interface    : NULL0                           Flags        : D                
                                                                                    
    

    Run the display ipv6 routing-table vpn-instance command on the PE. You can view the routes to the peer switch.

    CE1 can communicate with SwitchA, and CE2 can communicate with SwitchB.

    CE1 cannot communicate with CE2 and SwitchB, and SwitchA cannot communicate with CE2 and SwitchB.

Configuration Files
  • Configuration file of CE1

    #
    sysname CE1
    #
    vlan batch 10
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 2001::2/64
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    bgp 65410
     peer 2001::1 as-number 100
     #
     ipv6-family unicast
      import-route direct
      peer 2001::1 enable
    #
    return
  • Configuration file of CE2

    #
    sysname CE2
    #
    vlan batch 20
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 2002::2/64
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    bgp 65420
     peer 2002::1 as-number 100
     #
     ipv6-family unicast
      import-route direct
      peer 2002::1 enable
    #
    return
  • Configuration file of PE1

    #
    sysname PE1
    #
    vlan batch 10 20 30
    #
    ip vpn-instance vpna
     ipv6-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv6-family
      route-distinguisher 100:2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
    mpls lsr-id 1.1.1.9
    #
    mpls
    #
    mpls ldp
     #  ipv4-family
    #
    interface Vlanif10
     ip binding vpn-instance vpna
     ipv6 enable
     ipv6 address 2001::1/64
    #
    interface Vlanif20
     ip binding vpn-instance vpnb
     ipv6 enable
     ipv6 address 2002::1/64
    #
    interface Vlanif30
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    bgp 100
     peer 2.2.2.9 as-number 100
     peer 2.2.2.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 2.2.2.9 enable
     #
     ipv6-family vpnv6
      policy vpn-target
      peer 2.2.2.9 enable
     #
     ipv6-family vpn-instance vpna
      peer 2001::2 as-number 65410
      import-route direct
     #
     ipv6-family vpn-instance vpnb
      peer 2002::2 as-number 65420
      import-route direct
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
    #
    return
  • Configuration file of PE2

    #
    sysname PE2
    #
    vlan batch 30 100 200
    #
    ip vpn-instance vpna
     ipv6-family
      route-distinguisher 200:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv6-family 
      route-distinguisher 200:2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
    mpls lsr-id 2.2.2.9
    #
    mpls
    #
    mpls ldp
     #  ipv4-family
    #
    ospfv3 100 vpn-instance vpna
     router-id 3.3.3.3
     import-route bgp
    #
    ospfv3 200 vpn-instance vpnb
     router-id 4.4.4.4
     import-route bgp
    #
    interface Vlanif30
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif100  
     ip binding vpn-instance vpna 
     ipv6 enable
     ipv6 address 2007::1/64
     ospfv3 100 area 0.0.0.0
    #      
    interface Vlanif200 
     ip binding vpn-instance vpnb 
     ipv6 enable
     ipv6 address 2008::1/64
     ospfv3 200 area 0.0.0.0 
    #                                       
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/17/2
     port link-type trunk                                                           
     port trunk allow-pass vlan 100 200  
    #
    bgp 100
     peer 1.1.1.9 as-number 100
     peer 1.1.1.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 1.1.1.9 enable
     #
     ipv6-family vpnv6
      policy vpn-target
      peer 1.1.1.9 enable
     #
     ipv6-family vpn-instance vpna
      import-route ospfv3 100
     #
     ipv6-family vpn-instance vpnb
      import-route ospfv3 200
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
    #
    return
  • Configuration file of the MCE

    #
    sysname MCE
    #
    vlan batch 60 70 100 200
    #
    ip vpn-instance vpna
     ipv6-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv6-family
      route-distinguisher 100:2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
    ospfv3 100 vpn-instance vpna
     router-id 1.1.1.1
     vpn-instance-capability simple
     import-route static
    #
    ospfv3 200 vpn-instance vpnb
     router-id 2.2.2.2
     vpn-instance-capability simple
     import-route ripng 200
    #
    interface Vlanif60
     ip binding vpn-instance vpna
     ipv6 enable
     ipv6 address 2003::1/64
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif70
     ip binding vpn-instance vpnb
     ipv6 enable
     ipv6 address 2004::1/64
     ripng 200 enable
    #
    interface Vlanif100
     ip binding vpn-instance vpna
     ipv6 enable
     ipv6 address 2007::2/64
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif200
     ip binding vpn-instance vpnb
     ipv6 enable
     ipv6 address 2008::2/64
     ospfv3 200 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type trunk    
     port trunk allow-pass vlan 100 200 
    #
    interface 10GE1/17/3
     port link-type trunk                                                           
     port trunk allow-pass vlan 60 
    #
    interface 10GE1/17/4
     port link-type trunk                                                           
     port trunk allow-pass vlan 70 
    #
    ripng 200 vpn-instance vpnb
     import-route ospfv3 200
    #
    ipv6 route-static vpn-instance vpna 2005:: 64 2003::2
    #
    return
  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 60 80
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address 2003::2/64
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address 2005::1/64
    #
    interface 10GE1/17/1
     port link-type trunk                                                           
     port trunk allow-pass vlan 60 
    #
    interface 10GE1/17/2
     port link-type trunk                                                           
     port trunk allow-pass vlan 80 
    #
    ipv6 route-static :: 0 2003::1
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 70 80
    #
    interface Vlanif70
     ipv6 enable
     ipv6 address 2004::2/64
     ripng 200 enable
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address 2006::1/64
     ripng 200 enable
    #
    interface 10GE1/17/1
     port link-type trunk  
     port trunk allow-pass vlan 70 
    #
    interface 10GE1/17/2
     port link-type trunk 
     port trunk allow-pass vlan 80 
    #
    ripng 200
    #
    return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 59781

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next