No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides several configuration examples of LLDP, including networking requirements and configuration roadmap.

Example for Configuring LLDP on the Device That Has a Single Neighbor

Networking Requirements

As shown in Figure 14-27, SwitchA and SwitchB are directly connected; routes between the NMS and SwitchA, and the NMS and SwitchB are reachable; SNMP is configured.

A network administrator wants to obtain communication information between SwitchA and SwitchB, and alarms of device function changes to know the detailed network topology and configuration conflicts.

Figure 14-27 Single-neighbor network
Configuration Roadmap
To enable the network administrator to obtain information about links between SwitchA and SwitchB on the NMS, configure the LLDP function. The configuration roadmap is as follows:
  1. Enable global LLDP on SwitchA and SwitchB.
  2. Configure management IP addresses for SwitchA and SwitchB.

Procedure

  1. Enable global LLDP on SwitchA and SwitchB.

    # Configure SwitchA.
    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] lldp enable
    [*SwitchA] commit
    # Configure SwitchB.
    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] lldp enable
    [*SwitchB] commit

  2. Configure management IP addresses for SwitchA and SwitchB.

    NOTE:

    The specified IP address must exist on the device. For detailed configurations, see the configuration files.

    # Configure SwitchA.
    [~SwitchA] lldp management-address 10.10.10.1
    [*SwitchA] commit
    # Configure SwitchB.
    [~SwitchB] lldp management-address 10.10.10.2
    [*SwitchB] commit

  3. Verify the configurations.

    • Check SwitchA.

      # Check neighbor information of SwitchA.

      [~SwitchA] display lldp neighbor brief
      Local Interface         Exptime(s) Neighbor Interface      Neighbor Device      
      ------------------------------------------------------------------------------- 
      10GE1/17/1                      115 10GE1/17/1               SwitchB
    • Check SwitchB.

      # Check neighbor information of SwitchB.

      [~SwitchB] display lldp neighbor brief
      Local Interface         Exptime(s) Neighbor Interface      Neighbor Device      
      ------------------------------------------------------------------------------- 
      10GE1/17/1                      110 10GE1/17/1               SwitchA

Configuration Files
  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.10.10.1 255.255.255.0
    #
    lldp enable
    #
    lldp management-address  10.10.10.1
    #
    return
    
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.10.10.2 255.255.255.0
    #
    lldp enable
    #
    lldp management-address 10.10.10.2
    #
    return

Example for Configuring LLDP on the Network with link aggregation configured

Networking Requirements

As shown in Figure 14-28, SwitchA and SwitchB are connected through an Eth-Trunk. Routes between the NMS and switches are reachable, and SNMP is configured.

A network administrator wants to obtain Layer 2 information about SwitchA and SwitchB to know the detailed network topology and configuration conflicts.

Figure 14-28 Network with link aggregation configured
Configuration Roadmap
The LLDP function can meet the network administrator's requirement. The configuration roadmap is as follows:
  1. Add the physical interfaces on SwitchA and SwitchB to the Eth-Trunk.
  2. Enable global LLDP on SwitchA and SwitchB.
  3. Configure management IP addresses for SwitchA and SwitchB.

Procedure

  1. Add the physical interfaces on SwitchA and SwitchB to the Eth-Trunk.

    # Configure SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100
    [*SwitchA] interface eth-trunk 1
    [*SwitchA-Eth-Trunk1] trunkport 10ge 1/17/1 to 1/17/3
    [*SwitchA-Eth-Trunk1] port link-type trunk
    [*SwitchA-Eth-Trunk1] port trunk allow-pass vlan 100
    [*SwitchA-Eth-Trunk1] commit
    [~SwitchA-Eth-Trunk1] quit

    # Configure SwitchB.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 100
    [*SwitchB] interface eth-trunk 1
    [*SwitchB-Eth-Trunk1] trunkport 10ge 1/17/1 to 1/17/3
    [*SwitchB-Eth-Trunk1] port link-type trunk
    [*SwitchB-Eth-Trunk1] port trunk allow-pass vlan 100
    [*SwitchB-Eth-Trunk1] commit
    [~SwitchB-Eth-Trunk1] quit

  2. Enable global LLDP on SwitchA and SwitchB.

    # Configure SwitchA.
    [~*SwitchA] lldp enable
    [**SwitchA] commit
    # Configure SwitchB.
    [~SwitchB] lldp enable
    [*SwitchB] commit

  3. Configure management IP addresses for SwitchA and SwitchB.

    NOTE:

    The specified IP address must exist on the device. For detailed configurations, see the configuration files.

    # Configure SwitchA.
    [~SwitchA] lldp management-address 10.10.10.1
    [**SwitchA] commit
    # Configure SwitchB.
    [~SwitchB] lldp management-address 10.10.10.2
    [*SwitchB] commit

  4. Verify the configurations.

    • Check the SwitchA configuration.

      # Check whether the physical interfaces are added to Eth-Trunk1.

      [~SwitchA] display eth-trunk 1
      Eth-Trunk1's state information is:
      WorkingMode: NORMAL         Hash arithmetic: According to SIP-XOR-DIP
      Least Active-linknumber: 1  Max Bandwidth-affected-linknumber: 16
      Operate status: up          Number Of Up Ports In Trunk: 3
      --------------------------------------------------------------------------------
      PortName                Status      Weight
      10GE1/17/1               Up          1
      10GE1/17/2               Up          1
      10GE1/17/3               Up          1                                           

      # Check neighbor information of SwitchA.

      [~SwitchA] display lldp neighbor brief
      Local Interface         Exptime(s) Neighbor Interface      Neighbor Device      
      ------------------------------------------------------------------------------- 
      10GE1/17/1                      115 10GE1/17/1               SwitchB
      10GE1/17/2                      115 10GE1/17/2               SwitchB
      10GE1/17/3                      115 10GE1/17/3               SwitchB
      
    • Check the SwitchB configuration.

      Refer to the steps for checking SwitchA.

Configuration Files
  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
     vlan batch 100
    #
    interface Vlanif100
     ip address 10.10.10.1 255.255.255.0
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/17/1
     eth-trunk 1
    #
    interface 10GE1/17/2
     eth-trunk 1
    #
    interface 10GE1/17/3
     eth-trunk 1
    #
    lldp enable
    #
    lldp management-address 10.10.10.1
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
     vlan batch 100
    #
    interface Vlanif100
     ip address 10.10.10.2 255.255.255.0
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/17/1
     eth-trunk 1
    #
    interface 10GE1/17/2
     eth-trunk 1
    #
    interface 10GE1/17/3
     eth-trunk 1
    #
    lldp enable
    #
    lldp management-address 10.10.10.2
    #
    return

Example for Configuring MDN

Networking Requirements

As shown in Figure 14-29, non-Huawei devices S1 and S2 have direct links to Huawei switch, and the switch has a reachable route to the NMS. The switch needs to identify and receive the non-standard discovery protocol packets from S1 and S2, and send traps when the neighbors change.

Figure 14-29 Networking diagram for configuring MDN
Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable the LLDP function for the Switch globally.
  2. Configure MDN on the Switch so that the Switch can detect non-Huawei devices to which the Switch is directly connected.
  3. Enable LLDP trap on the switch so that the switch can send traps when neighbors change. You can also configure the switch to send traps to the NMS if necessary.

Procedure

  1. Enable the LLDP function for the Switch globally.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] lldp enable
    

  2. Configure MDN on the Switch.

    # Configure MDN on 10ge 1/17/1.
    [*Switch] interface 10ge 1/17/1
    [*Switch-10GE1/17/1] lldp mdn enable
    [*Switch-10GE1/17/1] quit
    [*Switch] interface 10ge 1/17/2
    [*Switch-10GE1/17/2] lldp mdn enable
    [*Switch-10GE1/17/2] quit

  3. Enable LLDP trap on the switch.

    [*Switch] snmp-agent trap enable feature-name lldp
    [*Switch] commit

  4. Verify the configurations.

    View information about MDN neighbors of the Switch.

    [~Switch] display lldp mdn neighbor
    10GE1/17/1 has 1 neighbor(s):
    Neighbor index                     :1
    MacAddress                         :0023-ea20-b010             
    Discovered time                    :2012-03-09 13:09:55
    
    10GE1/17/2 has 1 neighbor(s):
    Neighbor index                     :1
    MacAddress                         :0023-ea20-b011             
    Discovered time                    :2012-03-09 13:09:58

Configuration Files
# Configuration file of Switch
#
sysname Switch
#
interface 10GE1/17/1
 lldp mdn enable
#
interface 10GE1/17/2
 lldp mdn enable
#
snmp-agent trap enable feature-name lldp trap-name hwLldpMdnRemTablesChange
#
lldp enable
#
return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 58706

Downloads: 3621

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next