No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This example describes how to configure UDP helper on a switch modules.

Example for Configuring UDP Helper

Networking Requirements

As shown in Figure 6-40, Switch Module connects to a local area network (LAN) through 10GE1/17/2, which needs to be added to VLAN20. The IP address to be assigned to VLANIF20 is 10.110.1.1/16. NetBIOS-NS is connected to 10GE1/17/1 on Switch Module. The IP address of the NetBIOS-NS server is 202.2.1.1/16 and 10GE1/17/1 needs to be added to VLAN10. The IP address to be assigned to VLANIF10 is 202.2.1.2/16. PC1 and PC2 on the LAN need to access each other using host names.

Figure 6-40 UDP helper network

Configuration Roadmap
  1. Because the PCs on the LAN need to access each other using host names, the host names must be resolved into IP addresses. However, the NetBIOS-NS and PCs are in different broadcast domains. The NetBIOS-NS Register packets cannot reach the NetBIOS-NS server. The Switch Module must be enabled with UDP helper to forward the UDP packets with destination port 137 (NetBIOS-NS port) to the NetBIOS-NS server.
  2. After UDP helper is enabled, specify the IP address of destination NetBIOS-NS server on VLANIF20.
NOTE:

After UDP helper is enabled on the Switch Module, the Switch Module relays the broadcast packets with UDP destination port 137 by default. The UDP port number, therefore, does not need to be configured in this example.

Procedure

  1. Add 10GE1/17/2 of Switch Module to VLAN20 and assign an IP address to VLANIF20.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch Module
    [*HUAWEI] commit
    [~Switch Module] vlan batch 20
    [*Switch Module] interface 10ge 1/17/2
    [*Switch Module-10GE1/17/2] port default vlan 20
    [*Switch Module-10GE1/17/2] quit
    [*Switch Module] interface vlanif 20
    [*Switch Module-Vlanif20] ip address 10.110.1.1 16
    [*Switch Module-Vlanif20] quit
    [*Switch Module] commit
    

  2. Add 10GE1/17/1 of Switch Module to VLAN10 and assign an IP address to VLANIF10.

    [~Switch Module] vlan batch 10
    [*Switch Module] interface 10ge 1/17/1
    [*Switch Module-10GE1/17/1] port default vlan 10
    [*Switch Module-10GE1/17/1] quit
    [*Switch Module] interface vlanif 10
    [*Switch Module-Vlanif10] ip address 202.2.1.2 16
    [*Switch Module-Vlanif10] quit
    [*Switch Module] commit
    

  3. Enable UDP helper.

    [~Switch Module] ip udp-helper enable
    [*Switch Module] commit

  4. Configure a destination server for packet relay on VLANIF20 of Switch Module.

    [~Switch Module] interface vlanif 20
    [*Switch Module-Vlanif20] ip udp-helper server 202.2.1.1
    [*Switch Module-Vlanif20] quit
    [*Switch Module] commit
    

  5. Verify the configuration.

    When the PCs access each other using host names, the Switch Module starts to collect statistics on UDP helper.

    [~Switch Module] display ip udp-helper server
    vlan-interface        Server-Ip                  packet-num  packet-drop
    ------------------------------------------------------------------------ 
    Vlanif20              202.2.1.1                         201            0   

Configuration Files

Configuration file of the Switch Module

#
sysname Switch Module
#
vlan batch 10 20
#
ip udp-helper enable
#
interface Vlanif10
 ip address 202.2.1.2 255.255.0.0
#     
interface Vlanif20
 ip address 10.110.1.1 255.255.0.0     
 ip udp-helper server 202.2.1.1 
#
interface 10GE1/17/1
 port default vlan 10
#
interface 10GE1/17/2
 port default vlan 20
#
return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 59390

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next