No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides examples for the BFD configuration, including networking requirements, configuration notes, and configuration roadmap.

Example for Configuring Single-hop BFD for Detecting Faults on a Layer 2 Link

Networking Requirements

As shown in Figure 11-22, Switch ModuleA and Switch ModuleB are connected through a Layer 2 interface. Faults on the link between Switch ModuleA and Switch ModuleB need to be fast detected.

Figure 11-22 Single-hop BFD for detecting faults on a Layer 2 link
Configuration Roadmap

The configuration roadmap is as follows:

Configure BFD sessions on Switch ModuleA and Switch ModuleB to detect faults on the link between Switch ModuleA and Switch ModuleB.

Procedure

  1. Configure interfaces that connect the Switch ModuleA and Switch ModuleB to ensure transmission of packets at Layer 2.

    # Configure the Switch ModuleA.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan 10
    [*Switch ModuleA-vlan10] quit
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/1] undo port trunk allow-pass vlan 1
    [*Switch ModuleA-10GE1/17/1] port trunk pvid vlan 10
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit
    

    # Configure the interface on the Switch ModuleB. The configuration method is the same as that on the Switch ModuleA. See details in the configuration files.

  2. Configure single-hop BFD on Switch ModuleA.

    # Enable BFD on Switch ModuleA.

    [~Switch ModuleA] bfd
    [*Switch ModuleA-bfd] quit

    # Create a BFD session on Switch ModuleA.

    [*Switch ModuleA] bfd atob bind peer-ip default-ip interface 10ge 1/17/1
    [*Switch ModuleA-bfd-session-atob] discriminator local 1
    [*Switch ModuleA-bfd-session-atob] discriminator remote 2
    [*Switch ModuleA-bfd-session-atob] commit
    [~Switch ModuleA-bfd-session-atob] quit
    

  3. Configure single-hop BFD on Switch ModuleB.

    # Enable BFD on Switch ModuleB.

    [~Switch ModuleB] bfd
    [*Switch ModuleB-bfd] quit

    # Create a BFD session on Switch ModuleB.

    [*Switch ModuleB] bfd btoa bind peer-ip default-ip interface 10ge 1/17/1
    [*Switch ModuleB-bfd-session-btoa] discriminator local 2
    [*Switch ModuleB-bfd-session-btoa] discriminator remote 1
    [*Switch ModuleB-bfd-session-btoa] commit
    [~Switch ModuleB-bfd-session-btoa] quit

  4. Verify the configuration.

    After the configuration is complete, run the display bfd session all verbose command on Switch ModuleA and Switch ModuleB. You can see that a single-hop BFD session is set up and its status is Up.

    The display on Switch ModuleA is used as an example.

    [Switch ModuleA] display bfd session all verbose
    Total UP/DOWN Session Number : 1/0
    --------------------------------------------------------------------------------
      Name : atob                  (Single Hops)   State : Up                           
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2          
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(10GE1/17/1)                                 
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 224.0.0.184                                          
      Bind Interface         : 10GE1/17/1                                            
      FSM Board Id           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000       
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000       
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : No Diagnostic                       
      Bind Application       : No Application Bind                                  
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    

    # Run the shutdown command on 10GE1/17/1 of Switch ModuleA to simulate a link fault.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] shutdown
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit

    After the configuration is complete, run the display bfd session all verbose command on Switch ModuleA and Switch ModuleB. You can see that a single-hop BFD session is set up and its status is Down. The display on Switch ModuleA is used as an example.

    [Switch ModuleA] display bfd session all verbose
    Total UP/DOWN Session Number : 0/1
    --------------------------------------------------------------------------------
      Name : atob                  (Single Hops)   State : Down                         
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2          
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(10GE1/17/1)                                 
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 224.0.0.184                                          
      Bind Interface         : 10GE1/17/1                                            
      FSM Board Id           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 4331             Actual Rx Interval (ms): 4331       
      WTR Interval (ms)      : -                Detect Interval (ms)   : -          
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : No Application Bind                                  
      Session Not Up Reason  : In negotiation                                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    bfd
    #
    interface 10GE1/17/1
     shutdown
     port link-type trunk
     port trunk pvid vlan 10
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
    #
    bfd atob bind peer-ip default-ip interface 10GE1/17/1
     discriminator local 1
     discriminator remote 2
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    bfd
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 10
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
    #
    bfd btoa bind peer-ip default-ip interface 10GE1/17/1
     discriminator local 2
     discriminator remote 1
    #
    return

Example for Configuring Single-Hop BFD on a VLANIF Interface

Networking Requirements

As shown in Figure 11-23, Switch ModuleA connects to Switch ModuleB through the VLANIF interface and Layer 2 transmission devices, SwitchC and SwitchD, are deployed between them. Faults on the link between Switch ModuleA and Switch ModuleB need to be fast detected.

Figure 11-23 Networking diagram for configuring single-hop BFD on a VLANIF interface
Configuration Roadmap

The configuration roadmap is as follows:

Configure BFD sessions on Switch ModuleA and Switch ModuleB.

Procedure

  1. Configure devices to ensure network connectivity.

    # Assign an IP address to each interface. Switch ModuleA is used as an example. The configuration of Switch ModuleB is similar to the configuration of Switch ModuleA, and is not mentioned here.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 100
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 100
    [*Switch ModuleA-10GE1/17/1] port trunk pvid vlan 100
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface vlanif 100
    [*Switch ModuleA-Vlanif100] ip address 10.1.1.5 24
    [*Switch ModuleA-Vlanif100] quit
    [*Switch ModuleA] commit

  2. Configure single-hop BFD.

    # Enable BFD and create a BFD session on Switch ModuleA.

    [~Switch ModuleA] bfd
    [*Switch ModuleA-bfd] quit
    [*Switch ModuleA] bfd atob bind peer-ip 10.1.1.6 interface vlanif 100
    [*Switch ModuleA-bfd-session-atob] discriminator local 1
    [*Switch ModuleA-bfd-session-atob] discriminator remote 2
    [*Switch ModuleA-bfd-session-atob] commit
    [~Switch ModuleA-bfd-session-atob] quit
    

    # Enable BFD and create a BFD session on Switch ModuleB.

    [~Switch ModuleB] bfd
    [*Switch ModuleB-bfd] quit
    [*Switch ModuleB] bfd btoa bind peer-ip 10.1.1.5 interface vlanif 100
    [*Switch ModuleB-bfd-session-btoa] discriminator local 2
    [*Switch ModuleB-bfd-session-btoa] discriminator remote 1
    [*Switch ModuleB-bfd-session-btoa] commit
    [~Switch ModuleB-bfd-session-btoa] quit
    

  3. Verify the configuration.

    # After the configuration is complete, run the display bfd session all verbose command on Switch ModuleA and Switch ModuleB. You can see that a single-hop BFD session is set up and its status is Up. The display on Switch ModuleA is used as an example.

    <SwitchA> display bfd session all verbose
    Total UP/DOWN Session Number : 1/0
    --------------------------------------------------------------------------------
      Name : atob                  (Single Hops)   State : Up
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Interface(Vlanif100)  
      Bind Session Type      : Static 
      Bind Peer IP Address   : 10.1.1.6         
      Bind Interface         : Vlanif100
      FSM Board Id           : 1                ToS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000       
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000       
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : No Application Bind                                  
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    

    # Run the shutdown command on the 10GE1/17/1 interface of Switch ModuleA to simulate a link fault.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] shutdown
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit

    # After the configuration is complete, run the display bfd session all verbose command on Switch ModuleA and Switch ModuleB. You can see that a single-hop BFD session is set up and its status is Down. Take the display on Switch ModuleA as an example.

    <SwitchA> display bfd session all verbose
    Total UP/DOWN Session Number : 0/1
    --------------------------------------------------------------------------------
      Name : atob                  (Single Hops)   State : Down
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Interface(Vlanif100)  
      Bind Session Type      : Static 
      Bind Peer IP Address   : 10.1.1.6         
      Bind Interface         : Vlanif100
      FSM Board Id           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 10093            Actual Rx Interval (ms): 10093      
      WTR Interval (ms)      : -                Detect Interval (ms)   : -          
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : No Application Bind                                  
      Session Not Up Reason  : In negotiation                                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ip address 10.1.1.5 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    bfd atob bind peer-ip 10.1.1.6 interface Vlanif100
     discriminator local 1
     discriminator remote 2
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname SwitchB
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ip address 10.1.1.6 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    bfd btoa bind peer-ip 10.1.1.5 interface Vlanif100
     discriminator local 2
     discriminator remote 1
    #
    return

Example for Configuring Multi-Hop BFD

Networking Requirements

As shown in Figure 11-24, Switch ModuleA is indirectly connected to Switch ModuleC and Layer 2 transmission devices, SwitchD and SwitchE, are deployed between them. Static routes are configured so that Switch ModuleA can communicate with Switch ModuleC. Faults on the link between Switch ModuleA and Switch ModuleC need to be fast detected.

Figure 11-24 Networking diagram for configuring multi-hop BFD
Configuration Roadmap

The configuration roadmap is as follows:

Configure BFD sessions on Switch ModuleA and Switch ModuleC to detect the multi-hop route.

Procedure

  1. Configure devices to ensure network connectivity.

    # Assign an IP address to each interface. Switch ModuleA is used as an example. The configurations of Switch ModuleB and Switch ModuleC are similar to the configuration of Switch ModuleA, and are not mentioned here.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 10
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/1] port trunk pvid vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ip address 10.1.1.1 24
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] commit

  2. Configure a reachable static route between Switch ModuleA and Switch ModuleC.

    The configuration of Switch ModuleC is similar to the configuration of Switch ModuleA, and is not mentioned here. For details, see the configuration files.

    [~Switch ModuleA] ip route-static 10.2.1.0 24 10.1.1.2
    [*Switch ModuleA] commit

  3. Configure multi-hop BFD.

    # Create a BFD session between Switch ModuleA and Switch ModuleC.

    [~Switch ModuleA] bfd
    [*Switch ModuleA-bfd] quit
    [*Switch ModuleA] bfd atoc bind peer-ip 10.2.1.2
    [*Switch ModuleA-bfd-session-atoc] discriminator local 10
    [*Switch ModuleA-bfd-session-atoc] discriminator remote 20
    [*Switch ModuleA-bfd-session-atoc] commit
    [~Switch ModuleA-bfd-session-atoc] quit

    # Create a BFD session between Switch ModuleC and Switch ModuleA.

    [~Switch ModuleC] bfd
    [*Switch ModuleC-bfd] quit
    [*Switch ModuleC] bfd ctoa bind peer-ip 10.1.1.1
    [*Switch ModuleC-bfd-session-ctoa] discriminator local 20
    [*Switch ModuleC-bfd-session-ctoa] discriminator remote 10
    [*Switch ModuleC-bfd-session-ctoa] commit
    [~Switch ModuleC-bfd-session-ctoa] quit

  4. Verify the configuration.

    After the configuration, run the display bfd session verbose command on Switch ModuleA and Switch ModuleC. You can see that a BFD session is set up and is in Up state. Take the display on Switch ModuleA as an example.

    [Switch ModuleA] display bfd session all verbose
    Total UP/DOWN Session Number : 1/0
    --------------------------------------------------------------------------------
      Name : atoc                  (Multiple Hops) State : Up
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Peer IP Address                                      
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 10.2.1.2                                             
      Bind Interface         : -                                                    
      FSM Board Id           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 3000             Actual Rx Interval (ms): 3000       
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000       
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 4784             TTL                    : 254        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : No Application Bind                                  
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    

    # Run the shutdown command on the 10GE1/17/1 interface of Switch ModuleA to simulate a link fault.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] shutdown
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit

    After the configuration, run the display bfd session all verbose command on Switch ModuleA and Switch ModuleB. You can see that a multi-hop BFD session is set up and the status is Down. Take the display on Switch ModuleA as an example.

    [Switch ModuleA] display bfd session all verbose
    Total UP/DOWN Session Number : 0/1
    --------------------------------------------------------------------------------
      Name : atoc                  (Multiple Hops) State : Down
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Peer IP Address                                      
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 10.2.1.2                                             
      Bind Interface         : -                                                    
      FSM Board Id           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 6761             Actual Rx Interval (ms): 6761       
      WTR Interval (ms)      : -                Detect Interval (ms)   : -          
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 4784             TTL                    : 254        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : No Application Bind                                  
      Session Not Up Reason  : In negotiation                                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10
    #
    bfd
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk  port trunk pvid vlan 10  port trunk allow-pass vlan 10
    #
    bfd atoc bind peer-ip 10.2.1.2
     discriminator local 10
     discriminator remote 20
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk pvid vlan 20
     port trunk allow-pass vlan 20
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 20
    #
    bfd
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk  port trunk pvid vlan 20  port trunk allow-pass vlan 20
    #
    bfd ctoa bind peer-ip 10.1.1.1
     discriminator local 20
     discriminator remote 10
    #
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return

Example for Configuring a BFD for Perlink Session to Detect Eth-Trunk Member Link Faults on a VLAN

This section provides an example for configuring a BFD for Perlink session to monitor Eth-Trunk member links on a VLAN and rapidly detect link faults.

Networking Requirements

On the network shown in Figure 11-25, Switch ModuleA and Switch ModuleB are directly connected through Eth-Trunk interfaces, which join VLAN 100. BFD sessions can be bound to VLANIF interfaces to detect the connectivity of the Eth-Trunk between Switch ModuleA and Switch ModuleB. If BFD for IP single-hop sessions are used, BFD will select one of the member links of the Eth-Trunk to monitor the status of the Eth-Trunk. Once BFD detects that the selected member link is Down, it considers the Eth-Trunk to be Down even if other member links of the Eth-Trunk are Up. To prevent BFD from incorrectly detecting the Eth-Trunk state, you can deploy BFD for Perlink sessions instead of BFD for IP single-hop sessions.

Figure 11-25 Configuring a BFD for Perlink session to detect Eth-Trunk member link faults on a VLAN
Configuration Roadmap

The configuration roadmap is as follows:

  1. Create an Eth-Trunk interface on Switch ModuleA and Switch ModuleB, and add Ethernet physical interfaces to the Eth-Trunk interface.

  2. Create a VLAN on Switch ModuleA and Switch ModuleB, add the Eth-Trunk interface to the VLAN, and create a VLANIF interface to implement Layer 3 interworking between Switch ModuleA and Switch ModuleB through the VLANIF interface.
  3. Configure a BFD for Perlink session on Switch ModuleA to monitor the Eth-Trunk member links between Switch ModuleA and Switch ModuleB.

Procedure

  1. Create an Eth-Trunk interface on Switch ModuleA and Switch ModuleB, and add Ethernet physical interfaces to the Eth-Trunk interface.

    # Configure Switch ModuleA. The configuration of Switch ModuleB is similar to the configuration of Switch ModuleA. See the configuration file for details.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] interface Eth-Trunk 1
    [*Switch ModuleA-Eth-Trunk1] commit
    [~Switch ModuleA-Eth-Trunk1] quit
    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] eth-trunk 1
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit
    [~Switch ModuleA] interface 10ge 1/17/2
    [~Switch ModuleA-10GE1/17/2] eth-trunk 1
    [*Switch ModuleA-10GE1/17/2] commit
    [~Switch ModuleA-10GE1/17/2] quit

  2. Create a VLAN on Switch ModuleA and Switch ModuleB, add the Eth-Trunk interface to the VLAN, and create a VLANIF interface to implement Layer 3 interworking between Switch ModuleA and Switch ModuleB through the VLANIF interface.

    # Configure Switch ModuleA. The configuration of Switch ModuleB is similar to the configuration of Switch ModuleA. See the configuration file for details.

    [~Switch ModuleA] vlan 100
    [*Switch ModuleA-vlan100] commit
    [~Switch ModuleA-vlan100] quit
    [~Switch ModuleA] interface Eth-Trunk 1
    [~Switch ModuleA-Eth-Trunk1] port link-type trunk
    [*Switch ModuleA-Eth-Trunk1] port trunk allow-pass vlan 100
    [*Switch ModuleA-Eth-Trunk1] commit
    [~Switch ModuleA-Eth-Trunk1] quit
    [~Switch ModuleA] interface vlanif 100
    [*Switch ModuleA-Vlanif100] ip address 100.1.1.5 24
    [*Switch ModuleA-Vlanif100] commit
    [~Switch ModuleA-Vlanif100] quit

  3. Configure a BFD for Perlink session on Switch ModuleA to monitor the Eth-Trunk member links between Switch ModuleA and Switch ModuleB.

    [~Switch ModuleA] bfd
    [*Switch ModuleA-bfd] quit
    [*Switch ModuleA] bfd atob bind peer-ip 100.1.1.6 interface vlanif 100 source-ip 100.1.1.5 per-link one-arm-echo
    [*Switch ModuleA-bfd-session-atob] commit
    [~Switch ModuleA-bfd-session-atob] quit

  4. Verify the configuration.

    After completing the configuration, run the display bfd session all verbose command on Switch ModuleA. The command output shows that three BFD sessions have been established and their statuses are Up. The discriminators of the three BFD sessions are dynamically allocated. The BFD session bound to VLANIF 100 is the management session, and the other two are BFD sub-sessions and bound to 10GE1/17/1 and 10GE1/17/2.

    <Switch ModuleA> display bfd session all verbose
    Total UP/DOWN Session Number : 3/0
    --------------------------------------------------------------------------------
      Name : atob                  (Single Hops)   State : Up
    --------------------------------------------------------------------------------
      Local Discriminator    : 16385            Remote Discriminator   : 16385
      Session Detect Mode    : Asynchronous Mode With Echo Function
      BFD Bind Type          : Interface(Vlanif100)  
      Bind Session Type      : Static_Auto(Bundle_Main) 
      Bind Peer IP Address   : 100.1.1.6        
      Bind Interface         : Vlanif100                                         
      Bind Source IP Address : 100.1.1.5   
      FSM Board ID           : -                ToS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000 
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000 
      Local Detect Multi     : 3                Active Multi           : 3  
      Destination Port       : 3784             TTL                    : 255 
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : AUTO   
      Session Description    : - 
    --------------------------------------------------------------------------------
    
    --------------------------------------------------------------------------------
      Name : dyn_16386             (Single Hops)   State : Up
    --------------------------------------------------------------------------------
      Local Discriminator    : 16386            Remote Discriminator   : 16386
      Session Detect Mode    : Asynchronous Mode With Echo Function
      BFD Bind Type          : Interface(10GE1/17/1)  
      Bind Session Type      : Dynamic(Bundle_Sub) 
      Bind Peer IP Address   : 100.1.1.6        
      Bind Interface         : 10GE1/17/1          
      Bind Source IP Address : 100.1.1.5   
      FSM Board ID           : 1                ToS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000
      Local Detect Multi     : 3                Active Multi           : 3 
      Destination Port       : 3784             TTL                    : 255 
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : BFD   
      Session Description    : - 
    --------------------------------------------------------------------------------
    
    --------------------------------------------------------------------------------
      Name : dyn_16387             (Single Hops)   State : Up
    --------------------------------------------------------------------------------
      Local Discriminator    : 16387            Remote Discriminator   : 16387
      Session Detect Mode    : Asynchronous Mode With Echo Function
      BFD Bind Type          : Interface(10GE1/17/2)  
      Bind Session Type      : Dynamic(Bundle_Sub) 
      Bind Peer IP Address   : 100.1.1.6        
      Bind Interface         : 10GE1/17/2           
      Bind Source IP Address : 100.1.1.5   
      FSM Board ID           : 1                ToS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000
      Process PST            : Disable          Config PST             : Disable    
      Local Detect Multi     : 3                Active Multi           : 3 
      Destination Port       : 3784             TTL                    : 255 
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : BFD   
      Session Description    : - 
    --------------------------------------------------------------------------------
    

    # Shut down 10GE1/17/1 on Switch ModuleA to simulate a link fault.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] shutdown
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit

    # Run the display bfd session all command on Switch ModuleA to view the statuses of the BFD sessions. The command output shows that the status of the BFD sub-session bound to 10GE1/17/1 is Down and that the statuses of the BFD sub-session bound to 10GE1/17/2 and the BFD management session bound to VLANIF 100 are still Up.

    <Switch ModuleA> display bfd session all
    S: Static session
    D: Dynamic session
    IP: IP session
    IF: Single-hop session
    PEER: Multi-hop session
    AUTO: Automatically negotiated session
    Total UP/DOWN Session Number : 2/1
    --------------------------------------------------------------------------------
    Local      Remote     PeerIpAddr      State     Type        InterfaceName 
    --------------------------------------------------------------------------------
    16385      16385      100.1.1.6       Up        S/AUTO-IF   Vlanif100
    16386      16386      100.1.1.6       Down      D/IP-IF     10GE1/17/1
    16387      16387      100.1.1.6       Up        D/IP-IF     10GE1/17/2
    --------------------------------------------------------------------------------

    # Shut down 10GE1/17/2, and run the display bfd session all command on Switch ModuleA. The command output shows that the statuses of the BFD sessions are all Down.

    <Switch ModuleA> display bfd session all
    S: Static session
    D: Dynamic session
    IP: IP session
    IF: Single-hop session
    PEER: Multi-hop session
    AUTO: Automatically negotiated session
    Total UP/DOWN Session Number : 0/3
    --------------------------------------------------------------------------------
    Local      Remote     PeerIpAddr      State     Type        InterfaceName 
    --------------------------------------------------------------------------------
    16385      16385      100.1.1.6       Down      S/AUTO-IF   Vlanif100
    16386      16386      100.1.1.6       Down      D/IP-IF     10GE1/17/1
    16387      16387      100.1.1.6       Down      D/IP-IF     10GE1/17/2
    --------------------------------------------------------------------------------

Configuration Files
  • Switch ModuleA configuration file

    #
    sysname Switch ModuleA
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ip address 100.1.1.5 255.255.255.0
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/17/1
     shutdown
     eth-trunk 1
    #
    interface 10GE1/17/2
     shutdown
     eth-trunk 1
    #
    bfd atob bind peer-ip 100.1.1.6 interface Vlanif100 source-ip 100.1.1.5 per-link one-arm-echo
    #
    return
  • Switch ModuleB configuration file

    #
    sysname Switch ModuleB
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 100.1.1.6 255.255.255.0
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/17/1
     eth-trunk 1
    #
    interface 10GE1/17/2
     eth-trunk 1
    #
    return

Example for Associating the BFD Session with the Interface Status

Networking Requirements

As shown in Figure 11-26, SwitchA is directly connected to SwitchB and Layer 2 transmission devices, SwitchC and SwitchD, are deployed between them. It is required that SwitchA and SwitchB fast detect link faults of the Layer 2 tranmission devices to trigger fast route convergence.

Figure 11-26 Associating the BFD session with the interface status
Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure BFD sessions on SwitchA and SwitchB to detect faults on the link between SwitchA and SwitchB.

  2. Configure association between the BFD session and interface status on SwitchA and SwitchB after the BFD session becomes Up.

Procedure

  1. Configure interfaces that connect the Switch ModuleA and Switch ModuleB to ensure transmission of packets at Layer 2.

    # Configure the Switch ModuleA.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan 10
    [*Switch ModuleA-vlan10] quit
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/1] undo port trunk allow-pass vlan 1
    [*Switch ModuleA-10GE1/17/1] port trunk pvid vlan 10
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit
    

    # Configure the interface on the Switch ModuleB. The configuration method is the same as that on the Switch ModuleA. See details in the configuration files.

  2. Configure single-hop BFD on Switch ModuleA.

    # Enable BFD on Switch ModuleA.

    [~Switch ModuleA] bfd
    [*Switch ModuleA-bfd] quit

    # Create a BFD session on Switch ModuleA.

    [*Switch ModuleA] bfd atob bind peer-ip default-ip interface 10ge 1/17/1
    [*Switch ModuleA-bfd-session-atob] discriminator local 1
    [*Switch ModuleA-bfd-session-atob] discriminator remote 2
    [*Switch ModuleA-bfd-session-atob] commit
    [~Switch ModuleA-bfd-session-atob] quit
    

  3. Configure single-hop BFD on Switch ModuleB.

    # Enable BFD on Switch ModuleB.

    [~Switch ModuleB] bfd
    [*Switch ModuleB-bfd] quit

    # Create a BFD session on Switch ModuleB.

    [*Switch ModuleB] bfd btoa bind peer-ip default-ip interface 10ge 1/17/1
    [*Switch ModuleB-bfd-session-btoa] discriminator local 2
    [*Switch ModuleB-bfd-session-btoa] discriminator remote 1
    [*Switch ModuleB-bfd-session-btoa] commit
    [~Switch ModuleB-bfd-session-btoa] quit

  4. Configuring association between BFD session status and interface status.

    # Configure association between the BFD session status and the interface status on Switch ModuleA.

    [~SwitchA] bfd atob
    [~SwitchA-bfd-session-atob] process-interface-status
    [*SwitchA-bfd-session-atob] commit
    [~SwitchA-bfd-session-atob] quit

    # Configure association between the BFD session status and the interface status on Switch ModuleB.

    [~SwitchB] bfd btoa
    [~SwitchB-bfd-session-btoa] process-interface-status
    [*SwitchB-bfd-session-btoa] commit
    [~SwitchB-bfd-session-btoa] quit

  5. Verify the configuration.

    After the configuration is complete, run the display bfd session all verbose command on Switch ModuleA and Switch ModuleB. You can see that the BFD session status is Up and the Bind Application field is IFNET.

    The display on Switch ModuleA is used as an example.

    <Switch ModuleA> display bfd session all verbose
    Total UP/DOWN Session Number : 1/0
    --------------------------------------------------------------------------------
      Name : atob                  (Single Hops)   State : Up                
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2          
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(10GE1/17/1)                                 
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 224.0.0.184                                          
      Bind Interface         : 10GE1/17/1                                            
      FSM Board ID           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000       
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000       
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : IFNET                                         
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    

    # Run the shutdown command on 10GE1/17/1 of Switch ModuleB to make the BFD session go Down.

    [~Switch ModuleB] interface 10ge 1/17/1
    [~Switch ModuleB-10GE1/17/1] shutdown
    [*Switch ModuleB-10GE1/17/1] commit
    [~Switch ModuleB-10GE1/17/1] quit

    # Run the display bfd session all verbose and display interface 10ge 1/17/1 commands on Switch ModuleA. You can see that the BFD session status is Down, and the status of 10GE1/17/1 is DOWN (BFD status down).

    <Switch ModuleA> display bfd session all verbose
    Total UP/DOWN Session Number : 0/1
    --------------------------------------------------------------------------------
      Name : atob                  (Single Hops)   State : Down             
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2          
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(10GE1/17/1)                                 
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 224.0.0.184                                          
      Bind Interface         : 10GE1/17/1                                            
      FSM Board ID           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 4331             Actual Rx Interval (ms): 4331       
      WTR Interval (ms)      : -                Detect Interval (ms)   : -          
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : IFNET                                  
      Session Not Up Reason  : In negotiation                                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    
    <Switch ModuleA> display interface 10ge 1/17/1
    10GE1/17/1 current state : UP (ifindex: 11)                                      
    Line protocol current state : DOWN (BFD status down)
    ……

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10
    #
     bfd
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 10
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
    #
    bfd atob bind peer-ip default-ip interface 10GE1/17/1
     discriminator local 1
     discriminator remote 2
     process-interface-status
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 10
    #
     bfd
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 10
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
    #
    bfd btoa bind peer-ip default-ip interface 10GE1/17/1
     discriminator local 2
     discriminator remote 1
     process-interface-status
    #
    return

Example for Configuring Single-Hop BFD for IPv6

Networking Requirements

As shown in Figure 11-27, Switch ModuleA connects to Switch ModuleB through the VLANIF interface. Faults on the link between Switch ModuleA and Switch ModuleB need to be fast detected.

Figure 11-27 Networking diagram for configuring single-hop BFD for IPv6
Configuration Roadmap

The configuration roadmap is as follows:

Configure BFD sessions on Switch ModuleA and Switch ModuleB.

Procedure

  1. On Switch ModuleA and Switch ModuleB, create VLANs and add 10GE1/17/1 interfaces to VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 100
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 100
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit

    The configuration of Switch ModuleB is similar to the configuration of Switch ModuleA. See the configuration file for details.

  2. Configure IPv6 addresses for VLANIF interfaces so that Switch ModuleA and Switch ModuleB can communicate at Layer 3.

    [~Switch ModuleA] interface vlanif 100
    [~Switch ModuleA-Vlanif100] ipv6 enable
    [*Switch ModuleA-Vlanif100] ipv6 address 2000::1 64
    [*Switch ModuleA-Vlanif100] commit
    [~Switch ModuleA-Vlanif100] quit

    The configuration of Switch ModuleB is similar to the configuration of Switch ModuleA. See the configuration file for details.

  3. Configure single-hop BFD.

    # Enable BFD and create a BFD session on Switch ModuleA.

    [~Switch ModuleA] bfd
    [*Switch ModuleA-bfd] quit
    [*Switch ModuleA] bfd atob bind peer-ipv6 2000::2 interface vlanif 100
    [*Switch ModuleA-bfd-session-atob] discriminator local 1
    [*Switch ModuleA-bfd-session-atob] discriminator remote 2
    [*Switch ModuleA-bfd-session-atob] commit
    [~Switch ModuleA-bfd-session-atob] quit
    

    # Enable BFD and create a BFD session on Switch ModuleB.

    [~Switch ModuleB] bfd
    [*Switch ModuleB-bfd] quit
    [*Switch ModuleB] bfd btoa bind peer-ipv6 2000::1 interface vlanif 100
    [*Switch ModuleB-bfd-session-btoa] discriminator local 2
    [*Switch ModuleB-bfd-session-btoa] discriminator remote 1
    [*Switch ModuleB-bfd-session-btoa] commit
    [~Switch ModuleB-bfd-session-btoa] quit
    

  4. Verify the configuration.

    After the configuration is complete, run the display bfd session all verbose command on Switch ModuleA and Switch ModuleB. You can see that a single-hop BFD session is set up and its status is Up. The display on Switch ModuleA is used as an example.

    <SwitchA> display bfd session all verbose
    Total UP/DOWN Session Number : 1/0
    --------------------------------------------------------------------------------
      Name : atob                    (Single Hops)   State : Up
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Interface(Vlanif100)  
      Bind Session Type      : Static 
      Bind Peer IP Address   : 2000::2         
      Bind Interface         : Vlanif100
      FSM Board Id           : 1                ToS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000       
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000       
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : No Application Bind                                  
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    

    # Run the shutdown command on the 10GE1/17/1 interface of Switch ModuleA to simulate a link fault.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] shutdown
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit

    After the configuration is complete, run the display bfd session all verbose command on Switch ModuleA and Switch ModuleB. You can see that a single-hop BFD session is set up and its status is Down. Take the display on Switch ModuleA as an example.

    <SwitchA> display bfd session all verbose
    Total UP/DOWN Session Number : 0/1
    --------------------------------------------------------------------------------
      Name : atob                    (Single Hops)   State : Down
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Interface(Vlanif100)  
      Bind Session Type      : Static 
      Bind Peer IP Address   : 2000::2         
      Bind Interface         : Vlanif100
      FSM Board Id           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 10093            Actual Rx Interval (ms): 10093      
      WTR Interval (ms)      : -                Detect Interval (ms)   : -          
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : No Application Bind                                  
      Session Not Up Reason  : In negotiation                                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname SwitchA
    #
    vlan batch 100
    #
     bfd
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address 2000::1/64
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    bfd atob bind peer-ipv6 2000::2 interface Vlanif100
     discriminator local 1
     discriminator remote 2
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname SwitchB
    #
    vlan batch 100
    #
     bfd
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address 2000::2/64
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    bfd btoa bind peer-ipv6 2000::1 interface Vlanif100
     discriminator local 2
     discriminator remote 1
    #
    return

Example for Configuring Multi-Hop BFD for IPv6

Networking Requirements

As shown in Figure 11-28, Switch ModuleA is indirectly connected to Switch ModuleC and Layer 2 transmission devices, SwitchD and SwitchE, are deployed between them. Static routes are configured so that Switch ModuleA can communicate with Switch ModuleC. Faults on the link between Switch ModuleA and Switch ModuleC need to be fast detected.

Figure 11-28 Networking diagram for configuring multi-hop BFD for IPv6
Configuration Roadmap

The configuration roadmap is as follows:

Configure BFD sessions on Switch ModuleA and Switch ModuleC to detect the multi-hop route.

Procedure

  1. Add interfaces to VLANs, create VLANIF interfaces, and assign IP addresses to VLANIF interfaces. The configuration details are not mentioned here.
  2. Configure a reachable IPv6 static route between Switch ModuleA and Switch ModuleC.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~Switch ModuleA] ipv6 route-static 2002:: 64 2001::2
    [*Switch ModuleA] commit

    The configuration of Switch ModuleC is similar to the configuration of Switch ModuleA. See details in the configuration file.

  3. Configure multi-hop BFD.

    # Create a BFD session between Switch ModuleA and Switch ModuleC.

    [~Switch ModuleA] bfd
    [*Switch ModuleA-bfd] quit
    [*Switch ModuleA] bfd atoc bind peer-ipv6 2002::1
    [*Switch ModuleA-bfd-session-atoc] discriminator local 10
    [*Switch ModuleA-bfd-session-atoc] discriminator remote 20
    [*Switch ModuleA-bfd-session-atoc] commit
    [~Switch ModuleA-bfd-session-atoc] quit

    # Create a BFD session between Switch ModuleC and Switch ModuleA.

    [~Switch ModuleC] bfd
    [*Switch ModuleC-bfd] quit
    [*Switch ModuleC] bfd ctoa bind peer-ipv6 2001::1
    [*Switch ModuleC-bfd-session-ctoa] discriminator local 20
    [*Switch ModuleC-bfd-session-ctoa] discriminator remote 10
    [*Switch ModuleC-bfd-session-ctoa] commit
    [~Switch ModuleC-bfd-session-ctoa] quit

  4. Verify the configuration.

    After the configuration, run the display bfd session verbose command on Switch ModuleA and Switch ModuleC. You can see that a BFD session is set up and is in Up state. Take the display on Switch ModuleA as an example.

    <Switch ModuleA> display bfd session all verbose
    Total UP/DOWN Session Number : 1/0
    --------------------------------------------------------------------------------
      Name : atoc                  (Multiple Hops) State : Up
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Peer IP Address                                      
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 2002::1                                              
      Bind Interface         : -                                                    
      FSM Board Id           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000       
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000       
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 4784             TTL                    : 254        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : No Application Bind                                  
      Session Description    : -                                                    
    ---------------------------------------------------------------
    

    # Run the shutdown command on the 10GE1/17/1 interface of Switch ModuleA to simulate a link fault.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] shutdown
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit

    After the configuration, run the display bfd session all verbose command on Switch ModuleA and Switch ModuleB. You can see that a multi-hop BFD session is set up and the status is Down. Take the display on Switch ModuleA as an example.

    <Switch ModuleA> display bfd session all verbose
    Total UP/DOWN Session Number : 0/1
    --------------------------------------------------------------------------------
      Name : atoc                  (Multiple Hops) State : Down
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Peer IP Address                                      
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 2002::1                                             
      Bind Interface         : -                                                    
      FSM Board Id           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 6761             Actual Rx Interval (ms): 6761       
      WTR Interval (ms)      : -                Detect Interval (ms)   : -          
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 4784             TTL                    : 254        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : No Application Bind                                  
      Session Not Up Reason  : In negotiation                                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10
    #
     bfd
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 2001::1/64
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10
    #
    bfd atoc bind peer-ip 2002::1
     discriminator local 10
     discriminator remote 20
    #
     ipv6 route-static 2002:: 64 2001::2
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 2001::2 64
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 2002::2 64
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10
    #
    interface 10GE2/17/1
     port link-type trunk
     port trunk pvid vlan 20
     port trunk allow-pass vlan 20
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
     bfd
    #
     vlan batch 20
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 2002::1 64
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 20
     port trunk allow-pass vlan 20
    #
    bfd ctoa bind peer-ipv6 2001::1
     discriminator local 20
     discriminator remote 10
    #
     ipv6 route-static 2001:: 64 2002::2
    #
    return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 57261

Downloads: 3617

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next