No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides several configuration examples of link aggregation.

Example for Configuring Link Aggregation in Manual Load Balancing Mode

Networking Requirements

As shown in Figure 5-33, Switch ModuleA and Switch ModuleB connect to devices in VLAN 10 and VLAN 20 through Ethernet links, and heavy traffic is transmitted between Switch ModuleA and Switch ModuleB.

Switch ModuleA and Switch ModuleB can provide higher link bandwidth to implement inter-VLAN communication. Reliability of data transmission needs to be ensured.

Figure 5-33 Networking diagram for configuring link aggregation in manual load balancing mode
Configuration Roadmap

The configuration roadmap is as follows:

  1. Create an Eth-Trunk and add member interfaces to the Eth-Trunk to increase link bandwidth.

    NOTE:
    An interface is added to VLAN1 by default. To avoid broadcast strom, shut down the interface or remove the interface from VLAN1 before adding it to an Eth-Trunk interface.
  2. Create VLANs and add interfaces to the VLANs.

  3. Set the load balancing mode to ensure that traffic is load balanced between member interfaces of the Eth-Trunk.

Procedure

  1. Create an Eth-Trunk on SwitchA and SwitchB, and add member interfaces to the Eth-Trunk.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] interface eth-trunk 1
    [*Switch ModuleA-Eth-Trunk1] trunkport 10ge 1/17/1 to 1/17/3
    [*Switch ModuleA-Eth-Trunk1] commit
    [~Switch ModuleA-Eth-Trunk1] quit
    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleB
    [*HUAWEI] commit
    [~Switch ModuleB] interface eth-trunk 1
    [*Switch ModuleB-Eth-Trunk1] trunkport 10ge 1/17/1 to 1/17/3
    [*Switch ModuleB-Eth-Trunk1] commit
    [~Switch ModuleB-Eth-Trunk1] quit

  2. Create VLANs and add interfaces to the VLANs.

    # Create VLAN 10 and VLAN 20, and add interfaces to VLAN 10 and VLAN 20. The configuration of SwitchB is similar to the configuration of SwitchA, and the configuration details are not mentioned here.

    [~Switch ModuleA] vlan batch 10 20
    [*Switch ModuleA] interface 10ge 1/17/4
    [*Switch ModuleA-10GE1/17/4] port link-type trunk
    [*Switch ModuleA-10GE1/17/4] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/4] quit
    [*Switch ModuleA] interface 10ge 1/17/5
    [*Switch ModuleA-10GE1/17/5] port link-type trunk
    [*Switch ModuleA-10GE1/17/5] port trunk allow-pass vlan 20
    [*Switch ModuleA-10GE1/17/5] quit
    [*Switch ModuleA] commit

    # Configure Eth-Trunk 1 to allow packets from VLAN 10 and VLAN 20 to pass through. The configuration of SwitchB is similar to the configuration of SwitchA, and the configuration details are not mentioned here.

    [~Switch ModuleA] interface eth-trunk 1
    [~Switch ModuleA-Eth-Trunk1] port link-type trunk
    [*Switch ModuleA-Eth-Trunk1] port trunk allow-pass vlan 10 20
    [*Switch ModuleA-Eth-Trunk1] commit
    [~Switch ModuleA-Eth-Trunk1] quit

  3. Set the load balancing mode of Eth-Trunk 1. The configuration of SwitchB is similar to the configuration of SwitchA, and the configuration details are not mentioned here.

    [~Switch ModuleA] interface eth-trunk 1
    [~Switch ModuleA-Eth-Trunk1] load-balance src-dst-mac
    [*Switch ModuleA-Eth-Trunk1] commit
    [~Switch ModuleA-Eth-Trunk1] quit
    

  4. Verify the configuration.

    Run the display eth-trunk 1 command in any view to check whether the Eth-Trunk is created and whether member interfaces are added.

    [~Switch ModuleA] display eth-trunk 1
    Eth-Trunk1's state information is: 
    Working Mode: Normal           Hash Arithmetic: src-dst-mac
    Least Active-linknumber: 1     Max Bandwidth-affected-linknumber: 16
    Operating Status: up           Number of Up Ports in Trunk: 3
    --------------------------------------------------------------------------------
    PortName                Status       Weight
    10GE1/17/1               Up           1
    10GE1/17/2               Up           1
    10GE1/17/3               Up           1
    

    The preceding command output shows that Eth-Trunk 1 has three member interfaces: 10GE1/17/1, 10GE1/17/2, and 10GE1/17/3. The member interfaces are both in Up state.

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 20
    #
    interface Eth-Trunk1
     port link-type trunk 
     port trunk allow-pass vlan 10 20
     load-balance src-dst-mac 
    # 
    interface 10GE1/17/1 
     eth-trunk 1
    # 
    interface 10GE1/17/2 
     eth-trunk 1
    # 
    interface 10GE1/17/3 
     eth-trunk 1
    #
    interface 10GE1/17/4 
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/5 
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 10 20
    #
    interface Eth-Trunk1
     port link-type trunk 
     port trunk allow-pass vlan 10 20
     load-balance src-dst-mac 
    # 
    interface 10GE1/17/1 
     eth-trunk 1
    # 
    interface 10GE1/17/2 
     eth-trunk 1
    # 
    interface 10GE1/17/3 
     eth-trunk 1
    #
    interface 10GE1/17/4 
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/5 
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return

Example for Configuring Link Aggregation in LACP Mode

Networking Requirements

To improve bandwidth and connection reliability, configure a link aggregation group on two directly connected Switch Modulees, as shown in Figure 5-34. The requirements are as follows:

  • Two active links implement load balancing.

  • One link function as the backup link. When a fault occurs on an active link, the backup link replaces the faulty link to maintain reliable data transmission.

Figure 5-34 Networking diagram for configuring link aggregation in LACP mode
Configuration Roadmap

The configuration roadmap is as follows:

  1. Create an Eth-Trunk and configure the Eth-Trunk to work in LACP mode to implement link aggregation.

  2. Add member interfaces to the Eth-Trunk.

    NOTE:
    An interface is added to VLAN1 by default. To avoid broadcast strom, shut down the interface or remove the interface from VLAN1 before adding it to an Eth-Trunk interface.
  3. Set the system priority and determine the Actor so that the Partner selects active interfaces based on the Actor interface priority.

  4. Set the upper threshold for the number of active interfaces to improve reliability.

  5. Set interface priorities and determine active interfaces so that interfaces with higher priorities are selected as active interfaces.

Procedure

  1. Create Eth-Trunk 1 on Switch ModuleA and configure Eth-Trunk 1 to work in LACP mode. The configuration of Switch ModuleB is similar to the configuration of Switch ModuleA, and the configuration details are not mentioned here.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] interface eth-trunk 1
    [*Switch ModuleA-Eth-Trunk1] mode lacp-static
    [*Switch ModuleA-Eth-Trunk1] commit
    [~Switch ModuleA-Eth-Trunk1] quit

  2. Add member interfaces to Eth-Trunk 1 on Switch ModuleA. The configuration of Switch ModuleB is similar to the configuration of Switch ModuleA, and the configuration details are not mentioned here.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] eth-trunk 1
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] eth-trunk 1
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] interface 10ge 1/17/3
    [*Switch ModuleA-10GE1/17/3] eth-trunk 1
    [*Switch ModuleA-10GE1/17/3] quit
    [*Switch ModuleA] commit
    

  3. Set the system priority on Switch ModuleA to 100 so that Switch ModuleA becomes the Actor.

    [~Switch ModuleA] lacp priority 100
    [*Switch ModuleA] commit
    

  4. On Switch ModuleA, set the upper threshold for the number of active interfaces to 2.

    [~Switch ModuleA] interface eth-trunk 1
    [~Switch ModuleA-Eth-Trunk1] lacp max active-linknumber 2
    [*Switch ModuleA-Eth-Trunk1] commit
    [~Switch ModuleA-Eth-Trunk1] quit

  5. Set the priority of the interface and determine active links on Switch ModuleA.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] lacp priority 100
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] lacp priority 100
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] commit
    

  6. Verify the configuration.

    # Check information about the Eth-Trunk of the Switch Modules and check whether negotiation is successful on the link.

    [~Switch ModuleA] display eth-trunk 1
    Eth-Trunk1's state information is:                                                                                                 
    Local:                                                                                                                              
    LAG ID: 1                       Working Mode: Static                                                                                 
    Preempt Delay: Disabled         Hash Arithmetic: profile default                                                                    
    System Priority: 100            System ID: 0025-9e95-7c31                                                                           
    Least Active-linknumber: 1      Max Active-linknumber: 2                                                                            
    Operating Status: up            Number Of Up Ports In Trunk: 2
    Timeout Period: Slow
    --------------------------------------------------------------------------------                                                    
    ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight                                                    
    10GE1/17/1              Selected 10GE     100     1      20289   10111100  1                                                         
    10GE1/17/2              Selected 10GE     100     2      20289   10111100  1                                                         
    10GE1/17/3              Unselect 10GE     32768   3      20289   10100000  1                                                         
                                                                                                                                        
    Partner:                                                                                                                            
    --------------------------------------------------------------------------------                                                    
    ActorPortName          SysPri   SystemID        PortPri PortNo PortKey PortState                                                    
    10GE1/17/1              32768    0025-9e95-7c11  32768   4      20289   10111100                                                     
    10GE1/17/2              32768    0025-9e95-7c11  32768   5      20289   10111100                                                     
    10GE1/17/3              32768    0025-9e95-7c11  32768   6      20289   10100000
    [~Switch ModuleB] display eth-trunk 1
    Eth-Trunk1's state information is:                                                                                                 
    Local:                                                                                                                              
    LAG ID: 1                       Working Mode: Static                                                                                 
    Preempt Delay: Disabled         Hash Arithmetic: profile default                                                                    
    System Priority: 32768          System ID: 0025-9e95-7c11                                                                           
    Least Active-linknumber: 1      Max Active-linknumber: 16                                                                           
    Operating Status: up            Number Of Up Ports In Trunk: 2
    Timeout Period: Slow
    --------------------------------------------------------------------------------                                                    
    ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight                                                    
    10GE1/17/1              Selected 10GE     32768   4      20289   10111100  1                                                         
    10GE1/17/2              Selected 10GE     32768   5      20289   10111100  1                                                         
    10GE1/17/3              Unselect 10GE     32768   6      20289   10100000  1                                                         
                                                                                                                                        
    Partner:                                                                                                                            
    --------------------------------------------------------------------------------                                                    
    ActorPortName          SysPri   SystemID        PortPri PortNo PortKey PortState                                                    
    10GE1/17/1              100      0025-9e95-7c31  100     1      20289   10111100                                                     
    10GE1/17/2              100      0025-9e95-7c31  100     2      20289   10111100                                                     
    10GE1/17/3              100      0025-9e95-7c31  32768   3      20289   10100000                                                     
    

    The preceding information shows that the system priority of Switch ModuleA is 100, which is higher than the system priority of Switch ModuleB. Member interfaces 10GE1/17/1 and 10GE1/17/2 become the active interfaces and are in Selected state. Interface 10GE1/17/3 is in Unselect state. Two links are active and working in load balancing mode, and one link is the backup links.

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    lacp priority 100
    #
    interface Eth-Trunk1
     mode lacp-static
     lacp max active-linknumber 2
    #
    interface 10GE1/17/1
     eth-trunk 1
     lacp priority 100
    #
    interface 10GE1/17/2
     eth-trunk 1
     lacp priority 100
    #
    interface 10GE1/17/3
     eth-trunk 1
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    interface Eth-Trunk1
     mode lacp-static
    #
    interface 10GE1/17/1
     eth-trunk 1
    #
    interface 10GE1/17/2
     eth-trunk 1
    #
    interface 10GE1/17/3
     eth-trunk 1
    #
    return

Example for Configuring an Eth-Trunk Interface to Work in Dynamic LACP Mode

Networking Requirements

As shown in Figure 5-35, ServerA is directly connected to SwitchA through an static LACP-enabled Eth-Trunk interface. The file ServerB connecting to SwitchA stores ServerA's network adapter configurations. After ServerA is restarted, its configurations are lost and must be obtained from the remote file ServerB. In this situation, because ServerA has lost its Eth-Trunk configurations, LACP negotiation between SwitchA and ServerA fails. In addition, SwitchA's Eth-Trunk interface cannot go Up and therefore is unable to forward data.

You can configure the Eth-Trunk interface on SwitchA to work in dynamic LACP mode. When LACP negotiation fails, SwitchA can forward packets at Layer 2 through member interfaces. Therefore, ServerA can successfully obtain the configuration from ServerB. After ServerA obtains the configuration, an Eth-Trunk in LACP mode is established. Devices at both ends of the Eth-Trunk send LACPDUs for negotiation.

Figure 5-35 Networking diagram for an Eth-Trunk interface working in dynamic LACP mode

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the Eth-Trunk interface on SwitchA to work in dynamic LACP mode, and add Ethernet physical interfaces to the Eth-Trunk interface to implement link aggregation.

  2. Set the upper threshold for the number of active interfaces to improve reliability.

  3. Set interface priorities and determine active interfaces so that interfaces with higher priorities are selected as active interfaces.

Procedure

  1. Configure the Eth-Trunk interface on SwitchA to work in dynamic LACP mode and add Ethernet physical interfaces to the Eth-Trunk interface.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~Switch ModuleA] interface eth-trunk 1
    [*Switch ModuleA-Eth-Trunk1] mode lacp-dynamic
    [*Switch ModuleA-Eth-Trunk1] quit
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] eth-trunk 1
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] eth-trunk 1
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] interface 10ge 1/17/3
    [*Switch ModuleA-10GE1/17/3] eth-trunk 1
    [*Switch ModuleA-10GE1/17/3] quit
    [*Switch ModuleA] commit

  2. On SwitchA, set the upper threshold for the number of active interfaces to 2.

    [~Switch ModuleA] interface eth-trunk 1
    [~Switch ModuleA-Eth-Trunk1] lacp max active-linknumber 2
    [*Switch ModuleA-Eth-Trunk1] quit
    [*Switch ModuleA] commit

  3. Set the priority of the interface and determine active links on Switch ModuleA.

    [~Switch ModuleA] interface 10ge 1/17/1
    [~Switch ModuleA-10GE1/17/1] lacp priority 100
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] lacp priority 100
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] commit

  4. Verify the configuration.

    # Run the display eth-trunk command on SwitchA to view information about the Eth-Trunk interface. The command output shows Eth-Trunk state information, such as Eth-Trunk ID (1) and working mode (dynamic LACP mode). 10GE1/17/1, 10GE1/17/2, and 10GE1/17/3 are in Indep state.

    [~Switch ModuleA] display eth-trunk 1
    Eth-Trunk1's state information is:                                                                                                  
    Local:                                                                                                                              
    LAG ID: 1                       Working Mode: Dynamic                                                                               
    Preempt Delay: Disabled         Hash Arithmetic: profile default                                                                    
    System Priority: 32768          System ID: 0025-9e95-7c11                                                                           
    Least Active-linknumber: 1      Max Active-linknumber: 2                                                                            
    Operating Status: up          Number Of Up Ports In Trunk: 0                                                                      
    Timeout Period: Slow
    --------------------------------------------------------------------------------                                                    
    ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight                                                    
    10GE1/17/1              Indep    10GE     100     0      321     10100010  1                                                         
    10GE1/17/2              Indep    10GE     100     1      321     10100010  1                                                         
    10GE1/17/3              Indep    10GE     32768   2      321     10100010  1                                                         
                                                                                                                                        
    Partner:                                                                                                                            
    --------------------------------------------------------------------------------                                                    
    ActorPortName          SysPri   SystemID        PortPri PortNo PortKey PortState                                                    
    10GE1/17/1              0        0000-0000-0000  0       0      0       10100011                                                     
    10GE1/17/2              0        0000-0000-0000  0       0      0       10100011                                                     
    10GE1/17/3              0        0000-0000-0000  0       0      0       10100011

    # After SwitchA receives LACPDUs from ServerA and link aggregation negotiation between SwitchA and ServerA succeeds, run the display eth-trunk command on SwitchA to view information about the Eth-Trunk interface. The command output shows Eth-Trunk state information, such as Eth-Trunk ID (1) and working mode (dynamic LACP mode). 10GE1/17/1 and 10GE1/17/2 are active interfaces and in Selected state, and 10GE1/17/3 is in Unselect state.

    [~Switch ModuleA] display eth-trunk 1
    Eth-Trunk1's state information is:                                                                                                  
    Local:                                                                                                                              
    LAG ID: 1                       Working Mode: Dynamic                                                                               
    Preempt Delay: Disabled:        Hash Arithmetic: profile default                                                                    
    System Priority: 32768          System ID: 0025-9e95-7c11                                                                           
    Least Active-linknumber: 1      Max Active-linknumber: 2                                                                            
    Operating Status: up            Number Of Up Ports In Trunk: 2                                                                      
    Timeout Period: Slow
    --------------------------------------------------------------------------------                                                    
    ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight                                                    
    10GE1/17/1              Selected 10GE     100     0      321     10111100  1                                                         
    10GE1/17/2              Selected 10GE     100     1      321     10111100  1                                                         
    10GE1/17/3              Unselect 10GE     32768   2      321     10100000  1                                                         
                                                                                                                                        
    Partner:                                                                                                                            
    --------------------------------------------------------------------------------                                                    
    ActorPortName          SysPri   SystemID        PortPri PortNo PortKey PortState                                                    
    10GE1/17/1              32768    0025-9e95-7c31  32768   0      321     10111100                                                     
    10GE1/17/2              32768    0025-9e95-7c31  32768   1      321     10111100                                                     
    10GE1/17/3              32768    0025-9e95-7c31  32768   2      321     10100000

Configuration Files

Configuration file of Switch ModuleA

#
sysname Switch ModuleA
#
interface Eth-Trunk1
 mode lacp-dynamic
 lacp max active-linknumber 2
#
interface 10GE1/17/1
 eth-trunk 1
 lacp priority 100
#
interface 10GE1/17/2
 eth-trunk 1
 lacp priority 100
#
interface 10GE1/17/3
 eth-trunk 1
#
return

Example for Configuring an Inter-Chassis Eth-Trunk Interface to Forward Traffic Preferentially Through Local Member Interfaces

Networking Requirements

As shown in Figure 5-36, SwitchB and SwitchC are connected through stack cables to increase the total capacity of devices. The two switches functions as a logical switch. SwitchB functions as the master switch and SwitchC functions as the backup switch.

To implement backup between devices and improve reliability, physical interfaces on the two switches are added to an Eth-Trunk. When the network runs properly, check member interface information on SwitchA. Traffic from VLAN 2 is forwarded through 10GE1/17/1 and 10GE1/17/2, and traffic from VLAN 3 is forwarded through 10GE1/17/1 and 10GE1/17/2. This increases bandwidth use efficiency between devices and reduces traffic forwarding efficiency.

To ensure that traffic from VLAN 2 is forwarded through 10GE1/17/1 and traffic from VLAN 3 is forwarded through 10GE1/17/2, you can configure the Eth-Trunk to preferentially forward local interface traffic.

Figure 5-36 Preferentially forwarding local interface traffic
Configuration Roadmap

The configuration roadmap is as follows:

  1. Create an Eth-Trunk to implement link aggregation.

  2. Add member interfaces to the Eth-Trunk.

  3. Enable the Eth-Trunk to preferentially forward local interface traffic so that traffic is forwarded by member interfaces on the local device.

  4. Configure Layer 2 forwarding to implement Layer 2 connectivity.

Procedure

  1. Create an Eth-Trunk interface and specify the allowed VLANs.

    # Configure the stack. In this example, SwitchB is the master switch.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 2 3
    [*SwitchB] interface eth-trunk 1
    [*SwitchB-Eth-Trunk1] port link-type trunk 
    [*SwitchB-Eth-Trunk1] port trunk allow-pass vlan 2 3
    [*SwitchB-Eth-Trunk1] commit
    [~SwitchB-Eth-Trunk1] quit

    # Configure SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 2 3
    [*SwitchA] interface eth-trunk 1
    [*SwitchA-Eth-Trunk1] port link-type trunk
    [*SwitchA-Eth-Trunk1] port trunk allow-pass vlan 2 3
    [*SwitchA-Eth-Trunk1] commit
    [~SwitchA-Eth-Trunk1] quit

  2. Add member interfaces to the Eth-Trunk.

    # Configure the stack.

    [~SwitchB] interface 10GE 1/17/1
    [~SwitchB-10GE1/17/1] eth-trunk 1
    [*SwitchB-10GE1/17/1] quit
    [*SwitchB] interface 10GE 2/17/1
    [*SwitchB-10GE2/17/1] eth-trunk 1
    [*SwitchB-10GE2/17/1] quit
    [*SwitchB] commit

    # Configure SwitchA.

    [~SwitchA] interface 10GE 1/17/1
    [~SwitchA-10GE1/17/1] eth-trunk 1
    [*SwitchA-10GE1/17/1] quit
    [*SwitchA] interface 10GE 1/17/2
    [*SwitchA-10GE1/17/2] eth-trunk 1
    [*SwitchA-10GE1/17/2] quit
    [*SwitchA] commit

  3. In the stack, configure the Eth-Trunk to preferentially forward local interface traffic.

    [~SwitchB] interface eth-trunk 1
    [~SwitchB-Eth-Trunk1] undo local-preference disable
    [*SwitchB-Eth-Trunk1] commit
    [~SwitchB-Eth-Trunk1] quit

  4. Configure Layer 2 forwarding.

    # Configure the stack.

    [~SwitchB] interface 10GE 1/17/2
    [~SwitchB-10GE1/17/2] port link-type trunk
    [*SwitchB-10GE1/17/2] port trunk allow-pass vlan 2
    [*SwitchB-10GE1/17/2] quit
    [*SwitchB] interface 10GE 2/17/2
    [*SwitchB-10GE2/17/2] port link-type trunk
    [*SwitchB-10GE2/17/2] port trunk allow-pass vlan 3
    [*SwitchB-10GE2/17/2] quit
    [*SwitchB] commit

    # Configure SwitchD.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchD
    [*HUAWEI] commit
    [~SwitchD] vlan 2
    [*SwitchD-vlan2] quit
    [*SwitchD] interface 10GE 1/17/1
    [*SwitchD-10GE1/17/1] port link-type trunk
    [*SwitchD-10GE1/17/1] port trunk allow-pass vlan 2
    [*SwitchD-10GE1/17/1] quit
    [*SwitchD] interface 10GE 1/17/2
    [*SwitchD-10GE1/17/2] port link-type trunk
    [*SwitchD-10GE1/17/2] port trunk allow-pass vlan 2
    [*SwitchD-10GE1/17/2] quit
    [*SwitchD] commit

    # Configure SwitchE.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchE
    [*HUAWEI] commit
    [~SwitchE] vlan 3
    [*SwitchE-vlan3] quit
    [*SwitchE] interface 10GE 1/17/1
    [*SwitchE-10GE1/17/1] port link-type trunk
    [*SwitchE-10GE1/17/1] port trunk allow-pass vlan 3
    [*SwitchE-10GE1/17/1] quit
    [*SwitchE] interface 10GE 1/17/2
    [*SwitchE-10GE1/17/2] port link-type trunk
    [*SwitchE-10GE1/17/2] port trunk allow-pass vlan 3
    [*SwitchE-10GE1/17/2] quit
    [*SwitchE] commit

  5. Verify the configuration.

    After the configuration is complete, run the display eth-trunk membership command in any view. You can view information about member interfaces of the Eth-Trunk.

    Use the display on the stack device as an example.

    [~SwitchB] display eth-trunk membership 1
    Trunk ID: 1
    Used Status: Valid
    Type: Ethernet
    Working Mode: Normal
    Number Of Ports in Trunk: 2                                                                                                         
    Number Of Up Ports in Trunk: 2
    Operating Status: up
    
    Interface 10GE1/17/1, valid, operate up, weight=1,
    Interface 10GE2/17/1, valid, operate up, weight=1,
    

Configuration Files
  • Configuration file of the stack

    #
    sysname SwitchB
    #
    vlan batch 2 to 3
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    interface 10GE1/17/1
     eth-trunk 1
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    interface 10GE2/17/1
     eth-trunk 1
    #
    interface 10GE2/17/2
     port link-type trunk
     port trunk allow-pass vlan 3
    #
    return
  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 2 to 3
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    interface 10GE1/17/1
     eth-trunk 1
    #
    interface 10GE1/17/2
     eth-trunk 1
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    vlan batch 2
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    return
  • Configuration file of SwitchE

    #
    sysname SwitchE
    #
    vlan batch 3
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 3
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 3
    #
    return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 59657

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next