No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section describes IS-IS configuration examples, including networking requirements, configuration roadmap, and configuration procedure.

Example for Configuring Basic IS-IS Functions

Networking Requirements

As shown in Figure 7-84, there are four devices (SwitchA, SwitchB, SwitchC, and SwitchD) on the network. The four devices need to communicate with each other. SwitchA and SwitchB can only process a small amount of data because they have lower performance than the other two devices.

Figure 7-84 Networking diagram of configuring basic IS-IS functions

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable IS-IS on each device so that the devices can be interconnected. Configure SwitchA and SwitchB as Level-1 devices to enable them to maintain less data.

Procedure

  1. Configure VLANs that each interface belongs to.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan 10
    [*Switch ModuleA-vlan10] quit
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/1] commit
    [~Switch ModuleA-10GE1/17/1] quit
    

    The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here.

  2. Assign the IP addresses for VLANIF interfaces.

    [~Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ip address 10.1.1.2 24
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit

    The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here.

  3. Configure basic IS-IS functions.

    # Configure Switch ModuleA.

    [~Switch ModuleA] isis 1
    [*Switch ModuleA-isis-1] is-level level-1
    [*Switch ModuleA-isis-1] network-entity 10.0000.0000.0001.00
    [*Switch ModuleA-isis-1] quit
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] isis enable 1
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit

    # Configure Switch ModuleB.

    [~Switch ModuleB] isis 1
    [*Switch ModuleB-isis-1] is-level level-1
    [*Switch ModuleB-isis-1] network-entity 10.0000.0000.0002.00
    [*Switch ModuleB-isis-1] quit
    [*Switch ModuleB] interface vlanif 20
    [*Switch ModuleB-Vlanif20] isis enable 1
    [*Switch ModuleA-Vlanif20] commit
    [~Switch ModuleB-Vlanif20] quit

    # Configure Switch ModuleC.

    [~Switch ModuleC] isis 1
    [*Switch ModuleC-isis-1] network-entity 10.0000.0000.0003.00
    [*Switch ModuleC-isis-1] quit
    [*Switch ModuleC] interface vlanif 10
    [*Switch ModuleC-Vlanif10] isis enable 1
    [*Switch ModuleC-Vlanif10] quit
    [*Switch ModuleC] interface vlanif 20
    [*Switch ModuleC-Vlanif20] isis enable 1
    [*Switch ModuleC-Vlanif20] quit
    [*Switch ModuleC] interface vlanif 30
    [*Switch ModuleC-Vlanif30] isis enable 1
    [*Switch ModuleC-Vlanif30] commit
    [~Switch ModuleC-Vlanif30] quit

    # Configure Switch ModuleD.

    [~Switch ModuleD] isis 1
    [*Switch ModuleD-isis-1] is-level level-2
    [*Switch ModuleD-isis-1] network-entity 20.0000.0000.0004.00
    [*Switch ModuleD-isis-1] quit
    [*Switch ModuleD] interface vlanif 30
    [*Switch ModuleD-Vlanif30] isis enable 1
    [*Switch ModuleD-Vlanif30] quit
    [*Switch ModuleD] interface vlanif 40
    [*Switch ModuleD-Vlanif40] isis enable 1
    [*Switch ModuleD-Vlanif40] commit
    [~Switch ModuleD-Vlanif40] quit

  4. Configure the authentication mode and password for Switch ModuleA and Switch ModuleC to authenticate Hello packets.

    # Configure Switch ModuleA.

    [~Switch ModuleA] interface vlanif 10
    [~Switch ModuleA-Vlanif10] isis authentication-mode md5 huawei
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit

    # Configure Switch ModuleC.

    [~Switch ModuleC] interface vlanif 10
    [~Switch ModuleC-Vlanif10] isis authentication-mode md5 huawei
    [*Switch ModuleC-Vlanif10] commit
    [~Switch ModuleC-Vlanif10] quit

  5. Verify the configuration.

    # View the IS-IS LSDB information of each switch modules.

    [~Switch ModuleA] display isis lsdb
                                                                                    
    Database Information for ISIS(1)                                                
    --------------------------------------------------------------------------------
                                                                                    
    Level-1 Link State Database                                                     
                                                                                    
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),            
               ATT-Attached, P-Partition, OL-Overload                               
                                                                                    
    
    LSPID                 Seq Num      Checksum      HoldTime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0001.00-00* 0x00000006   0xbf7d        649           68      0/0/0
    0000.0000.0002.00-00  0x00000003   0xef4d        545           68      0/0/0
    0000.0000.0003.00-00  0x00000008   0x3340        582           111     1/0/0
     
    
    Total LSP(s): 3 
    [~Switch ModuleB] display isis lsdb
                                                                                    
    Database Information for ISIS(1)                                                
    --------------------------------------------------------------------------------
                                                                                    
    Level-1 Link State Database                                                     
                                                                                    
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),            
               ATT-Attached, P-Partition, OL-Overload                               
                                                                                    
    
    LSPID                 Seq Num      Checksum      HoldTime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0001.00-00  0x00000006   0xbf7d        642           68      0/0/0
    0000.0000.0002.00-00* 0x00000003   0xef4d        538           68      0/0/0
    0000.0000.0003.00-00  0x00000008   0x3340        574           111     1/0/0
     
    
    Total LSP(s): 3 
    [~Switch ModuleC] display isis lsdb
                                                                                    
    Database Information for ISIS(1)                                                
    --------------------------------------------------------------------------------
                                                                                    
    Level-1 Link State Database                                                     
                                                                                    
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),            
               ATT-Attached, P-Partition, OL-Overload                               
                                                                                    
    
    LSPID                 Seq Num      Checksum      HoldTime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0001.00-00  0x00000006   0xbf7d        638           68      0/0/0
    0000.0000.0002.00-00  0x00000003   0xef4d        533           68      0/0/0
    0000.0000.0003.00-00* 0x00000008   0x3340        569           111     1/0/0
     
    
    Total LSP(s): 3 
                                                                                    
                                                                                    
                                                                                    
    Level-2 Link State Database                                                     
                                                                                    
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),            
               ATT-Attached, P-Partition, OL-Overload                               
                                                                                    
    
                              Level-2 Link State Database
    LSPID                 Seq Num      Checksum      HoldTime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0003.00-00* 0x00000008   0x55bb        650           100     0/0/0
    0000.0000.0004.00-00  0x00000005   0x651         629           84      0/0/0
     
    
    Total LSP(s): 2 
    [~Switch ModuleD] display isis lsdb
                                                                                    
    Database Information for ISIS(1)                                                
    --------------------------------------------------------------------------------
                                                                                    
    Level-2 Link State Database                                                     
                                                                                    
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),            
               ATT-Attached, P-Partition, OL-Overload                               
                                                                                    
    
    LSPID                 Seq Num      Checksum      HoldTime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0003.00-00  0x00000008   0x55bb        644           100     0/0/0
    0000.0000.0004.00-00* 0x00000005   0x651         624           84      0/0/0
     
    
    Total LSP(s): 2 

    # View the IS-IS routing information of each switch modules. The routing table of a Level-1 device contains a default route with the next hop as a Level-1-2 device. The routing table of a Level-2 device contains all Level-1 and Level-2 routes.

    [~Switch ModuleA] display isis route
                                                                                    
    Route Information for ISIS(1)                                                   
    --------------------------------------------------------------------------------
                                                                                    
    Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,          
                                   U-Up/Down Bit Set                                
                                                                                    
    ISIS(1) Level-1 Forwarding Table                                                
    --------------------------------------------------------------------------------
                                                                                    
    
     IPV4 Destination   IntCost   ExtCost ExitInterface   NextHop         Flags
    --------------------------------------------------------------------------
     0.0.0.0/0          10        NULL    Vlanif10        10.1.1.1        A/-/-/-
     10.1.1.0/24        10        NULL    -               Direct          D/-/L/-
     10.1.2.0/24        20        NULL    Vlanif10        10.1.1.1        A/-/-/-
     192.168.0.0/24     20        NULL    Vlanif10        10.1.1.1        A/-/-/-
    [~Switch ModuleC] display isis route
                                                                                    
    Route Information for ISIS(1)                                                   
    --------------------------------------------------------------------------------
                                                                                    
    Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,          
                                   U-Up/Down Bit Set                                
                                                                                    
    ISIS(1) Level-1 Forwarding Table                                                
    --------------------------------------------------------------------------------
                                                                                    
    
     IPV4 Destination   IntCost   ExtCost ExitInterface   NextHop         Flags
    -------------------------------------------------------------------------
     10.1.1.0/24        10        NULL    -               Direct          D/-/L/-
     10.1.2.0/24        10        NULL    -               Direct          D/-/L/-
     192.168.0.0/24     10        NULL    -               Direct          D/-/L/-
                                                                                    
                                                                                    
    ISIS(1) Level-2 Forwarding Table                                                
    --------------------------------------------------------------------------------
                                                                                    
    
     IPV4 Destination   IntCost   ExtCost ExitInterface   NextHop         Flags
    -------------------------------------------------------------------------
     10.1.1.0/24        10        NULL    -               Direct          D/-/L/-
     10.1.2.0/24        10        NULL    -               Direct          D/-/L/-
     172.16.0.0/16      20        NULL    Vlanif30        192.168.0.2     A/-/-/-
     192.168.0.0/24     10        NULL    -               Direct          D/-/L/-
    
    
    [~Switch ModuleD] display isis route
                                                                                    
    Route Information for ISIS(1)                                                   
    --------------------------------------------------------------------------------
                                                                                    
    Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,          
                                   U-Up/Down Bit Set                                
                                                                                    
    ISIS(1) Level-1 Forwarding Table                                                
    --------------------------------------------------------------------------------
                                                                                    
    
     IPV4 Destination   IntCost   ExtCost ExitInterface   NextHop          Flags
    --------------------------------------------------------------------------
     10.1.1.0/24        20        NULL    Vlanif30          192.168.0.1      A/-/-/-
     10.1.2.0/24        20        NULL    Vlanif30          192.168.0.1      A/-/-/-
     172.16.0.0/16      10        NULL    -                 Direct           D/-/L/-
     192.168.0.0/24     10        NULL    -                 Direct           D/-/L/-

Configuration Files
  • Configuration file of Switch ModuleA
    #
    sysname Switch ModuleA
    #
    vlan batch 10
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
     isis authentication-mode md5 cipher %$%$mCq>5gS+rI*Hnl"\N"n3,sja%$%$
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Configuration file of Switch ModuleB
    #
    sysname Switch ModuleB
    #
    vlan batch 20
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • Configuration file of Switch ModuleC
    #
    sysname Switch ModuleC
    #
    vlan batch 10 20 30
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
     isis authentication-mode md5 cipher %$%$xcT`05J];Ja`JG1aI~v&,(|s%$%$ 
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif30
     ip address 192.168.0.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
  • Configuration file of Switch ModuleD
    #
    sysname Switch ModuleD
    #
    vlan batch 30 40
    #
    isis 1
     is-level level-2
     network-entity 20.0000.0000.0004.00
    #
    interface Vlanif30
     ip address 192.168.0.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif40
     ip address 172.16.1.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    return

Example for Configuring IS-IS DIS Election

Networking Requirements

In Figure 7-85, four switches on the broadcast network communicate using IS-IS. SwitchA and SwitchB are Level-1-2 devices, SwitchC is a Level-1 device, and SwitchD is a Level-2 device. SwitchA with high performance needs to be configured as a Level-2 DIS.

Figure 7-85 Networking diagram of configuring IS-IS DIS election

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IS-IS to enable network interconnectivity.

  2. Set the DIS priority of SwitchA to 100 so that SwitchA can be elected as a Level-2 DIS.

Procedure

  1. Configure an IPv4 address for each interface. The configuration details are not described here.
  2. View the MAC address of the VLANIF interface on each switch modules. When each VLANIF interface has the same DIS priority, the switch modules with a larger interface MAC address is elected as the DIS.

    # View the MAC address of VLANIF10 on Switch ModuleA.

    [~Switch ModuleA] display arp interface vlanif 10
    ARP Entry Types: D - Dynamic, S - Static, I - Interface                         
    EXP: Expire-time                                              
    IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE
    -------------------------------------------------------------------------
    10.1.1.1        00e0-fc10-afec        I          Vlanif10
    -------------------------------------------------------------------------
    Total:1         Dynamic:0       Static:0    Interface:1  

    # View the MAC address of VLANIF10 on Switch ModuleB.

    [~Switch ModuleB] display arp interface vlanif 10
    ARP Entry Types: D - Dynamic, S - Static, I - Interface                         
    EXP: Expire-time                                              
    IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE
    -------------------------------------------------------------------------
    10.1.1.2        00e0-fccd-acdf        I          Vlanif10
    -------------------------------------------------------------------------
    Total:1         Dynamic:0       Static:0    Interface:1

    # View the MAC address of VLANIF10 on Switch ModuleC.

    [~Switch ModuleC] display arp interface vlanif 10
    ARP Entry Types: D - Dynamic, S - Static, I - Interface                         
    EXP: Expire-time                                              
    IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE
    -------------------------------------------------------------------------
    10.1.1.3        00e0-fc50-25fe        I          Vlanif10
    -------------------------------------------------------------------------
    Total:1         Dynamic:0       Static:0    Interface:1

    # View the MAC address of VLANIF10 on Switch ModuleD.

    [~Switch ModuleD] display arp interface vlanif 10
    ARP Entry Types: D - Dynamic, S - Static, I - Interface                         
    EXP: Expire-time                                              
    IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE
    -------------------------------------------------------------------------
    10.1.1.4        00e0-fcfd-305c        I          Vlanif10
    -------------------------------------------------------------------------
    Total:1         Dynamic:0       Static:0    Interface:1

  3. Configure IS-IS protocol.

    # Configure Switch ModuleA.

    [~Switch ModuleA] isis 1
    [*Switch ModuleA-isis-1] network-entity 10.0000.0000.0001.00
    [*Switch ModuleA-isis-1] quit
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] isis enable 1
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit

    # Configure Switch ModuleB.

    [~Switch ModuleB] isis 1
    [*Switch ModuleB-isis-1] network-entity 10.0000.0000.0002.00
    [*Switch ModuleB-isis-1] quit
    [*Switch ModuleB] interface vlanif 10
    [*Switch ModuleB-Vlanif10] isis enable 1
    [*Switch ModuleB-Vlanif10] commit
    [~Switch ModuleB-Vlanif10] quit

    # Configure Switch ModuleC.

    [~Switch ModuleC] isis 1
    [*Switch ModuleC-isis-1] network-entity 10.0000.0000.0003.00
    [*Switch ModuleC-isis-1] is-level level-1
    [*Switch ModuleC-isis-1] quit
    [*Switch ModuleC] interface vlanif 10
    [*Switch ModuleC-Vlanif10] isis enable 1
    [*Switch ModuleC-Vlanif10] commit
    [~Switch ModuleC-Vlanif10] quit

    # Configure Switch ModuleD.

    [~Switch ModuleD] isis 1
    [*Switch ModuleD-isis-1] network-entity 10.0000.0000.0004.00
    [*Switch ModuleD-isis-1] is-level level-2
    [*Switch ModuleD-isis-1] quit
    [*Switch ModuleD] interface vlanif 10
    [*Switch ModuleD-Vlanif10] isis enable 1
    [*Switch ModuleD-Vlanif10] commit
    [~Switch ModuleD-Vlanif10] quit

    # Check IS-IS neighbor information on Switch ModuleA.

    [~Switch ModuleA] display isis peer
                                                                                    
    Peer Information for ISIS(80)                                                   
    --------------------------------------------------------------------------------
                                                                                    
      System ID     Interface       Circuit ID        State HoldTime(s) Type     PRI
    --------------------------------------------------------------------------------
    0000.0000.0002  Vlanif10        0000.0000.0002.01  Up             8 L1(L1L2)  64
    0000.0000.0003  Vlanif10        0000.0000.0002.01  Up            29 L1        64
    0000.0000.0002  Vlanif10        0000.0000.0002.01  Up             6 L2(L1L2)  64
    0000.0000.0004  Vlanif10        0000.0000.0002.01  Up            27 L2        64
                                                                                    
    Total Peer(s): 4                                                                

    # View IS-IS interface information on Switch ModuleA.

    [~Switch ModuleA] display isis interface
                                                                                    
    Interface Information for ISIS(1)                                              
    --------------------------------------------------------------------------------
     Interface         ID      IPV4 State          IPV6 State      MTU  Type  DIS   
     Vlanif10          001         Up          Mtu:Up/Lnk:Dn/IP:Dn 1497 L1/L2 No/No 

    # View IS-IS interface information on Switch ModuleB.

    [~Switch ModuleB] display isis interface
                                                                                    
    Interface Information for ISIS(1)                                              
    --------------------------------------------------------------------------------
     Interface         ID      IPV4 State          IPV6 State      MTU  Type  DIS   
     Vlanif10          001         Up          Mtu:Up/Lnk:Dn/IP:Dn 1497 L1/L2 Yes/No

    # View IS-IS interface information on Switch ModuleD.

    [~Switch ModuleD] display isis interface
                                                                                    
    Interface Information for ISIS(1)                                              
    --------------------------------------------------------------------------------
     Interface         ID      IPV4 State          IPV6 State      MTU  Type  DIS   
     Vlanif10          001         Up          Mtu:Up/Lnk:Dn/IP:Dn 1497 L1/L2 No/Yes 

    As shown in the preceding interface information, when the default DIS priority is used, the IS-IS interface on Switch ModuleB has the largest MAC address among all the interfaces on the Level-1 Switch Modules. Therefore, Switch ModuleB is elected as a Level-1 DIS. The IS-IS interface on Switch ModuleD has the largest MAC address among all the interfaces on the Level-2 Switch Modules. Therefore, Switch ModuleD is elected as a Level-2 DIS. Level-1 and Level-2 pseudonodes are 0000.0000.0002.01 and 0000.0000.0004.01 respectively.

  4. Configure the DIS priority of Switch ModuleA.

    [~Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] isis dis-priority 100
    [*Switch ModuleA-Vlanif10] commit

    # View IS-IS neighbor information on Switch ModuleA.

    [~Switch ModuleA] display isis peer
                                                                                    
    Peer Information for ISIS(80)                                                   
    --------------------------------------------------------------------------------
                                                                                    
      System ID     Interface       Circuit ID        State HoldTime(s) Type     PRI
    --------------------------------------------------------------------------------
    0000.0000.0002  Vlanif10        0000.0000.0001.01  Up            23 L1(L1L2)  64
    0000.0000.0003  Vlanif10        0000.0000.0001.01  Up            27 L1        64
    0000.0000.0002  Vlanif10        0000.0000.0001.01  Up            23 L2(L1L2)  64
    0000.0000.0004  Vlanif10        0000.0000.0001.01  Up            23 L2        64
                                                                                    
    Total Peer(s): 4                                                                

  5. Verify the configuration.

    # View IS-IS interface information on Switch ModuleA.

    [~Switch ModuleA] display isis interface
                                                                                    
    Interface Information for ISIS(1)                                              
    --------------------------------------------------------------------------------
     Interface         ID      IPV4 State          IPV6 State      MTU  Type  DIS   
     Vlanif10          001         Up          Mtu:Up/Lnk:Dn/IP:Dn 1497 L1/L2 Yes/Yes

    As shown in the preceding information, after the DIS priority of the IS-IS interface on Switch Module is changed, Switch ModuleA becomes a Level-1-2 DIS (DR) immediately and its pseudonode is 0000.0000.0001.01.

    # View IS-IS neighbor and interface information on Switch ModuleB.

    [~Switch ModuleB] display isis peer
                                                                                    
    Peer Information for ISIS(1)                                                   
    --------------------------------------------------------------------------------
                                                                                    
      System ID     Interface       Circuit ID        State HoldTime(s) Type     PRI
    --------------------------------------------------------------------------------
    0000.0000.0001  Vlanif10        0000.0000.0001.01  Up             8 L1(L1L2) 100
    0000.0000.0003  Vlanif10        0000.0000.0001.01  Up            22 L1        64
    0000.0000.0001  Vlanif10        0000.0000.0001.01  Up             8 L2(L1L2) 100
    0000.0000.0004  Vlanif10        0000.0000.0001.01  Up            26 L2        64
                                                                                    
    Total Peer(s): 4                                                                
     [~Switch ModuleB] display isis interface
                                                                                    
    Interface Information for ISIS(1)                                              
    --------------------------------------------------------------------------------
     Interface         ID      IPV4 State          IPV6 State      MTU  Type  DIS   
     Vlanif10          001         Up          Mtu:Up/Lnk:Dn/IP:Dn 1497 L1/L2 No/No 

    # View IS-IS neighbor and interface information on Switch ModuleD.

    [~Switch ModuleD] display isis peer
                                                                                    
    Peer Information for ISIS(1)                                                   
    --------------------------------------------------------------------------------
                                                                                    
      System ID     Interface       Circuit ID        State HoldTime(s) Type     PRI
    --------------------------------------------------------------------------------
    0000.0000.0001  Vlanif10        0000.0000.0001.01  Up             8 L2       100
    0000.0000.0002  Vlanif10        0000.0000.0001.01  Up            22 L2        64
                                                                                    
    Total Peer(s): 2                                                                
    [~Switch ModuleD] display isis interface
                                                                                    
    Interface Information for ISIS(1)                                              
    --------------------------------------------------------------------------------
     Interface         ID      IPV4 State          IPV6 State      MTU  Type  DIS   
     Vlanif10          001         Up          Mtu:Up/Lnk:Dn/IP:Dn 1497 L1/L2 No/No 

Configuration Files
  • Configuration file of Switch ModuleA
    #
    sysname Switch ModuleA
    #
    vlan batch 10
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
     isis dis-priority 100
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
  • Configuration file of Switch ModuleB
    #
    sysname Switch ModuleB
    #
    vlan batch 10
    #
    isis 1
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
  • Configuration file of Switch ModuleC
    #
    sysname Switch ModuleC
    #
    vlan batch 10
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif10
     ip address 10.1.1.3 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
  • Configuration file of Switch ModuleD
    #
    sysname Switch ModuleD
    #
    vlan batch 10
    #
    isis 1
     is-level level-2
     network-entity 10.0000.0000.0004.00
    #
    interface Vlanif10
     ip address 10.1.1.4 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    

Example for Configuring IS-IS to Interact with BGP

Networking Requirements

As shown in Figure 7-86, Switch A and Switch B belong to the same AS, and the IS-IS neighbor relationship is established between Switch A and Switch B. An EBGP connection is established between Switch B and Switch C. Switch A, Switch B, and Switch C need to communicate with each other. Besides, the metric of routes need to be changed when AS 65009 sends the routes to AS 65008.

Figure 7-86 Networking diagram of configuring IS-IS to interact with BGP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces, and enable IS-IS and BGP to ensure that there are reachable routes inside each AS.

  2. Configure IS-IS and BGP to import routes from each other on Switch B to ensure that there are routes on each network segment. Configure a route-policy to change the metric of imported routes when IS-IS imports BGP routes.

Procedure

  1. Configure VLANs that each interface belongs to.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleB
    [*HUAWEI] commit
    [~Switch ModuleB] vlan batch 10 20
    [*Switch ModuleB] interface 10ge 1/17/1
    [*Switch ModuleB-10GE1/17/1] port link-type trunk
    [*Switch ModuleB-10GE1/17/1] port trunk allow-pass vlan 10
    [*Switch ModuleB-10GE1/17/1] quit
    [*Switch ModuleB] interface 10ge 1/17/2
    [*Switch ModuleB-10GE1/17/2] port link-type trunk
    [*Switch ModuleB-10GE1/17/2] port trunk allow-pass vlan 20
    [*Switch ModuleB-10GE1/17/2] quit
    [*Switch ModuleB] commit

    The configurations of Switch ModuleA and Switch ModuleC are similar to the configuration of Switch ModuleA, and are not mentioned here.

  2. Assign the IP addresses for VLANIF interfaces.

    [~Switch ModuleB] interface vlanif 10
    [*Switch ModuleB-Vlanif10] ip address 10.1.1.2/24
    [*Switch ModuleB-Vlanif10] quit
    [*Switch ModuleB] interface vlanif 20
    [*Switch ModuleB-Vlanif20] ip address 10.2.1.1/24
    [*Switch ModuleB-Vlanif20] quit
    [*Switch ModuleB] commit

    The configurations of Switch ModuleA and Switch ModuleC are similar to the configuration of Switch ModuleA, and are not mentioned here.

  3. Configure basic IS-IS functions.

    # Configure Switch ModuleA.

    [~Switch ModuleA] isis 1
    [*Switch ModuleA-isis-1] network-entity 10.0000.0000.0001.00
    [*Switch ModuleA-isis-1] quit
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] isis enable 1
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] commit

    # Configure Switch ModuleB.

    [~Switch ModuleB] isis 1
    [*Switch ModuleB-isis-1] network-entity 10.0000.0000.0002.00
    [*Switch ModuleB-isis-1] quit
    [*Switch ModuleB] interface vlanif 10
    [*Switch ModuleB-Vlanif10] isis enable 1
    [*Switch ModuleB-Vlanif10] quit
    [*Switch ModuleB] interface vlanif 20
    [*Switch ModuleB-Vlanif20] isis enable 1
    [*Switch ModuleB-Vlanif20] quit
    [*Switch ModuleB] commit

  4. Establish an EBGP connection.

    # Configure Switch ModuleB.

    [~Switch ModuleB] bgp 65008
    [*Switch ModuleB-bgp] router-id 1.1.1.1
    [*Switch ModuleB-bgp] peer 10.2.1.2 as-number 65009
    [*Switch ModuleB-bgp] ipv4-family unicast
    [*Switch ModuleB-bgp-af-ipv4] network 10.2.1.0 255.255.255.0
    [*Switch ModuleB-bgp-af-ipv4] commit
    [~Switch ModuleB-bgp-af-ipv4] quit
    [~Switch ModuleB-bgp] quit

    Configure Switch ModuleC.

    [~Switch ModuleC] bgp 65009
    [*Switch ModuleC-bgp] router-id 2.2.2.2
    [*Switch ModuleC-bgp] peer 10.2.1.1 as-number 65008
    [*Switch ModuleC-bgp] ipv4-family unicast
    [*Switch ModuleC-bgp-af-ipv4] network 10.2.1.0 255.255.255.0
    [*Switch ModuleC-bgp-af-ipv4] commit
    [~Switch ModuleC-bgp-af-ipv4] quit
    [~Switch ModuleC-bgp] quit

  5. Configure IS-IS to import BGP routes.

    # Configure a static route on Switch ModuleC.

    [~Switch ModuleC] ip route-static 200.1.1.1 32 NULL 0
    [*Switch ModuleC] commit

    # On Switch ModuleC, configure BGP to import the static route.

    [~Switch ModuleC] bgp 65009
    [~Switch ModuleC-bgp] import-route static
    [*Switch ModuleC-bgp] quit
    [*Switch ModuleC] commit

    # On Switch ModuleB, configure IS-IS to import the BGP route.

    [~Switch ModuleB] isis 1
    [~Switch ModuleB-isis-1] import-route bgp
    [*Switch ModuleB-isis-1] quit
    [*Switch ModuleB] commit

    # View the routing table of Switch ModuleA, and you can see that IS-IS successfully imports BGP route 200.1.1.1/32.

    [~Switch ModuleA] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Tables: _Public_
             Destinations : 6        Routes : 6
    
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
    
           10.1.1.0/24  Direct 0    0           D  10.1.1.1        Vlanif10
           10.1.1.1/32  Direct 0    0           D  127.0.0.1       InLoopBack0
           10.1.1.2/32  Direct 0    0           D  10.1.1.2        Vlanif10
           127.0.0.0/8  Direct 0    0           D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0           D  127.0.0.1       InLoopBack0
          200.1.1.1/32  ISIS-L2   15   74          D   10.1.1.2       Vlanif10

    # On Switch B, configure the AS_Path filter, and apply the filter in route-policy RTC.

    [~Switch ModuleB] ip as-path-filter 1 permit 65009
    [*Switch ModuleB] route-policy RTC permit node 0
    [*Switch ModuleB-route-policy] if-match as-path-filter 1
    [*Switch ModuleB-route-policy] apply cost 20
    [*Switch ModuleB-route-policy] quit
    [*Switch ModuleB] commit

    # On Switch ModuleB, configure IS-IS to import the BGP route.

    [~Switch ModuleB] isis 1
    [~Switch ModuleB-isis-1] import-route bgp route-policy RTC
    [*Switch ModuleB-isis-1] quit
    [*Switch ModuleB] commit

    # View the routing table of Switch ModuleA, and you can see that the AS_Path filter is successfully applied and the cost of imported route 200.1.1.1/32 changes from 74 to 94.

    [~Switch ModuleA] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Tables: _Public_
             Destinations : 6        Routes : 6
    
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
    
           10.1.1.0/24  Direct 0    0           D  10.1.1.1        Vlanif10
           10.1.1.1/32  Direct 0    0           D  127.0.0.1       Vlanif10
           10.1.1.2/32  Direct 0    0           D  10.1.1.2        Vlanif10
           127.0.0.0/8  Direct 0    0           D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0           D  127.0.0.1       InLoopBack0
          200.1.1.1/32  ISIS-L2    15     94  D  10.1.1.2       Vlanif10

  6. Configure BGP to import IS-IS routes.

    [~Switch ModuleB] bgp 65008
    [~Switch ModuleB-bgp] import-route isis 1
    [*Switch ModuleB-bgp] quit
    [*Switch ModuleB] commit

    # View the routing table of Switch ModuleC, and you can see that BGP successfully imports IS-IS route 10.1.1.0/24.

    [~Switch ModuleC] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Tables: _Public_
             Destinations : 7        Routes : 7
    
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
    
           10.1.1.0/24    EBGP   255   0   D   10.2.1.1       Vlanif20
           10.2.1.0/24  Direct 0    0           D  10.2.1.2        Vlanif10
           10.2.1.1/32  Direct 0    0           D  10.2.1.1        Vlanif20
           10.2.1.2/32  Direct 0    0           D  127.0.0.1       InLoopBack0
           127.0.0.0/8  Direct 0    0           D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0           D  127.0.0.1       InLoopBack0
          200.1.1.1/32  Static 60   0           D  0.0.0.0         NULL0
    

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 10 20
    #
    isis 1
     network-entity 10.0000.0000.0002.00
     import-route bgp route-policy RTC
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    bgp 65008
     router-id 1.1.1.1
     peer 10.2.1.2 as-number 65009
     #
     ipv4-family unicast
      network 10.2.1.0 255.255.255.0
      import-route isis 1
      peer 10.2.1.2 enable
    #
    route-policy RTC permit node 0
     if-match as-path-filter 1
     apply cost 20
    #
     ip as-path-filter 1 index 10 permit 65009
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    bgp 65009
     router-id 2.2.2.2
     peer 10.2.1.1 as-number 65008
     #
     ipv4-family unicast
      network 10.2.1.0 255.255.255.0
      import-route static
      peer 10.2.1.1 enable
    #
     ip route-static 200.1.1.1 255.255.255.255 NULL0
    #
    return

Example for Configuring IS-IS Auto FRR

Networking Requirements

As shown in Figure 7-87, four devices (Switch A, Switch B, Switch C, and Switch D) communicate using IS-IS. The reliability of data forwarding from Switch A to Switch D needs to be improved. When the primary link fails, traffic is transmitted to the backup link in milliseconds.

Figure 7-87 Networking diagram of configuring IS-IS Auto FRR

Configuration Roadmap

The configuration roadmap is as follows:

  1. Set a larger link cost on VLANIF 20 of Switch A, and ensure that Link T is preferentially selected for data forwarding from Switch A to Switch D.

  2. Configure IS-IS Auto FRR on Switch A to allow traffic to be fast switched to the backup link without waiting for route convergence when a fault occurs on Link T. This improves the reliability of data forwarding.

Procedure

  1. Configure VLANs that each interface belongs to.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 10 20
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] port link-type trunk
    [*Switch ModuleA-10GE1/17/2] port trunk allow-pass vlan 20
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] commit

    The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here.

  2. Configure the IP addresses of each VLANIF interface.

    [~Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ip address 1.0.0.1 24
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] interface vlanif 20
    [*Switch ModuleA-Vlanif20] ip address 2.0.0.1 24
    [*Switch ModuleA-Vlanif20] quit
    [*Switch ModuleA] commit

    The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here.

  3. Configure basic IS-IS functions.

    # Configure Switch ModuleA.

    [~Switch ModuleA] isis 1
    [*Switch ModuleA-isis-1] is-level level-1-2
    [*Switch ModuleA-isis-1] network-entity 10.0000.0000.0001.00
    [*Switch ModuleA-isis-1] quit
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] isis enable 1
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] interface vlanif 20
    [*Switch ModuleA-Vlanif20] isis enable 1
    [*Switch ModuleA-Vlanif20] quit
    [*Switch ModuleA] commit

    # Configure Switch ModuleB.

    [~Switch ModuleB] isis 1
    [*Switch ModuleB-isis-1] is-level level-1-2
    [*Switch ModuleB-isis-1] network-entity 10.0000.0000.0002.00
    [*Switch ModuleB-isis-1] quit
    [*Switch ModuleB] interface vlanif 20
    [*Switch ModuleB-Vlanif20] isis enable 1
    [*Switch ModuleB-Vlanif20] quit
    [*Switch ModuleB] interface vlanif 30
    [*Switch ModuleB-Vlanif30] isis enable 1
    [*Switch ModuleB-Vlanif30] quit
    [*Switch ModuleB] commit

    # Configure Switch ModuleC.

    [~Switch ModuleC] isis 1
    [*Switch ModuleC-isis-1] is-level level-1-2
    [*Switch ModuleC-isis-1] network-entity 10.0000.0000.0003.00
    [*Switch ModuleC-isis-1] quit
    [*Switch ModuleC] interface vlanif 10
    [*Switch ModuleC-Vlanif10] isis enable 1
    [*Switch ModuleC-Vlanif10] quit
    [*Switch ModuleC] interface vlanif 50
    [*Switch ModuleC-Vlanif50] isis enable 1
    [*Switch ModuleC-Vlanif50] quit
    [*Switch ModuleC] commit

    # Configure Switch ModuleD.

    [~Switch ModuleD] isis 1
    [*Switch ModuleD-isis-1] is-level level-1-2
    [*Switch ModuleD-isis-1] network-entity 10.0000.0000.0004.00
    [*Switch ModuleD-isis-1] quit
    [*Switch ModuleD] interface vlanif 50
    [*Switch ModuleD-Vlanif50] isis enable 1
    [*Switch ModuleD-Vlanif50] quit
    [*Switch ModuleD] interface vlanif 30
    [*Switch ModuleD-Vlanif30] isis enable 1
    [*Switch ModuleD-Vlanif30] quit
    [*Switch ModuleD] interface vlanif 40
    [*Switch ModuleD-Vlanif40] isis enable 1
    [*Switch ModuleD-Vlanif40] quit
    [*Switch ModuleD] commit

  4. Set the interface cost of VLANIF 20 on Switch ModuleA to 30, and then check the routing information.

    # Set the interface cost of VLANIF 20 on Switch ModuleA to 30.

    [~Switch ModuleA] interface vlanif 20
    [~Switch ModuleA-Vlanif20] isis cost 30
    [*Switch ModuleA-Vlanif20] quit
    [*Switch ModuleA] return

    # Check information about the link from Switch ModuleA to Switch ModuleD. Link T has a lower cost, and so IS-IS optimally selects Link T to send traffic that is forwarded by Switch ModuleA.

    <Switch ModuleA> display isis route 100.1.1.1 verbose
                                                                                    
    Route Information for ISIS(1)                                                   
    --------------------------------------------------------------------------------
                                                                                    
    Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,          
                                   U-Up/Down Bit Set                                
                                                                                    
    ISIS(1) Level-1 Forwarding Table                                                
    --------------------------------------------------------------------------------
                                                                                    
                                                                                    
     IPV4 Dest  : 100.1.1.0/24       Int. Cost : 30            Ext. Cost : NULL     
     Admin Tag  : -                  Src Count : 1             Flags     : A/-/L/-
     Priority   : Low                                                               
     NextHop    :                    Interface :               ExitIndex :          
     1.0.0.2                          Vlanif10                 0x00000003
                                                                                    
                                                                                    
    ISIS(1) Level-2 Forwarding Table                                                
    --------------------------------------------------------------------------------
                            --------------------------------                        
                                                                                    
     IPV4 Dest  : 100.1.1.0/24       Int. Cost : 30            Ext. Cost : NULL     
     Admin Tag  : -                  Src Count : 3             Flags     : -/-/-/-
     Priority   : Low                                                               
                                                                                    
    

    As shown in the command output, traffic from Switch ModuleA to Switch ModuleD is only forwarded through Link T.

  5. Enable IS-IS Auto FRR on Switch ModuleA, and then check the routing information.

    # Enable IS-IS Auto FRR on Switch ModuleA.

    <Switch ModuleA> system-view
    [~Switch ModuleA] isis 1
    [~Switch ModuleA-isis-1] frr
    [*Switch ModuleA-isis-1-frr] loop-free-alternate
    [*Switch ModuleA-isis-1-frr] commit
    

    # Check the routing information from Switch ModuleA to Switch ModuleD. You can find that IS-IS creates a backup link because IS-IS Auto FRR is enabled.

    <Switch ModuleA> display isis route 100.1.1.1 verbose
                                                                                    
    Route Information for ISIS(1)                                                   
    --------------------------------------------------------------------------------
                                                                                    
    Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,          
                                   U-Up/Down Bit Set                                
                                                                                    
    ISIS(1) Level-1 Forwarding Table                                                
    --------------------------------------------------------------------------------
                                                                                    
                                                                                    
     IPV4 Dest  : 100.1.1.0/24       Int. Cost : 30            Ext. Cost : NULL     
     Admin Tag  : -                  Src Count : 1             Flags     : A/-/L/-
     Priority   : Low                                                               
     NextHop    :                    Interface :               ExitIndex :          
        1.0.0.2                            Vlanif10                   0x00000003    
     (B)2.0.0.2                            Vlanif20                  0x00000004
                                                                                    
                                                                                    
                                                                                    
                            ISIS(1) Level-2 Forwarding Table                        
                            --------------------------------                        
                                                                                    
     IPV4 Dest  : 100.1.1.0/24       Int. Cost : 30            Ext. Cost : NULL     
     Admin Tag  : -                  Src Count : 3             Flags     : -/-/-/-
     Priority   : Low                                                               
                                                                                    
                                                                                    

    # Check the protection type for the traffic from Switch ModuleA to Switch ModuleD.

    <Switch ModuleA> display isis spf-tree systemid 0000.0000.0004 verbose
                                                                                    
    Shortest Path Tree for ISIS(1)                                                  
    ------------------------------------------------------------------------------  
                                                                                    
                                                                                    
    ISIS(1) Level-1 Shortest Path Tree                                              
    ------------------------------------------------------------------------------  
     0000.0000.0004.00                                                              
       Distance            : 20                                                     
       Distance-URT        : 20                                                     
       Flags               : SPT/V4_Islt/V6_Islt                                            
       IPv4 Nexthops-URT   : 1                                                      
                 (1) 1.0.0.2          IF:Vlanif10  NBR:0000.0000.0003.00            
                 (B) 2.0.0.2          IF:Vlanif20  NBR:0000.0000.0002.00            
                                      TYPE:LOOP-FREE  PROTECT:LINK-NODE             
       IPv4 Nexthops-MIGP  : 0                                                      
       IPv6 Nexthops       : 0                                                      
       Neighbors: 2 (Children:1 Parents:1 Others:0)                                 
                 (1)   0000.0000.0003.02                                            
                         Cost  : 10                                                 
                         Flags : Parent                                             
                                                                                    
                 (2)   0000.0000.0004.03                                            
                         Cost  : 10                                                 
                         Flags : Child                                              
                                                                                    
                                                                                    
    ISIS(1) Level-2 Shortest Path Tree                                              
    ------------------------------------------------------------------------------  
     0000.0000.0004.00                                                              
       Distance            : 20                                                     
       Distance-URT        : 20                                                     
       Flags               : SPT/V4_Islt/V6_Islt                                            
       IPv4 Nexthops-URT   : 1                                                      
                 (1) 1.0.0.2          IF:Vlanif10  NBR:0000.0000.0003.00            
                 (B) 2.0.0.2          IF:Vlanif20  NBR:0000.0000.0002.00            
                                      TYPE:LOOP-FREE  PROTECT:LINK-NODE             
       IPv4 Nexthops-MIGP  : 0                                                      
       IPv6 Nexthops       : 0                                                      
       Neighbors: 2 (Children:1 Parents:1 Others:0)                                 
                 (1)   0000.0000.0003.02                                            
                         Cost  : 10                                                 
                         Flags : Parent                                             
                                                                                    
                 (2)   0000.0000.0004.03                                            
                         Cost  : 10                                                 
                         Flags : Child                                              
                                                                                    

    As shown in the preceding command output, link-node dual protection is performed on the traffic from Switch ModuleA to Switch ModuleD.

    # Run the display fib 100.1.1.1 verbose command on Switch ModuleA to check the forwarding entry of traffic from Switch ModuleA to Switch ModuleD.

    <Switch ModuleA> display fib 100.1.1.1 verbose
      Route Entry Count: 1
     Destination: 100.1.1.0           Mask     : 255.255.255.0
     Nexthop    : 1.0.0.2             OutIf    : Vlanif10
     LocalAddr  : 1.0.0.1             LocalMask: 0.0.0.0
     Flags      : DGU                 Age      : 6sec
     ATIndex    : 0                   Slot     : 0
     LspFwdFlag : 0                   LspToken : 0x0
     InLabel    : NULL                OriginAs : 0
     BGPNextHop : 0.0.0.0             PeerAs   : 0
     QosInfo    : 0x0                 OriginQos: 0x0
     NexthopBak : 2.0.0.2             OutIfBak : Vlanif20
     LspTokenBak: 0x0                 InLabelBak : NULL
     LspToken_ForInLabelBak     : 0x0
     EntryRefCount : 0
     VlanId : 0x0                 
     BgpKey : 0                   
     BgpKeyBak : 0
     LspType         : 0              Label_ForLspTokenBak   : 0
     MplsMtu         : 0              Gateway_ForLspTokenBak : 0.0.0.0
     NextToken       : 0x0            IfIndex_ForLspTokenBak : 0
     Label_NextToken : 0              Label : 0
     LspBfdState     : 0
    

    As shown in the command output, the outbound interface of the primary link from Switch ModuleA to Switch ModuleD is Vlanif10. The backup link follows the route with Vlanif20 as the outbound interface and 2.0.0.2 as the next hop.

  6. Verify the configuration.

    # Run the shutdown command on Vlanif50 of Switch ModuleC to shut down the link.

    [~Switch ModuleC] interface vlanif 50
    [~Switch ModuleC-Vlanif50] shutdown
    [*Switch ModuleC-Vlanif50] commit

    # Run the display fib 100.1.1.1 verbose command on Switch ModuleA to check information about the route from Switch ModuleA to Switch ModuleD.

    <Switch ModuleA> display ip fib slot 1 100.1.1.1 verbose
     FIB Table : _public_                                                           
     Total number of Routes : 1                                                     
                                                    
    Destination: 100.1.1.0           Mask     : 255.255.255.0
     Nexthop    : 2.0.0.2             OutIf    : Vlanif20
     LocalAddr  : 0.0.0.0             LocalMask: 0.0.0.0
     Flags      : DGU                 Age      : 124sec
     ATIndex    : 0                   Slot     : 1
     LspFwdFlag :  0                    LspToken :  0x0                             
     InLabel    :  0x0                  OriginAs :  0                               
     BGPNextHop :  0                    PeerAs   :  0                               
     QosInfo    :  0                    OriginQos:  0                               
     VlanId     :  0                                                                
     BgpKey     :  0                                                                
     BgpKeyBak  :  0                                                                
     NexthopBak :  0.0.0.0              OutIfBak   :  [No Intf]                     
     LspTokenBak:  0x0                  InLabelBak :  0x0                           
     LspToken_ForInLabelBak     : 0x0                                               
     Nexthop_ForLspTokenBak     : 0.0.0.0                                           
     OutIf_ForLspTokenBak       : [No Intf]                                         
     Nexthop_ForLspToken_ForInLabelBak   : 0.0.0.0                                  
     OutIf_ForLspToken_ForInLabelBak     : [No Intf]                                
     LspType         : 0               Label_ForLspTokenBak   : 0x0                 
     MplsMtu         : 0               Gateway_ForLspTokenBak : 0.0.0.0             
     NextToken       : 0               IfIndex_ForLspTokenBak : 0                   
     Label_NextToken : 0               Label : 0                                    
     LspBfdState     : 0                                                            

    As shown in the command output, the traffic forwarded by the Switch ModuleA is switched to the backup link with outbound interface Vlanif20 and next hop 2.0.0.2.

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 20
    
    #
    isis 1
     network-entity 10.0000.0000.0001.00
     frr
      loop-free-alternate level-1
      loop-free-alternate level-2
    #
    interface Vlanif10
     ip address 1.0.0.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif20
     ip address 2.0.0.1 255.255.255.0
     isis enable 1
     isis cost 30
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 20 30
    #
    isis 1
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif20
     ip address 2.0.0.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif30
     ip address 3.0.0.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 10 50
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif10
     ip address 1.0.0.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif50
     shutdown
     ip address 4.0.0.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 50 
    #
    return
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 30 40 50
    #
    isis 1
     network-entity 10.0000.0000.0004.00
    #
    interface Vlanif50
     ip address 4.0.0.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif30
     ip address 3.0.0.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif40
     ip address 100.1.1.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 50 
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 40 
    #
    return

Example for Configuring Static BFD for IS-IS

Networking Requirements

As shown in Figure 7-88, three routers are interconnected using IS-IS, and RouterA and RouterB communicate with each other through a Layer 2 switch. When a link between RouterA and RouterB fails, the two routers can respond to the fault rapidly.

Figure 7-88 Networking diagram of configuring static BFD for IS-IS

NOTE:

BFD for IS-IS cannot be used to detect the multi-hop link between RouterA and RouterC, because the IS-IS neighbor relationship cannot be established between RouterA and RouterC.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces and enable IS-IS on each router to ensure reachable routes between the routers.

  2. Enable static BFD for IS-IS on RouterA and RouterB so that routers can rapidly detect link faults.

Procedure

  1. Configure VLANs that each interface belongs to.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 10
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] commit

    The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here.

  2. Assign the IP addresses for VLANIF interfaces.

    [~Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ip address 100.1.1.1 24
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] commit

    The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here.

  3. Configure basic IS-IS functions.

    # Configure Switch ModuleA.

    [~Switch ModuleA] isis 1
    [*Switch ModuleA-isis-1] is-level level-2
    [*Switch ModuleA-isis-1] network-entity aa.1111.1111.1111.00
    [*Switch ModuleA-isis-1] quit
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] isis enable 1
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] commit

    # Configure Switch ModuleB.

    [~Switch ModuleB] isis 1
    [*Switch ModuleB-isis-1] is-level level-2
    [*Switch ModuleB-isis-1] network-entity aa.2222.2222.2222.00
    [*Switch ModuleB-isis-1] quit
    [*Switch ModuleB] interface vlanif 10
    [*Switch ModuleB-Vlanif10] isis enable 1
    [*Switch ModuleB-Vlanif10] quit
    [*Switch ModuleB] interface vlanif 20
    [*Switch ModuleB-Vlanif20] isis enable 1
    [*Switch ModuleB-Vlanif20] quit
    [*Switch ModuleB] commit

    # Configure Switch ModuleC.

    [~Switch ModuleC] isis 1
    [*Switch ModuleC-isis-1] is-level level-2
    [*Switch ModuleC-isis-1] network-entity aa.3333.3333.3333.00
    [*Switch ModuleC-isis-1] quit
    [*Switch ModuleC] interface vlanif 20
    [*Switch ModuleC-Vlanif20] isis enable 1
    [*Switch ModuleC-Vlanif20] quit
    [*Switch ModuleC] commit

    # After the preceding configurations, you can see that the neighbor relationship is established between Switch ModuleA and Switch ModuleB.

    [~Switch ModuleA] display isis peer
                              Peer information for ISIS(1)
                              ----------------------------
      System Id    Interface         Circuit Id       State HoldTime Type     PRI
    2222.2222.2222 Vlanif10           0000000001        Up   23s      L2       64

    The IS-IS routing table of Switch ModuleA contains the routes to Switch ModuleB and Switch ModuleC.

    [~Switch ModuleA] display isis route
                                                                                    
    Route Information for ISIS(1)                                                   
    --------------------------------------------------------------------------------
                                                                                    
    Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,          
                                   U-Up/Down Bit Set                                
                                                                                    
    ISIS(1) Level-2 Forwarding Table                                                
    --------------------------------------------------------------------------------
                                                                                    
    
     IPV4 Destination    IntCost   ExtCost ExitInterface   NextHop        Flags
    -------------------------------------------------------------------------
     100.1.1.0/24        10        NULL    Vlanif10         Direct       D/-/L/-
     100.2.1.0/24        20        NULL    Vlanif10         100.1.1.2    A/-/L/-

  4. Configure BFD.

    # Enable BFD on Switch ModuleA and configure a BFD session.

    [~Switch ModuleA] bfd
    [*Switch ModuleA-bfd] quit
    [*Switch ModuleA] bfd atob bind peer-ip 100.1.1.2 interface vlanif 10
    [*Switch ModuleA-bfd-session-atob] discriminator local 1
    [*Switch ModuleA-bfd-session-atob] discriminator remote 2
    [*Switch ModuleA-bfd-session-atob] commit
    [*Switch ModuleA-bfd-session-atob] quit
    [*Switch ModuleA] commit

    # Enable BFD on Switch ModuleA and configure a BFD session.

    [~Switch ModuleB] bfd
    [*Switch ModuleB-bfd] quit
    [*Switch ModuleB] bfd btoa bind peer-ip 100.1.1.1 interface vlanif 10
    [*Switch ModuleB-bfd-session-btoa] discriminator local 2
    [*Switch ModuleB-bfd-session-btoa] discriminator remote 1
    [*Switch ModuleB-bfd-session-btoa] quit
    [*Switch ModuleB] commit

    After the preceding configurations, run the display bfd session command on Switch ModuleA or Switch ModuleB, and you can see that the status of the BFD session is Up.

    The following uses the display on Switch ModuleA as an example.

    [~Switch ModuleA] display bfd session all
    S: Static session
    D: Dynamic session
    IP: IP session
    IF: Single-hop session
    PEER: Multi-hop session
    AUTO: Automatically negotiated session
    Total UP/DOWN Session Number : 1/0
    ------------------------------------------------------------------------
    Local Remote PeerIpAddr      State     Type        InterfaceName
    ------------------------------------------------------------------------
    1     2      100.1.1.2        Up      S/IP-IF      Vlanif10          
    ------------------------------------------------------------------------

  5. Enable IS-IS fast detect.

    # Configure Switch ModuleA.

    [~Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] isis bfd static
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] return

    # Configure Switch ModuleB.

    [~Switch ModuleB] interface Vlanif 10
    [*Switch ModuleB-Vlanif10] isis bfd static
    [*Switch ModuleB-Vlanif10] quit
    [*Switch ModuleB] commit

  6. Verify the configuration.

    # Enable debugging on Switch ModuleA.

    <Switch ModuleA> debugging isis adjacency
    <Switch ModuleA> debugging isis circuit-information
    <Switch ModuleA> terminal debugging

    # Run the shutdown command on 10GE1/17/1 of Switch ModuleB to simulate a link fault.

    [~Switch ModuleB] interface 10ge 1/17/1
    [~Switch ModuleB-10GE1/17/1] shutdown
    [*Switch ModuleB-10GE1/17/1] commit

    # On Switch ModuleA, you can view the following log information, which indicates that IS-IS deletes the neighbor relationship with Switch ModuleB after being notified by BFD of the fault.

    #80/active/IsisAdjacencyChange/Major/occurredTime:2011-03-09 04:17:07/-/-/alarmI
    D:0x08960007/VS=0:ISIS adjacency state change. (SysInstance=1, SysLevel=1, CircI
    ndex=2, CircIfIndex=20, LspId=2222.2222.2222.00.00, AdjState=1, IfIndex=20, IfNa
    me=Vlanif10, Reason=BFD detected that the neighbor went Down, SubReason=14)

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10
    #
    bfd
    #
    isis 1
     is-level level-2
     network-entity aa.1111.1111.1111.00
    #
    interface Vlanif10
     ip address 100.1.1.1 255.255.255.0
     isis enable 1
     isis bfd static
    #
    bfd atob bind peer-ip 100.1.1.2 interface Vlanif10
     discriminator local 1
     discriminator remote 2
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 10 20
    #
    bfd
    #
    isis 1
     is-level level-2
     network-entity aa.2222.2222.2222.00
    #
    interface Vlanif10
     ip address 100.1.1.2 255.255.255.0
     isis enable 1
     isis bfd static
    #
    interface Vlanif20
     ip address 100.2.1.1 255.255.255.0
     isis enable 1
    #
    bfd btoa bind peer-ip 100.1.1.1 interface Vlanif10
     discriminator local 2
     discriminator remote 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 20 
    
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 20
    #
    isis 1
     is-level level-2
     network-entity aa.3333.3333.3333.00
    #
    interface Vlanif20
     ip address 100.2.1.2 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return

Example for Configuring Dynamic BFD for IS-IS

Networking Requirements

As shown in Figure 7-89, three devices are interconnected using IS-IS, and SwitchA and SwitchB communicate with each other through a Layer 2 switch. When the link that passes through the switch between SwitchA and SwitchB fails, the two devices need to rapidly respond to the fault, and traffic can be switched to the link that passes through SwitchC for forwarding.

Figure 7-89 Networking diagram of configuring dynamic BFD for IS-IS

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces and enable IS-IS on each device to ensure reachable routes between the devices.

  2. Set the IS-IS interface cost to control route selection of the devices to make the link that passes through the switch from SwitchA to SwitchB as the primary link and the link that passes through SwitchC as the backup link.

  3. Configure dynamic BFD for IS-IS on SwitchA, SwitchB, and SwitchC so that link faults can be detected rapidly and traffic can be switched to the backup link for forwarding.

Procedure

  1. Configure VLANs that each interface belongs to.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 10 20
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10GE 1/17/2
    [*Switch ModuleA-10GE1/17/2] port link-type trunk
    [*Switch ModuleA-10GE1/17/2] port trunk allow-pass vlan 20
    [*Switch ModuleA-10GE1/17/2] commit
    [~Switch ModuleA-10GE1/17/2] quit

    The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here.

  2. Assign the IP addresses for VLANIF interfaces.

    [~Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ip address 1.1.1.1 24
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] interface vlanif 20
    [*Switch ModuleA-Vlanif20] ip address 3.3.3.1 24
    [*Switch ModuleA-Vlanif20] quit
    [*Switch ModuleA-Vlanif20] commit

    The configurations of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned here.

  3. Configure basic IS-IS functions.

    # Configure Switch ModuleA.

    [~Switch ModuleA] isis
    [*Switch ModuleA-isis-1] is-level level-2
    [*Switch ModuleA-isis-1] network-entity 10.0000.0000.0001.00
    [*Switch ModuleA-isis-1] quit
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] isis enable 1
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] interface vlanif 20
    [*Switch ModuleA-Vlanif20] isis enable 1
    [*Switch ModuleA-Vlanif20] commit
    [~Switch ModuleA-Vlanif20] quit

    # Configure Switch ModuleB.

    [~Switch ModuleB] isis
    [*Switch ModuleB-isis-1] is-level level-2
    [*Switch ModuleB-isis-1] network-entity 10.0000.0000.0002.00
    [*Switch ModuleB-isis-1] quit
    [*Switch ModuleB] interface vlanif 30
    [*Switch ModuleB-Vlanif30] isis enable 1
    [*Switch ModuleB-Vlanif30] quit
    [*Switch ModuleB] interface vlanif 20
    [*Switch ModuleB-Vlanif20] isis enable 1
    [*Switch ModuleB-Vlanif20] quit
    [*Switch ModuleB] interface vlanif 40
    [*Switch ModuleB-Vlanif40] isis enable 1
    [*Switch ModuleB-Vlanif40] commit
    [~Switch ModuleB-Vlanif40] quit

    # Configure Switch ModuleC.

    [~Switch ModuleC] isis
    [*Switch ModuleC-isis-1] is-level level-2
    [*Switch ModuleC-isis-1] network-entity 10.0000.0000.0003.00
    [*Switch ModuleC-isis-1] quit
    [*Switch ModuleC] interface vlanif 10
    [*Switch ModuleC-Vlanif10] isis enable 1
    [*Switch ModuleC-Vlanif10] quit
    [*Switch ModuleC] interface vlanif 30
    [*Switch ModuleC-Vlanif30] isis enable 1
    [*Switch ModuleC-Vlanif30] commit
    [~Switch ModuleC-Vlanif30] quit

    # switch moduless learn routes from each other. The following uses the routing table of Switch ModuleA as an example.

    [~Switch ModuleA] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Table: _public_
             Destinations : 8        Routes : 9
    
    
    Destination/Mask      Proto   Pre  Cost     Flags NextHop         Interface
            1.1.1.0/24    Direct  0    0           D  1.1.1.1         Vlanif10
            1.1.1.1/32    Direct  0    0           D  127.0.0.1       InLoopBack0
            2.2.2.0/24    ISIS    15   20          D  1.1.1.2         Vlanif10
            3.3.3.0/24    Direct  0    0           D  3.3.3.1         Vlanif10
            3.3.3.1/32    Direct  0    0           D  127.0.0.1       InLoopBack0
          127.0.0.0/8     Direct  0    0           D  127.0.0.1       InLoopBack0
          127.0.0.1/32    Direct  0    0           D  127.0.0.1       InLoopBack0
          172.16.1.0/24    ISIS   15   20          D  3.3.3.2         Vlanif20

    As shown in the routing table, the next-hop address of the route to 172.16.1.0/24 is 3.3.3.2, and traffic is transmitted on the primary link Switch ModuleA→Switch ModuleB.

  4. Set the interface cost.

    # Configure Switch ModuleA.

    [~Switch ModuleA] interface vlanif 20
    [~Switch ModuleA-Vlanif20] isis cost 5
    [*Switch ModuleA-Vlanif20] commit
    [~Switch ModuleA-Vlanif20] quit

    # Configure Switch ModuleB.

    [~Switch ModuleB] interface vlanif 20
    [~Switch ModuleB-Vlanif20] isis cost 5
    [*Switch ModuleB-Vlanif20] commit
    [~Switch ModuleB-Vlanif20] quit

  5. Configure BFD for IS-IS processes.

    # Enable BFD for IS-IS on Switch ModuleA.

    [~Switch ModuleA] bfd
    [*Switch ModuleA-bfd] quit
    [*Switch ModuleA] isis
    [*Switch ModuleA-isis-1] bfd all-interfaces enable
    [*Switch ModuleA-isis-1] commit
    [~Switch ModuleA-isis-1] quit

    # Enable BFD for IS-IS on Switch ModuleB.

    [~Switch ModuleB] bfd
    [*Switch ModuleB-bfd] quit
    [*Switch ModuleB] isis
    [*Switch ModuleB-isis-1] bfd all-interfaces enable
    [*Switch ModuleB-isis-1] commit
    [~Switch ModuleB-isis-1] quit

    # Enable BFD for IS-IS on Switch ModuleC.

    [~Switch ModuleC] bfd
    [*Switch ModuleC-bfd] quit
    [*Switch ModuleC] isis
    [*Switch ModuleC-isis-1] bfd all-interfaces enable
    [*Switch ModuleC-isis-1] commit
    [~Switch ModuleC-isis-1] quit

    # After the preceding configurations, run the display isis bfd session all command on Switch ModuleA, Switch ModuleB, and Switch ModuleC. You can see that the BFD session status is Up.

    The following uses the display on Switch ModuleA as an example.

    [~Switch ModuleA] display isis bfd session all
                          BFD session information for ISIS(1)
                          -----------------------------------
    Peer System ID : 0000.0000.0002          Interface : Vlanif20
    TX : 1000            BFD State : up      Peer IP Address : 3.3.3.2
    RX : 1000            LocDis : 16385      Local IP Address: 3.3.3.1
    Multiplier : 3       RemDis : 16388      Type : L2
    Diag : No diagnostic information
    
    Peer System ID : 0000.0000.0003          Interface : Vlanif10
    TX : 1000            BFD State : up      Peer IP Address : 1.1.1.2
    RX : 1000            LocDis : 16386      Local IP Address: 1.1.1.1
    Multiplier : 3       RemDis : 16387      Type : L2
    Diag : No diagnostic information
    
    Total BFD session(s): 2                       

    As shown in the preceding display, the status of the BFD session between Switch ModuleA and Switch ModuleB and that between Switch ModuleA and Switch ModuleC is Up.

  6. Configure BFD for IS-IS interfaces.

    # Configure BFD on VLANIF 20 of Switch ModuleA, set the minimum interval for sending packets to 100 ms, the minimum interval for receiving packets to 100 ms, and the local detection multiplier to 4.

    [~Switch ModuleA] interface vlanif 20
    [~Switch ModuleA-Vlanif20] isis bfd enable
    [*Switch ModuleA-Vlanif20] isis bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
    [*Switch ModuleA-Vlanif20] commit
    [~Switch ModuleA-Vlanif20] quit

    # Configure BFD on VLANIF 20 of Switch ModuleB, set the minimum interval for sending packets to 100 ms, the minimum interval for receiving packets to 100 ms, and the local detection multiplier to 4.

    [~Switch ModuleB] interface vlanif 20
    [~Switch ModuleB-Vlanif20] isis bfd enable
    [*Switch ModuleB-Vlanif20] isis bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
    [*Switch ModuleB-Vlanif20] commit
    [~Switch ModuleB-Vlanif20] quit

    # After the preceding configurations, run the display isis bfd session all command on Switch ModuleA or Switch ModuleB. You can see that the BFD parameters have taken effect. The following uses the display on Switch ModuleB as an example.

    [~Switch ModuleB] display isis bfd session all
                          BFD session information for ISIS(1)
                          -----------------------------------
    Peer System ID : 0000.0000.0001        Interface : Vlanif20
    TX : 100           BFD State : up      Peer IP Address : 3.3.3.1
    RX : 100           LocDis : 16385      Local IP Address: 3.3.3.2
    Multiplier : 4     RemDis : 16385      Type : L2
    Diag : No diagnostic information
    
    Peer System ID : 0000.0000.0003        Interface : Vlanif30
    TX : 10            BFD State : up      Peer IP Address : 2.2.2.1
    RX : 10            LocDis : 16385      Local IP Address: 2.2.2.2
    Multiplier : 4     RemDis : 16385      Type : L2
    Diag : No diagnostic information
    
    Total BFD session(s): 2                       

  7. # Run the shutdown command on GigabitEthernet1/0/2 of Switch ModuleB to simulate a primary link failure.

    [~Switch ModuleB] interface 10ge 1/17/2
    [~Switch ModuleB-10GE1/17/2] shutdown
    [*Switch ModuleB-10GE1/17/2] commit

  8. Verify the configuration.

    # View the routing table of Switch ModuleA.

    [~Switch ModuleA] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 9        Routes : 9
    
    Destination/Mask    Proto  Pre  Cost        Flags NextHop         Interface
    
            1.1.1.0/24  Direct 0    0             D  1.1.1.1         Vlanif10
            1.1.1.1/32  Direct 0    0             D  127.0.0.1       Vlanif10
          1.1.1.255/32  Direct 0    0             D  127.0.0.1       Vlanif10
            2.2.2.0/24  ISIS   15   20            D  1.1.1.2         Vlanif10
          127.0.0.0/8   Direct 0    0             D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0
         172.16.1.0/24  ISIS   15   30            D  1.1.1.2         Vlanif10
    255.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0   

    As shown in the routing table, the backup link Switch ModuleA→Switch ModuleC→Switch ModuleB takes effect after the primary link fails, and the next-hop address of the route to 172.16.1.0/24 becomes 1.1.1.2.

    # Run the display isis bfd session all command Switch ModuleA. You can see that the status of the BFD session between Switch ModuleA and Switch ModuleC is Up.

    [~Switch ModuleA] display isis bfd session all
                          BFD session information for ISIS(1)
                          -----------------------------------
    Peer System ID : 0000.0000.0003        Interface : Vlanif10
    TX : 10            BFD State : up      Peer IP Address : 1.1.1.2
    RX : 10            LocDis : 16385      Local IP Address: 1.1.1.1
    Multiplier : 3     RemDis : 16388      Type : L2
    Diag : No diagnostic information
    
    Total BFD session(s): 1                       

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 20
    #
     bfd
    #
    isis 1
     is-level level-2
     bfd all-interfaces enable
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 1.1.1.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif20
     ip address 3.3.3.1 255.255.255.0
     isis enable 1
     isis cost 5
     isis bfd enable
     isis bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 20 30 40
    #
     bfd
    #
    isis 1
     is-level level-2
     bfd all-interfaces enable
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif20
     ip address 3.3.3.2 255.255.255.0
     isis enable 1
     isis cost 5
     isis bfd enable
     isis bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
    #
    interface Vlanif30
     ip address 2.2.2.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif40
     ip address 172.16.1.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 40 
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 10 30
    #
     bfd
    #
    isis 1
     is-level level-2
     bfd all-interfaces enable
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif10
     ip address 1.1.1.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif30
     ip address 2.2.2.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 57335

Downloads: 3617

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next