No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides NQA configuration examples. A networking diagram is provided to demonstrate the configuration procedure in each example.

Example for Configuring an ICMP Test Instance

Networking Requirements

As shown in Figure 14-36, SwitchA, SwitchB, and SwitchC communicate at Layer 3 using VLANIF interfaces.

SwitchA functions as an NQA client to test whether SwitchB is reachable.

Figure 14-36 Networking diagram for configuring an ICMP test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an NQA ICMP test instance to test whether the route between the local device (SwitchA) and the specified destination device (SwitchB) is reachable and check the RTT of a test packet.

Procedure

  1. Create VLANs and add interfaces to the VLANs.

    # Configure SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 10
    [*SwitchA-vlan10] quit
    [*SwitchA] interface 10ge 1/17/1
    [*SwitchA-10GE1/17/1] port link-type trunk
    [*SwitchA-10GE1/17/1] port trunk pvid vlan 10
    [*SwitchA-10GE1/17/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/17/1] commit
    [~SwitchA-10GE1/17/1] quit

    # Configure SwitchB.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan 10
    [*SwitchB-vlan10] quit
    [*SwitchB] interface 10ge 1/17/1
    [*SwitchB-10GE1/17/1] port link-type trunk
    [*SwitchB-10GE1/17/1] port trunk pvid vlan 10
    [*SwitchB-10GE1/17/1] port trunk allow-pass vlan 10
    [*SwitchB-10GE1/17/1] commit
    [~SwitchB-10GE1/17/1] quit

  2. Create VLANIF interfaces and assign IP addresses to the VLANIF interfaces.

    # Configure SwitchA.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 20.20.20.1 24
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit

    # Configure SwitchB.

    [~SwitchB] interface vlanif 10
    [*SwitchB-Vlanif10] ip address 20.20.20.2 24
    [*SwitchB-Vlanif10] commit
    [~SwitchB-Vlanif10] quit

  3. Enable the NQA client and create an ICMP NQA test instance.

    [~SwitchA] nqa test-instance admin icmp
    [*SwitchA-nqa-admin-icmp] test-type icmp
    [*SwitchA-nqa-admin-icmp] destination-address ipv4 20.20.20.2
    [*SwitchA-nqa-admin-icmp] commit

  4. Start the test instance immediately.

    [~SwitchA-nqa-admin-icmp] start now
    [*SwitchA-nqa-admin-icmp] commit

  5. Verify the configuration.

    [~SwitchA-nqa-admin-icmp] display nqa results test-instance admin icmp
                                                                                    
    NQA entry(admin, icmp): test flag is active,test type is ICMP                   
      1 . Test 1 result   The test is finished                                      
       Send operation times: 3                Receive response times: 3             
       Completion:success                     RTD over thresholds number:0           
       Attempts number:1                      Drop operation number:0               
       Disconnect operation number:0          Operation timeout number:0            
       System busy operation number:0         Connection fail number:0              
       Operation sequence errors number:0     RTT Status errors number:0             
       Destination IP address:20.20.20.2                                             
       Min/Max/Average completion time: 2/5/3                                       
       Sum/Square-Sum  completion time: 9/33                                        
       Last response packet receiving time: 2012-08-08 15:53:08.4                                  
       Lost packet ratio: 0 %                                       

Configuration Files
  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 20.20.20.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10
    #
    nqa test-instance admin icmp
     test-type icmp
     destination-address ipv4 20.20.20.2
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 20.20.20.2 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10
    #
    return

Example for Configuring an ICMP Jitter Test Instance

Networking Requirements

As shown in Figure 14-37, SwitchA, SwitchB, and SwitchC communicate at Layer 3 using VLANIF interfaces.

SwitchA functions as the NQA client to test the jitter of the network between SwtichA and SwtichB.

Figure 14-37 Networking diagram for configuring an ICMP jitter test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwtichA as an NQA client and create an ICMP jitter test instance on SwtichA.

Procedure

  1. Create VLANs and add interfaces to the VLANs.

    # Configure SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 10
    [*SwitchA-vlan10] quit
    [*SwitchA] interface 10ge 1/17/1
    [*SwitchA-10GE1/17/1] port link-type trunk
    [*SwitchA-10GE1/17/1] port trunk pvid vlan 10
    [*SwitchA-10GE1/17/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/17/1] commit
    [~SwitchA-10GE1/17/1] quit

    # Configure SwitchB.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan 10
    [*SwitchB-vlan10] quit
    [*SwitchB] interface 10ge 1/17/1
    [*SwitchB-10GE1/17/1] port link-type trunk
    [*SwitchB-10GE1/17/1] port trunk pvid vlan 10
    [*SwitchB-10GE1/17/1] port trunk allow-pass vlan 10
    [*SwitchB-10GE1/17/1] commit
    [~SwitchB-10GE1/17/1] quit

  2. Create VLANIF interfaces and assign IP addresses to the VLANIF interfaces.

    # Configure SwitchA.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 20.20.20.1 24
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit

    # Configure SwitchB.

    [~SwitchB] interface vlanif 10
    [*SwitchB-Vlanif10] ip address 20.20.20.2 24
    [*SwitchB-Vlanif10] commit
    [~SwitchB-Vlanif10] quit

  3. # Enable the NQA client and create an ICMP jitter NQA test instance.

    [~SwitchA] nqa test-instance admin icmpjitter
    [*SwitchA-nqa-admin-icmpjitter] test-type icmpjitter
    [*SwitchA-nqa-admin-icmpjitter] destination-address ipv4 20.20.20.2
    [*SwitchA-nqa-admin-icmpjitter] commit

  4. Start the test instance immediately.

    [~SwitchA-nqa-admin-icmpjitter] start now
    [*SwitchA-nqa-admin-icmpjitter] commit

  5. Verify the configuration.

    [~SwitchA-nqa-admin-icmpjitter] display nqa results test-instance admin icmpjitter                                                                         
                                                                                    
    NQA entry(admin, icmpjitter): test flag is inactive, test type is ICMPJITTER    
      1 . Test 1 result   The test is finished                                      
       SendProbe: 60                          ResponseProbe: 60                     
       Completion: success                    RTD over thresholds number: 0         
       OWD over thresholds SD number: 0       OWD over thresholds DS number: 0      
       Min/Max/Avg/Sum RTT: 1/5/2/128         RTT square sum: 294                   
       Num of RTT: 60                         Drop operation number: 0              
       Operation sequence errors number: 0    RTT Status errors number: 0            
       System busy operation number: 0        Operation timeout number: 0           
       Min positive SD: 1                     Min positive DS: 1                    
       Max positive SD: 3                     Max positive DS: 1                    
       Positive SD number: 10                 Positive DS number: 9                 
       Positive SD sum: 12                    Positive DS sum: 9                    
       Positive SD square sum: 18             Positive DS square sum: 9             
       Min negative SD: 1                     Min negative DS: 1                    
       Max negative SD: 4                     Max negative DS: 5                    
       Negative SD number: 10                 Negative DS number: 9                 
       Negative SD sum: 13                    Negative DS sum: 13                   
       Negative SD square sum: 25             Negative DS square sum: 33            
       Min delay SD: 1                        Min delay DS: 0                       
       Avg delay SD: 0                        Avg delay DS: 0                       
       Max delay SD: 2                        Max delay DS: 2                       
       Delay SD square sum: 59                Delay DS square sum: 13               
       Packet loss SD: 0                      Packet loss DS: 0                     
       Packet loss unknown: 0                 Average of jitter: 1                  
       Average of jitter SD: 1                Average of jitter DS: 1               
       Jitter out value: 0.3360330            Jitter in value: 0.3163250            
       Number of OWD: 60                      Packet loss ratio: 0 %                
       OWD SD sum: 57                         OWD DS sum: 11                        
       ICPIF value: 0                         MOS-CQ value: 0                       
       TimeStamp unit: ms                                          

Configuration Files
  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 20.20.20.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10
    #
    nqa test-instance admin icmpjitter
     test-type icmpjitter
     destination-address ipv4 20.20.20.2
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 20.20.20.2 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10
    #
    return

Example for Configuring a TCP Test Instance

Networking Requirements

The NQA TCP test instance is used to obtain the time for setting up a TCP connection between SwitchA and SwitchC, as shown in the Figure 14-38.

Figure 14-38 Networking diagram for configuring a TCP test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure switchA as an NQA client and SwtichC as an NQA server.

  2. Configure the monitoring port number on the NQA server and create an NQA TCP test instance on the NQA client.

Procedure

  1. Configure each interface and ensure reachable routes between Switch Modulees, as shown in Figure 14-38.

    # Configure SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 100
    [*SwitchA-vlan100] quit
    [*SwitchA] interface 10ge 1/17/1
    [*SwitchA-10GE1/17/1] port link-type trunk
    [*SwitchA-10GE1/17/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/17/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/17/1] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] quit
    [*SwitchA] ip route-static 10.2.1.0 24 10.1.1.2
    [*SwitchA] commit
    NOTE:

    For configurations of Switch ModuleB and Switch ModuleC, see the configuration files.

  2. Configure the NQA server on SwitchC.

    # Configure the IP address and port number for monitoring TCP connections on the NQA server.

    <SwitchC> system-view
    [~SwitchC] nqa server tcpconnect 10.2.1.2 9000
    [*SwitchC] commit

  3. Configure SwitchA.

    # Enable the NQA client and create a TCP Private test instance.

    [~SwitchA] nqa test-instance admin tcp
    [*SwitchA-nqa-admin-tcp] test-type tcp
    [*SwitchA-nqa-admin-tcp] destination-address ipv4 10.2.1.2
    [*SwitchA-nqa-admin-tcp] destination-port 9000 
    [*SwitchA-nqa-admin-tcp] commit 

  4. Start the test instance.

    [~SwitchA-nqa-admin-tcp] start now
    [*SwitchA-nqa-admin-tcp] commit

  5. Verify the configuration.

    [~SwitchA-nqa-admin-tcp] display nqa results test-instance admin tcp
                                                                                    
    NQA entry(admin, tcp): test flag is active,test type is TCP                      
      1 . Test 1 result   The test is finished                                      
       Send operation times: 3                Receive response times: 3             
       Completion:success                     RTD over thresholds number:0           
       Attempts number:1                      Drop operation number:0               
       Disconnect operation number:0          Operation timeout number:0            
       System busy operation number:0         Connection fail number:0              
       Operation sequence errors number:0     RTT Status errors number:0             
       Destination IP address:10.2.1.2                                             
       Min/Max/Average completion time: 103/133/114                                 
       Sum/Square-Sum  completion time: 343/39747                                   
       Last response packet receiving time: 2012-08-09 00:24:06.1                                  
       Lost packet ratio: 0 %                            

Configuration Files
  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
     ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin tcp
     test-type tcp
     destination-address ipv4 10.2.1.2
     destination-port 9000
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 100 110
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    
    #
     nqa server tcpconnect 10.2.1.2 9000
    #
     ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return

Example for Configuring a UDP Jitter Test Instance

Networking Requirements

The NQA jitter test instance is used to obtain the jitter time of transmitting a packet from SwitchA to SwitchC, as shown in Figure 14-39.

Figure 14-39 Networking diagram for configuring a UDP Jitter test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchA as an NQA client and SwtichC as an NQA server.

  2. Configure the monitoring IP address and port number on the NQA server, and configure a jitter test instance on the NQA client.

Procedure

  1. Configure each interface and ensure reachable routes between Switch Modulees, as shown in Figure 14-39.

    # Configure SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 100
    [*SwitchA-vlan100] quit
    [*SwitchA] interface 10ge 1/17/1
    [*SwitchA-10GE1/17/1] port link-type trunk
    [*SwitchA-10GE1/17/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/17/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/17/1] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] quit
    [*SwitchA] ip route-static 10.2.1.0 24 10.1.1.2
    [*SwitchA] commit
    NOTE:

    For configurations of Switch ModuleB and Switch ModuleC, see the configuration files.

  2. Configure the NQA server on SwitchC.

    # Configure the IP address and port number for monitoring UDP services on the NQA server.

    <SwitchC> system-view
    [~SwitchC] nqa server udpecho 10.2.1.2 9000
    [*SwitchC] commit

  3. Configure SwitchA.

    # Enable the NQA client and create an NQA jitter test instance.

    [~SwitchA] nqa test-instance admin jitter
    [*SwitchA-nqa-admin-jitter] test-type jitter
    [*SwitchA-nqa-admin-jitter] destination-address ipv4 10.2.1.2
    [*SwitchA-nqa-admin-jitter] destination-port 9000 
    [*SwitchA-nqa-admin-jitter] commit 

  4. Start the test instance.

    [~SwitchA-nqa-admin-jitter] start now
    [*SwitchA-nqa-admin-jitter] commit

  5. Verify the configuration.

    [~SwitchA-nqa-admin-jitter] display nqa results test-instance admin jitter
    
    NQA entry(admin, jitter): test flag is inactive, test type is JITTER
      1 . Test 1 result   The test is finished
       SendProbe: 60                          ResponseProbe: 60                     
       Completion: success                    RTD over thresholds number: 0         
       OWD over thresholds SD number: 0       OWD over thresholds DS number: 0      
       Min/Max/Avg/Sum RTT: 2/77/7/401        RTT square sum: 11877                 
       Num of RTT: 60                         Drop operation number: 0              
       Operation sequence errors number: 0    RTT Status errors number: 0           
       System busy operation number: 0        Operation timeout number: 0           
       Min positive SD: 1                     Min positive DS: 1                    
       Max positive SD: 10                    Max positive DS: 2                    
       Positive SD number: 7                  Positive DS number: 14                
       Positive SD sum: 16                    Positive DS sum: 16                   
       Positive SD square sum: 106            Positive DS square sum: 20            
       Min negative SD: 1                     Min negative DS: 1                    
       Max negative SD: 10                    Max negative DS: 21                   
       Negative SD number: 9                  Negative DS number: 18                
       Negative SD sum: 18                    Negative DS sum: 88                   
       Negative SD square sum: 108            Negative DS square sum: 1368          
       Min delay SD: 1                        Min delay DS: 0                       
       Avg delay SD: 3                        Avg delay DS: 2                       
       Max delay SD: 38                       Max delay DS: 38                      
       Delay SD square sum: 2858              Delay DS square sum: 2723             
       Packet loss SD: 0                      Packet loss DS: 0                     
       Packet loss unknown: 0                 Average of jitter: 2                  
       Average of jitter SD: 2                Average of jitter DS: 3               
       Jitter out value: 0.4763590            Jitter in value: 1.5859300            
       Number of OWD: 60                      Packet loss ratio: 0 %                
       OWD SD sum: 184                        OWD DS sum: 157                       
       ICPIF value: 0                         MOS-CQ value: 0                       
       TimeStamp unit: ms

Configuration Files
  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
     ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin jitter
     test-type jitter
     destination-address ipv4 10.2.1.2
     destination-port 9000
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 100 110
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
     nqa server udpecho 10.2.1.2 9000
    #
     ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 59766

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next