No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides configuration examples of RIPng, including networking requirements, configuration notes, and configuration roadmap.

Example for Configuring Basic RIPng Functions

This section describes how to configure basic RIPng functions.

Networking Requirements

As shown in Figure 7-29, it is required that RIPng be enabled on all interfaces of Switch A, Switch B, Switch C, and Switch D and the switches communicate through RIPng.

Figure 7-29 Networking diagram of configuring basic RIPng functions

Configuration Notes

When configuring basic RIPng functions, note the following:

  • RIPng takes effect only after IPv6 is enabled on interfaces.

  • Enable RIPng on switches and configure RIPng basic functions.

Procedure

  1. Configure IPv6 addresses for interfaces. The configuration details are not described here.
  2. Configure basic RIPng functions.

    # Configure Switch A.

    [~SwitchA] ripng 1
    [*SwitchA-ripng-1] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ipv6 enable
    [*SwitchA-Vlanif100] ripng 1 enable
    [*SwitchA-Vlanif100] quit
    [*SwitchA] commit

    # Configure Switch B.

    [~SwitchB] ripng 1
    [*SwitchB-ripng-1] quit
    [*SwitchB] interface vlanif 100
    [*SwitchB-Vlanif100] ipv6 enable
    [*SwitchB-Vlanif100] ripng 1 enable
    [*SwitchB-Vlanif100] quit
    [*SwitchB] interface vlanif 200
    [*SwitchB-Vlanif200] ipv6 enable
    [*SwitchB-Vlanif200] ripng 1 enable
    [*SwitchB-Vlanif200] quit
    [*SwitchB] interface vlanif 300
    [*SwitchB-Vlanif300] ipv6 enable
    [*SwitchB-Vlanif300] ripng 1 enable
    [*SwitchB-Vlanif300] quit
    [*SwitchB] commit

    # Configure Switch C.

    [~SwitchC] ripng 1
    [*SwitchC-ripng-1] quit
    [*SwitchC] interface vlanif 200
    [*SwitchC-Vlanif200] ipv6 enable
    [*SwitchC-Vlanif200] ripng 1 enable
    [*SwitchC-Vlanif200] quit
    [*SwitchC] commit

    # Configure Switch D.

    [~SwitchD] ripng 1
    [*SwitchD-ripng-1] quit
    [*SwitchD] interface vlanif 300
    [*SwitchD-Vlanif300] ipv6 enable
    [*SwitchD-Vlanif300] ripng 1 enable
    [*SwitchD-Vlanif300] quit
    [*SwitchD] commit

  3. Verify the configuration.

    # View RIPng neighbors of Switch A.

    [~SwitchA] display ripng 1 neighbor
     Neighbor  :  FE80::225:9EFF:FE01:21C Vlanif100                                  
        Protocol : RIPNG  

    The command output shows that Switch A has established the neighbor relationship with Switch B on the network.

    # View RIPng routing information of Switch A.

    [~SwitchA] display ripng 1 route
     Route Flags: A - Aging,  S - Suppressed,  G - Garbage-collect                  
     ----------------------------------------------------------------------------   
     Peer FE80::225:9EFF:FE01:21C on Vlanif100                                       
     Dest 2000::/24,                                                                  
         via FE80::225:9EFF:FE01:21C, cost  1, tag 0, A, 4 Sec                      
     Dest 3000::/24,                                                                 
         via FE80::225:9EFF:FE01:21C, cost  1, tag 0, A, 4 Sec 

    The command output shows that Switch A has learned routing information on the network.

Configuration Files
  • Configuration file of Switch A

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif 100
     ipv6 enable
     ipv6 address 1000::1/24
     ripng 1 enable
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    ripng 1
    #
    return
  • Configuration file of Switch B

    #
    sysname SwitchB
    #
    vlan batch 100 200 300
    #
    interface Vlanif 100
     ipv6 enable
     ipv6 address 1000::2/24
     ripng 1 enable
    #
    interface Vlanif 200
     ipv6 enable
     ipv6 address 2000::1/24
     ripng 1 enable
    #
    interface Vlanif 300
     ipv6 enable
     ipv6 address 3000::1/24
     ripng 1 enable
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    ripng 1
    #
    return
  • Configuration file of Switch C

    #
    sysname SwitchC
    #
    vlan batch 200
    #
    interface Vlanif 200
     ipv6 enable
     ipv6 address 2000::2/24
     ripng 1 enable
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    ripng 1
    #
    return
  • Configuration file of Switch D

    #
    sysname SwitchD
    #
    vlan batch 300
    #
    interface Vlanif 300
     ipv6 enable
     ipv6 address 3000::2/24
     ripng 1 enable
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    ripng 1
    #
    return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 58556

Downloads: 3621

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next