No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides configuration examples including networking requirements and configuration roadmap.

Example for Configuring NLB Cluster Association

Networking Requirements

As shown in Figure 10-69, Switch_1 connects to three NLB servers through interfaces 10GE1/17/1, 10GE1/17/2, and 10GE1/17/3 respectively. The three interfaces belong to VLAN 10. The NLB group works in multicast mode. Each server in the NLB group has its own IP address and MAC address. The servers also share virtual IP address 10.128.246.252/24 and virtual MAC address 03bf-0a80-f6fc.

When the client attempts to connect to the virtual IP address of the NLB group, Switch_1 needs to forward packets destined for the group virtual IP address to all servers in the NLB group.

Figure 10-69 Networking diagram for configuring multi-interface ARP
Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces and add the interfaces to VLANs.
  2. Configure a multi-interface MAC address entry and a static ARP entry so that Switch_1 can forward packets destined for the group virtual IP address to the three servers in the NLB group.

Procedure

  1. Create VLANs and add interfaces to these VLANs.

    # On Switch_1, create VLANs and add interfaces to these VLANs.
    <HUAWEI> system-view
    [~HUAWEI] sysname Switch_1
    [*HUAWEI] commit
    [~Switch_1] vlan batch 10 20
    [*Switch_1] vlan 10
    [*Switch_1-vlan10] port 10ge 1/17/1 to 1/17/3
    [*Switch_1-vlan10] quit
    [*Switch_1] interface 10ge 1/17/4
    [*Switch_1-10GE1/17/4] port link-type trunk
    [*Switch_1-10GE1/17/4] port trunk allow-pass vlan 20
    [*Switch_1-10GE1/17/4] quit
    [*Switch_1] commit
    # On Switch_2, create a VLAN and add the interface to the VLAN.
    <HUAWEI> system-view
    [~HUAWEI] sysname Switch_2
    [*HUAWEI] commit
    [~Switch_2] vlan batch 20
    [*Switch_2] interface 10ge 1/17/1
    [*Switch_2-10GE1/17/1] port link-type trunk
    [*Switch_2-10GE1/17/1] port trunk allow-pass vlan 20
    [*Switch_2-10GE1/17/1] quit
    [*Switch_2] commit

  2. On Switch_1, create interfaces VLANIF10 and VLANIF20 and configure IP addresses for them.

    [~Switch_1] interface vlanif 10
    [~Switch_1-Vlanif10] ip address 10.128.246.251 24
    [*Switch_1-Vlanif10] quit
    [*Switch_1] interface vlanif 20
    [*Switch_1-Vlanif20] ip address 20.20.20.1 24
    [*Switch_1-Vlanif20] quit
    [*Switch_1] commit

  3. On Switch_1, configure a multi-interface MAC address entry.

    [~Switch_1] mac-address multiport 03bf-0a80-f6fc interface 10ge 1/17/1 to 10ge 1/17/3 vlan 10
    [*Switch_1] commit

  4. On Switch_1, configure a static ARP entry.

    [~Switch_1] arp static 10.128.246.252 03bf-0a80-f6fc
    [*Switch_1] commit
    [~Switch_1] quit

  5. Verify the configuration.

    # On Switch_1, run the display mac-address multiport vlan 10 command to check the multi-interface MAC address table.

    <Switch_1> display mac-address multiport vlan 10
    --------------------------------------------------------------------
    MAC Address         VLANID         Out-Interface                    
    --------------------------------------------------------------------
    03bf-0a80-f6fc      10             10GE1/17/1                        
                                       10GE1/17/2                        
                                       10GE1/17/3                        
                                               3 port(s)                
    --------------------------------------------------------------------
     Total Group(s) : 1 

    # On Switch_1, run the display arp static command to check the static ARP mapping table.

    <Switch_1> display arp static
    ARP Entry Types: D - Dynamic, S - Static, I - Interface                      
    EXP: Expire-time
                                                                                 
    IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE 
    ------------------------------------------------------------------------------
    10.128.246.252  03bf-0a80-f6fc        S/10      Multi-port:3                  
    ------------------------------------------------------------------------------
    Total:1         Dynamic:0       Static:1    Interface:0  

Configuration Files
  • Configuration file of Switch_1

    #
    sysname Switch_1
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 10.128.246.251 255.255.255.0
    #
    interface Vlanif20
     ip address 20.20.20.1 255.255.255.0
    #
    interface 10GE1/17/1
     port default vlan 10
     mac-address multiport 03bf-0a80-f6fc vlan 10 
    #
    interface 10GE1/17/2
     port default vlan 10
     mac-address multiport 03bf-0a80-f6fc vlan 10
    #
    interface 10GE1/17/3
     port default vlan 10
     mac-address multiport 03bf-0a80-f6fc vlan 10
    #
    interface 10GE1/17/4
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    arp static 10.128.246.252 03bf-0a80-f6fc
    #
    return
    
  • Configuration file of Switch_2

    #
    sysname Switch_2
    #
    vlan batch 20
    #
    interface 10GE1/17/1
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return
    
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 57535

Downloads: 3619

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next