No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides configuration examples of TRILL. Refer to the networking diagrams to help familiarize yourself with the configuration. The configuration examples include networking requirements and configuration roadmap.

Example for Configuring Basic TRILL Functions

Networking Requirements
Figure 10-33 shows a data center network. It is required that an unblocked Layer network be constructed, multi-path forwarding be implemented, and each network node can implement line-speed forwarding.
NOTE:

In the figure, 10GE1 indicates 10GE1/17/1, 10GE2 indicates 10GE1/17/2, and 10GE3 indicates 10GE1/17/3.

Figure 10-33 Networking for configuring basic TRILL functions

Configuration Roadmap

Using TRILL to construct a Layer 2 network can meet the requirements. The configuration roadmap is as follows:

  1. Enable TRILL globally on five RBs so that the RBs can process TRILL packets.

  2. Configure mandatory parameters such as the VLAN, NET, and nickname.

  3. Enable TRILL on the interfaces connecting the five RBs so that the interfaces can send and receive TRILL packets.

  4. Configure an admin VLAN on each of five RBs so that the administrators can manage devices using the NMS.

Procedure

  1. Enable TRILL on each RB, and configure their VLANs, NETs, and nicknames.

    # Configure RB1.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB1
    [*HUAWEI] commit
    [~RB1] vlan 100
    [*RB1-vlan100] commit
    [~RB1-vlan100] quit
    [~RB1] trill
    [*RB1-trill] carrier-vlan 10
    [*RB1-trill] ce-vlan 100
    [*RB1-trill] network-entity 00.0000.0000.1111.00
    [*RB1-trill] nickname 100
    [*RB1-trill] commit
    [~RB1-trill] quit

    # Configure RB2.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB2
    [*HUAWEI] commit
    [~RB2] vlan 100
    [*RB2-vlan100] commit
    [~RB2-vlan100] quit
    [~RB2] trill
    [*RB2-trill] carrier-vlan 10
    [*RB2-trill] ce-vlan 100
    [*RB2-trill] network-entity 00.0000.0000.2222.00
    [*RB2-trill] nickname 200
    [*RB2-trill] commit
    [~RB2-trill] quit

    # Configure RB3.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB3
    [*HUAWEI] commit
    [~RB3] vlan 100
    [*RB3-vlan100] commit
    [~RB3-vlan100] quit
    [~RB3] trill
    [*RB3-trill] carrier-vlan 10
    [*RB3-trill] ce-vlan 100
    [*RB3-trill] network-entity 00.0000.0000.3333.00
    [*RB3-trill] nickname 300
    [*RB3-trill] commit
    [~RB3-trill] quit

    # Configure RB4.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB4
    [*HUAWEI] commit
    [~RB4] trill
    [*RB4-trill] carrier-vlan 10
    [*RB4-trill] network-entity 00.0000.0000.4444.00
    [*RB4-trill] nickname 400
    [*RB4-trill] commit
    [~RB4-trill] quit

    # Configure RB5.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB5
    [*HUAWEI] commit
    [~RB5] trill
    [*RB5-trill] carrier-vlan 10
    [*RB5-trill] network-entity 00.0000.0000.5555.00
    [*RB5-trill] nickname 500
    [*RB5-trill] commit
    [~RB5-trill] quit

  2. Configure TRILL on each interface.

    # Enable TRILL on the interface of RB1.

    [~RB1] interface 10ge 1/17/1
    [~RB1-10GE1/17/1] undo shutdown
    [~RB1-10GE1/17/1] port link-type trunk
    [*RB1-10GE1/17/1] trill enable
    [*RB1-10GE1/17/1] quit
    [*RB1] interface 10ge 1/17/2
    [*RB1-10GE1/17/2] undo shutdown
    [*RB1-10GE1/17/2] port link-type trunk
    [*RB1-10GE1/17/2] trill enable
    [*RB1-10GE1/17/2] quit
    [*RB1] interface 10ge 1/17/3
    [*RB1-10GE1/17/3] undo shutdown
    [*RB1-10GE1/17/3] port default vlan 100
    [*RB1-10GE1/17/3] commit
    [~RB1-10GE1/17/3] quit

    The configurations on other RBs are similar to that on RB1. For detailed configurations, see Configuration Files.

  3. Configure admin VLAN

    # Configure an admin VLAN on each device of the TRILL network, configure VLANIF interfaces for the admin VLANs and configure an IP address for each VLANIF interface. RB1 is used as an example here.

    [~RB1] vlan 50
    [*RB1-vlan50] quit
    [*RB1] interface vlanif 50
    [*RB1-Vlanif50] ip address 192.168.10.1 24
    [*RB1-Vlanif50] quit
    [*RB1] trill
    [*RB1-trill] admin-vlan 50
    [*RB1-trill] commit
    [~RB1-trill] quit

    The configurations on other RBs are similar to that on RB1. For detailed configurations, see Configuration Files.

  4. Check the TRILL database and unicast routing table of each RB.

    # Run the display trill interface command to view information about the TRILL-enabled interface on each RB. RB1 is used as an example here.

    [~RB1] display trill interface
      
    Interface information for TRILL
    -------------------------------------------------------------------
    Total Interface(s): 2
    
    Interface  Circuit-ID  State            MTU Type  DRB-State   DVLAN
    -------------------------------------------------------------------
    10GE1/17/1         001  UP              1497 L1    Non-DRB     10
    10GE1/17/2         002  UP              1497 L1    Non-DRB     10
    

    # Run the display trill nickname command to view the nickname of each RB. RB1 is used as an example here.

    [~RB1] display trill nickname
     
    Nickname information for TRILL
    ------------------------------------------------------------------
    *-Local Nickname, A-Advertised, S-Suppressed / S-Static, D-Dynamic
    
    Total Nickname(s): 5
    
      Nickname Source ID         State Priority RootPri
    ---------------------------------------------------
    *      100 0000.0000.1111    A/S        192   32768
           200 0000.0000.2222    A/S        192   32768
           300 0000.0000.3333    A/S        192   32768
           400 0000.0000.4444    A/S        192   32768
           500 0000.0000.5555    A/S        192   32768
    

    # Run the display trill route command to view the unicast routing table of each RB. RB1 is used as an example here.

    [~RB1] display trill route
     
    TRILL Unicast Routing Table
    -------------------------------------------------------------------
    Flags: D-Download To Fib
    
    Total Route(s): 4
    
    Nickname       Cost Flag OutInterface  OuterVlan NextHop        Hop
    -------------------------------------------------------------------
         200       4000 D    10GE1/17/1            10 3609-b654-1220   2
                             10GE1/17/2            10 3609-b655-1220   2
         300       4000 D    10GE1/17/2            10 3609-b665-1220   2
         400       2000 D    10GE1/17/1            10 3609-b664-1220   1
         500       2000 D    10GE1/17/2            10 3609-b665-1220   1
    

  5. Disable load balancing on RB1 by setting the number of equal-cost routes for load balancing to 1.

    [~RB1] trill
    [*RB1-trill] maximum load-balance 1
    [*RB1-trill] commit

    # Check the unicast routing table of RB1.

    [~RB1-trill] display trill route
     
    TRILL Unicast Routing Table
    -------------------------------------------------------------------
    Flags: D-Download To Fib
    
    Total Route(s): 4
    
    Nickname       Cost Flag OutInterface  OuterVlan NextHop        Hop
    -------------------------------------------------------------------
         200       4000 D    10GE1/17/1            10 3609-b654-1220   2
         300       4000 D    10GE1/17/2            10 3609-b665-1220   2
         400       2000 D    10GE1/17/1            10 3609-b664-1220   1
         500       2000 D    10GE1/17/2            10 3609-b665-1220   1
    

    The preceding table shows that the outbound interface of the route to Nickname 200 is 10GE1/17/1. After the maximum number of equal-cost routes for load balancing is configured to 1, the route with the next hop RB4 is selected as the optimal route because RB4 has a smaller interface index.

  6. Restore the default number of equal-cost routes for load balancing on RB1.

    [*RB1-trill] undo maximum load-balance
    [*RB1-trill] commit

    # Check the TRILL unicast routing table of RB1.

    [~RB1-trill] display trill route
     
    TRILL Unicast Routing Table
    -------------------------------------------------------------------
    Flags: D-Download To Fib
    
    Total Route(s): 4
    
    Nickname       Cost Flag OutInterface  OuterVlan NextHop        Hop
    -------------------------------------------------------------------
         200       4000 D    10GE1/17/1            10 3609-b654-1220   2
                             10GE1/17/2            10 3609-b655-1220   2
         300       4000 D    10GE1/17/2            10 3609-b665-1220   2
         400       2000 D    10GE1/17/1            10 3609-b664-1220   1
         500       2000 D    10GE1/17/2            10 3609-b665-1220   1
    

    The preceding table shows the valid routes with the next hops RB4 (3609-b654-1220) and RB5 (3609-b655-1220) of RB1. By default, the maximum number of equal-cost routes for load balancing is 16.

Configuration Files
  • Configurations files of RB1

    #
    sysname RB1
    #
    vlan batch 50 100
    #
    trill
     network-entity 00.0000.0000.1111.00
     nickname 100
     carrier-vlan 10
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif50
     ip address 192.168.10.1 255.255.255.0 
    #
    interface 10GE1/17/1
     port link-type hybrid
     undo port hybrid untagged vlan 1
     trill enable 
    #
    interface 10GE1/17/2
     port link-type hybrid
     undo port hybrid untagged vlan 1
     trill enable 
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #               
    return
  • Configurations files of RB2

    #
    sysname RB2
    #
    vlan batch 50 100
    #
    trill
     network-entity 00.0000.0000.2222.00
     nickname 200
     carrier-vlan 10
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif50
     ip address 192.168.10.2 255.255.255.0 
    #
    interface 10GE1/17/1
     port link-type hybrid
     undo port hybrid untagged vlan 1
     trill enable 
    #
    interface 10GE1/17/2
     port link-type hybrid
     undo port hybrid untagged vlan 1
     trill enable 
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #               
    return
  • Configurations files of RB3

    #
    sysname RB3
    #
    vlan batch 50 100
    #
    trill
     network-entity 00.0000.0000.3333.00
     nickname 300
     carrier-vlan 10
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif50
     ip address 192.168.10.3 255.255.255.0 
    #
    interface 10GE1/17/1
     port link-type hybrid
     undo port hybrid untagged vlan 1
     trill enable 
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #               
    return
  • Configurations files of RB4

    #
    sysname RB4
    #
    vlan batch 50
    #
    trill
     network-entity 00.0000.0000.4444.00
     nickname 400
     carrier-vlan 10
     admin-vlan 50
    #
    interface Vlanif50
     ip address 192.168.10.4 255.255.255.0 
    #
    interface 10GE1/17/1
     port link-type hybrid
     undo port hybrid untagged vlan 1
     trill enable 
    #
    interface 10GE1/17/2
     port link-type hybrid
     undo port hybrid untagged vlan 1
     trill enable 
    #               
    return
  • Configurations files of RB5

    #
    sysname RB5
    #
    vlan batch 50
    #
    trill
     network-entity 00.0000.0000.5555.00
     nickname 500
     carrier-vlan 10
     admin-vlan 50
    #
    interface Vlanif50
     ip address 192.168.10.5 255.255.255.0 
    #
    interface 10GE1/17/1
     port link-type hybrid
     undo port hybrid untagged vlan 1
     trill enable 
    #
    interface 10GE1/17/2
     port link-type hybrid
     undo port hybrid untagged vlan 1
     trill enable 
    #
    interface 10GE1/17/3
     port link-type hybrid
     undo port hybrid untagged vlan 1
     trill enable 
    #
    return

Example for Configuring the Association Between MSTP and TRILL

Networking Requirements

As shown in Figure 10-34, an enterprise's data center network originally runs MSTP to avoid loops. The customer plans to expand the network capacity to construct a large Layer 2 network using TRILL. It is required that the original MSTP network be dual-homed to the TRILL network to implement seamless expansion.

Figure 10-34 Networking for configuring the association between MSTP and TRILL

Configuration Roadmap

As the MSTP network needs to be dual-homed to the TRILL network, you are advised to configure the association between MSTP and TRILL to avoid loops. The configuration roadmap is as follows:

  1. Configure basic TRILL functions on devices in the new network so that the devices can communicate with each other using TRILL.

  2. Configure the association between MSTP and TRILL on the edge device connecting the TRILL network to the MSTP network so that loops are avoided and the TC packets of the MSTP network can be sent through the TRILL network.

Procedure

  1. Enable TRILL on each RB, and configure their VLANs, NETs, and nicknames.

    # Configure RB1.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB1
    [*HUAWEI] commit
    [~RB1] trill
    [*RB1-trill] carrier-vlan 10
    [*RB1-trill] network-entity 00.0000.0000.1111.00
    [*RB1-trill] nickname 100
    [*RB1-trill] commit
    [~RB1-trill] quit

    # Configure RB2.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB2
    [*HUAWEI] commit
    [~RB2] vlan 100
    [*RB2-vlan100] commit
    [~RB2-vlan100] quit
    [~RB2] trill
    [*RB2-trill] carrier-vlan 10
    [*RB2-trill] ce-vlan 100
    [*RB2-trill] network-entity 00.0000.0000.2222.00
    [*RB2-trill] nickname 200
    [*RB2-trill] commit
    [~RB2-trill] quit

    # Configure RB3.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB3
    [*HUAWEI] commit
    [~RB3] vlan 100
    [*RB3-vlan100] commit
    [~RB3-vlan100] quit
    [~RB3] trill
    [*RB3-trill] carrier-vlan 10
    [*RB3-trill] ce-vlan 100
    [*RB3-trill] network-entity 00.0000.0000.3333.00
    [*RB3-trill] nickname 300
    [*RB3-trill] commit
    [~RB3-trill] quit

    # Configure RB4.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB4
    [*HUAWEI] commit
    [~RB4] vlan 100
    [*RB4-vlan100] commit
    [~RB4-vlan100] quit
    [~RB4] trill
    [*RB4-trill] carrier-vlan 10
    [*RB4-trill] ce-vlan 100
    [*RB4-trill] network-entity 00.0000.0000.4444.00
    [*RB4-trill] nickname 400
    [*RB4-trill] commit
    [~RB4-trill] quit

  2. Configure TRILL on each interface.

    # Configure RB1.

    [~RB1] interface 10ge 1/17/1
    [~RB1-10GE1/17/1] port link-type hybrid
    [*RB1-10GE1/17/1] trill enable
    [*RB1-10GE1/17/1] quit
    [*RB1] interface 10ge 1/17/2
    [*RB1-10GE1/17/2] port link-type hybrid
    [*RB1-10GE1/17/2] trill enable
    [*RB1-10GE1/17/2] quit
    [*RB1] interface 10ge 1/17/3
    [*RB1-10GE1/17/3] port link-type hybrid
    [*RB1-10GE1/17/3] trill enable
    [*RB1-10GE1/17/3] commit
    [~RB1-10GE1/17/3] quit

    # Configure RB2.

    [~RB2] interface 10ge 1/17/2
    [~RB2-10GE1/17/2] port link-type hybrid
    [*RB2-10GE1/17/2] trill enable
    [*RB2-10GE1/17/2] undo stp enable
    [*RB2-10GE1/17/2] commit
    [~RB2-10GE1/17/2] quit

    # Configure RB3.

    [~RB3] interface 10ge 1/17/2
    [~RB3-10GE1/17/2] port link-type hybrid
    [*RB3-10GE1/17/2] trill enable
    [*RB3-10GE1/17/2] undo stp enable
    [*RB3-10GE1/17/2] commit
    [~RB3-10GE1/17/2] quit

    # Configure RB4.

    [~RB4] interface 10ge 1/17/1
    [~RB4-10GE1/17/1] port link-type hybrid
    [*RB4-10GE1/17/1] trill enable port-mode access
    [*RB4-10GE1/17/1] port hybrid pvid vlan 100
    [*RB4-10GE1/17/1] port hybrid untagged vlan 100
    [*RB4-10GE1/17/1] quit
    [*RB4] interface 10ge 1/17/2
    [*RB4-10GE1/17/2] port link-type hybrid
    [*RB4-10GE1/17/2] trill enable
    [*RB4-10GE1/17/2] commit
    [~RB4-10GE1/17/2] quit

  3. Check the unicast routing table of RB2.

    # Run the display trill route command to view the unicast routing table of RB2.

    [~RB2] display trill route
      
    TRILL Unicast Routing Table
    -------------------------------------------------------------------
    
    Flags: D-Download To Fib
    
    Total Route(s): 3
    
    Nickname       Cost Flag OutInterface  OuterVlan NextHop        Hop
    -------------------------------------------------------------------
         100       2000 D    10GE1/17/2            10 3609-b654-1220   1
         300       4000 D    10GE1/17/2            10 3609-b664-1220   2
         400       4000 D    10GE1/17/2            10 3609-b664-1220   2
    

  4. Configure the association between MSTP and TRILL.

    # Configure an admin VLAN on each device of the TRILL network, and configure VLANIF interfaces for the admin VLANs. RB1 is used as an example here.

    [~RB1] vlan 50
    [*RB1-vlan50] quit
    [*RB1] interface vlanif 50
    [*RB1-Vlanif50] quit
    [*RB1] trill
    [*RB1-trill] admin-vlan 50
    [*RB1-trill] commit
    [~RB1-trill] quit
    The configurations on RB2, RB3, and RB4 are the same as that on RB1.

    The VLANIF interface is configured for the admin VLAN; however, the admin VLAN still carries TRILL traffic, not Layer 3 traffic.

    # Add RB2 and RB3 to the MSTP region of the original network. Configure RB2 and RB3 as the root bridge of the MSTP instance, and configure the same bridge MAC address for them. In addition, configure 10GE1/17/1 to allow the traffic of the CE VLAN and admin VLAN to pass through. RB2 is used as an example here.

    [*RB2] stp region-configuration
    [*RB2-mst-region] region-name RG1
    [*RB2-mst-region] instance 1 vlan 100
    [*RB2-mst-region] quit
    [*RB2] stp instance 1 root primary
    [*RB2] stp bridge-address 39-39-39
    [*RB2] interface 10ge 1/17/1
    [*RB2-10GE1/17/1] port link-type hybrid
    [*RB2-10GE1/17/1] port hybrid untagged vlan 50 100
    [*RB2-10GE1/17/1] quit
    [*RB2] commit

    The configuration on RB3 is the same as that on RB2.

    # Enable the association between MSTP and TRILL on RB2 and RB3, and specify the VLAN that carries the association packets as the admin VLAN. RB2 is used as an example here.The configuration on RB3 is the same as that on RB2.

    [~RB2] stp tc-notify trill vlan 50
    [*RB2] commit

Configuration Files
  • Configurations files of RB1

    #
    sysname RB1
    #
    vlan batch 50
    #
    trill
     network-entity 00.0000.0000.1111.00
     nickname 100
     carrier-vlan 10
     admin-vlan 50
    #
    interface Vlanif50
    #               
    interface 10GE1/17/1
     port link-type hybrid
     undo port hybrid untagged vlan 1
     trill enable 
    #
    interface 10GE1/17/2
     port link-type hybrid
     undo port hybrid untagged vlan 1
     trill enable 
    #
    interface 10GE1/17/3
     port link-type hybrid
     undo port hybrid untagged vlan 1
     trill enable 
    #               
    return
  • Configurations files of RB2

    #
    sysname RB2
    #
    vlan batch 50 100
    #
    stp bridge-address 0039-0039-0039
    stp tc-notify trill vlan 50
    stp instance 1 root primary
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 100
    #
    trill
     network-entity 00.0000.0000.2222.00
     nickname 200
     carrier-vlan 10
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif50
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid untagged vlan 50 100
    #
    interface 10GE1/17/2
     port link-type hybrid
     undo port hybrid untagged vlan 1
     stp disable
     trill enable 
    #
    return
  • Configurations files of RB3

    #
    sysname RB3
    #
    vlan batch 50 100
    #
    stp bridge-address 0039-0039-0039
    stp tc-notify trill vlan 50
    stp instance 1 root primary
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 100
    #
    trill
     network-entity 00.0000.0000.3333.00
     nickname 300
     carrier-vlan 10
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif50
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid untagged vlan 50 100
    #
    interface 10GE1/17/2
     port link-type hybrid
     undo port hybrid untagged vlan 1
     stp disable
     trill enable 
    #               
    return
  • Configurations files of RB4

    #
    sysname RB4
    #
    vlan batch 50 100
    #
    trill
     network-entity 00.0000.0000.4444.00
     nickname 400
     carrier-vlan 10
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif50
    #
    interface 10GE1/17/1
     port link-type hybrid
     undo port hybrid untagged vlan 1
     trill enable 
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #               
    return

Example for Configuring TRILL Network Dual-Homing Through an E-Trunk

Networking Requirements

As shown in Figure 10-35, devices access the TRILL network. The following requirements must be met:

  • To ensure reliability, a device is dual-homed to the TRILL network through two links. When one access link fails, traffic can be fast switched to the other link.
  • To improve bandwidth efficiency, the two links work in active-active mode. That is, the two links are both in active state and forward traffic in load balancing mode.
Figure 10-35 Connecting an E-Trunk to a TRILL network

You can connect an E-Trunk to the TRILL network to meet the preceding requirements. On the access side, the E-Trunk ensures device-level reliability and link-level reliability. RB1 and RB2 use the same pseudo nickname and work like one logical device to access the TRILL network. You can deploy dynamic fabric service (DFS) on the two RBs and associate DFS with the E-Trunk and TRILL to ensure correct service packet forwarding.
NOTE:

To help you learn about key points in the configuration, this configuration example uses switches as servers that need to access the TRILL network.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic TRILL functions on RB1, RB2, and RB3 for TRILL network interworking.
  2. Configure DFS on RB1 and RB2 and associate DFS with TRILL.
  3. Create Eth-Trunk interfaces.
    • Create an Eth-Trunk interface in dynamic LACP mode on RB1 and RB2 and add member interfaces to the Eth-Trunk interface.
    • Create an Eth-Trunk interface in static LACP mode on the switch and add member interfaces to the Eth-Trunk interface.
  4. Configure an E-Trunk on RB1 and RB2.
    1. Create an E-Trunk on RB1 and RB2, associate the E-Trunk with DFS, and configure parameters for the E-Trunk.
      • E-Trunk priority

      • E-Trunk description

      • LACP system ID and LACP priority of E-Trunk member interfaces (Eth-Trunk interfaces)

    2. Add Eth-Trunk interfaces in dynamic LACP mode on RB1 and RB2 to the E-Trunk.
NOTE:

If Eth-Trunk interfaces in manual load balancing mode are added to an E-Trunk, packet loss lasts for a long time when one RB restarts and user traffic is switched back to the RB for forwarding. Therefore, you are advised to add Eth-Trunk interfaces in static or dynamic LACP mode to an E-Trunk.

If the link through which RB1 is uplink connected to the TRILL network fails, RB1 discards all received user traffic because no uplink outbound interface is available. You can configure a monitor-link to associate the uplink and downlink interfaces of RB1. When the uplink outbound interface of RB1 becomes Down, the downlink interface also becomes Down. Then user traffic will not be forwarded or discarded by RB1. For details about the monitor-link configuration, see Configuring Uplink and Downlink Interfaces in a Monitor Link Group.

In a TRILL active-active scenario, if a TRILL network connects to a Layer 3 multicast network, run the igmp snooping static-router-port command on E-Trunk member interfaces (Eth-Trunk interfaces) to manually configure router outbound interfaces. This configuration ensures that the Eth-Trunk interfaces stably receive multicast data packets for a long time.

In this configuration example, Eth-Trunk interfaces in dynamic LACP mode are added to an E-Trunk, and an Eth-Trunk interface in static LACP mode is configured on the switch.

Procedure

  1. Configure basic TRILL functions on RB1, RB2, and RB3.

    • # Configure RB1.

      <HUAWEI> system-view
      [~HUAWEI] sysname RB1
      [*HUAWEI] commit
      [~RB1] vlan batch 100
      [*RB1] trill
      [*RB1-trill] network-entity 00.0000.0000.1111.00
      [*RB1-trill] nickname 100
      [*RB1-trill] carrier-vlan 2
      [*RB1-trill] ce-vlan 100
      [*RB1-trill] quit
      [*RB1] interface 10ge 1/17/4
      [*RB1-10GE1/17/4] port link-type hybrid
      [*RB1-10GE1/17/4] trill enable port-mode hybrid
      [*RB1-10GE1/17/4] quit
      [*RB1] interface 10ge 1/17/3
      [*RB1-10GE1/17/3] undo stp enable
      [*RB1-10GE1/17/3] peer-link 1
      [*RB1-10GE1/17/3] quit
      [*RB1] commit
    • # Configure RB2.

      <HUAWEI> system-view
      [~HUAWEI] sysname RB2
      [*HUAWEI] commit
      [~RB2] vlan batch 100
      [*RB2] trill
      [*RB2-trill] network-entity 00.0000.0000.2222.00
      [*RB2-trill] nickname 200
      [*RB2-trill] carrier-vlan 2
      [*RB2-trill] ce-vlan 100
      [*RB2-trill] quit
      [*RB2] interface 10ge 1/17/4
      [*RB2-10GE1/17/4] port link-type hybrid
      [*RB2-10GE1/17/4] trill enable port-mode hybrid
      [*RB2-10GE1/17/4] quit
      [*RB2] interface 10ge 1/17/3
      [*RB2-10GE1/17/3] undo stp enable
      [*RB2-10GE1/17/3] peer-link 1
      [*RB2-10GE1/17/3] quit
      [*RB2] commit
    • # Configure RB3.

      <HUAWEI> system-view
      [~HUAWEI] sysname RB3
      [*HUAWEI] commit
      [*RB3] trill
      [*RB3-trill] network-entity 00.0000.0000.3333.00
      [*RB3-trill] nickname 400
      [*RB3-trill] carrier-vlan 2
      [*RB3-trill] quit
      [*RB3] interface 10ge 1/17/1
      [*RB3-10GE1/17/1] port link-type hybrid
      [*RB3-10GE1/17/1] trill enable port-mode hybrid
      [*RB3-10GE1/17/1] quit
      [*RB3] interface 10ge 1/17/2
      [*RB3-10GE1/17/2] port link-type hybrid
      [*RB3-10GE1/17/2] trill enable port-mode hybrid
      [*RB3-10GE1/17/2] quit
      [*RB3] commit

    After the preceding configurations are successful, run the display trill peer command to view TRILL neighbor information.

    [~RB1] display trill peer
                                                                                    
    Peer information for TRILL                                                      
    ------------------------------------------------------------------------------  
                                                                                    
    Total Peer(s): 1                                                                
                                                                                    
    System ID       Interface          Circuit ID        State  HoldTime Type  PRI  
    ------------------------------------------------------------------------------  
    0000.0000.3333  10GE1/17/4          0000.0000.3333.02 Report       7s L1     64  
                                                                                    

  2. Configure DFS on RB1 and RB2 and associate DFS with TRILL.

    • # Configure RB1.

      [~RB1] dfs-group 1
      [*RB1-dfs-group-1] peer-nickname 200
      [*RB1-dfs-group-1] pseudo-nickname 300
      [*RB1-dfs-group-1] quit
      [*RB1] commit
    • # Configure RB2.

      [~RB2] dfs-group 1
      [*RB2-dfs-group-1] peer-nickname 100
      [*RB2-dfs-group-1] pseudo-nickname 300
      [*RB2-dfs-group-1] quit
      [*RB2] commit

  3. Configure an Eth-Trunk interface in dynamic LACP mode on RB1 and RB2, configure an Eth-Trunk interface in static LACP mode on the switch, and add member interfaces to the Eth-Trunk interfaces.

    • # Configure RB1.

      [~RB1] interface eth-trunk 10
      [*RB1-Eth-Trunk10] mode lacp-dynamic
      [*RB1-Eth-Trunk10] port link-type trunk
      [*RB1-Eth-Trunk10] port trunk allow-pass vlan 100
      [*RB1-Eth-Trunk10] quit
      [*RB1] interface 10ge 1/17/1
      [*RB1-10GE1/17/1] eth-trunk 10
      [*RB1-10GE1/17/1] quit
      [*RB1] interface 10ge 1/17/2
      [*RB1-10GE1/17/2] eth-trunk 10
      [*RB1-10GE1/17/2] quit
      [*RB1] commit
    • # Configure RB2.

      [~RB2] interface eth-trunk 10
      [*RB2-Eth-Trunk10] mode lacp-dynamic
      [*RB2-Eth-Trunk10] port link-type trunk
      [*RB2-Eth-Trunk10] port trunk allow-pass vlan 100
      [*RB2-Eth-Trunk10] quit
      [*RB2] interface 10ge 1/17/1
      [*RB2-10GE1/17/1] eth-trunk 10
      [*RB2-10GE1/17/1] quit
      [*RB2] interface 10ge 1/17/2
      [*RB2-10GE1/17/2] eth-trunk 10
      [*RB2-10GE1/17/2] quit
      [*RB2] commit
    • # Configure the switch.

      <HUAWEI> system-view
      [~HUAWEI] sysname CE
      [*HUAWEI] commit
      [~CE] vlan batch 100
      [*CE] interface eth-trunk 20
      [*CE-Eth-Trunk20] mode lacp-static
      [*CE-Eth-Trunk20] port link-type trunk
      [*CE-Eth-Trunk20] port trunk allow-pass vlan 100
      [*CE-Eth-Trunk20] quit
      [*CE] interface 10ge 1/17/1
      [*CE-10GE1/17/1] eth-trunk 20
      [*CE-10GE1/17/1] quit
      [*CE] interface 10ge 1/17/2
      [*CE-10GE1/17/2] eth-trunk 20
      [*CE-10GE1/17/2] quit
      [*CE] interface 10ge 1/17/3
      [*CE-10GE1/17/3] eth-trunk 20
      [*CE-10GE1/17/3] quit
      [*CE] interface 10ge 1/17/4
      [*CE-10GE1/17/4] eth-trunk 20
      [*CE-10GE1/17/4] quit
      [*CE] commit

    After the preceding configurations are successful, run the display eth-trunk command on the switch to view the working mode and member interface information on the Eth-Trunk interface.

    [~CE] display eth-trunk 20
    Eth-Trunk20's state information is:
    Local:
    LAG ID: 20                      Working Mode: Static
    Preempt Delay: Disabled         Hash Arithmetic: profile default
    System Priority: 32768          System ID: 0019-7459-3301
    Least Active-linknumber: 1      Max Active-linknumber: 32 
    Operating Status: up            Number Of Up Ports In Trunk: 2
    Timeout Period: Slow          
    --------------------------------------------------------------------------------
    ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight
    10GE1/17/1              Selected 10GE     32768   1      5185    10111100  1     
    10GE1/17/2              Selected 10GE     32768   0      5185    10111100  1     
    10GE1/17/3              Unselect 10GE     32768   2      5185    10100000  1     
    10GE1/17/4              Unselect 10GE     32768   3      5185    10100000  1     
    
    Partner:
    --------------------------------------------------------------------------------
    ActorPortName          SysPri   SystemID        PortPri PortNo PortKey PortState
    10GE1/17/1              32768    e468-a356-0cb1  32768   1      2625    10111100 
    10GE1/17/2              32768    0025-9e95-7c21  32768   1      2625    10111100 
    10GE1/17/3              32768    0025-9e95-7c21  32768   2      2625    10110000 
    10GE1/17/4              32768    e468-a356-0cb1  32768   0      2625    10110000 
    

    The command output shows that only the member interface connecting the switch to RB1 is selected to forward traffic. That is, RB1 and RB2 do not forward traffic in load balancing mode.

  4. Configure an E-Trunk on RB1 and RB2

    1. Create an E-Trunk on RB1 and RB2, associate the E-Trunk with DFS, and configure parameters for the E-Trunk.

      # Configure RB1.

      [~RB1] e-trunk 1
      [*RB1-e-trunk-1] dfs-group 1
      [*RB1-e-trunk-1] description RB1_to_RB2
      [*RB1-e-trunk-1] priority 10
      [*RB1-e-trunk-1] quit
      [*RB1] lacp e-trunk priority 1
      [*RB1] lacp e-trunk system-id 00E0-FC00-0000
      [*RB1] commit

      # Configure RB2.

      [~RB2] e-trunk 1
      [*RB2-e-trunk-1] dfs-group 1
      [*RB2-e-trunk-1] description RB2_to_RB1
      [*RB2-e-trunk-1] priority 20
      [*RB2-e-trunk-1] quit
      [*RB2] lacp e-trunk priority 1
      [*RB2] lacp e-trunk system-id 00E0-FC00-0000
      [*RB2] commit

      Member Eth-Trunk interfaces of the same E-Trunk must have the same LACP priority and LACP system ID.

    2. On RB1 and RB2, add Eth-Trunk interfaces in dynamic LACP mode to the E-Trunk.

      # Configure RB1.

      [~RB1] interface eth-trunk 10
      [~RB1-Eth-Trunk10] e-trunk 1
      [*RB1-Eth-Trunk10] quit
      [*RB1] commit

      # Configure RB2.

      [~RB2] interface eth-trunk 10
      [~RB2-Eth-Trunk10] e-trunk 1
      [*RB2-Eth-Trunk10] quit
      [*RB2] commit

  5. Verify the configuration.

    # Run the display eth-trunk command on the switch to view the configuration of the Eth-Trunk interface.

    [~CE] display eth-trunk 20
    Eth-Trunk20's state information is:                                             
    Local:                                                                          
    LAG ID: 20                      Working Mode: Static                            
    Preempt Delay: Disabled         Hash Arithmetic: profile default                
    System Priority: 32768          System ID: 0019-7459-3301                       
    Least Active-linknumber: 1      Max Active-linknumber: 32                       
    Operating Status: up            Number Of Up Ports In Trunk: 4                  
    Timeout Period: Slow                                                            
    --------------------------------------------------------------------------------
    ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight
    10GE1/17/1              Selected 10GE     32768   2      5185    10111100  1     
    10GE1/17/2              Selected 10GE     32768   0      5185    10111100  1     
    10GE1/17/3              Selected 10GE     32768   1      5185    10111100  1     
    10GE1/17/4              Selected 10GE     32768   3      5185    10111100  1     
                                                                                    
    Partner:                                                                        
    --------------------------------------------------------------------------------
    ActorPortName          SysPri   SystemID        PortPri PortNo PortKey PortState
    10GE1/17/1              1        00e0-fc00-0000  32768   1      2625    10111100 
    10GE1/17/2              1        00e0-fc00-0000  32768   1      2625    10111100 
    10GE1/17/3              1        00e0-fc00-0000  32768   2      2625    10111100 
    10GE1/17/4              1        00e0-fc00-0000  32768   0      2625    10111100 
                                                                                    

    The command output shows that member interfaces connecting the CE to RB1 and RB2 respectively are selected to forward traffic.

    # Run the display e-trunk command on RB1 and RB2 to view information about the E-Trunk.

    [~RB1] display e-trunk 1
                                The E-Trunk information                             
    E-TRUNK-ID : 1                          Dfs-GroupId : 1                         
    Priority : 10                           System-ID : 0025-9e95-7c21              
    Peer-Nickname : 200                     Local-Nickname : 100                    
    State : Master                          Causation : PRI                         
    Receive : 42780                         Send : 43832                            
    RecDrop : 0                             SndDrop : 0                             
    Peer-Priority : 20                      Peer-System-ID : e468-a356-0cb1         
    Description : RB1_to_RB2                                                        
    --------------------------------------------------------------------------------
                                The Member information                              
    Type      ID  LocalPhyState  Work-Mode     State   Causation        Remote-ID   
    Eth-Trunk 10  Up             active-active Master  ACTIVE_ACTIVE    10          
    [~RB2] display e-trunk 1
                                The E-Trunk information                             
    E-TRUNK-ID : 1                          Dfs-GroupId : 1                         
    Priority : 20                           System-ID : e468-a356-0cb1              
    Peer-Nickname : 100                     Local-Nickname : 200                    
    State : Backup                          Causation : PRI                         
    Receive : 43844                         Send : 42840                            
    RecDrop : 0                             SndDrop : 0                             
    Peer-Priority : 10                      Peer-System-ID : 0025-9e95-7c21         
    Description : RB2_to_RB1                                                        
    --------------------------------------------------------------------------------
                                The Member information                              
    Type      ID  LocalPhyState  Work-Mode     State   Causation        Remote-ID   
    Eth-Trunk 10  Up             active-active Master  ACTIVE_ACTIVE    10          

    The command output shows that the working mode of the E-Trunk on RB1 and RB2 is active-active, and the E-Trunk status is Master. That is, RB1 and RB2 forward traffic in load balancing mode.

    # Run the shutdown command on the peer-link of RB2 to simulate an interface fault, and then run the display e-trunk command. The command output shows that the E-Trunk status of RB1 is Master, the E-Trunk status of RB2 is Backup, the Eth-Trunk interface status of the E-Trunk is Down, and the fault cause is PEERLINK_DOWN, indicating a peer-link fault. When this fault occurs, only RB1 in Master state forwards traffic.

    [~RB1] display e-trunk 1
                                The E-Trunk information                             
    E-TRUNK-ID : 1                          Dfs-GroupId : 1                         
    Priority : 10                           System-ID : 0025-9e95-7c21              
    Peer-Nickname : 200                     Local-Nickname : 100                    
    State : Master                          Causation : PRI                         
    Receive : 43464                         Send : 44514                            
    RecDrop : 0                             SndDrop : 0                             
    Peer-Priority : 20                      Peer-System-ID : e468-a356-0cb1         
    Description : RB1_to_RB2                                                        
    --------------------------------------------------------------------------------
                                The Member information                              
    Type      ID  LocalPhyState  Work-Mode     State   Causation        Remote-ID   
    Eth-Trunk 10  Up             active-active Master  PEER_MEMBER_DOWN 10          
    [~RB2] display e-trunk 1
                                The E-Trunk information                             
    E-TRUNK-ID : 1                          Dfs-GroupId : 1                         
    Priority : 20                           System-ID : e468-a356-0cb1              
    Peer-Nickname : 100                     Local-Nickname : 200                    
    State : Backup                          Causation : PRI                         
    Receive : 44526                         Send : 43525                            
    RecDrop : 0                             SndDrop : 0                             
    Peer-Priority : 10                      Peer-System-ID : 0025-9e95-7c21         
    Description : RB2_to_RB1                                                        
    --------------------------------------------------------------------------------
                                The Member information                              
    Type      ID  LocalPhyState  Work-Mode     State   Causation        Remote-ID   
    Eth-Trunk 10  Down           active-active Backup  PEERLINK_DOWN    10          

Configuration Files
  • Configuration file of the switch

    #
    sysname CE
    #
    vlan batch 100
    #
    interface Eth-Trunk20
     port link-type trunk
     port trunk allow-pass vlan 100
     mode lacp-static
    #
    interface 10GE1/17/1
     eth-trunk 20
    #
    interface 10GE1/17/2
     eth-trunk 20
    #
    interface 10GE1/17/3
     eth-trunk 20
    #
    interface 10GE1/17/4
     eth-trunk 20
    #
    return
  • Configuration file of RB1

    #
    sysname RB1
    #
    vlan batch 100
    #
    lacp e-trunk system-id 00e0-fc00-0000
    lacp e-trunk priority 1
    #
    trill
     network-entity 00.0000.0000.1111.00
     nickname 100
     carrier-vlan 2
     ce-vlan 100
    #
    dfs-group 1
     peer-nickname 200
     pseudo-nickname 300
    #
    e-trunk 1
     dfs-group 1
     priority 10
     description RB1_to_RB2
    #
    interface Eth-Trunk10
     port link-type trunk
     port trunk allow-pass vlan 100
     mode lacp-dynamic
     e-trunk 1
    #
    interface 10GE1/17/1
     eth-trunk 10
    #
    interface 10GE1/17/2
     eth-trunk 10
    #
    interface 10GE1/17/3
     stp disable
     peer-link 1
    #
    interface 10GE1/17/4
     port link-type hybrid
     trill enable port-mode hybrid
    #
    return
  • Configuration file of RB2

    #
    sysname RB2
    #
    vlan batch 100
    #
    lacp e-trunk system-id 00e0-fc00-0000
    lacp e-trunk priority 1
    #
    trill
     network-entity 00.0000.0000.2222.00
     nickname 200
     carrier-vlan 2
     ce-vlan 100
    #
    dfs-group 1
     peer-nickname 100
     pseudo-nickname 300
    #
    e-trunk 1
     dfs-group 1
     priority 20
     description RB2_to_RB1
    #
    interface Eth-Trunk10
     port link-type trunk
     port trunk allow-pass vlan 100
     mode lacp-dynamic
     e-trunk 1
    #
    interface 10GE1/17/1
     eth-trunk 10
    #
    interface 10GE1/17/2
     eth-trunk 10
    #
    interface 10GE1/17/3
     stp disable
     peer-link 1
    #
    interface 10GE1/17/4
     port link-type hybrid
     trill enable port-mode hybrid
    #
    return
  • Configuration file of RB3

    #
    sysname RB3
    #
    trill
     network-entity 00.0000.0000.3333.00
     nickname 400
     carrier-vlan 2
    #
    interface 10GE1/17/1
     port link-type hybrid
     trill enable port-mode hybrid
    #
    interface 10GE1/17/2
     port link-type hybrid
     trill enable port-mode hybrid
    #
    return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 59680

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next