No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides configuration examples of RIP, including networking requirements, configuration notes, and configuration roadmap.

Example for Configuring Basic RIP Functions

Networking Requirements

As shown in Figure 7-26, Switch ModuleA, Switch ModuleB, Switch ModuleC, and Switch ModuleD are located on a small-sized network, and they need to communicate with each other.

Figure 7-26 Network diagram of basic RIP functions

Configuration Roadmap

The network size is small, so RIP-2 is recommended. The configuration roadmap is as follows:

  1. Configure a VLAN and an IP address for each interface to ensure network reachability.

  2. Enable RIP on each switch modules to implement network connections between processes.

  3. Configure RIP-2 on each switch modules to improve RIP performance.

Procedure

  1. Name the device.The configuration procedure is not provided here.
  2. Configure a VLAN and an IP address for each interface. The configuration procedure is not provided here.
  3. Specify the network segment where RIP needs to be enabled.

    # Configure Switch ModuleA.

    [~Switch ModuleA] rip
    [*Switch ModuleA-rip-1] network 192.168.1.0
    [*Switch ModuleA-rip-1] commit
    [~Switch ModuleA-rip-1] quit

    # Configure Switch ModuleB.

    [~Switch ModuleB] rip
    [*Switch ModuleB-rip-1] network 192.168.1.0
    [*Switch ModuleB-rip-1] network 172.16.0.0
    [*Switch ModuleB-rip-1] network 10.0.0.0
    [*Switch ModuleB-rip-1] commit
    [~Switch ModuleB-rip-1] quit

    # Configure Switch ModuleC.

    [~Switch ModuleC] rip
    [*Switch ModuleC-rip-1] network 172.16.0.0
    [*Switch ModuleC-rip-1] commit
    [~Switch ModuleC-rip-1] quit

    # Configure Switch ModuleD.

    [~Switch ModuleD] rip
    [*Switch ModuleD-rip-1] network 10.0.0.0
    [*Switch ModuleD-rip-1] commit
    [~Switch ModuleD-rip-1] quit

    # Display the RIP routing table of Switch ModuleA.

    [~Switch ModuleA] display rip 1 route
     Route Flags: R - RIP
                  A - Aging, S - Suppressed, G - Garbage-collect
    -------------------------------------------------------------------------
     Peer 192.168.1.2  on Vlanif10
          Destination/Mask        Nexthop     Cost   Tag     Flags   Sec
             10.0.0.0/8        192.168.1.2      1    0        RA      14
            172.16.0.0/16      192.168.1.2      1    0        RA      14

    From the routing table, you can find that the routes advertised by RIP-1 use natural masks.

  4. Specify the RIP version.

    # Configure RIP-2 on Switch ModuleA.

    [~Switch ModuleA] rip
    [*Switch ModuleA-rip-1] version 2
    [*Switch ModuleA-rip-1] commit
    [~Switch ModuleA-rip-1] quit

    # Configure RIP-2 on Switch ModuleB.

    [~Switch ModuleB] rip
    [*Switch ModuleB-rip-1] version 2
    [*Switch ModuleB-rip-1] commit
    [~Switch ModuleB-rip-1] quit

    # Configure RIP-2 on Switch ModuleC.

    [~Switch ModuleC] rip
    [*Switch ModuleC-rip-1] version 2
    [*Switch ModuleC-rip-1] commit
    [~Switch ModuleC-rip-1] quit

    # Configure RIP-2 on Switch ModuleD.

    [~Switch ModuleD] rip
    [*Switch ModuleD-rip-1] version 2
    [*Switch ModuleD-rip-1] commit
    [~Switch ModuleD-rip-1] quit

  5. Verify the configuration.

    # Display the RIP routing table of Switch ModuleA.

    [~Switch ModuleA] display rip 1 route
    Route Flags: R - RIP
                 A - Aging, S - Suppressed, G - Garbage-collect 
    -------------------------------------------------------------------------
     Peer 192.168.1.2  on Vlanif10
          Destination/Mask        Nexthop       Cost   Tag     Flags   Sec
             10.1.1.0/24         192.168.1.2      1    0        RA      32
            172.16.1.0/24        192.168.1.2      1    0        RA      32

    The RIP routing table shows that the routes advertised by RIP-2 contain accurate subnet masks.

Configuration Files
  • # Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10
    #
    interface Vlanif 10
     ip address 192.168.1.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    rip 1
     version 2
     network 192.168.1.0
    #
    return
  • # Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 10 20 30
    #
    interface Vlanif 10
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif 20
     ip address 172.16.1.1 255.255.255.0
    #
    interface Vlanif 30
     ip address 10.1.1.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    rip 1
     version 2
     network 10.0.0.0
     network 172.16.0.0
     network 192.168.1.0
    #
    return
  • # Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 20
    #
    interface Vlanif 20
     ip address 172.16.1.2 255.255.255.0
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    rip 1
     version 2
     network 172.16.0.0
    #
    return
  • # Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 30
    #
    interface Vlanif 30
     ip address 10.1.1.2 255.255.255.0
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    rip 1
     version 2
     network 10.0.0.0
    #
    return

Example for Importing Routes to RIP

Networking Requirements

As shown in Figure 7-27, two RIP processes, RIP100 and RIP200, run on Switch ModuleB. Switch ModuleA needs to communicate with network segment 192.168.3.0/24.

Figure 7-27 Network diagram of importing routes to RIP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable RIP on each switch modules to implement network connections between processes.

  2. On Switch ModuleB, import routes between RIP100 and RIP200 and set the default metric of routes imported from RIP200 to 3.

  3. Configure an ACL on Switch ModuleB to filter route 192.168.4.0/24 imported from RIP200.

Procedure

  1. Name the device.The configuration procedure is not provided here.
  2. Configure a VLAN and an IP address for each interface. The configuration procedure is not provided here.
  3. Configure basic RIP functions.

    # Enable RIP100 on Switch ModuleA.

    [~Switch ModuleA] rip 100
    [*Switch ModuleA-rip-100] network 192.168.0.0
    [*Switch ModuleA-rip-100] network 192.168.1.0
    [*Switch ModuleA-rip-100] commit
    [~Switch ModuleA-rip-100] quit

    # Enable RIP100 and RIP200 on Switch ModuleB.

    [~Switch ModuleB] rip 100
    [*Switch ModuleB-rip-100] network 192.168.1.0
    [*Switch ModuleB-rip-100] commit
    [~Switch ModuleB-rip-100] quit
    [~Switch ModuleB] rip 200
    [*Switch ModuleB-rip-200] network 192.168.2.0
    [*Switch ModuleB-rip-200] commit
    [~Switch ModuleB-rip-200] quit

    # Enable RIP200 on Switch ModuleC.

    [~Switch ModuleC] rip 200
    [*Switch ModuleC-rip-200] network 192.168.2.0
    [*Switch ModuleC-rip-200] network 192.168.3.0
    [*Switch ModuleC-rip-200] network 192.168.4.0
    [*Switch ModuleC-rip-200] commit
    [~Switch ModuleC-rip-200] quit

    # Display the routing table of Switch ModuleA.

    [~Switch ModuleA] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Table: _public_
             Destinations : 10       Routes : 10
    
    
    Destination/Mask    Proto  Pre  Cost   Flags    NextHop        Interface
    
    
          127.0.0.0/8   Direct 0    0        D      127.0.0.1      InLoopBack0
          127.0.0.1/32  Direct 0    0        D      127.0.0.1      InLoopBack0
    127.255.255.255/32  Direct 0    0        D      127.0.0.1      InLoopBack0
        192.168.0.0/24  Direct 0    0        D      192.168.0.1    Vlanif50
        192.168.0.1/32  Direct 0    0        D      127.0.0.1      Vlanif50
      192.168.0.255/32  Direct 0    0        D      127.0.0.1      Vlanif50
        192.168.1.0/24  Direct 0    0        D      192.168.1.1    Vlanif10
        192.168.1.1/32  Direct 0    0        D      127.0.0.1      Vlanif10
      192.168.1.255/32  Direct 0    0        D      127.0.0.1      Vlanif10
    255.255.255.255/32  Direct 0    0        D      127.0.0.1      InLoopBack0

    The routing table of Switch ModuleA does not contain the routes imported from other processes.

  4. Configure RIP to import external routes.

    # On Switch ModuleB, set the default metric of imported routes to 3 and configure the RIP processes to import routes into each other's routing table.

    [~Switch ModuleB] rip 100
    [~Switch ModuleB-rip-100] default-cost 3
    [*Switch ModuleB-rip-100] import-route rip 200
    [*Switch ModuleB-rip-100] quit
    [*Switch ModuleB] rip 200
    [*Switch ModuleB-rip-200] import-route rip 100
    [*Switch ModuleB-rip-200] quit
    [*Switch ModuleB] commit

    # Display the routing table of Switch ModuleA after the routes are imported.

    [~Switch ModuleA] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Table: _public_
             Destinations : 13       Routes : 13
     
    
    Destination/Mask    Proto  Pre  Cost   Flags    NextHop         Interface
     
    
          127.0.0.0/8   Direct 0    0        D      127.0.0.1      InLoopBack0
          127.0.0.1/32  Direct 0    0        D      127.0.0.1      InLoopBack0
    127.255.255.255/32  Direct 0    0        D      127.0.0.1      InLoopBack0
        192.168.0.0/24  Direct 0    0        D      192.168.0.1    Vlanif50
        192.168.0.1/32  Direct 0    0        D      127.0.0.1      Vlanif50
      192.168.0.255/32  Direct 0    0        D      127.0.0.1      Vlanif50
        192.168.1.0/24  Direct 0    0        D      192.168.1.1    Vlanif10
        192.168.1.1/32  Direct 0    0        D      127.0.0.1      Vlanif10
      192.168.1.255/32  Direct 0    0        D      127.0.0.1      Vlanif10
    255.255.255.255/32  Direct 0    0        D      127.0.0.1      InLoopBack0
        192.168.2.0/24  RIP    100  4       D          192.168.1.2     Vlanif10
        192.168.3.0/24  RIP    100  4       D          192.168.1.2     Vlanif10
        192.168.4.0/24  RIP    100  4       D          192.168.1.2     Vlanif10

    The RIP routing table of Switch ModuleA contains routes 192.168.2.0/24, 192.168.3.0/24, and 192.168.4.0/24, which are learned by RIP200 on Switch ModuleB.

  5. Configure RIP to filter imported routes.

    # Configure an ACL on Switch ModuleB and add a rule to the ACL. The rule denies the packets sent from 192.168.4.0/24.

    [~Switch ModuleB] acl 2000
    [*Switch ModuleB-acl4-basic-2000] rule deny source 192.168.4.0 0.0.0.255
    [*Switch ModuleB-acl4-basic-2000] rule permit
    [*Switch ModuleB-acl4-basic-2000] quit

    # Configure Switch ModuleB to filter route 192.168.4.0/24 imported from RIP200.

    [*Switch ModuleB] rip 100
    [*Switch ModuleB-rip-100] filter-policy 2000 export
    [*Switch ModuleB-rip-100] quit
    [*Switch ModuleB] commit

  6. Verify the configuration.

    # Display the RIP routing table of Switch ModuleA after the routes are filtered.

    [~Switch ModuleA] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Table: _public_
             Destinations : 12        Routes : 12
     
    
    Destination/Mask    Proto  Pre  Cost   Flags    NextHop         Interface
     
    
          127.0.0.0/8   Direct 0    0        D      127.0.0.1      InLoopBack0
          127.0.0.1/32  Direct 0    0        D      127.0.0.1      InLoopBack0
    127.255.255.255/32  Direct 0    0        D      127.0.0.1      InLoopBack0
        192.168.0.0/24  Direct 0    0        D      192.168.0.1    Vlanif50
        192.168.0.1/32  Direct 0    0        D      127.0.0.1      Vlanif50
      192.168.0.255/32  Direct 0    0        D      127.0.0.1      Vlanif50
        192.168.1.0/24  Direct 0    0        D      192.168.1.1    Vlanif10
        192.168.1.1/32  Direct 0    0        D      127.0.0.1      Vlanif10
      192.168.1.255/32  Direct 0    0        D      127.0.0.1      Vlanif10
    255.255.255.255/32  Direct 0    0        D      127.0.0.1      InLoopBack0
        192.168.2.0/24  RIP    100  4       D       192.168.1.2     Vlanif10
        192.168.3.0/24  RIP    100  4       D       192.168.1.2     Vlanif10

    The RIP routing table of Switch ModuleA does not contain the route originating from 192.168.4.0/24.

Configuration Files
  • # Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 50
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface Vlanif50
     ip address 192.168.0.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    rip 100
     network 192.168.0.0
     network 192.168.1.0
    #
    return
  • # Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 10 20
    #
    acl number 2000
     rule 5 deny source 192.168.4.0 0.0.0.255
     rule 10 permit
    #
    interface Vlanif10
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    rip 100
     default-cost 3
     network 192.168.1.0
     filter-policy 2000 export
     import-route rip 200
    #
    rip 200
     network 192.168.2.0
     import-route rip 100
    #
    return
  • # Configuration file of Switch ModuleC

    #
     sysname Switch ModuleC
    #
    vlan batch 20 30 40
    #
    interface Vlanif20
     ip address 192.168.2.2 255.255.255.0
    #
    interface Vlanif30
     ip address 192.168.3.1 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.4.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    rip 200
     network 192.168.2.0
     network 192.168.3.0
     network 192.168.4.0
    #
    return

Example for Configuring Dynamic BFD for RIP

Networking Requirements

As shown in Figure 7-28, there are four switch moduleses that communicate using RIP on a small-sized network. Services are transmitted through the primary link Switch Module A→Switch Module B→Switch Module D. Reliability must be improved for data transmitted from Switch Module A to Switch Module B so that services can be rapidly switched to another path for transmission when the primary link fails.

Figure 7-28 Networking diagram for configuring BFD for RIP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a VLAN and an IP address for each interface to ensure network reachability.

  2. Enable RIP on each switch modules to implement network connections between processes.

  3. Configure BFD for RIP on interfaces at both ends of the link between Switch Module A and Switch Module B. BFD can rapidly detect the link status and help RIP speed up route convergence to implement fast link switching.

Procedure

  1. Configure a VLAN for each interface.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 10 20
    [*Switch ModuleA] interface 10GE 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10GE 1/17/2
    [*Switch ModuleA-10GE1/17/2] port link-type trunk
    [*Switch ModuleA-10GE1/17/2] port trunk allow-pass vlan 20
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] commit

    The configurations of Switch Module B, Switch Module C and Switch Module D are similar to the configuration of Switch Module A, and are not mentioned here.

  2. Configure IP address for each vlanif interface.

    [~Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ip address 2.2.2.1 24
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] interface vlanif 20
    [*Switch ModuleA-Vlanif20] ip address 3.3.3.1 24
    [*Switch ModuleA-Vlanif20] quit
    [*Switch ModuleA] commit

    The configurations of Switch Module B, Switch Module C and Switch Module D are similar to the configuration of Switch Module A, and are not mentioned here.

  3. Configure basic RIP functions.

    # Configure Switch Module A.

    <Switch ModuleA> system-view
    [~Switch ModuleA] rip 1
    [*Switch ModuleA-rip-1] version 2
    [*Switch ModuleA-rip-1] network 2.0.0.0
    [*Switch ModuleA-rip-1] network 3.0.0.0
    [*Switch ModuleA-rip-1] quit
    [*Switch ModuleA] commit

    # Configure Switch Module B.

    <Switch ModuleB> system-view
    [~Switch ModuleB] rip 1
    [*Switch ModuleB-rip-1] version 2
    [*Switch ModuleB-rip-1] network 2.0.0.0
    [*Switch ModuleB-rip-1] network 4.0.0.0
    [*Switch ModuleB-rip-1] network 172.16.0.0
    [*Switch ModuleB-rip-1] quit
    [*Switch ModuleB] commit

    # Configure Switch Module C.

    <Switch ModuleC> system-view
    [~Switch ModuleC] rip 1
    [*Switch ModuleC-rip-1] version 2
    [*Switch ModuleC-rip-1] network 3.0.0.0
    [*Switch ModuleC-rip-1] network 4.0.0.0
    [*Switch ModuleC-rip-1] quit
    [*Switch ModuleC] commit

    # Configure Switch Module D.

    <Switch ModuleD> system-view
    [~Switch ModuleD] rip 1
    [*Switch ModuleD-rip-1] version 2
    [*Switch ModuleD-rip-1] network 172.16.0.0
    [*Switch ModuleD-rip-1] quit
    [*Switch ModuleD] commit

    # After completing the preceding operations, run the display rip neighbor command. The command output shows that Switch Module A, Switch Module B, and Switch Module C have established neighbor relationships with each other. In the following example, the display on Switch Module A is used.

    [~Switch ModuleA] display rip 1 neighbor
    ---------------------------------------------------------------------           
     IP Address      Interface                   Type   Last-Heard   Routes         
    ---------------------------------------------------------------------           
     2.2.2.2         Vlanif10                    RIP    0:0:14            2         
     3.3.3.2         Vlanif20                    RIP    0:0:19            1         
    

    # Run the display ip routing-table command. The command output shows that the switch moduleses have imported routes from each other. In the following example, the display on Switch Module A is used.

    [~Switch ModuleA] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------  
    Routing Table: _public_                                                          
             Destinations : 12       Routes : 13                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
            2.2.2.0/24  Direct  0    0           D   2.2.2.1         Vlanif10       
            2.2.2.1/32  Direct  0    0           D   127.0.0.1       Vlanif10       
          2.2.2.255/32  Direct  0    0           D   127.0.0.1       Vlanif10       
            3.3.3.0/24  Direct  0    0           D   3.3.3.1         Vlanif20       
            3.3.3.1/32  Direct  0    0           D   127.0.0.1       Vlanif20       
          3.3.3.255/32  Direct  0    0           D   127.0.0.1       Vlanif20       
            4.4.4.0/24  RIP     100  1           D   3.3.3.2         Vlanif20       
                        RIP     100  1           D   2.2.2.2         Vlanif10       
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
        127.0.0.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
         172.16.1.0/24  RIP     100  1           D   2.2.2.2         Vlanif10       
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0

    The preceding command output shows that the next-hop address and outbound interface of the route to destination 172.16.1.0/16 are 2.2.2.2 and Vlanif10 respectively, and traffic is transmitted over the active link Switch Module A->Switch Module B.

  4. Configure BFD in RIP processes.

    # Configure BFD on all interfaces of Switch Module A.

    [~Switch ModuleA] bfd
    [*Switch ModuleA-bfd] quit
    [*Switch ModuleA] rip 1
    [*Switch ModuleA-rip-1] bfd all-interfaces enable
    [*Switch ModuleA-rip-1] bfd all-interfaces min-rx-interval 100 min-tx-interval 100 detect-multiplier 10
    [*Switch ModuleA-rip-1] quit
    [*Switch ModuleA] commit

    The configuration of Switch Module B is similar to that of Switch Module A, and is not provided here.

    # After completing the preceding operations, run the display rip bfd session command on Switch Module A. The command output shows that Switch Module A and Switch Module B have established a BFD session and the BFDState field value is displayed as Up. In the following example, the display on Switch Module A is used.

    [~Switch ModuleA] display rip 1 bfd session all
     Interface :Vlanif10
     LocalIp       :2.2.2.1       RemoteIp  :2.2.2.2       BFDState  :Up
    
     Interface :Vlanif20
     LocalIp       :3.3.3.1       RemoteIp  :3.3.3.2       BFDState  :Down

  5. Verify the configuration.

    # Run the shutdown command on 10GE 1/17/0 of Switch Module B to simulate a fault in the active link.

    NOTE:

    The link fault is simulated to verify the configuration. In actual situations, the operation is not required.

    [~Switch ModuleB] interface 10GE 1/17/1
    [~Switch ModuleB-10GE1/17/1] shutdown
    [*Switch ModuleB-10GE1/17/1] commit

    # Check the routing table of Switch Module A.

    [~Switch ModuleA] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------  
    Routing Table: _public_                                                          
             Destinations : 9       Routes : 9                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
            3.3.3.0/24  Direct  0    0           D   3.3.3.1         Vlanif20       
            3.3.3.1/32  Direct  0    0           D   127.0.0.1       Vlanif20       
          3.3.3.255/32  Direct  0    0           D   127.0.0.1       Vlanif20       
            4.4.4.0/24  RIP     100  1           D   3.3.3.2         Vlanif20       
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
        127.0.0.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
         172.16.1.0/24  RIP     100  2           D   3.3.3.2         Vlanif20       
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0    

    The preceding command output shows that the standby link Switch Module A->Switch Module C->Switch Module B is used after the active link fails, and the next-hop address and outbound interface of the route to destination 172.16.1.0/16 are 3.3.3.2 and Vlanif20 respectively.

Configuration Files
  • Configuration file of Switch Module A

    #
    sysname Switch ModuleA
    #
    vlan batch 10 20
    #
    bfd
    #
    interface Vlanif10
     ip address 2.2.2.1 255.255.255.0
    #
    interface Vlanif20
     ip address 3.3.3.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    rip 1 
     version 2 
     network 2.0.0.0
     network 3.0.0.0
     bfd all-interfaces enable 
     bfd all-interfaces min-tx-interval 100 min-rx-interval 100 detect-multiplier 10
    #
    return
  • Configuration file of Switch Module B

    #
    sysname Switch ModuleB
    #
    vlan batch 10 30 40
    #
    bfd
    #
    interface Vlanif10
     ip address 2.2.2.2 255.255.255.0
    #
    interface Vlanif30
     ip address 4.4.4.1 255.255.255.0
    #
    interface Vlanif40
     ip address 172.16.1.1 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    rip 1 
     version 2 
     network 2.0.0.0
     network 4.0.0.0
     network 172.16.0.0
     bfd all-interfaces enable 
     bfd all-interfaces min-tx-interval 100 min-rx-interval 100 detect-multiplier 10
    #
    return
  • Configuration file of Switch Module C

    #
    sysname Switch ModuleC
    #
    vlan batch 20 30
    #
    interface Vlanif20
     ip address 3.3.3.2 255.255.255.0
    #
    interface Vlanif30
     ip address 4.4.4.2 255.255.255.0
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    rip 1 
     version 2 
     network 3.0.0.0
     network 4.0.0.0
    #
    return
  • Configuration file of Switch Module D

    #
    sysname Switch ModuleD
    #
    vlan batch 40
    #
    interface Vlanif40
     ip address 172.16.1.2 255.255.255.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    rip 1 
     version 2 
     network 172.16.0.0
    #
    return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 57131

Downloads: 3617

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next