No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 13

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

The configuration examples describe how to implement PIM-SM inter-domain multicast using MSDP, inter-AS multicast, anycast RP within a PIM-SM domain, and how to configure filtering policies for SA messages.

Example for Configuring PIM-SM Inter-domain Multicast Using MSDP

Networking Requirements

As shown in Figure 8-81, two ASs exist on the network. Each AS contains at least one PIM-SM domain and each PIM-SM domain may contain no or one multicast source and receiver. The receiver in PIM-SM2 domain wants to receive the multicast data sent by both S3 in PIM-SM3 and S1 in PIM-SM1.

Figure 8-81 Networking diagram of PIM-SM inter-domain multicast

Configuration Roadmap

Configure MSDP, and set up MSDP peer relationships between RPs in PIM-SM domains to implement inter-domain multicast.

  1. Configure IP addresses for the interfaces on each switch modules. Configure OSPF in the ASs to ensure route reachability within each AS.

  2. Configure EBGP peers between ASs and import BGP and OSPF routes into each other's routing table to ensure route reachability between ASs.

  3. Enable multicast routing and PIM-SM on each interface. Configure a BSR boundary to divide the PIM-SM domain and enable IGMP on interfaces connected to network segments of receiver hosts.

  4. Configure C-BSRs and C-RPs. Configure the RPs in PIM-SM1 and PIM-SM2 on the ASBRs.

  5. Set up MSDP peer relationships between RPs in PIM-SM domains. According to the RPF rule, switch moduleses receive SA messages from the next hop destined for the source RP.

Procedure

  1. Configure IP addresses for interfaces and configure a unicast routing protocol on each switch modules.

    # According to Figure 8-81, configure IP addresses and masks for the interfaces on each switch modules. Configure OSPF between switch moduleses. Ensure network connectivity in each AS and enable each switch modules to update routes using the unicast routing protocol. The configuration details are not mentioned here.

  2. Configure EBGP peers between ASs and import routes of BGP and OSPF into each other's routing table.

    # Configure EBGP on Switch ModuleB and import OSPF routes to BGP.

    [~Switch ModuleB] bgp 100
    [*Switch ModuleB-bgp] router-id 1.1.1.1
    [*Switch ModuleB-bgp] peer 192.168.2.2 as-number 200
    [*Switch ModuleB-bgp] import-route ospf 1
    [*Switch ModuleB-bgp] commit
    [~Switch ModuleB-bgp] quit

    # Configure EBGP on Switch ModuleC and import OSPF routes to BGP.

    [~Switch ModuleC] bgp 200
    [*Switch ModuleC-bgp] router-id 2.2.2.2
    [*Switch ModuleC-bgp] peer 192.168.2.1 as-number 100
    [*Switch ModuleC-bgp] import-route ospf 1
    [*Switch ModuleC-bgp] commit
    [~Switch ModuleC-bgp] quit

    # Import BGP routes to OSPF on Switch ModuleB. The configuration on Switch ModuleC is similar to the configuration on Switch ModuleB, and is not mentioned here.

    [~Switch ModuleB] ospf 1
    [*Switch ModuleB-ospf-1] import-route bgp
    [*Switch ModuleB-ospf-1] commit
    [~Switch ModuleB-ospf-1] quit

  3. Enable multicast routing, enable PIM-SM on all interfaces. Configure a BSR boundary to divide the PIM-SM domain and enable IGMP on interfaces connected to network segments of receiver hosts.

    # Enable multicast routing on Switch ModuleB and enable PIM-SM on each interface. The configurations on other switch moduleses are similar to the configuration on Switch ModuleB, and are not mentioned here.

    [~Switch ModuleB] multicast routing-enable
    [*Switch ModuleB] interface vlanif 100
    [*Switch ModuleB-Vlanif100] pim sm
    [*Switch ModuleB-Vlanif100] commit
    [~Switch ModuleB-Vlanif100] quit
    [~Switch ModuleB] interface vlanif 200
    [~Switch ModuleB-Vlanif200] pim sm
    [*Switch ModuleB-Vlanif200] commit
    [~Switch ModuleB-Vlanif200] quit
    

    # Configure a BSR boundary on VLANIF200 of Switch ModuleB.

    [~Switch ModuleB] interface vlanif 200
    [~Switch ModuleB-Vlanif200] pim bsr-boundary
    [*Switch ModuleB-Vlanif200] commit
    [~Switch ModuleB-Vlanif200] quit

    # Configure BSR boundaries on VLANIF200 and VLANIF400 of Switch ModuleC. Configure a BSR boundary on VLANIF400 of Switch ModuleE. The configurations on Switch ModuleC and Switch ModuleE are similar to the configuration on Switch ModuleB, and are not mentioned here.

    # Enable IGMP on the interface connecting to Switch ModuleD to the user network segment.

    [~Switch ModuleD] interface vlanif 102
    [~Switch ModuleD-Vlanif102] igmp enable
    [*Switch ModuleD-Vlanif102] commit
    [~Switch ModuleD-Vlanif102] quit

  4. Configure C-BSRs and C-RPs.

    # Create a Loopback0 interface, and then configure the C-BSR and C-RP on Loopback0 of Switch ModuleB. The configurations on Switch ModuleC and Switch ModuleE are similar to the configuration on Switch ModuleB, and are not mentioned here.

    [~Switch ModuleB] interface loopback 0
    [*Switch ModuleB-LoopBack0] ip address 1.1.1.1 255.255.255.255
    [*Switch ModuleB-LoopBack0] pim sm
    [*Switch ModuleB-LoopBack0] commit
    [~Switch ModuleB-LoopBack0] quit
    [~Switch ModuleB] pim
    [*Switch ModuleB-pim] c-bsr loopback 0
    [*Switch ModuleB-pim] c-rp loopback 0
    [*Switch ModuleB-pim] commit
    [~Switch ModuleB-pim] quit

  5. Configure MSDP peers.

    # Configure an MSDP peer on Switch ModuleB.

    [~Switch ModuleB] msdp
    [*Switch ModuleB-msdp] peer 192.168.2.2 connect-interface vlanif200
    [*Switch ModuleB-msdp] commit
    [~Switch ModuleB-msdp] quit

    # Configure MSDP peers on Switch ModuleC.

    [~Switch ModuleC] msdp
    [*Switch ModuleC-msdp] peer 192.168.2.1 connect-interface vlanif200
    [*Switch ModuleC-msdp] peer 192.168.4.2 connect-interface vlanif400
    [*Switch ModuleC-msdp] commit
    [~Switch ModuleC-msdp] quit

    # Configure an MSDP peer on Switch ModuleE.

    [~Switch ModuleE] msdp
    [*Switch ModuleE-msdp] peer 192.168.4.1 connect-interface vlanif400
    [*Switch ModuleE-msdp] commit
    [~Switch ModuleE-msdp] quit

  6. Verify the configuration.

    # Run the display bgp peer command to view the BGP peer relationships among switch moduleses. The following output shows the BGP peers of Switch ModuleB and Switch ModuleC:

    [~Switch ModuleB] display bgp peer
    
     BGP local router ID : 1.1.1.1
     Local AS number : 100
     Total number of peers : 1                     Peers in established state : 1
    
      Peer          V   AS   MsgRcvd    MsgSent    OutQ    Up/Down          State    PrefRcv
      192.168.2.2   4   200       24         21       0    00:13:09   Established          6
    
    
    [~Switch ModuleC] display bgp peer
    
    BGP local router ID : 2.2.2.2
     Local AS number : 200
     Total number of peers : 1                     Peers in established state : 1  
    
      Peer          V   AS    MsgRcvd    MsgSent     OutQ   Up/Down          State    PrefRcv
      192.168.2.1   4   100        18         16        0   00:12:04   Established          1
    

    # Run the display msdp brief command to view the status of the MSDP peers on switch moduleses. The following output shows summary information about MSDP peers on Switch ModuleB, Switch ModuleC and Switch ModuleE:

    [~Switch ModuleB] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net                            
    ---------------------------------------------------------------------------------  
      Configured   Up           Listen       Connect      Shutdown     Down          
               1    1                0             0             0        0
    ---------------------------------------------------------------------------------  
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count
      192.168.2.2        Up        00:12:27        200               13             0
    
    
    [~Switch ModuleC] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net                            
    ---------------------------------------------------------------------------------  
      Configured   Up           Listen       Connect      Shutdown     Down          
               2    2                0             0             0        0
    ---------------------------------------------------------------------------------  
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count
      192.168.2.1        Up        01:07:08        100                8             0
      192.168.4.2        Up        00:06:39        ?(unknown)        13             0
    
    
    [~Switch ModuleE] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net                            
    ---------------------------------------------------------------------------------  
      Configured   Up           Listen       Connect      Shutdown     Down          
               1    1                0             0             0        0
    ---------------------------------------------------------------------------------  
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count
      192.168.4.1        Up        00:15:32        ?(unknown)         8             0
    
    

    # Run the display msdp peer-status command to view the details about MSDP peers on switch moduleses. The following output shows the details about the MSDP peer of Switch ModuleB:

    [~Switch ModuleB] display msdp peer-status
    MSDP Peer Information of VPN instance: public net
      MSDP Peer 192.168.2.2, AS 200
      Description:
      Information about connection status:
        State: Up
        Up/down time: 00:15:47
        Resets: 0
        Connection interface: Vlanif200 (192.168.2.1)
        Number of sent/received messages: 46/46
        Number of discarded output messages: 0
        Elapsed time since last connection or counters clear: 00:17:51
      Information about (Source, Group)-based SA filtering policy:
        Import policy: none
        Export policy: none
      Information about SA-Requests:
        Policy to accept SA-Request messages: none
        Sending SA-Requests status: disable
      Minimum TTL to forward SA with encapsulated data: 0
      SAs learned from this peer: 0, SA-cache maximum for the peer: none
      Input queue size: 0, Output queue size: 0
      Counters for MSDP message:
        Count of RPF check failure: 0
        Incoming/outgoing SA messages: 20/30
        Incoming/outgoing SA requests: 0/0
        Incoming/outgoing SA responses: 0/0
        Incoming/outgoing data packets: 0/0
      Peer authentication: unconfigured
      Peer authentication type: none

    # Run the display pim routing-table command to view the PIM routing table on a switch modules. When S1 (10.110.1.2/24) in PIM-SM1 and S3 (10.110.3.2/24) in PIM-SM3 send multicast data to multicast group G (225.1.1.1), Receiver (10.110.2.2/24) in PIM-SM2 receives the multicast data sent to G. The following output shows the PIM routing tables on Switch ModuleB and Switch ModuleC:

    [~Switch ModuleB] display pim routing-table
    VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
     
     (10.110.1.2, 225.1.1.1)
         RP: 1.1.1.1(local)
         Protocol: pim-sm, Flag: SPT EXT ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif100
             Upstream neighbor: 192.168.1.1
             RPF prime neighbor: 192.168.1.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif200
                 Protocol: pim-sm, UpTime: 00:00:42, Expires:-
    
    
    [~Switch ModuleC] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 2 (S, G) entries
     
    (*, 225.1.1.1)
         RP: 2.2.2.2(local)
         Protocol: pim-sm, Flag: WC RPT
         UpTime: 00:13:46
         Upstream interface: NULL, 
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
        Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif300,
                 Protocol: pim-sm, UpTime: 00:13:46, Expires:-
    
    (10.110.1.2, 225.1.1.1)
         RP: 2.2.2.2
         Protocol: pim-sm, Flag: SPT MSDP ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif200
             Upstream neighbor: 192.168.2.1
             RPF prime neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif300
                 Protocol: pim-sm, UpTime: 00:00:42, Expires:-
    
    (10.110.3.2, 225.1.1.1)
         RP: 2.2.2.2
         Protocol: pim-sm, Flag: SPT MSDP ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif400
             Upstream neighbor: 192.168.4.2
             RPF prime neighbor: 192.168.4.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif300
                 Protocol: pim-sm, UpTime: 00:00:42, Expires:-
    

Configuration Files

  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 100 101
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif101
     ip address 10.110.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 101
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 100 200
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif200
     ip address 192.168.2.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    bgp 100
     router-id 1.1.1.1
     peer 192.168.2.2 as-number 200
    #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.2.2 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 192.168.1.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     peer 192.168.2.2 connect-interface Vlanif200
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 200 300 400
    #
    multicast routing-enable
    #
    interface Vlanif200
     ip address 192.168.2.2 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface Vlanif300
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif400
     ip address 192.168.4.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    bgp 200
     router-id 2.2.2.2
     peer 192.168.2.1 as-number 100
    #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.2.1 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     peer 192.168.2.1 connect-interface Vlanif200
     peer 192.168.4.2 connect-interface Vlanif400
    #
    return
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 102 300
    #
    multicast routing-enable
    #
    interface Vlanif102
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif300
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 102
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    return
  • Configuration file of Switch ModuleE

    #
    sysname Switch ModuleE
    #
    vlan batch 400 500
    #
    multicast routing-enable
    #
    interface Vlanif400
     ip address 192.168.4.2 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface Vlanif500
     ip address 192.168.5.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     pim sm
    # 
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 192.168.4.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     peer 192.168.4.1 connect-interface Vlanif400
    #
    return
  • Configuration file of Switch ModuleF

    #
    sysname Switch ModuleF
    #
    vlan batch 103 500
    #
    multicast routing-enable
    #
    interface Vlanif103
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif500
     ip address 192.168.5.2 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 103
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    ospf 1
     area 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    return

Example for Configuring Inter-AS Multicast Using Static RPF Peers

Networking Requirements

As shown in Figure 8-82, two ASs exist on the network. Each AS contains at least one PIM-SM domain and each PIM-SM domain may contain no or one multicast source and receiver. Source information needs to be transmitted across PIM-SM domains without changing unicast topology.

Figure 8-82 Networking diagram of inter-AS multicast using static RPF peers

Configuration Roadmap

Configure an MSDP peer on the RP in each PIM-SM domain and specify static RPF peers for the MSDP peers to transmit source information across PIM-SM domains without changing unicast topology.

  1. Configure IP addresses for the interfaces on each switch modules, configure OSPF in the ASs, configure EBGP between ASs, and import BGP and OSPF routes into each other's routing table.

  2. Enable multicast on all switch moduleses and PIM-SM on all interfaces, and enable IGMP on interfaces connected to network segments of receiver hosts. Configure Loopback0 interfaces, C-BSRs, and C-RPs on switch moduleses. Configure Loopback0 interfaces on Switch ModuleC, Switch ModuleD, and Switch ModuleF as the C-BSR and the C-RP of each PIM-SM domain.

  3. Set up MSDP peer relationships between RPs in PIM-SIM domains. Set up the MSDP peer relationship between Switch ModuleC and Switch ModuleD, and between Switch ModuleC and Switch ModuleF.

  4. Specify static RPF peers for the MSDP peers. Specify Switch ModuleD and Switch ModuleF as the static RPF peers of Switch ModuleC. Specify Switch ModuleC as the only static RPF peer of Switch ModuleD and Switch ModuleF. According to RPF rules, switch moduleses accept SA messages from static RPF peers.

Procedure

  1. Configure IP addresses for interfaces and configure a unicast routing protocol on each switch modules.

    # According to Figure 8-82, configure IP addresses and masks for the interfaces on each switch modules. Configure OSPF in the ASs. Configure EBGP between Switch ModuleA and Switch ModuleF, and between Switch ModuleB and Switch ModuleE. Import BGP and OSPF routes into each other's routing table. Ensure network connectivity between switch moduleses and enable switch moduleses to update routes using the unicast routing protocol. The configuration details are not mentioned here.

  2. Enable multicast routing on all switch moduleses and PIM-SM on all interfaces, and enable IGMP on interfaces connected to network segments of receiver hosts. In addition, configure the BSR boundary on the interfaces of switch moduleses on the AS boundary.

    # Enable multicast routing on switch moduleses and enable PIM-SM on each interface. The configurations on other switch moduleses are similar to the configuration on Switch ModuleC, and are not mentioned here.

    [~Switch ModuleC] multicast routing-enable
    [*Switch ModuleC] interface vlanif 100
    [*Switch ModuleC-Vlanif100] pim sm
    [*Switch ModuleC-Vlanif100] commit
    [~Switch ModuleC-Vlanif100] quit
    [~Switch ModuleC] interface vlanif 400
    [~Switch ModuleC-Vlanif400] pim sm
    [*Switch ModuleC-Vlanif400] commit
    [~Switch ModuleC-Vlanif400] quit

    # Enable IGMP on VLANIF102 of Switch ModuleE. The configuration on Switch ModuleG is similar to the configuration on Switch ModuleE, and is not mentioned here.

    [~E] interface vlanif 102
    [~Switch ModuleE-Vlanif102] igmp enable
    [*Switch ModuleE-Vlanif102] commit
    [~Switch ModuleE-Vlanif102] quit

    # Configure a BSR boundary on VLANIF500 of Switch ModuleA, VLANIF200 of Switch ModuleB, VLANIF200 of Switch ModuleE, and VLANIF500 of Switch ModuleF. The configurations on Switch ModuleB, Switch ModuleE, and Switch ModuleF are similar to the configuration on Switch ModuleA, and are not mentioned here.

    [~Switch ModuleA] interface vlanif 500
    [~Switch ModuleA-Vlanif500] pim bsr-boundary
    [*Switch ModuleA-Vlanif500] commit
    [~Switch ModuleA-Vlanif500] quit

  3. Configure Loopback0 interfaces, C-BSRs, and C-RPs on switch moduleses.

    # Configure Loopback0 interfaces on Switch ModuleC, Switch ModuleD, and Switch ModuleF. Configure Loopback0 interfaces as C-BSRs and C-RPs. The configurations on Switch ModuleD and Switch ModuleF are similar to the configuration on Switch ModuleC, and are not mentioned here.

    [~Switch ModuleC] interface loopback 0
    [*Switch ModuleC-LoopBack0] ip address 1.1.1.1 255.255.255.255
    [*Switch ModuleC-LoopBack0] pim sm
    [*Switch ModuleC-LoopBack0] commit
    [~Switch ModuleC-LoopBack0] quit
    [~Switch ModuleC] pim
    [*Switch ModuleC-pim] c-bsr loopback 0
    [*Switch ModuleC-pim] c-rp loopback 0
    [*Switch ModuleC-pim] commit
    [~Switch ModuleC-pim] quit

  4. Configure static RPF peers.

    # Configure Switch ModuleD and Switch ModuleF as the static RPF peers of Switch ModuleC.

    [~Switch ModuleC] ip ip-prefix list-df permit 192.168.0.0 16 greater-equal 16 less-equal 32
    [*Switch ModuleC] msdp
    [*Switch ModuleC-msdp] peer 192.168.3.2 connect-interface vlanif100
    [*Switch ModuleC-msdp] peer 192.168.5.1 connect-interface vlanif400
    [*Switch ModuleC-msdp] static-rpf-peer 192.168.3.2 rp-policy list-df
    [*Switch ModuleC-msdp] static-rpf-peer 192.168.5.1 rp-policy list-df 
    [*Switch ModuleC-msdp] commit
    [~Switch ModuleC-msdp] quit

    # Configure Switch ModuleC as the only static RPF peer of Switch ModuleD and Switch ModuleF. The configuration on Switch ModuleF is similar to the configuration on Switch ModuleD, and is not mentioned here.

    [~Switch ModuleD] ip ip-prefix list-c permit 192.168.0.0 16 greater-equal 16 less-equal 32
    [*Switch ModuleD] msdp
    [*Switch ModuleD-msdp] peer 192.168.1.1 connect-interface vlanif300
    [*Switch ModuleD-msdp] static-rpf-peer 192.168.1.1 rp-policy list-c 
    [*Switch ModuleD-msdp] commit 
    [~Switch ModuleD-msdp] quit 
    

  5. Verify the configuration.

    # Run the display bgp peer command to view the BGP peer relationships among switch moduleses. No command output is displayed on Switch ModuleC, which indicates that no BGP peer relationship is set up between Switch ModuleC and Switch ModuleD, or between Switch ModuleC and Switch ModuleF.

    # Run the display msdp brief command to view the status of the MSDP peers on switch moduleses. When S1 in the PIM-SM1 domain sends multicast data, the receivers in PIM-SM2 and PIM-SM3 domains can receive the data. The following output shows summary information about MSDP peers on Switch ModuleC, Switch ModuleD and Switch ModuleF:

    [~Switch ModuleC] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net
    ---------------------------------------------------------------------------------
      Configured   Up           Listen       Connect      Shutdown     Down
               2    2                0             0             0        0
    ---------------------------------------------------------------------------------
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count
      192.168.3.2        Up        01:07:08       200                 8             0
      192.168.5.1        Up        00:16:39       200                13             0
    
    
    [~Switch ModuleD] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net
    ---------------------------------------------------------------------------------
      Configured   Up           Listen       Connect      Shutdown     Down
               1    1                0             0             0        0
    ---------------------------------------------------------------------------------
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count
      192.168.1.1        Up        01:07:09       100                 8             0
    
    
    [~Switch ModuleF] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net
    ---------------------------------------------------------------------------------
      Configured   Up           Listen       Connect      Shutdown     Down 
               1    1                0             0             0        0
    ---------------------------------------------------------------------------------
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count
      192.168.4.1        Up        00:16:40       100                13             0
    
    

Configuration Files

  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 101 400 500
    #
    multicast routing-enable
    #
    interface Vlanif101
     ip address 10.110.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif400
     ip address 192.168.4.2 255.255.255.0
     pim sm
    #
    interface Vlanif500
     ip address 192.168.5.2 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface 10GE1/17/3
     port default vlan 101
    #
    bgp 100
     router-id 1.1.1.3
     peer 192.168.5.1 as-number 200
    #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.5.1 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    return
    
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 100 200
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif200
     ip address 192.168.2.2 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    bgp 100
     router-id 1.1.1.2
     peer 192.168.2.1 as-number 200
    #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.2.1 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
    
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 100 400
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif400
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    ip ip-prefix list-df index 10 permit 192.168.0.0 16 greater-equal 16 less-equal 32
    #
    msdp
     peer 192.168.3.2 connect-interface vlanif100
     peer 192.168.5.1 connect-interface vlanif400
     static-rpf-peer 192.168.3.2 rp-policy list-df
     static-rpf-peer 192.168.5.1 rp-policy list-df
    #
    return
    
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 300
    #
    multicast routing-enable
    #
    interface Vlanif300
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 192.168.3.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    ip ip-prefix list-c index 10 permit 192.168.0.0 16 greater-equal 16 less-equal 32
    #
    msdp
     peer 192.168.1.1 connect-interface vlanif300
     static-rpf-peer 192.168.1.1 rp-policy list-c
    #
    return
    
  • Configuration file of Switch ModuleE

    #
    sysname Switch ModuleE
    #
    vlan batch 102 200 300
    #
    multicast routing-enable
    #
    interface Vlanif102
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif200
     ip address 192.168.2.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface Vlanif300
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/17/3
     port default vlan 102
    #
    bgp 200
     router-id 2.2.2.1
     peer 192.168.2.2 as-number 100
    #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.2.2 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    return
    
  • Configuration file of Switch ModuleF

    #
    sysname Switch ModuleF
    #
    vlan batch 500 600
    #
    multicast routing-enable
    #
    interface Vlanif500
     ip address 192.168.5.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface Vlanif600
     ip address 192.168.6.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     pim sm
    #
    bgp 200
     router-id 3.3.3.3
     peer 192.168.5.2 as-number 100
    #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.5.2 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 192.168.5.0 0.0.0.255
      network 192.168.6.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    ip ip-prefix list-c index 10 permit 192.168.0.0 16 greater-equal 16 less-equal 32
    #
    msdp
     peer 192.168.4.1 connect-interface vlanif500
     static-rpf-peer 192.168.4.1 rp-policy list-c
    #
    return
  • Configuration file of Switch ModuleG

    #
    sysname Switch ModuleG
    #
    vlan batch 103 104 600
    #
    multicast routing-enable
    #
    interface Vlanif103
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif104
     ip address 10.110.4.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif600
     ip address 192.168.6.2 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 103
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface 10GE1/17/3
     port default vlan 104
    #
    ospf 1
     area 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 10.110.4.0 0.0.0.255
      network 192.168.6.0 0.0.0.255
    #
    return
    

Example for Configuring Anycast RP in a PIM-SM Domain

Networking Requirements

As shown in Figure 8-83, a PIM-SM domain contains multiple multicast sources and receivers. RPs in a PIM-SM domain need to be configured as MSDP peers to perform load balancing.

Figure 8-83 Networking diagram of anycast RP

Configuration Roadmap

Configure anycast RPs using MSDP so that the receiver sends a Join message to the closest RP and the multicast source sends a Register message to the nearest RP. RPs implement load balancing.

  1. Configure IP addresses for the interfaces on each switch modules and configure OSPF in the PIM-SM domain.

  2. Enable multicast on all switch moduleses and PIM-SM on all interfaces, and enable IGMP on interfaces connected to network segments of receiver hosts.

  3. Configure the same Loopback10 address on Switch ModuleC and Switch ModuleD. Configure C-RPs on Loopback10 interfaces, and configure C-BSRs on Loopback1 interfaces.

  4. Configure MSDP peers on Loopback0 interfaces of Switch ModuleC and Switch ModuleD. According to RPF rules, the switch moduleses receive SA messages from the source RP.

Procedure

  1. Configure IP addresses for interfaces and configure a unicast routing protocol on each switch modules.

    # According to Figure 8-83, configure IP addresses and masks for the interfaces in the PIM-SM domain. Configure OSPF between switch moduleses. The configuration details are not mentioned here.

  2. Enable multicast routing and configure PIM-SM.

    # Enable multicast routing on all switch moduleses and PIM-SM on all interfaces. Enable IGMP on interfaces connected to network segments of receiver hosts. The configurations on other switch moduleses are similar to the configuration on Switch ModuleC, and are not mentioned here.

    [~Switch ModuleC] multicast routing-enable
    [*Switch ModuleC] interface vlanif 104
    [*Switch ModuleC-Vlanif104] pim sm
    [*Switch ModuleC-Vlanif104] igmp enable
    [*Switch ModuleC-Vlanif104] commit
    [~Switch ModuleC-Vlanif104] quit
    [~Switch ModuleC] interface vlanif 101
    [~Switch ModuleC-Vlanif101] pim sm
    [*Switch ModuleC-Vlanif101] commit
    [~Switch ModuleC-Vlanif102] quit
    [~Switch ModuleC] interface vlanif 100
    [~Switch ModuleC-Vlanif100] pim sm
    [*Switch ModuleC-Vlanif100] commit
    [~Switch ModuleC-Vlanif100] quit

  3. Configure Loopback1 interfaces, Loopback10 interfaces, C-BSRs, and C-RPs.

    # Configure Loopback1 addresses and the same Loopback10 address for Switch ModuleC and Switch ModuleD. Configure C-BSRs on Loopback1 interfaces and C-RPs on Loopback10 interfaces. The configuration on Switch ModuleD is similar to the configuration on Switch ModuleC, and is not mentioned here.

    [~Switch ModuleC] interface loopback 1
    [*Switch ModuleC-LoopBack1] ip address 3.3.3.3 255.255.255.255
    [*Switch ModuleC-LoopBack1] pim sm
    [*Switch ModuleC-LoopBack1] commit
    [~Switch ModuleC-LoopBack1] quit
    [~Switch ModuleC] interface loopback 10
    [*Switch ModuleC-LoopBack10] ip address 10.1.1.1 255.255.255.255
    [*Switch ModuleC-LoopBack10] pim sm
    [*Switch ModuleC-LoopBack10] commit
    [~Switch ModuleC-LoopBack10] quit
    [~Switch ModuleC] pim
    [*Switch ModuleC-pim] c-bsr loopback 1
    [*Switch ModuleC-pim] c-rp loopback 10
    [*Switch ModuleC-pim] commit
    [~Switch ModuleC-pim] quit

  4. Configure MSDP peers on Loopback0 interfaces.

    # Configure an MSDP peer on Loopback0 of Switch ModuleC.

    [~Switch ModuleC] interface loopback 0
    [*Switch ModuleC-LoopBack0] ip address 1.1.1.1 255.255.255.255
    [*Switch ModuleC-LoopBack0] pim sm
    [*Switch ModuleC-LoopBack0] commit
    [~Switch ModuleC-LoopBack0] quit
    [~Switch ModuleC] msdp
    [*Switch ModuleC-msdp] originating-rp loopback0
    [*Switch ModuleC-msdp] peer 2.2.2.2 connect-interface loopback0
    [*Switch ModuleC-msdp] commit
    [~Switch ModuleC-msdp] quit

    # Configure an MSDP peer on Loopback0 of Switch ModuleD.

    [~Switch ModuleD] interface loopback 0
    [*Switch ModuleD-LoopBack0] ip address 2.2.2.2 255.255.255.255
    [*Switch ModuleD-LoopBack0] pim sm
    [*Switch ModuleD-LoopBack0] commit
    [~Switch ModuleD-LoopBack0] quit
    [~Switch ModuleD] msdp
    [*Switch ModuleD-msdp] originating-rp loopback0
    [*Switch ModuleD-msdp] peer 1.1.1.1 connect-interface loopback0
    [*Switch ModuleD-msdp] commit
    [~Switch ModuleD-msdp] quit

  5. Verify the configuration.

    # Run the display msdp brief command to view the status of the MSDP peers on switch moduleses. The following output shows summary information about MSDP peers on Switch ModuleC and Switch ModuleD:

    [~Switch ModuleC] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net  
    ---------------------------------------------------------------------------------                                                   
      Configured   Up           Listen       Connect      Shutdown     Down                                                             
               1    1                0             0             0        0                                                             
    ---------------------------------------------------------------------------------                                                   
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count                                                   
      2.2.2.2               Up     00:10:17        ?(unknown)         0             0                                                   
    
    
    [~Switch ModuleD] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net  
    ---------------------------------------------------------------------------------                                                   
      Configured   Up           Listen       Connect      Shutdown     Down                                                             
               1    1                0             0             0        0                                                             
    ---------------------------------------------------------------------------------                                                   
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count                                                   
      1.1.1.1               Up     00:10:18        ?(unknown)         0             0                                                   
    
    

    # Run the display pim routing-table command to view the PIM routing table on a switch modules. When S1 (10.110.5.100/24) in the PIM-SM domain sends multicast data to G (225.1.1.1), User1 (Receiver) joins G and receives the multicast data sent to G. Comparing information about the PIM routing tables on Switch ModuleC and Switch ModuleD, you can find that Switch ModuleC is the valid RP. S1 registers to Switch ModuleC, and User1 sends a Join message to Switch ModuleC.

    [~Switch ModuleC] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
     
     (*, 225.1.1.1)
         RP: 10.1.1.1 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:08:49
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif104
                 Protocol: igmp, UpTime: 00:08:49, Expires: -
     
     (10.110.5.1, 225.1.1.1)
         RP: 10.1.1.1 (local)
         Protocol: pim-sm, Flag: SPT 2MSDP ACT
         UpTime: 00:07:26
         Upstream interface: Vlanif101
             Upstream neighbor: 10.110.1.2
             RPF prime neighbor: 10.110.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif104
                 Protocol: pim-sm, UpTime: 00:07:26, Expires: -
    
    
    [~Switch ModuleD] display pim routing-table

    Not output is displayed.

    # User1 exits from G, and S1 stops sending multicast data to G. You can run the reset pim routing-table command to clear PIM routing entries on Switch ModuleC.

    [~Switch ModuleC] quit
    <Switch ModuleC> reset pim routing-table group 225.1.1.1 mask 255.255.255.255 source 10.110.5.100 interface vlanif 104

    # User2 joins G, and S2 (10.110.6.100/24) sends multicast dat to G. Comparing information about the PIM routing tables on Switch ModuleC and Switch ModuleD, you can find that Switch ModuleD is the valid RP. S2 registers to Switch ModuleD, and User2 sends a Join message to Switch ModuleD.

    <Switch ModuleC> display pim routing-table

    Not output is displayed.

    [~Switch ModuleD] display pim routing-table
    VPN-Instance: public net  
    Total 1 (*, G) entry; 1 (S, G) entry
     
    (*, 225.1.1.1)
         RP: 10.1.1.1 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:07:23
         Upstream interface: Register 
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif103,
                 Protocol: igmp, UpTime: 00:07:23, Expires:-
    
     (10.110.6.100, 225.1.1.1)
         RP: 10.1.1.1 (local)
         Protocol: pim-sm, Flag: SPT 2MSDP ACT
         UpTime: 00:05:20
         Upstream interface: Vlanif102
             Upstream neighbor: 10.110.2.2
             RPF prime neighbor: 10.110.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif103
                 Protocol: pim-sm, UpTime: 00:05:20, Expires: -

Configuration Files

  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 101 105
    #
    multicast routing-enable
    #
    interface Vlanif101
     ip address 10.110.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif105
     ip address 10.110.5.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 105
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 10.110.5.0 0.0.0.255
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 102 106
    #
    multicast routing-enable
    #
    interface Vlanif102
     ip address 10.110.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif106
     ip address 10.110.6.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 106
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 10.110.6.0 0.0.0.255
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 100 to 101 104
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif101
     ip address 10.110.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif104
     ip address 10.110.4.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    interface 10GE1/17/3
     port default vlan 104
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
     pim sm
    #
    interface LoopBack10
     ip address 10.1.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.1.1.1 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 10.110.4.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     c-bsr LoopBack1
     c-rp LoopBack10
    #
    msdp
     originating-rp LoopBack0
     peer 2.2.2.2 connect-interface LoopBack0
    #
    return
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 102 to 103 300
    #
    multicast routing-enable
    #
    interface Vlanif102
     ip address 10.110.2.1 255.255.255.0
     pim sm
    #
    interface Vlanif103
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif300
     ip address 192.168.3.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    interface 10GE1/17/3
     port default vlan 103
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
     pim sm
    #
    interface LoopBack10
     ip address 10.1.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 10.1.1.1 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 10.110.3.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     c-bsr LoopBack1
     c-rp LoopBack10
    #
    msdp
     originating-rp LoopBack0
     peer 1.1.1.1 connect-interface LoopBack0
    #
    return
  • Configuration file of Switch ModuleE

    #
    sysname Switch ModuleE
    #
    vlan batch 100 300
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif300
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    return

Example for Configuring SA Message Filtering

Networking Requirements

As shown in Figure 8-84, service data is transmitted in multicast mode on the network that is divided into three PIM-SM domains. The multicast source Source1 sends multicast data to multicast groups 225.1.1.0/30 and 226.1.1.0/30, and Source2 sends multicast data to the multicast group 227.1.1.0/30. According to service requirements, HostA and HostB need to receive only multicast data that is sent to multicast groups 225.1.1.0/30 and 226.1.1.0/30, and HostC needs to receive only multicast data that is sent to multicast groups 226.1.1.0/30 and 227.1.1.0/30.

Figure 8-84 Networking diagram for configuring SA message filtering

Configuration Roadmap

Configure MSDP to implement multicast source information sharing among domains. Configure SA message filtering so that the receivers receive only required multicast data.

  1. Configure IP addresses for the interfaces on each switch modules and configure OSPF in the PIM-SM domain.

  2. Enable multicast and PIM-SM on each interface. Configure a BSR boundary to divide the PIM-SM domain and enable IGMP on interfaces connected to network segments of receiver hosts.

  3. Configure Loopback0 interfaces on Switch ModuleA, Switch ModuleC, and Switch ModuleD as the C-BSR and the C-RP of each PIM-SM domain.

  4. Set up MSDP peer relationships between RPs in PIM-SIM domains. Set up the MSDP peer relationship between Switch ModuleA and Switch ModuleC, and between Switch ModuleC and Switch ModuleD.

  5. Configure rules for filtering SA messages. Prohibit Switch ModuleC from forwarding SA messages carrying (Source1, 225.1.1.0/30) entries to Switch ModuleD. Prohibit Switch ModuleD from creating SA messages carrying Source2 information.

Procedure

  1. Configure IP addresses for interfaces and configure a unicast routing protocol on each switch modules.

    # According to Figure 8-84, configure IP addresses and masks for the interfaces in the PIM-SM domain. Configure OSPF between switch moduleses. The configuration details are not mentioned here.

  2. Enable multicast routing and configure PIM-SM.

    # Enable multicast routing on all switch moduleses and PIM-SM on all interfaces. Enable IGMP on interfaces connected to network segments of receiver hosts. The following information shows the configuration on Switch ModuleA. The configurations on other switch moduleses are similar to the configuration on Switch ModuleA, and are not mentioned here.

    [~Switch ModuleA] multicast routing-enable
    [*Switch ModuleA] interface vlanif 100
    [*Switch ModuleA-Vlanif100] pim sm
    [*Switch ModuleA-Vlanif100] igmp enable
    [*Switch ModuleA-Vlanif100] commit
    [~Switch ModuleA-Vlanif100] quit
    [~Switch ModuleA] interface vlanif 101
    [~Switch ModuleA-Vlanif101] pim sm
    [*Switch ModuleA-Vlanif101] commit
    [~Switch ModuleA-Vlanif101] quit
    [~Switch ModuleA] interface vlanif 102
    [~Switch ModuleA-Vlanif102] pim sm
    [*Switch ModuleA-Vlanif102] commit
    [~Switch ModuleA-Vlanif102] quit
    [~Switch ModuleA] interface loopback 0
    [~Switch ModuleA-LoopBack0] pim sm
    [*Switch ModuleA-LoopBack0] commit
    [~Switch ModuleA-LoopBack0] quit

  3. Configure a BSR boundary to divide the PIM-SM domain.

    # Configure a BSR boundary on Switch ModuleC. The configurations on Switch ModuleA, Switch ModuleB, and Switch ModuleD are similar to the configuration on Switch ModuleC, and are not mentioned here.

    [~Switch ModuleC] interface vlanif 101
    [~Switch ModuleC-Vlanif101] pim bsr-boundary
    [*Switch ModuleC-Vlanif101] quit
    [*Switch ModuleC] interface vlanif 103
    [*Switch ModuleC-Vlanif103] pim bsr-boundary
    [*Switch ModuleC-Vlanif103] quit
    [*Switch ModuleC] interface vlanif 104
    [*Switch ModuleC-Vlanif104] pim bsr-boundary
    [*Switch ModuleC-Vlanif104] quit
    [*Switch ModuleC] commit
    

  4. Configure C-BSRs and C-RPs.

    # Configure the C-BSR and C-RP on the Loopback0 interface of Switch ModuleA. The configurations on Switch ModuleC and Switch ModuleD are similar to the configuration on Switch ModuleA, and are not mentioned here.

    [~Switch ModuleA] pim
    [*Switch ModuleA-pim] c-bsr loopback0
    [*Switch ModuleA-pim] c-rp loopback0
    [*Switch ModuleC-pim] commit
    [~Switch ModuleC-pim] quit
    

  5. Configure MSDP peers.

    # Configure an MSDP peer on Switch ModuleA.

    [~Switch ModuleA] msdp
    [*Switch ModuleA-msdp] peer 192.168.1.2 connect-interface vlanif 101
    [*Switch ModuleA-msdp] commit
    [~Switch ModuleA-msdp] quit

    # Configure MSDP peers on Switch ModuleC.

    [~Switch ModuleC] msdp
    [*Switch ModuleC-msdp] peer 192.168.1.1 connect-interface vlanif 101
    [*Switch ModuleC-msdp] peer 10.110.5.2 connect-interface vlanif 104
    [*Switch ModuleC-msdp] commit
    [~Switch ModuleC-msdp] quit

    # Configure an MSDP peer on Switch ModuleD.

    [~Switch ModuleD] msdp
    [*Switch ModuleD-msdp] peer 10.110.5.1 connect-interface vlanif 104
    [*Switch ModuleD-msdp] commit
    [~Switch ModuleD-msdp] quit

  6. Configure rules for filtering SA messages.

    # Prohibit Switch ModuleC from forwarding SA messages carrying (Source1, 225.1.1.0/30) entries to Switch ModuleD.

    [~Switch ModuleC] acl number 3001
    [*Switch ModuleC-acl4-advance-3001] rule deny ip source 10.110.3.100 0 destination 225.1.1.0 0.0.0.3
    [*Switch ModuleC-acl4-advance-3001] rule permit ip source any destination any
    [*Switch ModuleC-acl4-advance-3001] commit
    [~Switch ModuleC-acl4-advance-3001] quit
    [~Switch ModuleC] msdp
    [*Switch ModuleC-msdp] peer 10.110.5.2 sa-policy export 3001
    [*Switch ModuleC-msdp] commit
    [~Switch ModuleC-msdp] quit
    

    # Prohibit Switch ModuleD from creating SA messages carrying Source2 information.

    [~Switch ModuleD] acl number 2001
    [*Switch ModuleD-acl4-basic-2001] rule deny source 10.110.6.100 0
    [*Switch ModuleD-acl4-basic-2001] quit
    [*Switch ModuleD] msdp
    [*Switch ModuleD-msdp] import-source acl 2001
    [*Switch ModuleD-msdp] quit
    [*Switch ModuleD] commit

  7. Verify the configuration.

    # Run the display msdp sa-cache command to view information about the (S, G) entries in the SA cache on switch moduleses. The following output shows information about the (S, G) entries in the SA cache on Switch ModuleC and Switch ModuleD.

    [~Switch ModuleC] display msdp sa-cache
    MSDP Source-Active Cache Information of VPN instance: public net
     MSDP Total Source-Active Cache - 8 entries
     MSDP matched 8 entries
    
    (10.110.3.100, 225.1.1.0)
     Origin RP: 1.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 225.1.1.1)
     Origin RP: 1.1.1.1 
     Pro: BGP, AS: ? 
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 225.1.1.2)
     Origin RP: 1.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 225.1.1.3)
     Origin RP: 1.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 226.1.1.0)
     Origin RP: 1.1.1.1 
     Pro: BGP, AS: ? 
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 226.1.1.1) 
     Origin RP: 1.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 226.1.1.2)
     Origin RP: 1.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 226.1.1.3)
     Origin RP: 1.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28
    
    [~Switch ModuleD] display msdp sa-cache
    MSDP Source-Active Cache Information of VPN instance: public net
     MSDP Total Source-Active Cache - 4 entries
     MSDP matched 4 entries
    
    (10.110.3.100, 226.1.1.0)
     Origin RP: 1.1.1.1
     Pro: BGP, AS: ? 
     Uptime: 00:24:53, Expires: 00:05:06
    
    (10.110.3.100, 226.1.1.1)
     Origin RP: 1.1.1.1
     Pro: BGP, AS: ? 
     Uptime: 00:24:53, Expires: 00:05:06
    
    (10.110.3.100, 226.1.1.2)
     Origin RP: 1.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:24:53, Expires: 00:05:06
    
    (10.110.3.100, 226.1.1.3)
     Origin RP: 1.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:24:53, Expires: 00:05:06
    
    

    The preceding output shows that only multicast data to multicast groups 225.1.1.0/30 and 226.1.1.0/30 exists in the SA cache on Switch ModuleC, and only multicast data to the multicast group 226.1.1.0/30 exists in the SA cache on Switch ModuleD.

Configuration Files

  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 100 to 102
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 10.110.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif101
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif102
     ip address 10.110.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 100
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 10.110.2.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     peer 192.168.1.2 connect-interface Vlanif101
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 102 to 103 200
    #
    multicast routing-enable
    #
    interface Vlanif102
     ip address 10.110.2.2 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif103
     ip address 192.168.2.1 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif200
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 200
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 103
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 10.110.3.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 101 103 to 104 300
    #
    multicast routing-enable
    #
    acl number 3001
     rule 5 deny ip source 10.110.3.100 0 destination 225.1.1.0 0.0.0.3 
     rule 10 permit ip 
    #
    interface Vlanif101
     ip address 192.168.1.2 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif103
     ip address 192.168.2.2 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif104
     ip address 10.110.5.1 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif300
     ip address 10.110.4.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface 10GE1/17/1
     port default vlan 300
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 104
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    interface 10GE1/17/4
     port link-type trunk
     port trunk allow-pass vlan 103
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.110.4.0 0.0.0.255
      network 10.110.5.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     peer 192.168.1.1 connect-interface Vlanif101
     peer 10.110.5.2 connect-interface Vlanif104
     peer 10.110.5.2 sa-policy export 3001
    #
    return
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 104 400 500
    #
    multicast routing-enable
    #
    acl number 2001
     rule 5 deny source 10.110.6.100 0 
    #
    interface Vlanif104
     ip address 10.110.5.2 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif400
     ip address 10.110.6.1 255.255.255.0
     pim sm
    #
    interface Vlanif500
     ip address 10.110.7.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface 10GE1/17/1
     port default vlan 500
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 104
    #
    interface 10GE1/17/3
     port default vlan 400
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.110.5.0 0.0.0.255
      network 10.110.6.0 0.0.0.255
      network 10.110.7.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     import-source acl 2001
     peer 10.110.5.1 connect-interface Vlanif104
    #
    return
Translation
Download
Updated: 2019-12-13

Document ID: EDOC1000041694

Views: 60619

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next