No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 13

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Example

Configuration Example

Example for Configuring PIM-SM (IPv6) in the ASM Model

Networking Requirements

As shown in Figure 8-67, the shared network segment is connected to the Internet. HostA and HostB want to receive multicast data from Source.

Figure 8-67 Networking diagram for configuring PIM-SM (IPv6) in the ASM model

Configuration Roadmap

Configure the PIM-SM (IPv6) protocol on the switches to enable them to provide the ASM service for user hosts on the network. Then all the hosts in a multicast group can receive multicast data sent from any sources to this group.

  1. Configure an IPv6 address for each interface and an IPv6 unicast routing protocol. PIM (IPv6) is an intra-domain multicast routing protocol that depends on IPv6 unicast routing protocols.

  2. Enable the IPv6 multicast function on all switches to provide IPv6 multicast services. Before configuring PIM-SM (IPv6), you must enable the IPv6 multicast function.

  3. Enable PIM-SM (IPv6) on all interfaces. You can configure other PIM-SM (IPv6) functions only after PIM-SM (IPv6) is enabled.

  4. Enable MLD on interfaces that connect the switch and hosts. A receiver can join and leave a multicast group by sending MLD messages. The leaf switches maintain the multicast member relationship through MLD.

  5. Enable PIM silent (IPv6) on interfaces that connect the switch and hosts to prevent malicious hosts from simulating sending Hello packets. In this manner, security of PIM-SM (IPv6) domain is ensured.

    If the user host network segment connects to multiple switches, do not enable PIM silent (IPv6) on interfaces that connect these switches and user hosts. For example, PIM silent (IPv6) cannot be enabled on SwitchB and SwitchC in the figure.

  6. Configure the RP. In PIM-SM (IPv6) domain, RP is essential in providing ASM services and helps forward multicast data. You are advised to configure RP on switches that have more multicast flows. For example, you can configure RP on SwitchE in the figure.

  7. Configure the BSR boundary on interfaces connected to the Internet. The Bootstrap message cannot pass through the BSR boundary; therefore, the BSR serves only this PIM-SM (IPv6) domain. In this manner, multicast services can be controlled effectively.

Procedure

  1. Configure an IPv6 address for each interface and an IPv6 unicast routing protocol.

    # Configure the IPv6 address and mask for each interface shown in Figure 8-67, and configure OSPFv3 on each switch to ensure that switches can communicate at the network layer and can dynamically update routes through the IPv6 unicast routing protocol. The configuration of SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration of SwitchA, and are not provided here.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] ospfv3 100
    [*SwitchA-ospfv3-100] router-id 1.1.1.1
    [*SwitchA-ospfv3-100] quit
    [*SwitchA] vlan batch 10 20 30
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address 2001::1 64
    [*SwitchA-Vlanif10] ospfv3 100 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address 3001::1 64
    [*SwitchA-Vlanif20] ospfv3 100 area 0
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ipv6 enable
    [*SwitchA-Vlanif30] ipv6 address 2002::1 64
    [*SwitchA-Vlanif30] ospfv3 100 area 0
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface 10ge 1/17/1
    [*SwitchA-10GE1/17/1] port link-type hybrid
    [*SwitchA-10GE1/17/1] port hybrid untagged vlan 10
    [*SwitchA-10GE1/17/1] port hybrid pvid vlan 10
    [*SwitchA-10GE1/17/1] quit
    [*SwitchA] interface 10ge 1/17/2
    [*SwitchA-10GE1/17/2] port link-type hybrid
    [*SwitchA-10GE1/17/2] port hybrid untagged vlan 20
    [*SwitchA-10GE1/17/2] port hybrid pvid vlan 20
    [*SwitchA-10GE1/17/2] quit
    [*SwitchA] interface 10ge 1/17/3
    [*SwitchA-10GE1/17/3] port link-type hybrid
    [*SwitchA-10GE1/17/3] port hybrid untagged vlan 30
    [*SwitchA-10GE1/17/3] port hybrid pvid vlan 30
    [*SwitchA-10GE1/17/3] quit
    [*SwitchA] commit

  2. Enable multicast, and enable PIM-SM (IPv6) on all interfaces.

    # Enable IPv6 multicast on all switches and PIM-SM (IPv6) on all interfaces. The configuration of SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration of SwitchA, and are not provided here.

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim ipv6 sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] pim ipv6 sm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit

  3. Enable MLD on interfaces that connect the switch and hosts.

    # Enable MLD on interfaces that connect SwitchA and user hosts. The configuration of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not provided here.

    [~SwitchA] interface vlanif 20
    [~SwitchA-Vlanif20] mld enable
    [*SwitchA-Vlanif20] commit

  4. Enable PIM silent (IPv6) on interfaces on SwitchA.

    [~SwitchA-Vlanif20] pim ipv6 silent
    [*SwitchA-Vlanif20] commit
    [~SwitchA-Vlanif20] quit

  5. Configure the RP.

    # Configure the C-RP on SwitchE and specify the group address range served by the C-RP.

    [~SwitchE] acl ipv6 number 2001
    [*SwitchE-acl6-basic-2001] rule permit source ff1e::1 64
    [*SwitchE-acl6-basic-2001] quit
    [*SwitchE] pim ipv6
    [*SwitchE-pim6] c-rp 2005::2 group-policy 2001
    [*SwitchE-pim6] commit

    # Configure a C-BSR on SwitchE.

    [~SwitchE-pim6] c-bsr 2005::2
    [*SwitchE-pim6] commit
    [~SwitchE-pim6] quit

  6. Configure the BSR boundary on interfaces that connect SwitchD to the Internet.

    [~SwitchD] interface vlanif 70
    [~SwitchD-Vlanif70] pim ipv6 bsr-boundary
    [*SwitchD-Vlanif70] commit
    [~SwitchD-Vlanif70] quit

  7. Verify the configuration.

    # Run the display pim ipv6 interface command to check the PIM (IPv6) configuration and status. In this example, the PIM (IPv6) information on SwitchC is displayed as follows:

    [~SwitchC] display pim ipv6 interface
     PN-Instance: public net
     Interface           State NbrCnt HelloInt   DR-Pri     DR-Address
     Vlanif40            up    1      30         1          FE80::200:FF:FE13:21
     Vlanif50            up    1      30         1          FE80::200:FF:FE00:10(local)
    

    # Run the display pim ipv6 bsr-info command to check information about the BSR selection on the switch. For example, BSR information on SwitchA and SwitchE is displayed as follows (C-BSR information is also displayed on SwitchE).

    [~SwitchA] display pim ipv6 bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: 2005::2
         Priority: 0
         Hash mask length: 126
         State: Accept Preferred
         Uptime: 01:40:40
         Next BSR message scheduled at: 00:01:42
         C-RP Count: 1
    
    [~SwitchE] display pim ipv6 bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: 2005::2
         Priority: 0
         Hash Mask length: 126
         State: Elected
         Uptime: 00:00:18
         Next BSR message scheduled at :00:01:42
         C-RP Count: 1
     Candidate AdminScoped BSR Count: 0
     Candidate BSR Address: 2005::2
         Priority: 0
         Hash mask length: 126
         State:Elected
         Wait to be BSR: 0

    # Run the display pim ipv6 rp-info command to check the RP information on the switch. In this example, the RP information on SwitchA is displayed as follows:

    [~SwitchA] display pim ipv6 rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: FF0E::1/64
         RP: 2005::2
         Priority: 192
         Uptime: 00:05:19
         Expires: 00:02:11
    

    # Run the display pim ipv6 routing-table command to view the PIM (IPv6) multicast routing table. Multicast source S (5001::5/64) sends multicast packets to multicast groups FF1E::1/64 and FF1E::2/64. HostA needs to receive data sent to group FF1E::1, and HostB needs to receive data sent to group FF1E::2.

    By default, after the receiver's DR receives the first multicast data, an SPT switchover is performed and (S, G) routing entries are created. Therefore, (S, G) routing entries displayed on the switch are (S, G) entries after the SPT switchover.

    [~SwitchA] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, FF1E::1)
         RP: 2005::2
         Protocol: pim-sm, Flag: WC
         UpTime: 00:02:15
         Upstream interface: Vlanif10
             Upstream neighbor: FE80::9D62:0:FDC5:2
             RPF prime neighbor: FE80::9D62:0:FDC5:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: mld, UpTime: 00:02:15, Expires:  -
    
     (5001::5, FF1E::1)
         RP: 2005::2
         Protocol: pim-sm, Flag: SPT LOC ACT
         UpTime: 00:00:11
         Upstream interface: Vlanif30
             Upstream neighbor: FE80::A01:10C:1
             RPF prime neighbor: FE80::A01:10C:1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: pim-sm, UpTime: 00:00:11, Expires: -
    
    
    [~SwitchB] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, FF1E::2)
         RP: 2005::2
         Protocol: pim-sm, Flag: WC
         UpTime: 00:14:44
         Upstream interface: Vlanif90
             Upstream neighbor: FE80::33FE:0:852C:2
             RPF prime neighbor: FE80::33FE:0:852C:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: mld, UpTime: 00:14:44, Expires: -
    
     (5001::5, FF1E::2)
         RP: 2005::2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:2:42
         Upstream interface: Vlanif90
             Upstream neighbor: FE80::33FE:0:852C:2
             RPF prime neighbor: FE80::33FE:0:852C:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-sm, UpTime: 00:14:44, Expires: -
    
    
    [~SwitchC] display pim ipv6 routing-table
    VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (5001::5, FF1E::2)
         RP: 2005::2
         Protocol: pim-sm, Flag:
         UpTime: 00:2:42
         Upstream interface: Vlanif50
             Upstream neighbor: FE80::71FE:11:21
             RPF prime neighbor: FE80::71FE:11:21
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-sm, UpTime: 00:13:46, Expires: -
    
    
    [~SwitchD] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 2 (S, G) entry
     (5001::5, FF1E::1)
         RP: 2005::2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:16:56
         Upstream interface: Vlanif80
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif30
                 Protocol: pim-sm, UpTime: 00:16:56, Expires: 00:02:34
    
     (5001::5, FF1E::2)
         RP: 2005::2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:02:54
         Upstream interface: Vlanif80
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
                1: Vlanif60
                 Protocol: pim-sm, UpTime: 00:02:54, Expires: 00:02:36
    
    
    [~SwitchE] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 2 (*, G) entry; 2 (S, G) entry
    
     (*, FF1E::1)
         RP: 2005::2(local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:02:15
         Upstream interface: Register
             Upstream neighbor: FE80::9D62:0:FDC5:2
             RPF prime neighbor: FE80::9D62:0:FDC5:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -
    
     (5001::5, FF1E::1)
         RP: 2005::2(local)
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:16:56
         Upstream interface: Vlanif60
             Upstream neighbor: FE80::659:10C:3
             RPF prime neighbor: FE80::659:10C:3
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10
                 Protocol: pim-sm, UpTime: 00:16:56, Expires: 00:02:34
    
     (*, FF1E::2)
         RP: 2005::2(local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:02:15
         Upstream interface: Register
             Upstream neighbor: FE80::659:10C:3
             RPF prime neighbor: FE80::659:10C:3
         Downstream interface(s) information:
         Total number of downstreams: 2
             1: Vlanif90
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -
             2: Vlanif50
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -
    
     (5001::5, FF1E::2)
         RP: 2005::2(local)
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:02:54
         Upstream interface: Vlanif60
             Upstream neighbor: FE80::659:10C:3
             RPF prime neighbor: FE80::659:10C:3
         Downstream interface(s) information:
         Total number of downstreams: 2
             1: Vlanif90
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -
             2: Vlanif50
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20 30
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 1.1.1.1  
     area 0.0.0.0 
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 2001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 3001::1/64
     pim ipv6 silent
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address 2002::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 40 90
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 2.2.2.2
     area 0.0.0.0 
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address 4001::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif90
     ipv6 enable
     ipv6 address 2003::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 90
     port hybrid untagged vlan 90
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 40 50
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 3.3.3.3 
     area 0.0.0.0 
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address 4001::2/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address 2004::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 50
     port hybrid untagged vlan 50
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    vlan batch 30 60 70 80
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 4.4.4.4 
     area 0.0.0.0 
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address 2002::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address 2005::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif70
     ipv6 enable
     ipv6 address 6001::1/64
     pim ipv6 bsr-boundary
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address 5001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 80
     port hybrid untagged vlan 80
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 70
     port hybrid untagged vlan 70
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    interface 10GE1/17/4
     port link-type hybrid
     port hybrid pvid vlan 60
     port hybrid untagged vlan 60
    #
    return
  • Configuration file of SwitchE

    #
    sysname SwitchE
    #
    vlan batch 10 50 60 90
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2001
     rule 0 permit source FF1E::1/64
    #
    ospfv3 100
     router-id 5.5.5.5 
     area 0.0.0.0 
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 2001::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address 2004::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address 2005::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif90
     ipv6 enable
     ipv6 address 2003::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 50
     port hybrid untagged vlan 50
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 90
     port hybrid untagged vlan 90
    #
    interface 10GE1/17/4
     port link-type hybrid
     port hybrid pvid vlan 60
     port hybrid untagged vlan 60
    #
    pim ipv6
     c-bsr 2005::2
     c-rp 2005::2 group-policy 2001
    #
    return

Example for Configuring PIM-SM (IPv6) in the SSM Model

Networking Requirements

As shown in Figure 8-68, HostA wants to receive multicast data from S1 and S2, while HostB wants to receive multicast data from S2.

Figure 8-68 Networking diagram for configuring PIM-SM (IPv6) in the SSM model

Configuration Roadmap

Configure the PIM-SM (IPv6) protocol on the switches to enable them to provide the SSM service for user hosts on the network. Then hosts in a multicast group can receive multicast data sent from specified sources to this group.

  1. Configure an IPv6 address for each interface and an IPv6 unicast routing protocol. PIM (IPv6) is an intra-domain multicast routing protocol that depends on IPv6 unicast routing protocols.

  2. Enable the IPv6 multicast function on switches providing multicast services. Before configuring PIM-SM (IPv6), you must enable the IPv6 multicast function.

  3. Enable PIM-SM (IPv6) on all interfaces. You can configure other PIM-SM (IPv6) functions only after PIM-SM (IPv6) is enabled.

  4. Enable MLD on interfaces that connect the switch and hosts and set the MLD version to MLDv2. A receiver can join and leave a multicast group of a specified source by sending MLD messages. The leaf switches maintain the multicast member relationship through MLD.

  5. Enable PIM silent (IPv6) on interfaces that connect the switch and hosts to prevent malicious hosts from simulating sending Hello packets. In this manner, security of PIM-SM (IPv6) domain is ensured.

    If the user host network segment connects to multiple switches, do not enable PIM silent (IPv6) on interfaces that connect these switches and user hosts. For example, PIM (IPv6) silent cannot be enabled on SwitchB and Switch C.

  6. Configure the address range for SSM groups on each switch. Ensure that switches in the PIM-SM (IPv6) domain provide services only for multicast groups in the range of SSM group addresses. In this manner, multicast can be controlled effectively.

    SSM group address range configured on each switch must be the same.

Procedure

  1. Configure an IPv6 address for each interface and an IPv6 unicast routing protocol.

    # Configure the IPv6 address and mask for each interface shown in Figure 8-68, and configure OSPFv3 on each switch to ensure that switches can communicate at the network layer and can dynamically update routes through the IPv6 unicast routing protocol.. The configuration details are not provided here. The configuration of SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration of SwitchA, and are not mentioned.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20 30
    [*SwitchA] interface 10ge 1/17/1
    [*SwitchA-10GE1/17/1] port link-type hybrid
    [*SwitchA-10GE1/17/1] port hybrid pvid vlan 10
    [*SwitchA-10GE1/17/1] port hybrid untagged vlan 10
    [*SwitchA-10GE1/17/1] quit
    [*SwitchA] interface 10ge 1/17/2
    [*SwitchA-10GE1/17/2] port link-type hybrid
    [*SwitchA-10GE1/17/2] port hybrid pvid vlan 30
    [*SwitchA-10GE1/17/2] port hybrid untagged vlan 30
    [*SwitchA-10GE1/17/2] quit
    [*SwitchA] interface 10ge 1/17/3
    [*SwitchA-10GE1/17/3] port link-type hybrid
    [*SwitchA-10GE1/17/3] port hybrid pvid vlan 20
    [*SwitchA-10GE1/17/3] port hybrid untagged vlan 20
    [*SwitchA-10GE1/17/3] quit
    [*SwitchA] ospfv3 100
    [*SwitchA-ospfv3-100] router-id 1.1.1.1
    [*SwitchA-ospfv3-100] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address 2005::1 64
    [*SwitchA-Vlanif10] ospfv3 100 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address 3001::1 64
    [*SwitchA-Vlanif20] ospfv3 100 area 0
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ipv6 enable
    [*SwitchA-Vlanif30] ipv6 address 2001::1 64
    [*SwitchA-Vlanif30] ospfv3 100 area 0
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit
    

  2. Enable IPv6 multicast, and enable PIM-SM (IPv6) on all interfaces.

    # Enable IPv6 multicast on all switches and PIM-SM (IPv6) on all interfaces. The configuration of SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration of SwitchA, and are not mentioned.

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim ipv6 sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] pim ipv6 sm
    [*SwitchA-Vlanif30] commit
    [~SwitchA-Vlanif30] quit

  3. Enable MLD on interfaces that connect the switch and hosts and set the MLD version to MLDv2.

    # Enable MLD on interfaces that connect SwitchA and user hosts. The configuration of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not provided here.

    [~SwitchA] interface vlanif 20
    [~SwitchA-Vlanif20] mld enable
    [*SwitchA-Vlanif20] mld version 2
    [*SwitchA-Vlanif20] commit

  4. Enable PIM silent (IPv6) on interfaces on SwitchA.

    [~SwitchA-Vlanif20] pim ipv6 silent
    [*SwitchA-Vlanif20] commit
    [~SwitchA-Vlanif20] quit

  5. Configure the address range for SSM groups.

    # Set the range of SSM group addresses to ff3e::/64 on all the switches. The configurations of SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration of SwitchA, and are not provided here.

    [~SwitchA] acl ipv6 number 2000
    [*SwitchA-acl6-basic-2000] rule permit source ff3e:: 64
    [*SwitchA-acl6-basic-2000] quit
    [*SwitchA] pim ipv6
    [*SwitchA-pim6] ssm-policy 2000
    [*SwitchA-pim6] commit
    [~SwitchA-pim6] quit
    

  6. Verify the configuration.

    # Run the display pim ipv6 interface command to check the PIM (IPv6) configuration and status. The PIM (IPv6) information on SwitchC is displayed as follows:

    [~SwitchC] display pim ipv6 interface
    VPN-Instance: public net
    Interface       State   NbrCnt   HelloInt   DR-Pri     DR-Address
    Vlanif40        up      1         30         1         FE80::200:FF:FE13:21
    Vlanif50        up      1         30         1         FE80::200:FF:FE00:10(local)

    # Run the display pim ipv6 routing-table command to view the PIM (IPv6) routing table. HostA receives information sent from multicast source 5001::100/64 and 6001::100/64 to the multicast group FF3E::1/64. HostB receives information sent from multicast source 5001::100/64 to multicast group FF3E::1/64. The following information is displayed.

    [~SwitchA] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 2 (S, G) entries
     
     (5001::100, FF3E::1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:13:46
         Upstream interface: Vlanif10, 
             Upstream neighbor: FE80::9D62:0:FDC5:2
             RPF prime neighbor: FE80::9D62:0:FDC5:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: mld, UpTime: 00:13:46, Expires:-
     
     (6001::100, FF3E::1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif30
             Upstream neighbor: FE80::A01:10C:1
             RPF prime neighbor: FE80::A01:10C:1
        Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: mld, UpTime: 00:00:42, Expires:-
    
    [~SwitchB] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (S, G) entry
     
     (5001::100, FF3E::1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:10:12
         Upstream interface: Vlanif90 
             Upstream neighbor: FE80::33FE:0:852C:2
             RPF prime neighbor: FE80::33FE:0:852C:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: mld, UpTime: 00:10:12, Expires:-
    
    [~SwitchC] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (S, G) entry
    
     (5001::100, FF3E::1)
         Protocol: pim-ssm, Flag:
         UpTime: 00:01:25
         Upstream interface: Vlanif50
             Upstream neighbor: FE80::A11:110C:11
             RPF prime neighbor: FE80::A11:110C:11
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: mld, UpTime: 00:01:25, Expires:-
    
    [~SwitchD] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (S, G) entry
     
     (5001::100, FF3E::1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif80
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: pim-ssm, UpTime: 00:00:42, Expires:-
    
    [~SwitchE] display pim ipv6 routing-table
    VPN-Instance: public net
     Total 1 (S, G) entry
     
     (5001::100, FF3E::1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:13:16
         Upstream interface: Vlanif 60
             Upstream neighbor: FE80::9D62:0:FDC5:2
             RPF prime neighbor: FE80::9D62:0:FDC5:21
         Downstream interface(s) information:
         Total number of downstreams: 3
             1: Vlanif10
                 Protocol: pim-ssm, UpTime: 00:12:15, Expires: 00:04:32
             2: Vlanif50
                 Protocol: pim-ssm, UpTime: 00:11:17, Expires: 00:02:55
             3: Vlanif90
                 Protocol: pim-ssm, UpTime: 00:13:16, Expires: 00:03:22
    
    [~SwitchF] display pim ipv6 routing-table
    VPN-Instance: public net
     Total 1 (S, G) entry
     
     (6001::100, FF3E::1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:13:16
         Upstream interface: Vlanif70
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif30
                 Protocol: pim-ssm, UpTime: 00:15:28, Expires: 00:05:21
    

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20 30
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 0 permit source FF3E::/64
    #
    ospfv3 100
     router-id 1.1.1.1 
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 2005::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 3001::1/64
     pim ipv6 silent
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface vlanif 30
     ipv6 enable
     ipv6 address 2001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    pim ipv6
     ssm-policy 2000
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 40 90
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 0 permit source FF3E::/64
    #
    ospfv3 100
     router-id 2.2.2.2 
     area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address 4001::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif90
     ipv6 enable
     ipv6 address 2002::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 90
     port hybrid untagged vlan 90
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    pim ipv6
     ssm-policy 2000
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 40 50
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 0 permit source FF3E::/64
    #
    ospfv3 100
     router-id 3.3.3.3 
     area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address 4001::2/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address 2003::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 50
     port hybrid untagged vlan 50
    #
    pim ipv6
     ssm-policy 2000
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    vlan batch 60 80
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 0 permit source FF3E::/64
    #
    ospfv3 100
     router-id 4.4.4.4 
     area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address 2004::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address 5001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 80
     port hybrid untagged vlan 80
    #
    interface 10GE1/17/4
     port link-type hybrid
     port hybrid pvid vlan 60
     port hybrid untagged vlan 60
    #
    pim ipv6
     ssm-policy 2000
    #
    return
  • Configuration file of SwitchE

    #
    sysname SwitchE
    #
    vlan batch 10 50 60 90
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 0 permit source FF3E::/64
    #
    ospfv3 100
     router-id 5.5.5.5 
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 2005::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address 2003::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address 2004::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif90
     ipv6 enable
     ipv6 address 2002::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 50
     port hybrid untagged vlan 50
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 90
     port hybrid untagged vlan 90
    #
    interface 10GE1/17/4
     port link-type hybrid
     port hybrid pvid vlan 60
     port hybrid untagged vlan 60
    #
    pim ipv6
     ssm-policy 2000
    #
    return
  • Configuration file of SwitchF

    #
    sysname SwitchF
    #
    vlan batch 30 70
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 0 permit source FF3E::/64
    #
    ospfv3 100
     router-id 6.6.6.6 
     area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address 2001::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif70
     ipv6 enable
     ipv6 address 6001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 70
     port hybrid untagged vlan 70
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    pim ipv6
     ssm-policy 2000
    #
    return

Example for Configuring PIM (IPv6) for Anycast RP

Networking Requirements

Receiver1 and Receiver2 in Figure 8-69 receive VoD information in multicast mode. When the network is overloaded or traffic is concentrated on an RP, the RP may be overburdened or fails and the route convergence may be slow. Receiver2 is required to join the closest RP to fast receive the multicast data.

Figure 8-69 Networking diagram for configuring PIM (IPv6) for Anycast RP

Configuration Roadmap

Configuring PIM (IPv6) for anycast RP reduces the burden on an RP and hosts can join the closest RP.

  1. Configure IP addresses for interfaces of each switch modules, and configure OSPFv3 to implement IP interworking.

  2. Enable the multicast function and enable PIM-SM (IPv6) on each interface.

  3. Enable MLD on the interfaces that connect switch modules to hosts.

  4. Configure loopback 0 on Switch ModuleC and Switch ModuleD as C-RP and C-BSR respectively.

  5. Configure loopback 0 on Switch ModuleC and Switch ModuleD as Anycast RPs.

  6. Configure the addresses of loopback 0 on Switch ModuleC and Switch ModuleD as local addresses of Anycast RPs.

  7. Set an Anycast RP peer relationship between Switch ModuleC and Switch ModuleD.

Procedure

  1. Configure an IP address for each interface and configure the unicast routing protocol.

    # Configure an IP address and mask for each interface according to Figure 8-69. Configure OSPFv3 on each switch to ensure IP connectivity between them, and enable them to dynamically update routing information. The configuration of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned. See the configuration files for the configurations.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] ospfv3 100
    [*SwitchA-ospfv3-100] router-id 1.1.1.1
    [*SwitchA-ospfv3-100] quit
    [*SwitchA] vlan batch 10 20
    [*SwitchA] interface 10ge 1/17/1
    [*SwitchA-10GE1/17/1] port link-type hybrid
    [*SwitchA-10GE1/17/1] port hybrid untagged vlan 10
    [*SwitchA-10GE1/17/1] port hybrid pvid vlan 10
    [*SwitchA-10GE1/17/1] quit
    [*SwitchA] interface 10ge 1/17/2
    [*SwitchA-10GE1/17/2] port link-type hybrid
    [*SwitchA-10GE1/17/2] port hybrid untagged vlan 20
    [*SwitchA-10GE1/17/2] port hybrid pvid vlan 20
    [*SwitchA-10GE1/17/2] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address 3001::1 64
    [*SwitchA-Vlanif10] ospfv3 100 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address 2001::1 64
    [*SwitchA-Vlanif20] ospfv3 100 area 0
    [*SwitchA-Vlanif20] quit
    [*SwitchA] commit

  2. Enable IPv6 multicast routing on all switchs and PIM-SM (IPv6) on all interfaces.

    # Enable IPv6 multicast routing on all switchs and enable PIM-SM (IPv6) on all interfaces. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned here. See the configuration files for the configurations.

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim ipv6 sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] commit

  3. Enable MLD on the interfaces that connect the switch modules to hosts.

    # Enable IGMP on the interfaces that connect SwitchC and SwitchD to hosts.

    # Configure SwitchC.

    [~SwitchC] interface vlanif 30
    [~SwitchC-Vlanif30] mld enable
    [*SwitchC-Vlanif30] quit
    [*SwitchC] commit

    # Configure SwitchD.

    [~SwitchD] interface vlanif 60
    [~SwitchD-Vlanif60] mld enable
    [*SwitchD-Vlanif60] quit
    [*SwitchD] commit

  4. Configure loopback 0 on SwitchC and SwitchD as the C-RP and C-BSR respectively.

    # Configure SwitchC.

    [~SwitchC] pim ipv6
    [*SwitchC-pim6] c-bsr 1::1
    [*SwitchC-pim6] c-rp 1::1
    [*SwitchC-pim6] quit
    [*SwitchC] commit

    # Configure SwitchD.

    [~SwitchD] pim ipv6
    [*SwitchD-pim6] c-bsr 1::1
    [*SwitchD-pim6] c-rp 1::1
    [*SwitchD-pim6] quit
    [*SwitchD] commit

  5. Configure loopback 0 on SwitchC and SwitchD as Anycast RPs.

    # Configure SwitchC.

    [~SwitchC] pim ipv6
    [~SwitchC-pim6] anycast-rp 1::1
    [*SwitchC-pim6-anycast-rp-1::1] quit
    [*SwitchC-pim6] quit
    [*SwitchC] commit

    # Configure SwitchD.

    [~SwitchD] pim ipv6
    [~SwitchD-pim6] anycast-rp 1::1
    [*SwitchD-pim6-anycast-rp-1::1] quit
    [*SwitchD-pim6] quit
    [*SwitchD] commit

  6. Configure the addresses of loopback 0 on SwitchC and SwitchD as local addresses of Anycast RPs.

    # Configure SwitchC.

    [~SwitchC] pim ipv6
    [~SwitchC-pim6] anycast-rp 1::1
    [*SwitchC-pim6-anycast-rp-1::1] local-address 2::2
    [*SwitchC-pim6-anycast-rp-1::1] quit
    [*SwitchC-pim6] quit
    [*SwitchC] commit

    # Configure SwitchD.

    [~SwitchD] pim ipv6
    [~SwitchD-pim6] anycast-rp 1::1
    [*SwitchD-pim6-anycast-rp-1::1] local-address 3::3
    [*SwitchD-pim6-anycast-rp-1::1] quit
    [*SwitchD-pim6] quit
    [*SwitchD] commit

  7. Set an Anycast RP peer relationship between SwitchC and SwitchD.

    # Configure SwitchC.

    [~SwitchC] pim ipv6
    [~SwitchC-pim6] anycast-rp 1::1
    [*SwitchC-pim6-anycast-rp-1::1] peer 3::3
    [*SwitchC-pim6-anycast-rp-1::1] quit
    [*SwitchC-pim6] quit
    [*SwitchC] commit

    # Configure SwitchD.

    [~SwitchD] pim ipv6
    [~SwitchD-pim6] anycast-rp 1::1
    [*SwitchD-pim6-anycast-rp-1::1] peer 2::2
    [*SwitchD-pim6-anycast-rp-1::1] quit
    [*SwitchD-pim6] quit
    [*SwitchD] commit

  8. Verify the configuration.

    # Run the display pim ipv6 rp-info command on SwitchC and SwitchD to check RP information.

    [~SwitchC] display pim ipv6 rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: FF00::/8
         RP: 1::1 (local)
         Priority: 192
         Uptime: 00:06:34
         Expires: 00:01:56
    
    [~SwitchD] display pim ipv6 rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: FF00::/8
         RP: 1::1 (local)
         Priority: 192
         Uptime: 00:06:34
         Expires: 00:01:56
    

    The command output shows that SwitchC and SwitchD serve as RPs and forward the Register message from the multicast source to each other.

    # Run the display pim ipv6 routing-table command to check PIM entries on each switch modules. Source (3001::2/64) in the PIM-SM domain sends multicast data to multicast group G (ff2e::1). Receiver2 joins G and receives the multicast data sent to G. Source sends a Register message to SwitchC and Receiver2 sends a Join message to SwitchD.

    [~SwitchC] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (3001::2, FF2E::1)
         RP: 1::1 (local)
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:00:38
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif30
                 Protocol: pim-sm, UpTime: 00:01:25, Expires: -
    
    
    [~SwitchD] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, FF2E::1)
         RP: 1::1 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:01:25
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: pim-sm, UpTime: 00:01:25, Expires: -
    
     (3001::2, FF2E::1)
         RP: 1::1 (local)
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:00:02
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: pim-sm, UpTime: 00:00:02, Expires: -

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 1.1.1.1
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 3001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 2001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 50
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 2.2.2.2
     area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address 2002::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 50
     port hybrid untagged vlan 50
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 20 30 40
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 3.3.3.3
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 2001::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address 3002::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address 2003::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    interface LoopBack0
     ipv6 enable
     ipv6 address 1::1/128
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface LoopBack1
     ipv6 enable
     ipv6 address 2::2/128
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    pim ipv6
     c-bsr 1::1
     c-rp 1::1
     anycast-rp 1::1
      local-address 2::2
      peer 3::3
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    vlan batch 40 50 60
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 4.4.4.4
     area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address 2003::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address 2002::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address 3003::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 50
     port hybrid untagged vlan 50
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 60
     port hybrid untagged vlan 60
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    interface LoopBack0
     ipv6 enable
     ipv6 address 1::1/128
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface LoopBack1
     ipv6 enable
     ipv6 address 3::3/128
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    pim ipv6
     c-bsr 1::1
     c-rp 1::1
     anycast-rp 1::1
      local-address 3::3
      peer 2::2
    #
    return
    

Example for Configuring Basic Bidir-PIM (IPv6) Functions

Networking Requirements

Figure 8-70 shows the IPv6 campus network of an enterprise. A multicast protocol is required on the network to allow multi-party video conferences among users connected to the network.

Figure 8-70 Networking diagram for basic Bidir-PIM (IPv6) configurations

Configuration Roadmap

If a multi-party video conferencing network runs PIM-SM (IPv6) to provide multicast services for many users, switches on the network will be overloaded because a lot of forwarding resources are consumed on the switches. To conserve the forwarding resources on the switches, configure Bidir-PIM (IPv6) on this network. The configuration roadmap is as follows:

  1. Assign IPv6 addresses to interfaces and configure an IPv6 unicast routing protocol on the switches. Ensure that the IPv6 unicast routing protocol works normally.

  2. Enable Bidir-PIM (IPv6) on all the switches that need to provide multicast services. Other Bidir-PIM (IPv6) functions can be configured only after Bidir-PIM (IPv6) is enabled.

  3. Enable PIM-SM (IPv6) on all switch interfaces. Bidir-PIM (IPv6) uses the same neighbor discovery mechanism as PIM-SM (IPv6). PIM-SM (IPv6) must be enabled on interfaces so that neighbor relationships can be set up between the switches.

  4. Enable MLD on the interfaces connected to network segments of the hosts. Ensure that the receiver hosts can access the multicast network.

  5. Configure SwitchE as the RP and configure it to serve Bidir-PIM (IPv6). An RP is usually deployed on a device with multiple branches for multicast data forwarding.

Procedure

  1. Assign IPv6 addresses to interfaces and configure an IPv6 unicast routing protocol on the switches.

    # Configure IPv6 addresses and masks for switch interfaces according to Figure 8-70. Configure OSPFv3 on the switches to implement IPv6 interworking between the switches and enable the switches to dynamically update routes. The configurations on Switch ModuleB, Switch ModuleC, Switch ModuleD, and Switch ModuleE are similar to the configuration on Switch ModuleA, and are not mentioned here.

    # Add interfaces of Switch ModuleA to VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 10 50
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port default vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] port link-type trunk
    [*Switch ModuleA-10GE1/17/2] port trunk allow-pass vlan 50
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] commit
    

    # Assign IPv6 addresses to VLANIF interfaces on Switch ModuleA.

    [~Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ipv6 enable
    [*Switch ModuleA-Vlanif10] ipv6 address 3001::1 64
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] interface vlanif 50
    [*Switch ModuleA-Vlanif50] ipv6 enable
    [*Switch ModuleA-Vlanif50] ipv6 address 2001::1 64
    [*Switch ModuleA-Vlanif50] quit
    [*Switch ModuleA] commit

    # Configure a routing protocol on Switch ModuleA. OSPFv3 is used in this example.

    [~Switch ModuleA] ospfv3
    [*Switch ModuleA-ospfv3-1] router-id 1.1.1.1
    [*Switch ModuleA-ospfv3-1] quit
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ospfv3 1 area 0
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] interface vlanif 50
    [*Switch ModuleA-Vlanif50] ospfv3 1 area 0
    [*Switch ModuleA-Vlanif50] quit
    [*Switch ModuleA] commit

  2. Enable Bidir-PIM (IPv6) globally and enable PIM-SM (IPv6) on all interfaces.

    # Enable Bidir-PIM (IPv6) globally on all switches and enable PIM-SM (IPv6) on all interfaces. The configurations on Switch ModuleB, Switch ModuleC, Switch ModuleD, and Switch ModuleE are similar to the configuration on Switch ModuleA, and are not mentioned here.

    [~Switch ModuleA] multicast ipv6 routing-enable
    [*Switch ModuleA] pim ipv6
    [*Switch ModuleA-pim6] bidir-pim
    [*Switch ModuleA-pim6] quit
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] pim ipv6 sm
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit
    [~Switch ModuleA] interface vlanif 50
    [~Switch ModuleA-Vlanif50] pim ipv6 sm
    [*Switch ModuleA-Vlanif50] commit
    [~Switch ModuleA-Vlanif50] quit
    

  3. Enable MLD on interfaces directly connected to network segments of hosts.

    # Enable MLD on interface of Switch ModuleA connected to the network segment of HostA. The configurations on Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration on Switch ModuleA, and are not mentioned here.

    [~Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] mld enable
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit
    

  4. Configure an RP.

    # Configure VLANIF 60 (with IPv6 address 2002::2) on the Switch ModuleE as a C-RP and C-BSR interface, and configure the C-RP to serve Bidir-PIM (IPv6).

    [~Switch ModuleE] pim ipv6
    [*Switch ModuleE-pim6] c-bsr 2002::2 
    [*Switch ModuleE-pim6] c-rp 2002::2 bidir
    [*Switch ModuleE-pim6] commit
    [~Switch ModuleE-pim6] quit
    

  5. Verify the configuration.

    # Run the display pim ipv6 bsr-info command on the switches to view BSR information. For example, BSR information on Switch ModuleA and Switch ModuleE is displayed as follows. (The command output on Switch ModuleE also displays C-BSR information.)

    [~Switch ModuleA] display pim ipv6 bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: 2002::2
         Priority: 0
         Hash mask length: 126
         State: Accept Preferred
         Uptime: 01:40:40
         Expires: 00:01:42
         C-RP Count: 1
    
    
    [~Switch ModuleE] display pim ipv6 bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: 2002::2
         Priority: 0
         Hash mask length: 126
         State: Elected
         Uptime: 00:00:18
         Next BSR message scheduled at :00:01:42
         C-RP Count: 1
     Candidate AdminScoped BSR Count: 0
     Candidate BSR Address: 2002::2
         Priority: 0
         Hash mask length: 126
         State:Elected
         Wait to be BSR: 0

    The preceding information shows that the addresses of the elected BSR and C-BSR are both 2002::2, IPv6 address of VLANIF60 on SwitchE.

    # Run the display pim ipv6 rp-info command on the switches to check RP information. For example, RP information on Switch ModuleA is as follows:

    [~Switch ModuleA] display pim ipv6 rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number: 1
     Group/MaskLen: FF00::/8
         RP: 2002::2
         Priority: 192
         Uptime: 00:45:13
         Expires: 00:02:17
         BIDIR: Y
    

    The preceding information shows that the address of the elected RP is 2002::2 (IPv6 address of VLANIF60 on SwitchE), and the elected RP serves Bidir-PIM (IPv6).

    # Run the display pim ipv6 df-info command on the switches to check DF information. For example, DF information on SwitchA and SwitchE is as follows:

    [~Switch ModuleA] display pim ipv6 df-info
     VPN-Instance: public net
     Total Number of DF = 2
    
     RP: 2002::2
     Interface           DF-Address                            DF-Uptime     Rpf-Interface
     Vlanif10            FE80::225:9E00:C895:7C21(local)       22:25:01      N
     Vlanif50            FE80::2E0:3FFF:FE27:AE05              22:25:01      Y
    [~Switch ModuleE] display pim ipv6 df-info
     VPN-Instance: public net
     Total Number of DF = 4
    
     RP: 2002::2
     Interface           DF-Address                                DF-Uptime     Rpf-Interface
     Vlanif50            FE80::2E0:3FFF:FE27:AE05(local)           22:31:44      N
     Vlanif60            -                                         -             Y
     Vlanif70            FE80::1E2:4CFD:FE23:BC01(local)           22:31:44      N
     Vlanif80            FE80::324:2D23:DF18:2F3D(local)           22:31:44      N

    # After HostA, HostB, HostC, and HostD join group FF1E::1 using MLD, you can run the display pim ipv6 routing-table command on the switches to view the PIM (IPv6) routing table. For example, the PIM (IPv6) routing table on SwitchA is as follows:

    [~Switch ModuleA] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
    
     (*, FF1E::1)
         RP: 2002::2
         Protocol: bidir-pim, Flag: WC
         UpTime: 22:36:47
         Rpf interface: Vlanif50
             Upstream neighbor: FE80::2E0:3FFF:FE27:AE05
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif10
                 Protocol: mld, UpTime: 22:36:46, Expires: - 
            2: Vlanif50(RPF)
                 Protocol: bidir-pim, UpTime: 22:36:47, Expires: -

    You can see that the routing entries are generated by Bidir-PIM (IPv6), and multicast data sent from the hosts (multicast sources) can be forwarded along the bidirectional RPT set up based on the (*, FF1E::1) entry.

Configuration Files

  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 50
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 1.1.1.1
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 3001::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address 2001::1/64
     pim ipv6 sm 
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/17/1
     port default vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    pim ipv6
     bidir-pim
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 20 60
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 2.2.2.2
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 3002::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address 2002::1/64
     pim ipv6 sm 
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/17/1
     port default vlan 20
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    pim ipv6
     bidir-pim
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 30 70
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 3.3.3.3
     area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address 3003::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif70
     ipv6 enable
     ipv6 address 2003::1/64
     pim ipv6 sm 
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/17/1
     port default vlan 30
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    pim ipv6
     bidir-pim
    #
    return
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 40 80
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 4.4.4.4
     area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address 3004::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address 2004::1/64
     pim ipv6 sm 
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/17/1
     port default vlan 40
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    pim ipv6
     bidir-pim
    #
    return
  • Configuration file of Switch ModuleE

    #
    sysname Switch ModuleE
    #
    vlan batch 50 60 70 80
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 5.5.5.5
     area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address 2001::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address 2002::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif70
     ipv6 enable
     ipv6 address 2003::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address 2004::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    interface 10GE1/17/4
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    pim ipv6
     c-bsr 2002::2
     bidir-pim
     c-rp 2002::2 bidir
    #
    return

Example for Configuring Bidir-PIM (IPv6) and PIM-SM (IPv6) on the Same Network

Networking Requirements

On the network shown in Figure 8-71, HostA needs to receive data for multicast group FF1E::1 through Bidir-PIM (IPv6), and HostB needs to receive for multicast group FF2E::1 through PIM-SM (IPv6).

Figure 8-71 Bidir-PIM (IPv6) and PIM-SM (IPv6) on the same network

Configuration Roadmap

Configure dynamic RPs to serve Bidir-PIM (IPv6) and PIM-SM (IPv6) on Switch ModuleA and configure ACL rules to define the range of multicast groups served by dynamic RPs. In this way, both Bidir-PIM (IPv6) and PIM-SM (IPv6) can function on the network. The configuration roadmap is as follows:

  1. Assign IPv6 addresses to interfaces and configure a unicast routing protocol on each switch modules.

  2. Enable IPv6 multicast routing on all the switch moduleses that provide multicast services.

  3. Enable Bidir-PIM (IPv6) on all the switch moduleses that provide multicast services.

  4. Enable PIM-SM (IPv6) on all interfaces of the switch moduleses that provide multicast services.

  5. Enable MLD on switch modules interfaces directly connected to hosts.

  6. Configure the dynamic RP function. On Switch ModuleA, configure dynamic RPs on different interfaces to serve Bidir-PIM (IPv6) and PIM-SM (IPv6) respectively, and configure ACL rules to define the range of multicast groups served by dynamic RPs.

Procedure

  1. Assign IPv6 addresses to interfaces and configure a unicast routing protocol on each switch modules.

    # Configure IPv6 addresses and masks for switch interfaces according to Figure 8-71. Configure OSPFv3 on the switches to implement IPv6 interworking between the switches and enable the switches to dynamically update routes. The configurations of Switch ModuleB and Switch ModuleC are similar to the configuration of Switch ModuleA, and are not mentioned here.

    # Add interfaces of Switch ModuleA to VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 30 100 200
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port default vlan 30
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] port link-type trunk
    [*Switch ModuleA-10GE1/17/2] port trunk allow-pass vlan 100
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] interface 10ge 1/17/3
    [*Switch ModuleA-10GE1/17/3] port link-type trunk
    [*Switch ModuleA-10GE1/17/3] port trunk allow-pass vlan 200
    [*Switch ModuleA-10GE1/17/3] quit
    [*Switch ModuleA] commit
    

    # Assign IPv6 addresses to interfaces of Switch ModuleA.

    [~Switch ModuleA] interface vlanif 30
    [*Switch ModuleA-Vlanif30] ipv6 enable
    [*Switch ModuleA-Vlanif30] ipv6 address 2001:3::1 64
    [*Switch ModuleA-Vlanif30] quit
    [*Switch ModuleA] interface vlanif 100
    [*Switch ModuleA-Vlanif100] ipv6 enable
    [*Switch ModuleA-Vlanif100] ipv6 address 2002:1::1 64
    [*Switch ModuleA-Vlanif100] quit
    [*Switch ModuleA] interface vlanif 200
    [*Switch ModuleA-Vlanif200] ipv6 enable
    [*Switch ModuleA-Vlanif200] ipv6 address 2002:2::1 64
    [*Switch ModuleA-Vlanif200] quit
    [*Switch ModuleA] interface loopback0
    [*Switch ModuleA-LoopBack0] ipv6 enable
    [*Switch ModuleA-LoopBack0] ipv6 address 1::1 128
    [*Switch ModuleA-LoopBack0] quit
    [*Switch ModuleA] commit

    # Configure unicast routing protocol OSPFv3 on Switch ModuleA.

    [~Switch ModuleA] ospfv3
    [*Switch ModuleA-ospfv3-1] router-id 1.1.1.1
    [*Switch ModuleA-ospfv3-1] quit
    [*Switch ModuleA] interface vlanif 30
    [*Switch ModuleA-Vlanif30] ospfv3 1 area 0
    [*Switch ModuleA-Vlanif30] quit
    [*Switch ModuleA] interface vlanif 100
    [*Switch ModuleA-Vlanif100] ospfv3 1 area 0
    [*Switch ModuleA-Vlanif100] quit
    [*Switch ModuleA] interface vlanif 200
    [*Switch ModuleA-Vlanif200] ospfv3 1 area 0
    [*Switch ModuleA-Vlanif200] quit
    [*Switch ModuleA] commit
    

  2. Enable IPv6 multicast routing and Bidir-PIM (IPv6) on the switch moduleses.

    # Enable IPv6 multicast routing and Bidir-PIM (IPv6) on Switch ModuleA. The configurations of Switch ModuleB and Switch ModuleC are similar to the configuration of Switch ModuleA, and are not mentioned here.

    [~Switch ModuleA] multicast ipv6 routing-enable
    [*Switch ModuleA] pim ipv6
    [*Switch ModuleA-pim6] bidir-pim
    [*Switch ModuleA-pim6] commit
    [~Switch ModuleA-pim6] quit
    

  3. Enable PIM-SM (IPv6) on all the switch modules interfaces.

    # Enable PIM-SM (IPv6) on all the interfaces of Switch ModuleA. The configurations of Switch ModuleB and Switch ModuleC are similar to the configuration of Switch ModuleA, and are not mentioned here.

    [~Switch ModuleA] interface vlanif 30
    [~Switch ModuleA-Vlanif30] pim ipv6 sm
    [*Switch ModuleA-Vlanif30] quit
    [*Switch ModuleA] interface vlanif 100
    [*Switch ModuleA-Vlanif100] pim ipv6 sm
    [*Switch ModuleA-Vlanif100] quit
    [*Switch ModuleA] interface vlanif 200
    [*Switch ModuleA-Vlanif200] pim ipv6 sm
    [*Switch ModuleA-Vlanif200] quit
    [*Switch ModuleA] interface loopback0
    [*Switch ModuleA-LoopBack0] pim ipv6 sm
    [*Switch ModuleA-LoopBack0] quit
    [*Switch ModuleA] commit

  4. Enable MLD on interfaces directly connected to network segments of hosts.

    # Configure Switch ModuleB.

    [~Switch ModuleB] interface vlanif 10
    [~Switch ModuleB-Vlanif10] mld enable
    [*Switch ModuleB-Vlanif10] commit
    [~Switch ModuleB-Vlanif10] quit
    

    # Configure Switch ModuleC.

    [~Switch ModuleC] interface vlanif 20
    [~Switch ModuleC-Vlanif20] mld enable
    [*Switch ModuleC-Vlanif20] commit
    [~Switch ModuleC-Vlanif20] quit
    

  5. Configure the dynamic RP function.

    # Configure different C-RP interfaces to serve Bidir-PIM (IPv6) and PIM-SM (IPv6) on Switch ModuleA.

    [~Switch ModuleA] acl ipv6 number 2000
    [*Switch ModuleA-acl6-basic-2000] rule permit source ff1e:: 64
    [*Switch ModuleA-acl6-basic-2000] quit
    [*Switch ModuleA] acl ipv6 number 2001
    [*Switch ModuleA-acl6-basic-2001] rule permit source ff2e:: 64
    [*Switch ModuleA-acl6-basic-2001] quit
    [*Switch ModuleA] pim ipv6
    [*Switch ModuleA-pim6] c-bsr 2001:3::1
    [*Switch ModuleA-pim6] c-rp 1::1 group-policy 2000 bidir
    [*Switch ModuleA-pim6] c-rp 2001:3::1 group-policy 2001
    [*Switch ModuleA-pim6] commit
    [~Switch ModuleA-pim6] quit
    

  6. Verify the configuration.

    # Run the display pim ipv6 routing-table command to view the PIM (IPv6) routing table on each switch modules. You can see from the routing tables that multicast source 2001:3::2/64 sends data to multicast groups FF1E::1/64 and FF2E::1/64, HostA joined group FF1E::1/64, and HostB joined group FF2E::1/64. For example, the PIM (IPv6) routing tables on Switch ModuleA and Switch ModuleB are as follows:

    [~Switch ModuleA] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 2 (*, G) entries; 1 (S, G) entry
    
     (*, FF2E::1)
         RP: 2001:3::1 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:29:14
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif200
                 Protocol: pim-sm, UpTime: 00:27:04, Expires: 00:03:27
    
    
     (2001:3::2, FF2E::1)
         RP: 2001:3::1 (local)
         Protocol: pim-sm, Flag: SPT LOC ACT
         UpTime: 00:00:31
         Upstream interface: Vlanif30
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif200
                 Protocol: pim-sm, UpTime: 00:00:38, Expires: 00:02:53
    
     (*, FF1E::1)
         RP: 1::1 (local)
         Protocol: bidir-pim, Flag: WC ACT
         UpTime: 00:29:22
         Rpf interface: LoopBack0
             Upstream neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif100
                 Protocol: bidir-pim, UpTime: 00:29:42, Expires: 00:02:48
            2: LoopBack0(RPF)
                 Protocol: bidir-pim, UpTime: 00:29:42, Expires: -
    [~Switch ModuleB] display pim ipv6 routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
    
     (*, FF1E::1)
         RP: 1::1
         Protocol: bidir-pim, Flag: WC ACT
         UpTime: 00:17:14
         Rpf interface: Vlanif100
             Upstream neighbor: FE80::3ABA:34FF:FEF6:7605
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif10
                 Protocol: mld, UpTime: 00:17:13, Expires: -
            2: Vlanif100(RPF)
                 Protocol: bidir-pim, UpTime: 00:17:14, Expires: - 

    According to the command output, HostA can receive data for group FF1E::1 through Bidir-PIM (IPv6), and HostB can receive data for group FF2E::1 through PIM-SM (IPv6).

Configuration Files

  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 30 100 200
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF1E::/64
    #
    acl ipv6 number 2001
     rule 5 permit source FF2E::/64
    #
    ospfv3 1
     router-id 1.1.1.1
     area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address 2001:3::1/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address 2002:1::1/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address 2002:2::1/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/17/1
     port default vlan 30
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack0
     ipv6 enable
     ipv6 address 1::1/128
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    pim ipv6
     c-bsr 2001:3::1
     bidir-pim
     c-rp 1::1 group-policy 2000 bidir
     c-rp 2001:3::1 group-policy 2001
    #
    return
    
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 10 100
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 2.2.2.2
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 2001:1::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address 2002:1::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/17/1
     port default vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    pim ipv6
     bidir-pim
    #
    return
    
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 20 200
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 3.3.3.3
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 2001:2::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address 2002:2::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/17/1
     port default vlan 20
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    pim ipv6
     bidir-pim
    #
    return
    
Translation
Download
Updated: 2019-12-13

Document ID: EDOC1000041694

Views: 60590

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next