No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 13

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides examples for configuring basic MLD functions and MLD SSM mapping.

Example for Configuring Basic MLD Functions

Networking Requirements

As shown in Figure 8-42, network segments N1 and N2 composed of different user groups exist on an IPv6 network. Switch ModuleA connects to N1, and Switch ModuleB and Switch ModuleC connect to N2. The PIM (IPv6) network uses multicast address FF16::1 to transmit video streams. The multicast function needs to be enabled on the network so that hosts can receive multicast data.

Figure 8-42 Networking diagram for basic MLD configurations

Configuration Roadmap

To meet the preceding requirements, configure basic MLD functions.

  1. Configure an IPv6 unicast routing protocol on the network to implement IP interworking. Multicast routing protocols work depending on unicast routing protocols.
  2. Configure PIM-SM (IPv6) on all the switches that provide IPv6 multicast services.
  3. Enable MLD on the interfaces connected to hosts so that hosts can receive multicast data.

Procedure

  1. Configure IPv6 addresses for interfaces and configure an IPv6 unicast routing protocol on the interfaces.

    # Create VLANs and add physical interfaces to VLANs on the switches. Configure IPv6 addresses for the VLANIF interfaces. Configure Open Shortest Path First Version 3 (OSPFv3) on the switches to implement IP interworking. The configurations on SwitchB, SwitchC, and SwitchD are similar to those on SwitchA and are not mentioned here.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 11
    [*SwitchA] interface 10GE 1/17/1
    [*SwitchA-10GE1/17/1] port link-type hybrid
    [*SwitchA-10GE1/17/1] port hybrid pvid vlan 10
    [*SwitchA-10GE1/17/1] port hybrid untagged vlan 10
    [*SwitchA-10GE1/17/1] quit
    [*SwitchA] interface 10GE 1/17/2
    [*SwitchA-10GE1/17/2] port link-type hybrid
    [*SwitchA-10GE1/17/2] port hybrid pvid vlan 11
    [*SwitchA-10GE1/17/2] port hybrid untagged vlan 11
    [*SwitchA-10GE1/17/2] quit
    [*SwitchA] ospfv3 100
    [*SwitchA-ospfv3-100] router-id 1.1.1.1
    [*SwitchA-ospfv3-100] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address 3000::12 64
    [*SwitchA-Vlanif10] ospfv3 100 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 11
    [*SwitchA-Vlanif11] ipv6 enable
    [*SwitchA-Vlanif11] ipv6 address 2002::1 64
    [*SwitchA-Vlanif11] ospfv3 100 area 0
    [*SwitchA-Vlanif11] quit
    [*SwitchA] commit

  2. Configure PIM-SM (IPv6) on all switches.

    # Enable the IPv6 multicast function on SwitchD, and enable PIM-SM (IPv6) on all interfaces of SwitchD. The configurations of SwitchA, SwitchB and SwitchC are similar to the configuration of SwitchD, and are not mentioned here.

    [~SwitchD] multicast ipv6 routing-enable
    [*SwitchD] interface vlanif 11
    [*SwitchD-Vlanif11] pim ipv6 sm
    [*SwitchD-Vlanif11] quit
    [*SwitchD] interface vlanif 21
    [*SwitchD-Vlanif21] pim ipv6 sm
    [*SwitchD-Vlanif21] quit
    [*SwitchD] interface vlanif 31
    [*SwitchD-Vlanif31] pim ipv6 sm
    [*SwitchD-Vlanif31] quit
    [*SwitchD] interface vlanif 40
    [*SwitchD-Vlanif40] pim ipv6 sm
    [*SwitchD-Vlanif40] quit
    [*SwitchD] commit

    # Configure an RP. Configure C-BSR and C-RP on SwitchD.

    [~SwitchD] pim ipv6
    [*SwitchD-pim6] c-bsr 2000::1
    [*SwitchD-pim6] c-rp 2000::1
    [*SwitchD-pim6] commit
    [~SwitchD-pim6] quit
    

  3. Enable MLD on the interfaces connected to user hosts.

    # Enable MLD on VLANIF 10 of SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here.

    [~SwitchA] interface vlanif 10
    [~SwitchA-Vlanif10] mld enable
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit

  4. Verify the configuration.

    # Run the display mld interface command to check information about MLD configuration and running on each interface of the switches. MLD information about VLANIF 20 on SwitchB is as follows:

    [~SwitchB] display mld interface vlanif 20 verbose
    Interface information
     Vlanif20(FE80::225:9EFF:FE95:7C27):
       MLD is enabled
       Current MLD version is 2
       MLD state: up
       MLD group policy: none
       Query interval for MLD (negotiated): 125 s
       Query interval for MLD (configured): 125 s
       Other querier timeout for MLD: 0 s
       Maximum query response time for MLD: 10 s
       Last listener query time: 2 s
       Last listener query interval: 1 s
       Startup query interval: 31 s
       Startup query count: 2
       General query timer expiry (hours:minutes:seconds): 00:00:28
       Querier for MLD: FE80::225:9EFF:FE95:7C27 (this router)
       MLD activity: 2 joins, 0 dones
       Robustness (negotiated): 2
       Robustness (configured): 2
       Require-router-alert: disabled
       Send-router-alert: enabled
       Ip-source-policy: disabled  
       Query Ip-source-policy: disabled 
       Prompt-leave: disabled
       SSM-Mapping: disabled
       Startup-query-timer-expiry: off
       Other-querier-present-timer-expiry: off
      Total 1 MLD Group reported 
    

    The command output shows that SwitchB is a querier. This is because the IPv6 address of VLANIF 20 on SwitchB is smaller than that of SwitchC on the same network segment. In addition, VLANIF 20 has received Multicast Listener Report messages from a multicast group.

    # Run the display pim ipv6 routing-table command to check the PIM-SM (IPv6) multicast routing table on each switch. The PIM-SM (IPv6) multicast routing table on SwitchA is as follows:

    [~SwitchA] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
      
     (*, FF16::1)
         RP: 2000::1
         Protocol: pim-sm, Flag: WC 
         UpTime: 00:21:35 
         Upstream interface: Vlanif11 
             Upstream neighbor: FE80::225:9EFF:FE01:20E   
             RPF prime neighbor: FE80::225:9EFF:FE01:20E 
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10 
                 Protocol: mld, UpTime: 00:21:35, Expires: -  
      
     (2000::5, FF16::1)  
         RP: 2000::1
         Protocol: pim-sm, Flag: SPT ACT 
         UpTime: 00:22:46 
         Upstream interface: Vlanif11  
             Upstream neighbor: FE80::225:9EFF:FE01:20E  
             RPF prime neighbor: FE80::225:9EFF:FE01:20E 
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10 
                 Protocol: pim-sm, UpTime: 00:22:47, Expires: -
    
    

    The command output shows that (*, FF16::1) and (2000::5, FF16::1) entries exist on SwitchA. This indicates that VLANIF 10 has joined multicast groups FF16::1 and can receive multicast data from multicast source 2000::5.

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 to 11
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 1.1.1.1
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 3000::12/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0 
    #
    interface Vlanif11
     ipv6 enable
     ipv6 address 2002::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 11
     port hybrid untagged vlan 11
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 20 to 21
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 2.2.2.2
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 3001::10/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif21
     ipv6 enable
     ipv6 address 2003::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 21
     port hybrid untagged vlan 21
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 20 31
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 3.3.3.3
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 3001::12/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif31
     ipv6 enable
     ipv6 address 2004::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 31
     port hybrid untagged vlan 31
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    vlan batch 11 21 31 40
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 4.4.4.4
     area 0.0.0.0
    #
    interface Vlanif11
     ipv6 enable
     ipv6 address 2002::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif21
     ipv6 enable
     ipv6 address 2003::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif31
     ipv6 enable
     ipv6 address 2004::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address 2000::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 11
     port hybrid untagged vlan 11
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 21
     port hybrid untagged vlan 21
    #
    interface 10GE1/17/4
     port link-type hybrid
     port hybrid pvid vlan 31
     port hybrid untagged vlan 31
    #
    pim ipv6
     c-bsr 2000::1
     c-rp 2000::1
    #
    return

Example for Configuring MLD SSM Mapping

Networking Requirements

The IPv6 multicast network shown in Figure 8-43 is running PIM-SM (IPv6) and uses the SSM model to provide IPv6 multicast services. The switch interface connected to the receiver is running MLDv2, while the receiver is running MLDv1 and does not support MLDv2.

On this network, the SSM group address range is FF3E::/64. Source1, Source2, and Source3 all send multicast data to IPv6 groups in this range, but the receiver only wants to receive IPv6 multicast data from Source1 and Source3.

Figure 8-43 Networking diagram for MLD SSM mapping configuration

Configuration Roadmap

To meet the preceding requirements, configure MLD SSM mapping on SwitchD connected to Receiver to provide SSM services to receiver running MLDv1,

  1. Configure an IPv6 unicast routing protocol on the network to implement IP interworking. Multicast routing protocols work depending on unicast routing protocols.

  2. Configure basic multicast functions on the switches to provide multicast data forwarding.

  3. Enable MLD SSM mapping on SwitchD and configure the mapping rules.

Procedure

  1. Configure IPv6 addresses for interfaces and configure a unicast routing protocol on the switches.

    # Create VLANs and add physical interfaces to VLANs on the switches. Configure IPv6 addresses for the VLANIF interfaces. Configure Open Shortest Path First Version 3 (OSPFv3) on the switches to implement IP interworking. The configurations on SwitchB, SwitchC, and SwitchD are similar to those on SwitchA and are not mentioned here.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20 30
    [*SwitchA] interface 10GE 1/17/1
    [*SwitchA-10GE1/17/1] port link-type hybrid
    [*SwitchA-10GE1/17/1] port hybrid pvid vlan 10
    [*SwitchA-10GE1/17/1] port hybrid untagged vlan 10
    [*SwitchA-10GE1/17/1] quit
    [*SwitchA] interface 10GE 1/17/2
    [*SwitchA-10GE1/17/2] port link-type hybrid
    [*SwitchA-10GE1/17/2] port hybrid pvid vlan 20
    [*SwitchA-10GE1/17/2] port hybrid untagged vlan 20
    [*SwitchA-10GE1/17/2] quit
    [*SwitchA] interface 10GE 1/17/3
    [*SwitchA-10GE1/17/3] port link-type hybrid
    [*SwitchA-10GE1/17/3] port hybrid pvid vlan 30
    [*SwitchA-10GE1/17/3] port hybrid untagged vlan 30
    [*SwitchA-10GE1/17/3] quit
    [*SwitchA] ospfv3 100
    [*SwitchA-ospfv3-100] router-id 1.1.1.1
    [*SwitchA-ospfv3-100] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address 2001::2 64
    [*SwitchA-Vlanif10] ospfv3 100 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address 3001::1 64
    [*SwitchA-Vlanif20] ospfv3 100 area 0
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ipv6 enable
    [*SwitchA-Vlanif30] ipv6 address 3003::1 64
    [*SwitchA-Vlanif30] ospfv3 100 area 0
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit

  2. Configure the basic IPv6 multicast functions on each switch.

    # On SwitchA, enable multicast routing globally and enable PIM-SM (IPv6) on the VLANIF interfaces. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim ipv6 sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] pim ipv6 sm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit
    

    # On SwitchD, enable MLD and set the MLD version to v2 on VLANIF 13 (the interface connected to the receiver).

    [~SwitchD] interface vlanif 13
    [~SwitchD-Vlanif13] mld enable
    [*SwitchD-Vlanif13] mld version 2
    [*SwitchD-Vlanif13] commit
    [~SwitchD-Vlanif13] quit
    

  3. Enable MLD SSM mapping on SwitchD and configure mapping rules.

    # Enable MLD SSM mapping on VLANIF 13 of SwitchD.

    [~SwitchD] interface vlanif 13
    [~SwitchD-Vlanif13] mld ssm-mapping enable
    [*SwitchD-Vlanif13] commit
    [~SwitchD-Vlanif13] quit
    

    # Set the SSM group address range to FF3E::/64 on all the switches. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

    [~SwitchA] acl ipv6 number 2000
    [*SwitchA-acl6-basic-2000] rule permit source ff3e::/64
    [*SwitchA-acl6-basic-2000] quit
    [*SwitchA] pim ipv6
    [*SwitchA-pim6] ssm-policy 2000
    [*SwitchA-pim6] commit
    [~SwitchA-pim6] quit
    

    # On SwitchD, map the multicast groups in the range of FF3E::/64 to Source 1 and Source 3.

    [~SwitchD] mld
    [*SwitchD-mld] ssm-mapping ff3e:: 64 2001::1
    [*SwitchD-mld] ssm-mapping ff3e:: 64 2003::1
    [*SwitchD-mld] commit
    [~SwitchD-mld] quit
    

  4. Verify the configuration.

    # Run the display mld ssm-mapping group command on SwitchD to check mapping between multicast sources and multicast group addresses.

    [~SwitchD] display mld ssm-mapping group
    MLD SSM-Mapping conversion table of VPN-Instance: public net 
     Total 2 entries    2 entries matched  
    
     00001. (2001::1, FF3E::) 
    
     00002. (2003::1, FF3E::) 
    
     Total 2 entries matched    
    
    

    The command output shows that multicast groups within the range of FF3E::/64 are mapped to Source1 and Source3.

    # After the receiver joins group FF3E::1, run the display mld group ssm-mapping verbose command to view information about group memberships established with SSM mapping on the switches. The following group membership information is displayed on SwitchD:

    [~SwitchD] display mld group ssm-mapping verbose
    Interface group report information of VPN-Instance: public net
     Vlanif13(FE80::225:9EFF:FE95:7C27):
      Total entry on this interface: 1
      Total 1 MLD SSM-Mapping Group reported
       Group: FF3E::1
         Uptime: 00:00:13
         Expires: 00:04:07
         Last reporter: 2004::1 
         Last-listener-query-counter: 0
         Last-listener-query-timer-expiry: off
         Group mode: exclude
         Version1-host-present-timer-expiry: 00:04:07
         Source list:
           Source: 2001::1
           Uptime: 00:00:21
           Source: 2003::1
           Uptime: 00:00:21
    

    The command output shows that Receiver has joined multicast group with the address of FF3E::1.

    # Run the display pim ipv6 routing-table command to view the PIM-SM (IPv6) multicast routing table on the switches. The PIM-SM (IPv6) multicast routing table on SwitchD is as follows:

    [~SwitchD] display pim ipv6 routing-table
    VPN-Instance: public net
     Total 2 (S, G) entries
     (2001::1, FF3E::1)
         Protocol: pim-ssm, Flag:SG_RCVR
         UpTime: 00:11:25
         Upstream interface: Vlanif30
             Upstream neighbor: FE80::225:9EFF:FE01:20E
             RPF prime neighbor: FE80::225:9EFF:FE01:20E
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif13
                 Protocol: ssm-map, UpTime: 00:11:25, Expires:-
    
     (2003::1, FF3E::1)
         Protocol: pim-ssm, Flag:SG_RCVR
         UpTime: 00:11:25
         Upstream interface: Vlanif21
             Upstream neighbor: FE80::225:9EFF:FE95:7C2B
             RPF prime neighbor: FE80::225:9EFF:FE95:7C2B
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif13
                 Protocol: ssm-map, UpTime: 00:11:25, Expires:-
    

    The command output shows that (2001::1, FF3E::1) and (2003::1, FF3E::1) entries exist on SwitchD and the protocol type is ssm-map, indicating that VLANIF 13 has joined the multicast group with the address of FF3E::1 using SSM mapping. After multicast sources 2001::1 and 2003::1 send multicast data to FF3E::1, SwitchD receives the multicast data from the two multicast sources through VLANIF 30 and VLANIF 21 respectively.

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20 30
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF3E::/64
    #
    ospfv3 100
     router-id 1.1.1.1
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address 2001::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 3001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address 3003::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    pim ipv6
     ssm-policy 2000
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 11 20 31
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF3E::/64 
    #
    ospfv3 100
     router-id 2.2.2.2
     area 0.0.0.0
    #
    interface Vlanif11
     ipv6 enable
     ipv6 address 2002::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address 3001::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif31
     ipv6 enable
     ipv6 address 3002::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 11
     port hybrid untagged vlan 11
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 31
     port hybrid untagged vlan 31
    #
    pim ipv6
     ssm-policy 2000
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 12 21 31
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF3E::/64 
    #
    ospfv3 100
     router-id 3.3.3.3
     area 0.0.0.0
    #
    interface Vlanif12
     ipv6 enable
     ipv6 address 2003::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif21
     ipv6 enable
     ipv6 address 3004::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif31
     ipv6 enable
     ipv6 address 3002::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 12
     port hybrid untagged vlan 12
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 21
     port hybrid untagged vlan 21
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 31
     port hybrid untagged vlan 31
    #
    pim ipv6
     ssm-policy 2000
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    vlan batch 13 21 30
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF3E::/64 
    #
    ospfv3 100
     router-id 4.4.4.4
     area 0.0.0.0
    #
    interface Vlanif13
     ipv6 enable
     ipv6 address 2004::2/64
     pim ipv6 sm
     mld enable
     mld ssm-mapping enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif21
     ipv6 enable
     ipv6 address 3004::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address 3003::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/17/1
     port link-type hybrid
     port hybrid pvid vlan 13
     port hybrid untagged vlan 13
    #
    interface 10GE1/17/2
     port link-type hybrid
     port hybrid pvid vlan 21
     port hybrid untagged vlan 21
    #
    interface 10GE1/17/3
     port link-type hybrid
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    mld
     ssm-mapping FF3E:: 64 2001::1
     ssm-mapping FF3E:: 64 2003::1
    #
    pim ipv6
     ssm-policy 2000
    #
    return
Translation
Download
Updated: 2019-12-13

Document ID: EDOC1000041694

Views: 59920

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next