No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Example

Configuration Example

This section describes examples for configuring PIM (IPv4) functions.

Example for Configuring PIM-SM in the ASM Model

Networking Requirements

As shown in Figure 8-62, the network is connected to the Internet. After the PIM-SM protocol is configured on the switch, the switch is required to provide ASM services for hosts on the Internet so that hosts in a multicast group can receive VoD information sent from any sources.

Figure 8-62 Networking diagram for configuring PIM-SM in the ASM model

Configuration Roadmap
  1. Configure an IP address for each interface and a unicast routing protocol. PIM is an intra-domain multicast routing protocol that depends on unicast routing protocols.

  2. Enable the multicast function on all switches providing multicast services. Before configuring PIM-SM, you must enable the multicast function.

  3. Enable PIM-SM on all interfaces. You can configure other PIM-SM functions only after PIM-SM is enabled.

  4. Enable IGMP on interfaces that connect the switch and hosts. A receiver can join and leave a multicast group by sending IGMP messages. The leaf switches maintain the multicast member relationship through IGMP.

  5. Enable PIM silent on interfaces that connect the switch and hosts to prevent malicious hosts from simulating sending PIM Hello packets. In this manner, security of PIM-SM domain is ensured.

    NOTE:

    If the user host network segment connects to multiple switches, do not enable PIM silent on interfaces that connect these switches and user hosts. For example, PIM silent cannot be enabled on Switch ModuleB and Switch ModuleC.

  6. Configure the RP. In PIM-SM domain, RP is essential in providing ASM services and helps forward multicast data. You are advised to configure RP on switches that have more multicast flows. For example, you can configure RP on Switch ModuleE in the figure.

  7. Configure the BSR boundary on interfaces connected to the Internet. The Bootstrap message cannot pass through the BSR boundary; therefore, the BSR serves only this PIM-SM domain. In this manner, multicast services can be controlled effectively.

Procedure

  1. Configure an IP address for each interface and a unicast routing protocol.

    # Configure the IP address and mask for each interface shown in Figure 8-62, and configure OSPF on each switch to ensure that switches can communicate at the network layer and can dynamically update routes through the unicast routing protocol. The configuration details are not provided here. The configurations of Switch ModuleB, Switch ModuleC, Switch ModuleD, and Switch ModuleE are similar to the configuration of Switch Module A, and are not provided here.

    # Add interfaces of Switch ModuleA to VLANs.

    [~Switch ModuleA] vlan batch 10 20 30
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] port default vlan 20
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] interface 10ge 1/17/3
    [*Switch ModuleA-10GE1/17/3] port link-type trunk
    [*Switch ModuleA-10GE1/17/3] port trunk allow-pass vlan 30
    [*Switch ModuleA-10GE1/17/3] quit
    [*Switch ModuleA] commit

    # Assign IP addresses to VLANIF interfaces on Switch ModuleA.

    [~Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ip address 192.168.5.1 24
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] interface vlanif 20
    [*Switch ModuleA-Vlanif20] ip address 10.110.1.1 24
    [*Switch ModuleA-Vlanif20] quit
    [*Switch ModuleA] interface vlanif 30
    [*Switch ModuleA-Vlanif30] ip address 192.168.1.1 24
    [*Switch ModuleA-Vlanif30] quit
    [*Switch ModuleA] commit

    # Configure a routing protocol on Switch ModuleA. OSPF is used in this example.

    [~Switch ModuleA] ospf
    [*Switch ModuleA-ospf-1] area 0
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 10.110.1.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 192.168.5.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] commit
    [~Switch ModuleA-ospf-1-area-0.0.0.0] quit
    [~Switch ModuleA-ospf-1] quit

  2. Enable multicast, and enable PIM-SM on all interfaces.

    # Enable multicast on all switches and PIM-SM on all interfaces. The configurations of Switch ModuleB, Switch ModuleC, Switch ModuleD, and Switch ModuleE are similar to the configuration of Switch Module A, and are not provided here.

    [~Switch ModuleA] multicast routing-enable
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] pim sm
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit
    [~Switch ModuleA] interface vlanif 20
    [~Switch ModuleA-Vlanif20] pim sm
    [*Switch ModuleA-Vlanif20] commit
    [~Switch ModuleA-Vlanif20] quit
    [~Switch ModuleA] interface vlanif 30
    [~Switch ModuleA-Vlanif30] pim sm
    [*Switch ModuleA-Vlanif30] commit
    [~Switch ModuleA-Vlanif30] quit

  3. Enable IGMP on interfaces that connect the switch and hosts.

    # Enable IGMP on interfaces that connect Switch ModuleA and user hosts. The configuration of Switch ModuleB and Switch ModuleC are similar to the configuration of Switch ModuleA, and are not provided here.

    [~Switch ModuleA] interface vlanif 20
    [~Switch ModuleA-Vlanif20] igmp enable
    [*Switch ModuleA-Vlanif20] commit
    [~Switch ModuleA-Vlanif20] quit

  4. Enable PIM silent on interfaces on Switch ModuleA.

    [~Switch ModuleA] interface vlanif 20
    [~Switch ModuleA-Vlanif20] pim silent
    [*Switch ModuleA-Vlanif20] commit
    [~Switch ModuleA-Vlanif20] quit

  5. Configure the RP.

    NOTE:

    RP can be configured in two modes: static RP and dynamic RP. The static RP can be configured together with the dynamic RP. You can also configure only the static RP or the dynamic RP. When the static RP and the dynamic RP are configured simultaneously, you can adjust parameters to specify the preferred RP.

    This example shows how to configure both the static RP and the dynamic RP and to specify the dynamic RP as the preferred RP and the static RP as the standby RP.

    # Configure the dynamic RP. Configure C-RP and C-BSR on one or more switches in the PIM-SM domain. In this example, specify Switch ModuleE as both the C-RP and the C-BSR. Configure the address range of the multicast group that the RP serves on Switch ModuleE and configure the C-BSR and C-RP on the interface.

    [~Switch ModuleE] acl number 2008
    [*Switch ModuleE-acl4-basic-2008] rule permit source 225.1.1.0 0.0.0.255
    [*Switch ModuleE-acl4-basic-2008] commit
    [~Switch ModuleE-acl4-basic-2008] quit
    [*Switch ModuleE] pim
    [*Switch ModuleE-pim] c-bsr vlanif 60 
    [*Switch ModuleE-pim] c-rp vlanif 60 group-policy 2008
    [*Switch ModuleE-pim] commit
    [~Switch ModuleE-pim] quit

    # Configure the static RP. Specify the address of static RP on all switches. Perform the following configurations on Switch ModuleA. The configuration of Switch ModuleB, Switch ModuleC, Switch ModuleD, and Switch ModuleE are similar to the configurations of Switch ModuleA, and are not provided here.

    NOTE:

    If you enter preferred in the static-rp X.X.X.X command, the static RP is selected as the RP in the PIM-SM domain.

    [~Switch ModuleA] pim
    [*Switch ModuleA-pim] static-rp 192.168.2.2
    [*Switch ModuleA-pim] commit
    [~Switch ModuleA-pim] quit

  6. Configure the BSR boundary on interfaces that connect Switch ModuleD to the Internet.

    [~Switch ModuleD] interface vlanif 70
    [~Switch ModuleD-Vlanif70] pim bsr-boundary
    [*Switch ModuleD-Vlanif70] commit
    [~Switch ModuleD-Vlanif70] quit

  7. Verify the configuration.

    # Run the display pim interface command to check the PIM configuration and status. The PIM information on Switch ModuleC is displayed as follows

    <Switch ModuleC> display pim interface
     VPN-Instance: public net
     Interface       State   NbrCnt   HelloInt   DR-Pri     DR-Address
     Vlanif40        up           0         30        1     10.110.2.2 (local)
     Vlanif50        up           1         30        1     192.168.3.1 (local)

    # Run the display pim bsr-info command to check information about the BSR selection on the switch. For example, the BSR information on Switch Module A and Switch Module E is displayed as follows (C-BSR information is also displayed on Switch Module E):

    <Switch ModuleA> display pim bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: 192.168.4.2
         Priority: 0
         Hash mask length: 30
         State: Accept Preferred
         Scope: Not scoped
         Uptime: 01:40:40
         Expires: 00:01:42
         C-RP Count: 1
    
    
    <Switch ModuleE> display pim bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: 192.168.4.2
         Priority: 0
         Mask length: 30
         State: Elected
         Scope: Not scoped
         Uptime: 00:00:18
         Next BSR message scheduled at :00:01:42
         C-RP Count: 1
     Candidate AdminScoped BSR Count: 0
     Candidate BSR Address is: 192.168.4.2
         Priority: 0
         Hash mask length: 30
         State:Elected
         Scope: Not scoped   
         Wait to be BSR: 0

    # Run the display pim rp-info command to check the RP information on the Switch Module. In this example, the RP information on Switch ModuleA is displayed as follows:

    <Switch ModuleA> display pim rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Information:
     Group/MaskLen: 225.1.1.0/24
         RP: 192.168.4.2
         Priority: 0
         Uptime: 00:45:13
         Expires: 00:02:17
         BIDIR: N 
     PIM SM static RP Information:
         Static RP: 192.168.2.2   
             BIDIR: N 
    

    # Run the display pim routing-table command to view the PIM routing table. The multicast source 10.110.3.100/24 sends message to the multicast group 225.1.1.1/24. Host A and Host B join the multicast group 225.1.1.1/24. Detailed information is displayed as follows:

    NOTE:

    By default, after the receiver's DR receives the first multicast data, an SPT switchover is performed and (S, G) routing entries are created. Therefore, (S, G) routing entries displayed on the switch are (S, G) entries after the SPT switchover.

    <Switch ModuleA> display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
     
    (*, 225.1.1.1)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: WC
         UpTime: 00:13:46
         Upstream interface: Vlanif30 
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: igmp, UpTime: 00:13:46, Expires:-
     
    (10.110.3.100, 225.1.1.1)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:01:42
         Upstream interface: Vlanif10
             Upstream neighbor: 192.168.5.2
             RPF prime neighbor: 192.168.5.2
        Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: pim-sm, UpTime: 00:01:42, Expires:-
    
    
    <Switch ModuleB> display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
     
    (*, 225.1.1.1)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: WC
         UpTime: 00:10:12
         Upstream interface: Vlanif90 
             Upstream neighbor: 192.168.2.2
             RPF prime neighbor: 192.168.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: igmp, UpTime: 00:10:12, Expires:-
     
    (10.110.3.100, 225.1.1.1)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: 
         UpTime: 00:00:42
         Upstream interface: Vlanif90
             Upstream neighbor: 192.168.2.2
             RPF prime neighbor: 192.168.2.2
        Downstream interface(s) information:
         Total number of downstreams: none
    
    
    <Switch ModuleC> display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
     
    (*, 225.1.1.1)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: WC
         UpTime: 00:10:12
         Upstream interface: Vlanif50 
             Upstream neighbor: 192.168.3.2
             RPF prime neighbor: 192.168.3.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: igmp, UpTime: 00:10:12, Expires:-
    
     (10.110.3.100, 225.1.1.1)
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:01:25
         Upstream interface: Vlanif50
             Upstream neighbor: 192.168.3.2
             RPF prime neighbor: 192.168.3.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-sm, UpTime: 00:01:25, Expires:-
    
    
    <Switch ModuleD> display pim routing-table
    VPN-Instance: public net
     Total 0 (*, G) entry; 2 (S, G) entry
     
     (10.110.3.100, 225.1.1.1)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: SPT LOC ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif80
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 2
             1: Vlanif30
                 Protocol: pim-sm, UpTime: 00:00:42, Expires:-
             2: Vlanif60
                 Protocol: pim-sm, UpTime: 00:00:42, Expires:-
    
    
    <Switch ModuleE> display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
     
     (*, 225.1.1.1)
         RP: 192.168.4.2 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:13:16
         Upstream interface: Register
             Upstream neighbor: 192.168.4.1
             RPF prime neighbor: 192.168.4.1
         Downstream interface(s) information:
         Total number of downstreams: 2
             1: Vlanif10
                 Protocol: pim-sm, UpTime: 00:13:16, Expires: 00:03:22
             1: Vlanif90
                 Protocol: pim-sm, UpTime: 00:13:16, Expires: 00:03:22
     
    (10.110.3.100, 225.1.1.1)
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:01:22
         Upstream interface: Vlanif60
             Upstream neighbor: 192.168.4.1
             RPF prime neighbor: 192.168.4.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif50
                 Protocol: pim-sm, UpTime: 00:01:22, Expires:-
    

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 20 30
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 192.168.5.1 255.255.255.0
     pim sm
    #
    interface Vlanif20
     ip address 10.110.1.1 255.255.255.0
     pim silent
     pim sm 
     igmp enable
    #
    interface vlanif30
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port default vlan 20
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    pim
     static-rp 192.168.2.2
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    multicast routing-enable
    #
    vlan batch 40 90
    #
    interface Vlanif40
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif90
     ip address 192.168.2.1 255.255.255.0
     pim sm 
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 90
    #
    interface 10GE1/17/2
     port default vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     static-rp 192.168.2.2
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 40 50
    #
    multicast routing-enable
    #
    interface Vlanif40
     ip address 10.110.2.2 255.255.255.0
     pim sm 
     igmp enable
    #
    interface Vlanif50
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 40
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     static-rp 192.168.2.2
    #
    return
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 30 60 70 80
    #
    multicast routing-enable
    #
    interface Vlanif30
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif60
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    interface Vlanif70
     ip address 10.110.4.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface Vlanif80
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 80
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/17/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1
     area 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 10.110.4.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     static-rp 192.168.2.2 
    #
    return
  • Configuration file of Switch ModuleE

    #
    sysname Switch ModuleE
    #
    vlan batch 10 50 60 90
    #
    multicast routing-enable
    #
    acl number 2008
     rule 5 permit source 225.1.1.0 0.0.0.255
    #
    interface Vlanif10
     ip address 192.168.5.2 255.255.255.0
     pim sm
    #
    interface Vlanif50
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif60
     ip address 192.168.4.2 255.255.255.0
     pim sm
    #
    interface Vlanif90
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 90
    #
    interface 10GE1/17/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    pim
     c-bsr vlanif 60
     c-rp vlanif 60 group-policy 2008
     static-rp 192.168.2.2 
    #
    return

Example for Configuring PIM-SM in the SSM Model

Networking Requirements

In Figure 8-63, the switch configured with PIM-SM is required to provide SSM services for hosts on the network so that hosts in a multicast group can receive VoD information sent from specified multicast sources.

Figure 8-63 Networking diagram for configuring PIM-SM in the SSM model

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each interface and a unicast routing protocol. PIM is an intra-domain multicast routing protocol that depends on unicast routing protocols.

  2. Enable the multicast function on switches providing multicast services. Before configuring PIM-SM, you must enable the multicast function.

  3. Enable PIM-SM on all interfaces. You can configure other PIM-SM functions only after PIM-SM is enabled.

  4. Enable IGMP on interfaces that connect the switch and hosts and set the IGMP version to IGMPv3. A receiver can join and leave a multicast group of a specified source by sending IGMP messages. The leaf switches maintain the multicast member relationship through IGMP.

  5. Enable PIM silent on interfaces that connect the switch and hosts to prevent malicious hosts from simulating sending PIM Hello packets. In this manner, security of PIM-SM domain is ensured.

    NOTE:

    If the user host network segment connects to multiple switches, do not enable PIM silent on interfaces that connect these switches and user hosts. For example, PIM silent cannot be enabled on Switch ModuleB and Switch ModuleC.

  6. Configure the same address range for SSM groups on each switch. Ensure that switches in the PIM-SM domain provide services only for multicast groups in the range of SSM group addresses. In this manner, multicast can be controlled effectively.

Procedure

  1. Configure an IP address for each interface and a unicast routing protocol.

    # Configure the IP address and mask for each interface shown in Figure 8-63, and configure OSPF on each switch to ensure that switches can communicate at the network layer and can dynamically update routes through the unicast routing protocol. The configuration of Switch ModuleB, Switch ModuleC, Switch ModuleD, Switch ModuleE, and Switch ModuleF are similar to the configuration of Switch ModuleA, and are not mentioned.

    # Add interfaces of Switch ModuleA to VLANs.

    [~Switch ModuleA] vlan batch 10 20 30
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port link-type trunk
    [*Switch ModuleA-10GE1/17/1] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] port link-type trunk
    [*Switch ModuleA-10GE1/17/2] port trunk allow-pass vlan 30
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] interface 10ge 1/17/3
    [*Switch ModuleA-10GE1/17/3] port default vlan 20
    [*Switch ModuleA-10GE1/17/3] quit
    [*Switch ModuleA] commit
    

    # Assign IP addresses to VLANIF interfaces on Switch ModuleA.

    [~Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ip address 192.168.5.1 24
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] interface vlanif 20
    [*Switch ModuleA-Vlanif20] ip address 10.110.1.1 24
    [*Switch ModuleA-Vlanif20] quit
    [*Switch ModuleA] interface vlanif 30
    [*Switch ModuleA-Vlanif30] ip address 192.168.1.1 24
    [*Switch ModuleA-Vlanif30] quit
    [*Switch ModuleA] commit

    # Configure a routing protocol on Switch ModuleA. OSPF is used in this example.

    [~Switch ModuleA] ospf
    [*Switch ModuleA-ospf-1] area 0
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 10.110.1.0 24
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 192.168.1.0 24
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 192.168.5.0 24
    [*Switch ModuleA-ospf-1-area-0.0.0.0] commit
    [~Switch ModuleA-ospf-1-area-0.0.0.0] quit
    [~Switch ModuleA-ospf-1] quit

  2. Enable multicast, and enable PIM-SM on all interfaces.

    # Enable multicast on all switches and PIM-SM on all interfaces. The configuration of Switch Module B, Switch Module C, Switch Module D, Switch Module E, and Switch ModuleF are similar to the configuration of Switch Module A, and are not mentioned.

    [~Switch ModuleA] multicast routing-enable
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] pim sm
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit
    [~Switch ModuleA] interface vlanif 20
    [~Switch ModuleA-Vlanif20] pim sm
    [*Switch ModuleA-Vlanif20] commit
    [~Switch ModuleA-Vlanif20] quit
    [~Switch ModuleA] interface vlanif 30
    [~Switch ModuleA-Vlanif30] pim sm
    [*Switch ModuleA-Vlanif30] commit
    [~Switch ModuleA-Vlanif30] quit

  3. Enable IGMP on interfaces that connect the switch and hosts and set IGMP version to IGMPv3.

    # Enable IGMP on interfaces that connect Switch ModuleA and user hosts. The configuration of Switch ModuleB and Switch ModuleC are similar to the configuration of Switch ModuleA, and are not mentioned.

    [~Switch ModuleA] interface vlanif 20
    [~Switch ModuleA-Vlanif20] igmp enable
    [*Switch ModuleA-Vlanif20] igmp version 3
    [*Switch ModuleA-Vlanif20] commit
    [~Switch ModuleA-Vlanif20] quit
    

  4. Enable PIM silent on interfaces on Switch ModuleA.

    [~Switch ModuleA] interface vlanif 20
    [~Switch ModuleA-Vlanif20] pim silent
    [*Switch ModuleA-Vlanif20] commit
    [~Switch ModuleA-Vlanif20] quit
    

  5. Configure the address range for SSM groups.

    # Set the address of SSM group to range from 232.1.1.0 to 232.1.1.24 on all switches. The configuration of Switch Module B, Switch Module C, Switch Module D, Switch Module E, and Switch ModuleF are similar to the configuration of Switch Module A, and are not mentioned here.

    [~Switch ModuleA] acl number 2000
    [*Switch ModuleA-acl4-basic-2000] rule permit source 232.1.1.0 0.0.0.255
    [*Switch ModuleA-acl4-basic-2000] commit
    [~Switch ModuleA-acl4-basic-2000] quit
    [*Switch ModuleA] pim
    [*Switch ModuleA-pim] ssm-policy 2000
    [*Switch ModuleA-pim] commit
    [~Switch ModuleA-pim] quit

  6. Verify the configuration.

    # Run the display pim interface command to check the PIM configuration and status. The PIM information on Switch ModuleC is displayed as follows:

    <Switch ModuleC> display pim interface
     VPN-Instance: public net
     Interface       State   NbrCnt   HelloInt   DR-Pri     DR-Address
     Vlanif40        up           0         30        1     10.110.2.2 (local)
     Vlanif50        up           1         30        1     192.168.3.1 (local)

    # Run the display pim routing-table command to view the PIM routing table. HostA receives information sent from multicast source 10.110.3.100/24 and 10.110.4.100/24 to the multicast group 232.1.1.1/24. HostB receives information sent from multicast source 10.110.3.100/24 to multicast group 232.1.1.1/24. The following information is displayed.

    <Switch ModuleA> display pim routing-table
    VPN-Instance: public net
     Total 2 (S, G) entries
     
    (10.110.3.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:13:46
         Upstream interface: Vlanif10
             Upstream neighbor: 192.168.5.2
             RPF prime neighbor: 192.168.5.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: igmp, UpTime: 00:13:46, Expires:-
     
    (10.110.4.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif30
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
        Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: igmp, UpTime: 00:00:42, Expires:-
    
    
    <Switch ModuleB> display pim routing-table
    VPN-Instance: public net
     Total 1 (S, G) entry
     
    (10.110.3.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:10:12
         Upstream interface: Vlanif90
             Upstream neighbor: 192.168.2.2
             RPF prime neighbor: 192.168.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: igmp, UpTime: 00:10:12, Expires:-
    
    
    <Switch ModuleC> display pim routing-table
    VPN-Instance: public net
     Total 1 (S, G) entry
    
     (10.110.3.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:01:25
         Upstream interface: Vlanif50
             Upstream neighbor: 192.168.3.2
             RPF prime neighbor: 192.168.3.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: igmp, UpTime: 00:01:25, Expires:-
    
    
    <Switch ModuleD> display pim routing-table
    VPN-Instance: public net
     Total 1 (S, G) entry
     
     (10.110.3.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif80
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: pim-ssm, UpTime: 00:00:42, Expires:-
    
    
    <Switch ModuleE> display pim routing-table
    VPN-Instance: public net
     Total 1 (S, G) entry
     
     (10.110.3.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:13:16
         Upstream interface: Vlanif60
             Upstream neighbor: 192.168.4.1
             RPF prime neighbor: 192.168.4.1
         Downstream interface(s) information:
         Total number of downstreams: 3
             1: Vlanif10
                 Protocol: pim-ssm, UpTime: 00:13:16, Expires: 00:03:22
             2: Vlanif50
                 Protocol: pim-ssm, UpTime: 00:13:16, Expires: 00:03:22
             3: Vlanif90
                 Protocol: pim-ssm, UpTime: 00:13:16, Expires: 00:03:22
    
    
    <Switch ModuleF> display pim routing-table
    VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
     
     (10.110.4.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:13:16
         Upstream interface: Vlanif70
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif30
                 Protocol: pim-ssm, UpTime: 00:15:28, Expires: 00:05:21
    

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 20 30
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif10
     ip address 192.168.5.1 255.255.255.0
     pim sm
    #
    interface Vlanif20
     ip address 10.110.1.1 255.255.255.0
     pim silent
     pim sm 
     igmp enable
     igmp version 3
    #
    interface vlanif30
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/17/3
     port default vlan 20
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    multicast routing-enable
    #
    vlan batch 40 90
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif40
     ip address 10.110.2.1 255.255.255.0
     pim sm 
     igmp enable
     igmp version 3
    #
    interface Vlanif90
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 90
    #
    interface 10GE1/17/2
     port default vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 40 50
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif40
     ip address 10.110.2.2 255.255.255.0
     pim sm 
     igmp enable
     igmp version 3
    #
    interface Vlanif50
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 40
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 60 80
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif60
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    interface Vlanif80
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 80
    #
    interface 10GE1/17/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1
     area 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
  • Configuration file of Switch ModuleE

    #
    sysname Switch ModuleE
    #
    vlan batch 10 50 60 90
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif10
     ip address 192.168.5.2 255.255.255.0
     pim sm
    #
    interface Vlanif50
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif60
     ip address 192.168.4.2 255.255.255.0
     pim sm
    #
    interface Vlanif90
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 90
    #
    interface 10GE1/17/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
  • Configuration file of Switch ModuleF

    #
    sysname Switch ModuleD
    #
    vlan batch 30 70
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif30
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif70
     ip address 10.110.4.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 70
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 10.110.4.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return

Example for Configuring PIM for Anycast RP

Networking Requirements

HostA and HostB in Figure 8-64 receive VoD information in multicast mode. When the network is overloaded or traffic is concentrated on an RP, the RP may be overburdened or fails and the route convergence may be slow. HostB is required to join the closest RP to fast receive the multicast data.

Figure 8-64 Networking diagram for configuring PIM for anycast RP

Configuration Roadmap

Configuring PIM for anycast RP reduces the burden on an RP and hosts can join the closest RP.

  1. Configure IP addresses and unicast routes for interfaces on each switch modules to ensure connectivity at the network layer.

  2. Configure basic multicast functions so that multicast data can be forwarded. Enable multicast, enable PIM-SM and configure C-BSR and C-RP on each interface, and enable IGMP on interfaces that connect the switch and hosts.

  3. Configure anycast RP to allow HostB to fast receive multicast data. Configure Switch ModuleC and Switch ModuleD as the anycast RP peers. HostB joins the closest Switch ModuleD. After receiving the source multicast data, Switch ModuleA encapsulates the data into Register messages and sends the message to Switch ModuleC. Switch ModuleC forwards the Register message to Switch ModuleD. Host B then receives the multicast source data.

Procedure

  1. Configure an IP address for each interface on the switch modules and a unicast routing protocol.

    # Configure the IP address and mask for each interface on the switch modules shown in Figure 8-64, and configure OSPF on each switch modules to ensure that switches can communicate. The configuration of Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration of Switch ModuleA, and are not mentioned.

    # Add interfaces of Switch ModuleA to VLANs.

    [~Switch ModuleA] vlan batch 10 11
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port default vlan 11
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] port link-type trunk
    [*Switch ModuleA-10GE1/17/2] port trunk allow-pass vlan 10
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] commit
    

    # Assign IP addresses to VLANIF interfaces on Switch ModuleA.

    [~Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ip address 192.168.1.1 24
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] interface vlanif 11
    [*Switch ModuleA-Vlanif11] ip address 10.110.1.1 24
    [*Switch ModuleA-Vlanif11] quit
    [*Switch ModuleA] commit

    # Configure a routing protocol on Switch ModuleA. OSPF is used in this example.

    [*Switch ModuleA] ospf
    [*Switch ModuleA-ospf-1] area 0
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 10.110.1.0 24
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 192.168.1.0 24
    [*Switch ModuleA-ospf-1-area-0.0.0.0] commit
    [~Switch ModuleA-ospf-1-area-0.0.0.0] quit
    [~Switch ModuleA-ospf-1] quit

  2. Configure basic multicast functions on each switch modules.

    # Enable multicast routing on Switch ModuleA and PIM-SM on interfaces. The configuration of Switch ModuleB,Switch ModuleC, and Switch ModuleD are similar to the configuration of SwitchA, and are not mentioned here.

    [~Switch ModuleA] multicast routing-enable
    [*Switch ModuleA] interface vlanif10
    [*Switch ModuleA-Vlanif10] pim sm
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit
    [~Switch ModuleA] interface vlanif 11
    [~Switch ModuleA-Vlanif11] pim sm
    [*Switch ModuleA-Vlanif11] commit
    [~Switch ModuleA-Vlanif11] quit
    

    # Configure the Loopback0 interface of Switch ModuleC and Switch ModuleD as C-RP and C-BSR. The configuration of Switch ModuleD is similar to the configuration of Switch ModuleC, and is not mentioned here.

    [~Switch ModuleC] pim
    [*Switch ModuleC-pim] c-bsr loopback 0
    [*Switch ModuleC-pim] c-rp loopback 0
    [*Switch ModuleC-pim] commit
    [~Switch ModuleC-pim] quit
    

    # Enable IGMP on interfaces that connect Switch ModuleC, Switch ModuleD and hosts. The configuration of Switch ModuleD is similar to the configuration of Switch ModuleC, and is not mentioned.

    [~Switch ModuleC] interface vlanif 21
    [~Switch ModuleC-Vlanif21] igmp enable
    [*Switch ModuleC-Vlanif21] commit
    [~Switch ModuleC-Vlanif21] quit
    

  3. Configure anycast RP.

    # Configure the Loopback0 interface of Switch ModuleC and Switch ModuleD as anycast RPs. The configuration of Switch ModuleD is similar to the configuration of Switch ModuleC, and is not mentioned.

    [~Switch ModuleC] pim
    [*Switch ModuleC-pim] anycast-rp 1.1.1.1
    [*Switch ModuleC-pim-anycast-rp-1.1.1.1] commit
    [~Switch ModuleC-pim-anycast-rp-1.1.1.1] quit
    

    # Configure the address of Loopback1 on Switch ModuleC and Switch ModuleD as the local address of each anycast RP. The configuration of Switch ModuleD is similar to the configuration of Switch ModuleC, and is not mentioned.

    [~Switch ModuleC-pim] anycast-rp 1.1.1.1
    [*Switch ModuleC-pim-anycast-rp-1.1.1.1] local-address 2.2.2.2
    [*Switch ModuleC-pim-anycast-rp-1.1.1.1] commit
    [~Switch ModuleC-pim-anycast-rp-1.1.1.1] quit
    

    # Configure Switch ModuleC and Switch ModuleD as anycast RP peers.

    [~Switch ModuleC-pim] anycast-rp 1.1.1.1
    [*Switch ModuleC-pim-anycast-rp-1.1.1.1] peer 3.3.3.3
    [*Switch ModuleC-pim-anycast-rp-1.1.1.1] commit
    [~Switch ModuleC-pim-anycast-rp-1.1.1.1] quit
    [~Switch ModuleC-pim] quit
    

    [~Switch ModuleD-pim] anycast-rp 1.1.1.1
    [*Switch ModuleD-pim-anycast-rp-1.1.1.1] peer 2.2.2.2
    [*Switch ModuleD-pim-anycast-rp-1.1.1.1] commit
    [~Switch ModuleD-pim-anycast-rp-1.1.1.1] quit
    [~Switch ModuleD-pim] quit
    

  4. Verify the configuration.

    # Run the display pim rp-info command to check information about the RP on Switch ModuleC and Switch ModuleD.

    <Switch ModuleC> display pim rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: 224.0.0.0/4
         RP: 1.1.1.1 (local)
         Priority: 0
         Uptime: 00:45:19
         Expires: 00:02:11
         BIDIR: N
    
    <Switch ModuleD> display pim rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: 224.0.0.0/4
         RP: 1.1.1.1 (local)
         Priority: 0
         Uptime: 02:27:56
         Expires: 00:01:39
         BIDIR: N
    

    The preceding information shows that Switch ModuleC and Switch ModuleD serve as the RPs and can forward the Register message from the multicast source to each other.

    # Run the display pim routing-table command to check PIM entries on each switch modules. The multicast source 10.110.1.2/24 in the PIM-SM domain sends multicast data to multicast group G 226.1.1.1, and HostB joins G and receives the multicast data sent to G. The multicast source sends a Register message to Switch Module C and Host B sends a Join message to Switch Module D.

    <Switch ModuleC> display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (10.110.1.2, 226.1.1.1)
         RP: 1.1.1.1 (local)
         Protocol: pim-sm, Flag: SPT 2MSDP ACT
         UpTime: 00:00:38
         Upstream interface: Vlanif10
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif30
                 Protocol: pim-sm, UpTime: 00:01:15, Expires: -
    
    
    <Switch ModuleD> display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 226.1.1.1)
         RP: 1.1.1.1 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:01:25
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif31
                 Protocol: igmp, UpTime: 00:01:25, Expires: -
    
     (10.110.1.2, 226.1.1.1)
         RP: 1.1.1.1 (local)
         Protocol: pim-sm, Flag: SPT 2MSDP ACT
         UpTime: 00:00:02
         Upstream interface: Vlanif30
             Upstream neighbor: 192.168.3.1
             RPF prime neighbor: 192.168.3.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif31
                 Protocol: pim-sm, UpTime: 00:00:02, Expires: -

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 11
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif11
     ip address 10.110.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 11
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 20
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1
     area 0.0.0.0
       network 192.168.2.0 0.0.0.255
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 10 21 30
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif21
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif30
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/17/3
     port default vlan 21
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 10.110.2.0 0.0.0.255
      network 1.1.1.1 0.0.0.0
      network 2.2.2.2 0.0.0.0
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
     anycast-rp 1.1.1.1
      local-address 2.2.2.2
      peer 3.3.3.3
    #
    return
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 20 30 31
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif30
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif31
     ip address 10.110.3.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/17/2
     port default vlan 31
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
     anycast-rp 1.1.1.1
      local-address 3.3.3.3
      peer 2.2.2.2
    #
    return
    

Example for Configuring Basic Bidir-PIM Functions

Networking Requirements

Figure 8-65 shows an enterprise campus network. A multicast protocol is required on the network to allow multi-party video conferences among users connected to the network.

Figure 8-65 Networking diagram for basic Bidir-PIM configurations

Configuration Roadmap

If a multi-party video conferencing network runs PIM-SM to provide multicast services for many users, switches on the network will be overloaded because a lot of forwarding resources are consumed on the switches. To conserve the forwarding resources on the switches, configure Bidir-PIM on this network. The configuration roadmap is as follows:

  1. Assign IP addresses to interfaces and configure a unicast routing protocol on the switches. PIM is an intra-domain multicast routing protocol that depends on a unicast routing protocol. It can work only when the unicast routing protocol works normally.

  2. Enable Bidir-PIM on all the switches that need to provide multicast services. Other Bidir-PIM functions can be configured only after Bidir-PIM is enabled.

  3. Enable PIM-SM on all switch interfaces. Bidir-PIM uses the same neighbor discovery mechanism as PIM-SM. PIM-SM must be enabled on interfaces so that neighbor relationships can be set up between the switches.

  4. Enable IGMP on the interfaces connected to network segments of the hosts. Then receiver hosts can send IGMP messages to join or leave a group. The leaf switches use IGMP to maintain group memberships.

  5. Configure an RP and configure it to serve Bidir-PIM. On a Bidir-PIM network, an RP is the transit device for multicast data forwarding. An RP should be deployed on a switch with multiple branches for multicast data forwarding, like SwitchE in Figure 8-65.

Procedure

  1. Assign IP addresses to interfaces and configure a unicast routing protocol on the switches.

    # Configure IP addresses and masks for switch interfaces according to Figure 8-65. Configure OSPF on the switches to implement IP interworking between the switches and enable the switches to dynamically update routes. The configurations on Switch ModuleB, Switch ModuleC, Switch ModuleD, and Switch ModuleE are similar to the configuration on Switch ModuleA, and are not mentioned here.

    # Add interfaces of Switch ModuleA to VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 10 50
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port default vlan 10
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] port link-type trunk
    [*Switch ModuleA-10GE1/17/2] port trunk allow-pass vlan 50
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] commit
    

    # Assign IP addresses to VLANIF interfaces on Switch ModuleA.

    [~Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] ip address 192.168.1.1 24
    [*Switch ModuleA-Vlanif10] quit
    [*Switch ModuleA] interface vlanif 50
    [*Switch ModuleA-Vlanif50] ip address 10.1.1.1 24
    [*Switch ModuleA-Vlanif50] quit
    [*Switch ModuleA] commit

    # Configure a routing protocol on Switch ModuleA. OSPF is used in this example.

    [~Switch ModuleA] ospf
    [*Switch ModuleA-ospf-1] area 0
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] commit
    [~Switch ModuleA-ospf-1-area-0.0.0.0] quit
    [~Switch ModuleA-ospf-1] quit

  2. Enable Bidir-PIM globally and enable PIM-SM on all interfaces.

    # Enable Bidir-PIM globally on all switches and enable PIM-SM on all interfaces. The configurations on Switch ModuleB, Switch ModuleC, Switch ModuleD, and Switch ModuleE are similar to the configuration on Switch ModuleA, and are not mentioned here.

    [~Switch ModuleA] multicast routing-enable
    [*Switch ModuleA] pim
    [*Switch ModuleA-pim] bidir-pim
    [*Switch ModuleA-pim] quit
    [*Switch ModuleA] interface vlanif 10
    [*Switch ModuleA-Vlanif10] pim sm
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit
    [~Switch ModuleA] interface vlanif 50
    [~Switch ModuleA-Vlanif50] pim sm
    [*Switch ModuleA-Vlanif50] commit
    [~Switch ModuleA-Vlanif50] quit
    

  3. Enable IGMP on interfaces directly connected to network segments of hosts.

    # Enable IGMP on interface of Switch ModuleA connected to the network segment of HostA. The configurations on Switch ModuleB, Switch ModuleC, and Switch ModuleD are similar to the configuration on Switch ModuleA, and are not mentioned here.

    [~Switch ModuleA] interface vlanif 10
    [~Switch ModuleA-Vlanif10] igmp enable
    [*Switch ModuleA-Vlanif10] commit
    [~Switch ModuleA-Vlanif10] quit
    

  4. Configure an RP.

    # Configure a C-RP and a C-BSR on an interface of Switch ModuleE and configure the C-RP to serve Bidir-PIM.

    [~Switch ModuleE] pim
    [*Switch ModuleE-pim] c-bsr vlanif 60 
    [*Switch ModuleE-pim] c-rp vlanif 60 bidir
    [*Switch ModuleE-pim] commit
    [~Switch ModuleE-pim] quit
    

  5. Verify the configuration.

    # Run the display pim bsr-info command on the switches to view BSR information. For example, BSR information on Switch ModuleA and Switch ModuleE is displayed as follows. (The command output on Switch ModuleE also displays C-BSR information.)

    <Switch ModuleA> display pim bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: 10.1.2.2
         Priority: 0
         Hash mask length: 30
         State: Accept Preferred
         Scope: Not scoped
         Uptime: 00:05:57
         Expires: 00:01:27
         C-RP Count: 1
    
    
    <Switch ModuleE> display pim bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: 10.1.2.2
         Priority: 0
         Hash mask length: 30
         State: Elected
         Scope: Not scoped
         Uptime: 00:05:08 
         Next BSR message scheduled at: 00:00:06
         C-RP Count: 1
     Candidate AdminScoped BSR Count: 0
     Candidate BSR Address is: 10.1.2.2
         Priority: 0
         Hash mask length: 30
         State:Elected
         Scope: Not scoped   
         Wait to be BSR: 0

    The preceding information shows that the addresses of the elected BSR and C-BSR are both 10.1.2.2, IP address of VLANIF60 on Switch ModuleE.

    # Run the display pim rp-info command on the switches to check RP information. For example, RP information on Switch ModuleA is as follows:

    <Switch ModuleA> display pim rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number: 1
     Group/MaskLen: 224.0.0.0/4
         RP: 10.1.2.2
         Priority: 0
         Uptime: 00:10:49
         Expires: 00:01:41
         BIDIR: Y
    

    The preceding information shows that the address of the elected RP is 10.1.2.2 (IP address of VLANIF60 on Switch ModuleE), and the elected RP serves Bidir-PIM.

    # Run the display pim df-info command on the switches to check DF information. For example, DF information on SwitchA and SwitchE is as follows:

    <Switch ModuleA> display pim df-info
     VPN-Instance: public net
     Total Number of DF = 2
    
     RP: 10.1.2.2
     Interface           DF-Address               DF-Uptime     Rpf-Interface
     Vlanif10            192.168.1.1(local)       00:25:01      N
     Vlanif50            10.1.1.2                 00:25:01      Y
    <Switch ModuleE> display pim df-info
     VPN-Instance: public net
     Total Number of DF = 4
    
     RP: 10.1.2.2
     Interface           DF-Address               DF-Uptime     Rpf-Interface
     Vlanif50            10.1.1.2(local)          00:31:44      N
     Vlanif60            -                        -             Y
     Vlanif70            10.1.3.2(local)          00:31:44      N
     Vlanif80            10.1.4.2(local)          00:31:44      N

    # After HostA, HostB, HostC, and HostD join group 225.0.0.1 using IGMP, you can run the display pim routing-table command on the switches to view the PIM routing table. For example, the PIM routing table on SwitchA is as follows:

    <Switch ModuleA> display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
    
     (*, 225.0.0.1)
         RP: 10.1.2.2
         Protocol: bidir-pim, Flag: WC ACT
         UpTime: 00:36:47
         Rpf interface: Vlanif50
             Upstream neighbor: 10.1.1.2
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif10
                 Protocol: igmp, UpTime: 00:36:46, Expires: - 
            2: Vlanif50(RPF)
                 Protocol: bidir-pim, UpTime: 00:36:47, Expires: -

    You can see that the routing entries are generated by Bidir-PIM, and multicast data sent from the hosts (multicast sources) can be forwarded along the bidirectional RPT set up based on the (*, 225.0.0.1) entry.

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 10 50
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif50
     ip address 10.1.1.1 255.255.255.0
     pim sm 
    #
    interface 10GE1/17/1
     port default vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 20 60
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif60
     ip address 10.1.2.1 255.255.255.0
     pim sm 
    #
    interface 10GE1/17/1
     port default vlan 20
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 30 70
    #
    multicast routing-enable
    #
    interface Vlanif30
     ip address 192.168.3.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif70
     ip address 10.1.3.1 255.255.255.0
     pim sm 
    #
    interface 10GE1/17/1
     port default vlan 30
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    ospf 1
     area 0.0.0.0
      network 10.1.3.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
  • Configuration file of Switch ModuleD

    #
    sysname Switch ModuleD
    #
    vlan batch 40 80
    #
    multicast routing-enable
    #
    interface Vlanif40
     ip address 192.168.4.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif80
     ip address 10.1.4.1 255.255.255.0
     pim sm 
    #
    interface 10GE1/17/1
     port default vlan 40
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    ospf 1
     area 0.0.0.0
      network 10.1.4.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
  • Configuration file of Switch ModuleE

    #
    sysname Switch ModuleE
    #
    vlan batch 50 60 70 80
    #
    multicast routing-enable
    #
    interface Vlanif50
     ip address 10.1.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif60
     ip address 10.1.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif70
     ip address 10.1.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif80
     ip address 10.1.4.2 255.255.255.0
     pim sm 
    #
    interface 10GE1/17/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    interface 10GE1/17/4
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
    #
    pim
     c-bsr Vlanif60
     bidir-pim
     c-rp Vlanif60 bidir
    #
    return

Example for Configuring Bidir-PIM and PIM-SM on the Same Network

Networking Requirements

On the network shown in Figure 8-66, HostA needs to receive data for multicast group 225.1.1.1 through Bidir-PIM, and HostB needs to receive for multicast group 226.1.1.1 through PIM-SM.

Figure 8-66 Bidir-PIM and PIM-SM on the same network

Configuration Roadmap

Configure dynamic RPs to serve Bidir-PIM and PIM-SM on Switch ModuleA and configure ACL rules to define the range of multicast groups served by dynamic RPs. In this way, both Bidir-PIM and PIM-SM can function on the network. The configuration roadmap is as follows:

  1. Assign IP addresses to interfaces and configure a unicast routing protocol on each switch modules.

  2. Enable multicast routing on all the switch moduleses that provide multicast services.

  3. Enable Bidir-PIM on all the switch moduleses that provide multicast services.

  4. Enable PIM-SM on all interfaces of the switch moduleses that provide multicast services.

  5. Enable IGMP on switch modules interfaces directly connected to hosts.

  6. Configure the dynamic RP function. On Switch ModuleA, configure dynamic RPs on different interfaces to serve Bidir-PIM and PIM-SM respectively, and configure ACL rules to define the range of multicast groups served by dynamic RPs.

Procedure

  1. Assign IP addresses to interfaces and configure a unicast routing protocol on each switch modules.

    # Configure IP addresses and masks for switch interfaces according to Figure 8-66. Configure OSPF on the switches to implement IP interworking between the switches and enable the switches to dynamically update routes. The configurations of Switch ModuleB and Switch ModuleC are similar to the configuration of Switch ModuleA, and are not mentioned here.

    # Add interfaces of Switch ModuleA to VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch ModuleA
    [*HUAWEI] commit
    [~Switch ModuleA] vlan batch 30 100 200
    [*Switch ModuleA] interface 10ge 1/17/1
    [*Switch ModuleA-10GE1/17/1] port default vlan 30
    [*Switch ModuleA-10GE1/17/1] quit
    [*Switch ModuleA] interface 10ge 1/17/2
    [*Switch ModuleA-10GE1/17/2] port link-type trunk
    [*Switch ModuleA-10GE1/17/2] port trunk allow-pass vlan 100
    [*Switch ModuleA-10GE1/17/2] quit
    [*Switch ModuleA] interface 10ge 1/17/3
    [*Switch ModuleA-10GE1/17/3] port link-type trunk
    [*Switch ModuleA-10GE1/17/3] port trunk allow-pass vlan 200
    [*Switch ModuleA-10GE1/17/3] quit
    [*Switch ModuleA] commit
    

    # Assign IP addresses to interfaces of Switch ModuleA.

    [~Switch ModuleA] interface vlanif 30
    [*Switch ModuleA-Vlanif30] ip address 10.110.3.1 24
    [*Switch ModuleA-Vlanif30] quit
    [*Switch ModuleA] interface vlanif 100
    [*Switch ModuleA-Vlanif100] ip address 192.168.2.1 24
    [*Switch ModuleA-Vlanif100] quit
    [*Switch ModuleA] interface vlanif 200
    [*Switch ModuleA-Vlanif200] ip address 192.168.3.1 24
    [*Switch ModuleA-Vlanif200] quit
    [*Switch ModuleA] interface loopback0
    [*Switch ModuleA-LoopBack0] ip address 1.1.1.1 32
    [*Switch ModuleA-LoopBack0] quit
    [*Switch ModuleA] commit

    # Configure unicast routing protocol OSPF on Switch ModuleA.

    [~Switch ModuleA] router id 1.1.1.1
    [~Switch ModuleA] ospf
    [*Switch ModuleA-ospf-1] area 0
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 10.110.3.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255
    [*Switch ModuleA-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [*Switch ModuleA-ospf-1-area-0.0.0.0] commit
    [~Switch ModuleA-ospf-1-area-0.0.0.0] quit
    [~Switch ModuleA-ospf-1] quit

  2. Enable multicast routing and Bidir-PIM on the switch moduleses.

    # Enable multicast routing and Bidir-PIM on Switch ModuleA. The configurations of Switch ModuleB and Switch ModuleC are similar to the configuration of Switch ModuleA, and are not mentioned here.

    [~Switch ModuleA] multicast routing-enable
    [*Switch ModuleA] pim
    [*Switch ModuleA-pim] bidir-pim
    [*Switch ModuleA-pim] commit
    [~Switch ModuleA-pim] quit
    

  3. Enable PIM-SM on all the switch modules interfaces.

    # Enable PIM-SM on all the interfaces of Switch ModuleA. The configurations of Switch ModuleB and Switch ModuleC are similar to the configuration of Switch ModuleA, and are not mentioned here.

    [~Switch ModuleA] interface vlanif 30
    [~Switch ModuleA-Vlanif30] pim sm
    [*Switch ModuleA-Vlanif30] quit
    [*Switch ModuleA] interface vlanif 100
    [*Switch ModuleA-Vlanif100] pim sm
    [*Switch ModuleA-Vlanif100] quit
    [*Switch ModuleA] interface vlanif 200
    [*Switch ModuleA-Vlanif200] pim sm
    [*Switch ModuleA-Vlanif200] quit
    [*Switch ModuleA] interface loopback0
    [*Switch ModuleA-LoopBack0] pim sm
    [*Switch ModuleA-LoopBack0] quit
    [*Switch ModuleA] commit
    

  4. Enable IGMP on interfaces directly connected to network segments of hosts.

    # Configure Switch ModuleB.

    [~Switch ModuleB] interface vlanif 10
    [~Switch ModuleB-Vlanif10] igmp enable
    [*Switch ModuleB-Vlanif10] commit
    [~Switch ModuleB-Vlanif10] quit
    

    # Configure Switch ModuleC.

    [~Switch ModuleC] interface vlanif 20
    [~Switch ModuleC-Vlanif20] igmp enable
    [*Switch ModuleC-Vlanif20] commit
    [~Switch ModuleC-Vlanif20] quit
    

  5. Configure the dynamic RP function.

    # Configure different C-RP interfaces to serve Bidir-PIM and PIM-SM on Switch ModuleA.

    [~Switch ModuleA] acl number 2000
    [*Switch ModuleA-acl4-basic-2000] rule permit source 225.1.1.0 0.0.0.255
    [*Switch ModuleA-acl4-basic-2000] quit
    [*Switch ModuleA] acl number 2001
    [*Switch ModuleA-acl4-basic-2001] rule permit source 226.1.1.0 0.0.0.255
    [*Switch ModuleA-acl4-basic-2001] quit
    [*Switch ModuleA] pim
    [*Switch ModuleA-pim] c-bsr vlanif30
    [*Switch ModuleA-pim] c-rp loopback0 group-policy 2000 bidir
    [*Switch ModuleA-pim] c-rp vlanif30 group-policy 2001
    [*Switch ModuleA-pim] commit
    [~Switch ModuleA-pim] quit
    

  6. Verify the configuration.

    # Run the display pim routing-table command to view the PIM routing table on each switch modules. You can see from the routing tables that multicast source 10.110.3.100/24 sends data to multicast groups 225.1.1.1/24 and 226.1.1.1/24, HostA joined group 225.1.1.1/24, and HostB joined group 226.1.1.1/24. For example, the PIM routing tables on Switch ModuleA and Switch ModuleB are as follows:

    [~Switch ModuleA] display pim routing-table
     VPN-Instance: public net
     Total 2 (*, G) entries; 1 (S, G) entry
    
     (*, 226.1.1.1)
         RP: 10.110.3.1 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 03:05:41
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif200
                 Protocol: pim-sm, UpTime: 03:05:41, Expires: 00:02:50
    
     (10.110.3.100, 226.1.1.1)
         RP: 10.110.3.1 (local)
         Protocol: pim-sm, Flag: SPT LOC ACT
         UpTime: 00:06:27
         Upstream interface: Vlanif30
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif200
                 Protocol: pim-sm, UpTime: 00:06:27, Expires: 00:03:04
    
     (*, 225.1.1.1)
         RP: 1.1.1.1 (local)
         Protocol: bidir-pim, Flag: WC ACT
         UpTime: 03:00:42
         Rpf interface: LoopBack0
             Upstream neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif100
                 Protocol: bidir-pim, UpTime: 03:00:42, Expires: 00:02:48
            2: LoopBack0(RPF)
                 Protocol: bidir-pim, UpTime: 03:00:42, Expires: -
    [~Switch ModuleB] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 1.1.1.1
         Protocol: bidir-pim, Flag: WC ACT
         UpTime: 00:01:08
         Rpf interface: Vlanif100
             Upstream neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif10
                 Protocol: igmp, UpTime: 00:01:07, Expires: -
            2: Vlanif100(RPF)
                 Protocol: bidir-pim, UpTime: 00:01:08, Expires: - 

    According to the command output, HostA can receive data for group 225.1.1.1 through Bidir-PIM, and HostB can receive data for group 226.1.1.1 through PIM-SM.

Configuration Files
  • Configuration file of Switch ModuleA

    #
    sysname Switch ModuleA
    #
    vlan batch 30 100 200
    #
    router id 1.1.1.1
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 225.1.1.0 0.0.0.255
    #
    acl number 2001
     rule 5 permit source 226.1.1.0 0.0.0.255
    #
    interface Vlanif30
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif100
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface Vlanif200
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 30
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     c-bsr Vlanif30
     bidir-pim
     c-rp LoopBack0 group-policy 2000 bidir
     c-rp Vlanif30 group-policy 2001 
    #
    return
    
  • Configuration file of Switch ModuleB

    #
    sysname Switch ModuleB
    #
    vlan batch 10 100
    #
    router id 2.2.2.2
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 10.110.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif100
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 10
    #
    interface 10GE1/17/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
    
  • Configuration file of Switch ModuleC

    #
    sysname Switch ModuleC
    #
    vlan batch 20 200
    #
    router id 3.3.3.3
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif200
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface 10GE1/17/1
     port default vlan 20
    #
    interface 10GE1/17/3
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
    
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 57894

Downloads: 3621

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next