No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CX11x, CX31x, CX710 (Earlier Than V6.03), and CX91x Series Switch Modules V100R001C10 Configuration Guide 12

The documents describe the configuration of various services supported by the CX11x&CX31x&CX91x series switch modules The description covers configuration examples and function configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This topic describes the networking requirements, configuration methods, and configuration procedures for the typical application scenarios of Smart Channels and provides configuration files.

Configuring a Smart Channel of Automatic Link Aggregation

Network Requirements

As shown in Figure 11-89, the switch modules in slots 2X and 3X of the E9000 are in the stack mode. The two data center TOR switches are cascaded through a link or LAG. Each switch module connects to the two data center switches. The two links of each TOR switch are added to the corresponding LACP LAG. The four links are also added to the same Smart Channel. The LACP negotiation result is as follows: two links are added to Trunk A and forward data, and the other two links are added to Trunk B and blocked. This configuration ensures network connectivity and reliability by providing two LAGs in active/standby mode.

Figure 11-89 Automatic link aggregation
Configuration Method

Configure automatic link aggregation as follows:

  1. Configure Eth-Trunks for Switch A and Switch B.
  2. Configure Switch C and Switch D to work in Channel mode and create a stack based on them.

Procedure

  1. Configure Eth-Trunks for Switch A and Switch B.

    # Create Eth-Trunk 10 for Switch A and add ports to Eth-Trunk 10.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] interface eth-trunk 10
    [*SwitchA-Eth-Trunk10] mode lacp-static
    [*SwitchA-Eth-Trunk10] trunkport 10ge 2/17/1
    [*SwitchA-Eth-Trunk10] trunkport 10ge 2/17/2
    [*SwitchA-Eth-Trunk10] quit
    [*SwitchA] commit

    # Create Eth-Trunk 10 for Switch B and add ports to Eth-Trunk 10.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] interface eth-trunk 10
    [*SwitchB-Eth-Trunk10] mode lacp-static
    [*SwitchB-Eth-Trunk10] trunkport 10ge 3/17/1
    [*SwitchB-Eth-Trunk10] trunkport 10ge 3/17/2
    [*SwitchB-Eth-Trunk10] quit
    [*SwitchB] commit

  2. Configure Switch C and Switch D to work in Channel mode and create a stack based on them.

    # Set the working mode of Switch C to the Channel mode.

    <HUAWEI> working mode channel
    Warning: To change working mode, system will reboot and then startup with another configuration file for configured working mode. Continue? [Y/N]:y

    # Set the working mode of Switch D to the Channel mode.

    <HUAWEI> working mode channel
    Warning: To change working mode, system will reboot and then startup with another configuration file for configured working mode. Continue? [Y/N]:y

    # Create a stack based on Switch C and Switch D. For details, see Example for Establishing a Stack in a Chain Topology.

  3. Set the VLAN information.

    # Set the VLAN for Eth-Trunk 10 of Switch A.

    <SwitchA> system-view
    [~SwitchA] vlan 100
    [*SwitchA-vlan100] interface eth-trunk 10
    [*SwitchA-Eth-Trunk10] port link-type hybrid
    [*SwitchA-Eth-Trunk10] port hybrid tagged vlan 100
    [*SwitchA-Eth-Trunk10] quit
    [*SwitchA] commit

    # Set the VLAN for Eth-Trunk 10 of Switch B.

    <SwitchB> system-view
    [~SwitchB] vlan 100
    [*SwitchB-vlan100] interface eth-trunk 10
    [*SwitchB-Eth-Trunk10] port link-type hybrid
    [*SwitchB-Eth-Trunk10] port hybrid tagged vlan 100
    [*SwitchB-Eth-Trunk10] quit
    [*SwitchB] commit

    # Set the VLAN for the Smart Channel of Switch C and Switch D.

    <HUAWEI> system-view
    [~HUAWEI] sysname E9000
    [*HUAWEI] commit
    [~E9000] vlan 100
    [*E9000-vlan100] interface eth-trunk 0
    [*E9000-Eth-Trunk0] port link-type hybrid
    [*E9000-Eth-Trunk0] port hybrid tagged vlan 100
    [*E9000-Eth-Trunk0] quit
    [*E9000] interface eth-trunk 1
    [*E9000-Eth-Trunk1] port link-type hybrid
    [*E9000-Eth-Trunk1] port hybrid tagged vlan 100
    [*E9000-Eth-Trunk1] quit
    [*E9000] commit

  4. Verify the configuration result.

    In any view of the Switch C or Switch D CLI, run the display smart channel channel-id command to view the Smart Channel information.

    <E9000> display smart channel 1
    Smart channel 1 detail information:
    Link switch delay time: 30
    Current state: up
    
    TrunkA(active Link) state information:
    Eth-Trunk Id: 0,        Working Mode: static,         Add Member Port Mode: auto
    --------------------------------------------------------------------------------
    PortName                         Link-status                      Lacp-status                     
    --------------------------------------------------------------------------------
    10GE2/17/1                       up                               Selected                        
    10GE3/17/1                       up                               Selected                        
    --------------------------------------------------------------------------------
    
    TrunkB(standby Link) state information:
    Eth-Trunk Id: 1,        Working Mode: static,         Add Member Port Mode: auto
    --------------------------------------------------------------------------------
    PortName                         Link-status                      Lacp-status
    --------------------------------------------------------------------------------
    10GE2/17/2                       up                               Selected                        
    10GE3/17/2                       up                               Selected                        
    --------------------------------------------------------------------------------
    
    Member ports of smart channel 1:
    --------------------------------------------------------------------------------
    PortName                         Link-status                                                      
    --------------------------------------------------------------------------------
    10GE2/17/3                       down                                                             
    10GE2/17/4                       down                                                             
    10GE2/17/5                       down                                                             
    10GE2/17/6                       down                                                             
    10GE2/17/7                       down                                                             
    10GE2/17/8                       down                                                             
    10GE2/17/9                       down                                                             
    10GE2/17/10                      down                                                             
    10GE2/17/11                      down                                                             
    10GE2/17/12                      down                                                             
    10GE2/17/13                      down                                                             
    10GE2/17/14                      down                                                             
    10GE2/17/15                      down                                                             
    10GE2/17/16                      down                                                             
    10GE3/17/3                       down                                                             
    10GE3/17/4                       down                                                             
    10GE3/17/5                       down                                                             
    10GE3/17/6                       down                                                             
    10GE3/17/7                       down                                                             
    10GE3/17/8                       down                                                             
    10GE3/17/9                       down                                                             
    10GE3/17/10                      down                                                             
    10GE3/17/11                      down                                                             
    10GE3/17/12                      down                                                             
    10GE3/17/13                      down                                                             
    10GE3/17/14                      down                                                             
    10GE3/17/15                      down                                                             
    10GE3/17/16                      down                                                             
    --------------------------------------------------------------------------------
    
    Flow statistic:
    Last 300 seconds input rate 82 bits/sec, 0 packets/sec
    Last 300 seconds output rate 88 bits/sec, 0 packets/sec
    Input: 22 packets, 2752 bytes
           0 unicast, 1 broadcast, 21 multicast
           0 errors, 0 drops
    Output:23 packets, 2939 bytes
           0 unicast, 0 broadcast, 23 multicast
           0 errors, 0 drops

Configuration Files
  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    lacp priority 65535
    #
    interface Eth-Trunk10
     port link-type hybrid
     port hybrid tagged vlan 100
     mode lacp-static
    #
    interface 10GE2/17/1
     eth-trunk 10
    #
    interface 10GE2/17/2
     eth-trunk 10
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan 100
    #
    lacp priority 65535
    #
    interface Eth-Trunk10
     port link-type hybrid
     port hybrid tagged vlan 100
     mode lacp-static
    #
    interface 10GE3/17/1
     eth-trunk 10
    #
    interface 10GE3/17/2
     eth-trunk 10
    #
    return
  • Configuration file of the E9000

    #
    sysname E9000
    #
    vlan 100
    #
    interface Eth-Trunk0
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    interface Eth-Trunk1
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    return

Configuring a Smart Channel of Manual Link Aggregation

Network Requirements

As shown in Figure 11-90, the switch modules on the E9000 are in the stack mode. The two data center switches are also in the stack mode. Each switch module connects to a data center switch through two links. The four links are added to the same LAG (Eth-Trunk) on the data center switches. The four links are also added to the same LAG of a Smart Channel by using the CLI of switch modules. This is a single-LAG network.

Figure 11-90 Manual link aggregation
Configuration Method

Configure manual link aggregation as follows:

  1. Configure an Eth-Trunk for the stack formed by Switch A and Switch B.
  2. Configure Switch C and Switch D to work in Channel mode.
  3. Add ports to the Eth-Trunk.

Procedure

  1. Configure Eth-Trunks for Switch A and Switch B.

    # Configure an Eth-Trunk for the stack formed by Switch A and Switch B and add ports to the Eth-Trunk.

    <HUAWEI> system-view
    [~HUAWEI] sysname iStack
    [*HUAWEI] commit
    [~iStack] interface eth-trunk 10
    [*iStack-Eth-Trunk10] trunkport 10ge 2/17/1 to 2/17/2
    [*iStack-Eth-Trunk10] trunkport 10ge 3/17/1 to 3/17/2
    [*iStack-Eth-Trunk10] quit
    [*iStack] commit

  2. Configure Switch C and Switch D to work in Channel mode and create a stack based on them.

    # Set the working mode of Switch C to the Channel mode.

    <HUAWEI> working mode channel
    Warning: To change working mode, system will reboot and then startup with another configuration file for configured working mode. Continue? [Y/N]:y

    # Set the working mode of Switch D to the Channel mode.

    <HUAWEI> working mode channel
    Warning: To change working mode, system will reboot and then startup with another configuration file for configured working mode. Continue? [Y/N]:y

    # Create a stack based on Switch C and Switch D. For details, see Example for Establishing a Stack in a Chain Topology.

  3. Set VLAN information.

    # Set the VLAN for Eth-Trunk 10.

    <HUAWEI> system-view
    [~HUAWEI] sysname iStack
    [*HUAWEI] commit
    [~iStack] vlan 100
    [*iStack-vlan100] interface eth-trunk 10
    [*iStack-Eth-Trunk10] port link-type hybrid
    [*iStack-Eth-Trunk10] port hybrid tagged vlan 100
    [*iStack-Eth-Trunk10] quit
    [*iStack] commit

    # Set the VLAN for the Smart Channel of Switch C and Switch D.

    <HUAWEI> system-view
    [~HUAWEI] sysname E9000
    [*HUAWEI] commit
    [~E9000] vlan 100
    [*E9000-vlan100] interface eth-trunk 0
    [*E9000-Eth-Trunk0] port link-type hybrid
    [*E9000-Eth-Trunk0] port hybrid tagged vlan 100
    [*E9000-Eth-Trunk0] quit
    [*E9000] interface eth-trunk 1
    [*E9000-Eth-Trunk1] port link-type hybrid
    [*E9000-Eth-Trunk1] port hybrid tagged vlan 100
    [*E9000-Eth-Trunk1] quit
    [*E9000] commit

  4. Add ports to Trunk A using the Switch C and Switch D CLI.

    # Set the working mode of Switch C to the Channel mode.

    <HUAWEI> system-view
    [~HUAWEI] sysname E9000
    [*HUAWEI] commit
    [~E9000] smart channel 1
    [*E9000-smart-channel1] port member 10GE2/17/1 to 10GE2/17/2 trunkA
    [*E9000-smart-channel1] port member 10GE3/17/1 to 10GE3/17/2 trunkA
    [*E9000-smart-channel1] commit

  5. Verify the configuration result.

    In any view of the Switch C or Switch D CLI, run the display smart channel channel-id command to view Smart Channel information.

    <E9000> display smart channel 1
    Smart channel 1 detail information:
    Link switch delay time: 30
    Current state: up
    
    TrunkA(active Link) state information:
    Eth-Trunk Id: 0,        Working Mode: manual,         Add Member Port Mode: manual
    --------------------------------------------------------------------------------
    PortName                         Link-status                      Lacp-status                     
    --------------------------------------------------------------------------------
    10GE2/17/1                       up                               --                              
    10GE2/17/2                       up                               --                              
    10GE3/17/1                       up                               --                              
    10GE3/17/2                       up                               --                              
    --------------------------------------------------------------------------------
    
    TrunkB(standby Link) state information:
    Eth-Trunk Id: 1,        Working Mode: manual,         Add Member Port Mode: auto
    --------------------------------------------------------------------------------
    PortName                         Link-status                      Lacp-status
    --------------------------------------------------------------------------------
    --------------------------------------------------------------------------------
    
    Member ports of smart channel 1:
    --------------------------------------------------------------------------------
    PortName                         Link-status                                                      
    --------------------------------------------------------------------------------
    10GE2/17/3                       down                                                             
    10GE2/17/4                       down                                                             
    10GE2/17/5                       down                                                             
    10GE2/17/6                       down                                                             
    10GE2/17/7                       down                                                             
    10GE2/17/8                       down                                                             
    10GE2/17/9                       down                                                             
    10GE2/17/10                      down                                                             
    10GE2/17/11                      down                                                             
    10GE2/17/12                      down                                                             
    10GE2/17/13                      down                                                             
    10GE2/17/14                      down                                                             
    10GE2/17/15                      down                                                             
    10GE2/17/16                      down                                                             
    10GE3/17/3                       down                                                             
    10GE3/17/4                       down                                                             
    10GE3/17/5                       down                                                             
    10GE3/17/6                       down                                                             
    10GE3/17/7                       down                                                             
    10GE3/17/8                       down                                                             
    10GE3/17/9                       down                                                             
    10GE3/17/10                      down                                                             
    10GE3/17/11                      down                                                             
    10GE3/17/12                      down                                                             
    10GE3/17/13                      down                                                             
    10GE3/17/14                      down                                                             
    10GE3/17/15                      down                                                             
    10GE3/17/16                      down                                                             
    --------------------------------------------------------------------------------
    
    Flow statistic:
    Last 300 seconds input rate 82 bits/sec, 0 packets/sec
    Last 300 seconds output rate 88 bits/sec, 0 packets/sec
    Input: 22 packets, 2752 bytes
           0 unicast, 1 broadcast, 21 multicast
           0 errors, 0 drops
    Output:23 packets, 2939 bytes
           0 unicast, 0 broadcast, 23 multicast
           0 errors, 0 drops

Configuration Files
  • Configuration file of iStack (name of the stack formed by switches)

    #
    sysname iStack
    #
    vlan 100
    #
    lacp priority 65535
    #
    interface Eth-Trunk10
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    interface 10GE2/17/1
     eth-trunk 10
    #
    interface 10GE2/17/2
     eth-trunk 10
    #
    interface 10GE3/17/1
     eth-trunk 10
    #
    interface 10GE3/17/2
     eth-trunk 10
    #return
  • Configuration file of the E9000

    #
    sysname E9000
    #
    vlan 100
    #
    interface Eth-Trunk0
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    interface Eth-Trunk1
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    smart channel 1
     eth-trunk 0 1
     port member 10GE2/17/1 to 10GE2/17/2 TrunkA
     port member 10GE2/17/3 to 10GE2/17/16
     port member 10GE3/17/1 to 10GE3/17/2 TrunkA
     port member 10GE3/17/3 to 10GE3/17/16
    #
    return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000041694

Views: 59083

Downloads: 3623

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next