No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S1720, S2700, S3700, S5700, S6700, S7700, and S9700 Series Switches Common Operation Guide

This document describes the CLI-based configurations of universal protocols and common features for Huawei switches on basic networks.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Changing the Link Type of an Interface

Changing the Link Type of an Interface

The link type of an interface can be access, trunk, hybrid, or Dot1q-tunnel. The methods used to change the link type of an interface in different versions are different.
  • In V200R005 and later versions, run the port link-type { access | trunk | hybrid | dot1q-tunnel } command and enter y or n as prompted. When the interface uses the default VLAN configuration, the system does not display any message. The link type of the interface is changed directly.
    • When you enter y and press Enter, the device automatically deletes the non-default VLAN configuration of the interface and set the link type of the interface to the specified one.
    • When you enter n and press Enter, the device retains the current link type and VLAN configuration of the interface.
    Change the link type of the interface to hybrid.
    <HUAWEI> system-view
    [HUAWEI] interface gigabitethernet0/0/1
    [HUAWEI-GigabitEthernet0/0/1] port link-type hybrid
    Warning: This command will delete VLANs on this port. Continue?[Y/N]:y 
    Info: This operation may take a few seconds. Please wait for a moment...done.
  • In earlier versions of V200R005, an interface joins VLAN 1 by default, and the PVID of an interface is VLAN 1. You can run the port link-type { access | trunk | hybrid | dot1q-tunnel } command to change the link type of the interface.
    • Change the link type of the interface to access.

      <HUAWEI> system-view
      [HUAWEI] interface gigabitethernet0/0/1
      [HUAWEI-GigabitEthernet0/0/1] port link-type access
      [HUAWEI-GigabitEthernet0/0/1] port default vlan 10   //Set the PVID of the interface to VLAN 10.
    • Change the link type of the interface to trunk.

      <HUAWEI> system-view
      [HUAWEI] interface gigabitethernet0/0/1
      [HUAWEI-GigabitEthernet0/0/1] port link-type trunk
      [HUAWEI-GigabitEthernet0/0/1] port trunk pvid vlan 10   //Set the PVID of the interface to VLAN 10.
      [HUAWEI-GigabitEthernet0/0/1] port trunk allow-pass vlan 2 10 20   //Add the interface to VLAN 2, VLAN 10, and VLAN 20.
    • Change the link type of the interface to hybrid.

      <HUAWEI> system-view
      [HUAWEI] interface gigabitethernet0/0/1
      [HUAWEI-GigabitEthernet0/0/1] port link-type hybrid
      [HUAWEI-GigabitEthernet0/0/1] port hybrid pvid vlan 10   //Set the PVID of the interface to VLAN 10.
      [HUAWEI-GigabitEthernet0/0/1] port hybrid untagged vlan 2 10   //Add the interface to VLAN 2 and VLAN 10 in untagged mode.
      [HUAWEI-GigabitEthernet0/0/1] port hybrid tagged vlan 20   //Add the interface to VLAN 20 in tagged mode.
    • Change the link type of the interface to Dot1q-tunnel.

      <HUAWEI> system-view
      [HUAWEI] interface gigabitethernet0/0/1
      [HUAWEI-GigabitEthernet0/0/1] port link-type dot1q-tunnel
      [HUAWEI-GigabitEthernet0/0/1] port default vlan 10   //Set the PVID of the interface to VLAN 10. The interface adds VLAN 10 to all received data packets.

    When you change the link type of an interface that does not use the default VLAN configuration, the system displays the message "Error: Please renew the default configurations."

    You need to restore the default configuration of the interface, and then change the link type of the interface.

    • Restore the default VLAN configuration of an access or Dot1q-tunnel interface.
      <HUAWEI> system-view
      [HUAWEI] interface gigabitethernet0/0/1
      [HUAWEI-GigabitEthernet0/0/1] undo port default vlan
    • Restore the default VLAN configuration of a trunk interface.
      <HUAWEI> system-view
      [HUAWEI] interface gigabitethernet0/0/1
      [HUAWEI-GigabitEthernet0/0/1] undo port trunk pvid vlan
      [HUAWEI-GigabitEthernet0/0/1] undo port trunk allow-pass vlan all
      [HUAWEI-GigabitEthernet0/0/1] port trunk allow-pass vlan 1
    • Restore the default configuration of a hybrid interface.
      <HUAWEI> system-view
      [HUAWEI] interface gigabitethernet0/0/1
      [HUAWEI-GigabitEthernet0/0/1] undo port hybrid pvid vlan
      [HUAWEI-GigabitEthernet0/0/1] undo port hybrid vlan all
      [HUAWEI-GigabitEthernet0/0/1] port hybrid untagged vlan 1
Translation
Download
Updated: 2018-09-03

Document ID: EDOC1000057410

Views: 84044

Downloads: 12092

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next