No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 Series Agile Switches Typical Configuration Examples

This document provides examples for configuring features in typical usage scenarios.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Combining Standalone Switches into a CSS

Combining Standalone Switches into a CSS

Networking Requirements

Two modular switches at the aggregation layer use VRRP and STP to implement gateway backup. To simplify the configuration, the two modular switches need to be combined into a logical CSS.

In Figure 5-8, S1 and S2 at the aggregation layer are two standalone switches and need to be combined into a CSS to simplify configuration and facilitate maintenance and management.

Figure 5-8  Networking diagram of combining standalone switches into a CSS

When two standalone devices are combined into a CSS, major configuration changes include:
  • The VRRP gateway backup protocol deployed at the aggregation layer is not required and its configuration needs to be deleted.
  • The STP loop prevention protocol deployed at the access layer is not required and its configuration needs to be deleted.
  • The links at the access, aggregation, and core layers are changed to Eth-Trunks, and related interface configurations need to be changed, including basic VLAN configuration, QoS configuration, and ACL configuration.

Guidelines

  • Before combining two standalone switches into a CSS, ensure that the hardware and software of the two switches meet CSS requirements. CSS cards and cluster cables have been prepared.
  • After the CSS function is enabled on a standalone switch, configurations on the interfaces of the switch will be lost. Therefore, back up the configuration file before enabling the CSS function.
  • The following procedure provides only the related configurations. Whether other configurations need to be changed depends on the actual networking.

Procedure

  1. In the original networking, traffic at the access layer is load-balanced among multiple links through STP and VRRP. In Figure 5-9, some traffic is forwarded through S1 and some traffic is forwarded through S2.

    Figure 5-9  Existing traffic forwarding

  2. Manually shut down the uplink and downlink ports of S2 to change the STP and VRRP status so that S2 is isolated from the network and all traffic is forwarded through S1, as shown in Figure 5-10.

    Figure 5-10  Traffic forwarding after an STP and VRRP status switchover

  3. Back up the configuration file of S2. After the CSS function is enabled on a standalone switch, the interface number format on the switch is changed from slot ID/subcard ID/port number to stack member ID/slot ID/subcard ID/port number, and the configurations on the interfaces of the switch are lost.
  4. Change S2 to the CSS state.

    1. Power off S2, install CSS cards, and power on S2.
    2. Configure the CSS priority on S2.
      <S2> system-view
      [S2] set css priority 200  // Set the CSS priority to 200 to make S2 become the CSS master. The default CSS priority is 100.
      [S2] display css status saved  // Check whether the configuration is correct.
      Current Id   Saved Id     CSS Enable   CSS Mode    Priority    Master Force                                                         
      ------------------------------------------------------------------------------                                                      
      1            1            Off          CSS card    200         On                                                                   
    3. Enable the CSS function on S2 and restart S2.
      [S2] css enable
      Warning: The CSS configuration will take effect only after the system is rebooted. The next CSS mode is CSS card. Reboot now? [Y/N]:y
    4. After S2 is restarted, check its CSS status. If the following output is displayed, S2 has been changed to the CSS state:
      <S2> display device
      Chassis 1 (Master Switch)                                                       
      Chassis 1 (Master Switch)                                                       
      S12708's Device status:                                                         
      Slot  Sub Type         Online    Power      Register       Status     Role      
      ------------------------------------------------------------------------------- 
      5     -   ET1D2G48SEC0 Present   PowerOn    Registered     Normal     NA        
      7     -   ET1D2X16SSC0 Present   PowerOn    Registered     Normal     NA        
      8     -   ET1D2X48SEC0 Present   PowerOn    Registered     Normal     NA        
      9     -   ET1D2MPUA000 Present   PowerOn    Registered     Normal     Master    
      10    -   ET1D2MPUA000 Present   PowerOn    Registered     Normal     Slave     
      11    -   ET1D2SFUC000 Present   PowerOn    Registered     Normal     NA        
            1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA        
      12    -   ET1D2SFUC000 Present   PowerOn    Registered     Normal     NA        
            1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA        
      13    -   ET1D2SFUC000 Present   PowerOn    Registered     Normal     NA        
            1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA        
      14    -   ET1D2SFUC000 Present   PowerOn    Registered     Normal     NA        
            1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA        
      PWR1  -   -            Present   PowerOn    Registered     Normal     NA        
      PWR2  -   -            Present   PowerOn    Registered     Normal     NA        
      CMU2  -   EH1D200CMU00 Present   PowerOn    Registered     Normal     Master    
      FAN1  -   -            Present   PowerOn    Registered     Normal     NA        
      FAN2  -   -            Present   PowerOn    Registered     Normal     NA        
      FAN3  -   -            Present   PowerOn    Registered     Normal     NA        
      FAN4  -   -            Present   PowerOn    Registered     Normal     NA        
      

  5. Change the configuration of S2, which has been changed to a single-chassis cluster CSS-1. Alternatively, change the configuration after S1 and S2 are combined into a CSS. Changing the configuration of S2 before S1 and S2 are combined into a CSS can reduce the traffic loss.

    Figure 5-11  Single-chassis CSS

    1. Bind uplink ports XGE1/4/0/1 and XGE1/4/0/2 of CSS-1 to Eth-Trunks and move the configurations of these ports to the Eth-Trunks.

      For example: The configurations on the original ports (connecting CSS-1 to devices at the core layer) are as follows:
      #
      interface XGigabitEthernet4/0/1
       undo portswitch                                                                                                                    
       ip address 192.168.4.2 255.255.255.0 
      #
      interface XGigabitEthernet4/0/2
       port link-type trunk                                                                                                               
       port trunk allow-pass vlan 100 200
      #
      
      Change the configurations.
      <S2> system-view
      [S2] sysname CSS  // Change the device name to facilitate maintenance.
      [CSS] interface eth-trunk 20  // Add the port connecting the CSS to a core device to Eth-Trunk 20.
      [CSS-Eth-Trunk20] trunkport xgigabitethernet1/4/0/1
      [CSS-Eth-Trunk20] ip address 192.168.4.2 255.255.255.0
      [CSS-Eth-Trunk20] quit
      [CSS] interface eth-trunk 10  // Add the port connecting the CSS to another core device to Eth-Trunk 10.
      [CSS-Eth-Trunk10] trunkport xgigabitethernet1/4/0/2
      [CSS-Eth-Trunk10] port link-type trunk
      [CSS-Eth-Trunk10] port trunk allow-pass vlan 100 200
      [CSS-Eth-Trunk10] quit
      
    2. Change the configurations of devices at the core layer and access layer and bind physical ports to Eth-Trunks. The procedure is similar to the preceding procedure.

    3. Delete the VRRP configuration on CSS-1.

      For example, the configurations of VLANIF interfaces are as follows:
      #
      interface Vlanif100
       ip address 10.1.10.1 255.255.255.0
       vrrp vrid 1 virtual-ip 10.1.10.111
       vrrp vrid 1 priority 120
      #
      interface Vlanif200
       ip address 10.1.20.1 255.255.255.0
       vrrp vrid 2 virtual-ip 10.1.20.111
      #
      Delete the configurations of VLANIF interfaces.
      [CSS] interface vlanif 100
      [CSS-Vlanif100] undo vrrp vrid 1
      [CSS-Vlanif100] undo ip address
      [CSS-Vlanif100] quit
      [CSS] interface vlanif 200
      [CSS-Vlanif200] undo vrrp vrid 2
      [CSS-Vlanif200] undo ip address
      [CSS-Vlanif200] quit
      
    4. Delete unnecessary network segments from the OSPF routing domain.
    5. Change the configurations of the interfaces on which QoS and ACLs are configured to bind these interfaces to Eth-Trunks.
    6. Change the STP priority of CSS-1 so that CSS-1 becomes the root switch of all VLANs.

  6. Run the undo shutdown command to disable the interfaces on CSS-1 to check whether Layer 2 and Layer 3 forwarding between CSS-1 and devices at the access layer and core layer is normal.
  7. After confirming that Layer 2 and Layer 3 forwarding between CSS-1 and devices at the access layer and core layer is normal, shut down interfaces on S1 so that S1 is isolated from the network and all traffic is forwarded through CSS-1.

    Figure 5-12  Traffic switched to CSS-1

  8. Change S1 to the CSS state. After S1 is added to CSS-1, S1 uses the configuration file of CSS-1.

    1. Power off S1, install CSS cards, connect the cluster cables between S1 and CSS-1, and power on S1.
    2. Configure the CSS ID and retain the default CSS priority 100 on S1.
      <S1> system-view
      [S1] set css id 2
      
    3. Enable the CSS function on S1 and restart S1.
      [S1] css enable
      Warning: The CSS configuration will take effect only after the system is rebooted. The next CSS mode is CSS card. Reboot now? [Y/N]:y
    4. After S1 is restarted, check its CSS status. If the following output is displayed, S1 has joined the CSS.
      <CSS> display device
      Chassis 1 (Master Switch)                                                       
      S12708's Device status:                                                         
      Slot  Sub Type         Online    Power      Register       Status     Role      
      ------------------------------------------------------------------------------- 
      5     -   ET1D2G48SEC0 Present   PowerOn    Registered     Normal     NA        
      7     -   ET1D2X16SSC0 Present   PowerOn    Registered     Normal     NA        
      8     -   ET1D2X48SEC0 Present   PowerOn    Registered     Normal     NA        
      9     -   ET1D2MPUA000 Present   PowerOn    Registered     Normal     Master    
      10    -   ET1D2MPUA000 Present   PowerOn    Registered     Normal     Slave     
      11    -   ET1D2SFUC000 Present   PowerOn    Registered     Normal     NA        
            1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA        
      12    -   ET1D2SFUC000 Present   PowerOn    Registered     Normal     NA        
            1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA        
      13    -   ET1D2SFUC000 Present   PowerOn    Registered     Normal     NA        
            1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA        
      14    -   ET1D2SFUC000 Present   PowerOn    Registered     Normal     NA        
            1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA        
      PWR1  -   -            Present   PowerOn    Registered     Normal     NA        
      PWR2  -   -            Present   PowerOn    Registered     Normal     NA        
      CMU2  -   EH1D200CMU00 Present   PowerOn    Registered     Normal     Master    
      FAN1  -   -            Present   PowerOn    Registered     Normal     NA        
      FAN2  -   -            Present   PowerOn    Registered     Normal     NA        
      FAN3  -   -            Present   PowerOn    Registered     Normal     NA        
      FAN4  -   -            Present   PowerOn    Registered     Normal     NA  
      Chassis 2 (Standby Switch)                                                       
      S12708's Device status:                                                         
      Slot  Sub Type         Online    Power      Register       Status     Role      
      ------------------------------------------------------------------------------- 
      3     -   ET1D2G48SEC0 Present   PowerOn    Registered     Normal     NA        
      4     -   ET1D2X16SSC0 Present   PowerOn    Registered     Normal     NA        
      9     -   ET1D2MPUA000 Present   PowerOn    Registered     Normal     Slave     
      10    -   ET1D2MPUA000 Present   PowerOn    Registered     Normal     Master    
      11    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA        
            1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA        
      12    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA        
            1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA        
      13    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA        
            1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA        
      14    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA        
            1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA        
      PWR1  -   -            Present   PowerOn    Registered     Normal     NA        
      PWR2  -   -            Present   PowerOn    Registered     Normal     NA        
      CMU1  -   EH1D200CMU00 Present   PowerOn    Registered     Normal     Master    
      FAN1  -   -            Present   PowerOn    Registered     Normal     NA        
      FAN2  -   -            Present   PowerOn    Registered     Normal     NA        
      FAN3  -   -            Present   PowerOn    Registered     Normal     NA        
      FAN4  -   -            Present   PowerOn    Registered     Normal     NA   

  9. S1 is changed to CSS-2 and becomes the stack standby.

    Figure 5-13  Two CSS systems merging into one

  10. Change the configurations of CSS-2 and add interfaces of CSS-2 to Eth-Trunks.

    1. Add uplink ports XGE2/4/0/1 and XGE2/4/0/2 of CSS-2 to Eth-Trunks.

      [CSS] interface eth-trunk 20
      [CSS-Eth-Trunk20] trunkport xgigabitethernet2/4/0/1
      [CSS-Eth-Trunk20] quit
      [CSS] interface eth-trunk 10
      [CSS-Eth-Trunk10] trunkport xgigabitethernet2/4/0/2
      [CSS-Eth-Trunk10] quit
      
    2. Change the configurations of devices at the core layer and access layer and bind physical ports to Eth-Trunks. The procedure is similar to the preceding procedure.

  11. Run the undo shutdown command to disable the interfaces of CSS-2 and check whether Layer 2 and Layer 3 forwarding between CSS-2 and devices at the core layer and access layer is normal. In this case, S1 and S2 have been combined into a CSS, as shown in Figure 5-14.

    Figure 5-14  Traffic forwarding after a CSS merge

Download
Updated: 2019-05-16

Document ID: EDOC1000069466

Views: 189682

Downloads: 1849

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next