No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 Series Agile Switches Typical Configuration Examples

This document provides examples for configuring features in typical usage scenarios.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an OSPF Stub Area

Example for Configuring an OSPF Stub Area

Stub Area Overview

A stub area is an area that does not allow an ABR to advertise received AS external routes. In a stub area, the routing table size and transmitted routing information volume of routers are greatly reduced. A stub area is often placed at the edge of an AS. To ensure the reachability of a destination outside the AS, the ABR in the stub area generates a default route and advertises it to the non-ABR routers in the stub area.

Assume that a device of Company H connects to the backbone area through a single link. The device has low performance and a small routing table. The area where the device resides needs to access other areas or network segments outside the OSPF area, and the next-hop address of routes of the device is the IP address of the next-hop core device of the link. Therefore, the area where the device resides does not need to learn a large number of OSPF external routes and can be configured as a stub area. This configuration can reduce the routing table size of the area and resource consumption of the device.

Configuration Notes

  • The backbone area cannot be configured as a stub area.
  • An ASBR cannot exist in a stub area. That is, external routes are not advertised in a stub area.
  • A virtual link cannot pass through a stub area.
  • To configure an area as a stub area, configure stub area attributes on all the routers in this area using the stub command.
  • To configure an area as a totally stub area, run the stub command on all the routers in this area, and run the stub no-summary command on the ABR in this area.
  • The stub no-summary command can only be configured on an ABR to prevent the ABR from advertising Type 3 LSAs within a stub area. After this command is configured on the ABR, the area becomes a totally stub area, the number of routing entries on routers in the area is reduced, and there are only intra-area routes and a default route advertised by the ABR.
  • This example applies to all versions of the S12700.

Networking Requirements

As shown in Figure 9-7, SwitchA, SwitchB, and SwitchC run OSPF, and the OSPF network is divided into Area 0 and Area 1. SwitchB functions as an ASBR to communicate with external networks. The OSPF routing table size on SwitchC needs to be reduced without affecting communication.

Figure 9-7  Networking diagram for OSPF stub area configuration

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic OSPF functions on each switch to implement interworking in the OSPF network.

  2. Configure a static route on SwitchB and import the route to the OSPF routing table to ensure that there is a reachable route from the OSPF network to external networks.

  3. Configure Area 1 as a stub area to reduce the OSPF routing table size on SwitchC.

  4. Prohibit the ABR (SwitchA) in Area 1 from advertising Type 3 LSAs within the stub area to configure Area 1 as a totally stub area. This configuration minimizes the OSPF routing table size on SwitchC.

Procedure

  1. Specify the VLANs to which interfaces belong.

    # Configure SwitchA. The configurations of SwitchB and SwitchC are similar.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet1/0/2] quit

  2. Configure an IP address for each VLANIF interface.

    # Configure SwitchA. The configurations of Switch B and SwitchC are similar.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.0.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 192.168.1.1 24
    [SwitchA-Vlanif20] quit

  3. Configure basic OSPF functions.

    # Configure SwitchA.

    [SwitchA] ospf 1 router-id 10.1.1.1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

    # Configure SwitchB.

    [SwitchB] ospf 1 router-id 10.2.2.2
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    # Configure SwitchC.

    [SwitchC] ospf 1 router-id 10.3.3.3
    [SwitchC-ospf-1] area 1
    [SwitchC-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.1] quit
    [SwitchC-ospf-1] quit

  4. Configure SwitchB to import a static route.

    [SwitchB] ip route-static 10.0.0.0 8 null 0
    [SwitchB] ospf 1
    [SwitchB-ospf-1] import-route static type 1   //SwitchB functions as an ASBR and imports external routes.
    [SwitchB-ospf-1] quit

    # Check the OSPF routing table on SwitchC. The command output shows that the OSPF routing table contains an AS external route.

    [SwitchC] display ospf routing
    
         OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type         NextHop         AdvRouter       Area
     192.168.1.0/24     1     Transit      192.168.1.2     10.3.3.3        0.0.0.1
     192.168.0.0/24     2     Inter-area   192.168.1.1     10.1.1.1        0.0.0.1
    
     Routing for ASEs
     Destination    Cost      Type       Tag         NextHop         AdvRouter
     10.0.0.0/8    3         Type1      1           192.168.1.1     10.2.2.2
    
     Total Nets: 3
     Intra Area: 1  Inter Area: 1  ASE: 1  NSSA: 0

  5. Configure Area 1 as a stub area.

    # Configure SwitchA.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] stub   //Configure Area 1 as a stub area. All the routers in Area 1 must have the stub command configured.
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

    # Configure SwitchC.

    [SwitchC] ospf 1
    [SwitchC-ospf-1] area 1
    [SwitchC-ospf-1-area-0.0.0.1] stub   //Configure Area 1 as a stub area. All the routers in Area 1 must have the stub command configured.
    [SwitchC-ospf-1-area-0.0.0.1] quit
    [SwitchC-ospf-1] quit

    # Check the OSPF routing table on SwitchC. The command output shows that the OSPF routing table does not contain the AS external route 10.0.0.0/8 but contains a default route to external networks.

    [SwitchC] display ospf routing
    
              OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.1.0/24     1     Transit    192.168.1.2     10.3.3.3         0.0.0.1
     0.0.0.0/0          2     Inter-area 192.168.1.1     10.1.1.1         0.0.0.1
     192.168.0.0/24     2     Inter-area 192.168.1.1     10.1.1.1         0.0.0.1
    
     Total Nets: 3
     Intra Area: 1  Inter Area: 2  ASE: 0  NSSA: 0

  6. Configure Area 1 as a totally stub area.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] stub no-summary   //Configure Area 1 as a totally stub area. An ABR in Area 1 must have the stub no-summary command configured, while other routers in Area 1 must have the stub command configured.
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

  7. Verify the configuration.

    # Check the OSPF routing table on SwitchC. The command output shows that the OSPF routing table contains only an intra-area OSPF route and a default route to external networks but does not contain the Inter-Area route 192.168.0.0/24.

    [SwitchC] display ospf routing
    
              OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.1.0/24     1     Transit    192.168.1.2     10.3.3.3         0.0.0.1
     0.0.0.0/0          2     Inter-area 192.168.1.1     10.1.1.1         0.0.0.1
    
     Total Nets: 2
     Intra Area: 1  Inter Area: 1  ASE: 0  NSSA: 0

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 192.168.0.1 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.1.1.1
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
      stub no-summary
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 192.168.0.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ospf 1 router-id 10.2.2.2
     import-route static type 1
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
    #
    ip route-static 10.0.0.0 255.0.0.0 NULL0
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.3.3.3
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
      stub
    #
    return
Download
Updated: 2019-05-16

Document ID: EDOC1000069466

Views: 249914

Downloads: 1982

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next