No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 Series Agile Switches Typical Configuration Examples

This document provides examples for configuring features in typical usage scenarios.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a Layer 3 Switch to Work with a Router for Internet Access

Example for Configuring a Layer 3 Switch to Work with a Router for Internet Access

Layer 3 Switch

Layer 3 switches provide the routing function, which indicates a network-layer function in the OSI model.

Layer 3 switches can work at Layer 2 and Layer 3 and be deployed at the access layer or aggregation layer as user gateways.

Configuration Notes

  • Switch configurations used in this example apply to all versions of S12700 switches.
  • This example uses router configurations of AR3600 V200R007C00SPCc00. For other router configurations, see the corresponding documentation.

Networking Requirements

In Figure 2-42, a company has multiple departments that belong to different network segments, and each department needs to access the Internet. It is required that users access the Internet through the Layer 3 switch and router and that the Layer 3 switch function as the gateway of users.

Figure 2-42  Configuring a Layer 3 switch to work with a router for Internet access

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the switch as the gateway of users to allow users to communicate across network segments through VLANIF interfaces.

  2. Configure the switch as the DHCP server to assign IP addresses to users.

  3. Configure the NAT function on the router to enable intranet users to access the Internet.

Procedure

  1. Configure the switch.

    # Configure the interfaces connected to users and corresponding VLANIF interfaces.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 2 3
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access   //Set the link type of the interface to access.
    [Switch-GigabitEthernet1/0/2] port default vlan 2   //Add the interface to VLAN 2.
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] port link-type access
    [Switch-GigabitEthernet1/0/3] port default vlan 3   
    [Switch-GigabitEthernet1/0/3] quit
    [Switch] interface vlanif 2
    [Switch-Vlanif2] ip address 192.168.1.1 24
    [Switch-Vlanif2] quit
    [Switch] interface vlanif 3
    [Switch-Vlanif3] ip address 192.168.2.1 24
    [Switch-Vlanif3] quit
    

    # Configure the interface connected to the router and corresponding VLANIF interface.

    [Switch] vlan batch 100
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 100   
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface vlanif 100
    [Switch-Vlanif100] ip address 192.168.100.2 24
    [Switch-Vlanif100] quit
    

    # Configure the default route.

    [Switch] ip route-static 0.0.0.0 0.0.0.0 192.168.100.1   //The next hop of the default route is the IP address 192.168.100.1 of the router interface.
    

    # Configure the DHCP server.

    [Switch] dhcp enable   
    [Switch] interface vlanif 2
    [Switch-Vlanif2] dhcp select interface   //DHCP uses an interface address pool to assign IP addresses to intranet users.
    [Switch-Vlanif2] dhcp server dns-list 114.114.114.114 223.5.5.5   //The configured DNS-list 114.114.114.114 is a public DNS server address, which is the same for carriers. In practice, the DNS-list address needs to be configured based on the DNS assigned to a carrier.
    [Switch-Vlanif2] quit
    [Switch] interface vlanif 3
    [Switch-Vlanif3] dhcp select interface
    [Switch-Vlanif3] dhcp server dns-list 114.114.114.114 223.5.5.5
    [Switch-Vlanif3] quit
    

  2. Configure the router.

    # Configure an IP address for the interface connected to the switch.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] interface gigabitethernet 0/0/1
    [Router-GigabitEthernet0/0/1] ip address 192.168.100.1 255.255.255.0   //Configure the IP address 192.168.100.1 as the next-hop IP address of the switch's default route.
    [Router-GigabitEthernet0/0/1] quit
    

    # Configure an IP address for the interface connected to the Internet.

    [Router] interface gigabitethernet 0/0/2
    [Router-GigabitEthernet0/0/2] ip address 200.0.0.2 255.255.255.0   //The IP address of the interface connected to the Internet is on the same network segment as the public IP address.
    [Router-GigabitEthernet0/0/2] quit
    

    # Configure a default route and a return route.

    [Router] ip route-static 0.0.0.0 0.0.0.0 200.0.0.1   //Configure a static default route with the next hop pointing to the public IP address 200.0.0.1.
    [Router] ip route-static 192.168.0.0 255.255.0.0 192.168.100.2   //Configure a return route with the next hop pointing to the IP address 192.168.100.2 of the switch's uplink interface.
    

    # Configure the NAT function to enable intranet users to access the Internet.

    [Router] acl number 2001
    [Router-acl-basic-2001] rule 5 permit source 192.168.0.0 0.0.255.255   //NAT takes effect only for source IP addresses on the network segment 192.168.0.0/16 and translates only source IP addresses of outgoing packets on GE0/0/2.
    [Router-acl-basic-2001] quit
    [Router] interface gigabitethernet 0/0/2
    [Router-GigabitEthernet0/0/2] nat outbound 2001
    [Router-GigabitEthernet0/0/2] quit
    

  3. Check the configuration.

    Configure an IP address 192.168.1.2/24 and a gateway address 192.168.1.1 for PC1, and configure an IP address 192.168.2.2/24 and a gateway address 192.168.2.1 for PC2.

    Configure an IP address 200.0.0.1/24 and a gateway address 200.0.0.2 for external network.

    After the configurations are complete, PC1 and PC2 can ping the external network IP address 200.0.0.1/24 and access the Internet.

Configuration Files

  • Switch configuration file
    #
    sysname Switch
    #
    vlan batch 2 to 3 100
    #
    dhcp enable
    #
    interface Vlanif2
     ip address 192.168.1.1 255.255.255.0
     dhcp select interface
     dhcp server dns-list 114.114.114.114 223.5.5.5
    #
    interface Vlanif3
     ip address 192.168.2.1 255.255.255.0
     dhcp select interface
     dhcp server dns-list 114.114.114.114 223.5.5.5
    #
    interface Vlanif100
     ip address 192.168.100.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 2
    #
    interface GigabitEthernet1/0/3
     port link-type access
     port default vlan 3
    #
    ip route-static 0.0.0.0 0.0.0.0 192.168.100.1
    #
    return
    
  • Router configuration file
    #
    sysname Router
    #
    acl number 2001
     rule 5 permit source 192.168.0.0 0.0.255.255
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.100.1 255.255.255.0
    #
    interface GigabitEthernet0/0/2
     ip address 200.0.0.2 255.255.255.0
     nat outbound 2001
    #
    ip route-static 0.0.0.0 0.0.0.0 200.0.0.1
    ip route-static 192.168.0.0 255.255.0.0 192.168.100.2
    #
    return
    
Download
Updated: 2019-05-16

Document ID: EDOC1000069466

Views: 249913

Downloads: 1982

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next