No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 Series Agile Switches Typical Configuration Examples

This document provides examples for configuring features in typical usage scenarios.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Radio Calibration

Example for Configuring Radio Calibration

Radio Calibration Overview

Radio calibration can dynamically adjust channels and power of APs managed by the same AC to ensure that the APs work optimally. On a WLAN, the operating status of APs is affected by the radio environment. For example, signal interference occurs if adjacent APs managed by the same AC work on overlapping channels or an AP has high power. In this case, you can configure radio calibration on the AC.

Typical application scenarios of radio calibration are as follows:
  • During AP deployment, configure radio calibration to enable APs to automatically select the optimal channels.
  • When new APs are added to a network or the network environment changes, configure radio calibration so that APs can adjust channels and power at scheduled time to work optimally.

Configuration Notes

  • For details about common WLAN configuration notes, see General Precautions for WLAN. For more deployment and configuration suggestions, see Wireless Network Deployment and Configuration Suggestions.

  • For details about radio configuration notes, see Radio Configuration Suggestion.
  • From V200R011C10, WLAN configurations are automatically delivered, without the need of running the commit all command.

  • In this example, the security policy is WPA2-PSK-AES. To ensure network security, choose an appropriate security policy according to your network configurations.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. If you set the forwarding mode to direct forwarding, you are not advised to configure the management VLAN and service VLAN to be the same.

  • In direct forwarding mode, configure port isolation on the interface directly connected to APs. If port isolation is not configured, many broadcast packets will be transmitted in the VLANs or WLAN users on different APs can directly communicate at Layer 2.

  • Configure the management VLAN and service VLAN:
    • In tunnel forwarding mode, service packets are encapsulated in a CAPWAP tunnel and forwarded to the AC. The AC then forwards the packets to the upper-layer network. Service packets and management packets can be forwarded normally only if the network between the AC and APs is added to the management VLAN and the network between the AC and upper-layer network is added to the service VLAN.
    • In direct forwarding mode, service packets are not encapsulated into a CAPWAP tunnel, but are directly forwarded to the upper-layer network. Service packets and management packets can be forwarded normally only if the network between APs and upper-layer network is added to the service VLAN and the network between the AC and APs is added to the management VLAN.
  • When configuring radio calibration, set the channel mode and power mode of an AP that needs radio calibration to auto.
  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Table 12-1 and Table 12-2 list applicable products and versions.

Networking Requirements

As shown in Figure 12-15, a large number of APs are deployed in an office building. The APs connect to the AC through Switch_A to provide wireless services for users.

Manually configuring radio parameters (such as the channel) for the APs one by one would be time-consuming. To simplify network deployment, the IT department requires that the AC automatically allocate channels to the APs based on radio environments.

Figure 12-15  Networking diagram for configuring radio calibration

Configuration Roadmap

Table 12-15  Data required for completing the configuration

Item

Data

DHCP server The AC functions as a DHCP server to assign IP addresses to APs and STAs.
IP address pool for the APs 10.23.100.2-10.23.100.254/24
IP address pool for the STAs

10.23.101.2-10.23.101.254/24

IP address of the AC's source interface VLANIF 100: 10.23.100.1/24
AP group
  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-vap, regulatory domain profile domain1, 5G radio profile radio5g, and 2G radio profile radio2g
Regulatory domain profile
  • Name: domain1
  • Country code: CN
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-vap
  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLANs in the VLAN pool
  • Referenced profiles: SSID profile wlan-ssid and security profile wlan-security
5G radio profile
  • Name: radio5g
  • Referenced profiles: RRM profile wlan-net and air scan profile wlan-airscan
2G radio profile
  • Name: radio2g
  • Referenced profiles: RRM profile wlan-net and air scan profile wlan-airscan
RRM profile Name: wlan-net
Air scan profile
  • Name: wlan-airscan
  • Air scan channel set: all channels supported by the corresponding country code of an AP
  • Air scan interval: 80000 ms
  • Air scan duration: 80 ms
The configuration roadmap is as follows:
  1. Configure the APs, AC, and upper-layer devices to communicate with each other.
  2. Configure the AC as a DHCP server to assign IP addresses to APs and STAs.
  3. Configure a VLAN pool for service VLANs.
  4. Configure the APs to go online.
    1. Create an AP group to allow for the unified configuration of multiple APs.
    2. Configure AC system parameters, including the country code and source interface.
    3. Configure the AP authentication mode and import the APs offline to allow the APs to go online.
  5. Configure WLAN service parameters for STAs to access the WLAN.
  6. Configure radio calibration so that the AC can automatically allocate the optimal working channels to the APs.

Procedure

  1. Set the NAC mode to unified mode on the AC (default setting). Configure SwitchA and the AC to allow the AP and AC to transmit CAPWAP packets.

    # Add GE0/0/1 to GE0/0/3 on SwitchA to VLAN 100 (management VLAN).

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet0/0/1] stp edged-port enable
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/2] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet0/0/2] stp edged-port enable
    [SwitchA-GigabitEthernet0/0/3] port-isolate enable
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type trunk
    [SwitchA-GigabitEthernet0/0/3] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/3] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet0/0/3] stp edged-port enable
    [SwitchA-GigabitEthernet0/0/3] port-isolate enable
    [SwitchA-GigabitEthernet0/0/3] quit
    

    # Add GE0/0/4 that connects the SwitchA to AC to VLAN 100.

    [SwitchA] interface gigabitethernet 0/0/4
    [SwitchA-GigabitEthernet0/0/4] port link-type trunk
    [SwitchA-GigabitEthernet0/0/4] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/4] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet0/0/4] quit
    

    # Add GE1/0/1 that connects the AC to SwitchA to VLAN 100.

    <HUAWEI> system-view
    [HUAWEI] sysname AC
    [AC] vlan batch 100 101
    [AC] interface gigabitethernet 1/0/1
    [AC-GigabitEthernet1/0/1] port link-type trunk
    [AC-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet1/0/1] undo port trunk allow-pass vlan 1
    [AC-GigabitEthernet1/0/1] quit
    

  2. Configure the AC to communicate with the upstream device.

    NOTE:

    Configure AC uplink interfaces to transparently transmit service VLAN packets as required and communicate with the upstream device.

    # Add AC uplink interface GE1/0/2 to service VLAN 101.

    [AC] interface gigabitethernet 1/0/2
    [AC-GigabitEthernet1/0/2] port link-type trunk
    [AC-GigabitEthernet1/0/2] port trunk allow-pass vlan 101
    [AC-GigabitEthernet1/0/2] undo port trunk allow-pass vlan 1
    [AC-GigabitEthernet1/0/2] quit
    

  3. Configure the AC as a DHCP server to allocate IP addresses to STAs and the AP.

    # Configure the AC as the DHCP server to allocate an IP address to the AP from the IP address pool on VLANIF 100, and allocate IP addresses to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AC] dhcp enable  //Enable the DHCP function.
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface  //Configure an interface-based address pool.
    [AC-Vlanif100] quit
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.23.101.1 24
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit
    

  4. Configure the AP to go online.

    # Create an AP group.

    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.

    [AC-wlan-view] regulatory-domain-profile name domain1
    [AC-wlan-regulate-domain-domain1] country-code cn
    [AC-wlan-regulate-domain-domain1] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    

    # Configure the AC's source interface.

    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to AP group ap-group1. Assume that the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is deployed from its name. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP6010DN-AGN is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    [AC-wlan-view] ap-id 1 ap-mac dcd2-fc04-b500
    [AC-wlan-ap-1] ap-name area_2
    [AC-wlan-ap-1] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-1] quit

    # After the AP is powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the AP goes online normally.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [2]
    ---------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP             Type            State STA Uptime
    ---------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.101.253  AP6010DN-AGN    nor   0   5M:2S
    1    dcd2-fc04-b500 area_2 ap-group1 10.23.101.254  AP6010DN-AGN    nor   0   5M:4S
    ---------------------------------------------------------------------------------------
    Total: 2

  5. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-security
    [AC-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes  //Configure security policy WPA2+PSK+AES.
    [AC-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AC-wlan-view] ssid-profile name wlan-ssid
    [AC-wlan-ssid-prof-wlan-ssid] ssid wlan-net  //Set the SSID to wlan-net.
    [AC-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profile wlan-vap, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AC-wlan-view] vap-profile name wlan-vap
    [AC-wlan-vap-prof-wlan-vap] forward-mode tunnel  //Set the service forwarding mode to tunnel.
    [AC-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101  //Set the VLAN ID to 101. By default, the VLAN ID is 1.
    [AC-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AC-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AC-wlan-vap-prof-wlan-vap] quit
    

    # Bind VAP profile wlan-vap to the AP group and apply the profile to radio 0 and radio 1 of the AP.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  6. Configure radio calibration.

    # Create the RRM profile wlan-net and enable automatic channel selection and automatic transmit power selection in the RRM profile. By default, automatic channel selection and automatic transmit power selection are enabled.

    [AC-wlan-view] rrm-profile name wlan-net
    [AC-wlan-rrm-prof-wlan-net] undo calibrate auto-channel-select disable 
    [AC-wlan-rrm-prof-wlan-net] undo calibrate auto-txpower-select disable
    [AC-wlan-rrm-prof-wlan-net] quit

    # Create the air scan profile wlan-airscan and configure the scan channel set, scan interval, and scan duration. By default, an air scan channel set contains all channels supported by the corresponding country code of an AP.

    [AC-wlan-view] air-scan-profile name wlan-airscan
    [AC-wlan-air-scan-prof-wlan-airscan] scan-channel-set country-channel
    [AC-wlan-air-scan-prof-wlan-airscan] scan-period 80
    [AC-wlan-air-scan-prof-wlan-airscan] scan-interval 80000
    [AC-wlan-air-scan-prof-wlan-airscan] quit

    # Create the 2G radio profile radio2g and bind the RRM profile wlan-net and air scan profile wlan-airscan to the 2G radio profile.

    [AC-wlan-view] radio-2g-profile name radio2g 
    [AC-wlan-radio-2g-prof-radio2g] rrm-profile wlan-net
    [AC-wlan-radio-2g-prof-radio2g] air-scan-profile wlan-airscan
    [AC-wlan-radio-2g-prof-radio2g] quit

    # Create the 5G radio profile radio5g and bind the RRM profile wlan-net and air scan profile wlan-airscan to the 5G radio profile.

    [AC-wlan-view] radio-5g-profile name radio5g 
    [AC-wlan-radio-5g-prof-radio5g] rrm-profile wlan-net
    [AC-wlan-radio-5g-prof-radio5g] air-scan-profile wlan-airscan
    [AC-wlan-radio-5g-prof-radio5g] quit

    # Bind the 5G radio profile radio5g and 2G radio profile radio2g to the AP group ap-group1.

    [AC-wlan-view] ap-group name ap-group1 
    [AC-wlan-ap-group-ap-group1] radio-5g-profile radio5g
    [AC-wlan-ap-group-ap-group1] radio-2g-profile radio2g
    [AC-wlan-ap-group-ap-group1] quit

    # Set the radio calibration mode to manual and trigger radio calibration. By default, the radio calibration mode is manual.

    [AC-wlan-view] calibrate enable manual
    [AC-wlan-view] calibrate manual startup

  7. Commit the configuration.

    [AC-wlan-view] commit all
    Warning: Committing configuration may cause service interruption, continue?[Y/N]:y

  8. Verify the configuration.

    • Connect STAs to the WLAN with SSID wlan-net and enter the password a1234567. Run the display station ssid wlan-net command on the AC. The command output shows that the STAs are connected to the WLAN wlan-net.

      [AC-wlan-view] display station ssid wlan-net
      Rf/WLAN: Radio ID/WLAN ID                                                     
      Rx/Tx: link receive rate/link transmit rate(Mbps)                             
      ----------------------------------------------------------------------------------------
      STA MAC          AP ID Ap name  Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address     
      ----------------------------------------------------------------------------------------
      e019-1dc7-1e08   0     area_1   0/1      2.4G  11n   65/38      -29   101   10.23.101.253
      b878-2eb4-2689   1     area_2   0/1      2.4G  11n   78/43      -33   101   10.23.101.254
      ----------------------------------------------------------------------------------------
      Total: 2 2.4G: 2 5G: 0
    • # Run the display radio all command on the AC to check radio calibration results.

      [AC-wlan-view] display radio all
      CH/BW:Channel/Bandwidth
      CE:Current EIRP (dBm)
      ME:Max EIRP (dBm)
      CU:Channel utilization
      ST:Status
      ----------------------------------------------------------------------
      AP ID Name    RfID  Band  Type    ST      CH/BW    CE/ME   STA      CU
      ----------------------------------------------------------------------
      1     area_2  0     2.4G  bgn     on      1/20M    28/28   1        10%
      1     area_2  1     5G    an      on      149/20M  29/29   0        15%
      0     area_1  0     2.4G  bgn     on      6/20M    28/28   1        15%
      0     area_1  1     5G    an      on      153/20M  29/29   0        49%
      ----------------------------------------------------------------------
      Total:4
    • # Radio calibration stops half an hour after the radio calibration is manually triggered. (The following configuration steps are not provided in the configuration file.) After that, you can perform either of the following configurations:
      • (Recommended) Set the radio calibration mode to scheduled. Configure the APs to perform radio calibration in off-peak hours, for example, between 00:00 am and 06:00 am.

        [AC-wlan-view] calibrate enable schedule time 03:00:00 
        [AC-wlan-view] commit all
        Warning: Committing configuration may cause service interruption, continue?[Y/N]:y
      • Manually fix the working channels of APs: disable automatic channel selection and automatic transmit power selection in the RRM profile. Manually trigger radio calibration when new APs are added to the network.

        [AC-wlan-view] rrm-profile name wlan-net
        [AC-wlan-rrm-prof-wlan-net] calibrate auto-channel-select disable 
        [AC-wlan-rrm-prof-wlan-net] calibrate auto-txpower-select disable
        [AC-wlan-rrm-prof-wlan-net] quit
        [AC-wlan-view] calibrate enable manual
        [AC-wlan-view] calibrate manual startup
        [AC-wlan-view] commit all
        Warning: Committing configuration may cause service interruption, continue?[Y/N]:y

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface gigabitethernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
     stp edged-port enable
     port-isolate enable group 1
    #
    interface gigabitethernet0/0/2
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
     stp edged-port enable
     port-isolate enable group 1
    #
    interface gigabitethernet0/0/3
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
     stp edged-port enable
     port-isolate enable group 1
    #
    interface gigabitethernet0/0/4
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    return
  • AC configuration file

    #
    sysname AC
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 101
    #
    capwap source interface vlanif100
    #
    wlan
     calibrate enable schedule time 03:00:00
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      forward-mode tunnel
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
     regulatory-domain-profile name domain1
     air-scan-profile name wlan-airscan
      scan-period 80
      scan-interval 80000 
     rrm-profile name wlan-net
     radio-2g-profile name radio2g
      rrm-profile wlan-net
      air-scan-profile wlan-airscan 
     radio-5g-profile name radio5g
      rrm-profile wlan-net
      air-scan-profile wlan-airscan 
     ap-group name ap-group1
      regulatory-domain-profile domain1
      radio 0
       radio-2g-profile radio2g 
       radio-5g-profile radio5g 
       vap-profile wlan-vap wlan 1
      radio 1
       radio-5g-profile radio5g 
       vap-profile wlan-vap wlan 1
     ap-id 0 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
     ap-id 1 type-id 21 ap-mac dcd2-fc04-b500 ap-sn 210235554710CB000078
      ap-name area_2
      ap-group ap-group1
    #
    return
Download
Updated: 2019-05-16

Document ID: EDOC1000069466

Views: 190209

Downloads: 1849

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next