No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S2700, S3700, S5700, S6700, S7700, and S9700 Series Switches Typical Configuration Examples

This document provides examples for configuring features in typical usage scenarios.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an OSPF NSSA

Example for Configuring an OSPF NSSA

NSSA Overview

An NSSA is a special type of OSPF area. It is similar to a stub area in that neither of them transmits routes learned from other areas in the AS they reside. The difference is that an NSSA allows AS external routes to be imported and advertised in the entire AS whereas a stub area does not. To ensure the reachability of AS external routes, the ABR in an NSSA generates a default route and advertises the route to the other routers in the NSSA.

An NSSA allows Type 7 LSAs (NSSA External LSAs) to be advertised. Type 7 LSAs are generated by the ASBR of the NSSA. When reaching the ABR of the NSSA, these LSAs can be translated into Type 5 LSAs (AS External LSAs) and advertised to other areas.

Assume that a device of Company H connects to the backbone area through a single link. The device has low performance and a small routing table. The company wants to configure the area where the device resides as a stub area to reduce the routing table size and system resource consumption of the device. In addition, AS external routes need to be imported and advertised to the entire AS. However, a stub area cannot meet this requirement because it does not allow received AS external routes to be advertised. Therefore, the area needs to be configured as an NSSA.

Configuration Notes

  • The backbone area cannot be configured as an NSSA.
  • To configure an area as an NSSA, configure NSSA attributes on all the routers in this area.
  • A virtual link cannot pass through an NSSA.
  • To reduce the number of LSAs that are transmitted to the NSSA, configure no-summary on an ABR. This prevents the ABR from transmitting Type 3 LSAs to the NSSA, making the area a totally NSSA.
  • For the fixed switch models and versions that support this example, see Applicable Products and Versions.

Networking Requirements

As shown in Figure 9-8, SwitchA, SwitchB, SwitchC, and SwitchD run OSPF, and the OSPF network is divided into Area 0 and Area 1. Devices in Area 1 need to be prohibited from receiving external routes imported from other areas and to communicate with external networks using the external routes imported by the ASBR in Area 1. SwitchB transmits many services, so SwitchA needs to translate Type 7 LSAs into Type 5 LSAs and send the LSAs to other OSPF areas.

NOTE:

In this scenario, ensure that all connected interfaces have STP disabled. If STP is enabled and VLANIF interfaces of switches are used to construct a Layer 3 ring network, an interface on the network will be blocked. As a result, Layer 3 services on the network cannot run normally.

Figure 9-8  Networking diagram for OSPF NSSA configuration

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic OSPF functions on each switch to implement interworking in the OSPF network.

  2. Configure Area 1 as an NSSA, configure a static route on SwitchD, and configure SwitchD to import the static route into the OSPF routing table so that switches in Area 1 can communicate with external networks only through SwitchD.

  3. Configure SwitchA as an LSA translator to translate Type 7 LSAs into Type 5 LSAs and send the LSAs to other OSPF areas.

Procedure

  1. Specify the VLANs to which interfaces belong.

    # Configure SwitchA. The configurations of SwitchB, SwitchC, and SwitchD are similar.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 30
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 30
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/2] quit

  2. Configure an IP address for each VLANIF interface.

    # Configure SwitchA. The configurations of SwitchB, SwitchC, and SwitchD are similar.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.1.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 30
    [SwitchA-Vlanif30] ip address 192.168.3.1 24
    [SwitchA-Vlanif30] quit

  3. Configure basic OSPF functions.

    # Configure SwitchA.

    [SwitchA] ospf 1 router-id 10.1.1.1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] network 192.168.3.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

    # Configure SwitchB.

    [SwitchB] ospf 1 router-id 10.2.2.2
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] area 1
    [SwitchB-ospf-1-area-0.0.0.1] network 192.168.4.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.1] quit
    [SwitchB-ospf-1] quit

    # Configure SwitchC.

    [SwitchC] ospf 1 router-id 10.3.3.3
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

    # Configure SwitchD.

    [SwitchD] ospf 1 router-id 10.4.4.4
    [SwitchD-ospf-1] area 1
    [SwitchD-ospf-1-area-0.0.0.1] network 192.168.3.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.1] network 192.168.4.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.1] quit
    [SwitchD-ospf-1] quit

  4. Configure Area 1 as an NSSA.

    # Configure SwitchA.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] nssa   //Configure Area 1 as an NSSA. All the devices in Area 1 must have the nssa command configured.
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

    # Configure SwitchB.

    [SwitchB] ospf 1
    [SwitchB-ospf-1] area 1
    [SwitchB-ospf-1-area-0.0.0.1] nssa   //Configure Area 1 as an NSSA. All the devices in Area 1 must have the nssa command configured.
    [SwitchB-ospf-1-area-0.0.0.1] quit
    [SwitchB-ospf-1] quit

    # Configure SwitchD.

    [SwitchD] ospf 1
    [SwitchD-ospf-1] area 1
    [SwitchD-ospf-1-area-0.0.0.1] nssa   //Configure Area 1 as an NSSA. All the devices in Area 1 must have the nssa command configured.
    [SwitchD-ospf-1-area-0.0.0.1] quit
    [SwitchD-ospf-1] quit

  5. Configure SwitchD to import a static route.

    [SwitchD] ip route-static 172.16.0.0 16 null 0
    [SwitchD] ospf 1
    [SwitchD-ospf-1] import-route static   //Configure SwitchD to function as an ASBR of the NSSA to import external routes.
    [SwitchD-ospf-1] quit

    # Check the OSPF routing table on SwitchC.

    [SwitchC] display ospf routing
    
              OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.1.0/24     1     Transit    192.168.1.2     10.3.3.3       0.0.0.0
     192.168.2.0/24     1     Transit    192.168.2.2     10.3.3.3       0.0.0.0
     192.168.3.0/24     2     Inter-area 192.168.1.1     10.1.1.1       0.0.0.0
     192.168.4.0/24     2     Inter-area 192.168.2.1     10.2.2.2       0.0.0.0
     Routing for ASEs
     Destination        Cost      Type       Tag    NextHop         AdvRouter
     172.16.0.0/16       1         Type2       1     192.168.1.1     10.2.2.2
    
     Total Nets: 5
     Intra Area: 2  Inter Area: 2  ASE: 1  NSSA: 0

    The command output shows that the AS external routes imported into the NSSA are advertised by SwitchB to other areas. That is, SwitchB translates Type 7 LSAs into Type 5 LSAs. This is because OSPF selects the ABR with a larger router ID as an LSA translator.

  6. Configure SwitchA as an LSA translator.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] nssa translator-always
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

  7. Verify the configuration.

    # Wait for 40 seconds and then check the OSPF routing table on SwitchC.

    [SwitchC] display ospf routing
    
              OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.1.0/24     1     Transit    192.168.1.2     10.3.3.3       0.0.0.0
     192.168.2.0/24     1     Transit    192.168.2.2     10.3.3.3       0.0.0.0
     192.168.3.0/24     2     Inter-area 192.168.1.1     10.1.1.1       0.0.0.0
     192.168.4.0/24     2     Inter-area 192.168.2.1     10.2.2.2       0.0.0.0
     Routing for ASEs
     Destination        Cost      Type       Tag    NextHop         AdvRouter
     172.16.0.0/16       1         Type2       1     192.168.1.1     10.1.1.1
    
     Total Nets: 5
     Intra Area: 2  Inter Area: 2  ASE: 1  NSSA: 0

    The command output shows that the AS external routes imported into the NSSA are advertised by SwitchA to other areas. That is, SwitchA translates Type 7 LSAs into Type 5 LSAs.

    NOTE:

    By default, the new LSA translator works with the previous LSA translator to translate LSAs for 40 seconds. After 40 seconds, only the new LSA translator translates LSAs.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 30
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface Vlanif30
     ip address 192.168.3.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ospf 1 router-id 10.1.1.1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
     area 0.0.0.1
      network 192.168.3.0 0.0.0.255
      nssa translator-always
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 20 40
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.4.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.2.2.2
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
     area 0.0.0.1
      network 192.168.4.0 0.0.0.255
      nssa
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.2.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.3.3.3
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    vlan batch 30 40
    #
    interface Vlanif30
     ip address 192.168.3.2 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.4.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1 router-id 10.4.4.4
     import-route static
     area 0.0.0.1
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      nssa
    #
    ip route-static 172.16.0.0 255.255.0.0 NULL0
    #
    return

Applicable Products and Versions

Table 9-4  Applicable product models and versions

Product

Product Model

Software Version

S2700

S2720EI

V200R011C10, V200R012C00, V200R013C00

S3700

S3700EI

V100R006C05

S3700HI

V200R001C00

S5700

S5700EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02&C03)

S5710EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5720EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S5720SI and S5720S-SI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S5720I-SI

V200R012C00, V200R013C00

S5730SI

V200R011C10, V200R012C00, V200R013C00

S5730S-EI

V200R011C10, V200R012C00, V200R013C00

S5720LI and S5720S-LI

V200R010C00, V200R011C00, V200R011C10, V200R012(C00&C20), V200R013C00

S5700HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00SPC500&C01&C02)

S5710HI

V200R003C00, V200R005(C00&C02&C03)

S5720HI

V200R006C00, V200R007(C00&C10), V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S5730HI

V200R012C00, V200R013C00

S6700

S6700EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6720EI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720S-EI

V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720SI, S6720S-SI

V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720LI, S6720S-LI

V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720HI

V200R012C00, V200R013C00

S7700

S7703, S7706, and S7712

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005C00, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00, V200R013C00

S7703 PoE

V200R013C00

S7706 PoE

V200R013C00

S9700

S9703, S9706, and S9712

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005C00, V200R006C00, V200R007(C00&C10), V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00, V200R013C00

NOTE:
For details about software mappings, visit Hardware Query Tool and search for the desired product model.
Download
Updated: 2019-04-20

Document ID: EDOC1000069520

Views: 662941

Downloads: 29849

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next