No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S2700, S3700, S5700, S6700, S7700, and S9700 Series Switches Typical Configuration Examples

This document provides examples for configuring features in typical usage scenarios.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Rate Limiting in a Specified Time Range

Example for Configuring Rate Limiting in a Specified Time Range

Overview

An ACL contains various matching conditions. You can configure a time range and reference it in ACL rules on the device. This allows the device to match packets based on the time range, and the administrator can apply different policies to packets at different time ranges.

In this example, a basic ACL defines a time range and the basic ACL is referenced by the traffic policy module to limit Internet access rate during the specified time range.

Configuration Notes

For applicable product models and versions, see Applicable Product Models and Versions.

NOTE:
For details about software mappings, visit Hardware Query Tool and search for the desired product model.

Networking Requirements

In Figure 16-5, users connect to external network devices through GE2/0/1 of the switch.

During work hours from 8:30 to 18:00, the Internet access rate of employees needs to be limited to 4 Mbit/s.

Figure 16-5  Networking for configuring rate limiting in a specified time range

Configuration Roadmap

The traffic policy based on the time range is used to implement rate limiting. The configuration roadmap is as follows:
  1. Configure interfaces so that users can access the Internet through the Switch.
  2. Configure a time range and reference the time range in an ACL.
  3. Configure an ACL to match traffic passing the device in the specified time range.
  4. Configure a traffic policy to limit the rate of packets matching ACL rules.
  5. Apply the traffic policy to GE1/0/1 in the inbound direction.

Procedure

  1. Create a VLAN and configure interfaces.

    # Create VLAN 10 on the Switch.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit

    # Configure GE1/0/1 and GE2/0/1 on the Switch as trunk interfaces and add them to VLAN 10.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet2/0/1] quit
    NOTE:

    Configure the interface of the LSW connected to the Switch as a trunk interface and add it to VLAN 10.

    # Create VLANIF 10 and set its IP address to 192.168.1.1/24.

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 192.168.1.1 24
    [Switch-Vlanif10] quit
    NOTE:

    On the router, set the IP address of the interface connected to the Switch to 192.168.1.2/24, and configure a sub-interface on the interface to terminate the VLAN.

  2. Create a periodic time range working_time that defines work hours from 8:30 to 18:00.

    [Switch] time-range working_time 08:30 to 18:00 working-day  //Define the work hours.
    

  3. Configure ACL 2001 and define three rules to limit the bandwidth of packets from 192.168.1.10, 192.168.1.11, and 192.168.1.12 during work hours.

    [Switch] acl number 2001
    [Switch-acl-basic-2001] rule permit source 192.168.1.10 0 time-range working_time  //Limit the rate of packets from 192.168.1.10 at work hours.
    [Switch-acl-basic-2001] rule permit source 192.168.1.11 0 time-range working_time  //Limit the rate of packets from 192.168.1.11 at work hours.
    [Switch-acl-basic-2001] rule permit source 192.168.1.12 0 time-range working_time  //Limit the rate of packets from 192.168.1.12 at work hours.
    [Switch-acl-basic-2001] quit

  4. Reference ACL 2001 in a traffic classifier to classify packets.

    [Switch] traffic classifier c1
    [Switch-classifier-c1] if-match acl 2001
    [Switch-classifier-c1] quit

  5. Configure a traffic behavior to set the rate limit to 4 Mbit/s.

    [Switch] traffic behavior b1
    [Switch-behavior-b1] car cir 4096  //Limit the Internet access rate to 4 Mbit/s at work hours.
    [Switch-behavior-b1] statistic enable
    [Switch-behavior-b1] quit

  6. Configure a traffic policy and apply the traffic policy to GE1/0/1 in the inbound direction.

    [Switch] traffic policy p1
    [Switch-trafficpolicy-p1] classifier c1 behavior b1
    [Switch-trafficpolicy-p1] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] traffic-policy p1 inbound
    [Switch-GigabitEthernet1/0/1] quit

  7. Verify the configuration.

    # Check the traffic classifier configuration.

    [Switch] display traffic classifier user-defined c1
      User Defined Classifier Information:                                          
       Classifier: c1                                                               
        Precedence: 5                                                               
        Operator: OR                                                                
        Rule(s) : if-match acl 2001  

    # Check the traffic policy configuration.

    [Switch] display traffic policy user-defined p1
      User Defined Traffic Policy Information:                                      
      Policy: p1                                                                    
       Classifier: c1                                                               
        Operator: OR                                                                
         Behavior: b1                                                               
          Permit                                                                    
          Committed Access Rate:                                                    
            CIR 4096 (Kbps), PIR 4096 (Kbps), CBS 770048 (byte), PBS 1282048 (byte) 
            Color Mode: color Blind                                                 
            Conform Action: pass                                                    
            Yellow  Action: pass                                                    
            Exceed  Action: discard 
          Statistic: enable

    # Check the traffic policy that is applied to the interface. During work hours, when the rate of packets from each network segment on GE1/0/1 in the inbound direction is larger than 4 Mbit/s, packet loss occurs. The rate of packets from each network segment is limited within 4 Mbit/s.

    [Switch] display traffic policy statistics interface gigabitethernet 1/0/1 inbound
    
     Interface:  GigabitEthernet1/0/1
     Traffic policy inbound: p1
     Rule number: 3
     Current status: success
     Statistics interval: 300   
    ---------------------------------------------------------------------
     Board : 1
    ---------------------------------------------------------------------
     Matched          |      Packets:                        38,761
                      |      Bytes:                               -
                      |      Rate(pps):                           0
                      |      Rate(bps):                           -
    ---------------------------------------------------------------------
       Passed         |      Packets:                        25,534
                      |      Bytes:                               -
                      |      Rate(pps):                           0
                      |      Rate(bps):                           -
    ---------------------------------------------------------------------
       Dropped        |      Packets:                        13,227
                      |      Bytes:                               -
                      |      Rate(pps):                           0
                      |      Rate(bps):                           -
    ---------------------------------------------------------------------
         Filter       |      Packets:                             0
                      |      Bytes:                               -
    --------------------------------------------------------------------- 
         Car          |      Packets:                        13,227
                      |      Bytes:                               -
    ---------------------------------------------------------------------
    

Configuration Files

Switch configuration file

#
sysname Switch
#
vlan batch 10
#
time-range working_time 08:30 to 18:00 working-day     
#
acl number 2001  
 rule 5 permit source 192.168.1.10 0 time-range working_time
 rule 10 permit source 192.168.1.11 0 time-range working_time
 rule 15 permit source 192.168.1.12 0 time-range working_time
#
traffic classifier c1 operator or precedence 5
 if-match acl 2001
#
traffic behavior b1
 permit
 car cir 4096 pir 4096 cbs 770048 pbs 1282048 mode color-blind green pass yellow pass red discard
 statistic enable
#
traffic policy p1 match-order config
 classifier c1 behavior b1
#
interface Vlanif10                                                              
 ip address 192.168.1.1 255.255.255.0                                           
#                                                                               
interface GigabitEthernet1/0/1
 port link-type trunk
 port trunk allow-pass vlan 10
 traffic-policy p1 inbound
#                                                                               
interface GigabitEthernet2/0/1
 port link-type trunk                                                           
 port trunk allow-pass vlan 10                                                  
#
return

Applicable Product Models and Versions

Table 16-5  Applicable product models and versions

Product

Product Model

Software Version

S2700

S2752EI

V100R006C05

S2710SI

V100R006C05

S2720EI

V200R006C10, V200R009C00, V200R010C00, V200R011C10, V200R012C00, V200R013C00

S2750EI

V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S3700

S3700SI and S3700EI

V100R006C05

S3700HI

V200R001C00

S5700

S5700LI

V200R001C00, V200R002C00, V200R003(C00&C02&C10), V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S5700S-LI

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S5700SI

V200R001C00, V200R002C00, V200R003C00, V200R005C00

S5700EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02&C03)

S5700HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00SPC500&C01&C02)

S5710-C-LI

V200R001C00

S5710-X-LI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S5710EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5710HI

V200R003C00, V200R005(C00&C02&C03)

S5720LI and S5720S-LI

V200R010C00, V200R011C00, V200R011C10, V200R012(C00&C20), V200R013C00

S5720SI and S5720S-SI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S5720I-SI

V200R012C00, V200R013C00

S5720EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S5720HI

V200R006C00, V200R007(C00&C10), V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S5730HI

V200R012C00, V200R013C00

S5730SI

V200R011C10, V200R012C00, V200R013C00

S5730S-EI

V200R011C10, V200R012C00, V200R013C00

S6700

S6700EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6720LI and S6720S-LI

V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720SI and S6720S-SI

V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720EI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720S-EI

V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720HI

V200R012C00, V200R013C00

S7700

S7703, S7706, and S7712

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005C00, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00, V200R013C00

S7703 PoE

V200R013C00

S7706 PoE

V200R013C00

S9700

S9703, S9706, and S9712

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005C00, V200R006C00, V200R007(C00&C10), V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00, V200R013C00

Download
Updated: 2019-04-20

Document ID: EDOC1000069520

Views: 664932

Downloads: 29863

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next