No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S2700, S3700, S5700, S6700, S7700, and S9700 Series Switches Typical Configuration Examples

This document provides examples for configuring features in typical usage scenarios.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Files

Configuration Files

Core_SPE1 Configuration File

sysname Core_SPE1
#
router id 172.16.0.5
#
stp disable
#
ip vpn-instance vpna
 ipv4-family
  route-distinguisher 5:1
  tnl-policy TSel
  vpn-target 0:1 export-extcommunity
  vpn-target 0:1 import-extcommunity
#
tunnel-selector TSel permit node 9
 if-match ip next-hop ip-prefix core_nhp
#
tunnel-selector TSel permit node 10
 apply tunnel-policy TE
#
bfd
#
mpls lsr-id 172.16.0.5
mpls
 mpls te
 label advertise non-null
 mpls rsvp-te
 mpls rsvp-te hello
 mpls rsvp-te hello full-gr
 mpls te cspf
#
mpls ldp
 graceful-restart
#
load-balance-profile CUSTOM
 ipv6 field l4-sport l4-dport
 ipv4 field l4-sport l4-dport
#
interface Eth-Trunk4
 undo portswitch
 description Core_SPE1 to Core_SPE2
 ip address 172.17.4.8 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group c
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
 least active-linknumber 4
 load-balance enhanced profile CUSTOM
#
interface Eth-Trunk5
 undo portswitch
 description Core_SPE1 to Core_SPE3
 ip address 172.17.4.2 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 30
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
 least active-linknumber 4
 load-balance enhanced profile CUSTOM
#
interface Eth-Trunk17
 undo portswitch
 description Core_SPE1 to Site1_UPE1
 ip address 172.17.4.10 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 4
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
 least active-linknumber 4
 load-balance enhanced profile CUSTOM
#
interface XGigabitEthernet1/0/0
 eth-trunk 5
#
interface XGigabitEthernet1/0/1
 eth-trunk 5
#
interface XGigabitEthernet1/0/2
 eth-trunk 5
#
interface XGigabitEthernet1/0/3
 eth-trunk 5
#
interface XGigabitEthernet5/0/4
 eth-trunk 4
#
interface XGigabitEthernet5/0/5
 eth-trunk 4
#
interface XGigabitEthernet5/0/6
 eth-trunk 4
#
interface XGigabitEthernet5/0/7
 eth-trunk 4
#
interface XGigabitEthernet6/0/0
 eth-trunk 17
#
interface XGigabitEthernet6/0/1
 eth-trunk 17
#
interface XGigabitEthernet6/0/2
 eth-trunk 17
#
interface XGigabitEthernet6/0/3
 eth-trunk 17
#
interface XGigabitEthernet6/0/4
 undo portswitch
 description Core_SPE1 to Site3_UPE6
 ip address 172.17.10.2 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 20
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
#
interface LoopBack1
 description ** GRT Management Loopback **
 ip address 172.16.0.5 255.255.255.255
#
interface Tunnel611
 description Core_SPE1 to Site1_UPE1
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.2.51
 mpls te tunnel-id 71
 mpls te record-route
 mpls te affinity property 4 mask 4
 mpls te affinity property 8 mask 8 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel622
 description Core_SPE1 to Site1_UPE2
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.2.50
 mpls te tunnel-id 82
 mpls te record-route
 mpls te affinity property 8 mask 8
 mpls te affinity property 4 mask 4 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel711
 description Core_SPE1 to Site3_UPE6
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.2.86
 mpls te tunnel-id 311
 mpls te record-route
 mpls te affinity property 20 mask 20
 mpls te affinity property 10 mask 10 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel721
 description Core_SPE1 to Site3_UPE5
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.2.87
 mpls te tunnel-id 312
 mpls te record-route
 mpls te affinity property 10 mask 10
 mpls te affinity property 20 mask 20 secondary
 mpls te backup hot-standby 
 mpls te commit
#
bgp 65000
 graceful-restart
 group devCore internal
 peer devCore connect-interface LoopBack1
 peer 172.16.0.3 as-number 65000
 peer 172.16.0.3 group devCore
 peer 172.16.0.4 as-number 65000
 peer 172.16.0.4 group devCore
 group devHost internal
 peer devHost connect-interface LoopBack1
 peer 172.16.2.50 as-number 65000
 peer 172.16.2.50 group devHost
 peer 172.16.2.51 as-number 65000
 peer 172.16.2.51 group devHost
 peer 172.16.2.86 as-number 65000
 peer 172.16.2.86 group devHost
 peer 172.16.2.87 as-number 65000
 peer 172.16.2.87 group devHost
 #
 ipv4-family unicast
  undo synchronization
  undo peer devCore enable
  undo peer devHost enable
  undo peer 172.16.2.50 enable
  undo peer 172.16.2.51 enable
  undo peer 172.16.0.3 enable
  undo peer 172.16.0.4 enable
  undo peer 172.16.2.86 enable
  undo peer 172.16.2.87 enable
 #
 ipv4-family vpnv4
  policy vpn-target
  auto-frr
  nexthop recursive-lookup delay 10
  tunnel-selector TSel
  bestroute nexthop-resolved tunnel
  route-select delay 120
  peer devCore enable
  peer devCore route-policy core-import import
  peer devCore advertise-community
  peer 172.16.0.3 enable
  peer 172.16.0.3 group devCore
  peer 172.16.0.4 enable
  peer 172.16.0.4 group devCore
  peer devHost enable
  peer devHost route-policy p_iBGP_RR_in import
  peer devHost advertise-community
  peer devHost upe
  peer devHost default-originate vpn-instance vpna
  peer 172.16.2.50 enable
  peer 172.16.2.50 group devHost
  peer 172.16.2.51 enable
  peer 172.16.2.51 group devHost
  peer 172.16.2.86 enable
  peer 172.16.2.86 group devHost
  peer 172.16.2.87 enable
  peer 172.16.2.87 group devHost
 #
 ipv4-family vpn-instance vpna
  default-route imported
  auto-frr
  nexthop recursive-lookup route-policy delay_policy
  nexthop recursive-lookup delay 10
  vpn-route cross multipath
  route-select delay 120
#
ospf 1
 silent-interface all
 undo silent-interface Eth-Trunk4
 undo silent-interface Eth-Trunk5
 undo silent-interface Eth-Trunk17
 undo silent-interface XGigabitEthernet6/0/4
 spf-schedule-interval millisecond 10
 lsa-originate-interval 0
 lsa-arrival-interval 0
 opaque-capability enable
 graceful-restart period 600
 flooding-control
 area 0.0.0.0
  authentication-mode md5 1 cipher %^%#NInJJ<oF9VXb:BS~~9+JT'suROXkVHNG@8+*3FyB%^%#
  network 172.16.0.5 0.0.0.0
  network 172.17.4.2 0.0.0.0
  network 172.17.4.8 0.0.0.0
  network 172.17.4.10 0.0.0.0
  network 172.17.10.2 0.0.0.0
  mpls-te enable
#
route-policy delay_policy permit node 0
 if-match community-filter all_site
#
route-policy p_iBGP_RR_in deny node 5
 if-match ip-prefix deny_host
 if-match community-filter all_site
#
route-policy p_iBGP_RR_in permit node 11
 if-match community-filter site1
 apply preferred-value 300
#
route-policy p_iBGP_RR_in permit node 12
 if-match community-filter site2
 apply preferred-value 200
#
route-policy p_iBGP_RR_in permit node 13
 if-match community-filter site3
 apply preferred-value 200
#
route-policy p_iBGP_RR_in permit node 20
#
route-policy core-import deny node 5
 if-match community-filter site12
#
route-policy core-import deny node 6
 if-match community-filter site13
#
route-policy core-import permit node 10
#
ip ip-prefix deny_host index 10 permit 0.0.0.0 0 greater-equal 32 less-equal 32
ip ip-prefix core_nhp index 10 permit 172.16.0.3 32
ip ip-prefix core_nhp index 20 permit 172.16.0.4 32
#
ip community-filter basic site1 permit 100:100
ip community-filter basic site2 permit 200:200
ip community-filter basic site3 permit 300:300
ip community-filter basic all_site permit 5720:5720
ip community-filter basic site12 permit 12:12
ip community-filter basic site13 permit 13:13
#
tunnel-policy TSel
 tunnel select-seq cr-lsp lsp load-balance-number 1
#
tunnel-policy TE
 tunnel select-seq cr-lsp load-balance-number 1
#
bfd SPE1toSPE2 bind ldp-lsp peer-ip 172.16.0.3 nexthop 172.17.4.9 interface Eth-Trunk4
 discriminator local 317
 discriminator remote 137
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE1toSPE3 bind ldp-lsp peer-ip 172.16.0.4 nexthop 172.17.4.3 interface Eth-Trunk5
 discriminator local 32
 discriminator remote 23
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE1toUPE1_b bind mpls-te interface Tunnel611 te-lsp backup
 discriminator local 6116
 discriminator remote 6115
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE1toUPE1_m bind mpls-te interface Tunnel611 te-lsp
 discriminator local 6112
 discriminator remote 6111
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE1toUPE2_b bind mpls-te interface Tunnel622 te-lsp backup
 discriminator local 6226
 discriminator remote 6225
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE1toUPE2_m bind mpls-te interface Tunnel622 te-lsp
 discriminator local 6222
 discriminator remote 6221
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE1toUPE5_b bind mpls-te interface Tunnel721 te-lsp backup
 discriminator local 7216
 discriminator remote 7215
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE1toUPE5_m bind mpls-te interface Tunnel721 te-lsp
 discriminator local 7212
 discriminator remote 7211
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE1toUPE6_b bind mpls-te interface Tunnel711 te-lsp backup
 discriminator local 7116
 discriminator remote 7115
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE1toUPE6_m bind mpls-te interface Tunnel711 te-lsp
 discriminator local 7112
 discriminator remote 7111
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
return

Core_SPE2 Configuration File

sysname Core_SPE2
#
router id 172.16.0.3
#
stp disable
#
ip vpn-instance vpna
 ipv4-family
  route-distinguisher 3:1
  tnl-policy TSel
  vpn-target 0:1 export-extcommunity
  vpn-target 0:1 import-extcommunity
#
tunnel-selector TSel permit node 9
 if-match ip next-hop ip-prefix core_nhp
#
tunnel-selector TSel permit node 10
 apply tunnel-policy TE
#
bfd
#
mpls lsr-id 172.16.0.3
mpls
 mpls te
 label advertise non-null
 mpls rsvp-te
 mpls rsvp-te hello
 mpls rsvp-te hello full-gr
 mpls te cspf
#
mpls ldp
 graceful-restart
#
load-balance-profile CUSTOM
 ipv6 field l4-sport l4-dport
 ipv4 field l4-sport l4-dport
#
interface Eth-Trunk2
 undo portswitch
 description Core_SPE2 to Core_SPE3
 ip address 172.17.4.0 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 3
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
 least active-linknumber 4
 load-balance enhanced profile CUSTOM
#
interface Eth-Trunk4
 undo portswitch
 description Core_SPE2 to Core_SPE1
 ip address 172.17.4.9 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group c
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
 least active-linknumber 4
 load-balance enhanced profile CUSTOM
#
interface Eth-Trunk17
 undo portswitch
 description Core_SPE2 to Site1_UPE2
 ip address 172.17.4.12 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 8
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
 least active-linknumber 4
 load-balance enhanced profile CUSTOM
#
interface XGigabitEthernet3/0/4
 eth-trunk 2
#
interface XGigabitEthernet3/0/5
 eth-trunk 2
#
interface XGigabitEthernet3/0/6
 eth-trunk 2
#
interface XGigabitEthernet3/0/7
 eth-trunk 2
#
interface XGigabitEthernet5/0/0
 eth-trunk 17
#
interface XGigabitEthernet5/0/1
 eth-trunk 17
#
interface XGigabitEthernet5/0/2
 eth-trunk 17
#
interface XGigabitEthernet5/0/3
 eth-trunk 17
#
interface XGigabitEthernet5/0/5
 undo portswitch
 description Core_SPE2 to Site2_UPE3
 ip address 172.16.8.178 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 1
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
#
interface XGigabitEthernet6/0/4
 eth-trunk 4
#
interface XGigabitEthernet6/0/5
 eth-trunk 4
#
interface XGigabitEthernet6/0/6
 eth-trunk 4
#
interface XGigabitEthernet6/0/7
 eth-trunk 4
#
interface LoopBack1
 description ** GRT Management Loopback **
 ip address 172.16.0.3 255.255.255.255
#
interface Tunnel111
 description Core_SPE2 to Site2_UPE3
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.2.75
 mpls te tunnel-id 111
 mpls te record-route
 mpls te affinity property 1 mask 1
 mpls te affinity property 2 mask 2 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel121
 description Core_SPE2 to Site2_UPE4
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.2.76
 mpls te tunnel-id 121
 mpls te record-route
 mpls te affinity property 1 mask 1
 mpls te affinity property 2 mask 2 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel612
 description Core_SPE2 to Site1_UPE1
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.2.51
 mpls te tunnel-id 72
 mpls te record-route
 mpls te affinity property 4 mask 4
 mpls te affinity property 8 mask 8 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel621
 description Core_SPE2 to Site1_UPE2
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.2.50
 mpls te tunnel-id 81
 mpls te record-route
 mpls te affinity property 8 mask 8
 mpls te affinity property 4 mask 4 secondary
 mpls te backup hot-standby 
 mpls te commit
#
bgp 65000
 graceful-restart
 group devCore internal
 peer devCore connect-interface LoopBack1
 peer 172.16.0.4 as-number 65000
 peer 172.16.0.4 group devCore
 peer 172.16.0.5 as-number 65000
 peer 172.16.0.5 group devCore
 group devHost internal
 peer devHost connect-interface LoopBack1
 peer 172.16.2.50 as-number 65000
 peer 172.16.2.50 group devHost
 peer 172.16.2.51 as-number 65000
 peer 172.16.2.51 group devHost
 peer 172.16.2.75 as-number 65000
 peer 172.16.2.75 group devHost
 peer 172.16.2.76 as-number 65000
 peer 172.16.2.76 group devHost
 #
 ipv4-family unicast
  undo synchronization
  undo peer devCore enable
  undo peer devHost enable
  undo peer 172.16.2.50 enable
  undo peer 172.16.2.51 enable
  undo peer 172.16.2.75 enable
  undo peer 172.16.2.76 enable
 #
 ipv4-family vpnv4
  policy vpn-target
  auto-frr
  nexthop recursive-lookup delay 10
  tunnel-selector TSel
  bestroute nexthop-resolved tunnel
  route-select delay 120
  peer devCore enable
  peer devCore route-policy core-import import
  peer devCore advertise-community
  peer 172.16.0.4 enable
  peer 172.16.0.4 group devCore
  peer 172.16.0.5 enable
  peer 172.16.0.5 group devCore
  peer devHost enable
  peer devHost route-policy p_iBGP_RR_in import
  peer devHost advertise-community
  peer devHost upe
  peer devHost default-originate vpn-instance vpna
  peer 172.16.2.50 enable
  peer 172.16.2.50 group devHost
  peer 172.16.2.51 enable
  peer 172.16.2.51 group devHost
  peer 172.16.2.75 enable
  peer 172.16.2.75 group devHost
  peer 172.16.2.76 enable
  peer 172.16.2.76 group devHost
 #
 ipv4-family vpn-instance vpna
  default-route imported
  auto-frr
  nexthop recursive-lookup route-policy delay_policy
  nexthop recursive-lookup delay 10
  vpn-route cross multipath
  route-select delay 120
#
ospf 1
 silent-interface all
 undo silent-interface Eth-Trunk2
 undo silent-interface Eth-Trunk4
 undo silent-interface Eth-Trunk17
 undo silent-interface XGigabitEthernet5/0/5
 spf-schedule-interval millisecond 10
 lsa-originate-interval 0
 lsa-arrival-interval 0
 opaque-capability enable
 graceful-restart period 600
 flooding-control
 area 0.0.0.0
  authentication-mode md5 1 cipher %^%#8|'*QyJCZ<@"H2,\pm@FUK3R3uSfFGaaJr39=1%^%#
  network 172.16.0.3 0.0.0.0
  network 172.16.8.178 0.0.0.0
  network 172.17.4.0 0.0.0.0
  network 172.17.4.9 0.0.0.0
  network 172.17.4.12 0.0.0.0
  mpls-te enable
#
route-policy delay_policy permit node 0
 if-match community-filter all_site
#
route-policy p_iBGP_RR_in deny node 5
 if-match ip-prefix deny_host
 if-match community-filter all_site
#
route-policy p_iBGP_RR_in permit node 11
 if-match community-filter site1
 apply preferred-value 200
#
route-policy p_iBGP_RR_in permit node 12
 if-match community-filter site2
 apply preferred-value 300
#
route-policy p_iBGP_RR_in permit node 13
 if-match community-filter site3
 apply preferred-value 200
#
route-policy p_iBGP_RR_in permit node 20
#
route-policy core-import deny node 5
 if-match community-filter site12
#
route-policy core-import deny node 6
 if-match community-filter site23
#
route-policy core-import permit node 10
#
ip ip-prefix deny_host index 10 permit 0.0.0.0 0 greater-equal 32 less-equal 32
ip ip-prefix core_nhp index 10 permit 172.16.0.4 32
ip ip-prefix core_nhp index 20 permit 172.16.0.5 32
#
ip community-filter basic site1 permit 100:100
ip community-filter basic site2 permit 200:200
ip community-filter basic site3 permit 300:300
ip community-filter basic site12 permit 12:12
ip community-filter basic site23 permit 23:23
ip community-filter basic all_site permit 5720:5720
#
tunnel-policy TSel
 tunnel select-seq cr-lsp lsp load-balance-number 1
#
tunnel-policy TE
 tunnel select-seq cr-lsp load-balance-number 1
#
bfd SPE2toSPE1 bind ldp-lsp peer-ip 172.16.0.5 nexthop 172.17.4.8 interface Eth-Trunk4
 discriminator local 137
 discriminator remote 317
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE2toSPE3 bind ldp-lsp peer-ip 172.16.0.4 nexthop 172.17.4.1 interface Eth-Trunk2
 discriminator local 127
 discriminator remote 217
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE2toUPE1_b bind mpls-te interface Tunnel612 te-lsp backup
 discriminator local 6126
 discriminator remote 6125
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE2toUPE1_m bind mpls-te interface Tunnel612 te-lsp
 discriminator local 6122
 discriminator remote 6121
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE2toUPE2_b bind mpls-te interface Tunnel621 te-lsp backup
 discriminator local 6216
 discriminator remote 6215
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE2toUPE2_m bind mpls-te interface Tunnel621 te-lsp
 discriminator local 6212
 discriminator remote 6211
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE2toUPE3_b bind mpls-te interface Tunnel111 te-lsp backup
 discriminator local 1116
 discriminator remote 1115
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE2toUPE3_m bind mpls-te interface Tunnel111 te-lsp
 discriminator local 1112
 discriminator remote 1111
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE2toUPE4_b bind mpls-te interface Tunnel121 te-lsp backup
 discriminator local 1216
 discriminator remote 1215
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE2toUPE4_m bind mpls-te interface Tunnel121 te-lsp
 discriminator local 1212
 discriminator remote 1211
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
return

Core_SPE3 Configuration File

sysname Core_SPE3
#
router id 172.16.0.4
#
stp disable
#
ip vpn-instance vpna
 ipv4-family
  route-distinguisher 4:1
  tnl-policy TSel
  vpn-target 0:1 export-extcommunity
  vpn-target 0:1 import-extcommunity
#
tunnel-selector TSel permit node 9
 if-match ip next-hop ip-prefix core_nhp
#
tunnel-selector TSel permit node 10
 apply tunnel-policy TE
#
bfd
#
mpls lsr-id 172.16.0.4
mpls
 mpls te
 label advertise non-null
 mpls rsvp-te
 mpls rsvp-te hello
 mpls rsvp-te hello full-gr
 mpls te cspf
#
mpls ldp
 graceful-restart
#
load-balance-profile CUSTOM
 ipv6 field l4-sport l4-dport
 ipv4 field l4-sport l4-dport
#
interface Eth-Trunk2
 undo portswitch
 description Core_SPE3 to Core_SPE2
 ip address 172.17.4.1 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 3
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
 least active-linknumber 4
 load-balance enhanced profile CUSTOM
#
interface Eth-Trunk5
 undo portswitch
 description Core_SPE3 to Core_SPE1
 ip address 172.17.4.3 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 30
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
 least active-linknumber 4
 load-balance enhanced profile CUSTOM
#
interface XGigabitEthernet1/0/0
 eth-trunk 5
#
interface XGigabitEthernet1/0/1
 eth-trunk 5
#
interface XGigabitEthernet1/0/2
 eth-trunk 5
#
interface XGigabitEthernet1/0/3
 eth-trunk 5
#
interface XGigabitEthernet2/0/4
 eth-trunk 2
#
interface XGigabitEthernet2/0/5
 eth-trunk 2
#
interface XGigabitEthernet2/0/6
 eth-trunk 2
#
interface XGigabitEthernet2/0/7
 eth-trunk 2
#
interface XGigabitEthernet6/0/1
 undo portswitch
 description Core_SPE3 to Site3_UPE5
 ip address 172.16.8.213 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 10
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
#
interface XGigabitEthernet6/0/3
 undo portswitch
 description Core_SPE3 to Site2_UPE4
 ip address 172.16.8.183 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 2
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
#
interface LoopBack1
 description ** GRT Management Loopback **
 ip address 172.16.0.4 255.255.255.255
#
interface Tunnel112
 description Core_SPE3 to Site2_UPE3
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.2.75
 mpls te tunnel-id 112
 mpls te bfd enable
 mpls te record-route
 mpls te affinity property 2 mask 2
 mpls te affinity property 1 mask 1 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel122
 description Core_SPE3 to Site2_UPE4
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.2.76
 mpls te tunnel-id 122
 mpls te record-route
 mpls te affinity property 2 mask 2
 mpls te affinity property 1 mask 1 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel712
 description Core_SPE3 to Site3_UPE6
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.2.86
 mpls te tunnel-id 321
 mpls te record-route
 mpls te affinity property 10 mask 10
 mpls te affinity property 20 mask 20 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel722
 description Core_SPE3 to Site3_UPE5
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.2.87
 mpls te tunnel-id 322
 mpls te record-route
 mpls te affinity property 10 mask 10
 mpls te affinity property 20 mask 20 secondary
 mpls te backup hot-standby 
 mpls te commit
#
bgp 65000
 graceful-restart
 group devCore internal
 peer devCore connect-interface LoopBack1
 peer 172.16.0.3 as-number 65000
 peer 172.16.0.3 group devCore
 peer 172.16.0.5 as-number 65000
 peer 172.16.0.5 group devCore
 group devHost internal
 peer devHost connect-interface LoopBack1
 peer 172.16.2.75 as-number 65000
 peer 172.16.2.75 group devHost
 peer 172.16.2.76 as-number 65000
 peer 172.16.2.76 group devHost
 peer 172.16.2.86 as-number 65000
 peer 172.16.2.86 group devHost
 peer 172.16.2.87 as-number 65000
 peer 172.16.2.87 group devHost
 #
 ipv4-family unicast
  undo synchronization
  undo peer devCore enable
  undo peer devHost enable
  undo peer 172.16.0.3 enable
  undo peer 172.16.0.5 enable
  undo peer 172.16.2.75 enable
  undo peer 172.16.2.76 enable
  undo peer 172.16.2.86 enable
  undo peer 172.16.2.87 enable
 #
 ipv4-family vpnv4
  policy vpn-target
  auto-frr
  nexthop recursive-lookup delay 10
  tunnel-selector TSel
  bestroute nexthop-resolved tunnel
  route-select delay 120
  peer devCore enable
  peer devCore route-policy core-import import
  peer devCore advertise-community
  peer 172.16.0.3 enable
  peer 172.16.0.3 group devCore
  peer 172.16.0.5 enable
  peer 172.16.0.5 group devCore
  peer devHost enable
  peer devHost route-policy p_iBGP_RR_in import
  peer devHost advertise-community
  peer devHost upe
  peer devHost default-originate vpn-instance vpna
  peer 172.16.2.75 enable
  peer 172.16.2.75 group devHost
  peer 172.16.2.76 enable
  peer 172.16.2.76 group devHost
  peer 172.16.2.86 enable
  peer 172.16.2.86 group devHost
  peer 172.16.2.87 enable
  peer 172.16.2.87 group devHost
 #
 ipv4-family vpn-instance vpna
  default-route imported
  auto-frr
  nexthop recursive-lookup route-policy delay_policy
  nexthop recursive-lookup delay 10
  vpn-route cross multipath
  route-select delay 120
#
ospf 1
 silent-interface all
 undo silent-interface Eth-Trunk5
 undo silent-interface Eth-Trunk2
 undo silent-interface XGigabitEthernet6/0/1
 undo silent-interface XGigabitEthernet6/0/3
 spf-schedule-interval millisecond 10
 lsa-originate-interval 0
 lsa-arrival-interval 0
 opaque-capability enable
 graceful-restart period 600
 flooding-control
 area 0.0.0.0
  authentication-mode md5 1 cipher %^%#N@WU@i600:_5W!%F!L~9%7ui(!x:VP5<mJ:z>zJX%^%#
  network 172.16.0.4 0.0.0.0
  network 172.16.8.183 0.0.0.0
  network 172.16.8.213 0.0.0.0
  network 172.17.4.1 0.0.0.0
  network 172.17.4.3 0.0.0.0
  mpls-te enable
#
route-policy delay_policy permit node 0
#
route-policy p_iBGP_RR_in deny node 5
 if-match ip-prefix deny_host
 if-match community-filter all_site
#
route-policy p_iBGP_RR_in permit node 11
 if-match community-filter site1
 apply preferred-value 200
#
route-policy p_iBGP_RR_in permit node 12
 if-match community-filter site2
 apply preferred-value 200
#
route-policy p_iBGP_RR_in permit node 13
 if-match community-filter site3
 apply preferred-value 300
#
route-policy p_iBGP_RR_in permit node 20
#
route-policy core-import deny node 5
 if-match community-filter site13
#
route-policy core-import deny node 6
 if-match community-filter site23
#
route-policy core-import permit node 10
#
ip ip-prefix deny_host index 10 permit 0.0.0.0 0 greater-equal 32 less-equal 32
ip ip-prefix core_nhp index 10 permit 172.16.0.3 32
ip ip-prefix core_nhp index 20 permit 172.16.0.5 32
#
ip community-filter basic site1 permit 100:100
ip community-filter basic site2 permit 200:200
ip community-filter basic site3 permit 300:300
ip community-filter basic all_site permit 5720:5720
ip community-filter basic site13 permit 13:13
ip community-filter basic site23 permit 23:23
#
tunnel-policy TSel
 tunnel select-seq cr-lsp lsp load-balance-number 1
#
tunnel-policy TE
 tunnel select-seq cr-lsp load-balance-number 1
#
bfd SPE3toSPE1 bind ldp-lsp peer-ip 172.16.0.5 nexthop 172.17.4.2 interface Eth-Trunk5
 discriminator local 23
 discriminator remote 32
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE3toSPE2 bind ldp-lsp peer-ip 172.16.0.3 nexthop 172.17.4.0 interface Eth-Trunk2
 discriminator local 217
 discriminator remote 127
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE3toUPE3_b bind mpls-te interface Tunnel112 te-lsp backup
 discriminator local 1126
 discriminator remote 1125
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE3toUPE3_m bind mpls-te interface Tunnel112 te-lsp
 discriminator local 1122
 discriminator remote 1121
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE3toUPE4_b bind mpls-te interface Tunnel122 te-lsp backup
 discriminator local 1226
 discriminator remote 1225
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE3toUPE4_m bind mpls-te interface Tunnel122 te-lsp
 discriminator local 1222
 discriminator remote 1221
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE3toUPE5_b bind mpls-te interface Tunnel722 te-lsp backup
 discriminator local 7226
 discriminator remote 7225
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE3toUPE5_m bind mpls-te interface Tunnel722 te-lsp
 discriminator local 7222
 discriminator remote 7221
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE3toUPE6_b bind mpls-te interface Tunnel712 te-lsp backup
 discriminator local 7126
 discriminator remote 7125
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd SPE3toUPE6_m bind mpls-te interface Tunnel712 te-lsp
 discriminator local 7122
 discriminator remote 7121
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
return

Site1_UPE1 Configuration File

sysname Site1_UPE1
#
router id 172.16.2.51
#
arp vlink-direct-route advertise
#
stp disable
#
ip vpn-instance vpna
 ipv4-family
  route-distinguisher 1:1
  ip frr route-policy mixfrr
  tnl-policy TSel
  arp vlink-direct-route advertise
  vpn-target 0:1 export-extcommunity
  vpn-target 0:1 import-extcommunity
#
bfd
#
mpls lsr-id 172.16.2.51
mpls
 mpls te
 label advertise non-null
 mpls rsvp-te
 mpls rsvp-te hello
 mpls rsvp-te hello full-gr
 mpls te cspf
#
mpls ldp
 graceful-restart
#
interface Eth-Trunk7
 undo portswitch
 description Site1_UPE1 TO Site1_UPE2
 ip address 172.17.4.14 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group c
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
 least active-linknumber 4
#
interface Eth-Trunk17
 undo portswitch
 description Site1_UPE1 to Core_SPE1
 ip address 172.17.4.11 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 4
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
 least active-linknumber 4
#
interface XGigabitEthernet1/0/0
 eth-trunk 17
#
interface XGigabitEthernet1/0/1
 eth-trunk 17
#
interface XGigabitEthernet1/0/2
 eth-trunk 17
#
interface XGigabitEthernet1/0/3
 eth-trunk 17
#
interface XGigabitEthernet1/0/4
 port link-type trunk
 undo port trunk allow-pass vlan 1
#
interface XGigabitEthernet1/0/4.200
 dot1q termination vid 200
 ip binding vpn-instance vpna
 arp direct-route enable
 ip address 172.18.200.66 255.255.255.192
 vrrp vrid 1 virtual-ip 172.18.200.65
 vrrp vrid 1 preempt-mode timer delay 250
 vrrp vrid 1 track bfd-session 2200 peer
 vrrp vrid 1 backup-forward
 arp broadcast enable
 vrrp track bfd gratuitous-arp send enable
#
interface XGigabitEthernet4/0/4
 eth-trunk 7
#
interface XGigabitEthernet4/0/5
 eth-trunk 7
#
interface XGigabitEthernet4/0/6
 eth-trunk 7
#
interface XGigabitEthernet4/0/7
 eth-trunk 7
#
interface LoopBack1
 description ** GRT Management Loopback **
 ip address 172.16.2.51 255.255.255.255
#
interface Tunnel611
 description Site1_UPE1 to Core_SPE1
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.0.5
 mpls te tunnel-id 71
 mpls te record-route
 mpls te affinity property 4 mask 4
 mpls te affinity property 8 mask 8 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel612
 description Site1_UPE1 to Core_SPE2
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.0.3
 mpls te tunnel-id 72
 mpls te record-route
 mpls te affinity property 4 mask 4
 mpls te affinity property 8 mask 8 secondary
 mpls te backup hot-standby 
 mpls te commit
#
bfd vrrp-1 bind peer-ip 172.18.200.67 vpn-instance vpna interface XGigabitEthernet1/0/4.200 source-ip 172.18.200.66
 discriminator local 2200
 discriminator remote 1200
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 commit
#
bgp 65000
 graceful-restart
 group devCore internal
 peer devCore connect-interface LoopBack1
 peer 172.16.0.3 as-number 65000
 peer 172.16.0.3 group devCore
 peer 172.16.0.5 as-number 65000
 peer 172.16.0.5 group devCore
 group devHost internal
 peer devHost connect-interface LoopBack1
 peer 172.16.2.50 as-number 65000
 peer 172.16.2.50 group devHost
 #
 ipv4-family unicast
  undo synchronization
  undo peer devCore enable
  undo peer devHost enable
  undo peer 172.16.2.50 enable
  undo peer 172.16.0.3 enable
  undo peer 172.16.0.5 enable
 #
 ipv4-family vpnv4
  policy vpn-target
  route-select delay 120
  peer devCore enable
  peer devCore route-policy p_iBGP_host_ex export
  peer devCore advertise-community
  peer 172.16.0.3 enable
  peer 172.16.0.3 group devCore
  peer 172.16.0.3 preferred-value 200
  peer 172.16.0.5 enable
  peer 172.16.0.5 group devCore
  peer 172.16.0.5 preferred-value 300
  peer devHost enable
  peer devHost advertise-community
  peer 172.16.2.50 enable
  peer 172.16.2.50 group devHost
 #
 ipv4-family vpn-instance vpna
  default-route imported
  import-route direct route-policy p_iBGP_RR_ex
  auto-frr
  route-select delay 120
 #
#
ospf 1
 silent-interface all
 undo silent-interface Eth-Trunk7
 undo silent-interface Eth-Trunk17
 opaque-capability enable
 graceful-restart period 600
 bandwidth-reference 100000
 flooding-control
 area 0.0.0.0
  authentication-mode md5 1 cipher %^%#nU!dUe#c'J!;/%*WtZxQ<gP:'zx_E2OQnML]q;s#%^%#
  network 172.16.2.51 0.0.0.0
  network 172.17.4.11 0.0.0.0
  network 172.17.4.14 0.0.0.0
  mpls-te enable
#
route-policy mixfrr permit node 0
 apply backup-nexthop 172.16.2.50
#
route-policy p_iBGP_host_ex permit node 0
 apply community 100:100 5720:5720 12:12
#
route-policy p_iBGP_RR_ex permit node 0
 apply community 100:100 5720:5720 12:12
#
arp expire-time 62640
arp static 172.18.200.68 0001-0002-0003 vid 200 interface XGigabitEthernet1/0/4.200
#
tunnel-policy TSel
 tunnel select-seq cr-lsp lsp load-balance-number 1
#
bfd UPE1toSPE1_m_b bind mpls-te interface Tunnel611 te-lsp backup
 discriminator local 6115
 discriminator remote 6116
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE1toSPE1_m bind mpls-te interface Tunnel611 te-lsp
 discriminator local 6111
 discriminator remote 6112
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE1toSPE2_b bind mpls-te interface Tunnel612 te-lsp backup
 discriminator local 6125
 discriminator remote 6126
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE1toSPE2_m bind mpls-te interface Tunnel612 te-lsp
 discriminator local 6121
 discriminator remote 6122
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
return

Site1_UPE2 Configuration File

sysname Site1_UPE2
#
router id 172.16.2.50
#
arp vlink-direct-route advertise
#
stp disable
#
ip vpn-instance vpna
 ipv4-family
  route-distinguisher 1:1
  ip frr route-policy mixfrr
  tnl-policy TSel
  arp vlink-direct-route advertise
  vpn-target 0:1 export-extcommunity
  vpn-target 0:1 import-extcommunity
#
bfd
#
mpls lsr-id 172.16.2.50
mpls
 mpls te
 label advertise non-null
 mpls rsvp-te
 mpls rsvp-te hello
 mpls rsvp-te hello full-gr
 mpls te cspf
#
mpls ldp
 graceful-restart
#
#
interface Eth-Trunk7
 undo portswitch
 description Site1_UPE2 to Site1_UPE1
 ip address 172.17.4.15 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group c
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
 least active-linknumber 4
#
interface Eth-Trunk17
 undo portswitch
 description Site1_UPE2 to Core_SPE2
 ip address 172.17.4.13 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 8
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
 least active-linknumber 4
#
interface XGigabitEthernet1/0/4
 port link-type trunk
#
interface XGigabitEthernet1/0/4.200
 dot1q termination vid 200
 ip binding vpn-instance vpna
 arp direct-route enable
 ip address 172.18.200.67 255.255.255.192
 vrrp vrid 1 virtual-ip 172.18.200.65
 vrrp vrid 1 priority 90
 vrrp vrid 1 preempt-mode timer delay 250
 vrrp vrid 1 track bfd-session 1200 peer
 vrrp vrid 1 backup-forward
 arp broadcast enable
 vrrp track bfd gratuitous-arp send enable
#
interface XGigabitEthernet6/0/0
 eth-trunk 17
#
interface XGigabitEthernet6/0/1
 eth-trunk 17
#
interface XGigabitEthernet6/0/2
 eth-trunk 17
#
interface XGigabitEthernet6/0/3
 eth-trunk 17
#
interface XGigabitEthernet6/0/4
 eth-trunk 7
#
interface XGigabitEthernet6/0/5
 eth-trunk 7
#
interface XGigabitEthernet6/0/6
 eth-trunk 7
#
interface XGigabitEthernet6/0/7
 eth-trunk 7
#
interface LoopBack1
 description ** GRT Management Loopback **
 ip address 172.16.2.50 255.255.255.255
#
interface Tunnel621
 description Site1_UPE2 to Core_SPE2
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.0.3
 mpls te tunnel-id 81
 mpls te record-route
 mpls te affinity property 8 mask 8
 mpls te affinity property 4 mask 4 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel622
 description Site1_UPE2 to Core_SPE1
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.0.5
 mpls te tunnel-id 82
 mpls te record-route
 mpls te affinity property 8 mask 8
 mpls te affinity property 4 mask 4 secondary
 mpls te backup hot-standby 
 mpls te commit
#
bfd vrrp-1 bind peer-ip 172.18.200.66 vpn-instance vpna interface XGigabitEthernet1/0/4.200 source-ip 172.18.200.67
 discriminator local 1200
 discriminator remote 2200
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 commit
#
bgp 65000
 graceful-restart
 group devCore internal
 peer devCore connect-interface LoopBack1
 peer 172.16.0.3 as-number 65000
 peer 172.16.0.3 group devCore
 peer 172.16.0.5 as-number 65000
 peer 172.16.0.5 group devCore
 group devHost internal
 peer devHost connect-interface LoopBack1
 peer 172.16.2.51 as-number 65000
 peer 172.16.2.51 group devHost
 #
 ipv4-family unicast
  undo synchronization
  undo peer devCore enable
  undo peer devHost enable
  undo peer 172.16.2.51 enable
  undo peer 172.16.0.3 enable
  undo peer 172.16.0.5 enable
 #
 ipv4-family vpnv4
  policy vpn-target
  route-select delay 120
  peer devCore enable
  peer devCore route-policy p_iBGP_host_ex export
  peer devCore advertise-community
  peer 172.16.0.3 enable
  peer 172.16.0.3 group devCore
  peer 172.16.0.3 preferred-value 300
  peer 172.16.0.5 enable
  peer 172.16.0.5 group devCore
  peer 172.16.0.5 preferred-value 200
  peer devHost enable
  peer devHost advertise-community
  peer 172.16.2.51 enable
  peer 172.16.2.51 group devHost
 #
 ipv4-family vpn-instance vpna
  default-route imported
  import-route direct route-policy p_iBGP_RR_ex
  auto-frr
  route-select delay 120
 #
#
ospf 1
 silent-interface all
 undo silent-interface Eth-Trunk7
 undo silent-interface Eth-Trunk17
 opaque-capability enable
 graceful-restart period 600
 bandwidth-reference 100000
 flooding-control
 area 0.0.0.0
  authentication-mode md5 1 cipher %^%#GUPhWw-[LH2O6#NMxtJAl!Io8W~iF'![mQF[\9GI%^%#
  network 172.16.2.50 0.0.0.0
  network 172.16.2.92 0.0.0.0
  network 172.17.4.13 0.0.0.0
  network 172.17.4.15 0.0.0.0
  mpls-te enable
#
route-policy mixfrr permit node 0
 apply backup-nexthop 172.16.2.51
#
route-policy p_iBGP_host_ex permit node 0
 apply community 200:200 5720:5720 12:12
#
route-policy p_iBGP_RR_ex permit node 0
 apply community 200:200 5720:5720 12:12
#
arp expire-time 62640
arp static 172.18.200.68 0001-0002-0003 vid 200 interface XGigabitEthernet1/0/4.200
#
tunnel-policy TSel
 tunnel select-seq cr-lsp lsp load-balance-number 1
#
bfd UPE2toSPE1_b bind mpls-te interface Tunnel622 te-lsp backup
 discriminator local 6225
 discriminator remote 6226
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE2toSPE1_m bind mpls-te interface Tunnel622 te-lsp
 discriminator local 6221
 discriminator remote 6222
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE2toSPE2_b bind mpls-te interface Tunnel621 te-lsp backup
 discriminator local 6215
 discriminator remote 6216
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE2toSPE2_m bind mpls-te interface Tunnel621 te-lsp
 discriminator local 6211
 discriminator remote 6212
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
return 

Site2_UPE3 Configuration File

sysname Site2_UPE3
#
router id 172.16.2.75
#
arp vlink-direct-route advertise
#
stp disable
#
set service-mode enhanced
#
ip vpn-instance vpna
 ipv4-family
  route-distinguisher 1:1
  ip frr route-policy mixfrr
  tnl-policy TSel
  arp vlink-direct-route advertise
  vpn-target 0:1 export-extcommunity
  vpn-target 0:1 import-extcommunity
#
bfd
#
mpls lsr-id 172.16.2.75
mpls
 mpls te
 label advertise non-null
 mpls rsvp-te
 mpls rsvp-te hello
 mpls rsvp-te hello full-gr
 mpls te cspf
#
mpls ldp
 graceful-restart
#
interface XGigabitEthernet0/0/1
 undo portswitch
 description Site2_UPE3 to Core_SPE2
 ip address 172.16.8.179 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 1
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
#
interface XGigabitEthernet0/0/2
 port link-type trunk
 undo port trunk allow-pass vlan 1
#
interface XGigabitEthernet0/0/2.150
 dot1q termination vid 150
 ip binding vpn-instance vpna
 arp direct-route enable
 ip address 172.18.150.2 255.255.255.192
 vrrp vrid 1 virtual-ip 172.18.150.1
 vrrp vrid 1 preempt-mode timer delay 250
 vrrp vrid 1 track bfd-session 2150 peer
 vrrp vrid 1 backup-forward
 arp broadcast enable
 vrrp track bfd gratuitous-arp send enable
#
interface XGigabitEthernet0/0/4
 undo portswitch
 description Site2_UPE3 to Site2_UPE4
 ip address 172.16.8.180 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 3
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
#
interface LoopBack1
 description ** GRT Management Loopback **
 ip address 172.16.2.75 255.255.255.255
#
interface Tunnel111
 description Site2_UPE3 to Core_SPE2
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.0.3
 mpls te tunnel-id 111
 mpls te record-route
 mpls te affinity property 1 mask 1
 mpls te affinity property 2 mask 2 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel112
 description Site2_UPE3 to Core_SPE3
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.0.4
 mpls te tunnel-id 112
 mpls te record-route
 mpls te affinity property 2 mask 2
 mpls te affinity property 1 mask 1 secondary
 mpls te backup hot-standby 
 mpls te commit
#
bfd vrrp-1 bind peer-ip 172.18.150.3 vpn-instance vpna interface XGigabitEthernet0/0/2.150 source-ip 172.18.150.2
 discriminator local 2150
 discriminator remote 1150
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 commit
#
bgp 65000
 graceful-restart
 group devCore internal
 peer devCore connect-interface LoopBack1
 peer 172.16.0.3 as-number 65000
 peer 172.16.0.3 group devCore
 peer 172.16.0.4 as-number 65000
 peer 172.16.0.4 group devCore
 group devHost internal
 peer devHost connect-interface LoopBack1
 peer 172.16.2.76 as-number 65000
 peer 172.16.2.76 group devHost
 #
 ipv4-family unicast
  undo synchronization
  undo peer devCore enable
  undo peer devHost enable
  undo peer 172.16.0.3 enable
  undo peer 172.16.0.4 enable
  undo peer 172.16.2.76 enable
 #
 ipv4-family vpnv4
  policy vpn-target
  route-select delay 120
  peer devCore enable
  peer devCore route-policy p_iBGP_host_ex export
  peer devCore advertise-community
  peer 172.16.0.3 enable
  peer 172.16.0.3 group devCore
  peer 172.16.0.3 preferred-value 300
  peer 172.16.0.4 enable
  peer 172.16.0.4 group devCore
  peer 172.16.0.4 preferred-value 200
  peer devHost enable
  peer devHost advertise-community
  peer 172.16.2.76 enable
  peer 172.16.2.76 group devHost
 #
 ipv4-family vpn-instance vpna
  default-route imported
  import-route direct route-policy p_iBGP_RR_ex
  auto-frr
  route-select delay 120
#
ospf 1
 silent-interface all
 undo silent-interface XGigabitEthernet0/0/1
 undo silent-interface XGigabitEthernet0/0/4
 opaque-capability enable
 graceful-restart period 600
 bandwidth-reference 100000
 flooding-control
 area 0.0.0.0
  authentication-mode md5 1 cipher %^%#zJm-P{(FiMrB0bLa^ST'z[!(UezNNTx\CQ6@N\,K%^%#
  network 172.16.2.75 0.0.0.0
  network 172.16.8.179 0.0.0.0
  network 172.16.8.180 0.0.0.0
  mpls-te enable
#
route-policy mixfrr permit node 0
 apply backup-nexthop 172.16.2.76
#
route-policy p_iBGP_host_ex permit node 10
 apply community 200:200 5720:5720 23:23
#
route-policy p_iBGP_RR_ex permit node 0
 apply community 200:200 5720:5720 23:23
#
arp expire-time 62640
arp static 172.18.150.4 0000-0001-0003 vid 150 interface XGigabitEthernet0/0/2.150
#
tunnel-policy TSel
 tunnel select-seq cr-lsp lsp load-balance-number 1
#
bfd UPE3toSPE2_b bind mpls-te interface Tunnel111 te-lsp backup
 discriminator local 1115
 discriminator remote 1116
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE3toSPE2_m bind mpls-te interface Tunnel111 te-lsp
 discriminator local 1111
 discriminator remote 1112
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE3toSPE3_b bind mpls-te interface Tunnel112 te-lsp backup
 discriminator local 1125
 discriminator remote 1126
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE3toSPE3_m bind mpls-te interface Tunnel112 te-lsp
 discriminator local 1121
 discriminator remote 1122
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
return

Site2_UPE4 Configuration File

sysname Site2_UPE4
#
router id 172.16.2.76
#
arp vlink-direct-route advertise
#
stp disable
#
set service-mode enhanced
#
ip vpn-instance vpna
 ipv4-family
  route-distinguisher 1:1
  ip frr route-policy mixfrr
  tnl-policy TSel
  arp vlink-direct-route advertise
  vpn-target 0:1 export-extcommunity
  vpn-target 0:1 import-extcommunity
#
bfd
#
mpls lsr-id 172.16.2.76
mpls
 mpls te
 label advertise non-null
 mpls rsvp-te
 mpls rsvp-te hello
 mpls rsvp-te hello full-gr
 mpls te cspf
#
mpls ldp
 graceful-restart
#
interface XGigabitEthernet0/0/1
 undo portswitch
 description Site2_UPE4 to Core_SPE3
 ip address 172.16.8.182 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 2
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
#
interface XGigabitEthernet0/0/2
 port link-type trunk
 undo port trunk allow-pass vlan 1
#
interface XGigabitEthernet0/0/2.150
 dot1q termination vid 150
 ip binding vpn-instance vpna
 arp direct-route enable
 ip address 172.18.150.3 255.255.255.192
 vrrp vrid 1 virtual-ip 172.18.150.1
 vrrp vrid 1 priority 90
 vrrp vrid 1 preempt-mode timer delay 250
 vrrp vrid 1 track bfd-session 1150 peer
 vrrp vrid 1 backup-forward
 arp broadcast enable
 vrrp track bfd gratuitous-arp send enable
#
interface XGigabitEthernet0/0/4
 undo portswitch
 description Site2_UPE4 to Site2_UPE3
 ip address 172.16.8.181 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 3
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
#
interface LoopBack1
 description ** GRT Management Loopback **
 ip address 172.16.2.76 255.255.255.255
#
interface Tunnel121
 description Site2_UPE4 to Core_SPE2
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.0.3
 mpls te tunnel-id 121
 mpls te record-route
 mpls te affinity property 1 mask 1
 mpls te affinity property 2 mask 2 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel122
 description Site2_UPE4 to Core_SPE3
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.0.4
 mpls te tunnel-id 122
 mpls te record-route
 mpls te affinity property 2 mask 2
 mpls te affinity property 1 mask 1 secondary
 mpls te backup hot-standby 
 mpls te commit
#
bfd vrrp-1 bind peer-ip 172.18.150.2 vpn-instance vpna interface XGigabitEthernet0/0/2.150 source-ip 172.18.150.3
 discriminator local 1150
 discriminator remote 2150
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 commit
#
bgp 65000
 graceful-restart
 group devCore internal
 peer devCore connect-interface LoopBack1
 peer 172.16.0.3 as-number 65000
 peer 172.16.0.3 group devCore
 peer 172.16.0.4 as-number 65000
 peer 172.16.0.4 group devCore
 group devHost internal
 peer devHost connect-interface LoopBack1
 peer 172.16.2.75 as-number 65000
 peer 172.16.2.75 group devHost
 #
 ipv4-family unicast
  undo synchronization
  undo peer devCore enable
  undo peer devHost enable
  undo peer 172.16.0.3 enable
  undo peer 172.16.0.4 enable
  undo peer 172.16.2.75 enable
 #
 ipv4-family vpnv4
  policy vpn-target
  route-select delay 120
  peer devCore enable
  peer devCore route-policy p_iBGP_host_ex export
  peer devCore advertise-community
  peer 172.16.0.3 enable
  peer 172.16.0.3 group devCore
  peer 172.16.0.3 preferred-value 200
  peer 172.16.0.4 enable
  peer 172.16.0.4 group devCore
  peer 172.16.0.4 preferred-value 300
  peer devHost enable
  peer devHost advertise-community
  peer 172.16.2.75 enable
  peer 172.16.2.75 group devHost
 #
 ipv4-family vpn-instance vpna
  default-route imported
  import-route direct route-policy p_iBGP_RR_ex
  auto-frr
  route-select delay 120
#
ospf 1
 silent-interface all
 undo silent-interface XGigabitEthernet0/0/1
 undo silent-interface XGigabitEthernet0/0/4
 opaque-capability enable
 graceful-restart period 600
 bandwidth-reference 100000
 flooding-control
 area 0.0.0.0
  authentication-mode md5 1 cipher %^%#"sZy-UeQ88(kmb#.o"Y8*@/_9D[_<-3ET`+!1no4%^%#
  network 172.16.2.76 0.0.0.0
  network 172.16.8.181 0.0.0.0
  network 172.16.8.182 0.0.0.0
  mpls-te enable
#
route-policy mixfrr permit node 0
 apply backup-nexthop 172.16.2.75
#
route-policy p_iBGP_host_ex permit node 0
 apply community 300:300 5720:5720 23:23
#
route-policy p_iBGP_RR_ex permit node 0
 apply community 300:300 5720:5720 23:23
#
arp expire-time 62640
arp static 172.18.150.4 0000-0001-0003 vid 150 interface XGigabitEthernet0/0/2.150
#
tunnel-policy TSel
 tunnel select-seq cr-lsp lsp load-balance-number 1
#
bfd UPE4toSPE2_b bind mpls-te interface Tunnel121 te-lsp backup
 discriminator local 1215
 discriminator remote 1216
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE4toSPE2_m bind mpls-te interface Tunnel121 te-lsp
 discriminator local 1211
 discriminator remote 1212
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE4toSPE3_b bind mpls-te interface Tunnel122 te-lsp backup
 discriminator local 1225
 discriminator remote 1226
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE4toSPE3_m bind mpls-te interface Tunnel122 te-lsp
 discriminator local 1221
 discriminator remote 1222
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
return

Site3_UPE5 Configuration File

sysname Site3_UPE5
#
router id 172.16.2.87
#
arp vlink-direct-route advertise
#
stp disable
#
set service-mode enhanced
#
ip vpn-instance vpna
 ipv4-family
  route-distinguisher 1:1
  ip frr route-policy mixfrr
  tnl-policy TSel
  arp vlink-direct-route advertise
  vpn-target 0:1 export-extcommunity
  vpn-target 0:1 import-extcommunity
#
bfd
#
mpls lsr-id 172.16.2.87
mpls
 mpls te
 label advertise non-null
 mpls rsvp-te
 mpls rsvp-te hello
 mpls rsvp-te hello full-gr
 mpls te cspf
#
mpls ldp
 graceful-restart
#
interface XGigabitEthernet0/0/2
 port link-type trunk
 undo port trunk allow-pass vlan 1
#
interface XGigabitEthernet0/0/2.100
 dot1q termination vid 100
 ip binding vpn-instance vpna
 arp direct-route enable
 ip address 172.18.100.2 255.255.255.192
 vrrp vrid 1 virtual-ip 172.18.100.1
 vrrp vrid 1 preempt-mode timer delay 250
 vrrp vrid 1 track bfd-session 2150 peer
 vrrp vrid 1 backup-forward
 arp broadcast enable
 vrrp track bfd gratuitous-arp send enable
#
interface XGigabitEthernet0/0/1
 undo portswitch
 description Site3_UPE5 to Site3_UPE6
 ip address 172.17.10.0 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 3
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
#
interface XGigabitEthernet0/0/4
 undo portswitch
 description Site3_UPE5 to Core_SPE3
 ip address 172.16.8.212 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 2
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
#
interface LoopBack1
 description ** GRT Management Loopback **
 ip address 172.16.2.87 255.255.255.255
#
interface Tunnel721
 description Site3_UPE5 to Core_SPE1
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.0.5
 mpls te tunnel-id 312
 mpls te record-route
 mpls te affinity property 1 mask 1
 mpls te affinity property 2 mask 2 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel722
 description Site3_UPE5 to Core_SPE3
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.0.4
 mpls te tunnel-id 322
 mpls te record-route
 mpls te affinity property 2 mask 2
 mpls te affinity property 1 mask 1 secondary
 mpls te backup hot-standby 
 mpls te commit
#
bfd vrrp-2000 bind peer-ip 172.18.100.3 vpn-instance vpna interface XGigabitEthernet0/0/2.100 source-ip 172.18.100.2 auto
 min-tx-interval 3
 min-rx-interval 3
 commit
#
bgp 65000
 graceful-restart
 group devCore internal
 peer devCore connect-interface LoopBack1
 peer 172.16.0.4 as-number 65000
 peer 172.16.0.4 group devCore
 peer 172.16.0.5 as-number 65000
 peer 172.16.0.5 group devCore
 group devHost internal
 peer devHost connect-interface LoopBack1
 peer 172.16.2.86 as-number 65000
 peer 172.16.2.86 group devHost
 #
 ipv4-family unicast
  undo synchronization
  undo peer devCore enable
  undo peer devHost enable
  undo peer 172.16.0.4 enable
  undo peer 172.16.0.5 enable
  undo peer 172.16.2.86 enable
 #
 ipv4-family vpnv4
  policy vpn-target
  route-select delay 120
  peer devCore enable
  peer devCore route-policy p_iBGP_host_ex export
  peer devCore advertise-community
  peer 172.16.0.4 enable
  peer 172.16.0.4 group devCore
  peer 172.16.0.4 preferred-value 300
  peer 172.16.0.5 enable
  peer 172.16.0.5 group devCore
  peer 172.16.0.5 preferred-value 200
  peer devHost enable
  peer devHost advertise-community
  peer 172.16.2.86 enable
  peer 172.16.2.86 group devHost
 #
 ipv4-family vpn-instance vpna
  default-route imported
  import-route direct route-policy p_iBGP_RR_ex
  auto-frr
  route-select delay 120
#
ospf 1
 silent-interface all
 undo silent-interface XGigabitEthernet0/0/1
 undo silent-interface XGigabitEthernet0/0/4
 opaque-capability enable
 graceful-restart period 600
 bandwidth-reference 100000
 flooding-control
 area 0.0.0.0
  authentication-mode md5 1 cipher %#%#^tB:@vm8r%4Z0),RRem7dU.A3.}(a&*/IhJ70>y9%#%#
  network 172.16.2.87 0.0.0.0
  network 172.16.8.212 0.0.0.0
  network 172.17.10.0 0.0.0.0
  mpls-te enable
#
route-policy mixfrr permit node 0
 apply backup-nexthop 172.16.2.86
#
route-policy p_iBGP_host_ex permit node 0
 apply community 300:300 5720:5720 13:13
#
route-policy p_iBGP_RR_ex permit node 0
 apply community 300:300 5720:5720 13:13
#
arp expire-time 62640
arp static 172.18.100.4 0000-0002-0003 vid 100 interface XGigabitEthernet0/0/2.100
#
tunnel-policy TSel
 tunnel select-seq cr-lsp lsp load-balance-number 1
#
bfd UPE5toSPE1_b bind mpls-te interface Tunnel721 te-lsp backup
 discriminator local 7215
 discriminator remote 7216
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE5toSPE1_m bind mpls-te interface Tunnel721 te-lsp
 discriminator local 7211
 discriminator remote 7212
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE5toSPE3_b bind mpls-te interface Tunnel722 te-lsp backup
 discriminator local 7225
 discriminator remote 7226
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE5toSPE3_m bind mpls-te interface Tunnel722 te-lsp
 discriminator local 7221
 discriminator remote 7222
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
return

Site3_UPE6 Configuration File

sysname Site3_UPE6
#
router id 172.16.2.86
#
arp vlink-direct-route advertise
#
stp disable
#
set service-mode enhanced
#
ip vpn-instance vpna
 ipv4-family
  route-distinguisher 1:1
  ip frr route-policy mixfrr
  tnl-policy TSel
  arp vlink-direct-route advertise
  vpn-target 0:1 export-extcommunity
  vpn-target 0:1 import-extcommunity
#
bfd
#
mpls lsr-id 172.16.2.86
mpls
 mpls te
 label advertise non-null
 mpls rsvp-te
 mpls rsvp-te hello
 mpls rsvp-te hello full-gr
 mpls te cspf
#
mpls ldp
 graceful-restart
#
interface XGigabitEthernet0/0/2
 port link-type trunk
 undo port trunk allow-pass vlan 1
#
interface XGigabitEthernet0/0/2.100
 dot1q termination vid 100
 ip binding vpn-instance vpna
 arp direct-route enable
 ip address 172.18.100.3 255.255.255.192
 vrrp vrid 1 virtual-ip 172.18.100.1
 vrrp vrid 1 priority 90
 vrrp vrid 1 preempt-mode timer delay 250
 vrrp vrid 1 track bfd-session 2150 peer
 vrrp vrid 1 backup-forward
 arp broadcast enable
 vrrp track bfd gratuitous-arp send enable
#
interface XGigabitEthernet0/0/1
 undo portswitch
 description Site3_UPE6 to Site3_UPE5
 ip address 172.17.10.1 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 3
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
#
interface XGigabitEthernet0/0/4
 undo portswitch
 description Site3_UPE6 to Core_SPE1
 ip address 172.17.10.3 255.255.255.254
 ospf network-type p2p
 ospf ldp-sync
 ospf timer ldp-sync hold-down 20
 mpls
 mpls te
 mpls te link administrative group 1
 mpls rsvp-te
 mpls rsvp-te hello
 mpls ldp
#
interface LoopBack1
 description ** GRT Management Loopback **
 ip address 172.16.2.86 255.255.255.255
#
interface Tunnel711
 description Site3_UPE6 to Core_SPE1
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.0.5
 mpls te tunnel-id 311
 mpls te record-route
 mpls te affinity property 1 mask 1
 mpls te affinity property 2 mask 2 secondary
 mpls te backup hot-standby 
 mpls te commit
#
interface Tunnel712
 description Site3_UPE6 to Core_SPE3
 ip address unnumbered interface LoopBack1
 tunnel-protocol mpls te
 destination 172.16.0.4
 mpls te tunnel-id 321
 mpls te record-route
 mpls te affinity property 2 mask 2
 mpls te affinity property 1 mask 1 secondary
 mpls te backup hot-standby 
 mpls te commit
#
bfd vrrp-1 bind peer-ip 172.18.100.2 vpn-instance vpna interface XGigabitEthernet0/0/2.100 source-ip 172.18.100.3 auto
 min-tx-interval 3
 min-rx-interval 3
 commit
#
bgp 65000
 graceful-restart
 group devCore internal
 peer devCore connect-interface LoopBack1
 peer 172.16.0.4 as-number 65000
 peer 172.16.0.4 group devCore
 peer 172.16.0.5 as-number 65000
 peer 172.16.0.5 group devCore
 group devHost internal
 peer devHost connect-interface LoopBack1
 peer 172.16.2.87 as-number 65000
 peer 172.16.2.87 group devHost
 #
 ipv4-family unicast
  undo synchronization
  undo peer devCore enable
  undo peer devHost enable
  undo peer 172.16.0.4 enable
  undo peer 172.16.0.5 enable
  undo peer 172.16.2.87 enable
 #
 ipv4-family vpnv4
  policy vpn-target
  route-select delay 120
  peer devCore enable
  peer devCore route-policy p_iBGP_host_ex export
  peer devCore advertise-community
  peer 172.16.0.4 enable
  peer 172.16.0.4 group devCore
  peer 172.16.0.4 preferred-value 200
  peer 172.16.0.5 enable
  peer 172.16.0.5 group devCore
  peer 172.16.0.5 preferred-value 300
  peer devHost enable
  peer devHost advertise-community
  peer 172.16.2.87 enable
  peer 172.16.2.87 group devHost
 #
 ipv4-family vpn-instance vpna
  default-route imported
  import-route direct route-policy p_iBGP_RR_ex
  auto-frr
  route-select delay 120
#
ospf 1
 silent-interface all
 undo silent-interface XGigabitEthernet0/0/1
 undo silent-interface XGigabitEthernet0/0/4
 opaque-capability enable
 graceful-restart period 600
 bandwidth-reference 100000
 flooding-control
 area 0.0.0.0
  authentication-mode md5 1 cipher %#%#<3.TS63Ml*_Gn]2$}@O/G8llX)VNvDY\kT;4E9-A%#%#
  network 172.16.2.86 0.0.0.0
  network 172.17.10.1 0.0.0.0
  network 172.17.10.3 0.0.0.0
  mpls-te enable
#
route-policy mixfrr permit node 0
 apply backup-nexthop 172.16.2.87
#
route-policy p_iBGP_host_ex permit node 0
 apply community 100:100 5720:5720 13:13
#
route-policy p_iBGP_RR_ex permit node 0
 apply community 100:100 5720:5720 13:13
#
arp expire-time 62640
arp static 172.18.100.4 0000-0002-0003 vid 100 interface XGigabitEthernet0/0/2.100
#
tunnel-policy TSel
 tunnel select-seq cr-lsp lsp load-balance-number 1
#
bfd UPE6toSPE1_b bind mpls-te interface Tunnel711 te-lsp backup
 discriminator local 7115
 discriminator remote 7116
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE6toSPE1_m bind mpls-te interface Tunnel711 te-lsp
 discriminator local 7111
 discriminator remote 7112
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE6toSPE3_b bind mpls-te interface Tunnel712 te-lsp backup
 discriminator local 7125
 discriminator remote 7126
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
bfd UPE6toSPE3_m bind mpls-te interface Tunnel712 te-lsp
 discriminator local 7121
 discriminator remote 7122
 detect-multiplier 8
 min-tx-interval 3
 min-rx-interval 3
 process-pst
 commit
#
return
Download
Updated: 2019-04-20

Document ID: EDOC1000069520

Views: 697187

Downloads: 30201

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next