No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S2700, S3700, S5700, S6700, S7700, and S9700 Series Switches Typical Configuration Examples

This document provides examples for configuring features in typical usage scenarios.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring LBDT to Detect Loops on the Local Network

Example for Configuring LBDT to Detect Loops on the Local Network

Overview

When a loop occurs on a network, broadcast, multicast, and unknown unicast packets are repeatedly transmitted on the network. This wastes network resources and may even cause a network breakdown. To minimize the impact of loops on a Layer 2 network, a detection technology that quickly notifies users of loops is required. When a loop occurs, users are requested to check network connections and configurations, and control the problematic interface.

Loopback detection (LBDT) periodically sends LBDT packets on an interface to check whether the packets return to the local device (receive and transmit interfaces can be different), and determines whether loops occur on the interface, local network, or downstream network.
  • If LBDT packets are received and sent by the same interface, a loopback occurs on the interface or a loop occurs on the network connected to the interface.

  • If LBDT packets are received by another interface on the same device, a loop occurs on the network connected to the interface or device.

After loops are detected, the device can send alarms to the NMS and record logs, and can control the interface status (the interface is shut down by default) according to the device configuration so that the impact of loops on the device and network is minimized. The device provides the following actions after LBDT detects a loop:
  • Trap: The device reports a trap to the NMS and records a log, but does not take any action on the interface.

  • Block: The device blocks this interface, and can forward only BPDUs.

  • No learning: The interface is disabled from learning MAC addresses.

  • Shutdown: The device shuts down the interface.

  • Quitvlan: The interface is removed from the VLAN where a loop occurs.

The problematic interface continues to send LBDT packets. After the configured recovery time expires, the system attempts to restore the problematic interface. If the device receives no LBDT packets from the problematic interface within the next recovery time, it considers that the loop is eliminated on the interface and restores the interface.

LBDT can only detect loops on a single node, but cannot eliminate loops on the entire network in the same manner as ring network technologies of ERPS, RRPP, SEP, Smart Link, and STP/RSTP/MSTP/VBST.

Configuration Notes

  • This example applies to all versions of all S series switches.
  • In V200R008C00 and earlier versions, LBDT does not take effect in dynamic VLANs. In V200R008C00 and later versions, the LBDT-enabled switch can detect loops in dynamic VLANs, but the Quitvlan action is invalid for dynamic VLANs.

  • LBDT needs to send a large number of LBDT packets to detect loops, occupying system resources. Therefore, disable LBDT if loops do not need to be detected.

  • LBDT cannot be configured on an Eth-Trunk or its member interfaces.

  • An interface can send LBDT packets with the specified VLAN tag only when the specified VLAN has been created.

  • LBDT can detect loops in a maximum of eight VLANs.

  • When the PVID of the interface in the loop is the detected VLAN ID or the interface joins the detected VLAN in untagged mode, VLAN tags of LBDT packets are removed. As a result, the packet priority changes and the system may fail to detect loops.

  • When the Quitvlan action is used, the configuration file remains unchanged.

  • The LBDT action and MAC address flapping action affect each other, and cannot be configured simultaneously.

  • The Quitvlan action of LBDT conflicts with dynamic removal from VLANs (for example, GVRP and HVRP), and cannot be configured simultaneously.

  • The blocked ports of LBDT cannot block GVRP packets. To ensure that GVRP runs normally and prevent GVRP loops, do not enable GVRP on the blocked port of LBDT.
  • On a modular switch, LBDT and loop detection (LDT) cannot be configured simultaneously.

Networking Requirements

In Figure 7-39, a small-scale enterprise uses Layer 2 networking and belongs to VLAN 100. Because employees often move, the network topology changes frequently. Loops occur due to incorrect connections or configurations during the change. As a result, broadcast storms occur and affect communication of the Switch and entire network.

The requirements are as follows:
  • The Switch detects loops.
  • When a loop exists, the interface is blocked to reduce the impact of the loop on the Switch and network.
  • When the loop is eliminated, the interface can be restored.
Figure 7-39  Networking for configuring LBDT to detect loops on the local network

Configuration Roadmap

To detect loops on the network where the Switch is deployed, configure LBDT on GE1/0/1 and GE1/0/2 of the Switch. In this example, untagged LBDT packets sent by the Switch will be discarded by other switches on the network. As a result, the packets cannot be sent back to the Switch, and LBDT fails. Therefore, LBDT is configured in a specified VLAN. The configuration roadmap is as follows:

  1. Enable LBDT on interfaces and configure the Switch to detect loops in VLAN 100 to implement LBDT on the network where the Switch is located.
  2. Configure an action to be taken after a loop is detected and set the recovery time. After a loop is detected, the Switch blocks the interface to reduce the impact of the loop on the network. After a loop is eliminated, the interface can be restored.
NOTE:

Configure interfaces on other switching devices as trunk or hybrid interfaces and configure these interfaces to allow packets from corresponding VLANs to pass through to ensure Layer 2 connectivity.

Procedure

  1. Enable LBDT on interfaces.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] loopback-detect enable  //Enable LBDT on the interface.
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] loopback-detect enable  //Enable LBDT on the interface.
    [Switch-GigabitEthernet1/0/2] quit

  2. Specify the VLAN ID of LBDT packets.

    [Switch] vlan 100
    [Switch-vlan100] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid  //In V200R005C00 and later versions, the default link type of a switch interface is not hybrid. You can choose run the port link-type hybrid command to configure the link type of the interface as hybrid.
    [Switch-GigabitEthernet1/0/1] port hybrid tagged vlan 100
    [Switch-GigabitEthernet1/0/1] loopback-detect packet vlan 100  //Enable LBDT to detect loops in VLAN 100.
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type hybrid
    [Switch-GigabitEthernet1/0/2] port hybrid tagged vlan 100
    [Switch-GigabitEthernet1/0/2] loopback-detect packet vlan 100  //Enable LBDT to detect loops in VLAN 100.
    [Switch-GigabitEthernet1/0/2] quit

  3. Configure an action to be taken after a loop is detected and set the recovery time.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] loopback-detect action block  //Configure the Block action to be taken after a loop is detected.
    [Switch-GigabitEthernet1/0/1] loopback-detect recovery-time 30  //Set the recovery time to 30s.
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] loopback-detect action block  //Configure the Block action to be taken after a loop is detected.
    [Switch-GigabitEthernet1/0/2] loopback-detect recovery-time 30  //Set the recovery time to 30s.
    [Switch-GigabitEthernet1/0/2] quit

  4. Verify the configuration.

    1. Run the display loopback-detect command to check the LBDT configuration.

      [Switch] display loopback-detect 
      Loopback-detect sending-packet interval:  5                                                                                         
                                                                                                                                          
      ----------------------------------------------------------------------------------                                                  
      Interface                     RecoverTime  Action     Status                                                                        
      ----------------------------------------------------------------------------------                                                  
      GigabitEthernet1/0/1          30           block      NORMAL                                                                        
      GigabitEthernet1/0/2          30           block      NORMAL 
      ----------------------------------------------------------------------------------

      The preceding command output shows that the LBDT configuration is successful.

    2. After about 5s, run the display loopback-detect command to check whether GE1/0/1 or GE1/0/2 is blocked.

      [Switch] display loopback-detect 
      Loopback-detect sending-packet interval:  5                                                                                         
                                                                                                                                          
      ----------------------------------------------------------------------------------                                                  
      Interface                     RecoverTime  Action     Status                                                                        
      ----------------------------------------------------------------------------------                                                  
      GigabitEthernet1/0/1          30           block      NORMAL                                                                        
      GigabitEthernet1/0/2          30           block      BLOCK(Loopback detected) 
      ----------------------------------------------------------------------------------

      The preceding command output shows that GE1/0/2 is blocked.

    3. Shut down GE1/0/1. After 30s, run the display loopback-detect command to check whether GE1/0/2 is restored.

      [Switch] display loopback-detect 
      Loopback-detect sending-packet interval:  5                                                                                         
                                                                                                                                          
      ----------------------------------------------------------------------------------                                                  
      Interface                     RecoverTime  Action     Status                                                                        
      ----------------------------------------------------------------------------------                                                  
      GigabitEthernet1/0/1          30           block      NORMAL                                                                        
      GigabitEthernet1/0/2          30           block      NORMAL 
      ----------------------------------------------------------------------------------

      The preceding command output shows that GE1/0/2 is restored.

Configuration Files

Switch configuration file

#
sysname Switch
#
vlan batch 100
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid tagged vlan 100
 loopback-detect recovery-time 30
 loopback-detect packet vlan 100
 loopback-detect enable
 loopback-detect action block
#
interface GigabitEthernet1/0/2
 port link-type hybrid
 port hybrid tagged vlan 100
 loopback-detect recovery-time 30
 loopback-detect packet vlan 100
 loopback-detect enable
 loopback-detect action block
#
return
Download
Updated: 2019-04-20

Document ID: EDOC1000069520

Views: 626037

Downloads: 29475

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next