No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S2700, S3700, S5700, S6700, S7700, and S9700 Series Switches Typical Configuration Examples

This document provides examples for configuring features in typical usage scenarios.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Basic Configuration

Basic Configuration

Data Plan

Network Topology

Construct a network based on the topology shown in Figure 2-15, name network devices, and configure IP addresses for network devices, service interfaces, and user interfaces on the devices.

Figure 2-15  Network topology
Interface data plan

Table 2-15 and Table 2-16 list Eth-Trunks, local interfaces, and IP addresses of local interfaces on devices.

Table 2-15  Eth-Trunks
Device Role Interface Number Member Interface

Core_SPE1

Eth-Trunk4

XGigabitEthernet5/0/4

XGigabitEthernet5/0/5

XGigabitEthernet5/0/6

XGigabitEthernet5/0/7

Eth-Trunk5

XGigabitEthernet1/0/0

XGigabitEthernet1/0/1

XGigabitEthernet1/0/2

XGigabitEthernet1/0/3

Eth-Trunk17

XGigabitEthernet6/0/0

XGigabitEthernet6/0/1

XGigabitEthernet6/0/2

XGigabitEthernet6/0/3

Core_SPE2

Eth-Trunk4

XGigabitEthernet6/0/4

XGigabitEthernet6/0/5

XGigabitEthernet6/0/6

XGigabitEthernet6/0/7

Eth-Trunk2

XGigabitEthernet3/0/4

XGigabitEthernet3/0/5

XGigabitEthernet3/0/6

XGigabitEthernet3/0/7

Eth-Trunk17

XGigabitEthernet5/0/0

XGigabitEthernet5/0/1

XGigabitEthernet5/0/2

XGigabitEthernet5/0/3

Core_SPE3

Eth-Trunk5

XGigabitEthernet1/0/0

XGigabitEthernet1/0/1

XGigabitEthernet1/0/2

XGigabitEthernet1/0/3

Eth-Trunk2

XGigabitEthernet2/0/4

XGigabitEthernet2/0/5

XGigabitEthernet2/0/6

XGigabitEthernet2/0/7

Site1_UPE1

Eth-Trunk17

XGigabitEthernet1/0/0

XGigabitEthernet1/0/1

XGigabitEthernet1/0/2

XGigabitEthernet1/0/3

Eth-Trunk7

XGigabitEthernet4/0/4

XGigabitEthernet4/0/5

XGigabitEthernet4/0/6

XGigabitEthernet4/0/7

Site1_UPE2

Eth-Trunk17

XGigabitEthernet6/0/0

XGigabitEthernet6/0/1

XGigabitEthernet6/0/2

XGigabitEthernet6/0/3

Eth-Trunk7

XGigabitEthernet6/0/4

XGigabitEthernet6/0/5

XGigabitEthernet6/0/6

XGigabitEthernet6/0/7

Table 2-16  Local Interfaces and IP Addresses
Device Role Local Interface IP Address Interface Description

Core_SPE1

LoopBack1

172.16.0.5/32

-

Eth-Trunk4

172.17.4.8/31

Core_SPE1 to Core_SPE2

Eth-Trunk5

172.17.4.2/31

Core_SPE1 to Core_SPE3

Eth-Trunk17

172.17.4.10/31

Core_SPE1 to Site1_UPE1

XGigabitEthernet6/0/4

172.17.10.2/31

Core_SPE1 to Site3_UPE6

Core_SPE2

LoopBack1

172.16.0.3/32

-

Eth-Trunk4

172.17.4.9/31

Core_SPE2 to Core_SPE1

Eth-Trunk2

172.17.4.0/31

Core_SPE2 to Core_SPE3

Eth-Trunk17

172.17.4.12/31

Core_SPE2 to Site1_UPE2

XGigabitEthernet5/0/5

172.16.8.178/31

Core_SPE2 to Site2_UPE3

Core_SPE3

LoopBack1

172.16.0.4/32

-

Eth-Trunk5

172.17.4.3/31

Core_SPE3 to Core_SPE1

Eth-Trunk2

172.17.4.1/31

Core_SPE3 to Core_SPE2

XGigabitEthernet6/0/1

172.16.8.213/31

Core_SPE3 to Site3_UPE5

XGigabitEthernet6/0/3

172.16.8.183/31

Core_SPE3 to Site2_UPE4

Site1_UPE1

LoopBack1

172.16.2.51/32

-

Eth-Trunk17

172.17.4.11/31

Site1_UPE1 to Core_SPE1

Eth-Trunk7

172.17.4.14/31

Site1_UPE1 to Site1_UPE2

XGigabitEthernet1/0/4.200

172.18.200.66/26

Site1_UPE1 to CE1

Site1_UPE2

LoopBack1

172.16.2.50/32

-

Eth-Trunk17

172.17.4.13/31

Site1_UPE2 to Core_SPE2

Eth-Trunk7

172.17.4.15/31

Site1_UPE2 to Site1_UPE1

XGigabitEthernet1/0/4.200

172.18.200.67/26

Site1_UPE2 to CE1

Site2_UPE3

LoopBack1

172.16.2.75/32

-

XGigabitEthernet0/0/1

172.16.8.179/31

Site2_UPE3 to Core_SPE2

XGigabitEthernet0/0/4

172.16.8.180/31

Site2_UPE3 to Site2_UPE4

XGigabitEthernet0/0/2.150

172.18.150.2/26

Site2_UPE3 to CE2

Site2_UPE4

LoopBack1

172.16.2.76/32

-

XGigabitEthernet0/0/1

172.16.8.182/31

Site2_UPE4 to Core_SPE3

XGigabitEthernet0/0/4

172.16.8.181/31

Site2_UPE4 to Site2_UPE3

XGigabitEthernet0/0/2.150

172.18.150.3/26

Site2_UPE4 to CE2

Site3_UPE5

LoopBack1

172.16.2.87/32

-

XGigabitEthernet0/0/4

172.16.8.212/31

Site3_UPE5 to Core_SPE3

XGigabitEthernet0/0/1

172.17.10.0/31

Site3_UPE5 to Site3_UPE6

XGigabitEthernet0/0/2.100

172.18.100.2/26

Site3_UPE5 to CE3

Site3_UPE6

LoopBack1

172.16.2.86/32

-

XGigabitEthernet0/0/4

172.17.10.3/31

Site3_UPE6 to Core_SPE1

XGigabitEthernet0/0/1

172.17.10.1/31

Site3_UPE6 to Site3_UPE5

XGigabitEthernet0/0/2.100

172.18.100.3/26

Site3_UPE6 to CE3

Configuring Device Information

Data Plan
NOTE:

The data provided in this section is used as an example, which may vary depending on the network scale and topology.

Configure device information on all devices based on the network topology.

Device information includes the site name, device role, and device number. Each device is named in the format of AA_BBX.

  • AA: indicates the site name, such as Core and Site1.
  • BB: indicates the device role, such as SPE, UPE, and CE.
  • X: indicates the device number, starting from 1.

For example, Site1_UPE1 indicates a UPE numbered 1 at site 1. The following table describes the data plan.

Parameter Value Description
sysname Site1_UPE1 Device name.

Procedure

  • Configure the device name.

    The following uses the configuration of Site1_UPE1 as an example. The configurations of other devices are similar to the configuration of Site1_UPE1, and are not mentioned here.

    sysname Site1_UPE1

Configuring Interfaces

Procedure

  1. Add physical interfaces to Eth-Trunks.

    The following uses the configuration of Core_SPE1 as an example. The configurations of other devices are similar to the configuration of Core_SPE1, and are not mentioned here.

    #
    interface XGigabitEthernet1/0/0
     eth-trunk 5
    #
    interface XGigabitEthernet1/0/1
     eth-trunk 5
    #
    interface XGigabitEthernet1/0/2
     eth-trunk 5
    #
    interface XGigabitEthernet1/0/3
     eth-trunk 5
    #
    interface XGigabitEthernet5/0/4
     eth-trunk 4
    #
    interface XGigabitEthernet5/0/5
     eth-trunk 4
    #
    interface XGigabitEthernet5/0/6
     eth-trunk 4
    #
    interface XGigabitEthernet5/0/7
     eth-trunk 4
    #
    interface XGigabitEthernet6/0/0
     eth-trunk 17
    #
    interface XGigabitEthernet6/0/1
     eth-trunk 17
    #
    interface XGigabitEthernet6/0/2
     eth-trunk 17
    #
    interface XGigabitEthernet6/0/3
     eth-trunk 17
    #

  2. Configure descriptions and IP addresses for interfaces.

    The following uses the configuration of Core_SPE1 as an example. The configurations of other devices are similar to the configuration of Core_SPE1, and are not mentioned here.

    #
    interface Eth-Trunk4
     undo portswitch
     description Core_SPE1 to Core_SPE2
     ip address 172.17.4.8 255.255.255.254
    #
    interface Eth-Trunk5
     undo portswitch
     description Core_SPE1 to Core_SPE3
     ip address 172.17.4.2 255.255.255.254
    #
    interface Eth-Trunk17
     undo portswitch
     description Core_SPE1 to Site1_UPE1
     ip address 172.17.4.10 255.255.255.254
    #
    interface XGigabitEthernet6/0/4
     undo portswitch
     description Core_SPE1 to Site3_UPE6
     ip address 172.17.10.2 255.255.255.254
    #
    interface LoopBack1
     description ** GRT Management Loopback **
     ip address 172.16.0.5 255.255.255.255
    #

  3. Configure Eth-Trunks to function as 40GE interfaces.

    Run the least active-linknumber 4 command on Eth-Trunks of all S9700 switches to configure the Eth-Trunks to function as 40GE interfaces. If a member interface of an Eth-Trunk goes Down, the Eth-Trunk goes Down. The following uses the configuration of Core_SPE1 as an example. The configurations of other devices are similar to the configuration of Core_SPE1, and are not mentioned here.

    #
    interface Eth-Trunk4
     least active-linknumber 4
    #
    interface Eth-Trunk5
     least active-linknumber 4
    #
    interface Eth-Trunk17
     least active-linknumber 4
    #

  4. Create Eth-Trunk load balancing profiles and apply the profiles to Eth-Trunks.

    Configure load balancing based on the source and destination port numbers. The following uses the configuration of Core_SPE1 as an example. The configurations of other devices are similar to the configuration of Core_SPE1, and are not mentioned here.

    #
    load-balance-profile CUSTOM
     ipv6 field l4-sport l4-dport
     ipv4 field l4-sport l4-dport
    #
    interface Eth-Trunk4
     load-balance enhanced profile CUSTOM
    #
    interface Eth-Trunk5
     load-balance enhanced profile CUSTOM
    #
    interface Eth-Trunk17
     load-balance enhanced profile CUSTOM
    #

  5. Disable STP globally.

    All devices on the entire network are connected through Layer 3 interfaces, and Layer 2 loop prevention protocols are not required. Therefore, disable STP globally. The following uses the configuration of Core_SPE1 as an example. The configurations of other devices are similar to the configuration of Core_SPE1, and are not mentioned here.

    #
    stp disable
    #

Enabling BFD

Context

To implement protection switching within 50 ms, set the minimum interval at which BFD packets are sent and received to 3.3 ms. The restraints on switches are as follows:
  • For the S12700, the MPU must be an ET1D2MPUA000/ET1D2MPUDC00 card.
  • For the S9700, the MPU must be an EH1D2SRUDC00/EH1D2SRUDC01 card.
  • For the S7700, the MPU must have an ES0D00FSUA00 card installed or be an EH1D2SRUDC00/EH1D2SRUDC01 card.
  • For the S7706/S7706 PoE or S7712, the assign system-resource-mode static command must be run to set the resource allocation mode to static so that the BFD detection duration can be controlled within 50 ms.
  • For the S5720HI, S5730HI or S6720HI, the set service-mode enhanced command must be run to configure the switch to work in enhanced mode.

Procedure

  • Configure SPEs.

    The following uses the configuration of Core_SPE1 on the core ring as an example. The configurations of Core_SPE2 and Core_SPE3 are similar to the configuration of Core_SPE1, and are not mentioned here.

    #
    bfd
    #

  • Configure UPEs.

    The following uses the configuration of Site1_UPE1 as an example. The configurations of Site1_UPE2, Site2_UPE3, Site2_UPE4, Site3_UPE5, and Site3_UPE6 are similar to the configuration of Site1_UPE1, and are not mentioned here.

    #
    bfd
    #

Download
Updated: 2019-04-20

Document ID: EDOC1000069520

Views: 661104

Downloads: 29835

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next