No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR Router Troubleshooting Guide

This Product Documentation provides guidance for maintaining AR Enterprise Router, covering common information collection and fault diagnostic commands, typical fault troubleshooting guide, and troubleshooting.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
In AR Multi-Egress Scenarios, the Internet Access Speed Is Slow After NAT Is Configured on an Interface of a High-End LAN Card

In AR Multi-Egress Scenarios, the Internet Access Speed Is Slow After NAT Is Configured on an Interface of a High-End LAN Card

This section provides a case that the Internet access speed is slow after NAT is configured on an interface of a high-end LAN card in AR multi-egress scenarios.

Networking

Figure 28-4  Networking diagram

Fault Symptom

In Figure1, the AR functions as an enterprise gateway and has four interfaces connected to the carrier network. The four interfaces have been configured with fixed IP addresses. When a user uses any one of the four links, the web page browsing speed and data download speed are normal. However, if multiple links are used at the same time, web page browsing and data download are slow.

The AR configuration is as follows:

#
interface Vlanif100
 ip address 10.1.1.1 255.255.255.0
 dhcp select interface
 dhcp server dns-list 10.1.1.1 
#
interface Vlanif10 
 ip address 10.2.1.1 255.255.255.252
 nat outbound 2000
#
interface GigabitEthernet1/0/0 
 ip address 10.3.1.1 255.255.255.252
 nat outbound 2000
#
interface GigabitEthernet1/0/1 
 ip address 10.4.1.1 255.255.255.252
 nat outbound 2000
#
interface GigabitEthernet1/0/2 
 ip address 10.5.1.1 255.255.255.252
 nat outbound 2000
#
ip route-static 0.0.0.0 0.0.0.0 10.2.1.2 
ip route-static 0.0.0.0 0.0.0.0 10.3.1.2 
ip route-static 0.0.0.0 0.0.0.0 10.4.1.2 
ip route-static 0.0.0.0 0.0.0.0 10.5.1.2

Fault Analysis

  1. Check whether one of the four links is faulty. Run the shutdown command on the outbound interfaces of the four links to disconnect the links. The fault persists.
  2. Check whether the fault is caused by load balancing. Run the ip load-balance hash src-ip command in the system view to enable load balancing based on source IP addresses. The fault persists.
  3. Check whether the fault is caused by packet fragmentation. Run the tcp adjust-mss command on outbound interfaces of the four links to change the MSS of TCP packets to 1200. It is found that the improvement is not obvious. The fault persists.
  4. Check whether the fault is caused by STP. Run the undo stp enable command in the system view to disable STP. The test result shows that the Internet access speed increases but does not meet the customer's bandwidth requirement. The fault persists.
  5. Check whether the fault is caused by forwarding. Because the interface of link 1 is on an 8FE1GE board, run the set workmode lan-card l3centralize command in the system view to disable the routing and forwarding function of high-end LAN cards (8FE1GE and 24GE cards). The test result shows that the Internet access speed and download speed are normal. The fault has been rectified.

Procedure

  1. Run the system-view command to enter the system view.
  2. Run the set workmode lan-card l3centralize command to disable the routing and forwarding function of high-end LAN cards (8FE1GE and 24GE cards).

Suggestion

If multi-egress forwarding is abnormal, you can rectify the fault by checking link quality, link load balancing, interface TCP MSS, STP, and high-end LAN card forwarding.

Translation
Download
Updated: 2019-05-10

Document ID: EDOC1000079719

Views: 443806

Downloads: 4295

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next