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AR Router Troubleshooting Guide

This Product Documentation provides guidance for maintaining AR Enterprise Router, covering common information collection and fault diagnostic commands, typical fault troubleshooting guide, and troubleshooting.
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PPPoE Dial-up Service Cannot Be Used and the Network Access Rate Is Low

PPPoE Dial-up Service Cannot Be Used and the Network Access Rate Is Low

Keywords

PPPoE, dial-up, unavailable service, low rate

Abstract

The rate of Internet access using PPPoE dial-up is low.

Problem Description

A device connects to the Internet through two WAN interfaces. The device can normally access the Internet through one WAN interface using a fixed IP address. However, the device cannot properly access the Internet through the other WAN interface using PPPoE dial-up. The network access rate is low and a web page is displayed after it is refreshed multiple times.

Procedure

  1. The "PC-router-Internet" networking is tested and services are also abnormal.

    If the WAN interface using a fixed IP address is changed to use PPPoE dial-up, the fault also occurs. If the WAN interface using PPPoE dial-up is changed to use a fixed IP address, the device can normally access the Internet through the interface. The ISP remains unchanged.

  1. The "PC-Internet" networking is tested and no fault occurs. Therefore, the PC works properly.
  2. Run the tcp adjust-mss command to set the TCP MSS value of the dial-up interface to 1400, 1200, or 900. The fault persists.
  3. In the "PC-router-Internet" networking, only one WAN interface using PPPoE dial-up is tested and the fault persists. Run the display health and display interface commands. The command outputs show that the CPU usage and uplink bandwidth usage of the interface are normal, and the interface is negotiated to work in full-duplex mode.
  4. Run the display fe slot 0 fe-id 0 fwd-status all command to check the packet forwarding status of the device. No severe packet loss occurs.
    <Huawei> system
    [Huawei] diagnose
    [Huawei-diagnose] display fe slot 0 fe-id 0 fwd-status all
     ********************** FPA  POOL  STATE ***********************
           FPA  INT SUM :  0x0000000000000000
           FPA  POOL  0 :  487 
           FPA  POOL  1 :  21483 
           FPA  POOL  2 :  124 
           FPA  POOL  3 :  2041 
           FPA  POOL  4 :  0 
           FPA  POOL  5 :  2036 
           FPA  POOL  6 :  0 
           FPA  POOL  7 :  3072 
     
     ********* PKO  STATE (Only show abnormal PKO Queues) **********
     
     ************** Thread Active State Counter Value ***************
          Thread Id  1 :   0x00000000303e3524
          Thread Id  2 :   0x00000000335c1d64
          Thread Id  3 :   0x0000000030abdc44
     
     ********************* VFP_OCTEON_GET_STATS *********************
     VFP_OCTEON_STATS( port: 0 ),
          rx_pkts 2831557901,
          tx_pkts 2581402565,
          rx_bytes 2000777919,
          tx_bytes 2917281127,
          rx_crc_err 0,                      
          rx_frame_err 1,
          rx_dropped_packets 0
  1. Run the display session number command to check the number of session entries on the device. In peak hours, the number reaches the performance bottleneck of 16K.
    [Huawei] display session number
      The total number of session tables is: 16100
    [Huawei] display session number
      The total number of session tables is: 16045
    [Huawei] display session number
      The total number of session tables is: 16002
  1. Optimize NAT deployment on the intranet interface so that the number of session entries is smaller than the maximum value and users can normally access the Internet.
    #
    vlan batch 2 
    #
    acl number 3002 
     rule 5 permit ip source 192.168.2.0 0.0.0.255 destination 1.1.1.2 0 
    #
    interface Vlanif2   
     ip address 192.168.2.1 255.255.255.0    
     nat outbound 3002
    #
    return

Root Cause

  1. The AR router is tested. The test result shows that the router can normally forward packets, and the forwarding bottleneck is reached sometimes.
  2. According to analysis of obtained packets, the TCP connection has been established and enters the data obtaining phase. However, the device receives RST packets (No. 15136 and No. 15137) from the Internet. As a result, the TCP connection is torn down.

    When the device receives RST packets, the TCP connection is abnormal and the RST flag needs to be set. If the device receives RST packets, you need to check both the local and remote devices.

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Updated: 2019-08-09

Document ID: EDOC1000079719

Views: 492115

Downloads: 4523

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