No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR Router Troubleshooting Guide

This Product Documentation provides guidance for maintaining AR Enterprise Router, covering common information collection and fault diagnostic commands, typical fault troubleshooting guide, and troubleshooting.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
A Link Flapping Occurs If an NQA Test Instance Is Used to Detect 3G Links

A Link Flapping Occurs If an NQA Test Instance Is Used to Detect 3G Links

This section provides a troubleshooting case for the following fault: When an NQA test instance is used on an AR router to detect 3G links, a link flapping occurs because NQA test parameters are incorrectly configured.

Networking

Figure 15-8 Networking diagram for configuring 3G dual-uplink access to the Internet

Configurations of RouterA:

#
  sysname RouterA 
#
 vlan batch 10 
#
  dhcp enable 
#
acl number 3002
  rule 5 permit ip source 10.10.10.0 0.0.0.255   
# 
ip pool 3gpool
  gateway-list 10.10.10.254
  network 10.10.10.0 mask 255.255.255.0  
# 
interface Vlanif10
  ip address 10.10.10.1 255.255.255.0
  dhcp select global    
# 
interface Ethernet2/0/0
  port link-type trunk
  port trunk allow-pass vlan 10   
# 
interface Cellular0/0/0
  link-protocol ppp
  ppp ipcp dns request
  dialer enable-circular
  apn-profile 3gprofile1
  dialer timer autodial 10
  dialer number *99# autodial
  standby interface Cellular0/0/1
  nat outbound 3002
  ip address negotiate 
# 
interface Cellular0/0/1 
  link-protocol ppp
  ppp ipcp dns request
  dialer enable-circular
  apn-profile 3gprofile2
  dialer timer autodial 10
  dialer number #777 autodial
  nat outbound 3002  
  ip address negotiate
  modem auto-recovery track nqa admin Cellular1 probe-cycle 1
  modem auto-recovery track action plmn-search fail-times 1
# 
apn profile 3gprofile1
  user name 3guser1 password cipher %@%@}7g|@uc0bBQM%]VMM28)3U".%@%@ authentication-mode auto  
  apn 3GNET
apn profile 3gprofile2
  user name 3guser2 password cipher %@%@}6w|@uc0bBQM%]VMM28)3B".%@%@ authentication-mode auto 
# 
nqa test-instance admin Cellular0/0/1
  test-type icmp 
  frequency 15
  probe-count 5
  start now
#
ip route-static 0.0.0.0 0.0.0.0 Cellular0/0/0 preference 40 
ip route-static 0.0.0.0 0.0.0.0 Cellular0/0/1 preference 80 
# 
return

Fault Description

When an NQA test instance is used on RouterA to detect 3G links, the Cellular0/0/1 interface alternates between Up and Down.

Fault Analysis

  1. Cellular0/0/1 alternates between Up and Down, indicating that the 3G link route is reachable but the signals are unstable.
  2. If the number of NQA detection failures is 1, the device searches for the PLMN again to restore the 3G/LTE link. When the 3G link is unstable or faulty, the detection result of the NQA ICMP test instance is failure. In this case, the device searches for the PLMN again within 1 minute to restore the 3G link. Automatic test execution takes 15 seconds. During the PLMN search, the 3G link is not restored and the device is associated to search for the PLMN again. As a result, the 3G link alternates between Up and Down.

Procedure

Set the period for the device to detect the 3G/LTE link status using an NQA test instance to 4 minutes and set the interval between two tests using the test instance admin Cellular0/0/1 to 60 seconds.

<RouterA> system-view
[RouterA] interface cellular 0/0/0
[RouterA-Cellular0/0/0] modem auto-recovery track nqa admin Cellular1 probe-cycle 4
[RouterA-Cellular0/0/0] quit
[RouterA] nqa test-instance admin Cellular0/0/1
[RouterA-nqa-admin-Cellular0/0/1] frequency 60

Conclusions and Suggestions

In an ICMP test instance, the value of frequency (automatic test execution interval) must be greater than the value of interval (interval for the NQA test instance to send packets) multiplied by the value of probe-count(number of probes to be sent each time for the NQA test instance). The default value of interval is 4 seconds. You are advised to set probe-count to 3 or 4, and set frequency to a value greater than the value of interval multiplied by the value of probe-count to prevent mutual interference when multiple ICMP tests are performed simultaneously.

Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000079719

Views: 494420

Downloads: 4527

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next