No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR Router Troubleshooting Guide

This Product Documentation provides guidance for maintaining AR Enterprise Router, covering common information collection and fault diagnostic commands, typical fault troubleshooting guide, and troubleshooting.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Association Between VRRP and the Interface Status

Example for Configuring Association Between VRRP and the Interface Status

Networking Requirements

As shown in Figure 29-44, hosts on a LAN are dual-homed to RouterA and RouterB through the switch. A VRRP group is established on RouterA and RouterB, and RouterA is the master.

When GE1/0/0 on RouterA becomes faulty, the VRRP group can immediately detect the fault and an active/standby switchover is performed. RouterB then continues to forward services. This reduces the impact of the fault on service transmission.

Figure 29-44 Network diagram for configuring association between VRRP and the interface status

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface and configure a routing protocol to ensure network connectivity.
  2. Configure a VRRP group on RouterA and RouterB, set a higher priority for RouterA so that RouterA functions as the master to forward traffic, and set a lower priority for routerB so that routerB functions as the backup.
  3. Configure association between VRRP and GE1/0/0. When the link between RouterA and RouterC becomes faulty, the VRRP group can immediately detect the fault and an active/standby switchover is performed.

Procedure

  1. Configure devices to ensure network connectivity.

    # Assign an IP address to each interface. RouterA is used as an example. The configurations of RouterB and RouterC are similar to the configuration of RouterA, and are not mentioned here.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 10.1.1.1 24
    [RouterA-GigabitEthernet2/0/0] quit
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 192.168.1.1 24
    [RouterA-GigabitEthernet1/0/0] quit

    # Configure OSPF between RouterA, RouterB, and RouterC. RouterA is used as an example. The configurations of RouterB and RouterC are similar to the configuration of RouterA, and are not mentioned here.

    [RouterA] ospf 1
    [RouterA-ospf-1] area 0
    [RouterA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] quit
    [RouterA-ospf-1] quit

  2. Configure VRRP groups.

    # Configure VRRP group 1 on RouterA, and set the priority of RouterA to 120 and the preemption delay to 20s.

    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] vrrp vrid 1 virtual-ip 10.1.1.3
    [RouterA-GigabitEthernet2/0/0] vrrp vrid 1 priority 120
    [RouterA-GigabitEthernet2/0/0] vrrp vrid 1 preempt-mode timer delay 20
    [RouterA-GigabitEthernet2/0/0] quit

    # Configure VRRP group 1 on RouterB. RouterB uses default value 100.

    [RouterB] interface gigabitethernet 2/0/0
    [RouterB-GigabitEthernet2/0/0] vrrp vrid 1 virtual-ip 10.1.1.3
    [RouterB-GigabitEthernet2/0/0] quit

  3. Configure association between VRRP and the interface status.

    # Configure association between VRRP and the interface status on RouterA. When GE1/0/0 becomes Down, the priority of RouterA decreases by 40.

    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] vrrp vrid 1 track interface gigabitethernet 1/0/0 reduced 40
    [RouterA-GigabitEthernet2/0/0] quit

  4. Verify the configuration.

    # After the configuration is complete, run the display vrrp command on RouterA and RouterB. RouterA is the master, RouterB is the backup, and the associated interface is in Up state.

    [RouterA] display vrrp
      GigabitEthernet2/0/0 | Virtual Router 1
        State          : Master
        Virtual IP       : 10.1.1.3
        Master IP        : 10.1.1.1
        PriorityRun      : 120
        PriorityConfig   : 120
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 20 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth Type        : NONE
        Virtual Mac      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp              
        Backup-forward   : disabled
        Track IF         : GigabitEthernet1/0/0   Priority reduced : 40
        IF state       : UP
        Create time      : 2012-05-22 17:32:56
        Last change time : 2012-05-22 17:33:00
    
    [RouterB] display vrrp
      GigabitEthernet2/0/0 | Virtual Router 1
        State          : Backup
        Virtual IP       : 10.1.1.3
        Master IP        : 10.1.1.1
        PriorityRun      : 100
        PriorityConfig   : 100
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 0 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth Type        : NONE
        Virtual Mac      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time      : 2012-05-22 17:33:00
        Last change time : 2012-05-22 17:33:04

    # Run the shutdown command on GE1/0/0 of RouterA to simulate a link fault. Run the display vrrp command on RouterA and RouterB. You can see that RouterA switches to the Backup state, RouterB switches to the Master state, and the associated interface is in Down state.

    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] shutdown
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] display vrrp
      GigabitEthernet2/0/0 | Virtual Router 1
        State          : Backup
        Virtual IP       : 10.1.1.3
        Master IP        : 10.1.1.2
        PriorityRun      : 80
        PriorityConfig   : 120
        MasterPriority   : 100
        Preempt          : YES   Delay Time : 20 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth Type        : NONE
        Virtual Mac      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp             
        Backup-forward   : disabled
        Track IF         : GigabitEthernet1/0/0   Priority reduced : 40
        IF state       : DOWN
        Create time      : 2012-05-22 17:33:56
        Last change time : 2012-05-22 17:34:00
    
    [RouterB] display vrrp
      GigabitEthernet2/0/0 | Virtual Router 1
        State          : Master
        Virtual IP       : 10.1.1.3
        Master IP        : 10.1.1.2
        PriorityRun      : 100
        PriorityConfig   : 100
        MasterPriority   : 100
        Preempt          : YES   Delay Time : 0 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth Type        : NONE
        Virtual Mac      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time      : 2012-05-22 17:34:00
        Last change time : 2012-05-22 17:34:04

    # Run the undo shutdown command on GE1/0/0 of RouterA. Run the display vrrp command on RouterA and RouterB. After 20s, you can see that RouterA restores to be the master, RouterB restores to be the backup, and the associated interface is in Up state.

    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] undo shutdown
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] display vrrp
      GigabitEthernet2/0/0 | Virtual Router 1
        State          : Master
        Virtual IP       : 10.1.1.3
        Master IP        : 10.1.1.1
        PriorityRun      : 120
        PriorityConfig   : 120
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 20 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth Type        : NONE
        Virtual Mac      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Track IF         : GigabitEthernet1/0/0   Priority reduced : 40
        IF state       : UP
        Create time      : 2012-05-22 17:34:56
        Last change time : 2012-05-22 17:35:00
    
    [RouterB] display vrrp
      GigabitEthernet2/0/0 | Virtual Router 1
        State          : Backup
        Virtual IP       : 10.1.1.3
        Master IP        : 10.1.1.1
        PriorityRun      : 100
        PriorityConfig   : 100
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 0 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth Type        : NONE
        Virtual Mac      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time      : 2012-05-22 17:35:00
        Last change time : 2012-05-22 17:35:04

Configuration Files

  • RouterA configuration file

    #
    sysname RouterA
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.3
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 20
     vrrp vrid 1 track interface GigabitEthernet1/0/0 reduced 40
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 10.1.1.0 0.0.0.255
    #
    return
  • RouterB configuration file

    #
    sysname RouterB
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.2.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.3
    #
    ospf 1
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 10.1.1.0 0.0.0.255
    #
    return
  • RouterC configuration file

    #
    sysname RouterC
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.2.2 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000079719

Views: 489967

Downloads: 4503

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next