No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR Router Troubleshooting Guide

This Product Documentation provides guidance for maintaining AR Enterprise Router, covering common information collection and fault diagnostic commands, typical fault troubleshooting guide, and troubleshooting.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
How to Configure One-Armed Routing

How to Configure One-Armed Routing

Networking Requirements

One-armed routing allows configuring sub-interfaces on a router interface to enable users on different network segments and in different VLANs to communicate with each other.

In Figure 29-29, department 1 and department 2 of an enterprise use the same Internet services but belong to different VLANs and are located on different network segments. Users in department 1 and department 2 need to communicate in addition to accessing the Internet.

Figure 29-29 Configuring one-armed routing

Configuration Roadmap

The configuration roadmap is as follows:

  1. Set the ID of the VLAN that each interface belongs to.

  2. Configure sub-interfaces as Dot1q termination sub-interfaces.

  3. Configure IP addresses for sub-interfaces.

Procedure

  1. Configure VLANs for interfaces of RouterA and RouterB.

    # Add the uplink interface and user-side interface of RouterA into VLAN 10 in tagged mode and untagged mode respectively.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] vlan batch 10
    [RouterA] interface ethernet 2/0/1
    [RouterA-Ethernet2/0/1] port link-type access
    [RouterA-Ethernet2/0/1] port default vlan 10
    [RouterA-Ethernet2/0/1] quit
    [RouterA] interface ethernet 2/0/2
    [RouterA-Ethernet2/0/2] port link-type trunk
    [RouterA-Ethernet2/0/2] port trunk allow-pass vlan 10
    [RouterA-Ethernet2/0/2] quit
    

    # Add the uplink interface and user-side interface of RouterB into VLAN 20 in tagged mode and untagged mode respectively.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] vlan batch 20
    [RouterB] interface ethernet 2/0/1
    [RouterB-Ethernet2/0/1] port link-type access
    [RouterB-Ethernet2/0/1] port default vlan 20
    [RouterB-Ethernet2/0/1] quit
    [RouterB] interface ethernet 2/0/2
    [RouterB-Ethernet2/0/2] port link-type trunk
    [RouterB-Ethernet2/0/2] port trunk allow-pass vlan 20
    [RouterB-Ethernet2/0/2] quit
    

  2. Configure the interface that connects the Router to RouterA.

    # Create and configure an Ethernet sub-interface GE1/0/0.1.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] interface gigabitEthernet 1/0/0.1
    [Router-GigabitEthernet1/0/0.1] dot1q termination vid 10
    [Router-GigabitEthernet1/0/0.1] ip address 10.10.10.1 24
    [Router-GigabitEthernet1/0/0.1] arp broadcast enable
    [Router-GigabitEthernet1/0/0.1] quit
    

  3. Configure the interface that connects the Router to RouterB.

    # Create and configure an Ethernet sub-interface GE2/0/0.1.

    [Router] interface gigabitEthernet 2/0/0.1
    [Router-GigabitEthernet2/0/0.1] dot1q termination vid 20
    [Router-GigabitEthernet2/0/0.1] ip address 10.10.20.1 24
    [Router-GigabitEthernet2/0/0.1] arp broadcast enable
    [Router-GigabitEthernet2/0/0.1] quit
    

  4. Verify the configuration.

    # On PC1 in VLAN 10, set the IP address 10.10.10.1/24 of GE1/0/0.1 as the default gateway address.

    # On PC2 in VLAN 20, set the IP address 10.10.20.1/24 of GE2/0/0.1 as the default gateway address.

    After the preceding configurations are complete, PC1 in VLAN 10 and PC2 in VLAN 20 can communicate.

Configuration Files

  • Router configuration file
    #
    sysname Router
    #
    interface GigabitEthernet1/0/0.1
     dot1q termination vid 10
     ip address 10.10.10.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0.1
     dot1q termination vid 20
     ip address 10.10.20.1 255.255.255.0
    #
    return
    
  • RouterA configuration file
    #
    sysname RouterA
    #
    vlan batch 10
    #
    interface Ethernet2/0/1
     port link-type access
     port default vlan 10
    #
    interface Ethernet2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
  • RouterB configuration file
    #
    sysname RouterB
    #
    vlan batch 20
    #
    interface Ethernet2/0/1
     port link-type access
     port default vlan 20
    #
    interface Ethernet2/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
    
Translation
Download
Updated: 2019-08-09

Document ID: EDOC1000079719

Views: 492174

Downloads: 4523

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next