No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Multicast

AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R007

This document describes the principles and configurations of IP multicast, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IGMP Limit

Example for Configuring IGMP Limit

Networking Requirements

In Figure 2-21, a large number of receiver hosts on the network receive video streams in multicast mode. During peak usage periods, many users stream videos at the same time, consuming a large amount of bandwidth. As a result, performance of network devices degrades, and multicast data cannot be sent to user hosts in a stable manner.

The number of programs ordered by hosts must be limited. When the limit is reached, users cannot start streaming new video. This ensures that the current videos the users are streaming are delivered with a high quality. HostA connected to RouterA frequently requests high-quality video streams of group 225.1.1.3.

Figure 2-21  Network diagram for IGMP limit configuration

Configuration Roadmap

To meet the preceding requirements, you need to configure static multicast group 225.1.1.3 on RouterA's interface connected to the network segment of HostA, and configure an IGMP limit to restrict the number of IGMP entries on the routers. The configuration roadmap is as follows:

  1. To ensure that data sent from multicast sources can be correctly forwarded to the user network segments, configure a unicast routing protocol on the network to implement IP interworking. Multicast routing protocols are dependent on unicast routing protocols.

  2. To enable the routers to forward video streams to the hosts in multicast mode, configure basic multicast functions on the routers.

  3. To allow HostA to receive high-quality video streams of group 225.1.1.3 any time, configure static group 225.1.1.3 on RouterA's interface connected to the network segment of HostA.

  4. To control the number of videos that hosts can stream, configure an IGMP limit on the routers. The IGMP limit does not affect the static multicast group configured on the interface and can ensure video quality for this group.

Procedure

  1. Configure IP addresses for interfaces and configure a unicast routing protocol on each router.

    # Configure IP addresses and masks for router interfaces according to Figure 2-21. Configure Open Shortest Path First (OSPF) on the routers to implement IP interworking and dynamic route update. The configurations of RouterB, RouterC, and RouterD are similar to the configuration of RouterA, and are not mentioned here. See Configuration Files.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.110.1.1 24
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 192.168.1.1 24
    [RouterA-GigabitEthernet2/0/0] quit
    [RouterA] ospf
    [RouterA-ospf-1] area 0
    [RouterA-ospf-1-area-0.0.0.0] network 10.110.1.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] quit
    [RouterA-ospf-1] quit

  2. Enable IP multicast routing on all the routers and enable Protocol Independent Multicast Sparse Mode (PIM-SM) on all interfaces.

    # Enable IP multicast routing on RouterA and enable PIM-SM on all its interfaces. The configurations of RouterB, RouterC, and RouterD are similar to the configuration of RouterA, and are not mentioned here. See Configuration Files.

    [RouterA] multicast routing-enable
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] pim sm
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] pim sm
    [RouterA-GigabitEthernet2/0/0] quit
    

  3. Configure a static rendezvous point (RP).

    # Configure a static RP on RouterA. Specify the IP address of GE4/0/0 on RouterD as the static RP address. The configurations of RouterB, RouterC, and RouterD are similar to the configuration of RouterA, and are not mentioned here. See Configuration Files.

    [RouterA] pim
    [RouterA-pim] static-rp 192.168.4.1
    [RouterA-pim] quit
    

  4. Enable IGMP on the interfaces connected to the user network segments.

    # Enable IGMP on GE1/0/0 of RouterA. The configurations of RouterB and RouterC are similar to the configuration of RouterA, and are not mentioned here. See Configuration Files.

    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] igmp enable
    [RouterA-GigabitEthernet1/0/0] quit
    

  5. Configure a static multicast group.

    # Statically bind GE1/0/0 of RouterA to multicast group 225.1.1.3, so that HostA connected to GE1/0/0 can receive stable multicast data of this group.

    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] igmp static-group 225.1.1.3
    [RouterA-GigabitEthernet1/0/0] quit
    

  6. Set the maximum number of IGMP entries on last-hop routers.

    # Set the maximum number of IGMP entries on RouterA to 50.

    [RouterA] igmp global limit 50

    # Set the maximum number of IGMP entries in the public network instance to 40.

    [RouterA] igmp
    [RouterA-igmp] limit 40
    [RouterA-igmp] quit
    

    # Set the maximum number of IGMP entries on GE1/0/0 to 30.

    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] igmp limit 30 
    [RouterA-GigabitEthernet1/0/0] quit

    The configurations of RouterB and RouterC are similar to the configuration of RouterA, and are not mentioned here. See Configuration Files.

  7. Verify the configuration.

    # Run the display igmp interface command to check the IGMP configuration and running status on router interfaces. The IGMP command output on GE1/0/0 of RouterA is as follows:

    <RouterA> display igmp interface gigabitethernet 1/0/0
    Interface information of VPN-Instance: public net 
     GigabitEthernet1/0/0(10.110.1.1):
      IGMP is enabled
      Current IGMP version is 2
      IGMP state: up
      IGMP group policy: none
      IGMP limit: 30
      Value of query interval for IGMP (negotiated): -
      Value of query interval for IGMP (configured): 60 s
      Value of other querier timeout for IGMP: 0 s
      Value of maximum query response time for IGMP: 10 s
      Querier for IGMP: 10.110.1.1 (this router)
     Total 1 IGMP Group reported
    
    

    You can see that a maximum of 30 IGMP group memberships can be created on GE1/0/0 of RouterA.

    # Run the display igmp group interface gigabitethernet 1/0/0 static verbose command to check detailed information about the interface on which a static multicast group is configured.

    <RouterA> display igmp group interface gigabitethernet 1/0/0 static verbose
    Static join group information of VPN-Instance: public net
     Total 1 entry
      00001.(*, 225.1.1.3)
          1.GigabitEthernet1/0/0
              State:             UP
              Reference Count:   1
              Multicast Boundary:NO
              Outgoing Interface:NO
    

    The command output shows that static multicast group 225.1.1.3 is configured on GE1/0/0 of RouterA.

    # Run the display pim routing-table command to check the PIM-SM multicast routing table on each router.

    <RouterA> display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.3)
         RP: 192.168.4.1
         Protocol: pim-sm, Flag: WC
         UpTime: 00:21:35
         Upstream interface: GigabitEthernet2/0/0
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: static igmp, UpTime: 00:21:35, Expires: -
    
     (193.3.5.2, 225.1.1.3)
         RP: 192.168.4.1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:42:46
         Upstream interface: GigabitEthernet2/0/0
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: pim-sm, UpTime: 00:21:35, Expires: - 
    
    

    The command output shows that (*, 225.1.1.3) and (193.3.5.2, 225.1.1.3) entries exist on RouterA, indicating that GE1/0/0 has joined group 225.1.1.3 and can receive multicast data sent from 193.3.5.2 to 225.1.1.3.

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    igmp global limit 50 
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 10.110.1.1 255.255.255.0
     pim sm
     igmp enable
     igmp limit 30
     igmp static-group 225.1.1.3
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
     network 10.110.1.0 0.0.0.255
     network 192.168.1.0 0.0.0.255
    #
    igmp 
     limit 40
    #
    pim
     static-rp 192.168.4.1 
    #
    return
    
  • RouterB configuration file

    #
     sysname RouterB
    #
    igmp global limit 50 
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
     igmp limit 30
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
     network 10.110.2.0 0.0.0.255
     network 192.168.2.0 0.0.0.255
    #
    igmp 
     limit 40
    #
    pim
     static-rp 192.168.4.1 
    #
    return
  • RouterC configuration file

    #
     sysname RouterC
    #
    igmp global limit 50 
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 10.110.2.2 255.255.255.0
     pim sm
     igmp enable
     igmp limit 30
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
     network 10.110.2.0 0.0.0.255
     network 192.168.3.0 0.0.0.255
    #
    igmp 
     limit 40
    #
    pim
     static-rp 192.168.4.1 
    #
    return
  • RouterD configuration file

    #
     sysname RouterD
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet3/0/0
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet4/0/0
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
     network 192.168.1.0 0.0.0.255
     network 192.168.2.0 0.0.0.255
     network 192.168.3.0 0.0.0.255
     network 192.168.4.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.1 
    #
    return
Translation
Download
Updated: 2019-06-12

Document ID: EDOC1000097181

Views: 20393

Downloads: 401

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next