No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Multicast

AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R007

This document describes the principles and configurations of IP multicast, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Multicast VPN Extranet in the Scenario Where the Multicast Source Is on the Public Network

Example for Configuring Multicast VPN Extranet in the Scenario Where the Multicast Source Is on the Public Network

In a multicast network, you can deploy a multicast routing policy for a specified VPN instance. In this manner, the user hosts in this instance can receive multicast data from the multicast source in the public network instance.

Networking Requirements

In current multicast VPN applications, only VPN sites in the same VPN can transmit multicast traffic between each other. Inter-VPN multicast traffic transmission, however, is not supported.

In actual situations, it is common that two enterprises in different VPNs need to communicate or a service provider needs to provide multicast services for multiple customers but the service provider and the customers are in different VPNs. Therefore, inter-VPN multicast service transmission becomes necessary so that multicast data from a user in one VPN can reach users in other VPNs.

In a multicast network shown in Figure 7-31, Receiver in VPN RED wants to receive multicast data from Source on the public network. To meet such a requirement, you can deploy a multicast routing policy on the network so that Receiver in VPN RED can receive multicast data from Source in the public network.

NOTE:

In such a scenario, Source is on the public network whereas Receiver is in a VPN. The public network and receiver VPN can be only PIM-SM/Source-Specific Multicast (SSM) networks.

Figure 7-31  Networking diagram for configuring multicast VPN extranet in the scenario where the multicast source is on the public network

Device Interface IP Address
PE1 POS 1/0/0 192.168.1.1/24
GE 2/0/0 192.168.3.1/24
Loopback1 1.1.1.1/32
P POS 1/0/0 192.168.1.2/24
POS 2/0/0 192.168.2.1/24
PE2 POS 1/0/0 192.168.2.2/24
GE2/0/0 10.110.3.1/24
Loopback1 3.3.3.3/32
CE1 GE 1/0/0 10.110.3.2/24
GE 2/0/0 10.110.4.1/24

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a unicast routing protocol on the public network and enable the multicast function, ensuring normal multicast routing on the public network.

  2. Configure a VPN instance (VPN RED) enabled with the IPv4 address family on PE2; set the share-group address and address pool range of the switch-group for the VPN instance; create an MTunnel interface; bind the interface connecting PE2 to a CE1 to the VPN instance.

  3. Configure a unicast routing protocol on the public network and enable the multicast function in the VPN instance, ensuring normal multicast routing in the VPN instance.

  4. Configure a unicast routing protocol between a PE and a CE to ensure that the PE and the CE are routable.

  5. On PE2, bind the VPN instance to an MTunnel interface.

  6. Configure a Rendezvous Point (RP) to serve the multicast groups running the multicast VPN extranet service so that Receiver in VPN RED can receive multicast data from Source on the public network.

  7. Configure static routes between the VPN instance and Source and between the VPN instance and RP on the public network.

Data Preparation

To complete the configuration, you need the following data:

  • RD and RT of VPN RED: 300:1

  • Share-group address of VPN RED: 238.0.0.0

  • Address pool range of the switch-group in VPN RED: 226.1.1.0 255.255.255.240

Procedure

  1. Configure a unicast routing protocol on the public network and enable the multicast function, ensuring normal multicast routing on the public network.

    # Configure OSPF on the public network to ensure that devices on the public network are routable. Enable the global multicast function and enable the PIM function in the interface view, ensuring normal running of the public network.

    # Configure PE1.

    [PE1] multicast routing-enable
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.1 32
    [PE1-LoopBack1] pim sm
    [PE1-LoopBack1] quit
    [PE1] interface pos 1/0/0
    [PE1-Pos1/0/0] ip address 192.168.1.1 24
    [PE1-Pos1/0/0] pim sm
    [PE1-Pos1/0/0] quit
    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] ip address 192.168.3.1 24
    [PE1-GigabitEthernet2/0/0] pim sm
    [PE1-GigabitEthernet2/0/0] quit
    [PE1] ospf
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit

    # Configure P.

    [P] multicast routing-enable
    [P] interface pos 1/0/0
    [P-Pos1/0/0] ip address 192.168.1.2 24
    [P-Pos1/0/0] pim sm
    [P-Pos1/0/0] quit
    [P] interface pos 2/0/0
    [P-Pos2/0/0] ip address 192.168.2.1 24
    [P-Pos2/0/0] pim sm
    [P-Pos2/0/0] quit
    [P] ospf
    [P-ospf-1] area 0
    [P-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [P-ospf-1-area-0.0.0.0] quit
    [P-ospf-1] quit

    # Configure PE2.

    [PE2] multicast routing-enable
    [PE2] interface loopback 1
    [PE2-LoopBack1] ip address 3.3.3.3 32
    [PE2-LoopBack1] pim sm
    [PE2-LoopBack1] quit
    [PE2] interface pos 1/0/0
    [PE2-Pos1/0/0] ip address 192.168.2.2 24
    [PE2-Pos1/0/0] pim sm
    [PE2-Pos1/0/0] quit
    [PE2] ospf
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit

  2. Configure a VPN instance enabled with the IPv4 address family on PE2; set the share-group address and address pool range of the switch-group for the VPN instance; create an MTunnel interface; bind the interface connecting PE2 to the CE1 to the VPN instance.

    # Create VPN RED enabled with the IPv4 address family on PE2. Enable the global multicast function in VPN RED and set the share-group address and address pool range of the switch-group for VPN RED. Bind the share-group address to MTunnel 0 and bind GE 2/0/0 connecting PE2 to CE1 to VPN RED.

    [PE2] ip vpn-instance RED
    [PE2-vpn-instance-RED] ipv4-family
    [PE2-vpn-instance-RED-af-ipv4] route-distinguisher 200:1
    [PE2-vpn-instance-RED-af-ipv4] vpn-target 200:1 both
    [PE2-vpn-instance-RED-af-ipv4] multicast routing-enable
    [PE2-vpn-instance-RED-af-ipv4] multicast-domain share-group 238.0.0.0 binding mtunnel 1
    [PE2-vpn-instance-RED-af-ipv4] multicast-domain switch-group-pool 226.1.1.0 28
    [PE2-vpn-instance-RED-af-ipv4] quit
    [PE2-vpn-instance-RED] quit
    [PE2] interface gigabitethernet 2/0/0
    [PE2-GigabitEthernet2/0/0] ip binding vpn-instance RED
    [PE2-GigabitEthernet2/0/0] ip address 10.110.3.1 24
    [PE2-GigabitEthernet2/0/0] pim sm
    [PE2-GigabitEthernet2/0/0] quit

  3. Configure a unicast routing protocol on the public network and enable the multicast function in VPN RED, ensuring normal multicast routing.

    # Configure OSPF in VPN RED to ensure that devices in VPN RED are routable. Enable the global multicast function and enable the PIM function in the interface view, ensuring normal running of the multicast network in VPN RED.

    # Configure PE2.

    [PE2] ospf 2 vpn-instance RED
    [PE2-ospf-2] import-route direct
    [PE2-ospf-2] import-route static
    [PE2-ospf-2] area 0
    [PE2-ospf-2-area-0.0.0.0] network 10.110.3.0 0.0.0.255
    [PE2-ospf-2-area-0.0.0.0] quit
    [PE2-ospf-2] quit

    # Configure CE1.

    <Huawei> system-view
    [Huawei] sysname CE1
    [CE1] interface gigabitethernet 1/0/0
    [CE1-GigabitEthernet1/0/0] ip address 10.110.3.2 24
    [CE1-GigabitEthernet1/0/0] pim sm
    [CE1-GigabitEthernet1/0/0] quit
    [CE1] interface gigabitethernet 2/0/0
    [CE1-GigabitEthernet2/0/0] ip address 10.110.4.1 24
    [CE1-GigabitEthernet2/0/0] pim sm
    [CE1-GigabitEthernet2/0/0] quit
    [CE1] ospf 2
    [CE1-ospf-2] area 0
    [CE1-ospf-2-area-0.0.0.0] network 10.110.3.0 0.0.0.255
    [CE1-ospf-2-area-0.0.0.0] network 10.110.4.0 0.0.0.255
    [CE1-ospf-2-area-0.0.0.0] quit
    [CE1-ospf-2] quit

  4. Configure an IP addresses for the MTunnel interface.

    # On PE2, configure the address of the MTunnel interfaces as the address of loopback 1. The system automatically associates the MTunnel interface with VPN RED.

    # Configure PE2.

    [PE2] interface mtunnel 1
    [PE2-MTunnel1] ip address 3.3.3.3 32
    [PE2-MTunnel1] quit

  5. Configure an RP to serve the multicast groups running the multicast VPN extranet service.

    In the PIM view of PE1, P, PE2, and CE2 and the view of VPN RED on PE2, configure loopback 1 of PE1 as a static RP to serve the multicast groups running the multicast VPN extranet service.

    NOTE:

    Source VPN instances and receiver VPN instances support only static RPs. In addition, static RPs can be deployed only in source VPN instances.

    # Configure PE1.

    [PE1] pim
    [PE1-pim] static-rp 1.1.1.1
    [PE1-pim] quit

    # Configure P.

    [P] pim
    [P-pim] static-rp 1.1.1.1
    [P-pim] quit

    # Configure PE2.

    [PE2] pim
    [PE2-pim] static-rp 1.1.1.1
    [PE2-pim] quit
    [PE2] pim vpn-instance RED
    [PE2-pim-RED] static-rp 1.1.1.1
    [PE2-pim-RED] quit

    # Configure CE1.

    [CE1] pim
    [CE1-pim] static-rp 1.1.1.1
    [CE1-pim] quit

  6. Configure static routes between VPN RED and Source and between VPN RED and the RP on the public network.

    On PE2 and CE1, configure static routes between Source and the RP on the public network.

    # Configure PE2.

    [PE2] ip route-static vpn-instance RED 192.168.3.2 24 192.168.2.1 public
    [PE2] ip route-static vpn-instance RED 1.1.1.1 32 192.168.2.1 public

    # Configure CE1.

    [CE1] ip route-static 192.168.3.2 24 gigabitethernet1/0/0
    [CE1] ip route-static 1.1.1.1 255.255.255.255 gigabitethernet1/0/0 10.110.3.1

  7. Verify the configuration.

    By checking the configuration result, you can view that Receiver in VPN RED can receive multicast data from Source in the public network.

    # Run the display pim routing-table command on PE2 to check information about the PIM routing table. The following command output shows that the upstream of the Reverse Path Forwarding (RPF) route selected by the PIM entry corresponding to group 228.0.0.1 is the public network instance.

    <PE2> display pim vpn-instance RED routing-table extranet source-vpn-instance public
     VPN-Instance: RED
     Total 1 (*, G) entry; 1 (S, G) entry
    
     Total matched 1 (*, G) entry; 1 (S, G) entry
    
     (*, 228.0.0.1)
         RP: 1.1.1.1
         Protocol: pim-sm, Flag: WC
         UpTime: 00:01:00
         Upstream interface: MCAST_Extranet(public net)
             Upstream neighbor: 192.168.2.1
             RPF prime neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: pim-sm, UpTime: 00:01:00, Expires: 00:03:30
    
     (192.168.3.2, 228.0.0.1)
         RP: 1.1.1.1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:00:26
         Upstream interface: MCAST_Extranet(public net)
             Upstream neighbor: 192.168.2.1
             RPF prime neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: pim-sm, UpTime: 00:00:26, Expires: 00:03:05
    

    # Run the display multicast routing-table command on PE2 to check information about the multicast routing table. The following command output shows that the upstream of the RPF route selected by the multicast routing entry corresponding to group 228.0.0.1 is the public network instance.

    <PE2> display multicast vpn-instance RED routing-table extranet source-vpn-instance public
    Multicast routing table of VPN-Instance: RED
     Total 1 entry ,1 matched
    
     00001. (192.168.3.2, 228.0.0.1)
           Uptime: 00:00:23
           Upstream Interface: MCAST_Extranet(public net)
           List of 1 downstream interface
               1:  GigabitEthernet2/0/0  

    # Run the display multicast rpf-info command on PE2 to check the RPF routing information of source 192.168.3.2. The following command output shows that the upstream of the RPF route selected by the multicast routing entry corresponding to group 228.0.0.1 is the public network instance.

    <PE2> display multicast vpn-instance RED rpf-info 192.168.3.2 228.0.0.1
     VPN-Instance: RED
     RPF information about source 192.168.3.2 and group 228.0.0.1
         RPF interface: MCAST_Extranet     
         RPF Source VPN-Instance: public net
         Referenced route/mask: 192.168.3.0/24
         Referenced route type: unicast
         Route selection rule: preference-preferred
         Load splitting rule: disabled

    # After the preceding configurations, Receiver can receive multicast data from Source. Run the display pim routing-table command on CE1 to check information about the PIM routing table. The following command output shows that multicast data has reached CE1 and forwarded to Receiver.

    <CE1> display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 228.0.0.1)
         RP: 1.1.1.1
         Protocol: pim-sm, Flag: WC
         UpTime: 00:00:06
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 10.110.3.1
             RPF prime neighbor: 10.110.3.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: igmp, UpTime: 00:00:06, Expires: -
    
     (192.168.3.2, 228.0.0.1)
         RP: 1.1.1.1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:07:51
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 10.110.3.1
             RPF prime neighbor: 10.110.3.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: pim-sm, UpTime: 00:00:06, Expires: -
    

Configuration Files

  • Configuration file of PE1

    #
     sysname PE1
    #
     multicast routing-enable
    #
    interface POS1/0/0
     link-protocol ppp
     undo shutdown
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 1.1.1.1 0.0.0.0
    #
    pim 
     static-rp 1.1.1.1
    #
    return 
  • Configuration file of P

    #
     sysname P
    #
     multicast routing-enable
    #
    interface POS1/0/0
     link-protocol ppp
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface POS2/0/0
     link-protocol ppp
     undo shutdown
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     static-rp 1.1.1.1
    #
    return
  • Configuration file of PE2

    #
     sysname PE2
    #
     multicast routing-enable
    #
    ip vpn-instance RED
     ipv4-family
      route-distinguisher 300:1
      vpn-target 300:1 export-extcommunity
      vpn-target 300:1 import-extcommunity
      multicast routing-enable
      multicast-domain share-group 238.0.0.0 binding mtunnel 1
      multicast-domain switch-group-pool 226.1.1.0 255.255.255.240
    #
    interface POS1/0/0
     link-protocol ppp
     undo shutdown
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip binding vpn-instance RED
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
     pim sm
    #
    interface MTunnel1
     ip binding vpn-instance RED
     ip address 3.3.3.3 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 3.3.3.3 0.0.0.0
    #
    ospf 2 vpn-instance RED
     import-route direct
     import-route static
     area 0.0.0.0
      network 10.110.3.0 0.0.0.255
    #
    pim
     static-rp 1.1.1.1
    #
    pim vpn-instance RED
     static-rp 1.1.1.1
    #
     ip route-static vpn-instance RED 1.1.1.1 255.255.255.255 192.168.2.1 public
     ip route-static vpn-instance RED 192.168.3.0 255.255.255.0 192.168.2.1 public
    #
    return
    
  • Configuration file of CE1

    #
     sysname CE1
    #
     multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.110.3.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.110.4.1 255.255.255.0
     pim sm
    #
    ospf 2
     area 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 10.110.4.0 0.0.0.255
    #
    pim
     static-rp 1.1.1.1
    #
     ip route-static 1.1.1.1 255.255.255.255 GigabitEthernet1/0/0 10.110.3.1
     ip route-static 192.168.3.0 255.255.255.0 GigabitEthernet1/0/0 
    #
    return 
Translation
Download
Updated: 2019-06-12

Document ID: EDOC1000097181

Views: 21043

Downloads: 403

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next