No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Multicast

AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R007

This document describes the principles and configurations of IP multicast, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IGMP SSM Mapping

Example for Configuring IGMP SSM Mapping

Networking Requirements

In Figure 2-20, the network runs Protocol Independent Multicast Sparse Mode (PIM-SM) and uses the source-specific multicast (SSM) model to provide multicast services to group members. RouterD's interface GE1/0/0 connected to the network segment of Receiver runs IGMPv3. Receiver runs IGMPv2 and does not support IGMPv3; therefore, Receiver cannot specify desired multicast sources when it joins a group. The SSM group address range on the network is 232.1.1.0/24. Source1, Source2, and Source3 all send multicast data to the multicast groups in this range.

Receiver needs to obtain the SSM service and wants to receive only multicast data sent from Source1 and Source3.

Figure 2-20  Network diagram for IGMP SSM mapping configuration

Configuration Roadmap

Based on Receiver's requirements, you need configure IGMP SSM mapping on RouterD. The configuration roadmap is as follows:

  1. To ensure that data sent from the multicast sources can be correctly forwarded to the network segment of Receiver, configure a unicast routing protocol on the network to implement IP interworking. Multicast routing protocols are dependent on unicast routing protocols.

  2. To enable the routers to forward multicast data to Receiver, configure basic multicast functions on routers.

  3. To allow Receiver to receive data from specified multicast sources, enable IGMP SSM mapping and configure mapping rules on RouterD.

Procedure

  1. Configure IP addresses for interfaces and configure a unicast routing protocol on each Router.

    # Configure IP addresses and masks for router interfaces according to Figure 2-20. Configure Open Shortest Path First (OSPF) on the routers to implement IP interworking and dynamic route update. The configurations of RouterB, RouterC, and RouterD are similar to the configuration of RouterA, and are not mentioned here. See Configuration Files.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.10.1.2 24
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 192.168.1.1 24
    [RouterA-GigabitEthernet2/0/0] quit
    [RouterA] interface gigabitethernet 3/0/0
    [RouterA-GigabitEthernet3/0/0] ip address 192.168.4.2 24
    [RouterA-GigabitEthernet3/0/0] quit
    [RouterA] ospf
    [RouterA-ospf-1] area 0
    [RouterA-ospf-1-area-0.0.0.0] network 10.10.1.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] network 192.168.4.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] quit
    [RouterA-ospf-1] quit

  2. Enable IP multicast routing on all the routers and enable PIM-SM on all interfaces.

    # Enable IP multicast routing on RouterA and enable PIM-SM on all its interfaces. The configurations of RouterB, RouterC, and RouterD are similar to the configuration of RouterA, and are not mentioned here. See Configuration Files.

    [RouterA] multicast routing-enable
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] pim sm
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] pim sm
    [RouterA-GigabitEthernet2/0/0] quit
    [RouterA] interface gigabitethernet 3/0/0
    [RouterA-GigabitEthernet3/0/0] pim sm
    [RouterA-GigabitEthernet3/0/0] quit
    

  3. Enable IGMP on the interface of RouterD connected to Receiver and set the IGMP version to IGMPv3.

    # Enable IGMP on GE1/0/0 of RouterD and set the IGMP version to IGMPv3.

    [RouterD] interface gigabitethernet 1/0/0
    [RouterD-GigabitEthernet1/0/0] igmp enable
    [RouterD-GigabitEthernet1/0/0] igmp version 3
    [RouterD-GigabitEthernet1/0/0] quit
    

  4. Enable IGMP SSM mapping on the interface connected to Receiver.

    # Enable SSM mapping on GE1/0/0 of RouterD.

    [RouterD] interface gigabitethernet 1/0/0
    [RouterD-GigabitEthernet1/0/0] igmp ssm-mapping enable
    [RouterD-GigabitEthernet1/0/0] quit
    

  5. Configure the SSM group address range on all routers.

    # Set the SSM group address range to 232.1.1.0/24 on RouterA. The configurations of RouterB, RouterC, and RouterD are similar to the configuration of RouterA, and are not mentioned here. See Configuration Files.

    [RouterA] acl number 2000
    [RouterA-acl-basic-2000] rule permit source 232.1.1.0 0.0.0.255
    [RouterA-acl-basic-2000] quit
    [RouterA] pim
    [RouterA-pim] ssm-policy 2000
    [RouterA-pim] quit

  6. Configure IGMP SSM mapping rules on RouterD.

    # On RouterD, map the multicast groups in the range of 232.1.1.0/24 to Source1 and Source3.

    [RouterD] igmp
    [RouterD-igmp] ssm-mapping 232.1.1.0 24 10.10.1.1
    [RouterD-igmp] ssm-mapping 232.1.1.0 24 10.10.3.1
    [RouterD-igmp] quit
    

  7. Verify the configuration.

    # Run the display igmp ssm-mapping group command on RouterD to view the mappings between multicast sources and multicast groups.

    <RouterD> display igmp ssm-mapping group
    IGMP SSM-Mapping conversion table of VPN-Instance: public net
     Total 2 entries    2 entries matched
    
     00001. (10.10.1.1, 232.1.1.0/24)
    
     00002. (10.10.3.1, 232.1.1.0/24)
    
     Total 2 entries matched
    

    The preceding information shows that multicast groups in the range of 232.1.1.0/24 are mapped to Source1 and Source3.

    # Run the display igmp group ssm-mapping command on RouterD to view information about the group address used in SSM mapping. The command output is as follows:

    <RouterD> display igmp group ssm-mapping
    
    IGMP SSM mapping interface group report information of VPN-Instance: public net
    
     Limited entry of this VPN-Instance: - 
     GigabitEthernet1/0/0(10.10.4.2):
      Total 1 IGMP SSM-Mapping Group reported
       Group Address   Last Reporter   Uptime      Expires
       232.1.1.1       10.10.4.1       00:01:44    00:00:26
    
    

    The preceding information shows that Receiver has joined group 232.1.1.1.

    # Run the display pim routing-table command on RouterD to view the PIM-SM multicast routing table. The command output is as follows:

    <RouterD> display pim routing-table
    VPN-Instance: public net
     Total 2 (S, G) entries
    
     (10.10.1.1, 232.1.1.1)
         Protocol: pim-ssm, Flag: SG_RCVR
         UpTime: 00:19:40
         Upstream interface: GigabitEthernet3/0/0
             Upstream neighbor: 192.168.4.2
             RPF prime neighbor: 192.168.4.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: ssm-map, UpTime: 00:19:40, Expires: - 
    
     (10.10.3.1, 232.1.1.1)
         Protocol: pim-ssm, Flag: SG_RCVR
         UpTime: 00:19:40
         Upstream interface: GigabitEthernet2/0/0
             Upstream neighbor: 192.168.3.1
             RPF prime neighbor: 192.168.3.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: ssm-map, UpTime: 00:19:40, Expires: - 
    

    You can see that multicast sources 10.10.1.1 and 10.10.3.1 send data to group 232.1.1.1, and RouterD receives the multicast data from the two multicast sources through interfaces GE3/0/0 and GE2/0/0 respectively.

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface GigabitEthernet1/0/0
     ip address 10.10.1.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet3/0/0
     ip address 192.168.4.2 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.10.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #  
    return
  • RouterB configuration file

    #
     sysname RouterB
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface GigabitEthernet1/0/0
     ip address 10.10.2.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet3/0/0
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.10.2.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #  
    return
  • RouterC configuration file

    #
     sysname RouterC
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface GigabitEthernet1/0/0
     ip address 10.10.3.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet3/0/0
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.10.3.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #  
    return
  • RouterD configuration file

    #
     sysname RouterD
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface GigabitEthernet1/0/0
     ip address 10.10.4.2 255.255.255.0
     pim sm
     igmp enable
     igmp version 3
     igmp ssm-mapping enable
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet3/0/0
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.10.4 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    igmp
     ssm-mapping 232.1.1.0 255.255.255.0 10.10.1.1
     ssm-mapping 232.1.1.0 255.255.255.0 10.10.3.1
    #
    pim
     ssm-policy 2000
    #
    return
Translation
Download
Updated: 2019-06-12

Document ID: EDOC1000097181

Views: 21067

Downloads: 403

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next