No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Multicast

AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R007

This document describes the principles and configurations of IP multicast, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Inter-AS MVPN Option B

Example for Configuring Inter-AS MVPN Option B

Multicast services are deployed in an inter-AS MPLS VPN Option B scenario to transmit MVPN data on the public network or across ASs.

Networking Requirements

A carrier needs to provide multicast services for downstream Internet Service Providers (ISPs). Multicast Virtual Private Network (MVPN) is used to ensure network security and reliability. Inter-AS MVPN Option B is suitable when either of the following conditions is met:

  • Multicast services need to be deployed on a network where inter-AS VPN Option B has been configured.

  • Autonomous system boundary routers (ASBRs) on a network where no inter-AS VPN mode is configured can manage VPN routes, but there are not enough interfaces for each inter-AS VPN.

Inter-AS MVPN Option B supports only MDT-SAFI A-D of BGP A-D in the Source-Specific Multicast (SSM) model. Therefore, after configuring basic MVPN functions, configure MDT-SAFI A-D of BGP A-D.

On the network shown in Figure 7-25, Source1 is required to provide multicast services for PC1. Therefore, multicast networks between ASs 65001 and 65002 must interwork to forward MVPN services.

Figure 7-25  Networking for configuring inter-AS MVPN Option B

Table 7-6 lists the configurations of the interfaces shown in Figure 7-25.

Table 7-6  The router interface configurations

Device

Interface IP Address

Remarks

PE1

GE1: 10.1.1.2/24

Belongs to a VPN instance named VPN1.

GE2: 192.168.1.1/24

Belongs to the public network instance.

Loopback 1: 1.1.1.9/32

Belongs to the public network instance and establishes an IBGP peer relationship with the Loopback 1 interface of ASBR1 and an EBGP peer relationship with GE1 of CE1.

PE2

GE1: 192.168.2.2/24

Belongs to the public network instance.

GE2: 10.2.1.2/24

Belongs to a VPN instance named VPN1.

Loopback 1: 8.8.8.9/32

Belongs to the public network instance and establishes an IBGP peer relationship with the Loopback 1 interface of ASBR2 and an EBGP peer relationship with GE1 of CE1.

P1

GE1: 192.168.1.2/24

-

GE2: 172.16.2.2/24

-

Loopback 1: 2.2.2.9/32

-

P2

GE1: 172.16.1.2/24

-

GE2: 192.168.2.1/24

-

Loopback 1: 7.7.7.9/32

-

ASBR1

GE1: 172.16.2.1/24

Belongs to the public network instance.

GE2: 192.168.3.1/24

Belongs to the public network instance.

Loopback 1: 3.3.3.9/32

Belongs to the public network instance and establishes an IBGP peer relationship with the Loopback 1 interface of PE1 and an EBGP peer relationship with the Loopback 1 interface of ASBR2.

Loopback 2: 4.4.4.9/32

Belongs to the public network instance.

ASBR2

GE1: 192.168.3.2/24

Belongs to the public network instance.

GE2: 172.16.1.1/24

Belongs to the public network instance.

Loopback 1: 5.5.5.9/32

Belongs to the public network instance and establishes an IBGP peer relationship with the Loopback 1 interface of PE2 and an EBGP peer relationship with the Loopback 1 interface of ASBR1.

Loopback 2: 6.6.6.9/32

Belongs to the public network instance.

CE1

GE1: 10.1.1.1/24

Establishes an EBGP peer relationship with the GE1 interface of PE1.

GE2: 10.111.5.1/24

-

Loopback 1: 1.1.1.1/32

-

CE2

GE1: 10.2.1.1/24

Establishes an EBGP peer relationship with the GE2 interface of PE2.

GE2: 10.111.8.1/24

-

Loopback 1: 2.2.2.2/32

-

Source1

10.111.5.2/24

Is a multicast source of VPN1.

PC2

10.111.8.2/24

Is a multicast receiver of VPN1.

NOTE:

GE1 represents GigabitEthernet 1/0/0 and GE2 represents GigabitEthernet 2/0/0.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure inter-AS BGP/MPLS IP VPN Option B to ensure that the inter-AS VPN works properly and unicast routes are reachable.

  2. Configure basic PIM-SM functions to ensure that multicast runs properly in each AS.

  3. Configure the same share-group address, and Multicast Tunnel Interface (MTI) for the same VPN instance on PE1 and PE2.

  4. Enable PE1, PE2, ASBR1, and ASBR2 to exchange routing information with a specified peer or peer group in the MDT-SAFI address family view so that receivers can receive multicast data from the multicast source, and configure the MDT-SAFI A-D mode in the VPN instance IPv4 address family view of PE1 and PE2.

  5. Enable the PIM RPF Vector function (with RD information) in the VPN instance PIM view of PE1 and PE2 so that each P can find the next hop of the path to the multicast source and an inter-AS MDT can be established on the public network.

Data Preparation

To complete the configuration, you need the following data:

  • RD of VPN1 in AS 100 (100:1) and AS 200 (200:1)

  • VPN-target (1:1) of VPN1

  • Share-group address (232.1.1.1) of VPN1

Procedure

  1. Configure inter-AS BGP/MPLS IP VPN Option B to ensure that the inter-AS VPN works properly and unicast routes are reachable.

    Inter-AS VPN Option B has been deployed on the network in this example. For configuration details, see the section "Example for Configuring Inter-AS VPN Option B" in the BGP/MPLS IP VPN Configuration in the Huawei AR Series Access Routers Configuration Guide - VPN.

  2. Configure basic PIM-SM functions to ensure that multicast runs properly in each AS.

    For configuration details, see Example for Configuring Inter-AS MVPN Option A.

  3. Configure the same share-group address, and MTI for the same VPN instance on PE1 and PE2.

    For configuration details, see Example for Configuring Inter-AS MVPN Option B.

    As inter-AS MVPN Option B is configured to support only MDT-SAFI A-D of BGP A-D in the SSM model, the share-group address must be within the SSM group address range.

  4. Enable route exchange with a specific peer or peer group in the MDT-SAFI address family view of PE1, PE2, ASBR1, and ASBR2 so that receivers can receive multicast data from the multicast source, and configure the MDT-SAFI A-D mode in the VPN instance IPv4 address family view of PE1 and PE2.

    # Enable route exchange with a specific peer or peer group in the MDT-SAFI address family view of PE1 so that receivers can receive multicast data from the multicast source, and configure the MDT-SAFI A-D mode in the VPN instance IPv4 address family view of PE1.

    [PE1] bgp 100
    [PE1-bgp] ipv4-family mdt
    [PE1-bgp-af-mdt] peer 3.3.3.9 enable
    [PE1-bgp-af-mdt] quit
    [PE1-bgp] quit
    [PE1] ip vpn-instance VPN1
    [PE1-vpn-instance-VPN1] ipv4-family
    [PE1-vpn-instance-VPN1-af-ipv4] auto-discovery mdt
    [PE1-vpn-instance-VPN1-af-ipv4] quit
    [PE1-vpn-instance-VPN1] quit

    # Enable route exchange with a specific peer or peer group in the MDT-SAFI address family view of PE2 so that receivers can receive multicast data from the multicast source, and configure the MDT-SAFI A-D mode in the VPN instance IPv4 address family view of PE2.

    [PE2] bgp 200
    [PE2-bgp] ipv4-family mdt
    [PE2-bgp-af-mdt] peer 5.5.5.9 enable
    [PE2-bgp-af-mdt] quit
    [PE2-bgp] quit
    [PE2] ip vpn-instance VPN1
    [PE2-vpn-instance-VPN1] ipv4-family
    [PE2-vpn-instance-VPN1-af-ipv4] auto-discovery mdt
    [PE2-vpn-instance-VPN1-af-ipv4] quit
    [PE2-vpn-instance-VPN1] quit

    # Enable route exchange with a specific peer or peer group in the MDT-SAFI address family view of ASBR1 so that receivers can receive multicast data from the multicast source.

    [ASBR1] bgp 100
    [ASBR1-bgp] ipv4-family mdt
    [ASBR1-bgp-af-mdt] undo policy vpn-target
    [ASBR1-bgp-af-mdt] peer 1.1.1.9 enable
    [ASBR1-bgp-af-mdt] peer 1.1.1.9 next-hop-local
    [ASBR1-bgp-af-mdt] peer 192.168.3.2 enable
    [ASBR1-bgp-af-mdt] quit
    [ASBR1-bgp] quit

    # Enable route exchange with a specific peer or peer group in the MDT-SAFI address family view of ASBR2 so that receivers can receive multicast data from the multicast source.

    [ASBR2] bgp 200
    [ASBR2-bgp] ipv4-family mdt
    [ASBR2-bgp-af-mdt] undo policy vpn-target
    [ASBR2-bgp-af-mdt] peer 8.8.8.9 enable
    [ASBR2-bgp-af-mdt] peer 8.8.8.9 next-hop-local
    [ASBR2-bgp-af-mdt] peer 192.168.3.1 enable
    [ASBR2-bgp-af-mdt] quit
    [ASBR2-bgp] quit

  5. Enable the PIM RPF Vector function (with RD information) in the VPN instance PIM view of PE1 and PE2 so that each P can find the next hop of the path to the multicast source based on Vector and an inter-AS MDT can be established on the public network.

    # Enable the PIM RPF Vector function (with RD information) in the VPN instance PIM view of PE1 so that each P can find the next hop of the path to the multicast source based on Vector and an inter-AS MDT can be established on the public network.

    [PE1] pim vpn-instance VPN1
    [PE1-pim-VPN1] rpf-vector rd
    [PE1-pim-VPN1] quit

    # Enable the PIM RPF Vector function (with RD information) in the VPN instance PIM view of PE2 so that each P can find the next hop of the path to the multicast source based on Vector and an inter-AS MDT can be established on the public network.

    [PE2] pim vpn-instance VPN1
    [PE2-pim-VPN1] rpf-vector rd
    [PE2-pim-VPN1] quit

  6. Verify the configuration.

    Receivers can receive multicast data from the multicast source.

    # Run the igmp static-group command on CE2 to configure the static join function.

    [CE2] interface loopback 1
    [CE2-LoopBack1] igmp static-group 226.1.1.1 source 1.1.1.1

    # Run the display pim routing-table command on CE1 to view source/group information. The command output is as follows:

    [CE1] display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entries
    
     (1.1.1.1, 226.1.1.1)
         RP: NULL
         Protocol: pim-sm, Flag: SPT LOC
         UpTime: 00:00:07
         Upstream interface: LoopBack1
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: pim-sm, UpTime: 00:00:07, Expires: 00:03:23

    The preceding command output shows that Source1 can receive Join messages from PC1 that is configured to statically join the multicast group, indicating that inter-AS MVPN has been configured successfully.

    # Run the display pim routing-table rpf-vector command on ASBR1 to view the PIM routing table. The command output is as follows:

    [ASBR1] display pim routing-table rpf-vector
    VPN-Instance: public net
     Total 2 (S, G) entries
    
     Total matched 0 (*, G) entry; 2 (S, G) entries
    
     (1.1.1.9, 232.1.1.1)
         Protocol: pim-ssm, Flag:
         UpTime: 02:44:28
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 172.16.2.2
             RPF prime neighbor: 172.16.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: pim-ssm, UpTime: 02:44:28, Expires: 00:03:02
                 Total number of vectors: 1
                      1: vector: 100:1/192.168.3.1, neighbor: 192.168.3.2
     (8.8.8.9, 232.1.1.1)
         Protocol: pim-ssm, Flag:
         UpTime: 02:44:29
         Upstream interface: GigabitEthernet2/0/0
             RPF vector: 200:1/192.168.3.2         
             Upstream neighbor: 192.168.3.2
             RPF prime neighbor: 192.168.3.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: pim-ssm, UpTime: 02:44:29, Expires: 00:03:01
                 Total number of vectors: 1
                      1: vector: 100:1/3.3.3.9, neighbor: 172.16.2.2

    The preceding command output shows that a PIM-SSM MDT has been established and vectors of RPF routes are contained in the routing table.

    # Run the display pim vpn-instance VPN1 neighbor interface gigabitethernet1/0/0 command on PE1 to view the neighbors of a specific MTI of VPN1. The command output is as follows:

    [PE1] display pim vpn-instance VPN1 neighbor interface gigabitethernet1/0/0
    VPN-Instance: VPN1
    
     Total Number of Neighbors on this interface  = 1
    
     Neighbor        Interface           Uptime   Expires  Dr-Priority
     10.1.1.1        GE1/0/0             2d:01h   00:01:26 1            

    The preceding command output shows that the MTI has established neighbor relationships successfully.

    # Run the display multicast rpf-info 1.1.1.9 232.1.1.1 rd command on PE1 to view the RPF route and RPF vector of the (1.1.1.9, 232.1.1.1) entry. The command output is as follows:

    [PE1] display multicast rpf-info 1.1.1.9 232.1.1.1 rd
    VPN-Instance: public net
     RPF information about source 1.1.1.9 and group 232.1.1.1
         RPF interface: InLoopBack0
         Referenced route/mask: 1.1.1.9/32
         Referenced route type: unicast
         Route selection rule: preference-preferred
         Load splitting rule: disable
     RPF information about source 1.1.1.9 and group 232.1.1.1
         RPF interface: InLoopBack0
         Referenced route/mask: 1.1.1.9/32
         Referenced route type: unicast
         Route selection rule: preference-preferred
         Load splitting rule: disable
         RPF vector: 100:1/127.0.0.1 

Configuration Files

  • Configuration file of PE1

    #
    sysname PE1
    #
    multicast routing-enable
    #
    ip vpn-instance VPN1
     ipv4-family
      route-distinguisher 100:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
      multicast routing-enable
      multicast-domain share-group 232.1.1.1 binding mtunnel 0
      auto-discovery mdt
    #
    mpls lsr-id 1.1.1.9
    mpls
    #
    mpls ldp
    # 
    interface GigabitEthernet1/0/0
     undo shutdown
     ip binding vpn-instance VPN1
     ip address 10.1.1.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.1.1 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
     pim sm
    #
    interface MTunnel0
     ip binding vpn-instance VPN1
     ip address 1.1.1.9 255.255.255.255
    #
    bgp 100
     peer 3.3.3.9 as-number 100
     peer 3.3.3.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.9 enable
     #
     ipv4-family mdt
      policy vpn-target
      peer 3.3.3.9 enable
     #
     ipv4-family vpn-instance VPN1
      peer 10.1.1.1 as-number 65001
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 192.168.1.0 0.0.0.255
    #
    pim vpn-instance VPN1
     rpf-vector rd
    #
    return
  • Configuration file of PE2

    #
    sysname PE2
    #
    multicast routing-enable
    #
    ip vpn-instance VPN1
     ipv4-family
      route-distinguisher 200:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
      multicast routing-enable
      multicast-domain share-group 232.1.1.1 binding mtunnel 0
      auto-discovery mdt
    #
    mpls lsr-id 8.8.8.9
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.2.2 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip binding vpn-instance VPN1
     ip address 10.2.1.2 255.255.255.0
     pim sm
    # 
    interface LoopBack1
     ip address 8.8.8.9 255.255.255.255
     pim sm
    #
    interface MTunnel0
     ip binding vpn-instance VPN1
     ip address 8.8.8.9 255.255.255.255
    #
    bgp 200
     peer 5.5.5.9 as-number 200
     peer 5.5.5.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 5.5.5.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 5.5.5.9 enable
     #
     ipv4-family mdt
      policy vpn-target
      peer 5.5.5.9 enable
     #
     ipv4-family vpn-instance VPN1
      peer 10.2.1.1 as-number 65002
    #
    ospf 1
     area 0.0.0.0
      network 8.8.8.9 0.0.0.0
      network 192.168.2.0 0.0.0.255
    #
    pim vpn-instance VPN1
     rpf-vector rd
    #
    return 
    
  • Configuration file of P1

    #
    sysname P1
    #
    multicast routing-enable
    #
    mpls lsr-id 2.2.2.9
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 172.16.2.2 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 172.16.2.0 0.0.0.255
    #
    return
  • Configuration file of P2

    sysname P2
    #
    multicast routing-enable
    #
    mpls lsr-id 7.7.7.9
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 172.16.1.2 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.2.1 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 7.7.7.9 255.255.255.255
    #
    bgp 200
     #
     ipv4-family unicast
      undo synchronization
    #
    ospf 1
     area 0.0.0.0
      network 7.7.7.9 0.0.0.0
      network 172.16.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • Configuration file of ASBR1

    #
    sysname ASBR1
    #
    multicast routing-enable
    #
    mpls lsr-id 3.3.3.9
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 172.16.2.1 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.3.1 255.255.255.0
     pim sm
     mpls
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
     pim sm
    #
    interface LoopBack2
     ip address 4.4.4.9 255.255.255.255
     pim sm
    #
    bgp 100
     peer 1.1.1.9 as-number 100
     peer 1.1.1.9 connect-interface LoopBack1
     peer 192.168.3.2 as-number 200
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.9 enable
      peer 192.168.3.2 enable
     #
     ipv4-family vpnv4
      undo policy vpn-target
      apply-label per-nexthop
      peer 1.1.1.9 enable
      peer 1.1.1.9 next-hop-local
      peer 192.168.3.2 enable
     #
     ipv4-family mdt
      undo policy vpn-target
      peer 1.1.1.9 enable
      peer 1.1.1.9 next-hop-local
      peer 192.168.3.2 enable
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 4.4.4.9 0.0.0.0
      network 172.16.2.0 0.0.0.255
    #
    return
  • Configuration file of ASBR2

    #
    sysname ASBR2
    #
    multicast routing-enable
    #
    mpls lsr-id 5.5.5.9
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.3.2 255.255.255.0
     pim sm
     mpls
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 172.16.1.1 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 5.5.5.9 255.255.255.255
     pim sm
    #
    interface LoopBack2
     ip address 6.6.6.9 255.255.255.255
     pim sm
    #
    bgp 200
     peer 8.8.8.9 as-number 200
     peer 8.8.8.9 connect-interface LoopBack1
     peer 192.168.3.1 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      peer 8.8.8.9 enable
      peer 192.168.3.1 enable
     #
     ipv4-family vpnv4
      undo policy vpn-target
      apply-label per-nexthop
      peer 8.8.8.9 enable
      peer 8.8.8.9 next-hop-local
      peer 192.168.3.1 enable
     #
     ipv4-family mdt
      undo policy vpn-target
      peer 8.8.8.9 enable
      peer 8.8.8.9 next-hop-local
      peer 192.168.3.1 enable
    #
    ospf 1
     area 0.0.0.0
      network 5.5.5.9 0.0.0.0
      network 6.6.6.9 0.0.0.0
      network 172.16.1.0 0.0.0.255
    #
    return
  • Configuration file of CE1

    #
    sysname CE1
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.111.5.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    bgp 65001
     peer 10.1.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      network 1.1.1.1 255.255.255.255
      import-route direct
      peer 10.1.1.2 enable
    #
    return
  • Configuration file of CE2

    #
    sysname CE2
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.2.1.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.111.8.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    bgp 65002
     peer 10.2.1.2 as-number 200
     #
     ipv4-family unicast
      undo synchronization
      network 2.2.2.2 255.255.255.255
      import-route direct
      peer 10.2.1.2 enable
    #
    return
    
Translation
Download
Updated: 2019-06-12

Document ID: EDOC1000097181

Views: 21148

Downloads: 403

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next